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Chapter 1 Introduction

The Dominion KX Il is an enterprise-class, secure, KVM-over-IP switch that
provides multiple users with remote BIOS-level control of 8 to 64 servers.

KX Il comes with standard features such as DVI/HDMI/DisplayPort digital and
analog video, audio, virtual media, smart card/CAC, blade server support, and
mobile access.

Deploy KX lll individually, or with Raritan’s CommandCenter Secure Gateway

(CC-SG).

In This Chapter

Package CONTENTS ......uuiiiiiiec ettt e e et e e e e e e e e e e e e e e e sarraeeeeeeeeaannes 1
KX 1l Device Photos and FEATUIES ......ccccvvveieeeeeeeeiiteeeee e eeeeitree e e e e eeeearrereeeeeeennnns 1
KX Il Remote/Local Console Interfaces and User Station .......cceeeevvveevvereeeeeeinennns 5
QYA @ 11T 0 AN T o] [ToF= | 4 o 3 USSR 5
KX T ONINE HEIP 1.ttt et e e et e et e e e naaeee s 5

Package Contents

Each KX Ill ships as a fully-configured stand-alone product in a standard 1U or
2U form with 19" rackmount chassis.

e 1-KXIIl device

e 1-Quick Setup Guide

e 1-Rackmount kit

e 2-ACpower cords

e 1-Setof4rubber feet (for desktop use)

e 1-Application note

e 1-Warranty card

KX 11l Device Photos and Features

Hardware
e Integrated KVM-over-IP remote access
e 1U or 2U rack-mountable (brackets included)

e  Dual power supplies with failover; autoswitching power supply with power
failure warning

e  Support for the following CIMs:

=  For virtual media and Absolute Mouse Synchronization, use one of the
following CIMs:
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Chapter 1: Introduction

= D2CIM-VUSB

=  D2CIM-DVUSB

= D2CIM-DVUSB-DVI

= D2CIM-DVUSB-HDMI

=  D2CIM-DVUSB-DP
= Required for PS2 connection:

=  DCIM-PS2
DVI monitor support from the DVI local port
=  VGA support via a DVI to VGA converter
= DVl support via a standard DVI cable
Remote access and power management from an iPhone’ or iPad®

Support for tiering in which a base KX Ill device is used to access multiple
other tiered devices

Multiple user capacity (1/2/4/8 remote users; 1 local user)
UTP (Cat5/5e/6) server cabling

Dual Ethernet ports (10/100/1000 LAN) with failover or isolation mode
support

Field upgradeable

Local USB User port for in-rack access

=  USB Keyboard/mouse ports, or connect to a cellular modem

= One front and three back panel USB ports for supported USB devices
= Fully concurrent local and remote user access

= Local graphical user interface (GUI) for administration

Serial port to connect to an external telephone modem

Centralized access security

Integrated power control

LED indicators for dual power status, network activity, and remote user
status

Hardware Reset button

Software

Virtual media support in Windows*, Mac® and Linux® environments*
Absolute Mouse Synchronization*

*Note: Virtual media and Absolute Mouse Synchronization require use of a
D2CIM-VUSB, D2CIM-DVUSB, D2CIM-DVUSB-DVI, D2CIM-DVUSB-HDMI or
D2CIM-DVUSB-DP CIM.
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e Support for digital audio over USB

e Port scanning and thumbnail view of up to 32 targets within a configurable
scan set

e Web-based access and management
e Intuitive graphical user interface (GUI)
e  Support for dual port video output

e 256-bit encryption of complete KVM signal, including video and virtual
media

e LDAP, Active Directory®, RADIUS, or internal authentication and
authorization

e  DHCP or fixed IP addressing

e Smart card/CAC authentication

e SNMP, SNMPv3, SMTP, and Syslog management

e |Pv4 and IPv6 support

e Power control associated directly with servers to prevent mistakes

e Integration with Raritan's CommandCenter Secure Gateway (CC-SG)
management unit

e CCUnmanage feature to remove device from CC-SG control
e  Support of Raritan PDUs
e Support for remote IP access from the new Dominion KX IIl User Station

e Support for access to serial targets using the Dominion Serial Access
Module (DSAM)

Photos

Front View

uuuuuuuu

DKX3-832

Rear View - Features

Raritan. 3
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Hardware models vary. Newer 2020 models have moved the DVI port to the
bottom position.

Diagram key

OPVVO®OO

Dual Power AC 100V/240V

Dual 10/100/1000 Ethernet access

Local USB ports

DVI-D port

KVM ports for UTP Cabling (Cat5/5e/6)

Tier port for tiering devices

Modem port for external modems

Dominion Serial Access Module USB port
(optional)

Supported Number of Ports and Remote Users per Model

Model
KX3-864

KX3-832
KX3-808
KX3-464
KX3-432
KX3-416
KX3-232
KX3-216
KX3-132
KX3-116
KX3-108

Ports

64
32
8

64
32
16
32
16
32
16
8

Remote users

8
8
8
4
4
4
2
2
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KX 11l Remote/Local Console Interfaces and User Station

Use the Remote Console interface to configure and manage the KX Ill over a
network connection.

Use the Local Console interface to access the KX lll while at the rack.

See KX Ill Remote Console Interface (on page 16), KX Il Local Console - KX III
Administration Functions and KX Ill Local Console Interface (on page 24),
respectively.

The Dominion User Station provides an alternative interface for IP access to the
KX 1lI's target servers. See Dominion User Station (on page 144).

KVM Client Applications

KX Il works with -

e Active KVM Client (AKC) - Default client, Windows only. Microsoft .NET® 4.5
or above required to use KX Il with the Microsoft Windows’-based Active
KVM Client (AKC). See Active KVM Client (AKC) Help (on page 75)

e  Virtual KVM Client (VKC) -Java™ 1.8 is required to use the Java-based Virtual
KVM Client (VKC). Java 1.8.0_40 or higher is required to use the VKCS. Also
available in a Standalone version for the Chrome browser. Java is required.
See Virtual KVM Client (VKC and VKCs) Help (on page 35)

e HTML KVM Client (HKC) - Runs on Linux, Mac, and Windows without .NET,
in IE, Edge, Firefox, Chrome and Safari. No Java. Basic KVM features are
supported. See HTML KVM Client (HKC) (on page 78).

KX Il Online Help

Raritan.
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KX Il online help is considered your primary help resource.
KVM Client help is provided as part of KX Ill online help.

Online help is accompanied by the KX Il Quick Setup Guide, which is included
with your KX Il and can be found on the Support page of Raritan's website
(http://www.raritan.com/support/firmware-and-documentation).

The Support page also contains a PDF version of the end user help sections of
online help, and a PDF containing the KX IIl administrator help sections.

See the KX Il Release Notes for important information on the current release
before you begin using the KX 111

To use online help, Active Content must be enabled in your browser.


http://www.raritan.com/support/firmware-and-documentation

Chapter 2

Get Started Using KX IlI

This section walks you through high-level tasks to start using KX IlI.

In This Chapter

Install and Configure KX 1l .......ii et e 6
Default Login - Change the Password .........c.ccceccueeeeiciieecciiee e e 6
ATIOW POP-UPS 1oeeiiiiieieiiiieeeiiee e stee e ettt e e ae e e s tte e e e enta e e e saaaaesstseeeasnsaeeeeseneesnnseeean 6
Security Warnings and Validation MeSSages .......ccccueevivieeeeiiieeeeiieeessvieeesivee e 7
INStalling @ CertifiCate ...uuuii i e e 8
Converting a Binary Certificate to a Base64-Encoded DER Certificate (Optional)12
Logging INto KX Il oo, 14
Using a Smart Card at the Client COmMpPULer.......cccvvieiieiiiiiieeee e, 14
Login with a PKI Certificate in the BrowWSer .......cccceeeviieeeeiiiee e 15

Install and Configure KX IlI

If you have not already done so, install and configure KX 111

See the KX Il Quick Setup Guide that came with the KX Ill device or download it
from the Raritan Support website http://www.raritan.com/support.

Default Login - Change the Password

The KX Il device is shipped with the following default settings. You are forced
to change the password at first login. Up to 64 English alphanumeric and
special characters allowed.

e Username = admin
e Password=raritan
e |Paddress=192.168.0.192

Important: For backup and business continuity purposes, it is strongly
recommended you create a backup administrator username and password,
and keep that information in a secure location.

Allow Pop-Ups

Raritan.
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Regardless of the browser you are using, you must allow pop-ups in order to
launch the KX Il Remote Console.
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Security Warnings and Validation Messages

When logging in to KX IlI, security warnings and application validation messages

Raritan.
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may appear.

These include -

e Additional security warnings based on your browser and security settings

See Additional Security Warnings (on page 8)

e If you choose to use the Virtual KVM Client (VKC/VKCS), you may see Java™

security warnings and requests to validate KX III.

See Java Validation and Access Warning (on page 7) and Installing a

Certificate (on page 8).

Note! Use the HTML KVM Client (HKC) instead to avoid Java. The HKC is

Java-Free. See KVM Client Launching (on page 34).

Java Validation and Access Warning

When logging in to KX Ill using the Java-based client, Java prompts you to

validate KX Ill, and to allow access to the application.

Installing an SSL certificate in each KX Il device is recommended to reduce Java

warnings, and enhance security.

See SSL Certificates

Do you want to run this application?

Name: Raritan Favorite Devices Applet

({2

> Publisher: Raritan Americas, Inc.

Location: https://192.168.60. 137

This application will run with unrestricted access which may put your computer and personal
information at risk. Run this application only if you trust the location and publisher above.

@again for apps from the publisher@
6 More Information

Security Warning | 2 J

Do you want to Continue?
The connection te this website is untrusted.

Website: https://192. 168.60.137:443

Mote: The certificate is not valid and cannot be used to verify the identity of this website,

More Information
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Additional Security Warnings

Even after an SSL certificate is installed in the KX Ill, depending on your browser
and security settings, additional security warnings may be displayed when you
log in to KX III.

It is necessary to accept these warnings to launch the KX IIl Remote Console.
Reduce the number of warning messages during subsequent log ins by checking
the following options on the security and certificate warning messages:

e Inthe future, do not show this warning

e Always trust content from this publisher

Installing a Certificate

Security Warnieg 0

You may be prompted by the browser to accept and validate the KX IlI's SSL
certificate.

Depending on your browser and security settings, additional security warnings
may be displayed when you log in to KX Il1.

It is necessary to accept these warnings to launch the KX Il Remote Console.
For more information, see Security Warnings and Validation Messages (on
page 7).

Two sample methods on how to install an SSL Certificate in the browser are
provided here. Specific methods and steps depend on your browser and
operating system. See your browser and operating system help for details.

Example 1: Import the Certificate into the Browser

In this example, you import the Certificate into the browser.

===

[l The certificats used to identify the mebsits & not rusted. The reasons
are bsted below.
Proceed at your own risk. |

! More Information

| Doyou want te Continue?
The connextion to this website ks untrusted.

! : Wrebsite: hitps: {192, 168.61.20:443
Note:

| The certificate Authority that issued the certficate is not trusted.

f The appication is being donnloaded from & s other than the one
specified by the security certficate.
' - Dowrloading from "192.168.61.20"

- Expecting Raritan KM~

E ; | o—b"f“_wef_bﬁ‘?ﬁi

! Ths scplaton

Euture Java secusity pda .
contain the Permissions attrbute, Piease contact the Pubisher . Hoce Informaton

MNote to the Publisher: Seaurity festures to prevent
d F your Java appicaton wll cause this
‘applcation to be bloked in the fuure. See current Java

s Cootnm o e Comcl o documentaon sbout AR Mandest entries for the changes
need to be made.

that

Mote to users:For any questions, please contact the Fublsher
wha provided you with ths applcation,

Wit Jawa. com for more detads

Open a browser, then log in to KX I11.
Click More Information on the first warning.

Click View Certificate Details on the More Information dialog. You are
prompted to install the certificate. Follow the wizard steps.

Raritan.
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Note: If you are not prompted by the browser, manually select the Settings or
Options for your browser, and import the certificate. The following example

shows the IE > Tools > Internet Options method.

Raritan.
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Click the Content tab.
2. Click Certificates.

The Certificate Import Wizard opens and walks you through each step.

3. Click Finish on the last step of the Wizard.

Cinrtificate import Winsrd — |
Walcoma to the Certificats Impaort
Wizarel
£ T e e ins oy £ DACARES, CEWEGHIE WLt
; lta, and corbficate rewocation lets from pour dek ta 8
. cavthca e,
Intermet Opticers o 4 cerhcate, which & s ry 8 cerWcaNn suthonty, 5 |
B i ot g ety e Comar et
a r a2 e 2 1 bt e et
Gener | P Content | Comnectos o woe e
corifcates are et
Content T contrase, dhok Mest.
Ratings b you contral the Inserret cof
viewed on the. 3 '
Certcates
L certificates for encr voled cornedtel
A
| et | [ coce
BantoCeoepiete
Feme=— Il
L
| 3 o webpages ind sogoests mathes | Cortificane Import Wizarnd —
for ou. : - 3
i it v as | Completing the Certificate Import
[§==] Feedsand Web Shoes provide updated ‘Wizard
1 35| content from webates that can be
read in Intermet Explores snd other o w
f imschcoiy - The certhcate nd be rmperted after you ehek Frash.
i S
L= g ‘Yo baeve s e Foloming mettings: .
[T Acoratcaly desrrmesby
Contart Corttoatr
Fie tame C: s errfer Deskop'on

File to Import - Browse to locate the Certificate

Certificate Store - Select the location to store the Certificate

The Certificate is imported. Close the success message.

4. Click OK on the Internet Options dialog to apply the changes, then close

and

reopen the browser.
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Example 2: Add the KX Il to Trusted Sites and Import the Certificate

In this example, the KX lll's URL is added as a Trusted Site, and the Self Signed
Certificate is added as part of the process.

-

— - —— —

e S

Delete Browsing History...
InPrivate Erowsing

InPrivate Fittering
InPrivate Fiftesing Settings
Pop-up Bocker
SmartSereen Filter
Manage Add-oms

patiledity Vit
Compatibity Voew Settings

e to his Feed

n Freible

Feopen Last Browsing Sessicn

Ctrl+Shift+ Del
el Shift+ P

s @ CustomizeLinks (s, Scurce lmages & diTrack 3.0 251

............ oy

H et o e 3 v o change sty setings,

Vs i ekt P e Trusted sites (===

Jff Fou can s anv e mebattes fiom S 2one. All webaites 1
%y 5 zore il aw the s3ras securty ethrge.

i
' 2 ? A s webste 1 the Tone: |

WigE 1345 3651 O—Q—E |
g ot |

Cumtoem v, Crfadtire Vartrtes:

W N U R WN

Requre server verdicaton (htion:) for ol stes in S fove.

O

Open an IE browser, then select Tools > Internet Options to open the
Internet Options dialog

Click the Security tab.
Click on Trusted Sites.

Disable Protected Mode, and accept any warnings.
Click Sites to open the Trusted Sites dialog.

Enter the KX Il URL, then click Add.

Deselect server verification for the zone (if applicable).
Click Close.

Click OK on the Internet Options dialog to apply the changes, then close
and reopen the browser.
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Next, import the Certificate.

Mare Information
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Nobe: The certificate is not valid and cannot be used to verify the identity of this website,

This appiicaton wil be blodked in & future Java securily update
contan the Penmssions atirbute. Please contact the Publisher

JaR fle manifest does not
. one informaition

!j_! The certificate used to idenbfy the websits & not nusted. The reasors

are Ested below.
Prooeed at your own risk.

The certificats Authority that ssued ths certificate is not trusted.

The apphcation & beng dovenloaded from & ste other than the one:
spedified by the seourity cerbficate.
- Dowricading from "192. 168.51. 20

Hote to the Publisher: Seomty features to prevent
unautherized redistribubon of your Java application wil couse ths

[ corwve |[ cace |

1 fo be blocked in the future. See current Java
documertation sbout JAR Marifiest sntries for the dhanges that
need to be made,

Hote to users: For any questions, please contact the Publsher
wha provided you with this applcation,

Visit Java.com for more detads

0
L

1. Open an IE browser, then log in to KX III.

Click More Information on the first Java™ security warning.

Click View Certificate Details on the More Information dialog. You are

prompted to install the certificate. Follow the wizard steps.

For details see, Example 1: Import the Certificate into the Browser (on
page 8).
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Converting a Binary Certificate to a Base64-Encoded DER Certificate (Optional)

KX Il requires an SSL certificate in either Base64-Encoded DER format or PEM
format.

If you are using an SSL certificate in binary format, you cannot install it.

However, you can convert your binary SSL certificate.

v3

Oce7eles 17d8 45 fe 8fe5 ... r
shalRsA

shal

DigiCert Assured ID Root CA, ...
Thursday, November 09, 2006...
Sunday, November 09, 2031 7...
Diniert A A TN Rnnt C4

Edit Properties... | | CopytoFie... |
Learn more about certificate detais

(o ]

1. Locate the DEGHKVMOO0O1.cer binary file on your Windows machine.
Double-click on the DEGHKVMOO0O1.cer file to open its Certificate dialog.
2. Click the Detail tab.

12 Raritan.
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3. Click "Copy to File...".

Welcome to the Certificate Export
Wizard

This wizard helps you copy certificates, certificate trust
lists and certificate revocation lists from a certificate
store to your disk.

A certificate, which is issued by a certification authority, is
a confirmation of your identity and contains information
used to protect data or to establish secure network
connections. A certificate store is the system area where
certificates are kept.

To continue, dick Mext.

Certificates can be exported in a variety of fie formats.

Select the format you want to use:
() DER encoded binary X.509 (.CER)

() Cryptographic Message Syntax Standard - PKCS =7 Certificates (,P7E)
Indude all certificates in the certification path if possible

personal Information Exchange - PKCS =12 (.PFX)
Include all certificates in the certification path if possible
Delete the private key if the export is successful
Export all extended properties

Microsoft Serialized Certificate Store (.55T)

Learn more about certificate file formats

5. Select "Base-64 encoded X.509" in the second Wizard dialog.
6. Click Next to save the file as a Base-64 encoded X.509.

You can now install the certificate on your KX 111

13
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Logging In to KX llI

Log in to your KX lll Remote Console from any workstation with network
connectivity. See the Release Notes for supported browser versions.

Logging in and using KX Il requires you to allow pop-ups.

For information on security warnings and validation messages, and steps to
reduce or eliminate them, see Security Warnings and Validation Messages (on
page 7).

» To login via Remote Console:

1. Launch a supported web browser, and enter the IP address assigned to the
KX 1.

2. Adefault client is launched based on your PC and browser settings. See
KVM Clients (on page 34). You can also choose a client by entering the URL
directly. See KVM Client Launching (on page 34).

Enter your username and password, then click Login.

Accept the user agreement (if applicable). If security warnings appear, click
to accept.

Using a Smart Card at the Client Computer

When Client Certificate Authentication is enabled and configured, you can
access KX Il with a smart card at the card reader connected to your client
computer.

P To use a smart card at the at the client computer:
1. Insert the smart card into the reader.
2. Launch a browser and go to the KX Ill URL.

3. When prompted by the browser, enter the smart card PIN. If approved,
you will be logged in.

Raritan.
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If login fails, check the Audit log for failure information.

Windows Security

Smart Card

Please enter your authentication PIN.

Cancel

Login with a PKI Certificate in the Browser

When Client Certificate Authentication is enabled and configured, you can
access KX Il with a client certificate installed in your browser.

» To login with a PKI certificate in the browser:
Launch a browser and go to the KX III.

2. The browser presents a dialog to select the certificate for authentication.
Select the correct certificate, then click OK. If approved, you will be logged

in.

Select a certificate

Select a certificate to authenticate yourself to 192.168.61.140:443
Subject Issuer Serial

48942909-5667-4bc6-8cd4-40018b...  MS-Organization-Acc... D57AA9223B45ABB24...

Certificate information “ Cancel

Raritan. 15
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KX Il Interface and Navigation

The KX Il Remote Console and the KX Il Local Console are web-based graphical
user interfaces.

Use the Remote Console interface to configure and manage the KX Ill over a
network connection.

Use the Local Console interface to access the KX Il while at the rack.

Access targets from either the Remote or Local console from one of the
supported KVM clients.

If you have the Dominion User Station, you can also use it to access targets. See
Dominion User Station (on page 144).

In This Chapter

KX Il Remote Console INTEIfaCe ......coiiecviieiiee et 16
KX 111 Local Console Interface.....cccccvviiiiiiiiiiii 24

KX 11l Remote Console Interface
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The KX Il Remote Console is a browser-based graphical user interface that
allows you to log in to KVM target servers and serial targets connected to the
KX 11l and to remotely administer the KX III.

The KX Il Remote Console provides a network connection to your connected
KVM target servers. When you log into a KVM target server using the KX 111
Remote Console, a KVM Client window opens.

There are many similarities among the KX Il Local Console and the KX 111
Remote Console graphical user interfaces, and where there are differences,
they are noted in the user manual. The following options are available in the KX
Il Remote Console but not the KX Il Local Console:

e Virtual Media

e Favorites

e Backup/Restore

e  Firmware Upgrade

e  SSI Certificates

e Audio
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Port Access Page (Remote Console Display)

After a successful login, the Port Access page opens listing all ports along with
their status and availability.

Ports connected to KVM target servers (blades and standard servers) are
displayed in blue. Right-click on any of these ports to open the Port Action
menu. For more information, see Port Action Menu (on page 20).

If a KX Il port has no CIM connected or is connected to a CIM with no name, a
default port name of Dominion_Model Name_PortNumber is assigned to the
port. PortNumber is the number of the KX Ill physical port.

L]
Raritan BB o[ Ve i s iragomons  oevics seings secuy | aimsrre | Diagrosies |
.mmhmw" Home > Ports

Dominion® KX Il

Port Access
Time & Session: Click the individual port t II bl ti
May 12, 2020 180143 ick on the individual port name to see allowable operations.
0/ 2 Remote KVM channels currently in use.
User: admin
State: 56 sec idle
Your IP; 192.168.32.183 View By Group | View By Search | Set Scan |
Last L - May 11, 2020 17:18:16
ERILEGUE LT A, 4 No. Name Type Status Availability
1 Dominion_KX3_Port1 Not Available down idle
Device Information: .
Device Name: DominionKX3-232(G3)Pilot 2 > DominionKX-832(G3)Pilotd8-145 TierDevice up idle
IP Address: A
192 168 50 144 3 Vista Target Not Available down idle
192.168.60.219 4 DVM-DP Not Available down idle
Firmware: 3.6.9.5.3239
Device Model: DKX3-232 5 Dominion_KX3_Port> Not Available down idle
Network: LAN1 LAN2 6 Dominion_KX3_Port6 Not Available down idle
Powerin1: on
Powerln2- on 7 Dominion_KX3_Port7 Not Available down idle
ConfuredasiBa=S 8 Dominion_KX3_Port8 Not Available down idle
9 Dominion_KX3_Port9 Not Available down idle
Port States: B
6 Ports: up 10 Dominion_KX3_Port10 Not Available down idle
57 Ports: down 1 Dominion_KX3 Port11 Not Available down idle
63 Ports: idle
12 Dominion_KX3_Port12 Not Available down idle
13 Dominion_KX3_Port13 Not Available down idle
Connected Users: - -
admin (192.168.32.183) 14 Dominion_KX3_Port14 Not Available down idle
56 sec idle . . 5
15 Windows7Client Not Available down idle
1 16 KVMTarget-USBC Not Available down idle
Online Help
17 KVM_Switch_Port7 Dual-VM up idle

Four tabs are provided on the page allowing you to view by port, view by group,
view by search and scan ports. A fifth tab, View by Serial, is available when an
optional DSAM is connected.

You can sort by Port Number, Port Name, Status (Up and Down), and
Availability (Idle, Connected, Busy, Unavailable, and Connecting) by clicking on
the column heading.

Use the Set Scan tab to scan for up to 32 targets that are connected to the KX
Ill. See Scanning Ports - Remote Console (on page 147)

Raritan. 17

A brand of Klegrand’



Chapter 3: KX Il Interface and Navigation

Tiered Devices - Port Access Page

If you are using a tiered configuration in which a base KX lll device is used to
access multiple other tiered devices, the tiered devices are viewed on the Port
Access page by clicking on the Expand Arrow icon ® to the left of the tier
device name.

Blade Chassis - Port Access Page

The blade chassis is displayed in an expandable, hierarchical list on the Port
Access page, with the blade chassis at the root of the hierarchy and the
individual blades labeled and displayed below the root. Use the Expand Arrow
icon ® next to the root chassis to display the individual blades.

Note: To view the blade chassis in a hierarchal order, blade-chassis subtypes
must be configured for the blade server chassis.

Dual Port Video Groups - Port Access Page

Dual video port groups appear on the Port Access page as Dual Port types.

The primary and secondary ports that are a part of the port group appear on
the Port Access page as Dual Port(P) and Dual Port(S), respectively.

When you access a dual port video group from the remote client, you connect
to the primary port, which opens a KVM connection window to both the
primary and secondary ports of the dual port group.

Note: The dual video primary port is defined when the port group is created.

Note: You cannot remotely connect to the dual video port group by clicking on a
primary port unless two KVM channels are available. If two channels are not
available, the Connect link is not displayed.

Note: The Action menu is not displayed when you click on a secondary port in a
dual video port group.

Note: You cannot connect to the primary port and secondary port at the same
time from the Local Port.

View by Group Tab

The View by Group tab displays blade chassis, 'standard' port groups, and dual
video port groups. Click the Expand Arrow icon ™ next to a group to view the
ports assigned to the port group.

View By Port |MIRREIIGROUR| Virs: By Starch | Set Scan
& No. MHame
¥ WeliFGoup
X prman,

wr P pasendiary

» waT-dal vides

Raritan.

A brand of Olegrand’



Chapter 3: KX Il Interface and Navigation

View by Search Tab

The View by Search tab allows you to search by port name. The search feature
supports the use of an asterisk (*) as a wildcard, and full and partial names.

View by Serial Tab

The View By Serial tab is visible when a Dominion Serial Access Module (DSAM)
is connected by USB. Up to 4 serial targets can be connected to the DSAM by
USB.

' [ Power | Virtual Media | User Management | Device Settings | Security | Maintenance | Diag

Home > Parts

Port Access

Click on the individual port name to see allowable operations.
0/1 Remote KVM channels currently in use.

View By Port | View By Group | View By Search m
Status Availability

4 v DSAM4 Front DSAM up
1 DSAM4 Port 1 DCE up idle
42 DSAM4 Port 2 AUTO down idle
4.3 DSAM4 Port 3 AUTO down idle
4.4 DSAM4 Port 4 AUTO down idle

32 _'fRnws per Page

Set Scan Tab

The port scanning feature is accessed from the Set Scan tab on the Port Access
page. The feature allows you to define a set of KVM targets to be scanned.
Thumbnail views of the scanned targets are also available. Select a thumbnail
to open that target in its Virtual KVM Client window.

See Scanning Ports - Remote Console (on page 147) for more information.
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Port Action Menu
When you click a Port Name in the Port Access list, the Port Action menu
appears.

Choose the desired menu option for that port to execute it. Note that only
currently available options, depending on the port's status and availability, are
listed in the Port Action menu.

Home = Ports

Port Access

-
Click on the individual port name to see allowable operations. {
0/ 4 Remote KVM channels currently in use. r

View By Group | View By Search | Set Scan

1 HDMI Target i

3 [4JPO20540016] <

4 Windows XP SP3
Ll & oo —id T pg et re _f"'
T g
Connect

e Connect - Creates a new connection to the target server
For the KX lll Remote Console, a new KVM Client page appears.

For the KX Il Local Console, the display switches to the target server, and
switches away from the local user interface.

On the local port, the KX Il Local Console interface must be visible in order
to perform the switch.

Hot key switching is also available from the local port.

Note: This option is not available from the KX Il Remote Console for an
available port if all connections are busy.

Switch From

e  Switch From - Switches from an existing connection to the selected port
(KVM target server)
This menu item is available only for KVM targets, and only when a KVM
Client is opened.
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Note: This menu item is not available on the KX Il Local Console.

Home > Ports 1
Port Access }
+
Click on the individual port name to see allowable operations.
1/4 Remote KVM channels currently in use. }
4

Wiew By Port | View By Group | View By Search | 5et Scan

Switch From HDMI Target
Connect

(
}73 Low Cost DV [PQ20540016] . —
- .._’ .Dr’-\. qm v‘ #ﬁ r PR,

Disconnect
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Disconnect - Disconnects this port and closes the KVM Client page for this
target server

This menu item is available only when the port status is up and connected,
or up and busy.

Note: This menu item is not available on the KX Ill Local Console. The only
way to disconnect from the switched target in the Local Console is to use
the hot key.

Home = Ports

Port Access

1
o
Click on the individual port name to see allowable operatfons.?
1/ 4 Remote K\VM channels currently in use. N

Wiew By Port | View By Group | View By Search | 5et Scan

Dominion-KX2_Port? £

P e T I Py
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Power On

Power On - Powers on the target server through the associated outlet
This option is visible only when there are one or more power associations
to the target, and when the user has permission to operate this service.

Provided you have privileges to do so, you can manage power from the
Virtual KVM Client (VKC) and Active KVM Client (AKC) as well. See Power
Control Using VKC, VKCS, and AKC (on page 74)

Power Off

Power Off - Powers off the target server through the associated outlets

This option is visible only when there are one or more power associations
to the target, when the target power is on (port status is up), and when
user has permission to operate this service.

Provided you have privileges to do so, you can manage power from the
Virtual KVM Client (VKC) and Active KVM Client (AKC) as well. See Power
Control Using VKC, VKCS, and AKC (on page 74)

Power Cycle

Power Cycle - Power cycles the target server through the associated
outlets

This option is visible only when there are one or more power associations
to the target, and when the user has permission to operate this service.

Provided you have privileges to do so, you can manage power from the
Virtual KVM Client (VKC) and Active KVM Client (AKC) as well. See Power
Control Using VKC, VKCS, and AKC (on page 74)

DKX3-808 Fast Switching

DKX3-808 maintains the video connections to the servers, enabling faster
connections to servers and faster switching between channels.

Some Video Settings do not apply to DKX3-808 targets:

Automatic Color Calibration
Video Sensing: Best possible video mode/Quick sense video mode
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Left Panel
The left panel of the KX Ill interface contains the following information.

Note that some information is conditional - meaning it is displayed based on
your role, features being used and so on. Conditional information is noted here.

Information Description When displayed?

Time & Session The date and time the Always
current session started

User Username Always

State The current state of the Always
application, either idle or
active. If idle, the
application tracks and
displays the time the
session has been idle.

Your IP The IP address used to Always
access the KX 1l

Last Login The last login date and time Always

Under CC-SG The IP address of the CC-SG  When the KX Il is

Management device managing the KX Il being managed by
CC-SG

Device Information Information specific to the  Always

KX 11l you are using

Device Name Name assigned to the Always
device

IP Address The IP address of the KX 1ll  Always

Firmware Current version of firmware Always

Device Model Model of the KX IlI Always

Serial number Serial number of the KX Il Always

Network The name assigned to the Always

current network

Powerinl Status of the power 1 outlet Always
connection. Either on or off,
or Auto-detect off
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Information Description When displayed?

PowerIn2 Status of the power 2 outlet Always
connection. Either on or off,
or Auto-detect off

Configured As Base If you are using a tiering When the KX Il is part
or Configured As configuration, this indicates of a tiered
Tiered if the KX Ill you are configuration

accessing is the base device
or a tiered device.

Port States The statuses of the ports Always
being used by the KX IlI

Connected Users The users, identified by Always
their username and IP
address, who are currently
connected to the KX 111

Online Help Links to online help Always

Favorite Devices See Managing Favorites When enabled
(on page 152)

FIPS Mode FIPS Mode: EnabledSSL When FIPS is enabled
Certificate: FIPS Mode
Compliant

KX 11l Local Console Interface

There are many similarities among the KX Il Local Console and the KX 111
Remote Console graphical user interfaces. Where there are differences, they
are noted in the help.

For details on using the Local Console see KX Ill Local Console (on page 155).
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Virtual Media

In This Chapter
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Virtual Media File Server Setup (File Server ISO Images Only)

Overview
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All KX 11l models support virtual media. Virtual media extends KVM capabilities
by enabling target servers to remotely access media from a client PC and
network file servers.

With this feature, media mounted on client PCs and network file servers are
essentially "mounted virtually" by the target server. The target server can then
read from and write to that media as if it were physically connected to the
target server itself.

Each KX Ill comes equipped with virtual media to enable remote management
tasks using the widest variety of CD, DVD, USB, audio devices, internal and
remote drives, and images.

Virtual media sessions are secured using the strongest encryption offered by
the browser, typically 256 bit AES. Older browsers may only support 128 bit
AES.

HKC does not support all virtual media features. See HTML KVM Client (HKC)
for details
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Prerequisites for Using Virtual Media

KX 1l Virtual Media Prerequisites

e  For users requiring access to virtual media, the KX lll permissions must be
set to allow access to the relevant port, as well as virtual media access (VM
Access port permission) for the port. Port permissions are set at the
group-level.

e If you want to use PC-Share, Security Settings must also be enabled in
the Security Settings page. Optional

e A USB connection must exist between the device and the target server.

e  You must choose the correct USB connection settings for the KVM target
server you are connecting to.

Remote PC VM Prerequisites

e  Certain virtual media options require administrative privileges on the PC
(for example, drive redirection of complete drives).

Note: If you are using Windows, disable User Account Control or select Run
as Administrator when starting Internet Explorer. To do this, click the Start
Menu, locate IE, right-click and select Run as Administrator.

Target Server VM Prerequisites
e KVM target servers must support USB connected drives.

CIMs Required for Virtual Media

You must use one of the following CIMs is to use virtual media:
e D2CIM-VUSB

e D2CIM-DVUSB

e D2CIM-DVUSB-DVI

e D2CIM-DVUSB-HDMI

e D2CIM-DVUSB-DP

e D2CIM-VUSB-USBC

The black USB connector on the DVUSB CIMs are used for the keyboard and
mouse. The gray connector is used for virtual media.

For CIMs with two USB plugs, keep both connected to the device.

The device may not operate properly if both plugs are not connected to the
target server.
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Mounting Local Drives

This option mounts an entire drive, which means the entire disk drive is
mounted virtually onto the target server.

Use this option for hard drives and external drives only. It does not include
network drives, CD-ROM, or DVD-ROM drives.

Supported Tasks Via Virtual Media

Virtual media provides the ability to perform tasks remotely, such as:
e Transferring files

e Running diagnostics

e Installing or patching applications

e Complete installation of the operating system

Important: Once you are connected to a virtual media drive, do not change
mouse modes in the KVM client if you are performing file transfers, upgrades,
installations or other similar actions. Doing so may cause errors on the virtual
media drive or cause the virtual media drive to fail.

Supported Virtual Media Types

Raritan.
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The following virtual media types are supported for Windows*, Mac® and Linux”
clients when using AKC and VKC/VKCS.

e Internal and external hard drives

e Internal and USB-mounted CD and DVD drives
e USB mass storage devices

e  PChard drives

e |SO images (disk images)

o IMG files

o DMG files

e |S09660 is the standard supported. However, other ISO standards can be
used.

Note: Due to browser limitations, HKC supports a different set of virtual media
types.

27



28

Chapter 4: Virtual Media

Conditions when Read/Write is Not Available
Virtual media Read/Write is not available in the following situations:
e  For Linux"and Mac’ clients
e When the drive is write-protected
e  When the user does not have Read/Write permission:
= Port Permission Access is set to None or View

= Port Permission VM Access is set to Read-Only or Deny

Supported Virtual Media Operating Systems

The following client operating systems are supported:
e Windows " 10

e Windows’*7

e openSUSE 15

e Fedora’28

e RHEL 7.4

e (OSXSierra

The Active KVM Client (AKC) can be used to mount virtual media types but only
for Windows operating systems.

Number of Supported Virtual Media Drives

With the virtual media feature, you can mount up to two drives (of different
types) that are supported by the USB connection settings currently applied to
the target. These drives are accessible for the duration of the KVM session.

For example, you can mount a specific CD-ROM, use it, and then disconnect it
when you are done. The CD-ROM virtual media “channel” will remain open,
however, so that you can virtually mount another CD-ROM. These virtual media
“channels” remain open until the KVM session is closed as long as the USB
settings support it.

To use virtual media, connect/attach the media to the client or network file
server that you want to access from the target server.

This need not be the first step, but it must be done prior to attempting to
access this media.

Virtual Media

Access a Virtual Media Drive on a Client Computer

Important: Once you are connected to a virtual media drive, do not change
mouse modes in the KVM client if you are performing file transfers, upgrades,
installations or other similar actions. Doing so may cause errors on the virtual
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media drive or cause the virtual media drive to fail.

>

1.

2.

To access a virtual media drive on the client computer:

From the KVM client, choose Virtual Media > Connect Drive, or click the

Connect Drive... button D . The Map Virtual Media Drive dialog
appears.

Map Virtual Media Drive X

Select a local drive or image to mount onto the target server.

(®) Local Drive:
F: (Removable) v [ ] Read-Write

() Image File
Image Path

Cancel

Choose the drive from the Local Drive drop-down list.
If you want Read and Write capabilities, select the Read-Write checkbox.

This option is disabled for nonremovable drives. See the Conditions when
Read/Write is Not Available (on page 28) for more information.

When checked, you will be able to read or write to the connected USB disk.

WARNING: Enabling Read/Write access can be dangerous! Simultaneous
access to the same drive from more than one entity can result in data
corruption. If you do not require Write access, leave this option unselected.

Click OK. The media will be mounted on the target server virtually. You can
access the media just like any other drive.

Access a Virtual Media Image File

Use the "Image File" option to access a disk image of a removable disk.

>

Image file guidelines:

Image files created using dd on Linux (dd if=/dev/sdb of=disk.img) or
similar tools such as Win32Disklmager on Windows, or Mac Disk Utility are
supported.

Apple DMG files:
= DMG image files of a FAT32 USB drive are recognized on all OSs.
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=  DMG images files of a folder on a Mac Drive are recognized only on
Mac OS targets.

= |mage should be created via Mac Disk Utility using the following
settings: Encryption: None; Image format: read/write.

= Not supported: Encrypted or compressed dmg images, MacOS install
images, DMG files downloaded from the Apple support site.

To access a virtual media image file:

From the KVM client, choose Virtual Media > Connect Drive, or click the
Connect Drive... button . The Map Virtual Media Drive dialog appears.

Select the Image File option, then click Browse to find and select the .img
or .dmg file.

Click OK. The media will be mounted on the target server virtually.

Mounting CD-ROM/DVD-ROM/ISO Images
This option mounts CD-ROM, DVD-ROM, and ISO images.

Note: ISO9660 format is the standard supported. However, other CD-ROM
extensions may also work.

» To access a CD-ROM, DVD-ROM, or ISO image:

1.

From the KVM client, choose Virtual Media > Connect CD-ROM/ISO Image,

&
or click the Connect CD ROM/ISO button . The Map Virtual Media
CD/I1SO Image dialog appears.

For internal and external CD-ROM or DVD-ROM drives:
a. Choose the Local CD/DVD Drive option.

b. Choose the drive from the Local CD/DVD Drive drop-down list. All
available internal and external CD and DVD drive names will be
populated in the drop-down list.

c. Click OK.
For ISO images:

a. Choose the ISO Image option. Use this option when you want to
access a disk image of a CD, DVD, or hard drive. ISO format is the only
format supported.

b. Click Browse.

c. Navigate to the path containing the disk image you want to use and
click Open. The path is populated in the Image Path field.

d. Click OK.
For remote ISO images on a file server:

a. Choose the Remote Server ISO Image option.
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b. Choose Hostname and Image from the drop-down list. The file servers
and image paths available are those that you configured using the
Virtual Media Shared Images page. Only items you configured using
the Virtual Media Shared Images page will be in the drop-down list.

c. File Server Username - User name required for access to the file server.
The name can include the domain name such as mydomain/username.

d. File Server Password - Password required for access to the file server
(field is masked as you type).

e. Click OK.

The media will be mounted on the target server virtually. You can access
the media just like any other drive.

Note: If you are working with files on a Linux® target, use the Linux Sync
command after the files are copied using virtual media in order to view the
copied files. Files may not appear until a sync is performed.

Note: If you are using the Windows 7° operating system*, Removable Disk is not
displayed by default in the Window's My Computer folder when you mount a
Local CD/DVD Drive or Local or Remote ISO Image. To view the Local CD/DVD
Drive or Local or Remote ISO Image in this folder, select Tools > Folder Options >
View and deselect "Hide empty drives in the Computer folder".

Disconnect from Virtual Media Drives

»  To disconnect the virtual media drives:
e  For local drives, choose Virtual Media > Disconnect Drive.

e For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media >
Disconnect CD-ROM/ISO Image.

Note: In addition to disconnecting the virtual media using the Disconnect
command, simply closing the KVM connection closes the virtual media as well.

Virtual Media in a Linux Environment
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Active System Partitions
You cannot mount active system partitions from a Linux client.

Linux Ext3/4 drive partitions need to be unmounted via umount /dev/<device
label> prior to a making a virtual media connection.

Mapped Drives

Mapped drives from Linux clients are not locked when mounted onto
connected targets.
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Drive Partitions
The following drive partition limitations exist across operating systems:

e Windows’® and Mac targets are not able to read Linux formatted partitions
e Windows and Linux cannot read Mac formatted partitions
e Only Windows Fat partitions are supported by Linux

Root User Permission Requirement

Your virtual media connection can be closed if you mount a CD ROM from a
Linux client to a target and then unmount the CD ROM.

To avoid these issues, you must be a root user.

Connect Drive Permissions (Linux)

Linux users must have read-only permissions for the removable device they
wish to connect to the target. For /dev/sdb1 run the following as root user:

root@administrator-desktop:~# chmod 664 /dev/sdbl
root@administrator-desktop:~# 1ls -1 /dev/sdbl
brw-rw-r-- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl

The drive is then available to connect to the target.

Virtual Media in a Mac Environment

Active System Partition

You cannot use virtual media to mount active system partitions for a Mac
client.

Drive Partitions

The following drive partition limitations exist across operating systems:

e Windows’® and Mac targets are not able to read Linux formatted partitions
e  Windows cannot read Mac formatted partitions

e Windows FAT and NTFS are supported by Mac

e  Mac users must unmount any devices that are already mounted in order to
connect to a target server. Use >diskutil umount /dev/disk1s1 to unmount
the device and diskutil mount /dev/disk1s1 to remount it.
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Connect Drive Permissions (Mac)

For a device to be available to connect to a target from a Mac’ client, you must
have read-only permissions to the removable device, and also unmount the
drive after doing so.

For /dev/sdb1, run the following commands as root user:

root@administrator-desktop:~# chmod 664 /dev/sdbl
root@administrator-desktop:~# 1ls -1 /dev/sdbl
brw-rw-r-- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl
root@admistrator-desktop:~# diskutil umount /dev/sdbl

Virtual Media File Server Setup (File Server ISO Images Only)

This feature is only required when using virtual media to access file server 1ISO
images. 1ISO9660 format is the standard supported. However, other CD-ROM
extensions may also work.

Note: SMB/CIFS support is required on the file server.

Use the Remote Console File Server Setup page to designate the files server(s)
and image paths that you want to access using virtual media. File server ISO
images specified here are available for selection in the Remote Server ISO
Image Hostname and Image drop-down lists in the Map Virtual Media CD/ISO
Image dialog. See Mounting CD-ROM/DVD-ROM/ISO Images (on page 30).

» To designate file server ISO images for virtual media access:

1. Choose Virtual Media from the Remote Console. The File Server Setup
page opens.

2. Check the Selected checkbox for all media that you want accessible as
virtual media.

3. Enter information about the file server ISO images that you want to access:
= |P Address/Host Name - Host name or IP address of the file server.

= |mage Path - Full path name of the location of the ISO image. For
example, /sharename0/path0/image0.iso,
\sharename1\path1\image1l.iso, and so on.

Note: The host name cannot exceed 232 characters in length.

4. Click Save. All media specified here are now available for selection in the
Map Virtual Media CD/ISO Image dialog.
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KVM Client
HTML KVM Client

Active KVM Client

Virtual KVM Client

KVM Clients

KX Il can be accessed with a variety of KVM clients that support your individual
configuration.

e HKCis best for Linux and Mac users without Java.

e AKCis best for Windows Platforms, using Windows or Edge browsers.

e VKCis best for Linux and Mac users with Java.

Name Platforms Features
HKC = linux = Java-Free
= Mac = Supports most features
= Windows = See HTML KVM Client (HKC) (on
= HTML and Javascript page 78) for supported features
AKC =  Windows = Full-featured KVM Client
= Requires Microsoft .NET = Java-Free
VKC = Linux =  Full-featured KVM Client
= Mac = Requires Java

=  Windows

In This Chapter

KVM Client LAUNCHRING ... .viieiiiiie ettt e e s e e rae e e 34
Virtual KVM Client (VKC and VKCs) Help .....oeeiiiieecieececeee e 35
Active KVM Client (AKC) HEIP .ooeoeeieeeeee et 75
HTIML KVIME CHENT (HKC) vttt eeee e eeeseeseeseseesesesesseseeeeseeeesesesesseees 78

KVM Client Launching

KVM Client Name URL to Force Launch
HTML KVM Client - HKC <KX Il IP Address>/hkc
Java-Free

Active KVM Client -
Requires .NET

AKC <KX Il IP Address>/akc

Virtual KVM Client -

Requires Java

VKCs <KX 1l IP Address>/vkcs
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Virtual KVM Client (VKC and VKCs) Help

Raritan.

A brand of Klegrand’

Overview
There is one Virtual KVM Client for each target server connected.

Virtual KVM Client windows can be minimized, maximized, and moved around
your computer desktop.

IMPORTANT: Refreshing your browser closes the Virtual KVM Client
connection.

Recommended Minimum Virtual KVM Client (VKC) Requirements

It is recommended that the Virtual KVM Client (VKC) machines meet the
following minimum requirements.

e Client machine with either a -

= 'modern' dual-core CPU for a single connections, or

=  'modern' quad core CPU for two or more simultaneous connections
e 4GB of RAM

= VKC requires 50MB of RAM per connection

35



36

Chapter 5: KVM Clients

Virtual KVM Client Java Requirements

A supported Java version is required. Check the release notes for latest
supported version.

If Java is not installed, a prompt is displayed that the file cannot be opened,
with an option to search for the program.

Note: VKC cannot be launched from Safari, Edge, Chrome 45 or later, Firefox 42
or later. VKCS is recommended for these browsers.

P VKCS Launching:

For all browsers, the VKCS standalone application needs to be downloaded
everytime you use it.

e Chrome and Edge: The downloaded VKCS jnlp file must always be clicked at
bottom left corner of browser window to launch.

G HewTab 3 '\ New Tab %
C' | [1192.168.1.203/vkc ==

52 Apps  For quick access, place your bookmarks here on the bockmarks bar. Import bookmarks now..

Google

{=

& VkcStandaloneAppli. ﬁla b ¥ Show all downloads.
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e Internet Explorer: You must click Open at the bottom of the browser to
launch.

B start

X B — [m}
O 192.168.1.203 g = )

VkcStandAloneApplication (25),jnlp finished downloading. m View downloads X

Safari: Save the jnlp file locally. Hold down the Ctrl key when selecting to

open, then click Open in displayed prompt

Firefox: The current default setting in Firefox on Windows saves the file

and runs from the download. You can launch from the browser with this

setting: Tools>Options>Applications, then select "Jnlp File" in the Content

Type column, and change the Action from "Always ask" to "Use Java Web

Launcher".

When launched from the Firefox browser, an executable warning message

is displayed. There are two methods to suppress this:

= Launching via jnlp://<IP address>/vkcs

For details, go to:

https://superuser.com/questions/1441134/disable-firefoxs-open-executab

le-file-warning)

OR

= Add a new preference
"browser.download.skipConfirmLaunchExecutable" to about:config.

For details, go to https://support.mozilla.org/en-US/questions/1260307
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Proxy Server Configuration

When the use of a Proxy Server is required, a SOCKS proxy must also be
provided and configured on the remote client PC.

Note: If the installed proxy server is only capable of the HTTP proxy protocol,
you cannot connect.

>

1.

To configure the SOCKS proxy:

On the remote client PC, select Control Panel > Internet Options.

a.

On the Connections tab, click 'LAN settings'. The Local Area Network
(LAN) Settings dialog opens.

Select 'Use a proxy server for your LAN'.
Click Advanced. The Proxy Settings dialog opens.
Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

e.

Click OK at each dialog to apply the settings.

Next, configure the proxy settings for the Java” applets:

a.
b.

Select Control Panel > Java.

On the General tab, click Network Settings. The Network Settings
dialog opens.

Select "Use Proxy Server".
Click Advanced. The Advanced Network Settings dialog opens.
Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

Connect to a Target from Virtual KVM Client (VKC), Standalone VKC (VKCs), or
Active KVM Client (AKC)

Once you have logged on to the KX IIl Remote Console, access target servers via
the Virtual KVM Client (VKC), Standalone VKC (VKCs), or Active KVM Client

(AKC).

»  To connect to an available server:

1.

On the Port Access page, click on the port name of the target server you
want to connect to. The Port Action menu opens.
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2. Click Connect.

Home > Ports

Port Access

Click on the individual
0 /4 Remote KVM char

See Port Action Menu (on page 20) for details on additional available menu
options.

Configuring Connection Properties

Connection properties manage streaming video performance over remote
connections to target servers.

The properties are applied only to your connection - they do not impact the
connection of other users accessing the same target servers.

If you make changes to connection properties, they are retained by the client.
Access Connection Properties
P To access connection properties:

Click Connection > Properties, or click the Connection... icon to open the
Connection Properties dialog.

Connection USB Profile Keyboard Video Mouse Tools View Virtual Media Audio SmartCard Help

(@ h@EAD0 0B @E

Video Mode: Full Color 2

U

Moise Filter: 2

U
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Default Connection Property Settings - Optimized for Best Performance
The KX lll comes configured to provide optimal performance for the majority of
video streaming conditions.

Default connection settings are:

e Optimized for: Text Readability - video modes are designed to maximize
text readability.

This setting is ideal for general IT and computer applications, such as
performing server administration.

e Video Mode - defaults to Full Color 2.

Video frames transmit in high-quality, 24-bit color. This setting is suitable
where a high-speed LAN is used.

e Noise Filter - defaults to 2.
The noise filter setting does not often need to be changed.

Click Reset on the Connection Properties dialog at any time to return to the
default settings.

Tip: Use the Connection Information dialog to monitor the connection in
real-time. See Access and Copy Connection Information

Connection Info X
Item Description Data
1 Device Name DominionkX3-232(G3)Pilot
2 IP Address 192,168.59.144
3 Paort 443
4 DataIn 9,94 Kbitfs
5 Data Out 1.17 Kbitfs
e FPS 18
7 Ava. FPS 13.33 (9 Sec.)
3 Connect Time 00:00:14
9 Resolution 1280 x 1024
10 Refresh Rate 60 Hz
11 Protocol Version 01.31
Close

Optimize for: Selections
Text Readability

Text Readability is designed to provide video modes with lower color depth but
text remains readable. Greyscale modes are even available when applying
lower bandwidth settings.

This setting is ideal when working with computer GUIs, such as server
administration.

When working in full color video modes, a slight contrast boost is provided, and
text is sharper.

In lower quality video modes, bandwidth is decreased at the expense of
accuracy.
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Color Accuracy

When Color Accuracy is selected, all video modes are rendered in full 24-bit
color with more compression artifacts.

This setting applies to viewing video streams such as movies or other broadcast
streams.

In lower quality video modes, sharpness of fine detail, such as text, is sacrificed.

Video Mode

The Video Mode slider controls each video frame's encoding, affecting video
quality, frame rate and bandwidth.

Connection Properti

Optimize for: :TextReadabiIitg-I v:

Video Mode: Full Color 2

U

Best Least
Quality Noise Filter: 2 Bandwidth

U
‘I
[OK H Cancel H Apply ]I
: —

In general, moving the slider to the left results in higher quality at the cost of
higher bandwidth and, in some cases, lower frame rate.

Moving the slider to the right enables stronger compression, reducing the
bandwidth per frame, but video quality is reduced.

In situations where system bandwidth is a limiting factor, moving the video
mode slider to the right can result in higher frame rates.

When Text Readability is selected as the Optimized setting, the four rightmost
modes provide reduced color resolution or no color at all.

These modes are appropriate for administration work where text and GUI
elements take priority, and bandwidth is at a premium.

Click Reset on the Connection Properties dialog at any time to return to the
default settings.
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Noise Filter

Unless there is a specific need to do so, do not change the noise filter
setting. The default setting is designed to work well in most situations.

The Noise Filter controls how much interframe noise is absorbed by the KX
1.

Connection Properti

Optimize for: :TextReadabiIitg-I v:

Video Mode: Full Color 2

U

Best Least
Quality Noise Filter: 2 Bandwidth

U
‘I
[OK H Cancel H Apply ]I
: —

Moving the Noise Filter slider to the left lowers the filter threshold, resulting in
higher dynamic video quality. However, more noise is likely to come through,
resulting in higher bandwidth and lower frame rates.

Moving the slider to the right raises the threshold, allows less noise and less
bandwidth is used. Video artifacts may be increased.

Moving the noise filter to the right may be useful when accessing a computer
GUI over severely bandwidth-limited connections.

Click Reset on the Connection Properties dialog at any time to return to the
default settings.

Connection Information

Open the Connection Information dialog for real-time connection information
on your current connection, and copy the information from the dialog as
needed.

See Configuring Connection Properties (on page 39)

» To open connection info:

1. Click Connection > Info.
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Note: Clicking Copy to Clipboard copies the information for pasting.

Connection Info

X

Item Description

Device Name
IP Address
Part

Data In

Data Out
FPS

Avg, FPS
Connect Time
Resolution
Refresh Rate
Protocol Version

[T =T T - TR ) R N R T =y

1

Data

DominionkX3-232(G3)Pilot
192,168.59.144
443

9,94 Kbitfs

1.17 Kbitfs

18

13.33 (9 Sec.)
00:00:14

1280 x 1024

60 Hz

01.31

Close

»  Current connection information:

e Name of the KX III

e |P address of the KX 11l
e Port-The KVM communication TCP/IP port used to access KX IlI.

e Data In/Second - Data rate received from the KX Il

e Data Out/Second - Data rate sent to the KX IIl.

e Connect Time - The duration of the current connection.

e FPS-Video frames per second transmitted received from the KX III.

e Average FPS - Average video frames per second.

e Resolution - The target server horizontal and vertical resolution.

e Refresh Rate - Refresh rate of the target server.

e  Protocol Version - Communications protocol version.
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USB Profiles
Select a USB profile that best applies to the KVM target server.

For example, if the server is running Windows® operating system, it would be
best to use the Generic profile.

Or, to change settings in the BIOS menu or boot from a virtual media drive,
depending on the target server model, a BIOS profile may be more appropriate.

P> To set a USB profile for a target server:

e Choose USB Profile, then choose Generic, or choose Other Profiles to
select from a menu.

Connection | USBE Profile | Keyboard Video Mouse Tools View Virtual Media Audio SmartCard Power Control Help
% % _0_ Generic h'\‘-‘) (™| %
Other Profiles [} g Linux
Help on USB Profiles Mac OS-X (10.4.9 and later)
HP Proliant DL360/DL380 G4 (Windows 2003 Server Installation)
BIOS IEM Thinkcentre Lenovo
RUBY Industrial Mainboard (AwardBIOS)
HP Proliant DL360/DL380 G4 (HP SmartStart CD)
BIOS Dell PowerEdge Keyboard and Mouse Only
Supermicra Mainboard (Phoenix AwardBIOS)
SuSE Linux 9.2
BIOS Mac
BIOS Lenovo ThinkPad Té1 and X61
BIOS HP Compaq DCT100/DCT600
Use Full Speed for Virtual Media CIM
BIOS Generic
Troubleshooting 1

Troubleshooting 2

Troubleshooting 3

BIOS HP Proliant DL145

BIOS Dell PowerEdge 1950,/2950/2970/6950/R200
BIOS Dell Optiplex Keyboard and Mouse Only
BIOS Asus PACE00 Matherboard

IBM BladeCenter H with AMM

Use Full Speed for Keyboard and Mouse USE
BIOS HP Proliant DL385 G7

BIOS Dell Optiplex 790 Keyboard Only

BIOS Dell Optiplex 790

Mac USB-C

Target server may be powered off or in sleep mode

»  To view details on USB profiles:
e Choose USB Profile > Help on USB Profiles.
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Keyboard

Send Ctrl+Alt+Del Macro

Due to its frequent use, a Ctrl+Alt+Delete macro is preprogrammed.

Selecting Keyboard > Send Ctrl+Alt+Del, or clicking on the Ctrl+Alt+Delete

button EE in the toolbar sends this key sequence to the server or to the
KVM switch to which you are currently connected.

In contrast, if you were to physically press the Ctrl+Alt+Del keys, the command
would first be intercepted by your own PC due to the structure of the Windows
operating system, instead of sending the key sequence to the target server as
intended.

Send LeftAlt+Tab (Switch Between Open Windows on a Target Server)

Select Keyboard > Send LeftAlt + Tab to switch between open windows on the
target server.

Setting CIM Keyboard/Mouse Options

»  To access the DCIM-USBG2 setup menu:

Put the mouse focus on a window such as Note Pad (Windows® operating
system) or an equivalent.

2. Select Set CIM Keyboard/Mouse options. This is the equivalent of sending
the Left-Control and Num Lock to the target. The CIM setup menu options
are then displayed.

Set the language and mouse settings.

Exit the menu to return to normal CIM functionality.

Send Text to Target

»  To use the Send Text to Target function for the macro:

Click the Keyboard > Send Text to Target. The Send Text to Target dialog
appears.

2. Enter the text you want sent to the target.

Note: Non-English characters are not supported by the Send Text to Target
function.

3. Ifthe target uses a US/International keyboard layout, select the "Target
system is set to the US/International keyboard layout" checkbox.

4. Click OK.
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Keyboard Macros

Keyboard macros ensure that keystroke combinations intended for the target
server are sent to and interpreted only by the target server. Otherwise, they
might be interpreted by your client PC.

Macros are stored on the client PC and are PC-specific. If you use another PC,
you cannot see your macros.

In addition, if another person uses your PC and logs in under a different name,
that user will see your macros since they are computer-wide.

Build a New Macro

»  To build a macro:

1.
2.
3.

Click Keyboard > Keyboard Macros. The Keyboard Macros dialog appears.
Click Add. The Add Keyboard Macro dialog appears.

Type a name for the macro in the Keyboard Macro Name field. This name
appears in the Keyboard menu after it is created.

From the Hot-Key Combination field, select a keyboard combination from
the drop-down list. This allows you to execute the macro with a predefined
keystroke. Optional

In the Keys to Press drop-down list, select each key you would like to use
to emulate the keystrokes that is used to perform the command. Select the
keys in the order by which they are to be pressed. After each selection,
select Add Key. As each key is selected, it appears in the Macro Sequence
field and a Release Key command is automatically added after each
selection.

For example, create a macro to close a window by selecting Left Ctrl + Esc.
This appears in the Macro Sequence box as follows:

Press Left Alt
Press F4

Esc

Release F4

Esc

Release Left Alt

Review the Macro Sequence field to be sure the macro sequence is defined
correctly.

a. Toremove a step in the sequence, select it and click Remove.

b. To change the order of steps in the sequence, click the step and then
click the up or down arrow buttons to reorder them as needed.

Click OK to save the macro. Click Clear to clear all field and start over.
When you click OK, the Keyboard Macros dialog appears and lists the new
keyboard macro.
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Click Close to close the Keyboard Macros dialog. The macro now appears
on the Keyboard menu in the application.

Select the new macro on the menu to run it or use the keystrokes you
assigned to the macro.

Importing and Exporting Macros

Macros created in VKC cannot be used in AKC or vice versa. Macros created on
HKC are only compatible with HKC, and cannot be used on AKC or VKC. Likewise,
macros created on VKC or AKC cannot be used on HKC.

Import Macros

» To import macros:

1. Choose Keyboard > Import Keyboard Macros to open the Import Macros
dialog. Browse to the folder location of the macro file.

2. Click on the macro file and click Open to import the macro.

a. Iftoo many macros are found in the file, an error message is displayed
and the import terminates once OK is selected.

b. If the import fails, an error dialog appears and a message regarding
why the import failed is displayed. Select OK to continue the import
without importing the macros that cannot be imported.

3. Select the macros to be imported by checking their corresponding
checkbox or using the Select All or Deselect All options.
4. Click OK to begin the import.

a. Ifaduplicate macro is found, the Import Macros dialog appears. Do
one of the following:

Click Yes to replace the existing macro with the imported version.

Click Yes to All to replace the currently selected and any other
duplicate macros that are found.

Click No to keep the original macro and proceed to the next macro

Click No to All keep the original macro and proceed to the next
macro. Any other duplicates that are found are skipped as well.

Click Cancel to stop the import.

Alternatively, click Rename to rename the macro and import it. If
Rename is selected, the Rename Macro dialog appears. Enter a
new name for the macro in the field and click OK. The dialog
closes and the process proceeds. If the name that is entered is a
duplicate of a macro, an alert appears and you are required to
enter another name for the macro.

b. If during the import process the number of allowed, imported macros
is exceeded, a dialog appears. Click OK to attempt to continue
importing macros or click Cancel to stop the import process.
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The macros are then imported. If a macro is imported that contains a hot key
that already exists, the hot key for the imported macro is discarded.
Export Macros

1. Choose Tools > Export Macros to open the Select Keyboard Macros to
Export dialog.

Close Window
Deselect Al

2. Select the macros to be exported by checking their corresponding
checkbox or using the Select All or Deselect All options.

3. Click OK. An "Export Keyboard Macros to" dialog is displayed. Locate and
select the macro file. By default, the macro exists on your desktop.

4. Select the folder to save the macro file to, enter a name for the file and
click Save. If the macro already exists, you receive an alert message.

5. Select Yes to overwrite the existing macro or No to close the alert without
overwriting the macro.

Video Properties

Refreshing the Screen

The Refresh Screen command forces a refresh of the video screen. Video
settings can be refreshed automatically in several ways:

e The Refresh Screen command forces a refresh of the video screen.

e The Auto-sense Video Settings command automatically detects the target
server's video settings.

e The Calibrate Color command calibrates the video to enhance the colors
being displayed.

In addition, you can manually adjust the settings using the Video Settings
command.

» To refresh the video settings, do one of the following:
ic]
e Choose Video > Refresh Screen, or click the Refresh Screen button ==
in the toolbar.
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Auto-Sense Video Settings

The Auto-sense Video Settings command forces a re-sensing of the video
settings (resolution, refresh rate) and redraws the video screen.

» To automatically detect the video settings:
e Choose Video > Auto-sense Video Settings, or click the Auto-Sense Video

[

Settings button == in the toolbar.

A message stating that the auto adjustment is in progress appears.

Calibrating Color

Use the Calibrate Color command to optimize the color levels (hue, brightness,
saturation) of the transmitted video images.

The color settings are on a target server-basis.

Note: When color is successfully calibrated, the values are cached and reused
each time you switch to the target. Changes to the brightness and contrast in
Video Settings are not cached. Changing resolution resets the video to the
cached values again. You can clear the cached values in Video > Clear Video
Settings Cache. See Clear Video Settings Cache (on page 49).

»  To calibrate the color:

e Choose Video > Calibrate Color, or click the Calibrate Color button @
in the toolbar.

The target device screen updates its color calibration.

Clear Video Settings Cache

You can clear the video settings cache to delete old settings that do not apply
anymore, such as when a target server is replaced. When you clear the video
settings cache, the server automatically does a video auto-sense and color
calibration. The new values are cached and reused when the target is accessed
again.

P To clear the video settings cache:
e Choose Video > Clear Video Settings Cache in the toolbar.

Adjusting Video Settings

Use the Video Settings command to manually adjust the video settings.

P To change the video settings:

1. Choose Video > Video Settings to open the Video Settings dialog.
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2. Adjust the following settings as required. As you adjust the settings the
effects are immediately visible:

a.

PLL Settings

Clock - Controls how quickly video pixels are displayed across the video
screen. Changes made to clock settings cause the video image to
stretch or shrink horizontally. Odd number settings are recommended.
Under most circumstances, this setting should not be changed because
the autodetect is usually quite accurate.

Phase - Phase values range from 0 to 31 and will wrap around. Stop at
the phase value that produces the best video image for the active
target server.

Brightness: Use this setting to adjust the brightness of the target
server display.

Brightness Red - Controls the brightness of the target server display for
the red signal.

Brightness Green - Controls the brightness of the green signal.
Brightness Blue - Controls the brightness of the blue signal.
Contrast Red - Controls the red signal contrast.

Contrast Green - Controls the green signal.

Contrast Blue - Controls the blue signal.

If the video image looks extremely blurry or unfocused, the settings for
clock and phase can be adjusted until a better image appears on the
active target server.

Warning: Exercise caution when changing the Clock and Phase settings.
Doing so may result in lost or distorted video and you may not be able to
return to the previous state. Contact Technical Support before making any
changes.

d.

Horizontal Offset - Controls the horizontal positioning of the target
server display on your monitor.

Vertical Offset - Controls the vertical positioning of the target server
display on your monitor.

Select Automatic Color Calibration to enable this feature.

Select the video sensing mode.

Best possible video mode

The device will perform the full Auto Sense process when switching
targets or target resolutions. Selecting this option calibrates the video
for the best image quality.

Quick sense video mode

With this option, the device will use a quick video Auto Sense in order
to show the target's video sooner. This option is especially useful for
entering a target server's BIOS configuration right after a reboot.
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Click OK to apply the settings and close the dialog. Click Apply to apply the

settings without closing the dialog.

Note: Some Sun background screens, such as screens with very dark borders,

may not center precisely on certain Sun servers. Use a different background or
place a lighter colored icon in the upper left corner of the screen.

Video Settings

PLL Settings
Clock: 1,312 1026 { {1812
Phase: 1] o 31

Color Settings
Brightness Red: o o [} 127
Brightness Green: 0 o I} 127
Brightness Blue: = o {} 127
Contrast Red: CEIES i 127
Contrast Green: 87> 0 I} 127

Video Sensing

Contrast Blue: st o - {} 127
Horizontal Offset: 265
Vertical Offset: 31

Automatic Color Calibration

(@) Best possible video mode

() Quick sense video mode

Screenshot from Target Command (Target Screenshot)

Take a screenshot of a target server using the Screenshot from Target server

command. If needed, save this screenshot to a file location of your choosing as
a bitmap, JPEG or PNG file.

>

1.

To take a screenshot of the target server:

Select Video > Screenshot from Target, or click the Target Screenshot

button ﬂ on the toolbar.

In the Save dialog, choose the location to save the file, name the file, and

select a file format from the 'Files of type' drop-down.

Click Save to save the screenshot.
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Mouse Options
You can operate in either single mouse mode or dual mouse mode.

When in a dual mouse mode, and provided the option is properly configured,
the mouse cursors align.

When controlling a target server, the Remote Console displays two mouse
cursors - one belonging to your KX Ill client workstation, and the other
belonging to the target server.

When there are two mouse cursors, the device offers several mouse modes:
e Absolute (Mouse Synchronization)

e Intelligent (Mouse Mode)

e Standard (Mouse Mode)

When the mouse pointer lies within the KVM Client target server window,
mouse movements and clicks are directly transmitted to the connected target
server.

While in motion, the client mouse pointer slightly leads the target mouse
pointer due to mouse acceleration settings.

Single mouse mode allows you to view only the target server's pointer. You can
use Single mouse mode when other modes don't work.

You can toggle between these two modes (single mouse and dual mouse).

Dual Mouse Modes
Absolute Mouse Synchronization

In this mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different acceleration
or speed. This mode is supported on servers with USB ports and is the default
mode for virtual media CIMs.

e Absolute Mouse Synchronization requires the use of a virtual media CIM -
D2CIM-VUSB, D2CIM-DVUSB, D2CIM-DVUSB-DVI, D2CIM-DVUSB-HDMI,
D2CIM-DVUSB-DP, D2CIM-VUSB-USBC

»  To enter Absolute Mouse Synchronization:
e Choose Mouse > Absolute from the KVM client.

The black USB connector on the DVUSB CIMs are used for the keyboard and
mouse. The gray connector is used for virtual media.

For CIMs with two USB plugs, keep both connected to the device.

The device may not operate properly if both plugs are not connected to the
target server.
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Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse settings and
synchronize the mouse cursors accordingly, allowing mouse acceleration on the
target. Intelligent mouse mode is the default for non-VM targets.

Enter Intelligent Mouse Mode

P To enter intelligent mouse mode:
e Choose Mouse > Intelligent.
Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the Mouse
menu, automatically synchronizes mouse cursors during moments of inactivity.
For this to work properly, however, the following conditions must be met:

e The active desktop should be disabled on the target.
e No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of the
target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e The target advanced mouse properties such as “Enhanced pointer
precision" or “Snap mouse to default button in dialogs” should be disabled.

e The edges of the target video should be clearly visible (that is, a black
border should be visible between the target desktop and the remote KVM
console window when you scroll to an edge of the target video image).

e When using the intelligent mouse synchronization function, having a file
icon or folder icon located in the upper left corner of your desktop may
cause the function not to work properly. To be sure to avoid any problems
with this function, do not have file icons or folder icons in the upper left
corner of your desktop.

After autosensing the target video, manually initiate mouse synchronization by
clicking the Synchronize Mouse button on the toolbar. This also applies when
the resolution of the target changes if the mouse cursors start to desync from
each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.

Please note that mouse configurations will vary on different target operating
systems. Consult your OS guidelines for further details. Also note that
intelligent mouse synchronization does not work with UNIX targets.
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Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization algorithm. The
algorithm determines relative mouse positions on the client and target server.

In order for the client and target mouse cursors to stay in synch, mouse
acceleration must be disabled. Additionally, specific mouse parameters must
be set correctly.

»  To enter Standard Mouse mode:
e Choose Mouse > Standard.

Mouse Synchronization Tips
If you have an issue with mouse synchronization:

1. Verify that the selected video resolution and refresh rate are among those
supported by the device. The KVM Client Connection Info dialog displays
the actual values that the device is seeing.

2. Force an auto-sense by clicking the KVM Client auto-sense button.

3. If that does not improve the mouse synchronization (for Linux, UNIX, and
Solaris KVM target servers):

a. Open a terminal window.
b. Enter the following command: xset mouse 1 1

c. Close the terminal window.

4. Click the "KVM Client mouse synchronization" button ﬁ

Synchronize Your Mouse

In dual mouse mode, the Synchronize Mouse command forces realignment of
the target server mouse cursor with the client mouse cursor.

P To synchronize the mouse cursors, do one of the following:

e Click the Synchronize Mouse button ”} in the KVM client toolbar, or
select Mouse > Synchronize Mouse from the menu bar.

Note: This option is available only in Standard and Intelligent mouse modes.
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Single Mouse Mode

Single Mouse mode uses only the target server mouse cursor; the client mouse
cursor no longer appears onscreen.

Note: Single mouse mode does not work on Windows or Linux targets when the
client is running on a Virtual Machine.

» To enter single mouse mode, do one the following:
e Choose Mouse > Single Mouse Cursor.

e Click the Single/Double Mouse Cursor button h in the toolbar.

Single Cursor

—

You are about to enter Single Cursor mode, While you are in this mode,
W this software will have exclusive control over the mouse and keyboard.

To exit single cursor mode, you must press Ctrl+ LeftAlt+0
[7] Scale the video (no scroll bars)

ok || cancel

> To exit single mouse mode:

1. Press Ctrl+Alt+0 on your keyboard to exit single mouse mode.

Tool Options
General Settings

P To set the tools options:
Click Tools > Options. The Options dialog appears.

2. Select the Enable Logging checkbox only if directed to by Technical
Support.

This option creates a log file in your home directory.
3. Choose the Keyboard Type from the drop-down list (if necessary).
The options include:
= US/International
=  French (France)
= German (Germany)
= Japanese
= United Kingdom

= Korean (Korea)
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=  French (Belgium)
= Norwegian (Norway)
= Portuguese (Portugal)
= Danish (Denmark)
=  Swedish (Sweden)
= German (Switzerland)
= Hungarian (Hungary)
= Spanish (Spain)
= ltalian (Italy)
= Slovenian
= Translation: French - US
= Translation: French - US International
In AKC, the keyboard type defaults to the local client, so this option does
not apply.
4. Configure hotkeys:
= Toggle Full Screen Mode - Hotkey.

When you enter Full Screen mode, the display of the target server
becomes full screen and acquires the same resolution as the target
server.

This is the hot key used for toggling in and out of this mode.
= Toggle Single Cursor Mode - Hotkey.

When you enter single cursor mode, only the target server mouse
cursor is visible.

This is the hot key used to toggle in and out of single cursor mode,
removing and bringing back the client mouse cursor.

= Toggle Scaling Mode - Hotkey.
When you enter scaling mode, the target server scales to fit your
display.
This is the hot key used to toggle in and out of scaling mode.
= Disconnect from Target - Hotkey.
Enable this hotkey to allow users to quickly disconnect from the target.

For hotkey combinations, the application does not allow you to assign the
same hotkey combination to more than one function.

For example, if Q is already applied to the Disconnect from Target function,
it won't be available for the Toggle Full Screen Mode function.

Further, if a hotkey is added to the application due to an upgrade and the
default value for the key is already in use, the next available value is
applied to the function instead.
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5. Click OK.
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Options

General Client Launch Settings

[] Disable Hardware Accelerated Rendering
[] Enable Logging

m Adjust Full Screen Window Size to Target
J Resolution instead of Client Resolution

Toggle Full Screen Mode - HotKey: Clri+LeftAlt+M  ~
Toggle Single Cursor Mouse Mode - HolKey:  Ctri+LeftAlt+0

Toggle Scaling Mode - Hotkey: Ctri+LeftAlt+S
Disconnect From Target - HotKey: Chi+LeftAlt+Q  ~
[o< ] cone
Keyboard Limitations

Turkish Keyboards
Turkish keyboards are only supported on Active KVM Client (AKC).

Slovenian Keyboards

The < key does not work on Slovenian keyboards due to a JRE limitation.

Language Configuration on Linux

Because the Sun JRE on Linux has problems generating the correct Key Events
for foreign-language keyboards configured using System Preferences, configure
foreign keyboards using the methods described in the following table.

Language
US Intl

French
German
Japanese
UK

Korean
Belgian
Norwegian

Danish

Configuration method
Default

Keyboard Indicator
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)
Keyboard Indicator
Keyboard Indicator

Keyboard Indicator
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Language Configuration method

Swedish Keyboard Indicator

Hungarian System Settings (Control Center)
Spanish System Settings (Control Center)
Italian System Settings (Control Center)
Slovenian System Settings (Control Center)
Portuguese System Settings (Control Center)

Note: The Keyboard Indicator should be used on Linux systems using Gnome as
a desktop environment.

Client Launch Settings

Configuring client launch settings allows you to define the screen settings for a

KVM session.

»  To configure client launch settings:

1. Click Tools > Options. The Options dialog appears.
2. Click on the Client Launch Settings tab.

To configure the target window settings:

= Select 'Standard - sized to target Resolution' to open the window
using the target's current resolution. If the target resolution is
greater than the client resolution, the target window covers as
much screen area as possible and scroll bars are added (if
needed).

= Select 'Full Screen' to open the target window in full screen mode.
To configure the monitor on which the target viewer is launched:

= Select 'Monitor Client Was Launched From' if you want the target
viewer to be launched using the same display as the application
that is being used on the client (for example, a web browser or
applet).

= Use 'Select From Detected Monitors' to select from a list of
monitors that are currently detected by the application. If a
previously selected monitor is no longer detected, 'Currently
Selected Monitor Not Detected' is displayed.

To configure cursor shape:

= Select Default arrow, Dot, Crosshair, or Transparent to set the
cursor shape for all sessions. Use the Mouse menu to change the
cursor shape during a session.

To configure additional launch settings:
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= Select 'Enable Single Cursor Mode' to enable single mouse mode
as the default mouse mode when the server is accessed.

= Select 'Enable Scale Video' to automatically scale the display on
the target server when it is accessed.

= Select 'Pin Menu Toolbar' if you want the toolbar to remain visible
on the target when it is in Full Screen mode. By default, while the
target is in Full Screen mode, the menu is only visible when you
hover your mouse along the top of the screen.

= Always Show Tool Bar and Always Show Status Bar are per-user
settings that are stored in the computer you are accessing the
client from, so if you use a different computer, the setting may be
different. Select to keep tool bar and status bar visible as default,
deselect to keep tool bar and status bar hidden as default.

3. Click OK.

Options X
General Client Launch Settings
Window Mode
(®) Standard - sized to target resolution
() Full Screen

Monitor
(®) Monitor Client Was Launched From

() Select From Detected Monitors
Monitor A

Detected Monitors

Cursor Shape

(®) Default () Dot

() Crosshair () Transparent
Other

[ ] Enable Single Mouse Cursor
[ ] Enable Scale Video

[ ] Pin Menu Toolbar

Always Show Tool Bar
Always Show Status Bar

Cancel
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Configuring Port Scan Settings in VKC/VKCS and AKC

Configuring port scan options in VKC/VKCS and AKC applies to scanning from
the Remote Console.

To configure port scan options for the Local Console, see Configure Local
Console Scan Settings (on page 160)

Use the port scanning feature to search for selected targets, and display them
in a slide show view, allowing you to monitor up to 32 targets at one time.

You can connect to targets or focus on a specific target as needed. Scans can
include standard targets, blade servers, tiered devices, and KVM switch ports.

Configure scan settings from either the VKC/VKCS or AKC.

See Scanning Ports - Remote Console (on page 147)

Use the Scan Settings tab to customize the scan interval and default display
options.

Configure Port Scan
To set scan settings:

Click Tools > Options. The Options dialog appears.
Select the Scan Settings tab.

w N =T

In the "Display Interval" field, specify the number of seconds you want the
target that is in focus to display in the center of the Port Scan window.

4. Inthe "Interval Between Ports" field, specify the interval at which the
device should pause between ports.

5. Inthe Display section, change the default display options for the thumbnail
size and split orientation of the Port Scan window.
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6. Click OK.

Options X

General Clienk Launch Setting
Scan Intervals
Display Interval (3-255 sec): 10

Interval Between Ports (1-255 sec): |10

Display
Thumbnail Size: 160x120 R
Split Orientation: | Wertical b

Collecting a Diagnostic Snapshot of the Target

Administrators are able to collect a "snapshot" of a target.
The "snapshot" function generate log files and image files from the target.

It then bundles these files in a zip file that can be sent to Technical Support to
help diagnose technical problems you may be encountering.

The following files are included in the zip file:

e screenshot_image.png

This is a screenshot of the target that captures a picture of the issue you
are experiencing. This feature operates like the "Screenshot from Target"
feature.

e raw_video_image.png:

A snapshot image created from raw video data. Please note that client's
postprocessing is applied, just as if it were a "regular" screen update.

e raw_video_ycbcr420.bin:
Binary file of the raw snapshot.
e raw_video_ycbcr420.txt:

Text file containing data used to help diagnose issues.
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e Log.txt file:

These are the client logs.
Note that the logs are included even if you have not enabled information
to be captured in them. VKC uses internal memory to capture the

information in this case.

Collect a Diagnostic Snapshot
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P To capture a diagnostic snapshot:

[Took) view Virtal Megia Audio SmartCard Couer ool Help
Options...
Cellert Dingaentics Snapahe,.,

.'l'
Nebwork  Faesoftyoe:  [Z1p archive fles

File name:

(T - v - 80
Steps
@ Access a target, and then click Tools > Collect a Diagnostic Snapshot.
Several messages are displayed as the information is collected.
@ You are prompted to save the zip file containing the diagnostic files.

@ The zip file containing the diagnostic files is saved.
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View Options

View Toolbar

You can use the Virtual KVM client with or without the toolbar display.

» To toggle the display of the toolbar (on and off):
e Choose View > View Toolbar.

View Status Bar

By default, the status bar is displayed at the bottom of the target window.

»  To hide the status bar:
Click View > Status Bar to deselect it.

»  Torestore the status bar:
Click View > Status Bar to select it.

Scaling

Scaling your target window allows you to view the entire contents of the target
server window.

This feature increases or reduces the size of the target video to fit the Virtual
KVM Client window size, and maintains the aspect ratio so that you see the
entire target server desktop without using the scroll bar.

»  To toggle scaling (on and off):
e Choose View > Scaling.
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Full Screen Mode

When you enter Full Screen mode, the target's full screen is displayed and
acquires the same resolution as the target server.

The hot key used for exiting this mode is specified in the Options dialog, see
Tool Options (on page 55).

While in Full Screen mode, moving your mouse to the top of the screen
displays the Full Screen mode menu bar.

If you want the menu bar to remain visible while in Full Screen mode, enable
the Pin Menu Toolbar option from the Tool Options dialog. See Tool Options
(on page 55).

»  To enter full screen mode:

e Choose View > Full Screen, or click the Full Screen button @

»  To exit full screen mode:

e Press the hot key configured in the Tool's Options dialog. The default is
Ctrl+Alt+M.

If you want to access the target in full screen mode at all times, you can make
Full Screen mode the default.

» To set Full Screen mode as the default mode:
1. Click Tools > Options to open the Options dialog.

2. Select Enable Launch in Full Screen Mode and click OK.

Connect to Virtual Media
See Virtual Media (on page 25)

Smart Cards

Using the KX IIl, you are able to mount a smart card reader onto a target server
to support smart card authentication and related applications.

For a list of supported smart cards, smart card readers, and additional system
requirements, see Smart Card Minimum System Requirements, CIMs and
Supported/Unsupported Smart Card Readers (on page 66).

Note: The USB Smart Card token (eToken NG-OTP) is only supported from the
remote client.

Smart card reader mounting is also supported from the Local Console.

See Local Console Smart Card Access (on page 161).
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Smart Card Minimum System Requirements, CIMs and Supported/Unsupported Smart
Card Readers

Before you begin using a smart card reader, review the following:

e  Smart Card Minimum System Requirements (on page 195)
e Supported Computer Interface Module (CIMs) Specifications (on page
188)

e Supported and Unsupported Smart Card Readers

Authentication When Accessing a Smart Card Reader

When accessing a server remotely, you can select an attached smart card
reader and mount it onto the server.

Smart card authentication is used with the target server, it is not used to log
into the device. Therefore, changes to smart card PIN and credentials do not
require updates to device accounts.

PC Share Mode and Privacy Settings when Using Smart Cards

When PC-Share mode is enabled on the device, multiple users can share access
to a target server.

However, when a smart card reader is connected to a target, the device will
enforce privacy regardless of the PC-Share mode setting.

In addition, if you join a shared session on a target server, the smart card
reader mounting will be disabled until exclusive access to the target server
becomes available.

Smart Card Reader Detected

After a KVM session is established with a target server, a Smart Card menu and
button are available in VKC and AKC.

Once the Smart Card button is selected or Smart Card is selected from the
menu, the smart card readers that are detected as attached to the remote
client are displayed in a dialog.

From this dialog, you can attach additional smart card readers, refresh the list
of smart card readers attached to the target, and detach smart card readers.

You are also able to remove or reinsert a smart card. This function can be used
to provide notification to a target server OS that requires a removal/reinsertion
in order to display the appropriate login dialog. Using this function allows the
notification to be sent to a single target without affecting other active KVM
sessions.
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Mount a Smart Card Reader

When mounted onto the target server, the card reader and smart card will
cause the server to behave as if they had been directly attached.

Removal of the smart card or smart card reader will cause the user session to
be locked or you will be logged out depending on how the card removal policy
has been setup on the target server OS.

When the KVM session is terminated, either because it has been closed or
because you switch to a new target, the smart card reader will be automatically
unmounted from the target server.

>

1.

To mount a smart card reader from VKC or AKC:

Click the Smart Card menu and then select Smart Card Reader.

Alternatively, click the Smart Card button Q in the toolbar.
Select the smart card reader from the Select Smart Card Reader dialog.
Click Mount.

A progress dialog will open. Check the 'Mount selected card reader
automatically on connection to targets' checkbox to mount the smart card
reader automatically the next time you connect to a target. Click OK to
begin the mounting process.

Update a Smart Card Reader

>

To update the smart card in the Select Smart Card Reader dialog:

Click Refresh List if a new smart card reader has been attached to the
client PC.

Send Smart Card Remove and Reinsert Notifications

>

To send smart card remove and reinsert notifications to the target:

Select the smart card reader that is currently mounted and click the
Remove/Reinsert button.

Unmount (Remove) a Smart Card Reader

>
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To unmount a smart card reader:

Select the smart card reader to be unmounted and click the Unmount
button.

67



Chapter 5: KVM Clients

Digital Audio

The KX lll supports end-to-end, bidirectional, digital audio connections for
digital audio playback and capture devices from a remote client to a target
server.

The audio devices are accessed over a USB connection.

Current device firmware is required.
One of the following CIMs must be used:
=  D2CIM-DVUSB

= D2CIM-DVUSB-DVI

= D2CIM-DVUSB-HDMI
D2CIM-DVUSB-DP

Windows’, Linux® and Mac’ operating systems are supported. VKC, VKCS, and
AKC support connections to audio devices.

Note: Audio CDs are not supported by virtual media so they do not work with
the audio feature.

Before you begin using the audio feature, review the audio related information
documented in the following sections:

Supported Audio Device Formats (on page 68)
Recommendations for Dual Port Video

Dual Video Port Group Supported Mouse Modes
CIMs Required for Dual Video Support
Informational Notes, Audio (on page 220)

Supported Audio Device Formats

The KX lll supports one playback and capture device and one record device on a
target at a time. The following audio device formats are supported:

68

Stereo, 16 bit, 44.1K
Mono, 16 bit, 44.1K
Stereo, 16 bit, 22.05K
Mono, 16 bit, 22.05K
Stereo, 16 bit, 11.025K
Mono, 16 bit, 11.025K

Raritan.

Abrand of O legrand



Chapter 5: KVM Clients

Digital Audio VKC and AKC Icons

Audio Icon name Description
icons

§ Speaker These icons are located in status bar at the bottom of
4.1} the client window.

Green, blinking waves indicate an audio playback
session is currently streaming.

A black speaker icon is displayed when the session is
muted.

E.‘"l"

The icon is grayed out when no audio is connected.

Microphone These icons are located in the status bar at the
bottom of the client window.

fﬁ‘a
o

Red, blinking waves indicate an audio capture session
is currently underway.

fo Ham

The Speaker icon, indicating a playback session is
streaming, is also displayed when a session is
underway.

A black Microphone icon is displayed when the
session is muted.

When the Microphone icon is grayed out, no audio is
connected.

Audio Playback and Capture Recommendations and Requirements

Audio Level
e Set the target audio level to a mid-range setting.
For example, on a Windows’ client, set the audio to 50 or lower.

This setting must be configured through the playback or capture audio device,
not from the client audio device control.
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Recommendations for Audio Connections when PC Share Mode is Enabled

If you are using the audio feature while running PC Share mode, audio playback
and capture are interrupted if an additional audio device is connected to the
target.

For example, User A connects a playback device to Targetl and runs an audio
playback application then User B connects a capture device to the same target.
User A's playback session is interrupted and the audio application may need to
be restarted.

The interruption occurs because the USB device needs to be re-enumerated
with the new device configuration.

It may take some time for the target to install a driver for the new device.

Audio applications may stop playback completely, go to the next track, or just
continue playing.

The exact behavior is dependent on how the audio application is designed to
handle a disconnect/reconnect event.

Bandwidth Requirements

The table below details the audio playback and capture bandwidth
requirements to transport audio under each of the selected formats.

Audio format Network bandwidth requirement
44.1 KHz, 16bit stereo 176 KB/s

44.1 KHz, 16bit mono 88.2 KB/s

2.05 KHz, 16bit stereo 88.2 KB/s

22.05 KHz, 16bit mono 44.1 KB/s

11.025 KHz, 16bit stereo 44.1 KB/s

11.025 KHz, 16bit mono Audio 22.05 KB/s
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In practice, the bandwidth used when an audio device connects to a target is
higher due to the keyboard and video data consumed when opening and using
an audio application on the target.

A general recommendation is to have at least a 1.5MB connection before
running audio/video.

However, high video-content, full-color connections using high-target screen
resolutions consume much more bandwidth and impact the quality of the
audio considerably.

To help mitigate quality degeneration, there are a number of recommended
client settings that reduce the impact of video on audio quality at lower
bandwidths:

e Connect audio playback at the lower quality formats. The impact of video
consuming bandwidth is much less notable at 11k connections than at 44k

e Set the connection speed under Connection Properties to a value that best
matches the client to server connection

e Under Connection Properties, set the color depth to as low a value as
possible. Reducing the color depth to 8 bit color considerably reduces the
bandwidth consumed

e Set Smoothing to High. This will improve the appearance of the target
video by reducing displayed video noise

e Under Video settings, set the Noise Filter to its highest setting of 7 (highest
value) so less bandwidth is used for target screen changes

Saving Audio Settings

Audio device settings are applied on a per KX Il device basis.

Once the audio devices settings are configured and saved on the KX 1lI, the
same settings are applied to it.

For example, you can configure a Windows® audio device to use as stereo, 16
bit, 44.1K format.

When you connect to different targets and use that Windows audio device, the
stereo, 16 bit, 44.1K format is applied to each target server.

For all devices, the device type, device format, and the buffer settings applied
to the device are saved.

See Connecting and Disconnecting from a Digital Audio Device (on page 72)
for information on connecting to and configuring an audio device, and
Adjusting Buffer Size (Audio Settings) for information on audio device buffer
settings.

If you are using the audio feature while running PC Share mode and VM Share
mode so multiple users can access the same audio device on a target at once,
the audio device settings of the user who initiates the session are applied to all
users who join the session.

So, when a user joins an audio session, the target machine settings are used.
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Connecting to Multiple Targets from a Single Remote Client

Connect to audio on up to four (4) target servers at the same time from a single,
remote client.

See Connecting and Disconnecting from a Digital Audio Device (on page 72)
for information on connecting to audio devices.

"

A Speaker icon 1 is displayed in the status bar at the bottom of the client
window. It is grayed out when no audio is being used. When the Speaker icon

il
and Microphone icon '{'ﬁ" are displayed in the status bar, the session is being
captured as it is streamed.

Note: When audio over HDMl is connected, the idle user timeout setting is
ignored.

Operating System Audio Playback Support

Review the table shown here to see which client works with audio
playback/capture for each operating system:

Operating system Audio playback and capture supported by:
Windows® = Active KVM Client (AKC)
= Virtual KVM Client (VKC)
Linux® = Virtual KVM Client (VKC)
Mac® = Virtual KVM Client (VKC)

Connecting and Disconnecting from a Digital Audio Device

Audio device settings are applied on a per KX Il device basis.

Once the audio devices settings are configured and saved on the KX IlI, the
same settings are applied to it.

See Saving Audio Settings (on page 71) for more information.

Connect to a Digital Audio Device

»  To connect to an audio device:

1. Connect the audio device to the remote client PC prior to launching the
browser connection to the KX 111.

2. Connect to the target from the Port Access page.

3. Once connected, click the Audio button Eq.ﬂ in the toolbar.

The Connect Audio Device dialog appears. A list of available audio devices
connected to the remote client PC is displayed.
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Note: If there are no available audio devices connected to the remote client
PC, the Audio icon is grayed out. .

Check Connect Playback Device if you are connecting to a playback device.
Select the device that you wish to connect from the drop-down list.

Select the audio format for the playback device from the Format:
drop-down.

Note: Select the format that you wish to use based on the available
network bandwidth. Formats with lower sampling rates consume less
bandwidth and may tolerate more network congestion.

Select the "Mount selected playback device automatically on connection to
target" checkbox to automatically connect an audio playback device when
you connect to an audio supporting target.

Check Connect Recording Device if you are connecting a recording device.

Note: The device names listed in the Connect Recording Device drop-down
are truncated to a maximum of 30 characters for Java clients.

Select the device that you wish to connect from the drop-down list.

Select the audio format for the recording device from the Format:
drop-down.

Click OK. If the audio connection is established, a confirmation message
appears. Click OK.

If the connection was not established, an error message appears.

Once an audio connection is established, the Audio menu changes to
Disconnect Audio. The settings for the audio device are saved and applied
to subsequent connections to the audio device.

%

A Speaker icon 1-:5 is displayed in the status bar at the bottom of the
client window. It is grayed out when no audio is being used. When the

el B
Speaker icon and Microphone icon 'ﬁ' are displayed in the status bar,
the session is being captured as it is streamed.

Disconnect from an Audio Device

>

To disconnect from the audio device:

P
Click the Audio icon h@ in the toolbar and select OK when you are
prompted to confirm the disconnect. A confirmation message appears.
Click OK.
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Adjusting Capture and Playback Buffer Size (Audio Settings)

Once an audio device is connected, the buffer size can be adjusted as needed.

This feature is useful for controlling the quality of the audio, which may be
impacted by bandwidth limitations or network spikes.

Increasing the buffer size improves the audio quality but may impact the
delivery speed.

The maximum available buffer size is 400 milliseconds since anything higher
than that greatly impacts audio quality.

The buffer size can be adjusted whenever needed, including during an audio
session.

Audio settings are configured in VKC or AKC.
Adjust Audio Settings

P To adjust audio settings:

Select Audio Settings from the Audio menu. The Audio Settings dialog
opens.

2. Adjust the capture and/or playback buffer size as needed. Click OK.

Capture Buffer Size: - miliseconds

Playback Buffer Size: e miliseconds

Power Control Using VKC, VKCS, and AKC

You can power on, power off, and power cycle a target through the outlet it is
connected to.

Access the target, and then select a power control option from the Power
Control menu.

Connection USB Profile Keyboard Video Mouse Tools View Virtual Media Audie SmartCard [Power Control| Help

SREBhBEQIOOREE Pover On

Power Off

Power Cycle
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The menu option is disabled if you do not have permission for power control,
and when outlets are not associated with the port.

Version Information - Virtual KVM Client

For version information about the client, in case you require assistance from
Raritan Technical Support.

e Choose Help > About Raritan Virtual KVM Client.

Active KVM Client (AKC) Help

To launch AKC, enter https://<IP address>/akc in a browser.

The Active KVM Client (AKC) is based on Microsoft Windows .NET* technology.
This allows you to run the client in a Windows environments without Java..
AKC provides the same features as VKC with the exception of the following:

e Keyboard macros created in AKC cannot be used in any other client.

e Direct port access configuration

e  AKC server certification validation configuration (see Prerequisites for
Using AKC (on page 76))

For details on using the features, see Virtual KYM Client (VKC and VKCs) Help
(on page 35).

Recommended Minimum Active KVM Client (AKC) Requirements

It is recommended that the Active KVM Client (AKC) machines meet the
following minimum requirements.

e Client machine with either a -

=  'modern' dual-core CPU for a single connections, or

= 'modern' quad core CPU for two or more simultaneous connections
e 4GB of RAM

AKC Supported Microsoft .NET Framework

The Active KVM Client (AKC) requires Windows .NET". See the Release Notes for
supported versions.

AKC Supported Operating Systems

When launched from Internet Explorer®, the Active KVM Client (AKC) allows you
to reach target servers via the KX III.

AKC is compatible with the following platforms:

Windows 7° operating system (up to 64 bit)

Windows 8° operating system (up to 64 bit)

Windows 10 ° operating system (up to 64 bit)
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AKC Supported Browsers

See the Release Notes for supported browser versions.

Prerequisites for Using AKC

Allow Cookies

Ensure the cookies from the IP address of the device that is being accessed are
not currently being blocked.

Include KX Il IP Address in 'Trusted Sites Zone'

Windows® 7 users should ensure that the IP address of the device being
accessed is included in their browser's Trusted Sites Zone.

Disable 'Protected Mode'

‘Windows® 7 users should ensure that Protected Mode is not on when
accessing this device.

Enable AKC Download Server Certificate Validation

If the administrator has enabled the Enable AKC Download Server Certificate
Validation option:

e Administrators must upload a valid certificate to the device or generate a
self-signed certificate on the device. The certificate must have a valid host
designation.

e Each user must add the CA certificate (or a copy of self-signed certificate)
to the Trusted Root CA store in their browser.

Proxy Server Configuration

When the use of a Proxy Server is required, a SOCKS proxy must also be
provided and configured on the remote client PC.

Note: If the installed proxy server is only capable of the HTTP proxy protocol,
you cannot connect.

»  To configure the SOCKS proxy:
1. Onthe remote client PC, select Control Panel > Internet Options.

a. On the Connections tab, click 'LAN settings'. The Local Area Network
(LAN) Settings dialog opens.

b. Select 'Use a proxy server for your LAN'.
Click Advanced. The Proxy Settings dialog opens.

d. Configure the proxy servers for all protocols.
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IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

e. Click OK at each dialog to apply the settings.
2. Next, configure the proxy settings for the Java” applets:
a. Select Control Panel > Java.

b. Onthe General tab, click Network Settings. The Network Settings
dialog opens.

Select "Use Proxy Server".
d. Click Advanced. The Advanced Network Settings dialog opens.
e. Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

Connect to a Target from Virtual KVM Client (VKC), Standalone VKC (VKCs), or
Active KVM Client (AKC)

Once you have logged on to the KX IIl Remote Console, access target servers via
the Virtual KVM Client (VKC), Standalone VKC (VKCs), or Active KVM Client
(AKC).

»  To connect to an available server:

On the Port Access page, click on the port name of the target server you
want to connect to. The Port Action menu opens.

2. Click Connect.

Home > Forts

Port Access

Click on the individual
0 /4 Remote KVM char

View By Grd
4 No. Name
| e et

See Port Action Menu (on page 20) for details on additional available menu
options.
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HTML KVM Client (HKC)

The HTML KVM client (HKC) provides KVM over IP access that runs in the
browser without the need for applets or browser plugins. HKC uses Javascript,
NOT Java.

HKC runs on Linux and Mac clients, and on Windows clients in Internet Explorer
11, Edge, Firefox, Chrome and Safari browsers.

A mobile version of HKC also runs on iOS v10 and higher. See KVM Client
Launching (on page 34) for a full matrix of clients.

Many KVM features are supported. Future releases will provide more advanced
KVM features.

>

Supported Features:

Connection Properties

USB Profiles

Video Settings

Input Settings

Audio Playback

Virtual Media

Dual Video Targets on IE, Edge, Firefox and Chrome
Keyboard Macros

Import and Export of Keyboard Macros

Send Text to Target

Keyboard and Mouse Settings

Single Mouse Mode - not available on IE browser
Power Control (not supported for KX4-101)

Not supported:

Port Scanning

Smartcard

Limited Tools Menu options.

Limited keyboard support: US-English, UK-English, French, German,
Swiss-German, and Japanese are supported

Hotkeys for keyboard macros
Pre-populated keyboard macros for Sun targets

Can only create Macros from keys that exist on the client PC (US-English,
UK-English, French, German), no special function keys except for delay key.

Single Mouse mode - not available on IE

Virtual Media write not supported

Local file transfer supported by Chrome, Firefox, and Safari browsers only
USB drive connects
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Favorites
Audio capture

Dual video targets not supported on Safari. Use Chrome or Firefox to
connect to dual video targets on Mac OS.

Known Issues:

Ensure that the device certificate is installed and trusted. The certificate
Common name should match the IP address/Hostname used to connect to
the device. See SSL and TLS Certificates for information on creating and
installing certificates

When Single Mouse Mode in the Edge browser is selected for the first time,
the user is prompted to turn off the local mouse pointer. Select the bottom
part of the Yes button.

Target connections from Chrome 61 running on Fedora requires HardWare
Acceleration to be enabled.

If erratic mouse response is seen in Single Mouse mode on Fedora clients
using the default Gnome desktop, use the Gnome classic desktop.

To enable scrollbars on Mac Browser target connections: On the OS menu
bar, choose System Preferences > General > Show scroll bars: Always.

Internet Explorer and Edge support only 6 sessions at a time. The error
displayed when attempting to connect to a seventh target is "Error could
not connect to target." For IE11, you can increase the sessions allowed in
the Group policy editor. See
https://jwebsocket.org/documentation/reference-guide/internet-explorer-
tips.

For IE11 and Edge IPv6 device connections, either use device hostname or
literal IPv6 as UNC. See
https://en.wikipedia.org/wiki/IPv6_addresstLiteral_IPv6_addresses_in_UN
C_path_names

For Mac/Safari IPv6 device connections, use device hostname.

Client Keyboard input selection should be set for each device individually.
If encountering issues on browsers that have previously connected to an
older version, it may be necessary to clear the Cache Web Content from
the browser.

To launch HKC automatically in Safari browser: Use http://<IP
Address>/hkc, OR use http://<IP Address>/ if "Java content on browser" is
disabled in Java Control Panel, and "Java Plugin" is disabled in the browser.
From Chrome running on Linux, to get * * or #, the key needs to be hit three
times, or twice followed by a space.

On a default build of Redhat 7/Firefox ESR 24.5, there is no target video
displayed on HKC connections. Older versions of Firefox lack HTML5
functions needed to support HKC. Upgrade Firefox to the latest available
version.

If HKC does not load, but rather displays a white screen, your browser
memory may be full. Close all browser windows and try again.
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e No audio support on IE.

Connection Properties

Connection properties manage streaming video performance over remote
connections to target servers.

The properties are applied only to your connection - they do not impact the
connection of other users accessing the same target servers.

If you make changes to connection properties, they are retained by the client.

» To view connection properties:
e Choose File > Connection Properties.

Default Connection Properties

The KX lll comes configured to provide optimal performance for the majority of
video streaming conditions.

Default connection settings are:

e  Optimized for: Text Readability - video modes are designed to maximize
text readability.

This setting is ideal for general IT and computer applications, such as
performing server administration.

e Video Mode - defaults to Full Color 2.

Video frames transmit in high-quality, 24-bit color. This setting is suitable
where a high-speed LAN is used.

e Noise Filter - defaults to 2.
The noise filter setting does not often need to be changed.

Click Reset to regain the default connection properties.
Connection Properties

Optimize for: Text Readability =
Videc Mode: Full Color 2

Best Lower
Noise Filter: 2
Quality oise mier Bandwidth

H

e (0 (D D
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Text Readability

Text Readability is designed to provide video modes with lower color depth but
text remains readable. Greyscale modes are even available when applying
lower bandwidth settings.

This setting is ideal when working with computer GUIs, such as server
administration.

When working in full color video modes, a slight contrast boost is provided, and
text is sharper.

In lower quality video modes, bandwidth is decreased at the expense of
accuracy.

Color Accuracy

When Color Accuracy is selected, all video modes are rendered in full 24-bit
color with more compression artifacts.

This setting applies to viewing video streams such as movies or other broadcast
streams.

In lower quality video modes, sharpness of fine detail, such as text, is sacrificed.

Video Mode

The Video Mode slider controls each video frame's encoding, affecting video
quality, frame rate and bandwidth.

Connection Properties

Optimize for: Text Readability =
Video Mode: Full Color 2

Best Lower
Noise Filter: 2
Quality Bandwidth

g

o o] ]
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In general, moving the slider to the left results in higher quality at the cost of
higher bandwidth and, in some cases, lower frame rate.

Moving the slider to the right enables stronger compression, reducing the
bandwidth per frame, but video quality is reduced.

In situations where system bandwidth is a limiting factor, moving the video
mode slider to the right can result in higher frame rates.

When Text Readability is selected as the Optimized setting, the four rightmost
modes provide reduced color resolution or no color at all.

These modes are appropriate for administration work where text and GUI
elements take priority, and bandwidth is at a premium.

Noise Filter

Unless there is a specific need to do so, do not change the noise filter
setting. The default setting is designed to work well in most situations.

The Noise Filter controls how much interframe noise is absorbed by the KX III.
Connection Properties

Optimize for: Text Readability =
Video Mode: Full Color 2

Best Lower
Noise Filter: 2
Quality oise Tier Bandwidth

g

o o] ]

Moving the Noise Filter slider to the left lowers the filter threshold, resulting in
higher dynamic video quality. However, more noise is likely to come through,
resulting in higher bandwidth and lower frame rates.

Moving the slider to the right raises the threshold, allows less noise and less
bandwidth is used. Video artifacts may be increased.

Moving the noise filter to the right may be useful when accessing a computer
GUI over severely bandwidth-limited connections.
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Connection Info

Open the Connection Information dialog for real-time connection information
on your current connection, and copy the information from the dialog as
needed.

See Default Connection Properties (on page 80) for help configuring the
connection properties.

Name of the device

IP address of the device

Port - The KVM communication TCP/IP port used to access the device
Data In/Second - Data rate received from the device

Data Out/Second - Data rate sent to the device

FPS - Video frames per second from the device.

Average FPS - Average number of video frames per second.
Connect Time - The duration of the current connection.
Horizontal Resolution - The target server horizontal resolution.
Vertical Resolution - The target server vertical resolution.
Refresh Rate - Refresh rate of the target server.

Protocol Version - communications protocol version.

To view connection info:

Choose File > Connection Info.

Connection Info

Devica Namea: kx361-16
IP Address: 192.168.61.16
Port: 443

Data In/Second: 121 kBfs
Data Qut/Second: 234 Bfs
FPS: 17

Avg. FPS: 21.80
Connect Time: 00:00:25
Horizontal Resolution: 1024
‘Vertical Resolution: 768
Refresh Rate: 60 Hz
Protoceol Version: 1.31
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USB Profile
Select a USB profile that best applies to the KVM target server.

For example, if the server is running Windows® operating system, it would be
best to use the Generic profile.

Or, to change settings in the BIOS menu or boot from a virtual media drive,
depending on the target server model, a BIOS profile may be more appropriate.

P> To set a USB profile for a target server:

e Choose USB Profile, then choose Generic, or choose Other Profiles to
select from a menu.

@ SmartCard 7.5 - HTML KVM Client - Google Chrome

A Not secure | hitps://192.168.61.140/jsclient/C

File « USB Profile « nput iew « ools - Virtual Med
Help ~ Generic v
% h Other f‘:‘gu:atﬂ—'?# II-"I:J‘IIIIEFHI'D,'LIJ—.:? =

BIOS Dell PowerEdge 1950/2950/2970/6950/R200
BIOS Dell Cptiplex Keyboard and Mouse Only
BIOS Asus P4C800 Motherboard

IBM BladeCenter H with AMM

Use Full Speed for Keyboard and Mouse USB
BIOS HP Proliant DL385 G7

BIOS Dell Optiplex 790 Keyboard Only

BIOS Dell Optiplex 790

Mac USB-C

Help on USB profiles

Note: When using the D2CIM-VUSB-USBC on Mac targets, you must select the
"Mac USB-C" profile.

» To view details on USB profiles:

Choose USB Profile > Help on USB Profiles.

Input Menu
Keyboard Layout

» To set your keyboard type.
e Choose Input > Keyboard Layout, then select your keyboard type.

= de-de
= de-ch
= en-gb
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" en-us
= fr
[ ja

@ SmartCard 7.5 - HTML KVM Client - Google Chrome
A Mot secure | hitps//192.168.61.140/jsclient/Client.asp#
File - USB Profile ~ Input ~ Video ~ View ~ ools ~ Vir

Help ~ A Keyboard Layout de-de
0 22 Send Macro
de-ch
% h @ @ Q ﬂ # Wacro Editor en-gb
£ Send text to target en-us
<= Mouse Modes fr
£J Mouse Sync

Send Macro

Due to frequent use, several keyboard macros are preprogrammed.

» To send a preprogrammed macro:
e Choose Input > Send Macro, then select the macro:

= Ctrl+Alt+Del: Sends the key sequence to the target without affecting
the client.

= Alt+F4: Closes a window on a target server.
= Alt+Tab: Switch between open windows on a target server.

=  Print Screen: Take a screenshot of the target server.

Input ~ Video - View - Virtual Media ~
A Keyboard Layout + ) | g5y EE8

&2 Send Macro Ctri+Alt+Del
# Macro Editor Alt+F4

= Send text to target Alt+Tab

“ Mouse Modes

Print Screen
2 Mouse Sync
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Macro Editor

Keyboard macros ensure that keystroke combinations intended for the target
server are sent to and interpreted only by the target server. Otherwise, they
might be interpreted by your client PC.

Macros are stored on the client PC and are PC-specific. If you use another PC,
you cannot see your macros.

In addition, if another person uses your PC and logs in under a different name,
that user will see your macros since they are computer-wide.

Macros created with HKC are only available with the current browser and KVM
device. If you use HKC in more than one browser, or more than one KX Ill, your
macros will only be available on the browser and KX Il where they were
created. To reuse your macros in another KX Ill device, you can import and
export the macro files. See Import and Export Macros (on page 91).

»  To access the Macro Editor:
e Choose Inputs > Macro Editor.

e Select a macro from the Macros list to view the key combination.

Macro Editor

Name Ctrl+Alt+Del
Macros Keys
Ctri+Alt+Del o press: CTRL LEFT o Add Key
Alt+F4 press: ALT LEFT
Alt+Tab press: DELETE Add Delay
Print Screen release: CTRL LEFT
release: ALT LEFT i
release: DELETE A
- -
Delete

Use in Toolbar

Add New Macro Delete Macro

Export Import

m Cancel

Add New Macro

» To add a new macro:

1. Choose Inputs > Macro Editor.
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Click Add New Macro.

Macro Editor

Name New Macro
Macros Keys
Ctri+Alt+Del - - Add Key
Alt+F4
Alt+Tab Add Delay
Print Screen
New Macro i
- -
w

Delete

Add New Macro Delete Macro Use in Toolbar

Enter a Name for the new macro. The name will appear in the Send Macro
menu once the macro is saved.

Click Add Key, then press the key you want to add to the macro. The key
press and key release appear in the Keys list.

= To add more keys, click Add Key again, and press another key.
= Toremove a key, select it in the Keys list and click Delete Key

To put the keys in the correct sequence, click to select a key in the Keys list,
then click the up and down arrows.

To add a 500 ms delay to a key sequence, click Add Delay. A delay in the
middle of a press-and-release key sequence indicates holding down a key.
Add multiple delays to indicate a longer press-and-hold of a key. Click the
up and down arrows to move the delays into the correct sequence.
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7. Click OK to save. To use this macro from your toolbar, click Use in Toolbar.
See Add a Macro to the Toolbar (on page 89) for more details.

Macro Editor

Name Option-Command-P-R
Macros Keys

Clri+Alt+Del I . Add Key
Alt+F4 press: META
Alt+Tab press: P = Add Delay
Print Screen press: R
delay: 500ms 4 t

delay: 500ms

delay: 500ms s

= delay: 500ms =
o o Delete

Add New Macro Delete Macro Use in Toolbar ]|

Option-Command-P-R added to toolbar

o]

This example shows a macro for a Mac bootup sequence that requires a
2-second delay.

Delete a Macro

» To delete a macro:
1. Choose Inputs > Macro Editor.

2. Select the macro, then click Delete Macro.
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3. Click OK.
Macro Editor

Name New Macro

Macros Keys

Ctri+Alt+Del - -
Alt+F4

Alt+Tab Add Delay
Print Screen

New Macro i3

Add Key

1|

Delete

Add New Macro Delete Macro Use in Toolbar

Add a Macro to the Toolbar
You can add a single macro to your HKC toolbar, so that you can use the macro
by clicking an icon.

» To add a macro to the toolbar:
1. Choose Inputs > Macro Editor.

2. Select a macro from the Macros list.
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3. Click Use in Toolbar.

Macro Editor

Add Key

Add Delay

Delete

Use in Toolbar

MName New Macro
Macros Keys

Ciri+Alt+Del - press: ENTER
Alt+F4 delay. 500ms
Alt+Tab de 10ms
Print Screen del 15
New Macro release: ENTER

Add New Macro Delete Macro
Export mport

EED

4. A message appears to confirm the macro is added to the toolbar.

=  To remove the macro from the toolbar, click Remove from Toolbar, or
select a different macro and click Use in Toolbar.

New Macro added to toolbar am—

Remove from Toolbar

5. Click OK and exit the Macro Editor. The macro icon is added to the toolbar

when one has been set.

B hHE REEQ 00 @E
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Import and Export Macros

Macros created with HKC are only available with the current browser and KVM
device. If you use HKC in more than one browser, or more than one KX Ill, your
macros will only be available on the browser and KX lll where they were
created. To reuse your macros in another KX Il device, you can import and
export the macro files. Imported and exported macro files created on HKC are
only compatible with HKC, and cannot be used on AKC or VKC. Likewise, macro
files created on AKC or VKC cannot be imported for use on HKC.

Macros are exported to an xml file named "usermacros.xml". Files are saved in
your browser's default download location. Default macros are not exported.

»  To export and import macros:

Choose Input > Macro Editor. The list of macros created for your browser
and KX Ill displays in the Macro Editor dialog.

To export the list, click the Export button, then save the file.
Log in to the KX lll where you want to import the macros.

Choose Input > Macro Editor.

vk W

Click Import, then click Open to Import and select the usermacros.xml file,
and click OK.

6. The macros found in the file display in the list. Select the macros you want
to import, then click OK.

= Macro names must be unique. If a macro with the same name already
exists, an error message appears. Click the Edit icon to rename the
macro, then click the checkmark to save the name.

Macro Import

Open to Import

Select macros to import:

Macro1 4

Select All Deselect All
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Known Issues for Macros

e You cannot add the Command (Windows) key to a macro from Fedora
browsers. The key is consumed by the OS.

Send Text to Target

Use the Send Text to Target function to send text directly to the target. If a text
editor or command prompt is open and selected on the target, the text is
pasted there.

» To send text to target:

Choose Input > Send Text to Target. The Send Text to Target dialog
appears.

2. Enter the text you want sent to the target. Supported keyboard characters
only.

3. Click OK.

Mouse Modes

You can operate in either single mouse mode or dual mouse mode.

When in a dual mouse mode, and provided the option is properly configured,
the mouse cursors align.

When controlling a target server, the Remote Console displays two mouse
cursors - one belonging to your KX llI client workstation, and the other
belonging to the target server.

When there are two mouse cursors, the device offers several mouse modes:
e Absolute (Mouse Synchronization)

e Intelligent (Mouse Mode)

e Standard (Mouse Mode)

When the mouse pointer lies within the KVM Client target server window,
mouse movements and clicks are directly transmitted to the connected target
server.

While in motion, the client mouse pointer slightly leads the target mouse
pointer due to mouse acceleration settings.

Single mouse mode allows you to view only the target server's pointer. You can
use Single mouse mode when other modes don't work.

You can toggle between these two modes (single mouse and dual mouse).
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Absolute Mouse Synchronization

In this mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different acceleration
or speed. This mode is supported on servers with USB ports and is the default
mode for virtual media CIMs.

e Absolute Mouse Synchronization requires the use of a virtual media CIM -
D2CIM-VUSB, D2CIM-DVUSB, D2CIM-DVUSB-DVI, D2CIM-DVUSB-HDMI,
D2CIM-DVUSB-DP, D2CIM-VUSB-USBC

P To enter Absolute Mouse Synchronization Mode:
e Choose Input > Mouse Modes > Absolute.

Input ~ Video ~ View ~ Virtual Media ~

A Keyboard Layout o o
28 Send Macro )

# Macro Editor
= Send text to target
% Mouse Modes Absolute v
i
= Mouse Sync Intelligent
Standard
Single Mouse Mode
Intelligent

In Intelligent Mouse mode, the device can detect the target mouse settings and
synchronize the mouse cursors accordingly, allowing mouse acceleration on the
target.

P To enter Intelligent mouse mode:

e Choose Input > Mouse Mode > Intelligent. The mouse will synch. See
Intelligent Mouse Synchronization Conditions (on page 53).

Input ~ Video ~ View - Virtual Media ~

A Keyboard Layout (O] [DEL]
&2 Send Macro ) ——

#' Macro Editor L3
£ Send text to target

“ Mouse Modes Absolute

el

= Mouse Sync Intelligent «

Standard
Single Mouse Mode
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Standard

Standard Mouse mode uses a standard mouse synchronization algorithm. The
algorithm determines relative mouse positions on the client and target server.

In order for the client and target mouse cursors to stay in synch, mouse
acceleration must be disabled. Additionally, specific mouse parameters must
be set correctly.

»  To enter Standard mouse mode:
e Choose Input > Mouse Modes > Standard.

Input ~ Video - View ~ Virtual Media ~

i A Keyboard Layout [DEE |
2 Send Macro . e
# Macro Editor
£ Send text to target
4 Mouse Modes Absolute
£ Mouse Sync

Intelligent
Standard +
Single Mouse Mode

Single

Single Mouse mode uses only the target server mouse cursor; the client mouse
cursor no longer appears onscreen.

Note: Single mouse mode does not work on Windows or Linux targets when the
client is running on a Virtual Machine. Single mouse mode is not available on
Internet Explorer.

»  To enter Single mouse mode:
e Choose Inputs > Mouse Modes > Single.

Input ~ Video ~ View ~ Virtual Media ~

A Keyboard Layout o o
28 Send Macro ) an

# Macro Editor

= Send text to target

< Mouse Modes Absolute

e

> Mouse Sync Intelligent +*

Standard
| Single Mouse Mode |

e A message appears at the top of the client window: Press Esc to show your
cursor.

@ 192.168.61.16 has control of your pointer. Press Fsc to take back control.
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P To exit Single mouse mode:
e PressEsc.

e  Mouse mode changes back to dual mode.

Mouse Sync

In dual mouse mode, the Synchronize Mouse command forces realignment of
the target server mouse cursor with the client mouse cursor.

Note: This option is available only in Standard and Intelligent mouse modes.

» To synchronize the mouse cursors:

e Choose Inputs > Mouse Sync.

Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the Mouse
menu, automatically synchronizes mouse cursors during moments of inactivity.
For this to work properly, however, the following conditions must be met:

e The active desktop should be disabled on the target.

e No windows should appear in the top left corner of the target page.

e  There should not be an animated background in the top left corner of the
target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e The target advanced mouse properties such as “Enhanced pointer
precision" or “Snap mouse to default button in dialogs” should be disabled.

e The edges of the target video should be clearly visible (that is, a black
border should be visible between the target desktop and the remote KVM
console window when you scroll to an edge of the target video image).

e When using the intelligent mouse synchronization function, having a file
icon or folder icon located in the upper left corner of your desktop may
cause the function not to work properly. To be sure to avoid any problems
with this function, do not have file icons or folder icons in the upper left
corner of your desktop.

After autosensing the target video, manually initiate mouse synchronization by
clicking the Synchronize Mouse button on the toolbar. This also applies when
the resolution of the target changes if the mouse cursors start to desync from
each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.

Please note that mouse configurations will vary on different target operating
systems. Consult your OS guidelines for further details. Also note that
intelligent mouse synchronization does not work with UNIX targets.
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Video Menu

Refresh Screen

The Refresh Screen command forces a refresh of the video screen. Video
settings can be refreshed automatically in several ways:

e The Refresh Screen command forces a refresh of the video screen.

e The Auto-Sense command automatically detects the target server's video
settings.

e The Color Calibration command calibrates the video to enhance the colors
being displayed.

e In addition, you can manually adjust the settings using the Video Settings
command.

>  To force a refresh of the video screen:
e Choose Video > Refresh Video.
File ~ USB Profile ~ nput - Video ~ View ~

BRAEE KEEQ Orrhsen +——

Ed Screenshot

D Auto Sense

® Color Calibration

B \Video Settings

<& Clear Video Settings Cache

Screenshot

Take a screenshot of a target server using the Screenshot command.

> To take a screenshot of the target server:

1. Choose Video > Screenshot.
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2. The screenshot file appears as a download to view or save. Exact options
depend on your client browser.

File ~ USB Profile ~ Input ~ Video ~ View ~
Help ~ B Refresh Screen
2 ralE Ed Screenshot ¢——
S hESE REBEA ;T
E? & Color Calibration
’ ‘ B<\/ideo Settings
Security

‘Configuration <& Clear Video Settings Cache
. Wizard

CyberLink
PowerDVD =

»

Desktop Size is 1024x768 “= 2 BNUMS CAPS SCRL
B screenshot 14785..png ~ d—— Show all X
Auto Sense

The Auto Sense command forces a re-sensing of the video settings, such as
resolution and refresh rate, and redraws the video screen.

» To automatically re-sense the video settings:
e Choose Video > Auto Sense .
A message stating that the auto adjustment is in progress appears.

File - USB Profile ~ Input - Video ~ View « Help ~

a h @ @ “ @ B Refresh Screen

&dl Screenshot

D Auto Sense 4——

& Color Calibration

B \Video Settings

<& Clear Video Settings Cache

Auto adjustment in progress
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Color Calibration

The Color Calibration command optimizes the color levels, such as hue,
brightness, and saturation, of the transmitted video images.

The color settings are on a target server-basis.

Note: When color is successfully calibrated, the values are cached and reused
each time you switch to the target. Changes to the brightness and contrast in
Video Settings are not cached. Changing resolution resets the video to the
cached values again. You can clear the cached values in Video > Clear Video
Settings Cache. See Clear Video Settings Cache (on page 49).

P To calibrate color:
e Choose Video > Color Calibration.
A message stating that the color calibration is in progress appears.
File ~ USB Profile - Input = Video ~ View =

2 Al B Refresh Screen
& h @ @ “ E @ & Screenshot
 Auto Sense
6 Color Calibration
B VVideo Settings

<& Clear Video Settings Cache

Video Settings

Use the Video Settings command to manually adjust the video settings.

» To change the video settings:
Choose Video > Video Settings to open the Video Settings dialog.

2. Adjust the following settings as required. As you adjust the settings the

effects are immediately visible:

a. PLL Settings
Clock - Controls how quickly video pixels are displayed across the video
screen. Changes made to clock settings cause the video image to
stretch or shrink horizontally. Odd number settings are recommended.
Under most circumstances, this setting should not be changed because
the autodetect is usually quite accurate.
Phase - Phase values range from 0 to 31 and will wrap around. Stop at
the phase value that produces the best video image for the active
target server.

b. Brightness: Use this setting to adjust the brightness of the target
server display.
Brightness Red - Controls the brightness of the target server display for
the red signal.

Brightness Green - Controls the brightness of the green signal.
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Brightness Blue - Controls the brightness of the blue signal.

c. Contrast Red - Controls the red signal contrast.

Contrast Green - Controls the green signal.
Contrast Blue - Controls the blue signal.

If the video image looks extremely blurry or unfocused, the settings for
clock and phase can be adjusted until a better image appears on the
active target server.

Warning: Exercise caution when changing the Clock and Phase settings.
Doing so may result in lost or distorted video and you may not be able to
return to the previous state. Contact Technical Support before making any
changes.

d. Horizontal Offset - Controls the horizontal positioning of the target
server display on your monitor.
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e. Vertical Offset - Controls the vertical positioning of the target server

display on your monitor.

PLL Settings

Chack 1344

Phase 20

Color Settings

Brighiness Red
Brighiness Green
Erightness Blue
Contrast Red
Contrast Grean
Contrast Blue
Herizantal Offset

Vertical Offeet

¥ Automatic Color Calibration

Video Sensing

85

68

70

288

35

*= Eest possible video mode

Quick senze video mode

Video Settings

1026

1844

3

127

127

127

127

127

127

255

-TEB

m Canr_El
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Clear Video Settings Cache

You can clear the video settings cache to delete old settings that do not apply
anymore, such as when a target server is replaced. When you clear the video
settings cache, the server automatically does a video auto-sense and color
calibration. The new values are cached and reused when the target is accessed
again.

P To clear the video settings cache:
e Choose Video > Clear Video Settings Cache in the toolbar.

File ~ USB Profile ~ Input ~ Video ~ View ~

% h @ Q h @ @ B Refresh Screen

& Screenshot

@ Auto Sense

& Color Calibration

B \Video Settings

< Clear Video Settings Cache €¢—

View Menu
The View Menu contains options to customize your HKC display.

File ~ USB Profile « Input ~ Video ~ View ~
N =] EE @ Toolar
% h @ @ » - @ ﬁ [# Statusbar

¥ Scale Video

J Fullscreen

» Toolbar and Statusbar:

The toolbar contains icons for some commands. The Statusbar displays screen
resolution at the bottom of the client window.

> Scale Video:

Scale Video scales your video to view the entire contents of the target server
window in your HKC window. The scaling maintains the aspect ratio so that you
see the entire target server desktop without using the scroll bar.

>  Fullscreen:

Fullscreen sets the target window to the size of your full screen, removing your
client from the view.

e  Press Esc to exit fullscreen.
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Tools Menu

The Tools menu contains options for HKC target connection settings.

Tools = Virtual Mec

/ Client Settings
/ Launch Settings
© Touch Settings

P>  Client Settings:

Choose Tools > Client Settings to access the Disable Menu in Fullscreen
option.
When selected, the menu bar will not be available in fullscreen mode. This

setting is specific to the client, so it must be set for each client device and
each browser used for access.

Client Settings

|/ Disable Menu in Fullscreen

m Cancel
o

102
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v

Launch Settings:

Tap Tools > Launch Settings to access the Enable Scale Video option. When
enabled, target video scales to the current KVM window size.

»  Touch Settings - enabled for iOS clients:

Tap Tools > Touch Settings to access the Client Touch Settings. Customize
the Touch Input and Gesture Scrolling settings for your mobile device.

Client Touch Settings

Touch Input

Double Click Time (ms)
250 O 750

Mouse Click Hold Time (ms)
250 ‘0 750

(Juse Left Hand Mouse

Gesture Scrolling

(JEnable Inverted Scroll x-Axis

(JEnable Inverted Scroll y-Axis

m CHHCE!

= Double Click Time: Time between two touch taps for the equivalent of
a mouse double click.

= Mouse Click Hold Time: Time to hold after touch down for the
equivalent of a mouse right click.

= Use Left Hand Mouse: Enable if the target OS's primary mouse button
is set to Right.

= Enable Inverted Scroll x-Axis: If selected, two-finger movement to the
right moves the screen to the left instead of the default right.

= Enable Inverted Scroll y-Axis: If selected, two-finger movement up
moves the screen down instead of the default up.

Virtual Media Menu

Due to browser limitations, HKC supports a different set of virtual media
functions than the other KVM Clients.

Due to browser resources, virtual media file transfer is slower on HKC than the
other KVM clients.
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Connect Files and Folders

The Connect Files and Folders command provides an area to drag and drop files
or folders that you want to connect to on virtual media.

Supported browsers: Chrome, Firefox, Safari

File size limit: 4GB per file

»  To connect files and folders:

Choose Virtual Media > Connect Files and Folders. Or, click the matching
icon in toolbar.

m

File - USB Profile de ViEw w Virtual Media ~ Audio -

file = nput = Video ~
ﬁ h m @ ﬁ E @ Lﬂ k}_" B connect Files and Folders 44—

@ Connect IS0

2. Drag files or folders onto the Map Virtual Media Files and Folders dialog.
Click OK.

Map Virtual Media Files And Folders
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A message appears to show virtual media is connected. After a short time,

a VM drive containing the selected files or folders will be mapped to the

target server.

File ~ USB Profile ~ Input ~ Video ~ View ~ Virtual Media ~

ShREE CEEQ V0O @i

Vm connection
established

To disconnect files and folders:

Choose Virtual Media > Disconnect Files and Folders. Or, click the matching
icon in the toolbar.

File = JSB Profile - nput « Vide View - Virtual Media ~ Audio -

B pisconnect Files and Folders —
@ Connect ISO —

Connect ISO

The Connect ISO command maps a virtual media image file to the target. You
can connect to ISO, DMG or IMG files from your client PC or to ISO files from a
remote server.

Note: If connection to your SAMBA server is lost while transferring files from
your image file to the target, keyboard and mouse control will be lost for
several minutes, but will recover.

»

To map virtual media image files:

Choose Virtual Media > Connect ISO. Or, click the matching icon in the
toolbar.

ISB Profile - nput = Video - W - Virtual Media « Audio -

File -

Lﬁ k _‘ @ Q E @ 4 | . ) B pisconnect Files and Folders

@ Connect IS0 g—— o
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2. Select the option for your file's location:

Map Virtual Media ISO Image

@ IS0 Image ¢——
[ Browse... \ No file selected.

Remote Server ISO Image <4——

= Select ISO Image if the image file is directly accessible on your client.
Click Browse, select the ISO, DMG or IMG file, and click OK. The
filename appears next to the Browse button.

@ I1SO Image

| Browse... | Raritan.iso

= Select Remote Server ISO Image for ISO files on a remote server.
Remote ISO files must be pre-configured by an administrator for the
mapping to appear here. See Virtual Media File Server Setup (File
Server ISO Images Only) (on page 33). Select the Hostname, then
select the image file from the Image list. Enter the file server's
username and password.

3. Click OK to map the selected file to the target. A message appears to show
virtual media is connected.

File = USB Profile ~ Input - Video ~ View ~ Virtual Media ~

ShEHE CBEQ DO

Vm connection
established

»  To disconnect ISO:
e Choose Virtual Media > Disconnect ISO. Or, click the matching icon in the
toolbar.

File ~ USB Profile ~ Input ~ Video ~ View ~ Virtual Media ~ Audio ~

% h @ & Q @ 14 E ] B connect Files and Folders
4

@ Disconnect ISO €——
]
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Audio Menu
The Audio menu contains audio connection and settings.

Audio quality deteriorates if multiple target connections are open. To preserve
quality, limit to four target connections open on HKC when an audio session is
running.

Note: IE does not support audio. The menu will appear grayed out.

Connect Audio

The Connect Audio command connects your playback device, selects audio
format and gives an option to mount the selected playback device
automatically when you connect to the target.

HKC connects the client PC's default audio playback device. To use a different
device, it must be set as default in the client OS.

Supported audio sample rates differ depending on your connecting device and
browser:

e On Windows Edge - 11,025, 22,050 and 44,100 Hz

e  On Mac/Windows and Linux Chrome - 11,025, 22,050 and 44,100 Hz

e On Mac/Windows and Linux Firefox only 44.1 kHz available

e On Mac Safari - only 44.1 kHz available

e Onl0S devices - only 44.1 kHz available

Note: For best quality, limit the number of audio sessions to a maximum of four
KVM sessions.

»  To connect audio:

1. Choose Audio > Connect Audio, or click the matching icon in the toolbar.

File - USB Profile ~ Input - Video ~ View - Virtual Media ~ Audio ~

ﬁ h @ ﬁ Q @ D .7 =) Connect Audio €——

/ Audio Settings
—
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2. Inthe Connect Audio Device dialog, select the Connect Playback Device
checkbox.

Connect Audio Device

Connect Playback Device

Format:

stereo, 16bit, 44 100 Hz +

I Mount selected playback device automatically on connection to target

3. Select the Format.

stereo, 16bit, 44.100 Hz
mono, 16bit, 44.100 Hz
stereo, 16bit, 22.050 Hz
mono, 16bit, 22.050 Hz
stereo, 16bit, 11.025 Hz
mono, 16bit, 11.025 Hz

4. Select the "Mount selected playback device automatically on connection to
target" checkbox to enable the option. This setting will connect audio
automatically the next time you connect to targets.

5. Click OK. A success message appears.

Audio connection
established

» To disconnect audio:

1. Choose Audio > Disconnect Audio, or click the matching icon in the toolbar.
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Audio Settings

The Audio Settings option is enabled when audio is connected. Use the Audio
Settings to set the buffer and volume.

Increasing the buffer size improves the audio quality but may impact the
delivery speed.

The maximum available buffer size is 400 milliseconds since anything higher
than that greatly impacts audio quality.

P To configure audio settings:
1. Choose Audio > Audio Settings while Audio is connected.

2. Set the Buffer and Volume using the arrows or sliders.

Audio Device Settings

Buffer Sizes (ms)

Playback 280 |+ 40 O 400
Advanced
Volume 100 |2 0 ) 100

3. Click OK.

Power Control Menu

You can power on, power off, and power cycle a target through the outlet it is
connected to.

Access the target, and then select a power control option from the Power
Control menu.

The menu option is disabled if you do not have permission for power control,
and when outlets are not associated with the port.

Using HKC on Apple iOS Devices

KX Il supports remote access to targets from Apple mobile devices with iOS
10.0 or higher, using a mobile version of HKC. Due to Apple iOS limitations, you
may notice some differences in operation. See Limitations on Apple iOS
Devices (on page 116).
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Install Certificate on Apple iOS Device

You must install a CA-signed certificate on your Apple iOS device before you
can connect to KX lll. Access is prevented if only the default certificate is
present. Depending on your browser, you may see an error such as "This
Connection is Not Private".

When creating certificates, the certificate Common name should match the IP
address/Hostname used to connect to the device.

Install both the KX IlI certificate and the CA certificate used to sign the KX Il
certificate.

Note: If you have issues launching direct or CC-SG HKC connections from 10S
devices, check that the certificate meets Apple requirements:
https://support.apple.com/en-us/HT210176

»  Toinstall the certificate on an 10S device:

1. Email the certificate file to an email account that can be opened on the iOS
device. Open the email and tap the attachment.

2:47 w LTEW
{0 2 Messages N
Nina KVITKA @
To:
[

2. The certificate downloads as a "profile" that you have to install. You can
have only one profile ready to install at a time. For example, if you
download a profile and don't install it, and then download a second profile,
only the second profile is available to be installed. If a profile is not
installed within 8 minutes of downloading it, it is automatically deleted.

To install the profile, go to Settings, then tap Profile Downloaded.

Tap install, then follow prompts as presented to verify and Install.
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247 wITEE
« Mail
Cancel Install Profile Install
ﬁ systemtest
Signed by systemtest
Not Verified
Contains Certificate
More Details
—
« Mail
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2:48 WIUEED
« Mail
Cancel Warning Install

UNMANAGED ROOT CERTIFICATE

Installing the certificate "systemtest” will add
it to the list of trusted certificates on your
iPhone. This certificate will not be trusted for
websites until you enable it in Certificate Trust
Settings.

UNVERIFIED PROFILE

The authenticity of “systemtest” cannot
be verified.

Install

A

Cancel

When complete the certificate is marked Verified. Tap Done.

W LTE® )

Profile Installed Done

A

ﬁ systemtest

Signed by systemtest

Contains Certificate

Verified "

More Details
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2:50

€ General
Available
Version
Carrier

Model

Serial Number
Wi-Fi Address
Bluetooth
IMEI

ICCID

Modem Firmware

SEID

Legal

6.

w T .

About

8 GB

1.4 (15G77)

AT&T 32.01

Certificate Trust Settings —_

112

7.

2:51 w o Tm

{ mbout  Certificate Trust Settings
Trust Store Version 2018040200

Some certificate settings are enforced by
“Management Profile

ENABLE FULL TRUST FOR ROOT CERTIFICATES

Microsoft Intune Root Certification A
Microsoft Intune Root Certification A...
systemtest

SC_Online_lssuing /
SC_Online_lssuing W,

Learn more about trusted certificates

To enable the certificate, go to Settings > General > About, then scroll all
the way down. Tap Certificate Trust Settings.

Tap the certificate that was installed earlier to enable. A warning appears.
Tap Continue to enable. The certificate slider displays green for enabled.
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2:51 wilT ® )

{ About Certificate Trust Settings

Trust Store Version 2018040200

Some certificate settings are enforced by
“Management Profile”

ENABLE FULL TRUST FOR ROOT CERTIFICATES

Microsoft Intune Root Certification A...

Microsoft Intune Root Certification A...

systemtest o |

Root Certificate
Warning: enabling this certificate for SC_Online_lssuing

websites will allow third parties to view
SC_Online_lssuing o

any private data sent 1o websites.
Learn more about trusted certificates

Cancel Continue

Touch Mouse Functions

Use the touchscreen equivalent for each mouse function. Some touch settings
are configurable. See Tools Menu (on page 102).

Single Finger Touch Mouse Equivalent
touch down - move - release move mouse pointer
short tap left click

double short tap left double-click

short tap - touch down - hold for 250ms ~ mouse equivalent of Right Click"

short tap - touch down - move - release hold down left mouse button and
move, as in drag and drop or select

Two Finger Touch Mouse Equivalent

touch down - move - release move screen
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Keyboard Access on Mobile

Keyboard access to the target is through a virtual keyboard, available on the
toolbar. For all other actions requiring keyboard input, the 10S popup keyboard
displays automatically.

Manage HKC iOS Client Keyboard Macros

The HKC iOS client includes a list of default macros. You can create additional
macros using the HKC Macro Editor or import macros from a file. See Macro
Editor (on page 86) and Import and Export Macros (on page 91).

Note: To import macros when using an Apple iOS device, first export the file
from HKC using a PC client. Add the file to a Cloud location to access from the
10S device for import.

Tools Menu

The Tools menu contains options for HKC target connection settings.

Tools Virtual Mec

/ Client Settings
/ Launch Settings
O Touch Settings

P Client Settings:
e Choose Tools > Client Settings to access the Disable Menu in Fullscreen
option.

e When selected, the menu bar will not be available in fullscreen mode. This
setting is specific to the client, so it must be set for each client device and
each browser used for access.

Client Settings

Disable Menu in Fullscreen

m Cancel
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»  Launch Settings:

e Tap Tools > Launch Settings to access the Enable Scale Video option. When
enabled, target video scales to the current KVM window size.

»  Touch Settings - enabled for iOS clients:

e Tap Tools > Touch Settings to access the Client Touch Settings. Customize
the Touch Input and Gesture Scrolling settings for your mobile device.

Client Touch Settings

Touch Input

Double Click Time (ms)
250 O 750

Mouse Click Hold Time (ms)
250 ‘0 750

(Juse Left Hand Mouse

Gesture Scrolling

(JEnable Inverted Scroll x-Axis

(JEnable Inverted Scroll y-Axis

ﬂ CHHCE!

= Double Click Time: Time between two touch taps for the equivalent of
a mouse double click.

= Mouse Click Hold Time: Time to hold after touch down for the
equivalent of a mouse right click.

= Use Left Hand Mouse: Enable if the target OS's primary mouse button
is set to Right.

= Enable Inverted Scroll x-Axis: If selected, two-finger movement to the
right moves the screen to the left instead of the default right.

= Enable Inverted Scroll y-Axis: If selected, two-finger movement up
moves the screen down instead of the default up.
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Limitations on Apple iOS Devices

Mobile access with iOS devices is supported for several Raritan products. Not
all limitations apply to all products. Differences are noted.

Target connections are closed after about one minute if the browser is in
background, or if your iOS device enters Auto Lock mode

Unable to create Macros for some special characters: F1-F12, ESC, Control,
Alt, OS Meta keys and others. A selection of commonly used keys are
available in the default Macro list. These keys can be edited. Additional
keys such as F1-12 and arrows can be added using a Macro Import.

In Safari on i0OS, must refresh the connection to device after a KVM or
Serial target launch in order to access menu options or serial targets. Not
needed in Chrome on iOS.

iOS does not support auto connect audio device to targets.

On Ubuntu 14.04 target, no response to mouse click and hold on target
items to simulate right clicking.

Dual Target connection issues: Both target windows have to be closed
separately. Only 1 port of a Dual target opened from Safari on iOS 11.x
devices. (Dual targets not supported on KX4-101).

Options "FullScreen" and "Resize window to fit screen" are not
enabled/available on iOS.

KB locale from the Client Virtual Keyboard must match input locale of
device and OS locale of the target.

iOS client target window does not have scrollbars. Unscaled video can be
scrolled horizontally/vertically by sliding two fingers left/right or up/down.
See Touch Mouse Functions (on page 113).

On Safari, users are prompted to save passwords when switching from a
target with a server VM connection to another target. These prompts can
be turned off by unchecking the box "Usernames and passwords" in
Safari > Preferences > AutoFill.

On Safari, the onscreen keyboard includes word forecast. Selecting a
forecast word adds a space at the end. For example, at login screen,
selecting "admin" enters "admin ". Similar behavior occurs for VM File
server Username and other areas.

Cannot move menu option panels such as Connection Info.

iOS On-Screen keyboard is displayed from all mouse clicks on the HTML
admin page if keyboard "Go" is tapped to save setting changes instead of
tapping the Save button.

For DSAM targets opened from iOS clients, every time a menu item is
selected and closed the on-screen keyboard is displayed.

VKC login occurs when refreshing login page after a reboot. This causes
target connections to fail. To restore mobile HKC login, logout and enter
the KX Il IP or hostname again. Issue is applicable to both iOS and PC
Clients.
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The VM Files and Folders Option from the Virtual Media menu is disabled
as not possible to drag and drop files to panel.

Not all Accented letters are processed from iOS client.

Macro files exported from iOS devices using Safari are automatically given
the name "unknown" and need to be renamed with an xml extension to be
imported to another client.

Macro file export from Chrome on iOS devices is not possible due to issues
with downloading data.

Only characters support by target will be processed. There is no response
from iOS characters such as ¥, § and ... that are found on iPad keyboards.
With the onscreen keyboard, selecting ' character or "Return" key, brings
keyboard display back to first in list.
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Serial Access With Dominion Serial Access
Module

uejuey M———

E‘:[ .
[‘:[ .

T-HYSO

Connecting a KX Ill and a Dominion Serial Access Module (DSAM) provides
access to devices such as LAN switches and routers that have a RS-232 serial
port.

The DSAM is a 2- or 4 port serial module that derives power from the KX II1.

Connect a maximum of 2 DSAM modules to the KX Il using USB cables. DSAM
can be mounted in a OU configuration.

In This Chapter

CONNECE DSAM ... et e e e s 118
VieW DSAM SErial POIS ..cciiuiieiiiiie ettt st 122
Configure DSAM Serial POITS ....ccoiiiiiiiiee e e e 122
Configure Serial Port KEyWord LiSt ........cceeeeeciiieeieeeicciiiieee e 125
Upgrade DSAM FIrMWAIE ......uuvieieeeieeciieeeee e eeeciitee e e e e eeeeiaee e e e e e e eentnaeeeaeeeennnens 126
Supported CLI COMMANGS ....eeeiviieeeiiiie et e et e e eaee e e srre e e e sre e e e anees 127
Browser Tips fOr HSC .....uviiiiiiie ettt et e e e e et ee e 131
Connect to DSAM Serial Targets in Port Access Page.....cccccoecuveeevciveeeecvveeennen, 131
Connect to DSAM Serial Target with URL Direct Port ACCESS .......ccvvveeeurvreennen. 132
Connect to DSAM Serial Target via SSH......ccuviiiiiiiiicceeee e 133
HTML Serial Console (HSC) Help c...ueii i 133

Connect DSAM
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1. Connect the DSAM unit's USB cable to the TOP USB port on the rear of KX
11l device. Additional DSAM units can be added at any other USB port.
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2. Connect the serial devices to the serial ports on the DSAM unit.

Serial Devices Serial Devices
Cath
Connections
DSAM-4 DSAM-4
UsSB
Connections
At-the-Rack

Serial overIP

DSAM LED Operation
The DSAM unit has one LED for status, and 2 LEDs on each port.

Raritan DSAM-4

©

Status 1 2 3 & .

g—'F@fﬁfﬁTfﬁT
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P> Status LED:

The Status LED is labeled on the unit front. Light is on back. The Status LED
gives information at bootup and upgrade.

e Green LED - Slow blink: DSAM booting up but not controlled by KX IlI.
e Blue LED - Slow blink: DSAM controlled by KX III.
e  Blue LED - Fast blink: Firmware upgrade in progress.

> USB Port LEDs:
Each USB port has a left Green LED and a right Yellow LED.

e Green LED: Port is set as DCE
e Yellow LED: Port is set as DTE
e LEDs off: Port is set as AUTO
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Supported USB Device Combinations

Each USB device draws from a fixed pool of USB resources. There are limits on
the number of USB devices that can be connected to the KX Il at the same
time.

The following device combinations are supported for all KX Il hardware
versions.

If you have the latest 2020-released KX lll hardware, which have a hardware
revision number beginning with A or higher, the USB-combination in the last
column is supported. Older hardware revision numbers begin with 0-9. To
check your hardware version: Go to Maintenance > Device Information >
Hardware Revision number.

4-Port DSAM X X X
4-Port DSAM X X X X
2-Port DSAM X X X

2-Port DSAM

Keyboard and X X X X
Mouse

SmartCard X X X
Wireless Modem X X X X
DSAM Ports 8 6 6 4 2 8
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View DSAM Serial Ports

When a DSAM unit is connected to the KX Ill, a new tab is available in the Ports
page. The View by Serial tab shows all connected serial ports.

|

Status Availability
4 v DSAM4 Back Top DSAM up
41 DSANM4 Port 1 DCE up idle
42 DSAM4 Port 2 AUTO down idle
43 DSAM4 Port 3 AUTO down idle
4.4 DSAM4 Port 4 AUTO down idle
I * 32 Rows per Page

»  To view DSAM serial ports:
In the Port Access page, click the View By Serial tab.

e Ports are listed by physical USB position on the DSAM unit.
e USB Port column indicates which KX 1l USB port DSAM is plugged into.
e Type column indicates port's DTE/DCE setting.

122

Configure DSAM Serial Ports

The serial port configuration options are available when a DSAM unit is
connected.

P To configure DSAM serial ports:
1. Choose Device Settings > Serial Port Configuration.

2. Click the Port Name for the port you want to configure.

| Home = Device Seftings = Serial Port Configuration I

Serial Port Configuration

41 DSANM4 Port 1 —fet

42 DSAM4 Port 2 AUTO
43 DSAM4 Port 3 AUTO
4.4 DSAM4 Port 4 AUTO

3. The Port Type is set to Serial only.

4. Enter a meaningful name for the serial target or leave the default name.

Type:
Serial

Name:
DSAMA Port 1
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Power Association

If an outlet is connected to the same server that the port is connected to, a
power association can be made with the target device.

A port can have up to four associated outlets, and you can associate a different
rack PDU (power strip) with each. From this page, you can define those
associations so that you can power on, power off, and power cycle the server
from the Port Access page.

To use this feature, you need Raritan remote rack PDU(s).

1. Select the Power Strip Name and associate a name with each of the power
strip's outlets by selecting from the Outlet Name drop-down.

2. Click OK. A confirmation message is displayed.

Power Strip Name Outlet Name
Powerstrip : MNew outlet? :
Powerstrip | | Outlet 2| v |
Powerstrip | w | Cutlet 3| |
Powerstrip | v | Qutiet 4| v |

Serial Port Settings
Configure the remaining port settings.

1. Select the terminal emulation type from the drop-down menu in the
Emulation field. This is the terminal emulation mode used to match the
serial targets connected to the ports.

= VT100
= VT220
= VT320
= ANSI

2. Set Encoding if you want to always use a specific character encoding for
this port. Encoding overrides the global setting for the port to whatever
value you set.

= DEFAULT

= US-ASCI

= |SO8859-1
= |SO8859-15
= UTF-8

= Shift-JIS

= EUCJP

= EUC-CN

= EUC-KR

3. Inthe Equipment Type field, indicate whether you want the KX Ill to
automatically detect a physical connection to the target. The default is
Auto Detection.
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0 N o Wu

10.

11.

12.

13.

14.

15.

Force DTE causes KX Il to act as a piece of data terminal detection
equipment to detect targets connected to it.

Force DCE causes KX Ill to act as a piece of data communications
equipment to detect equipment connected to it.

Note: If the target has the ability to autodetect either DTE or DCE, you must
select either Force DTE or Force DCE for the port. KX Ill does not support
autodetection of both DCE and DTE on the same port.

Select the value of Bits Per Second (BPS) from the BPS drop-down menu.

= BPS options: 1200, 1800, 2400, 4800, 9600, 19200, 38400, 57600,
115200, 230400

Select the Parity/Bits from the Parity Bits drop-down menu.
Select the Flow Control from the Flow Control drop-down menu.
Select the Stop Bits from the Stop Bits drop-down menu.

If you need to configure the delay between when individual characters are
sent via the port, enter the time in milliseconds in the Char Delay field.

To configure the delay between when lines of text are sent via the port,
enter it in the Line Delay field.

Configure the sendbreak duration by entering the send break time in the
Send Break Duration field. The send break is configurable from Oms -
1000ms.

Select an option to allow single or multiple writers on a port at one time in
the Multiple Writers field.

Select Always Active if you want to log activities coming into a port even if
no user is connected.

The default option is to not maintain port access without a connected user,
which means ignore data coming into a port when no user is connected.

This option is for port data logs.

Note: When no users are logged into a port session, port traffic, by default,
is discarded .

If you do not want messages displayed to users connecting to KX Il via
Direct Port Access, select the Suppress Message checkbox.

Select the Escape Mode.

The escape sequence affects only the CLI. When entering the escape mode,
the user is given a menu of commands that can be performed (for example,
gethistory, power commands, and so on), a command to return to the port
session, and a command to exit the port connection.

The default is None.
Change as follows:
= Select control from the drop-down menu in the Escape Mode field.

Type the character in the Escape Character field. The default for the KX 111
is ] (closed bracket).
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Raritan recommends that you do not use [ or Ctrl-[. Either of these may
cause unintended commands, such as invoking the Escape Command
unintentionally. This key sequence is also triggered by the arrow keys on
the keyboard.

16. Type a command in the Exit Command field, such as 1ogout.

This is the command that is sent to your system when a user with write
permission disconnects from the port.

The main function of this command is to ensure that the user's session on
the target machine is closed; however, it is not imperative to have an Exit
command configured on a port.

17. Click OK.

Apply Settings to Other Ports
Once finished, you can apply the same port settings to other ports.

1. Select the ports from the Apply Serial Port Settings To Other Ports section
of the page.

2. Click OK to apply the port configuration settings.

Configure Serial Port Keyword List

Port keywords work as a filter. If a keyword is detected, a notification is sent to
the following:

e Audit Log

e Syslog Server (if configured)

e SNMP (if configured)

e  SMTP (if configured)-

This feature is useful for notifying administrators if a particular event occurs on
a port.

For keywords to trigger when no users are connected to a port, "Always Active"
must be selected on the port's Port Configuration page.

A list of existing port keywords is displayed on the Port Configuration page as
well.

»  To configure serial port keywords:

Choose Device Settings > Serial Port Keyword List. The Serial Port Keyword
List page opens.

Click Add at the bottom of list on the page. The Keyword page opens.
Type a keyword in the Keyword field.

Select the Port(s) you want to associate with that keyword.

Click Add to add them to the Selected box.

Click OK.

o vk W
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Upgrade DSAM Firmware

DSAM firmware is upgraded automatically during KX Il device firmware
upgrades if a new DSAM version is detected in the device firmware. You can
also upgrade your DSAM firmware manually.

»  To upgrade the DSAM firmware manually:
Choose Maintenance > DSAM Firmware Upgrade.

2. Select the checkboxes for the DSAM units you want to upgrade to the
Upgrade DSAM Version listed.

Click Upgrade, then click OK to confirm. A progress message appears.

4. When firmware upgrade completes, a success message appears.
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Supported CLI Commands

Raritan.
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Port Connect Commands

Connect to a serial port using port number or port name. Use double quotes
around port names that contain space symbols. For example: "DSAM Port 1".

admin > connect <port number>

admin > connect <port name>

»  Port number example:

admin > connect 1.1

»  Port name example:

admin > connect "DSAM Port 1"

Port Sub-Menu Commands

The port sub-menu can be reached using the escape key sequence.

Clear history buffer for this port.

admin > [portname] > clearhistory

Close this target connection. When a target is disconnected, the appropriate
disconnect message appears.

admin > [portname] > close, quit, g

Display the history buffer for this port.

admin > [portname] > gethistory

Get write access for the port.

admin > [portname] > getwrite

Return to the target session.

admin > [portname] > return

Send a break to the connected target.

admin > [portname] > sendbreak

Lock write access to this port.

admin > [portname] > writelock

Unlock write access to this port.

admin > [portname] > writeunlock

Query Power status of this port.
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Command
listports

Command

config port

admin > [portname] > powerstatus

Toggle Power On/Off of this port.

admin > [portname] > powertoggle

Power on the target.

admin > [portname] > poweron

Power off the target.

admin > [portname] > poweroff

Power cycle the target.

admin > [portname] > powercycle

Description

List accessible ports

Description

Configure Ports Commands

Enter admin > to access the menu.

Parameters
NA

Enter admin > config > port toaccessthe menu.

Parameters

port <number | range | *> - Single port or
range of ports (1-n or 1,3,4 or * for all ports)

name <port name> - Port name

bps <1200 | 1800 | 2400 | 4800 | 9600 | 19200
| 38400 | 57600 | 115200 | 230400> - Port
speed in bits-per-second

parity <none|even|odd> - Port parity type
flowcontrol <none |hw|sw> - Port flowcontrol
type hw = hardware flow control sw =X on/X
off)

eqtype <auto|dte|dce> - Equipment type
(auto=>AUTO Detection, dte=>Force DTE,
dce=>Force DCE)

Note: If the target has the ability to autodetect
either DTE or DCE, you must select either Force
DTE or Force DCE for the port. KX Il does not
support autodetection of both DCE and DTE on
the same port.

escapemode <none|control> - Use Ctrl-key
(escapemode=control) or single key
(escapemode=none) as escape sequence; for
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Parameters
example, Ctrl- =>escapemode=control,
escapechar= escapechar char-Escape
character

= Raritan recommends that you do not use or

Ctrl- as the Escape command. Either of these

may cause unintended commands, such as

opening a menu, instead of invoking the Escape

Command.

= emulation <vt100 | vt220 | vt320 | ansi> -
Target Emulation type

= sendbreak <duration>- Duration of the
sendbreak signal in milliseconds.

= exitstring <cmd #delay; > - Execute exit string
when port session closes, for example, config
port 1 exitstring logout (execute logout on exit)
config port 1 exitstring #0 (disable exit string for
the port). The delay is the amount of time to
wait after writing the command to the target.

Number in seconds up to 60.
= alwaysactive <true | false> - Determine

whether data coming into a port is logged, for

example, config port 1 alwaysactive true

(always log activities coming into a port even if
no user is connected) config port 1 alwaysactive
false (ignore data coming into a port when no

user is connected)

= suppress - Determine whether none or all
messages should be displayed during a DPA

connection, such as "Authentication successful"

= encoding - Target Encoding type

(DEFAULT | US-ASCII|1SO-8859-1|1SO-8859-15 | U

TF-8| Shift-JIS|EUC-JP| EUC-CN | EUC-KR)

=  multiwrite - Port set in Multiple Writer Mode.

= chardelay delay - Delay inserted between
writing characters (0-9999ms)

= linedelay delay - Delay inserted between
writing lines (0-9999ms)

= stopbits - Number of bits used to signal the end

of a character (usually 1) (1/2)

= stopbits <1/2> -Number of bits used to signal

the end of a character

= chardelay - Delay inserted between characters

(0-9999) in ms
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Command

Description Parameters

= Jinedelay - Delay inserted between lines
(0-9999) in ms

= escapechar - Escape character

= encoding -
<DEFAULT/US-ASCII/ISO-8859-1/1SO-8859-15/U
TF-8/Shift-JIS/EUC-JP/EUC-CN/EUC-KR> - Target
encoding type

= multiwrite <true/false> - Port set in multiple
writer mode

= suppress <true/false> - Suppress SX messages
when connecting to this target(true/false)

= sendbreak - Duration of sendbreak signal in ms

Command Line Interface Shortcuts

Press the Up arrow key to display the last entry.
Press Backspace to delete the last character typed.

Press Ctrl + C to terminate a command or cancel a command if you typed
the wrong parameters.

Press Enter on your keyboard to execute the command.

Press Tab on your keyboard to complete a command. Tab also completes
parameters and values (if the value is part of an enumerated set).

Command Line Interface High-Level Commands

The CLI is menu based. Some commands move to a menu with a different
command set.

The following common commands can be used at all levels of the command
line interface (CLI):

top - Return to the top level of the CLI hierarchy, or the username
prompt.

history - Displays the last 200 commands the user entered into the KX
11l CLI.

logout - Logs the user out of the current session.
quit - Moves the user back one level in the CLI hierarchy.

help - Displays an overview of the CLI syntax.
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Supported Escape Key Characters
The default escape key is CTRL ]

The following characters are supported for customized escape keys.

A-Z
a-Z
(]
{}

N

Browser Tips for HSC

Some browsers have limitations that affect HSC.

Internet Explorer has an internal limitation on the number of websockets
that are allowed to be created to a single server (6). This can be changed
by modifying a registry variable as shown here :
https://msdn.microsoft.com/en-us/library/ee330736(v=vs.85).aspx#webso
cket_maxconn.

Internet Explorer 11, Safari, and Edge have a limitation when connecting to
IPv6 devices. Using the numerical URL will not work when it attempts to
establish a websocket connection. In these browsers, use the device
hostname or literal IPv6 as UNC to connect to the SX II. See
https://en.wikipedia.org/wiki/IPv6_address#Literal_IPv6_addresses_in_UN
C_path_names

When using HSC in 10S Safari, the keyboard may not appear in some pages
if the "request desktop website" setting is enabled. To change the setting,
go to Settings > Safari >Request Desktop Website, then make sure All
Websites is not selected, and the device address is not selected. You can
also set this per address by clicking the "aA" in Safari's URL pane when
connected to the HSC port, then select "Website Settings" and make sure
that "Request Desktop Website" is not selected.

Connect to DSAM Serial Targets in Port Access Page

Raritan.
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»  To connect to DSAM serial targets:

1.

In the Port Access page, click the View By Serial tab to view the serial
targets.
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2. Click the port name you want to connect to. Click Connect.

Availability

4 v Front DSAM up
4.1 DCE up idle
42 DSAM4 Po AUTO down idle
4.3 D5ANM4 Port 3 AUTO down idle
4.4 DSAM4 Port 4 AUTO down idle

32 Rows per Page | set

3. The HTML Serial Console (HSC) window opens. See HTML Serial Console
(HSC) Help (on page 133)

Raritan HTML Serial Console : DSAM3 ... = O X

A | https://192.168.59.100/hsc_js/hsc_js.htm[?port=301&Ses

EMULATOR EDIT TOOLS POWER HELP

Successfully Connected!

4. To exit the serial port, hit the hot-key. Default hot key is
Scrolllock-Scrollock.

Connect to DSAM Serial Target with URL Direct Port Access
1. Choose Device Settings > Device Services, then select the Enable Direct
Port Access via URL checkbox.
2. To connect with direct port access, type the URL:

"https://<IP Address>/dpa.asp?port=<serial port
number>&username=<user name>&password=<password>"

Example:

https://192.168.51.101/dpa.asp?port=1.4&username=admin&password=r
aritan0
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3. HTML Serial Client (HSC) launches and connects to the serial target.

Connect to DSAM Serial Target via SSH
1. Choose Device Settings > Device Services, then select the Enable SSH
checkbox.
2. Launch SSH client in client PC to connect to KX IlI.
After login, user will enter CLI interface.

4. Type command "connect <serial port number>", or type command
"connect <name of serial port>".

Example-1: connect 4.1

Example-2: connect "DSAM4 Port1"

If successful, serial target is accessed.

6. To exit serial target, type escape-key-sequence, default is Ctrl-], then enter
port sub-menu CLl interface.

7. Type "quit", then enter main CLI interface.

HTML Serial Console (HSC) Help

You can connect to serial targets using HSC. HSC is supported with several
Raritan products that offer serial connections. Not all products support all HSC
features. Differences are noted.

Raritan HTML Serial Console : DSAM3 ... = O X

A | https://192.168.59.100/hsc_js/hsc_js.htmI?port=301&Ses

EMULATOR EDIT TOOLS POWER HELP

Successfully Connected!
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HSC Functions
KX4-101 does not support power functions in HSC.

Emulator

IMPORTANT: HSC sessions are affected by the KX Il Idle Timeout.

If you have not changed the KX Il Idle Timeout setting from the default, your
session could be closed automatically if it exceeds the Idle Timeout period.

Change the default Idle Timeout setting and then launch the HSC. See Login
Limitations for details on changing the Idle Timeout setting.

Access Emulator Options

1. Select the Emulator drop-down menu to display a list of options.

EMULATOR EDIT TOOLS POWER HELP
Settings bd !
Get History

Clear History

Get Write Lock
Write Unlock
Send Break
Reset Port

Connected Users...

Settings
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Note:

KX3 administrators can set Terminal emulation settings in Setup > Port
Configuration.

KX4-101 administrators can set terminal emulation settings in DSAM Serial
Ports > Settings.

1. Choose Emulator > Settings. The Terminal Properties dialog displays the
default settings.

Terminal Properties

Columns: |80 s Rows:

Foreground: - Background: -

Font size: 11 Scrollback: 1000 v
Encoding:  utf-8 v Language: English ~

Backspace Sends: Ctrl-H -

oK Cancel

2. Set the terminal size by selecting the number of Columns and Rows.
Default is 80 by 25.

Set the Foreground and Background colors. Default is white on black.
Set the Font size. Default is 11.

Set the Scrollback number to indicate the number of lines available for
scrolling.

Choose one of the following from the Encoding drop-down menu:

UTF-8

8-bit ascii
I1SO-8859-1
ISO-8859-15
Shift-JIS
EUC-JP
EUC-KR

Choose one of the following from the Language drop-down menu:

English
Japanese
Korean
Chinese

Bulgarian
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8. The Backspace Sends default is ASCII DEL, or you can choose Control-H
from the Backspace Sends drop-down menu.

9. Click OK to save. If you changed the Language setting, the HSC changes to
that language when the Display Settings window is closed.

Get History
History information can be useful when debugging, troubleshooting, or
administering a target device. The Get History feature:

e Allows you to view the recent history of console sessions by displaying the
console messages to and from the target device.

e Displays up to 512KB of recent console message history. This allows a user
to see target device events over time.

When the size limit is reached, the text wraps, overwriting the oldest data with
the newest.

Notes: History data is displayed only to the user who requested the history.

To view the Session History, choose Emulator > Get History.

Clear History

= To clear the history, choose Emulator > Clear History.

Get Write Access

Only users with permissions to the port get Write Access. The user with Write
Access can send commands to the target device. Write Access can be
transferred among users working in the HSC via the Get Write Access
command.

To enable Write Access, choose Emulator > Click Get Write Access.
e  You now have Write Access to the target device.
e When another user assumes Write Access from you:
= The HSC displays a red block icon before Write Access in the status bar.

= A message appears to the user who currently has Write Access,
alerting that user that another user has taken over access to the
console.

Get Write Lock

Write lock prevents other users from taking the write access while you are
using it.

1. To get write lock, choose Emulator > Get Write Lock.

2. If Get Write Lock is not available, a request rejected message appears.

Write Unlock
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To get Write Unlock, choose Emulator > Write Unlock.

Send Break

Some target systems such as Sun Solaris servers require the transmission of a
null character (Break) to generate the OK prompt. This is equivalent to issuing a
STOP-A from the Sun keyboard.

Only users with Write Access privileges can send a break.
To send an intentional “break” to a Sun Solaris server:

1. Verify that you have Write Access. If not, follow the instructions in the
previous section to obtain write access.

2. Choose Emulator > Send Break. A Send Break Ack (Acknowledgement)
message appears.

3. Click OK.

Reset Port

Reset Port resets the physical serial port on the SX2 and re-initializes it to the
configured values regarding bps/bits, and so on.

Connected Users

The Connected Users command allows you to view a list of other users who are
currently connected on the same port.

1. Choose Emulator > Connected Users.

User List

* admin

System: Auto Naming

oK

2. Astar appears in the Write column for the User who has Write Access to
the console.

Exit

1. Choose Emulator > Exit to close the HSC.
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Copy and Paste and Copy All

Data on the current visible page can be selected for copying. Copy and Paste
are accessible in the HSC by right click in the terminal window. Select Copy or
Paste in the context menu that appears.

To copy all text, use the Copy All option in the Edit menu.

If you need to paste a large amount of data, it is better to save the data in a file
and use the Send a Text File function. Pasting a large amount of data in a
browser windows can cause the browser to hang as it processes the data. See
Send Text File (on page 138).

When pasting data to a port, the end of a line is sent as a carriage return.
The Cut option on the right-click menu is disabled.

Do not use the Delete option that appears in the right-click menu of IE and
some versions of Firefox. This Delete option will remove display lines entirely
from the emulator window.

»  Browser-specific behaviors

When copying from IE or Edge browsers, there are no end of line characters in
the copied data. The pasted data appears to be all in one line and contains
many spaces. When pasting back into a HSC window, the data may appear to
be misaligned, but the data is complete.

Send Text File

1. Select Edit> Send Text File.
2. Inthe Send Text File dialog, click Browse to find the text file.
3. Click OK.
=  When you click OK, the selected file sends directly to the port.
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= |fthereis currently no target connected, nothing is visible on the

screen.
Send Text File
Browse... | No file selected.
OK Cancel
| File Upload [i_&
@ Q | » SX2 TextFile - Search SX2 Text File p
Organize ~ New folder = - O 9‘
- Favorites *  Name Date modified Type
B Desktop | SX2.txt 6/13/2016 5:03PM  Text Doc

4 Downloads

% Dropbox

m

[ «» Recent Places

] Libraries

*. Documents

4 Music
= Pictures
&Videos
v 4 1 | 3
File name: SX2.txt v |All Files v|
[ Open ‘VI l Cancel l

Note, if you are using a Mac® and/or Safari®, do the following in order to
use this feature:

In Safari, select Preferences.

Under the Security tab, select "Manage Website Settings"
Click on the KX Il website.

Select "Run in unsafe mode" from the drop-down box.

Restart Safari.
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Tools: Start and Stop Logging

The Tools menu contains options for creating a data history file and
downloading it.

1. Choose Tools > Start Logging to start the storage of serial port data in
memory.

2. Click Stop Logging to save the log file. A pop up message appears with a
download link. Click to download the memory buffer into a text file.

EMULATOR EDIT TOOLS POWER HELP

Successfully Connected!

Save Log File

Click Here to Download

OK

Write Access Encoding: utf-8 Term Size: 80 x 25

Power Status

Power Status in HSC shows the status of the outlet the target is plugged into.
1. Choose Power > Power Status.
2. The Notification dialog shows the status of the outlet as ON or OFF.
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Status may also show no associated outlet, or no power permission to the
port.

Notification

192.168.61.142(1) Power
Status : Off

OK

' Notification P

Port has no associated
outlets, or user does not
have power permission on
this port.

Power on a Target

Use this option to power on a target from HSC.

This option is visible only when there are one or more power associations to
the target, and when you have permission to manage the target's power.

1. Select Power> Power On.
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2. Click OK in the success message.

Notification

Power operation succeeded.

oK |

Power Off a Target

Use this option to power off a target from HSC.

This option is visible only when there are one or more power associations to
the target, and when you have permission to manage the target's power.

1. Select Power> Power Off.

2. Click OK in the success message.

Notification

Power operation succeeded.

oK |

Power Cycle a Target

Power cycling allows you to turn a target off and then back on through the
outlet it is plugged into.

This option is visible only when -

e there are one or more power associations to the target

e the targetis already powered on (the port status us Up)

e you have permission to manage the target's power

1. Choose Power> Power Cycle.

2. Click OK in the success message.
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Browser Tips for HSC

Some browsers have limitations that affect HSC.

Internet Explorer has an internal limitation on the number of websockets
that are allowed to be created to a single server (6). This can be changed
by modifying a registry variable as shown here :
https://msdn.microsoft.com/en-us/library/ee330736(v=vs.85).aspx#webso
cket_maxconn.

Internet Explorer 11, Safari, and Edge have a limitation when connecting to
IPv6 devices. Using the numerical URL will not work when it attempts to
establish a websocket connection. In these browsers, use the device
hostname or literal IPv6 as UNC to connect to the SX II. See
https://en.wikipedia.org/wiki/IPv6_address#Literal_IPv6_addresses_in_UN
C_path_names

When using HSC in 10S Safari, the keyboard may not appear in some pages
if the "request desktop website" setting is enabled. To change the setting,
go to Settings > Safari >Request Desktop Website, then make sure All
Websites is not selected, and the device address is not selected. You can
also set this per address by clicking the "aA" in Safari's URL pane when
connected to the HSC port, then select "Website Settings" and make sure
that "Request Desktop Website" is not selected.
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Chapter 7 Dominion User Station

To use a standalone appliance for remote access to KX Ill target servers instead
of using the VKC or AKC clients on a PC or laptop, purchase Dominion User
Stations from Raritan. The User Station is perfect for environments like labs,
studios and control rooms where a PC or laptop is not wanted.

This chapter provides a brief introduction to the User Station. For detailed
information, refer to the user documentation from the User Station's section
on the Raritan website's Support page (http://www.raritan.com/support/).

In This Chapter

[ Y=Y Y 1= RSN 144
User Station Photo and FEATUIES.......cccvvveiieieeeiiiieeeee ettt e 145
Operating the User Station ........c.ueeecciii e 145

Overview

The Dominion User Station (DKX3-UST) is designed to access servers and
computer devices connected to KX llI's from your LAN/WAN networks. ALL KX
I models are supported. KX Ill Release 3.2 and above is required.

One User Station can access the servers connected to multiple KX Ill's so that
you can easily access a large number of servers with a single click.

Note that the User Station does NOT support the access to a target server
which is from a tiered KX Ill or a blade server. Use VKC or AKC clients to access
such targets instead.

5SH, RDP, VNC

f—

..... -

KX 1 KvM
R - X3

KX 11l KvM

W L R B

KX IV-101 KVM
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Chapter 7: Dominion User Station

A USB Keyboard, USB mouse, and one or two HDMI- or

A DisplayPort-interfaced monitors

B Analog or digital audio appliances

c Optional smart card reader for remote IT device authentication
D External drives as virtual media, such as CD-ROM

E USB drives for virtual media or User Station software update

F Optional integration with CC-SG

User Station Photo and Features

Dominion User Station

e  Supports single or dual monitors

e Two 1080p streaming video sessions at 30 FPS
e Supports VGA, DVI, HDMI and DisplayPort video
e  Favorites and hot-key switching

e Access hundreds of servers

e Ultra-fast connections and sub-second switching with the non-blocking
DKX3-808 model

e Dual Gigabit Ethernet ports
e Self-contained, low maintenance appliance
e Desktop, rack and VESA mountable

Operating the User Station

1. Have the required equipment properly connected to the User Station.
a. Power OFF all devices.

b. Connect a USB keyboard, mouse and one or two monitors to the User
Station.

c. Connect the User Station to the LAN/WAN network.

2. Power on and log in to the User Station.
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= Forinitial login, use Raritan's default username and password: admin
and raritan.

3. Add KX IllI's data. See Logging In to KX lll (on page 14).
4. The added KX Ill's are displayed in the Port Navigator window.

e i e

Favorite Ports

5. Click a KX lll to show a list of its servers.

6. Click a target server, and a KVM Client opens, showing the target video.
Now you can control the target with the attached keyboard and mouse.

For detailed information, refer to the user documentation from the User
Station's section on the Raritan website's Support page
(http://www.raritan.com/support/).
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Chapter 8 KX 1l Remote Console

In This Chapter
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Changing @ PassWOrd ..........ueuieiiioiiiiiiiee et e e e e e ar e 151

Managing Favorites

Overview
When you log in to the KX Il using a network connection, you access the
Remote Console. The first page accessed is the Port Access page.

See Logging In to KX Ill (on page 14) and Port Access Page (Remote Console
Display) (on page 17)

Use the Remote Console to access and scan target servers, manage favorites,
and change your password.

For more in the Remote Console interface elements, see KX Ill Remote Console
Interface (on page 16).

Scanning Ports - Remote Console

Use the port scanning feature to search for selected targets and display them in
individual thumbnails as part of a slide show.

This feature allows you to monitor up to 32 targets at one time since you can
view each target server individually as it is displayed during the slide show.

Connect to targets or focus on a specific target as needed.

For dual video port groups, the primary port is included in a port scan, but the
secondary port is not included when connecting from a remote client. Both
ports can be included in the scan from the Local Port.

Note: The scan port feature is available from the Remote Console and Local
Console, but the feature varies slightly.
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Scanning Ports Slide Show - Remote Console
When you start a scan, the Port Scan window opens.
As each target is found, it is displayed as a thumbnail in a slide show.

The slide show scrolls through the target thumbnails based on the default
interval of 10 seconds or according to the interval you specify.

As the scan scrolls through the targets, the target that is the focus of the slide
show displays in the center of the page.

The name of the target is displayed below its thumbnail and in the task bar at
the bottom of the window.

If a target is busy, a blank screen is displayed instead of the target server access
page.

L2 Portscan - Virtual vMa Client S IR s R — L el

Scan Options

88 » Control Panel » Al Control Panel ems » Display » Screen Resolution

Change the appearance of your display

oslay

Resoltion: |_1-un x gno_-|

Cwientation: |Landscape

D 2 - k3 Lozal Port

B + - TLOREHEHKIT0. .

B 5 - Dominion0iz_Ports

l j L - Daminian+X2_Ports

Configure scan settings for the Remote Console in the KVM client.

Note: Scan port settings for the Local Console are configured on the Local Port
Settings page. See Scanning Ports - Local Console (on page 158)
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Target Status Indicators During Port Scanning - Remote Console

The status of each target is indicated by green, yellow and red lights that are
displayed below the target thumbnail.

As the target is the focus of the rotation, the indicator is in the task bar also
shows the status.

Lights for each target are gray until they are the focus of the slide show.
The status lights indicate the following:
e Green - the target is up/idle or up/connected

e Yellow - the target is down but connected

e Red -the target is down/idle, busy, or otherwise not accessible
) Port Scan - Virtual KvM Glient i S . - R

Wk

|'S » Cortrol Paned » Al Control Paned liems » Display » Screen Resalution

Change the appearance of your display

Dtsplay |2 Rarttan cv = el © - 03 Local Port

Resclution: |1m x 200 v|

Cwianation: |Lanﬂscw€

Bake Text Snd orhes items 1aiger of smaller
3¢

B + - T1D0E-HEHKCTI00. .

B 5 - Dominicn40Z_Forts

Di—Damhlan-KIl_Porlj [
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Using Scan Port Options
Following are options available to you while scanning targets.

With the exception of the Expand/Collapse icon, all of these options are
selected from the Options menu in the upper left of the Port Scan viewer.

The options will return to their defaults when you close the window.

Note: Configure scan settings such as the display interval from the KVM Client.

»  Hide or View Thumbnails
4
e Use the Expand/Collapse icon P atthe upper left of the window to hide
or view thumbnails. Expanded is the default view.

> Pause the Thumbnail Slide Show

e  Pause thumbnails from rotating between one target and the next by
selecting Options > Pause. Rotating thumbnails is the default setting.

»  Resume the Thumbnail Slide Show
e Resume the thumbnail rotation by selecting Options > Resume.

P Size the Thumbnails in the Port Scan Viewer
e Enlarge the size of the thumbnails by selecting Options > Size > 360x240.

e  Minimize the size of the thumbnails by selection Options > Size > 160x120.
This is the default thumbnail size.

P Change the Orientation of the Port Scan Viewer
e View thumbnails along the bottom of the Port Scan viewer by selecting
Options > Split Orientation > Horizontal.

e View thumbnails along the right of the Port Scan viewer by selecting

Options > Split Orientation > Vertical. This is the default view.
- — T T || el

| Port Scan - Virtual KVM Client

Thumbnail Size ¥
Split Qrientation
» Control Panel ¥ Al Control Paned ltems v Display » Screen Resolution

Change the appearance of your display
P )

Display B 2 -kx3 Local Port
Resalution: 1440 300 v|
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Scan for Targets

»  To scan for targets:

Click the Set Scan tab on the Port Access page.

2. Select the targets you want to include in the scan by selecting the
checkbox to the left of each target, or select the checkbox at the top of the
target column to select all targets.

3. Leave the Up Only checkbox selected if you only want targets that are up
to be included in the scan. Deselect this checkbox if you want to include all
targets, whether up or down.

4. Click Scan to begin the scan.

As each target is scanned, it is displayed in slide show view on the page.

5. Click Options > Pause to pause the slide show and stop it from moving
between targets, click Options > Resume to resume the slide show.
Click on a target thumbnail to scan it next.

Connect to a target by double clicking on its thumbnail.
Changing a Password

»  To change your KX Ill password:
Choose User Management > Change Password. The Change Password page
opens.
Type your current password in the Old Password field.

3. Type a new password in the New Password field. Retype the new password

Raritan.
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in the Confirm New Password field. Passwords can be up to 64 characters
in length and can consist of English alphanumeric characters and special
characters.

Click OK.

You will receive confirmation that the password was successfully changed.
Click OK.
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Note: If strong passwords are in use, this page displays information about the
format required for the passwords. For more information about passwords and
strong passwords, see Strong Passwords.

Home = User Management * Change Fasaword

Change Password

Old Password

Hew Password

Confirm Hew Password

OK | Cancel

Managing Favorites

A Favorites feature is provided so you can organize and quickly access the
devices you use frequently.

The Favorite Devices section is located in the lower left sidebar of the Port
Access page and provides the ability to:

e Create and manage a list of favorite devices

e Quickly access frequently-used devices

e List your favorites either by Device Name, IP Address, or DNS hostname
e Discover KX lll devices on its subnet

e Retrieve discovered KX IIl devices from the connected Dominion device

Note: Due to browser limitations, HKC does not support Favorites.

Enable Favorites

e Click Enable in the Favorite Devices section of the left panel of the KX 111
interface, below Online Help.
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Access and Display Favorites

»  To access a favorite KX Ill devices:

e (Click on a KX Il listed beneath Favorite Devices in the left of the Remote
Console.

P To display favorites by Name, IP Address or Host Name:
e Click Display by Name, Display by IP, or Display by Host Name.

Favaorite Devices:
Somerset
Tokyo
Raleigh

| Mzanage | | Display By Name |

[ Display By Host Name | [ Display By IP |

Discovering Devices on the Local Subnet

This option discovers KX Ill devices on your local subnet. This is the subnet
where the KX lll Remote Console is running.

These devices can be accessed directly from this page or you can add them to
your list of favorites.

»  To discover devices on the local subnet:

1. Choose Manage > Discover Devices - Local Subnet. The Discover Devices -
Local Subnet page appears.

2. Choose the appropriate discovery port:

= To use the default discovery port, select the Use Default Port 5000
checkbox.

= To use a different discovery port:

a. Deselect the Use Default Port 5000 checkbox.

b. Type the port number in the Discover on Port field.
c. Click Save.

3. Click Refresh. The list of devices on the local subnet is refreshed.

P> To add devices to your Favorites List:
Select the checkbox next to the device name/IP address.
2. Click Add.
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»  To access a discovered device:

e Click the device name or IP address for that device. A new browser opens
to that device.

Discovering Devices on the KX 11l Subnet
This feature is only available in the Java client , RSC.

This option discovers KX Ill devices on the device subnet. This is the subnet of
the KX Il device's IP address.

You can access these devices directly from the Subnet page or add them to
your list of favorites.

This feature allows multiple KX Ill devices to interoperate and scale
automatically.

The KX Il Remote Console automatically discovers the KX Ill devices, and any
other Raritan device, in the subnet of the KX IlI.

>  To discover devices on the device subnet:

1. Choose Manage > Discover Devices - KX lll Subnet.

Favaorite Devices:
Somerset
Tokyo
Raleigh

| Manage | | Display By Name |

[ Display By Host Name | [ Display By IP |

The Discover Devices - KX Ill Subnet page appears.

2. Click Refresh. The list of devices on the local subnet is refreshed.

P To add devices to your Favorites List:
1. Select the checkbox next to the device name/IP address.
2. Click Add.

»  To access a discovered device:

e Click the device name or IP address for that device. A new browser opens
to that device.
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Chapter 9 KX 1ll Local Console

The Local Console interface provides access to the KX Il while at the rack.

This section contains help on tasks performed by end users at the Local
Console.

In This Chapter

Accessing a Target SEIVer ..o,
Local Console Video Resolution Behavior
SIMUITANEOUS USEIS .ttt ettt ettt ettt e s e s sbte e e s nbaeesnanees
Local Port Hot Keys and CoONNECt KEYS .....cccveeeeeiiieiiiiieeciiie e eivee e
Scanning Ports - LOCal CONSOIE .....ccccvviieciiiie e e
Local Console SMart Card ACCESS ....uvereeiriiienieeriiee ettt see e
Local Console USB Profile OptioNnS.......c.ueeeecuiieeeiiiieeciieeeeiieeeeeee e e e eivee e
KX 11l Local Console FActory RESEt ......cuuvveeeeieeiiiiiiieee ettt
Resetting the KX Il Using the Reset Button

Accessing a Target Server

P To access a target server:

1. Click the Port Name of the target you want to access. The Port Action
Menu is displayed.

2. Choose Connect from the Port Action menu. The video display switches to
the target server interface.
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Local Console Video Resolution Behavior

By default, monitors are typically set to the highest resolution they support.

Once a monitor is connected to the KX Il Local Console, KX 1l detects the
monitor's native resolution. As long as the native resolution is supported by the
Local Console, KX Il uses that resolution.

If the native resolution is not supported by the Local Console, and no other
resolution is supported by the monitor and Local Console, KX Ill uses the
resolution of the last monitor that was connected to the Local Console.

For example, you connect a monitor set to a resolution of 1600x1200@60Hz to
the KX Il Local Console. KX Il uses that resolution since it is supported by the
Local Console.

If the next monitor you connect to the Local Console is not set to a supported
resolution, KX Il uses the resolution of 1024x768@60.

For a list of supported Local Console video resolutions, see KX Ill Supported
Local Port DVI Resolutions (on page 187).

Consider reviewing Video Mode and Resolution Notes (on page 214) for
additional information.

Simultaneous Users

The KX Il Local Console provides an independent access path to the connected
KVM target servers.

Using the Local Console does not prevent other users from simultaneously
connecting over the network. And even when remote users are connected to
the KX IIl, you can still simultaneously access your servers from the rack via the
Local Console.

Local Port Hot Keys and Connect Keys

Because the KX Il Local Console interface is completely replaced by the
interface for the target device you are accessing, a hot key is used to
disconnect from a target and return to the local port GUI.

A connect key is used to connect to a target or switch between targets.

The Local Port hot key allows you to rapidly access the KX Ill Local Console user
interface when a target device is currently being viewed.

See Select the Local Port Hotkey and Select the Local Port Connect Key for
more information.
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Return to the Local Console from a Target Device - Default Hot Key

e Press the Scroll Lock hot key twice rapidly

The video display switches from the target device interface to the KX Il

Local Console interface.

Local Port Auto-Sense (Video Refresh) - Default Hot Key

»  To perform an auto-sense (video refresh) on the KX Il local port via hot

key:

e Press and hold the Shift key, and quickly press the Scroll Lock key twice,

and then release.

Connect Key Examples

Standard servers

Connect key action

Access a port from the local
port

Switch between ports

Disconnect from a target and
return to the local port

Blade chassis

Connect key action

Access a port from the local
port GUI

Switch between ports

Disconnect from a target and
return to the local port GUI

Key sequence example
= Press Left ALT > Press and Release 5 > Release Left ALT

= Press Left ALT > Press and Release 1 > Press and Release 1 >
Release Left ALT

= Double-click Scroll Lock

Key sequence example

Access port 5, slot 2:

= Press Left ALT > Press and Release 5 > Press and Release - >
Press and Release 2 > Release Left ALT

Switch from target port 5, slot 2 to port 5, slot 11:

= Press Left ALT > Press and Release 5 > Press and Release - >
Press and Release 1 > Press and Release 1 > Release Left ALT

Disconnect from target port 5, slot 11 and return to the local

port GUI (the page from which you connected to target):

= Double Click Scroll Lock
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Special Sun Key Combinations

The following key combinations for Sun™ Microsystems server’s special keys
operate on the Local Console port. These special keys are available from the
Keyboard menu when you connect to a Sun target device:

Sun key Local port key combination
Again Ctrl+ Alt +F2

Props Ctrl + Alt +F3

Undo Ctrl + Alt +F4

Stop A Break a

Front Ctrl + Alt + F5

Copy Ctrl + Alt + F6

Open Ctrl + Alt + F7

Find Ctrl + Alt + F9

Cut Ctrl + Alt + F10
Paste Ctrl + Alt + F8

Mute Ctrl + Alt + F12
Compose Ctrl+ Alt + KPAD *
Vol + Ctrl + Alt + KPAD +
Vol - Ctrl + Alt + KPAD -
Stop No key combination
Power No key combination

Scanning Ports - Local Console

The scan port feature is available from the Remote Console and Local Console,
but the feature varies slightly. See Scanning Ports - Remote Console (on page
147)

Click the thumbnail of any target server to exit scan mode and connect to the
target, or use the Local Port ConnectKey sequence.

To exit scan mode, click the Stop Scan button in the thumbnail view, or use the
Local Port Hotkey sequence hot key.
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Scanning Port Slide Show - Local Console
When you start a scan, the Port Scan window opens.
As each target is found, it is displayed as a thumbnail in a slide show.

The slide show scrolls through the target thumbnails based on the default
interval of 10 seconds or according to the interval you specify.

As the scan scrolls through the targets, the target that is the focus of the slide
show displays in the center of the page.

The name of the target is displayed below its thumbnail and in the task bar at
the bottom of the window.

If a target is busy, a blank screen is displayed instead of the target server access
page.

Configure the time between the slide show thumbnail rotation and the
thumbnail focus interval on the Local Port Settings page.

See Configure Local Console Scan Settings (on page 160)

Note: Configure scan settings for the Remote Console from VKC, VKCS, or AKC.
See Configuring Port Scan Settings in VKC/VKCS and AKC (on page 60)

Connection  USE Profile Keyboard Video Mouse Tools View Vidusl Media Audic SmartCard Help

SR EEREEAD D
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Connection  USE Prefile Keyboard Video Mous= Tools View Virtual Media Audio SmartCard Help

S hEHELDEAQDDCR @ E

Welcome

Target Status Indicators During Port Scanning - Local Console

When scanning on the Local Console, the status of each target is indicated
below the thumbnail.

The scanning status of each target is displayed as:

not scanned
connecting
scanned
skipped

Configure Local Console Scan Settings

Do the following to configure Local Console scan port options.

wN e T

160

To configure the Local Console scan port settings:

On the Local Console, select Device Settings.

In the Local Port Settings section, select Local Port Scan Mode.
Change the display interval as needed:

= Display Interval - changes the scan display interval.

= |nterval Between Ports - change interval between switching different
port during scan.
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Scan for Targets - Local Console

»  To scan for targets:
Click the Set Scan tab on the Port Access page.

2. Select the targets you want to include in the scan by selecting the
checkbox to the left of each target, or select the checkbox at the top of the
target column to select all targets.

3. Leave the Up Only checkbox selected if you only want targets that are up
to be included in the scan. Deselect this checkbox if you want to include all
targets, whether up or down.

4. Click Scan to begin the scan.

As each target is scanned, it is displayed in slide show view on the page.

Local Console Smart Card Access

Raritan.
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To use a smart card to access a server at the Local Console, plug a USB smart
card reader into the KX Ill using one of the USB ports located on the KX III.

Once a smart card reader is plugged in or unplugged from the KX I, the KX 11l
autodetects it.

For a list of supported smart cards and additional system requirements, see
Supported Smart Card Readers (on page 197), Unsupported Smart Card
Readers (on page 198) and Smart Card Minimum System Requirements (on
page 195).

When mounted onto the target server, the card reader and smart card will
cause the server to behave as if they had been directly attached.

Removal of the smart card or smart card reader will cause the user session to
be locked or you will be logged out depending on how the card removal policy
has been setup on the target server OS.

When the KVM session is terminated, either because it has been closed or
because you switch to a new target, the smart card reader will be automatically
unmounted from the target server.

» To mount a smart card reader onto a target via the KX Ill Local console:

Plug a USB smart card reader into the KX Il using one of the USB ports
located on the device. Once attached, the smart card reader will be
detected by the KX 111

From the Local Console, click Tools.

3. Select the smart card reader from the Card Readers Detected list. Select
None from the list if you do not want a smart card reader mounted.

4. Click OK. Once the smart card reader is added, a message will appear on
the page indicating you have completed the operation successfully. A
status of either Selected or Not Selected will appear in the left panel of the
page under Card Reader.
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»  To update the Card Readers Detected list:

e Click Refresh if a new smart card has been mounted. The Card Readers

Detected list will be refreshed to reflect the newly added smart card
reader.

Card Readers Detected

USE SmartCard Reader (Gemplus)

QK Refresh | Cancel |

Note: If a smart card reader is selected for local port login in Security>Local
Smart Card Authentication, then that card reader cannot be selected for target
connections; it will be listed, but cannot be chosen.
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Using a Smart Card at the Local Port

When Local Smart Card Authentication is enabled, you can be authenticated by
using your smart card at the card reader connected to a KX IIl USB port.

If Local Smart Card Authentication is enabled but not required, the Login tab
remains accessible to allow for username/password login.

»  To use a smart card at the local port.

1. When the card reader is detected, the Login page shows a PIN tab.

m Local Console Port

Dominion® KX 111

Smart Card reader detected.

Insert Smart Card.

Login to DominionkKX

Username:| |

Password: |

2. Insert a card. The PIN tab opens automatically.
3. Enter the PIN and click Login.

Raritan.
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Local Console Port

Login - DominionkX

Dominion® KX il Smart Card reader detected.

Smart Card inserted.

Login to DominionKx

PIN: [

| Login

4. After successful entry of the card’s PIN, access is granted if the card
contains an authentication certificate approved by Client Certificate
Authentication. See Client Certificate Authentication Settings.

If login fails, check the Audit log for failure information.
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Local Console USB Profile Options

From the USB Profile Options section of the Tools page, you can choose from
the available USB profiles.

The ports that can be assigned profiles are displayed in the Port Name field and
the profiles that are available for a port appear in the Select Profile To Use field
after the port is selected. The profiles selected for use with a port appear in the
Profile In Use field.

»  To apply a USB profile to a local console port:

In the Port Name field, select the port you want to apply the USB profile
to.

2. Inthe Select Profile To Use field, select the profile to use from among
those available for the port.

3. Click OK. The USB profile will be applied to the local port and will appear in
the Profile In Use field.

USB Profile Options

Port Name Select Profile To Use

MNa Part Selected = Genenc

Mac O5-X (10.4.9 and later)

HP Proliant DL3I60/DL3IB0 G4 (Windows 2003 Server

Profile In Use

LI

ST ¥ W W

LR

ﬂi Il:‘lmsh| Cln::l|

l"--h-ﬂ"""h'--'ﬂ.---* b . ._"—_r.#'w.u_ R _,.._J r_h‘.\ B _Fr,.q...h ek ._._‘ ) ,\-”' ,.-n. ok }.Jﬁ._..-

KX 11l Local Console Factory Reset

Note: It is recommended that you save the audit log prior to performing a
factory reset.

The audit log is deleted when a factory reset is performed and the reset event is
not logged in the audit log. For more information about saving the audit log,
see Audit Log.

»  To perform a factory reset:

1. Choose Maintenance > Factory Reset. The Factory Reset page opens.
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2. Choose the appropriate reset option from the following options:
=  Full Factory Reset

Removes the entire configuration and resets the appliance completely
to the factory defaults.

Because of the complete nature of this reset, you will be prompted to
confirm the factory reset.

= Network Parameter Reset
Resets the network parameters of the appliance back to the default

values (click Device Settings > Network Settings to access this
information).

3. Click Reset to continue. You will be prompted to confirm the factory reset
because all network settings will be permanently lost.

4. Click OK proceed. Upon completion of full factory reset, the KX Il device is
automatically restarted.

Resetting the KX lll Using the Reset Button

On the back panel of the device, there is a Reset button. It is recessed to
prevent accidental resets (you need a pointed object to press this button).

The actions that are performed when the Reset button is pressed are defined
on the Encryption & Share page. See Encryption & Share.

Note: It is recommended that you save the audit log prior to performing a
factory reset.

The audit log is deleted when a factory reset is performed and the reset event is
not logged in the audit log. For more information about saving the audit log,

see Audit Log.

P To reset the device:

1. Power off the KX III.

2. Use a pointed object to press and hold the Reset button.

3.  While continuing to hold the Reset button, power the KX Ill device back on.
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4. Continue holding the Reset button for 10 seconds.

RESET LAN1
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Appendix A

Connecting a KX lll and Cat5 Reach DVI -
Provide Extended Local Port Functionality

An extended local port extends the reach of the local port beyond the rack the
KX 1l is located, for example to another KVM switch.

This can be achieved by configuring a KX Il to work with a Raritan Cat5 Reach
DVI transmitter and receiver, which are then connected to a remote console or
other device.

Once connected to the Cat5 Reach DVI, the KX Ill can be accessed up 500 feet
(152 m) away.

Connecting the KX lll to the Cat5 Reach DVI by daisy chaining Ethernet switches
extends can extend the KX IlI's reach up to 3000 feet (914 m).

In This Chapter

About the Cat5 ReaCh DVI .c..ccoooviiiiiiiiiiii 167
Connect Cat5 Reach DVI and Cat5 REaCh DVl.....uuuuuuuiiiiiiiciicceieccenenn 167

About the Cat5 Reach DVI

For details on the Cat5 Reach DVI, see the Cat5 Reach DVI online help available
on the Raritan Support page http://www.raritan.com/support.

Contact Raritan (http://www.raritan.com/contact-us/) for additional
information on the Cat5 Reach DVI, or for information on purchasing.

Connect Cat5 Reach DVI and Cat5 Reach DVI

Raritan.
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Note: The images used in the diagrams are not specific to Cat5 Reach DVI but
the connections are accurate.

This section introduces three scenarios involving KVM switches.
e Connect the Cat5 Reach DVI between any KVM switch and its local console.
e Connect the Cat5 Reach DVI between two KVM switches.

e Connect the Cat5 Reach DVI between a computer/server and a KVYM
switch.

Turn off all devices before making the connections.

For detailed information on setting up the local and remote consoles, see
Connecting a Keyboard/Mouse/Video Source in Cat5 Reach DVI Help for more
information.

» To connect Cat5 Reach DVI and Cat5 Reach DVI:

1. If you have not already done so, set up the local and remote consoles with
the Cat5 Reach DVI transmitter and receiver, respectively.
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Appendix A: Connecting a KX Ill and Cat5 Reach DVI - Provide Extended Local Port Functionality

See Basic Installation in Cat5 Reach DVI Help for more information.
2. Use a Cat5e/6 cable to connect the transmitter and receiver.

3. Connect the transmitter and receiver to an appropriate power source
respectively.

4. Connect the local console ports of the KVM switch to the transmitter.

a. Plugone end of the Raritan-provided DVI cable into the DVI-I IN port
on the transmitter, and the other end into the KVM switch's video
port.

b. Plug the USB-B connector of the Raritan-provided USB cable into the
USB-B port on the transmitter, and the other end into the KVM
switch's local USB-A port.

5. Turn on the KVM switch.

\\"

Tip: The local or remote console can be equipped with a KVM drawer instead of
a set of keyboard, mouse and monitor. See the illustration below.

o
. wa

a

R

]

» Toincrease the distance between two tiered KVM switches:

1. Set up a remote console by connecting the receiver to a KVM switch.
a. Connect a USB CIM to the receiver.

b. Connect this USB CIM to any channel port on the KVM switch via a
Cat5 cable.
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Appendix A: Connecting a KX 1ll and Cat5 Reach DVI - Provide Extended Local Port Functionality

2. Use a Cat5e/6 cable to connect the transmitter and receiver.

3. Connect the transmitter and receiver to an appropriate power source
respectively.

4, Connect the KVM switch to the transmitter.
5. Turn on both KVM switches.

0 W nowow

] S

= =2

» Toincrease the distance between any computer and a KVM switch:
1. Setup an optional local console with the transmitter.

2. Set up a remote console by connecting the receiver to a KVM switch.
3. Use a Cat5e/6 cable to connect the transmitter and receiver.
4.

Connect the transmitter and receiver to an appropriate power source
respectively.

5. Connect the computer to the transmitter.

6. Turn on the computer.

.

» [T 1
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Appendix B Accessing a Paragon Il from the KX IlI

In This Chapter

OVEIVIBW ..ttt ettt e e e e e e e st e e e e e s e r e e e e e e s ennnneeees 170
Supported Paragon Il CIMS and Configurations .........ccccccvveivciieeeciieeecciiee e 171
Connecting the Paragon Il to the KX [l .......cccuiviiiiiiicciieeee e 174

Overview

Connect the Paragon Il system to a KX Il device that is managed by CC-SG so
that Paragon Il is accessible from CC-SG.

This diagram indicates the configuration integrating KX III.

Note: The images are for example purposes only, and may not look exactly like
your device.

yd
3) TR sl
.- k- assassss sasasaiy
0 The Paragon Il system involving Paragon Il switches, servers
and user stations
9 The user station with a DCIM-USB G2 attached
(3] KX 11l
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Appendix B: Accessing a Paragon Il from the KX |11

When you access the Paragon Il system from KX Il or CC-SG (if the KX Il is
managed by CC-SG), the Paragon Il OSUI login screen appears for you to log in.

In this integration, you can perform any OSUI functions implemented with
current Paragon Il firmware or any KX Il function implemented with current KX
Il firmware except for the virtual media feature.

When accessing the Paragon Il OSUI through KX 11, DO NOT attempt to
synchronize the mouse manually. A mouse is not necessary on the OSUI screen
and mouse synchronization will delay the keyboard response for seconds.

See Supported Paragon Il CIMS and Configurations (on page 171) for
additional information.

Supported Paragon Il CIMS and Configurations

Raritan.
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The KX lll supports the P2CIM-APS2DUAL and P2CIM-AUSBDUAL CIMs, which
provide two RJ45 connections to different KVM switches.

Support of these CIMs provides a second path to access the target in the event
that one of the KVM switches is blocked or fails.

Paragon CIM Supports Does not support

P2CIM-APS2DUAL e  Servers with IBM® e Virtual media

PS/2-type keyboard e Smart cards

and mouse ports e Absolute Mouse mode

e  Automatic skew
compensation (when
the CIMs are connected
to Paragon I, not from
a KX 111)

e Intelligent Mouse mode

Use with blade chassis

Cascaded KVM
configurations

e Standard Mouse mode

Servers with USB- or Virtual media
Sun™ USB-type e  Smart cards
keyboard and mouse
ports

P2CIM-AUSBDUAL

Absolute Mouse mode
e Use with blade chassis

Cascaded KVM
configurations

e  Automatic skew
compensation (when
the CIMs are connected
to Paragon Il, not from
a Kx 1)

e Intelligent Mouse mode

e Standard Mouse mode
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KX 11l-to-KX 11l Paragon CIM Guidelines

The following system configuration guidelines should be followed when you are
using Paragon CIMs in a KX IlI-to-KX Il configuration:

Concurrent Access

Both KX Il KVM switches should be configured with the same policy for
concurrent access to targets - both PC-Share or both Private.

If Private access to targets is required, both KVM switches must be configured
accordingly:

e  From Security > Security Settings > Encryption & Share, set PC Share Mode
to ‘Private’

This guarantees that concurrent access to targets is prohibited, for all targets
by all user groups.

The KX Ill allows for more granular control of concurrent access to targets on a
per user group basis. This is done by setting the user group’s PC Share
permissions. However, this is only enforced within the boundary of a KX Il1.
User Group PC Share permissions must not be relied on if Privacy must be
guaranteed when using the P2CIM-APS2DUAL or P2CIM-AUSBDUAL with the KX
M.

CIM Name Updates

The P2CIM-APS2 and P2CIM-AUSB names are stored within the CIM’s memory.
There are two memory locations provided to accommodate the Paragon
naming convention (12 characters) and the KX Ill naming convention (32
characters).

When first connected to a KX I, the Paragon name will be retrieved from
memory and written into the CIM memory location used by KX Ill. Subsequent
queries for the CIM name or updates to the CIM name from the KX lll will be
made to the memory location used by the KX lll.  Updates will not be made by
the KX Il to the memory location used by Paragon II.

When the CIM name is updated by one KX Ill, the other KX Il will detect and
retrieve the updated name on the next attempt to connect to that target. Until
that time, the name will not be updated on the other KX III.

Port Status and Availability

The port status, displayed on the KX lll Port Access page as either Up or Down,
is updated to show whether the CIM is powered up and connected to the KX IlI
port.

The port availability, as displayed on the KX lll Port Access page as Idle, Busy or
Connected, is only updated to reflect activity on a target that has been initiated
from that same KX III.

If a connection to the target is in place from the other KX IlI, the availability is
checked when a connection is attempted. Access is denied or allowed
consistent with the PC-Share policy in place for the KX Ill. Until that time, the
availability is not be updated on the other KX III.

Raritan.
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Appendix B: Accessing a Paragon Il from the KX IlI

If access is denied because the target is busy, a notification is displayed.
Working from CC-SG

Operations initiated from CC-SG are based on the Status, Availability and CIM
name reported by the managed KX Ill. When the target is connected to two
managed KX Ills and the devices are added to CC-SG, two nodes will be created.
Each node will have its own oob-kvm interface associated with it. Alternatively,
a single node can be configured with an oob-kvm interface from each KX lI.

If the KX IlIs are configured for ‘Private’ mode, when a second connection is
attempted the user is notified that they cannot connect and access is denied.

When a port name change is initiated via the CC-SG Port Profile pane, the
changed name is pushed to the managed KX . The corresponding port name
of the other KX Il will not be updated in CC-SG until a connection is attempted
to the target port via the other KX IIlI’s oob-kvm interface.

KX Ill-to-Paragon Il Guidelines

The P2CIM-APS2DUAL or P2CIM-AUSBDUAL can be connected to a KX Il and
Paragon II.

Concurrent Access

The KX lll and Paragon Il must be configured with the same policy for
concurrent access to targets.

Paragon Il Mode description Supported?
operation mode
Private A server or other device on Supported.
a specific channel port can - paragon I and the KX IIl must
be accessed exclusively by  pe set to Private. The Private
only one user at a time. setting is applied on to KX llI
device, not per user group.
The Paragon Il uses Red to
indicate ‘busy’ or Green to
indicate ‘available’.

PC Share A server or other device on Supported.
a specific channel port can However, PC Share Idle
be selected and controlled ' Timeout, which is configured

by more than one user, on the Paragon ll, is not

but only one user has supported. Both users will
keyboard and mouse have concurrent keyboard and
control at any one time. mouse control.

The Paragon Il uses Green to
indicate ‘available’.  This will
also be true if another user is
already accessing the target.
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Paragon Il Mode description Supported?
operation mode

Public View While one user is accessing Not supported.

a server or other device on  This mode cannot be used

a specific channel port, when connecting the CIM to a
other users can select that  paragon 11 and the KX Il

channel port and view the
video output from that
device. However, only the
first user will have
keyboard and mouse
control until they
disconnect or switch away.

The Paragon Il uses Yellow to
indicate it is in P-View mode.

CIM Name Updates

CIM names updated from Paragon Il are stored and retrieved from the CIM
memory location corresponding to the Paragon naming convention.

CIM names updated from the KX Il are stored and retrieved from the CIM
memory location corresponding to the KX Il naming convention.

CIM name updates do not propagate between the Paragon Il and the KX III.

Supported Connection Distances Between Paragon Il and KX I

When using KX IIl as the front end of a Paragon Il system, you should restrict
the cable length (distance) for good video quality.

Supported distance from the Paragon Il user station to the target server is 500
cable feet (152 m). Greater distances may result in video performance that may
or may not be acceptable to you.

Supported distance from KX Il to the Paragon Il user station is up to 150 cable
feet (45 m).

174

Connecting the Paragon Il to the KX Il

P To connect the Paragon Il system to a KX III:

1.

Check whether the Paragon Il user station that you want to connect to the
KX 1l is implemented with version 4.6 firmware (or later). If not, upgrade it.

The Paragon Il user station can be one of these:

= P2-UST
= P2-EUST
= P2-EUST/C

See Paragon Il Help for information on upgrading.

Plug a compatible DCIM-USB into the USB and video ports on the Paragon
Il user station.
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Abrand of O legrand



Appendix B: Accessing a Paragon Il from the KX IlI

If the system is a two- or three-tier system, ensure the Paragon Il user
station is connected to the base KX Il device (first tier).

3. Connect the Paragon Il user station to a KX lll device via a Cat5 UTP cable
up to 150 feet (45 m).

=  Plug one end of the cable to the DCIM's RJ-45 port and the other end
to one of the channel ports on the KX Il device.

4. If you want to have more paths to access the same Paragon Il system in KX

Il or CC-SG, repeat Steps 1 to 3 to connect additional user stations to the
KX 1.
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Appendix C Updating the LDAP Schema

In This Chapter
Returning User Group INformation.........cceecieeieciiee e 176
Setting the Registry to Permit Write Operations to the Schema ..................... 177

Creating @ NeW AttribDULE......eiii i e
Adding Attributes to the Class
Updating the Schema Cache.......cccccceevriiiieeiieecinnnnn.
Editing rciusergroup Attributes for User Members

Returning User Group Information

Use the information in this section to return User Group information (and assist
with authorization) once authentication is successful.

From LDAP/LDAPS

When an LDAP/LDAPS authentication is successful, the KX Il determines the
permissions for a given user based on the permissions of the user's group. Your
remote LDAP server can provide these user group names by returning an
attribute named as follows:

rciusergroup attribute type: string

This may require a schema extension on your LDAP/LDAPS server. Consult your
authentication server administrator to enable this attribute.

In addition, for Microsoft® Active Directory*, the standard LDAP memberOf is
used.

From Microsoft Active Directory

Note: This should be attempted only by an experienced Active Directory’
administrator.

Returning user group information from Microsoft's® Active Directory for
Windows 2000° operating system server requires updating the LDAP/LDAPS
schema. See your Microsoft documentation for details.

1. Install the schema plug-in for Active Directory. See Microsoft Active
Directory documentation for instructions.

2. Run Active Directory Console and select Active Directory Schema.
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Setting the Registry to Permit Write Operations to the Schema

To allow a domain controller to write to the schema, you must set a registry
entry that permits schema updates.

P To permit write operations to the schema:

1. Right-click the Active Directory® Schema root node in the left pane of the

window and then click Operations Master. The Change Schema Master
dialog appears.

Change Schema Master ed |

The zchema master manages modifications to the schema. Only one
gerver in the enterprise performs this role.

Current schema maszster [online]:

rei-gofdj2nzmet. mypec. mydomain. com

To tranzfer the schema master role ko the targeted
domain controller below, click Change.

rei-gofdi2nzmet. mypc. mydamain. com

Cloze

2. Select the "Schema can be modified on this Domain Controller" checkbox.
Optional

3. Click OK.

Creating a New Attribute

>  To create new attributes for the rciusergroup class:

1. Click the + symbol before Active Directory® Schema in the left pane of the
window.

2. Right-click Attributes in the left pane.
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3. Click New and then choose Attribute. When the warning message appears,
click Continue and the Create New Attribute dialog appears.

Create New Attribute i )

‘ Create a New Attribute Object

~ ldentification

Common Mame:; Irr.'iusergroup

LDAP Display Name:  [rciusergroup

Unique X500 Object ID: |1.3.6.1.4.1.1374250

Description: | LDAP attribute
~ Syntax and Range
Syntax: I Case Insensitive String j
Minimum: |1
b airnum: |2'||

[~ MultiValued | oK I Cancel |

4. Type rciusergroup in the Common Name field.

5. Type rciusergroup in the LDAP Display Name field.

6. Type 1.3.6.1.4.1.13742.50 in the Unique x5000 Object ID field.
7. Type a meaningful description in the Description field.

8

Click the Syntax drop-down arrow and choose Case Insensitive String from
the list.

9. Type 1inthe Minimum field.
10. Type 24 in the Maximum field.
11. Click OK to create the new attribute.

Adding Attributes to the Class

»  To add attributes to the class:

1. Click Classes in the left pane of the window.
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2. Scroll to the user class in the right pane and right-click it.

'fiii Lonsolel - [Console Root'Active Directory Schema [ra-gefj2nzmzEn 10| x|
€ Fie Actin  Wiew Favcrites  Window  Help _ =]
eals = NE =
L_] Conscle Rock Marre I Tupe | Skabus I EIESEI:I
E|'"'_E Active Directory Schema | 2 cerviceConnechonPoink Shuckural Ackive Servi
ED Claszes B3 servicelrnstarce Shkruckural ackive Servi
—{10 atrioutes B cirrpleSecurnityObisct iz Ackivi The ¢
B3 st Skruckural Bikive Sike
W3 citeLink Structural Aitive Site-L
B2 sikelinlEridge Skruckural Ackive Sike-1
B3 it Container Shruckural rkive Sikes-
B3 sborage Skruckural Aickive Shore
B8 < bnst Skruckural Bickive Subn
B cubnegkContainer Skruckural Ackive Subn
B3 aubSchema Skruckural Bikive Zubs
B3 bop abstract Active Top
B2 bustecDomain Skruckural Ackive Trust
B2 bopelibrary Sbructural Active Type
a M \Wirdaw From Here
B8 yobime Bckive Volun -
4 | _hI a| Refrash | b
| Properties |
Help
3. Choose Properties from the menu. The user Properties dialog appears.
4. Click the Attributes tab to open it.
5. Click Add.
6. Choose rciusergroup from the Select Schema Object list.
CTTECTTE— 2x
Select a schema obgect
oducrlode
:nlld?a!h = l—lm
peoeas0 bt ame
) i]
peosqiGeree staonk nabled
[ttt
bl e ey
pupntads esch
peedntond ength
pvclL kel
pondF
el ervace
qusnFiter
Wﬂc:gb#!
rars oves —
B
reassengroupl
ONAMD ]

Raritan.

A brand of Klegrand’

179



Appendix C: Updating the LDAP Schema

7. Click OK in the Select Schema Object dialog.
8. Click OKin the User Properties dialog.

Updating the Schema Cache

»  To update the schema cache:

Right-click Active Directory® Schema in the left pane of the window and
select Reload the Schema.

2.  Minimize the Active Directory Schema MMC (Microsoft” Management
Console) console.

Editing rciusergroup Attributes for User Members

To run the Active Directory® script on a Windows 2003° server, use the script
provided by Microsoft® (available on the Windows 2003 server installation CD).
These scripts are loaded onto your system with a Microsoft® Windows 2003
installation. ADSI (Active Directory Service Interface) acts as a low-level editor
for Active Directory, allowing you to perform common administrative tasks
such as adding, deleting, and moving objects with a directory service.

> To edit the individual user attributes within the group rciusergroup:
1. From the installation CD, choose Support > Tools.
2. Double-click SUPTOOLS.MSI to install the support tools.
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3. Goto the directory where the support tools were installed. Run
adsiedit.msc. The ADSI Edit window opens.

2. nDST Edit
b Fle Ao Wies  Whdos  Heb |;|g|
+romiB®e
< aosiEde hlarm= { e [ Ditimised Hene
B Doman [ro-gof dizneret.mypc it | £ Donein [ro-gd4iZnamet mypc., . domanlés
=-5] Configurstion [rcrgeF4iZramet.m § Corfigarebon [rergef4iZramz. .. configurston
] Schema [ro-gefAEnmt. mupem | cchema [rcrgeMEramet mp... dHD
| I il I i |
4. Open the Domain.
5. Inthe left pane of the window, select the CN=Users folder.
<R, RDST Edit =0 =l
S Pl Adon Vs Window  Heb |=imiz]
eo|D@xFEABRIE
. OLEdE blarm= { e f Ditimpished Hene
B ﬂ |_:|':""'ﬁi" [rci-guf ) 2rizrrk, s, iy .i.']CH:MThsh'akw usEr Chi=Adminishrebor, CM=lsers,DC=mwpc, 0 C=nydomen, [
H-D Cri=mepe DL =mrdamen, D L h=Cart Fuishers e Chi=Cert Publishers, Ch=lsers, DC=nypc, DC=mydomain
-T- I-'-I l:|'1-E_ul:h _A'T']CHmdrlrs group Ch=Lrebdmrs, =llsers, DC=mvpe, DO =mydomeain, [«
f: I_\_J H=Compucets o H=CrelipdateP rooe proup Ch=CrellpdsteProsy, D=Users, D C=mypc, CC=nydome
7 I_I ;":;T@U"Tl::ﬂ %‘]CH:Dumh.ﬁdrlrs group Ch=Comein Sdmirs, D= sers, Co=nvpe DC=mpdomen
; B l:f!-Lo:.Iﬁg Y el H=Lmomein Compubsrs group Chi=Comen Compubers, CN=Users, 0 C=mypc, D C=mvdor
T:.l;:;l m:ﬂm'ﬂ o ZMCH=Comein Controbers wrop Chi=Cromein Controlers, CH=Users, D C=myoe, O C=mydor
i 4 o P %‘]EN:DumahGuuls group h=Comein Eussks, CH= s s, D =mpe, D =mydomsin
+|J m=5_rim deohi=Comein Users group CH=Cwomein Users, Chi= Ussrs, I =myp, Dio=mydoman, |
i- =3 ﬁlthl-a'nrprmndrrrﬁ Broup ohl=Erfarpeee Odmirs, Dl sers, D=y pe, Do = m
- Configuration [rckgorEramzt. m ﬁlchl-c-m.p Peloy Cremtor Cw...  group Ch=Crous Poloy Craator Cwmers, CH=Lsoes D e nywpe, |
#ri] schema [ro-gafEnzme: mepnm __'._'JEM-Guest user Chl=ELest, Chle Lo s, Do s, D =iy cdionn iy, D =oom
_IEM-I-Eb\ScmrﬁGm.p group Chl=HelrServicesGroup, CN=Lsers, D C=rmrens, [ C=mudar
'_-'Ichl-krhtqt user Chl=hirbigt, el | sers, DCemype O = med nmainy, D scor
LN h=ras and 145 Servers group CH=RAS and 145 Seresss, Ml=Users, DiC=mup: DC=nuc
;Icu-icrmnand'rhs group Chl=Schema admins, Chl=l_ser s, D0 =mype, - =niydomsir
i H=3_PPORT_ZEESASA0 user CR=SUPPORT_3E05q5a0, Chi=l_tiers O =, D =
ZAcH=Tel s erks group Chi=TadneoCbent s, Chi=Lszes, DC=riype, Do =miydomain,
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6. Locate the user name whose properties you want to adjust in the right
pane. Right-click the user name and select Properties.

7. Click the Attribute Editor tab if it is not already open. Choose rciusergroup
from the Attributes list.

CN=Administrator Properties ed |

Atribute Editor | Secuity |

¥ Show mandatory attributes
¥ Show optional attibutes

[T Show orly attributes that have values

Attributes:
Attribute | Syntax | " alue il
proxdddresses nicode String - <Mat Sets
pedlaztSet Large Integer/...  128299285243033603
queryPolicyBL Digtinguished ... <Mat Set:
ICiLSErgroup Laze Inzenszh..  <MaotSet:
reqiztereddddress Oetet Sting <Mat Sets
replPropertybdetallata Octet Sting Qw01 000 0=00 Ox00 Ox0
repll pT ol atel ectar Octet String <Mot Set:
repzFrom Cctet Sting <Mat Set»
repzT o Oetet Sting <Mat Sets =
revizion |nteger <Maot Set:
rid |nteger <Mot Set:
roomMumber dnicode Sting <Mot Set
sibAccountt ame Ihicode Str'inu Adrinigtrator _Ij
4 3

Edit |

0k I Cancel | Amply |

Click Edit. The String Attribute Editor dialog appears.

Type the user group (created in the KX IIl) in the Edit Attribute field. Click
OK.

String Attribute Editor x|

Attribute: roiuzergroup

Walle:
Jsdirir]

Clear | k. I Cancel
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In This Chapter
L e 1V T <SR UPRPPR 183
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BSIMI Certification ......uueeeee e 207
Hardware
Dimensions and Physical Specifications
Dominion KX lll Description  Power & Dimensions Weight Operating Humidity
model heat (WxDxH) temp
dissipation
DKX3-108 = 8server Dual Power 17.3" x 8.60lbs 02-45°C 0-85 % RH
ports 110v/240vV, 13.15" x
= 1remote 50-60Hz 1.73"
user 18ABOWS2  439x334x44 3.9kg ~ 32¢-113¢F
= 1local KCAL mm
port for
use at the
rack
DKX3-116 = 16server Dual Power  17.3"x 8.60Ibs 09-452C 0-85 % RH
ports 110v/240vV, 13.15" x
= 1remote 50-60Hz 1.73"
user 1.8A60W 52 4394334544  3.9kg 329-113°F
= 1 local KCAL -
port for
use at the
rack
DKX3-132 = 32server Dual Power 17.3" x 8.60lbs 02-45°C 0-85 % RH
ports 110V/240V, 13.15" x
= J1remote 50-60Hz 1.73"
user 1.8A60W 52 4394334544  3.9kg 329-113°F
= 1local KCAL mm
port for
use at the
rack
DKX3-216 " 16server Dual Power  17.3"x 9.08lbs 09-452C 0-85 % RH
ports 110v/240V, 13.15" x
= 2remote 50-60Hz 1.73"
L]
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Dominion KX 111

model

DKX3-232 -

DKX3-416 "

DKX3-432 -

DKX3-464 "

DKX3-808 -

184

Description

users

1 local
port for
use at the
rack

32 server
ports
2 remote
users

1 local
port for
use at the
rack

16 server
ports

4 remote
users

1 local
port for
use at the
rack

32 server
ports

4 remote
users

1 local
port for
use at the
rack

64 server
ports

4 remote
users

1 local
port for
use at the
rack

8 server
ports

8 remote

Power &
heat
dissipation
1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110v/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

Dimensions
(WxDxH)

439x334x44
mm

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3"x13.3"
x 3.5"

439x338x89
mm

17.3" x
13.15" x
1.73"

Weight

4.12kg

9.08lbs

4.12kg

9.08lbs

4.12kg

9.08lbs

4.12kg

12.391lbs

5.62kg

9.96lbs

Operating Humidity
temp

329-113¢9F

02-452C 0-85 % RH
3292-113¢°F

02-45°C 0-85 % RH
329-113°F

02-452C 0-85 % RH
329-113°F

09-45°C 0-85 % RH
329-113°F

02-452C 0-85 % RH
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Dominion KX 111

model

DKX3-832

DKX3-864
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Description

users

= 1local
port for
use at the
rack

= 32 server
ports

= 8remote
users

= 1 local
port for
use at the
rack

= 64 server
ports

= 8remote
users

= 1local
port for
use at the
rack

Power &
heat
dissipation
1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110v/240V,
50-60Hz

1.8A 60W 52
KCAL

Dimensions
(WxDxH)

439x334x44
mm

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3"x13.3"
x 3.5"

439x338x89
mm

Weight

4.52kg

9.96lbs

4.52kg

12.391bs

5.62kg

Appendix D: Specifications

Operating Humidity

temp

320-1139F

02-45°C 0-85 % RH

320-1139F

02-452C 0-85 % RH

320-1139F
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Supported Target Server Video Resolutions

When using digital CIMs, you set the target's video resolution to match your
monitor's native display resolution. The native display resolution is set when
configuring ports for digital CIMs (see Configure the CIM Target Settings).

Following is a complete list of supported video resolutions when accessing a
target from the Remote Console.

e 640x350@70Hz
e 640x350@85Hz
e 640x400@56Hz
e 640x400@84Hz
e 640x400@85Hz
e 640x480@60Hz
e 640x480@66.6Hz
e 640x480@72Hz
e 640x480@75Hz
e 640x480@85Hz
e 720x400@70Hz
e 720x400@84Hz
o 720x400@85Hz
e 300x600@56Hz
e 300x600@60Hz
e 300x600@70Hz
e 300x600@72Hz
e 300x600@75Hz
e 800x600@85Hz
e 300x600@90Hz
e 300x600@100Hz
o 832x624@75.1Hz
e 1024x768@60Hz
e 1024x768@70Hz
o 1024x768@72Hz
e 1024x768@85Hz
o 1024x768@75Hz
e 1024x768@90Hz
e 1024x768@100Hz
e 1152x864@60Hz
e 1152x864@70Hz
e 1152x864@75Hz
e 1152x864@85Hz
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1152x870@75.1Hz
1280x720@60Hz
1280x960@60Hz
1280x960@85Hz
1280x1024 @60Hz
1280x1024@75Hz
1280x1024@85Hz
1360x768@60Hz
1366x768@60Hz
1368x768@60Hz
1400x1050@60Hz
1440x900@60Hz
1600x1200@60Hz
1680x1050@60Hz
1920x1080@60Hz

1920x1200@60Hz (Requires Reduced Blanking Time)

Appendix D: Specifications

For 1920x1200@60Hz, you must use a digital CIM and set the CIM’s

preferred resolution to 1920x1200@60Hz.

KX 11l Supported Local Port DVI Resolutions

Following are the resolutions supported when connecting to a DVI monitor
from the Local port.

1920x1080@60Hz
1280x720@60Hz

1024x768@60Hz (default)

1024x768@75Hz
1280x1024 @60Hz
1280x1024@75Hz
1600x1200@60Hz
800x480@60Hz
1280x768@60Hz
1366x768@60Hz
1360x768@60Hz
1680x1050@60Hz
1440x900@60Hz
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Target Server Video Resolution - Supported Connection Distances and Refresh
Rates

The maximum supported distance is a function of many factors including the
type/quality of the Cat5 cable, server type and manufacturer, video driver and
monitor, environmental conditions, and user expectations.

The following table summarizes the maximum target server distance for
various video resolutions and refresh rates:

Target server video resolution Maximum distance
1024x768@60Hz (and below) 150' (45 m)
1280x1024@60Hz 100' (30 m)
1280x720@60Hz 75' (22 m)
1600x1200@60Hz 50' (15 m)
1920x1080@60Hz 50' (15 m)

See Supported Target Server Video Resolutions (on page 186) for the video
resolutions supported by the KX II.

Note: Due to the multiplicity of server manufacturers and types, OS versions,
video drivers, and so on, as well as the subjective nature of video quality,
performance cannot be guaranteed across all distances in all environments.

Supported Computer Interface Module (CIMs) Specifications

Digital CIMs support Display Data Channels (DDC) and Enhanced Extended Display
Identification Data (E-EDID).

Note: Both plugs must be plugged in for the HDMI and DVI CIMs.

CIM model Description Dimensions (WxDxH) Weight
D2CIM-DVUSB Dual USB CIM for: = 1.7"x3.5"x0.8" = 0.25lb
= OSvirtual media = 43x90x19mm = 0.11kg
=  Smartcard/CAC
= Audio

= Absolute Mouse Synchronization
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CIM model Description Dimensions (WxDxH) Weight

D2CIM-VUSB USB CIM for: 1.3"x3.0"x0.6" = 0.20lb
= OS virtual media 33 x 76 x 15mm = 0.09kg

= Absolute Mouse Synchronization

D2CIM-VUSB-USBC USB CIM for: = 1.7"x3.5"x0.8" = 0.25lb
= USB-C ports on Macs and PCs " 43x90x19mm * 0.11kg
= USB keyboard, mouse, and virtual

media

= DisplayPort video

= No Audio or Smartcard

D2CIM-DVUSB-DP Digital CIM that provides = 1.7"x3.5"x0.8" = 0.25lb
digital-to-analog conversion and = 43 x90x 19mm = 0.11kg
support for:
= OSvirtual media
= Smartcard/CAC
= Audio
= Absolute and Relative Mouse

Synchronization
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CIM model
D2CIM-DVUSB-HDMI

D2CIM-DVUSB-DVI

DCIM-PS2

Description Dimensions (WxDxH) Weight
Digital CIM that provides = 1.7"x35"x0.8" = 0.25lb
digital-to-analog conversion and = 43 x90x 19mm = 0.11kg

support for:

= OSvirtual media

= Smartcard/CAC

= Audio

= Absolute and Relative Mouse
Synchronization

1.7"x3.5"x0.8" = 0.25lb
43 x90 x 19mm = 0.11kg

Digital CIM that provides
digital-to-analog conversion and
support for:

= OSvirtual media

=  Smartcard/CAC

= Audio

= Absolute and Relative Mouse
Synchronization

1.3"x3.0"x0.6" = 0.20lb
33 x 76 x 15mm = 0.09kg

CIM for PS2
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Description Dimensions (WxDxH) Weight
CIM for USB and Sun USB = 1.3"x3.0"x0.6" = 0.20lb

= 33x76x15mm = 0.09kg

Supported Digital Video CIMs for Mac

Use a digital video CIM to connect to the following Mac® ports:

Mac port CIM

USB-C D2CIM-VUSB-USBC
DVI D2CIM-DVUSB-DVI
HDMI D2CIM-DVUSB-HDMI

DisplayPort or Thunderbolt D2CIM-DVUSB-DP

If the Mac’s HDMI or DisplayPort video has a mini connector, a passive adapter
cable may be required to connect to the full sized HDMI and DisplayPort plugs
on the digital CIMs.

Alternatively, use the Mac VGA adapter with the D2CIM-VUSB or
D2CIM-DVUSB. Note that this may be less reliable and the video quality may
suffer.

For information on established modes supported by the KX Il 2.5.0 (and later)
for Mac, see Digital CIM Established and Standard Modes (on page 192).
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Digital CIM Timing Modes

Following are the default timing modes that are used when the KX IlI
communicates with a video source via a digital CIM.

The timing mode that is used is dependent on the native resolution of the
video source.

See Configuring CIM Ports for more information.

960x1080@60Hz
1024x768@60Hz
1152x864@60Hz
1280x720@60Hz
1280x960@60Hz

1280x1024@60Hz (default resolution applied to digital CIMs)

1360x768@60Hz

1400x1050@60Hz
1440x900@60Hz

1600x1200@60Hz
1680x1050@60Hz
1920x1080@60Hz
1920x1200@60Hz

Digital CIM Established and Standard Modes

The following additional established and standard resolutions and timing

modes are supported by the KX 111 3.0.0 (and later).

192
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Digital CIM Established Modes

e 720x400@70Hz IBM, VGA

o 640x480@60Hz IBM, VGA

e 640x480@67Hz Apple Mac’ Il
e 640x480@72Hz VESA

e 640x480@75Hz VESA

e 800x600@56Hz VESA

e 800x600@60Hz VESA

e 300x600@72Hz VESA

e 800x600@75Hz VESA

e 832x624@75Hz Apple Mac I
e 1024x768@60Hz VESA

o 1024x768@70Hz VESA

e 1024x768@75Hz VESA

e 1280x1024@75Hz VESA

e 1152x870@75Hz Apple Mac Il

Digital CIM Standard Modes

e 1152x864@75Hz VESA
e 1280x960@60Hz VESA
e 1280x1024@60Hz VESA
e 1360x768@60Hz VESA
e 1400x1050@60Hz VESA
e 1440x900@60Hz VESA
e 1600x1200 @60Hz VESA
e 1680x1050@60Hz VESA
e 1920x1080@60Hz VESA

DVI Compatibility Mode

DVI Compatibility Mode may be required if you are using an HDMI CIM to
connect to a Dell Optiplex target with an Intel video card, or a Mac® Mini with
an HDMI video port.

Selecting this mode ensures a good video quality from the targets.

See Configuring CIM Ports in online help.
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Supported Remote Connections

Remote connection

Network

Protocols

Details

10BASE-T, 100BASE-T, and 1000BASE-T (Gigabit)

Ethernet

TCP/IP, UDP, SNTP, HTTP, HTTPS, RADIUS, LDAP/LDAPS

Network Speed Settings

KX 11l network speed setting

Network Auto
switch port
setting Auto
1000/Full
100/Full
100/Half
100/Half
10/Full
10/Half
10/Half
Legend:
194

1000/Full

100/Half

No
Communicati
on

100/Full

No
Communicati
on

No
Communicati
on

100/Half
100/Half

No
Communicati
on

No
Communicati
on

10/Full

No
Communicati
on

10/Half
10/Half

No
Communicati
on

No
Communicati
on

No
Communicati
on

No
Communicati
on

No
Communicati
on

No
Communicati
on

Does not function as expected

No
Communicati
on

No
Communicati
on
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Supported

Functions; not recommended

NOT supported by Ethernet specification; product will
communicate, but collisions will occur

Per Ethernet specification, these should be “no
communication,” however, note that the KX Il behavior
deviates from expected behavior

Note: For reliable network communication, configure the KX Il and the LAN
switch to the same LAN Interface Speed and Duplex. For example, configure the
KX Il and LAN Switch to Autodetect (recommended), or set both to a fixed
speed/duplex such as 100MB/s/Full.

Dell Chassis Cable Lengths and Video Resolutions

In order to maintain video quality, it is recommended to use the following cable
lengths and video resolutions when you are connecting to Dell® blade chassis

from the KX I1I:

Video resolution Cable length
1024x768@60Hz 50' (15.24 m)
1280x1024@60Hz 50' (15.24 m)
1600x1200@60Hz 30'(9.14 m)

Smart Card Minimum System Requirements

Local Port Requirements

The basic interoperability requirement for local port attachment to the KX Il is:

e All devices (smart card reader or token) that are locally attached must be
USB CCID-compliant.
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Target Server Requirements

When using smart card readers, the basic requirements for interoperability at
the target server are:

e The IFD (smart card reader) Handler must be a standard USB CCID device
driver (comparable to the generic Microsoft® USB CCID driver).

e Adigital CIM or D2CIM-DVUSB (Dual-VM CIM) is required and must be
using firmware version 3A6E or later.

e Blade chassis server connections, where a CIM per blade is used, are
supported.

e Blade chassis server connections, where a CIM per chassis is used, is only
supported for IBM* BladeCenter® models H and E with auto-discovery
enabled.

Remote Client Requirements

The basic requirements for interoperability at the remote client are:

e The IFD (smart card reader) Handler must be a PC/SC compliant device
driver.

e The ICC (smart card) Resource Manager must be available and be PC/SC
compliant.

e The JRE® Java™ 1.8 with smart card APl must be available for use by the
client application.

Remote Linux Client Requirements

If you are using a Linux® client, the following requirements must be met to use
smart card readers with the KX lll device.

Note: User login to client, on smart card insertion, may take longer when 1 or
more KVM sessions are actively in place to targets. As the login process to
these targets is also under way.

e PC/SC Requirements

Operating system Required PC/SC

RHEL 5 pcsc-lite-1.4.4-0.1.el5

SuSE 11 pcsc-lite-1.4.102-1.24
Fedora® Core 10 pcsc-lite-1.4.102.3.fc10.i386
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Type
uUsB

usB
usB
usB

USB Keyboard/Card
reader combo

USB Keyboard/Card
reader combo

USB reader for
SIM-sized cards

Integrated (Dell
Latitude D620)

PCMCIA
PCMCIA

Raritan.

A brand of Klegrand’

Appendix D: Specifications

e Create aJava’ Library Link

A soft link must be created to the libpcsclite.so after upgrading RHEL 4,
RHEL 5 and FC 10. For example, In —s /usr/lib/libpcsclite.so.1
Jusr/lib/libpcsclite.so, assuming installing the package places the libraries
in /usr/lib or /user/local/lib

e PC/SC Daemon

When the pcsc daemon (resource manager in framework) is restarted,
restart the browser

Supported Smart Card Readers

Vendor Model Verified

SCM Microsystems SCR331 Verified on local and
remote

Activldentity® Activldentity USB Reader v2.0 Verified on local and
remote

Activldentity Activldentity USB Reader v3.0 Verified on local and
remote

Gemalto” GemPC USB-SW Verified on local and
remote

Dell® USB Smart Card Reader Keyboard Verified on local and
remote

Cherry GmbH G83-6744 SmartBoard Verified on local and
remote

Omnikey 6121 Verified on local and
remote

0O2Micro 0z776 Remote only

Activldentity Activlidentity PCMCIA Reader Remote only

SCM Microsystems SCR243 Remote only

Note: SCM Microsystems SCR331 smart card readers must be using SCM
Microsystems firmware v5.25.
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Unsupported Smart Card Readers
The following card readers are not supported.

If a smart card reader does not appear in the supported smart card readers
table or in the unsupported smart card readers table, it's function cannot be
guaranteed.

Type Vendor Model Notes
USB Keyboard/Card HP° ED707A No interrupt endpoint
reader Combo =>not compatible with

Microsoft® driver

USB Keyboard/Card SCM SCR338 Proprietary card reader
reader Combo Microsystems implementation (not
CCID-compliant)

USB Token Aladdin® eToken Proprietary
PRO™ implementation

Audio Playback and Capture Recommendations and Requirements

Audio Level

e Set the target audio level to a mid-range setting.
For example, on a Windows® client, set the audio to 50 or lower.

This setting must be configured through the playback or capture audio device,
not from the client audio device control.

Recommendations for Audio Connections when PC Share Mode is Enabled

If you are using the audio feature while running PC Share mode, audio playback
and capture are interrupted if an additional audio device is connected to the
target.

For example, User A connects a playback device to Targetl and runs an audio
playback application then User B connects a capture device to the same target.
User A's playback session is interrupted and the audio application may need to
be restarted.

The interruption occurs because the USB device needs to be re-enumerated
with the new device configuration.

It may take some time for the target to install a driver for the new device.

Audio applications may stop playback completely, go to the next track, or just
continue playing.

The exact behavior is dependent on how the audio application is designed to
handle a disconnect/reconnect event.
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Bandwidth Requirements

The table below details the audio playback and capture bandwidth
requirements to transport audio under each of the selected formats.

Audio format Network bandwidth requirement
44.1 KHz, 16bit stereo 176 KB/s

44.1 KHz, 16bit mono 88.2 KB/s

2.05 KHz, 16bit stereo 88.2 KB/s

22.05 KHz, 16bit mono 44.1 KB/s

11.025 KHz, 16bit stereo 44.1 KB/s

11.025 KHz, 16bit mono Audio 22.05 KB/s

In practice, the bandwidth used when an audio device connects to a target is
higher due to the keyboard and video data consumed when opening and using
an audio application on the target.

A general recommendation is to have at least a 1.5MB connection before
running audio/video.

However, high video-content, full-color connections using high-target screen
resolutions consume much more bandwidth and impact the quality of the
audio considerably.

To help mitigate quality degeneration, there are a number of recommended
client settings that reduce the impact of video on audio quality at lower
bandwidths:

e Connect audio playback at the lower quality formats. The impact of video
consuming bandwidth is much less notable at 11k connections than at 44k

e Set the connection speed under Connection Properties to a value that best
matches the client to server connection

e Under Connection Properties, set the color depth to as low a value as
possible. Reducing the color depth to 8 bit color considerably reduces the
bandwidth consumed

e Set Smoothing to High. This will improve the appearance of the target
video by reducing displayed video noise

e Under Video settings, set the Noise Filter to its highest setting of 7 (highest
value) so less bandwidth is used for target screen changes
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Audio in a Mac Environment

Following are known issues in a Mac® environment.

e  On Mac clients, only one playback device is listed on the Connect Audio
panel. The device listed is the default and is displayed on the Connect
Audio panel as Java Sound Audio Engine.

e Using audio on a Mac target through Skype® may cause the audio to be
corrupted.

Number of Supported Audio/Virtual Media and Smartcard Connections

Following are the number of simultaneous Audio/Virtual Media and Smartcard
connections that can be made from a client to a target:

e 1smartcard

e 1virtual media

e 1Smartcard and 1 virtual media

e 2 virtual media

Certified Modems

e USRobotics® 56K 5686E

e ZOOM°Vv90

e ZOOM v92

e  USRobotics Sportster® 56K
e USRobotics Courier” 56K

KX 1l Supported Keyboard Languages

The KX Il provides keyboard support for the languages listed in the following
table.

Note: You can use the keyboard for Chinese, Japanese, and Korean for display
only; local language input is not supported at this time for the KX Ill Local
Console functions. For more information about non-US keyboards, see
Informational Notes (on page 208).

Note: It is strongly recommended that you use system-config-keyboard to
change languages if you are working in a Linux environment.

Language Regions Keyboard layout

US English United States of America and most  US Keyboard layout
of English-speaking countries: for
example, Canada, Australia, and
New Zealand.

US English United States of America and most  US Keyboard layout
International  of English-speaking countries: for
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Keystroke

Press C during
startup
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Language

UK English

Chinese
Traditional

Chinese
Simplified

Korean
Japanese

French

German

French
Norwegian
Danish
Swedish
Hungarian
Slovenian
Italian

Spanish

Portuguese

Regions
example, Netherlands

United Kingdom

Hong Kong S. A. R., Republic of
China (Taiwan)

Mainland of the People’s Republic

of China
South Korea
Japan

France

Germany and Austria

Belgium
Norway
Denmark
Sweden
Hungary
Slovenia

Italy

Spain and most Spanish speaking

countries

Portugal

Appendix D: Specifications

Keyboard layout

UK layout keyboard

Chinese Traditional

Chinese Simplified

Dubeolsik Hangul
JIS Keyboard

French (AZERTY) layout
keyboard.

German keyboard
(QWERTZ layout)

Belgian
Norwegian
Danish
Swedish
Hungarian
Slovenian
Italian

Spanish

Portuguese

Mac Mini BIOS Keystroke Commands

The following BIOS commands have been tested on Intel-based Mac® Mini
target servers and Mac Lion® servers running Mac Snow Leopard®. The servers
were attached to a KX Il with D2CIM-DVUSB and D2CIM-VUSB CIMs. See below
for the supported keys and any notes.

Description

Start up from a bootable Yes Yes

Virtual Media CIM

CD or DVD, such as the

Dual Virtual Media Mac Lion Server
CIM

HDMI CIM

Yes
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Keystroke

Press D during
startup

Press Option-
Command-P-R until
you hear startup
sound a second time.

Press Option during
startup

Press Eject, F12, or
hold the mouse
button

Press N during
startup

Press T during
startup

Press Shift during
startup

Press Command-V
during startup

Press Command-S
during startup

Press Option-N
during startup

Press Command-R
during startup

Description

Mac OS X Install disc

Start up in Apple
Hardware Test (AHT)

Reset NVRAM

Start up in Startup

Manager, where you can
select a Mac OS X volume

to start from

Ejects any removable

media, such as an optical

disc

Start up from a
compatible network
server (NetBoot)

Start up in Target Disk

mode

Start up in Safe Boot

mode and temporarily

disable login items

Start up in Verbose
mode.admin

Start up in Single-User

mode

Start from a NetBoot

server using the default

boot image

Virtual Media CIM

Yes

May need BIOS Mac
profile for the
mouse to work

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Start from Lion Recoveryl N/A

Dual Virtual Media
CIM

Yes

May need BIOS
Mac profile for
mouse to work

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

N/A

Mac Lion Server
HDMI CIM

Yes

May need BIOS
Mac profile for the
mouse to work

Yes

Yes

Yes

Yes

Known issue with
LION to boot to
safe mode. "Safe
Mode" in red does
not appear for Lion

Yes

Yes

Yes

Yes
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Using a Windows Keyboard to Access Mac Targets

A Windows® keyboard can be used to access a Mac® connected to a KX III.
Windows keys are then used to emulate the special Mac keys. This is the same
as connecting a Windows keyboard directly to the Mac.

TCP and UDP Ports Used

P Listening TCP Ports:

* 80: http access (configurable)

* 443: https access (configurable)

* 5000: CC-SG and KXUS access (configurable)
* 22: SSH access (if enabled, configurable)

* 68: DHCP access (if DHCP is enabled)

> Listening UDP Ports:
* 162: SNMP access (if SNMP Agent is enabled)
* 5001: CC_SG event notification (if under CC-SG management)

> TCP Ports Outgoing:

* 389: LDAP authentication (if LDAP is enabled, configurable)

* 636: LDAPS/StartTLS (if LDAPS/StartTLS is enabled, configurable)
* 25: SMTP (email) (if enabled)

* 445: SMB (Windows File System) access (Remote ISO image access).

>  UDP Ports Outgoing:

* 514: Syslog (if enabled, configurable)

* 5001: CC_SG event notification (if under CC-SG management, configurable)
* 1812: RADIUS authentication (if enabled, configurable)

* 1813: RADIUS authentication (if enabled, configurable)
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Software

Supported Operating Systems, Browsers and Java Versions

> Java:
Oracle Java™ Runtime Environment (JRE) version 8 is supported up to
1.8.0_251 at the time of this release.

Future Java versions should work correctly assuming no incompatible changes
are made by the Java developers. For any issues, please contact Technical
Support.

e  For best results, we recommend that Java Plug-in Caching is not enabled.

e  For greater security and fewer Java and browser warning messages,
Raritan recommends customers upload a SSL certificate to each KX llI
switch.

e Customers need to affirmatively click through all security warnings for the
Raritan Java applets to load. See www.raritan.com/java for more
information.

>  Browsers:
Supported browsers, see the Release Notes for latest supported versions:

e Internet Explorer
e  Microsoft Edge

e Firefox
e Chrome
e Safari

For more details on compatible browsers for your OS, see the table below.

The Active KVM Client (AKC), the native Windows Client, requires Internet
Explorer or Edge and Microsoft .NET Framework versions 4.5 and above, and is
supported on Windows 7/8/10 desktops.

Note: These support statements do not apply to the KX Ill when used with CC-SG.
Check the CC-SG Release Notes and Compatibility Matrix.

Operating Systems Browsers Java

Windows 10 Windows Edge Java 1.8 or later for
Windows 8" 64-bit Internet Explorer VKC

Windows 7° Home Premium SP1 64-bit Chrome Java1.8.0_151 or
Windows 7 Ultimate SP1 64-bit Firefox later for VKCs

Windows 7 Ultimate 32-bit

openSUSE® 15

Firefox
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Operating Systems
Fedora® 32

Red Hat 7.5

Mac 10.14, 10.15

Solaris® 10 64-bit
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Browsers Java

Firefox
Firefox

Safari
Chrome

Firefox

Firefox

JRE Requirements and Browser Considerations for Mac

Java Runtime Environment Requirements for Mac

Install Java Runtime Environment 8 (JRE)® on PCs and Macs® when using the
Virtual KVM Client (VKC) to access target devices via KX II.

This ensures in order to provide high performance, KVM-over-IP video
processing when remotely accessing target devices/PCs/Macs.

The latest version of JRE for Mac can be downloaded from the Oracle Support
website.

Browser Considerations for Mac

Java may be disabled by default in certain browsers. Enable Java and accept all
security warnings in order to use KX III.

Certain versions of Safari® block Java for security reasons. Use Firefox® instead
in this case.

Additionally, you may be required to navigate through a number of messages.
Select 'Do Not Block' if these messages are displayed.

Multi-Language Keyboard JRE Requirement

In order for multi-language keyboards to work in the KX lll and Virtual KVM
Client (VKC), install the multi-language version of JRE™.
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Events Captured in the Audit Log and Syslog

Following is a list and description of the events that are captured by the KX III
audit log and syslog:

206

Access Login - A user has logged in to the KX Il

Access Logout - A user has logged out of the KX lI

Active USB Profile - The USB profile is active

CIM Connected - A CIM was connected

CIM Disconnected - A CIM was disconnected

Connection Lost - The connection to the target was lost
Disconnected User - A user was disconnected from a port
Duplicate CIM Serial - A CIM has same serial number with other CIM.
End CC Control - CC-SG management ended

Login Failed - User login failed

Password Changed - Password change occurred

Port Connect - Port was connected

Port Disconnect - Port was disconnected

Port Status Change - Change in the port status

Scan Started - A target scan was started

Scan Stopped - A target scan was stopped

Session Timeout - A session timeout occurred

USB Profile Set Modify Failed - Failed to change USB Profile Set.
USB Profile Set Modified - USB Profile Set was modified.
USB Net Present - A broadband modem is plugged in.
USB Net Absent - A broadband modem is unplugged.

VM Image Connected - A VM image was connected

VM Image Disconnected - A VM image was disconnected

802.1X Authentication Failed, CA Certificate uploaded for 802.1X
authentication, Client Certificate uploaded for 802.1X authentication,
Client Key uploaded for 802.1X authentication
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BSMI Certification

WAE LA KWM-over-IP EfrtTHEEE Al (AKX) ‘DRX3L 7 (2FREEAREA)

Equipment name Type designation (Type)
RAMERELZRHE
Restricted substances and its chemical symbols
%7 Uni B | s | BRME | BR-Em
£l Lead sk Mercury | $%Cadmium | Hexavalent Polybrominated | Polybrominated
(Ph) (He) {Cd) chromium biphenyls diphenyl ethers
(%) (PBE; {PBLE)
T - O @) O O O
EERE | — O © O O O
s O o O ®) ®) O
ok O o O O O O
Hebmst O O O O O O

HEL TRE0Iwt %" AR CRE00I R RERAHTZAESHLAERETILESELS
& -
Note 1 ! “Exceeding 0.1 wt %07 and “exceeding 0.01 wt %47 indicate that the percentage content of the restricted substance exceeds the
reference percentage value of presence condition.

#AL Q" BREZEARADTZE S SEABE B S ATEAEME -

Note 2 1 “0” indicates that the percentage content of the restricted substance does not exceed the percentage of reference value of presence
o aae R 3

HEL =" GiEmERA T AHREE -

Note 3 : The “— indicates that the restricted substance corresponds to the exemption

PR

DKX3-108 DKX3-116 DKX3-132

DKX3-216 DKX3-232 DKX3-416

DKX3-432 DKX3-464 DKX3-808

DKX3-832 DKX3-864
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In This Chapter
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CC-SG NOEES it naan 221
Browser NOTES oo, 221

Overview

This section includes important notes on KX Il usage. Future updates will be
documented and available online through the Help link in the KX Il Remote
Console interface.

Note: Some topics in this section reference other multiple Raritan appliances
because various appliances are impacted by the information.

Java Runtime Environment (JRE) Notes

Raritan.
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Disable Java Caching and Clear the Java Cache

It is highly recommended that you disable Java caching in Microsoft Windows®,
and clear the Java” cache.

P To disable Java caching and clear the cache:
From the Windows Start menu, click Control Panel.

2. Double-click on the Java icon to launch it. The Java Control Panel dialog
appears.

3. To disable Java caching:

a. From the General tab, click the Settings button. The Temporary Files
Settings dialog appears.

b. Click the View Applets button. The Java Applet Cache Viewer opens.
c. Deselect the Enable Caching checkbox if it is already checked.
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d. Click OK.
4. To clear the Java cache:

a. From the Temporary Files Settings dialog, click the Delete Files button.
The Delete Temporary Files dialog appears.

b. Select the temporary files that you want to delete.
c. Click OK.

Java Not Loading Properly on Mac

If you are using a Mac® and see the following message when connecting to a
device from the KX Il Port Access Table, Java™ is not loaded properly:

"Error while getting the list of open targets, please try again in a few seconds".

If this occurs, check your Java installation from this website:
http://www.java.com/en/download/testjava.jsp
http://www.java.com/en/download/testjava.jsp

If your Java applet is inactive, it can be enabled from this page. If it is not
installed correctly, a message lets you know and you can then reinstall Java.

AKC Download Server Certification Validation IPv6 Support Notes

If you are connecting to a KX lll standalone device and support for AKC
download server certificate validation is enabled, the valid IPv6 format to
generate the certificate is either:
e CN =[fd07:02fa:6cff:2500:020d:5dff:fe00:01c0] when
there is a leading 0
or
e CN =[fd07:02fa:6cff:2500:020d:5dff:0000:01c0] when
there is no zero compression

Dual Stack Login Performance Issues

If you are using the KX Ill in a dual stack configuration, it is important you
configured the domain system (DNS) correctly in the KX lll in order to avoid
delays when logging in.

See Tips for Adding a Web Browser Interface for information on configuring
your DNS in KX III.

CIM Notes

Windows 3-Button Mouse on Linux Targets

When using a 3-button mouse on a Windows® client connecting to a Linux®
target, the left mouse button may get mapped to the center button of the
Windows client 3-button mouse.
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Target Video Picture Not Centered (Mouse Out of Synch)
At certain resolutions when using an HDMI or DVI CIM with the KX III:

e The video display may not be centered properly - black rectangles can be
seen at the edges of the screen

e The mouse on the target may appear to be slightly out of synch

If either or both of these occur, you may be able to correct this by adjusting the

display scaling options from the target computer’s video controller software.

For example, if your target computer uses the Catalyst Control Center video
controller, adjust the Underscan/Overscan setting as needed.

Powerstrip is not detected

When the PowerCIM-PDU is disconnected physically from the KX3, the PDU is
still listed in the PowerStrip Device drop-down list with a "Powerstrip is not
detected, please check!" message that does not disappear.

» Tosolve:

In the port configuration page for the port, click Reset To Default.
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Virtual Media Notes

Cannot Connect to Drives from Linux Clients

If you cannot connect to a virtual media drive on a target server when you
connect from a client running Linux® Fedora™ 18 with Java” 1.8 (update 45 and
later), disable SELinux in Fedora 18 on the client to resolve the problem.

Cannot Write To/From a File from a Mac Client

If you are connecting to the KX lll from a Mac® 10.8.5 client running Safari with
Java™ 1.8 and cannot write to/from a file on a KX2 or KX3 target server or access
virtual media, do the following to correct this:

1. In Safari, select Preferences.

2. Under the Security tab, select Manage Website Settings.
3. Click on "Website for KX2 or KX3".
4

Select "Run in unsafe mode" from the drop-down.

Note: In Safari 10.0, "Run in safe mode" is now hidden as an option for
Plugin-Settings. Hold the Mac Option/Alt key while clicking on the site to
list the option.

If running MacOS Sierra 10.12, Java version must be 1.8.0.121 or higher.

5. Restart Safari.
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Virtual Media via VKC and AKC in a Windows Environment

When Virtual Media is enabled, access to fixed drives and fixed drive partitions
will not be accessible with a Standard Windows user. To access those drives, a
Windows Administrator user must be used. This is because Windows User
Access Control (UAC) provides the lowest level of rights and privileges a user
needs for an application.

Both features affect the types of virtual media that can be accessed in VKC,
VKCS, and AKC. See your Microsoft® help for additional information on these
features and how to use them.

Following is a list virtual media types users can access via VKC and AKC when
running in a Windows environment.

Client Administrator Standard User
AKC and Access to: Access to:
VKC = Fixed drives and fixed drive = Removable drives
partitions = CD/DVD drives
= Removable drives * SO images
= CD/DVD drives = Remote ISO images

= |SO images
= Remote ISO images

Virtual Media Not Refreshed After Files Added

After a virtual media drive has been mounted, if you add a file(s) to that drive,
those files may not be immediately visible on the target server. Disconnect and
then reconnect the virtual media connection.

Virtual Media Linux Drive Listed Twice

For KX Ill, users who are logged in to Linux” clients as root users, the drives are
listed twice in the Local Drive drop-down.

For example, you will see eg /dev/sdc and eg /dev/sdcl where the first drive is
the boot sector and the second drive is the first partition on the disk.
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Disconnecting Mac and Linux Virtual Media USB Drives

In a Linux® or Mac® environment:

e  For Linux users, if there is /dev/sdb and /dev/sdb1, the client only uses
/dev/sdb1l and advertise it as removable disk

e /dev/sdb is not available for the user.

e  For Linux users, if there is /dev/sdb but no /dev/sdb1l, /dev/sdb is used as a
removable device

e  For Mac users, /dev/diskl and /dev/disk1s1 is used

Target BIOS Boot Time with Virtual Media

The BIOS for certain targets may take longer to boot if media is mounted
virtually at the target.

»  To shorten the boot time:
1. Close the Virtual KVM Client to completely release the virtual media drives.
2. Restart the target.

Virtual Media Connection Failures Using High Speed for Virtual Media
Connections

Under certain circumstances it may be necessary to select the "Use Full Speed
for Virtual Media CIM" when a target has problems with "High Speed USB"
connections or when the target is experiencing USB protocol errors caused by
signal degradation due to additional connectors and cables (for example, a
connection to a blade server via a dongle).

USB Port and Profile Notes

VM-CIMs and DL360 USB Ports

HP° DL360 servers have one USB port on the back of the device and another on
the front of the device. With the DL360, both ports cannot be used at the same
time. Therefore, a dual VM-CIM cannot be used on DL360 servers.

However, as a workaround, a USB2 hub can be attached to the USB port on the
back of the device and a dual VM-CIM can be attached to the hub.
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Help Choosing USB Profiles

When you are connected to a KVM target server via the Virtual KVM Client
(VKC), you can view information about USB profiles via the Help on USB Profiles
command on the USB Profile menu.

v HP Proliant DL3GO/OLIZ0 G4 (HP SEmartStart 0

Generic

Trouhleshooting 1
Trouhleshooting 2
Trouhleshooting 3

Add Other Profiles r

Help on LISE Profiles

USB profile help appears in the USB Profile Help window. For detailed
information about specific USB profiles, see Available USB Profiles.

A standard selection of USB configuration profiles are provided for a wide
range of operating system and BIOS level server implementations. These are
intended to provide an optimal match between remote USB device and target
server configurations.

The ‘Generic’ profile meets the needs of most commonly deployed target
server configurations.

Additional profiles are made available to meet the specific needs of other
commonly deployed server configurations (for example, Linux®, Mac OS X°).

There are also a number of profiles (designated by platform name and BIOS
revision) that have been tailored to enhance the virtual media function
compatibility with the target server, for example, when operating at the BIOS
level.

‘Add Other Profiles’ provides access to other profiles available on the system.
Profiles selected from this list will be added to the USB Profile Menu. This
includes a set of ‘trouble-shooting’ profiles intended to help identify
configuration limitations.

The USB Profile Menu selections are configurable via the Console Device
Settings > Port Configuration page.

Should none of the standard USB profiles provided meet your target server
requirements, Technical Support can work with you to arrive at a solution
tailored for that target.

1. Check the most recent release notes to see if a solution is already available
for your configuration.

2. If not, please provide the following information when contacting Technical
Support:
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a. Target server information, manufacturer, model, BIOS, manufacturer,
and version.

b. Theintended use (e.g. redirecting an image to reload a server’s
operating system from CD).

Changing a USB Profile when Using a Smart Card Reader

There may be certain circumstances under which you will need to change the
USB profile for a target server. For example, you may need to change the
connection speed to "Use Full Speed for Virtual Media CIM" when the target
has problems with the "High Speed USB" connection speed.

When a profile is changed, you may receive a New Hardware Detected
message and be required to log in to the target with administrative privileges
to reinstall the USB driver. This is only likely to occur the first few times the
target sees the new settings for the USB device. Afterward, the target will
select the driver correctly.

Video Mode and Resolution Notes

Video Image Appears Dark when Using a Mac

If you are using a Mac® with an HDMI video port and the video seems too dark,
enable DVI Compatibility Mode on the CIM to help resolve the issue.

See Configuring CIM Ports

Video Shrinks after Adjusting Target Clock

On HP° Proliant’ DL380p G8 target servers, certain resolutions cause the target
video to shrink. This is caused when the server's clock attempts to auto-adjust
and detects the wrong active line length.

Depending on the resolution the target is set to, this occurs when connecting
to the HP target from the KX Ill Remote Console or Local Port, or both the
Remote Console and Local Port. This issue was detected at the following
resolutions:

Target resolution Issue seen on Local  Issue seen from Remote
Port Console

1440x900@60Hz Yes Yes

1400x1050@60Hz No Yes

1152x864@60Hz No Yes
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Black Stripe/Bar(s) Displayed on the Local Port

Certain servers and video resolutions may display on the local port with small
black bars at the edge of the screen.

If this occurs:
1. Try adifferent resolution, or

2. If using a digital CIM, then change the Display Native Resolution on the
Port Configuration page to another resolution, or

3. If using the HDMI CIM, use the DVI Compatibility Mode.

Contact Raritan Technical Support for additional assistance.

Sun Composite Synch Video

Sun™ composite synch video is not supported.

SUSE/VESA Video Modes

The SuSE X.org configuration tool SaX2 generates video modes using modeline
entries in the X.org configuration file. These video modes do not correspond
exactly with VESA video mode timing (even when a VESA monitor is selected).
The KX Ill, on the other hand, relies on exact VESA mode timing for proper
synchronization. This disparity can result in black borders, missing sections of
the picture, and noise.

»  To configure the SUSE video display:

The generated configuration file /etc/X11/xorg.conf includes a Monitor
section with an option named UseModes. For example,
UseModes "Modes[0]"

2. Either comment out this line (using #) or delete it completely.
3. Restart the X server.

With this change, the internal video mode timing from the X server is used and
corresponds exactly with the VESA video mode timing, resulting in the proper
video display on the KX II1.
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Keyboard Notes

French Keyboard

Caret Symbol (Linux Clients Only)

The Virtual KVM Client (VKC) do not process the key combination of Alt Gr + 9
as the caret symbol (*) when using French keyboards with Linux® clients.

» To obtain the caret symbol:

From a French keyboard, press the » key (to the right of the P key), then
immediately press the space bar.

Alternatively, create a macro consisting of the following commands:
1. Press Right Alt

2. Press9.

3. Release 9.

4. Release Right Alt.

Note: These procedures do not apply to the circumflex accent (above vowels). In
all cases, the * key (to the right of the P key) works on French keyboards to
create the circumflex accent when used in combination with another character.

Numeric Keypad

From the Virtual KVM Client (VKC), the numeric keypad symbols display as
follows when using a French keyboard:

Numeric Displays as
keypad symbol
/ ;
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Tilde Symbol

From the Virtual KVM Client (VKC), the key combination of Alt Gr + 2 does not
produce the tilde (~) symbol when using a French keyboard.

»  To obtain the tilde symbol:

Create a macro consisting of the following commands:
e Pressright Alt

e Press2

e Release 2

e Release right Alt

Keyboard Language Preference (Fedora Linux Clients)

Because the Sun™ JRE™ on Linux® has problems generating the correct KeyEvents
for foreign-language keyboards configured using System Preferences, it is
recommended that you configure foreign keyboards using the methods
described in the following table.

Language Configuration method

Us Intl Default

UK System Settings (Control Center)
French Keyboard Indicator

German Keyboard Indicator

Hungarian System Settings (Control Center)
Spanish System Settings (Control Center)
Swiss-German System Settings (Control Center)
Norwegian Keyboard Indicator

Swedish Keyboard Indicator

Danish Keyboard Indicator

Japanese System Settings (Control Center)
Korean System Settings (Control Center)
Slovenian System Settings (Control Center)
Italian System Settings (Control Center)
Portuguese System Settings (Control Center)
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Note: The Keyboard Indicator should be used on Linux systems using Gnome as
a desktop environment.

When using a Hungarian keyboard from a Linux client, the Latin letter U with
Double Acute and the Latin letter O with Double Acute work only with JRE 1.6
(and later).

There are several methods that can be used to set the keyboard language
preference on Fedora® Linux clients. The following method must be used in
order for the keys to be mapped correctly from the Virtual KVM Client (VKC).

To set the keyboard language using System Settings:

From the toolbar, choose System > Preferences > Keyboard.
Open the Layouts tab.

Add or select the appropriate language.

Click Close.

PN Y

To set the keyboard language using the Keyboard Indicator:
Right-click the Task Bar and choose Add to Panel.

2. Inthe Add to Panel dialog, right-click the Keyboard Indicator and from the
menu choose Open Keyboard Preferences.

In the Keyboard Preferences dialog, click the Layouts tab.

Add and remove languages as necessary.

Macros Not Saving on Linux Targets

If you receive the following error message when you create and then save a
macro on a target server running Linux® Fedora™ 18 with Java" 1.7.0 (update 45
and later), disable SELinux in Fedora 18 on the target server to resolve the
problem.

"An error occurred attempting to write the new keyboard
macros. Macro was not added"
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Mac Keyboard Keys Not Supported for Remote Access

When a Mac® is used as the client, the following keys on the Mac® keyboard are
not captured by the Java” Runtime Environment (JRE"):

e F9

e F10
e Fl11
e Fl14
e F15

e Volume Up

e Volume Down
e Mute

e Eject

As a result, the Virtual KVM Client (VKC) are unable to process these keys from
a Mac client's keyboard.

Mouse Notes
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Mouse Pointer Synchronization (Fedora)

When connected in dual mouse mode to a target device running Fedora® 7, if
the target and local mouse pointers lose synchronization, changing the mouse
mode from or to Intelligent or Standard may improve synchronization.

Single mouse mode may also provide for better control.

»  To resynchronize the mouse cursors:
e Use the Synchronize Mouse option from the Virtual KVM Client (VKC).

Single Mouse Mode when Connecting to a Target Under CC-SG Control

When using Firefox® to connect to a KX Ill target under CC-SG control using
DCIM-PS2 or DCIM-USBG2, if you change to Single Mouse Mode in the Virtual
KVM Client (VKC), the VKC window will no longer be the focus window and the
mouse will not respond.

If this occurs, left click on the mouse or press Alt+Tab to return the focus to the
VKC window.

Mouse Sync Issues in Mac OS 10

In Mac OS 10, if mouse sync is an issue at some resolutions, use USB profile
"General" and Absolute mouse mode.
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Audio

Audio Playback and Capture Issues
Features that May Interrupt an Audio Connection

If you use any of the following features while connected to an audio device,
your audio connection may be interrupted. These features are not
recommended if you are connected to an audio device:

e Video Auto-Sense

e  Extensive use of the local port

e Adding users

Issues when Using a Capture Device and Playback Device Simultaneously on a
Target

On some targets, the simultaneous connection of capture devices and playback
devices may not work due to the USB hub controller and how it manages the
USB ports. Consider selecting an audio format that requires less bandwidth.

If this does not resolve the issue, connect the D2CIM-DVUSB CIM's keyboard
and mouse connector to a different port on the target. If this does not solve the
problem, connect the device to a USB hub and connect the hub to the target.

Audio in a Linux Environment

The following are known issues when using the audio feature in a Linux®
environment.

e Linux® users, use the default audio device for playback. Sound may not
come through if a non-default sound card is selected.

e  SuSE 11 clients require Javas_1_6_0-sun-alsa (ALSA support for

java-1_6_0-sun) to be installed via YAST.

e For Logitech® headsets with a built in a mic, only the Mono Capture option
is available.

e Inorder to display the device, if you are running SUSE 11 and an ALSA
driver, log out of KX I, then log back in.
Additionally, if you connect and disconnect the audio device a number of
times, the device may be listed several times vs. just once as it should.

e Using the audio feature with a Fedora Core® 13 target set to mono 16 bit,
44k may cause considerable interference during playback.

Audio in a Windows Environment

On Windows* 64-bit clients, only one playback device is listed on the Connect
Audio panel when accessing the device through the Virtual KVM Client (VKC).

The audio device is the default device, and is listed on the Connect Audio panel
as Java Sound Audio Engine.
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Smart Card Notes

Virtual KVM Client (VKC) Smart Card Connections to Fedora Servers

If you are using a smart card to connect to a Linux® Fedora® server via Virtual
KVM Client (VKC) upgrade the pcsc-lite library to 1.4.102-3 or above.

CC-SG Notes

Virtual KVM Client Version Not Known from CC-SG Proxy Mode

When the Virtual KVM Client (VKC) is launched from CommandCenter Secure
Gateway (CC-SG) in proxy mode, the VKC version is unknown.

In the About Raritan Virtual KVM Client dialog, the version is displayed as
“Version Unknown”.

Moving Between Ports on a Device

If you move a between ports on the same Raritan device and resume
management within one minute, CC-SG may display an error message.

If you resume management, the display will be updated.

Browser Notes

Resolving Issues with Firefox Freezing when Using Fedora

If you are accessing Firefox® and are using a Fedora“ server, Firefox may freeze
when it is opening.

To resolve this issue, install the libnpjp2.so Java” plug-in on the server.
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Question

What is Dominion KX 111?

How is KX Il
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different from KX II ?

Appendix F: Frequently Asked Questions

Answer

Dominion KX Il is a third-generation digital KVM
(keyboard, video, mouse) switch that enables one,
two, four or eight IT administrators to access and
control 8, 16, 32 or 64 servers over the network
with BIOS-level functionality. Dominion KX Il is
completely hardware- and OS-independent; users
can troubleshoot and reconfigure servers even
when servers are down.

At the rack, Dominion KX Ill provides the same
functionality, convenience, and space and cost
savings as traditional analog KVM switches.
However, Dominion KX Il also integrates the
industry’s highest performing KVM-over-IP
technology, allowing multiple administrators to
access server KVM consoles from any networked
workstation as well as from the iPhone® and iPad".

The KX Ill is the next generation version of the KX II.
Featuring a modern hardware design with
increased computing power and storage, the KX llI
provides KVM-over-IP access for IT
administration, as well as high performance IP
access for broadcast applications. KX Il includes
virtually all KX Il features with the following
advancements:

The KX lll's new video processing engine supports a
broad range of applications from traditional
computer applications to the most dynamic
broadcast applications requiring 30
frames-per-second 1920x1080 video, 24 bit color,
digital audio, dual monitors and DVI, HDMI,
DisplayPort and VGA video.

With the industry’s first DVI-based local port, the
KX llI's common user interface provides new levels
of productivity and performance for at-the-rack
administration and server access.

All KX Il models feature a tiering port to connect
multiple Dominion KX Il switches together and
access the attached servers. Up to 1024 servers can
be accessed via a consolidated port list.

KX 11l supports all Dominion and Paragon Il CIMs
supported by KX II.
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Question Answer

How does Dominion KX IlI differ from  When using Dominion KX lll remotely, the

remote control software? interface, at first glance, may seem similar to
remote control software such as pcAnywhere™,
Windows’ Terminal Services/Remote Desktop,
VNC, etc. However, because Dominion KX Il is not
a software but a hardware solution, it’s much more
powerful:

Hardware- and OS-independent — Dominion KX IlI
can be used to manage servers running many
popular OSs, including Intel’, Sun®, PowerPC
running Windows, Linux’, Solaris™, etc.

State-independent/Agentless — Dominion KX IIKX
Il does not require the managed server OS to be
up and running, nor does it require any special
software to be installed on the managed server.

Out-of-band — Even if the managed server’s own
network connection is unavailable, it can still be
managed through Dominion KX Il1.

BIOS-level access — Even if the server is hung at
boot up, requires booting to safe mode, or requires
system BIOS parameters to be altered, Dominion
KX 111 still works flawlessly to enable these
configurations to be made.

Can the Dominion KX Il be rack Yes. The Dominion KX Il ships standard with 19"
mounted? rack mount brackets. It can also be reverse rack
mounted so the server ports face forward.

How large is the Dominion KX I11? Dominion KX Ill is only 1U high (except the KX3-864
and KX3-464, which are 2U), fits in a standard 19"
rack mount and is only 11.4" (29 cm) deep. The
Dominion KX3-832 and KX3-864 are 13.8" (36 cm)
deep.

Remote Access
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Question

How many users can remotely access
servers on each Dominion KX III?

Can | remotely access servers from
my iPhone or iPad?

Can two people look at the same
server at the same time?

Can two people access the same
server, one remotely and one from
the local port?

In order to access Dominion KX IlI
from a client, what hardware,
software or network configuration is
required?

Raritan.
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Answer

Dominion KX Il models offer remote connections
for up to eight users per user channel to
simultaneously access and control a unique target
server. For one-channel appliances like the
DKX3-116, up to eight remote users can access and
control a single target server. For two-channel
appliances, like the DKX3-216, up to eight users can
access and control the server on channel one and
up to another eight users on channel two. For
four-channel appliances, up to eight users per
channel, for a total of 32 (8 x 4) users, can access
and control four servers. Likewise, for the
eight-channel appliances, up to eight users can
access a single server, up to an overall maximum of
32 users across the eight channels.

Yes. Users can access servers connected to the KX
Il using their iPhone or iPad.

Mobile access is provided through Mobile Access
Client, which requires the use of CommandCenter
Secure Gateway (CC-SG).

Yes. Actually, up to eight people can access and
control any single server at the same time.

Yes. The local port is completely independent of
the remote "ports." The local port can access the
same server using the PC-Share feature.

Because Dominion KX Il is completely
Web-accessible, it doesn’t require customers to
install proprietary software on clients used for
access.

Dominion KX Il can be accessed through major
Web browsers, including: Internet Explorer® and
Firefox®. Dominion KX lll can be accessed on
Windows’, Linux® and Mac’® desktops, via Raritan’s
Windows Client, and the Java"-based Virtual KVM
Client".

Dominion KX lll administrators can also perform
remote management (set passwords and security,
rename servers, change IP address, etc.) using a
convenient browser-based interface.
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Question

What is the file size of the applet
that’s used to access Dominion KX III?
How long does it take to retrieve?

Do you have a Windows KVM Client?

Do you have a non-Windows KVM
Client?

Do your KVM Clients have
multi-language support?

Do your KVM Clients support dual LCD
monitors?

Answer

The Virtual KVM Client (VKC) applet used to access
Dominion KX Il is approximately 500KB in size. The
following chart describes the time required to
retrieve Dominion KX IIl's applet at different
network speeds:

100Mbps Theoretical 100Mbit .05 seconds
network speed

60Mbps Likely practical .08 seconds
100Mbit network
speed

10Mbps Theoretical 10Mbit .4 seconds
network speed

6Mbps Likely practical .8 seconds
10Mbit network
speed

512Kbps Cable modem 8 seconds
download speed
(typical)

Yes. We have a native .NET Windows Client called
the Raritan Active KVM Client (AKC). See Active
KVM Client (AKC) Help (on page 75)

Yes. The Virtual KVM Client (VKC) allows
non-Windows users to connect to target servers in
the data center. See Virtual KYM Client (VKC and
VKCs) Help (on page 35)

Yes. The Dominion KX III’s remote HTML User
Interface and the KVM Clients support the
Japanese, Simplified Chinese and Traditional
Chinese languages. This is available stand-alone as
well as through CC-SG.

Yes. For customers wishing to enhance their
productivity by using multiple LCD monitors on
their desktops, the Dominion KX Il can launch KVM
sessions to multiple monitors, either in full screen
or standard modes.
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Question

Do you support servers with dual
video cards?

How do | access servers connected to
Dominion KX Il if the network ever
becomes unavailable?

Appendix F: Frequently Asked Questions

Answer

Yes, dual video cards are supported with an
extended desktop configuration available to the
remote user.

You can access servers at the rack or via modem.

Dominion KX Il offers a dedicated modem port for
attaching an external modem.

Universal Virtual Media

Question

Which Dominion KX Ill models
support virtual media?

Which types of virtual media does the
Dominion KX Ill support?

Raritan.
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Answer

All Dominion KX Il models support virtual media. It
is available stand-alone and through
CommandCenter® Secure Gateway, Raritan’s
centralized management appliance.

Dominion KX Il supports the following types of
media: internal and USB-connected CD/DVD drives,
USB mass storage devices, PC hard drives and ISO
images.
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Question Answer

What is required for virtual media? A Dominion KX Il virtual media CIM is required.
There are two VGA-based CIMs: a D2CIM-VUSB or
D2CIM-DVUSB.

The D2CIM-VUSB has a single USB connector and is
for customers who will use virtual media at the OS
level.

The D2CIM-DVUSB has dual USB connectors and
should be purchased by customers who wish to
utilize virtual media at the BIOS level. The
D2CIM-DVUSB is also required for smart card
authentication, tiering/cascading and digital audio.

Both support virtual media sessions to target servers
supporting the USB 2.0 interface. Available in
economical 32 and 64 quantity CIM packages, these
CIMs support Absolute Mouse Synchronization™ as
well as remote firmware updates.

Our CIMs have traditionally supported analog VGA
video. Three new dual virtual media CIMs support
digital video formats, including DVI, HDMI and
DisplayPort. These are the D2CIM-DVUSB-DVI,
D2CIM-DVUSB-HDMI and

D2CIM-DVUSB-DP.

Is virtual media secure? Yes. Virtual media sessions are secured using 256-bit
AES or 128-bit AES  encryption.

Does virtual media really support Yes. Audio playback and recording to a server

audio? connected to the Dominion KX Il is supported. You
can listen to sounds and audio playing on a remote
server in the data center using the speakers
connected to your desktop PC or laptop. You can
also record on the remote server using a
microphone connected to your PC or laptop. A
digital CIM or D2CIM-DVUSB dual virtual media CIM
is required.

What is a USB profile? Certain servers require a specifically configured USB
interface for USB-based services such as virtual
media. The USB profile tailors the KX III’'s USB
interface to the server to accommodate these
server-specific characteristics.

228 Raritan.

A brand of Olegrand



Question
Why would | use a USB profile?

How is a USB profile used?

Do | always need to set a USB profile
when | use virtual media?

What profiles are available? Where
can | find more information?

Appendix F: Frequently Asked Questions

Answer

USB profiles are most often required at the BIOS
level where there may not be full support for the
USB specification when accessing virtual media
drives. However, profiles are sometimes used at the
OS level, for example, for mouse synchronization for
Mac and Linux servers.

Individual ports or groups of ports can be configured
by the administrator to use a specific USB profile in
the KX III’s port configuration page. A USB profile
can also be selected in the KX 11l Client when
required. See the user guide for more information.

No. In many cases, the default USB profile is
sufficient when using virtual media at the OS level or
operating at the BIOS level without accessing virtual
media.

Consult the user guide for the available profiles and
for more information.

Bandwidth and KVM-over-IP Performance
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Question Answer
How is bandwidth used in Dominion KX Il offers totally new video processing
KVM-over-IP systems? that provides flexible, high performance video,

efficient use of bandwidth and anytime/anywhere
access via LAN, WAN or Internet.

The Dominion KX Il digitizes, compresses and
encrypts the keyboard, video and mouse signals
from the target server and transmits IP packets
over the IP network to the remote client to create
the remote session to the user. The KX Il provides
an at-the-rack experience based on its
industry-leading video processing algorithms.

Screen changes, i.e., video accounts for the
majority of the bandwidth used — and keyboard
and mouse activity are significantly less.

It is important to note that bandwidth is only used
when the user is active. The amount of bandwidth
used is based on the amount of change to the
server’s video display screen.

If there are no changes to the video —the user is
not interacting with the server —there is generally
little to no bandwidth used. If the user moves the
mouse or types a character, then there is a small
amount of bandwidth used. If the display is running
a complex screen saver or playing a video, then
there can be a larger amount of bandwidth used.

How does bandwidth affect In general, there is a trade-off between bandwidth

KVM-over-IP performance? and performance. The more bandwidth available,
the better performance can be. In limited
bandwidth environments, performance can
degrade. The Dominion KX lll has been optimized
to provide strong performance in a wide variety of
environments.
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Question
What factors affect bandwidth?

How much bandwidth does KX Il use
for common tasks?

How do | optimize performance and
bandwidth?
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Answer

There are many factors that determine how much
bandwidth will be used. The primary factor, noted
above, is the amount of change in the target
server’s video display. This is dependent on the
user’s task and actions.

Other factors include the server’s video resolution,
networking speed and characteristics, the KVM
Client Connection Properties, client PC resources
and video card noise.

Bandwidth primarily depends on the user’s task
and actions. The more the server’s video screen
changes, the more bandwidth is utilized.

KX 1ll provides a variety of settings in our remote
clients for the user to optimize bandwidth and
performance. The default settings will provide an
at-the-rack level of performance in standard
LAN/WAN environments with economical use of
bandwidth.

Optimize For. Use this setting to configure the
video engine for standard IT/computer applications
or for video/broadcast applications.

Compression. Move the slider to the left for the
highest possible video quality and to the right for
the least amount of bandwidth.

Noise Filter. In most cases, the default setting
will work best, however you can move to the left
for more responsive video and to the right for
lower bandwidth.

Other tips to decrease bandwidth include:

= Use a solid desktop background instead of a
complex image

= Disable screensavers

= Use a lower video resolution on the target
server

= Uncheck the "Show window contents while
dragging" option in Windows

= Use simple images, themes and desktops (e.g.,
Windows Classic)
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Question

| want to connect over the Internet.
What type of performance should |
expect?

| have a high bandwidth environment.
How can | optimize performance?

What is the maximum remote (over
IP) video resolution supported?

How much bandwidth is used for
audio?

What about servers with DVI ports?

Answer

It depends on the bandwidth and latency of the
Internet connection between your remote client
and the KX IIl. With a cable modem or high speed
DSL connection, your performance can be very
similar to a LAN/WAN connection. For lower speed
links, use the suggestions above to improve
performance.

The default settings will work well.  You can move
the Connection Properties settings to the left for
increased video performance.

The Dominion KX Ill is the first and only
KVM-over-IP switch to support full high definition
(HD) remote video resolution — 1920x1080 at
frame rates up to 30 frames per second with digital
audio.

In addition, popular widescreen formats are
supported, including 1600x1200, 1680x1050 and
1440x900, so remote users can work with today’s
higher resolution monitors.

It depends on the type of audio format used, but to
listen to CD quality audio, approximately 1.5 Mbps
is used.

Servers with DVI ports that support DVI-A (analog)
and DVI-I (integrated analog and digital) can use
Raritan’s ADVI-VGA inexpensive, passive adapter to
convert the server’s DVI port to a VGA plug that
can be connected to a KX lll CIM’s VGA plug.

Servers with DVI ports that support DVI-I or DVI-D
(digital) can use the new D2CIM-DVUSB-DVI CIM.

IPv6 Networking

232

Raritan.

Abrand of O legrand



Question
What is IPv6?

Why does KX 1l support IPv6
networking?

What is "dual stack" and why is
it required?

How do | enable IPv6 on the KX
"

What if | have an external
server with an IPv6 address that
| want to use with my KX 11I?

What if my network doesn’t
support IPv6?

Where can | get more
information on IPv6?
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Answer

IPv6 is the acronym for Internet Protocol Version 6. IPv6 is
the "next generation" IP protocol which will replace the
current IP Version 4 (IPv4) protocol.

IPv6 addresses a number of problems in IPv4, such as the
limited number of IPv4 addresses. It also improves IPv4 in
areas such as routing and network auto-configuration.
IPv6 is expected to gradually replace IPv4, with the two
coexisting for a number of years.

IPv6 treats one of the largest headaches of an IP network
from the administrator’s point of view — configuring and
maintaining an IP network.

U.S. government agencies and the Department of Defense
are now mandated to purchase IPv6-compatible products.
In addition, many enterprises and foreign countries, such
as China, will be transitioning to IPv6 over the next several
years.

Dual stack is the ability to simultaneously support IPv4 and
IPv6 protocols. Given the gradual transition from IPv4 to
IPv6, dual stack is a fundamental requirement for IPv6
support.

Use the "Network Settings" page, available from the
"Device Settings" tab. Enable IPv6 addressing and choose
manual or auto-configuration. Consult the user guide for
more information.

The KX Il can access external servers via their IPv6
addresses, for example, an SNMP manager, syslog server
or LDAP server.

Using the KX IlI’s dual-stack architecture, these external
servers can be accessed via: (1) an IPv4 address, (2) IPv6
address or (3) hostname. So, the KX Ill supports the mixed
IPv4/IPv6 environment many customers will have.

The KX llI's default networking is set at the factory for IPv4
only. When you are ready to use IPv6, then follow the
above instructions to enable IPv4/IPv6 dual-stack
operation.

See www.ipv6.org for general information on IPv6. The KX
Il user guide describes the KX II’s support for IPv6.
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Servers

Question

Does Dominion KX Il depend on a
Windows server to operate?

What should | do to prepare a server
for connection to Dominion KX III?

What about mouse synchronization?

What comes in the Dominion KX IlI
box?

Answer

Absolutely not. Because users depend on the KVM
infrastructure to always be available in any
scenario whatsoever (as they will likely need to use
the KVM infrastructure to fix problems), Dominion
KX lll is designed to be completely independent
from any external server.

Set the mouse parameter options to provide users
with the best mouse synchronization and turn off
screensavers and any power management features
that affect screen display.

In the past, KVM-over-IP mouse synchronization
was a frustrating experience. The Dominion KX IIl’s
Absolute Mouse Synchronization provides for a
tightly synchronized mouse without requiring
server mouse setting changes on Windows and
Apple® Mac servers. For other servers, the
Intelligent Mouse mode or the speedy, single
mouse mode can be used to avoid changing the
server mouse settings.

The following is included: (1) Dominion KX IlI
appliance, (2) Quick Setup Guide, (3) standard 19"
rack mount brackets, (4) user manual CD-ROM, (6)
localized AC line cord and (7) warranty certificate
and other documentation.

Blade Servers

Question

Can | connect blade servers to the
Dominion KX 111?

Which blade servers are supported?

Answer

Yes. Dominion KX Ill supports popular blade server
models from the leading blade server
manufacturers: HP*, IBM®, Dell° and Cisco".

The following models are supported: Dell
PowerEdge® 1855, 1955 and M1000e; HP
BladeSystem ¢3000 and c7000; IBM BladeCenter®
H, E and S; and Cisco UCS B-Series.

Raritan.

Abrand of O legrand



Question
Which CIM should | use?

Which types of access and control are

available?

Do | have to use hotkeys to switch
between blades?

Can | access the blade server’s
management module?

How many blade servers can |
connect to a Dominion KX 111?

I’'m an enterprise customer using
CommandCenter Secure Gateway.
Can | access blade servers via
CommandCenter Secure Gateway?

What if | also want in-band or
embedded KVM access?

I’'m running VMware® on some of my
blade servers. Is this supported?
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Answer

It depends on the type of KVM ports on the specific
make and model of the blade server you are using.
The following CIMs are supported: DCIM-PS2,
DCIM-USBG2, D2CIM-VUSB and D2CIM-DVUSB.

The Dominion KX Ill provides automated and
secure KVM access: (1) at the rack, (2) remotely
over IP, (3) via CommandCenter and (4) by modem.

Some blade servers require you to use hotkeys to
switch between blades. With the Dominion KX 11,
you don’t have to use these hotkeys. Just click on
the name of the blade server, and the Dominion KX
Il will automatically switch to that blade without
the explicit use of the hotkey.

Yes. You can define the URL of the management
module and access it from the Dominion KX Il or
from our CommandCenter Secure Gateway. If
configured, one-click access is available.

For performance and reliability reasons, you can
connect up to eight blade chassis to a Dominion KX
Ill, regardless of model. Raritan recommends
connecting up to two times the number of remote
connections supported by the device. For example,
with a KX3-216 with two remote channels, we
recommend connecting up to four blade server
chassis. You can, of course, connect individual
servers to the remaining server ports.

Yes. Once blade servers are configured on the
Dominion KX Ill, the CommandCenter Secure
Gateway user can access them via KVM
connections. In addition, the blade servers are
organized by chassis as well as CommandCenter
Secure Gateway custom views.

In-band and embedded access to blade servers can
be configured within CommandCenter Secure
Gateway.

Yes. With CommandCenter Secure Gateway, you
can display and access virtual machines running on
blade servers.
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Question

Is virtual media supported?

Is Absolute Mouse Synchronization
supported?

Is blade access secure?

Does the Dominion KSX Il or the KX

Answer

This depends on the blade server. HP blades can
support virtual media. The IBM BladeCenter
(except for BladeCenter T) supports virtual media if
configured appropriately. A virtual media CIM —
D2CIM-VUSB or D2CIM-DVUSB — must be used.

Servers with internal KVM switches inside the
blade chassis typically do not support absolute
mouse technology. For HP blade and some Dell
blade servers, a CIM can be connected to each
blade, so Absolute Mouse Synchronization is
supported.

Yes. Blade access uses all of the standard Dominion
KX 11l security features such as 128-bit or 256-bit
encryption. In addition, there are blade-specific
security features such as per blade access
permissions and hotkey-blocking that eliminates
unauthorized access.

At this time, these products do not support blade
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111-101 support blade servers? servers.
Installation
Question Answer

Besides the appliance itself, what do |

need to order to install Dominion KX
"

Which kind of Cat5 cabling should be
used in my installation?

Which types of servers and PCs can be
connected to Dominion KX III?

Each server that connects to Dominion KX 111
requires a Dominion or Paragon computer
interface module (CIM), an adapter that connects
directly to the keyboard, video and mouse ports of
the server.

Dominion KX lll can use any standard UTP
(unshielded twisted pair) cabling, whether Cat5,
Cat5e or Cat6. Often in our manuals and marketing
literature, Raritan will simply say "Cat5" cabling for
short. In actuality, any brand UTP cable will suffice
for Dominion KX III.

Dominion KX Il is completely vendor independent.
Any server with standards-compliant keyboard,
video and mouse ports can be connected. In
addition, servers with serial ports can be controlled
using the DSAM.
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Question

How do | connect servers to Dominion
KX 1117?

How far can my servers be from
Dominion KX III?

Some operating systems lock up when
| disconnect a keyboard or mouse
during operation. What prevents
servers connected to Dominion KX Il
from locking up when | switch away
from them?

Are there any agents
that must be installed on servers
connected to Dominion KX I11?

How many servers can be connected
to each Dominion KX Ill appliance?

What happens if | disconnect a server

from Dominion KX Il and reconnect it
to another Dominion KX Il appliance,

or connect it to a different port on the
same Dominion KX Il appliance?
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Answer

Servers that connect to the Dominion KX Il require
a Dominion or Paragon CIM, which connects
directly to the keyboard, video and mouse ports of
the server. Then, connect each CIM to Dominion KX
Il using standard UTP (unshielded twisted pair)
cable such as Cat5, Cat5e or Cat6.

In general, servers can be up to 150 feet (45 m)
away from Dominion KX Ill, depending on the type
of server. (See Target Server Video Resolution -
Supported Connection Distances and Refresh
Rates (on page 188)) For the D2CIM-VUSB CIMs
that supports virtual media and Absolute Mouse
Synchronization, a 100-foot (30 m) range is
recommended.

Each Dominion computer interface module (DCIM)
dongle acts as a virtual keyboard and mouse to the
server to which it is connected. This technology is
called KME (keyboard/mouse emulation). Raritan’s
KME technology is data center grade, battle-tested
and far more reliable than that found in lower-end
KVM switches: it incorporates more than 15 years
of experience and has been deployed to millions of
servers worldwide.

Servers connected to Dominion KX Il do not
require any software agents to be installed because
Dominion KX lll connects directly via hardware to
the servers’ keyboard, video and mouse ports.

Dominion KX Il models range from 8, 16 or 32
server ports in a 1U chassis, to 64 server ports in a
2U chassis. This is the industry’s highest digital
KVM switch port density.

Dominion KX Il will automatically update the
server port names when servers are moved from
port to port. Furthermore, this automatic update
does not just affect the local access port, but
propagates to all remote clients and the optional
CommandCenter Secure Gateway management
appliance.
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Question Answer

How do | connect a serially controlled Connecting a KX lll and a Dominion Serial Access
(RS-232) device, such as a Cisco Module (DSAM) provides serial access for the KX Il1.
router/switch ora headless Sun The DSAM is a 2- or 4 port serial module that
server, to Dominion derives power from the KX III.

KX 111?

Local Port - KX 11l

Question Answer

Can | access my servers directly from  Yes. At the rack, Dominion KX Il functions just like a

the rack? traditional KVM switch — allowing control of up to 64
servers using a single keyboard, monitor and mouse.
You can switch between servers by the browser-
based user interface or via a hotkey.

Can | consolidate the local ports of Yes. You can connect the local ports of multiple KX

multiple KX IlIs? Il switches to another KX Ill using the "tiering"
feature of the KX Ill. You can then access the servers
connected to your KX Il appliances from a single
point in the data center via a consolidated port list.

When | am using the local port, do | No. The Dominion KX Ill local port has a completely
prevent other users from accessing independent access path to the servers. This means
servers remotely? a user can access servers locally at the rack —

without compromising the number of users that
access the rack remotely at the same time.

Can | use a USB keyboard or mouse at Yes. The Dominion KX Il has USB keyboard and

the local port? mouse ports on the local port. Dominion KX 111
switches do not have PS/2 local ports. Customers
with PS/2 keyboards and mice should utilize a PS/2
to USB adapter.

Is there an onscreen display (OSD) for Yes, but Dominion KX IlI’s at-the-rack access goes

local, at-the-rack access? way beyond conventional OSDs. Featuring the
industry’s first browser-based interface for
at-the-rack access, Dominion KX IlI’s local port uses
the same interface for local and remote access.
Moreover, most administrative functions are
available at the rack.
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Question

How do | select between servers
while using the local port?

How do | ensure that only authorized
users can access servers from the
local port?

Appendix F: Frequently Asked Questions

Answer

The local port displays the connected servers using

the same user interface as the remote client. Users

connect to a server with a simple click of the mouse
or via a hotkey.

Users attempting to use the local port must pass the
same level of authentication as those accessing
remotely. This means that:

If the Dominion KX Il is configured to interact with
an external RADIUS, LDAP or Active Directory”
server, users attempting to access the local port will
authenticate against the same server.

If the external authentication servers are
unavailable, Dominion KX Ill fails over to its own
internal authentication database.

Dominion KX Il has its own stand-alone
authentication, enabling instant, out-of-the-box
installation.

Extended Local Port

Question

What is the extended local port?

Answer

The Dominion KX2-808, KX2-832 and KX2-864
featured an extended local port. The corresponding
Dominion KX Il models do not have an extended
local port. Instead all KX lll models have a tiering
port.

To extend the KX llI's digital local port, you can use
the Raritan Cat5 Reach DVI product for local and
remote access up to 500 meters.

See Connecting a KX Ill and Cat5 Reach DVI -

Provide Extended Local Port Functionality (on
page 167)

Dual Power Supplies
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Question

Does Dominion KX Il have a dual
power option?

Does the power supply used by
Dominion KX Il automatically detect
voltage settings?

If a power supply or input fails, will |
be notified?

Answer

Yes. All Dominion KX Il models come equipped with
dual AC inputs and power supplies with automatic
failover. Should one of the power inputs or power
supplies fail, then the KX Il will automatically switch
to the other.

Yes. Dominion KX IlI's power supply can be used in
AC voltage ranges from 100-240 volts, at 50-60 Hz.

The Dominion KX Il front panel LED will notify the
user of a power failure. An entry will also be sent to
the audit log and displayed on the KX remote client
user interface. If configured by the administrator,
then SNMP or syslog events will be generated.

Intelligent Power Distribution Unit (PDU) Control

Question

What type of remote power control
capabilities does Dominion KX IlI
offer?

What type of power strips does
Dominion KX Ill support?

How many PDUs can be connected to
a Dominion KX 111?

How do | connect the PDU to the
Dominion KX 111?

Answer

Raritan’s intelligent PDUs can be connected to the
Dominion KX Il to provide power control of target
servers and other equipment. For servers, after a
simple one-time configuration step, just click on
the server name to power on, off or to recycle a
hung server.

Raritan’s Dominion PX" and Remote Power Control
(RPC) power strips.

These come in many outlet, connector and amp
variations. Note that you should not connect the
PM series of power strips to the Dominion KX IIl as
these power strips do not provide outlet-level
switching.

Up to eight PDUs can be connected to a Dominion
KX Il appliance.

The D2CIM-PWR is used to connect the power strip
to the Dominion KX IIl. The D2CIM-PWR must be
purchased separately; it does not come with the
PDU.
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Question

Does Dominion KX Ill support servers
with multiple power supplies?

Does the Dominion KX Il display
statistics and measurements from the
PDU?

Does remote power control require
any special configuration of attached
servers?

What happens when | recycle power
to a server?

Appendix F: Frequently Asked Questions

Answer

Yes. Dominion KX Il can be easily configured to
support servers with multiple power supplies
connected to multiple power strips. Four power
supplies can be connected per target server.

Yes. PDU-level power statistics, including power,
current and voltage, are retrieved from the PDU
and displayed to the user.

Some servers ship with default BIOS settings such
that the server does not automatically restart after
losing and regaining power. For these servers, see
the server’s documentation to change this setting.

Note that this is the physical equivalent of
unplugging the server from the AC power line, and
reinserting the plug.

Ethernet and IP Networking

Question

What is the speed of Dominion KX llI’s
Ethernet interfaces?

Can | access Dominion
KX 11l over a wireless connection?

Does the Dominion KX Il offer dual
gigabit Ethernet ports to provide
redundant failover or load balancing?

Raritan.
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Answer

Dominion KX Ill supports gigabit as well as 10/100
Ethernet. KX Ill supports two 10/100/1000 speed
Ethernet interfaces, with configurable speed and
duplex settings (either auto detected or manually
set).

Yes. Dominion KX Il not only uses standard
Ethernet, but also very conservative bandwidth with
very high quality video. Thus, if a wireless client has
network connectivity to a Dominion KX Ill, servers
can be configured and managed at the BIOS level
wirelessly.

Yes. Dominion KX Ill features dual gigabit Ethernet
ports to provide redundant failover capabilities.
Should the primary Ethernet port (or the
switch/router to which it is connected) fail,
Dominion KX Il will failover to the secondary
network port with the same IP address — ensuring
that server operations are not disrupted. Note that
automatic failover must be enabled by the
administrator.
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Question

Can | use Dominion KX Il with a VPN?

Can | use KX Il with a proxy server?

How many TCP ports must be open on
my firewall in order to enable
network access to Dominion KX III?

Are these ports configurable?

Can Dominion KX Il be used with
Citrix*?

Can the Dominion KX Ill use DHCP?

Answer

Yes. Dominion KX Il uses standard Internet Protocol
(IP) technologies from Layer 1 through Layer 4.
Traffic can be easily tunneled through standard
VPNs.

Yes. KX Il can be used with a SOCKS proxy server,
assuming the remote client PC is configured
appropriately. Contact the user documentation or
online help for more information.

Two ports are required: TCP port 5000 to discover
other Dominion appliances and for communication
between Raritan appliances and CC-SG; and, of
course, port 443 for HTTPS communication.

Yes. Dominion KX III's TCP ports are configurable by
the administrator.

Dominion KX Il may work with remote access
products like Citrix if configured appropriately, but
Raritan cannot guarantee it will work with
acceptable performance. Customers should realize
that products like Citrix utilize video redirection
technologies similar in concept to digital KVM
switches so that two KVM-over-IP technologies are
being used simultaneously.

DHCP addressing can be used; however, Raritan
recommends fixed addressing since the Dominion
KX 1l is an infrastructure appliance and can be
accessed and administered more effectively with a
fixed IP address.
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Appendix F: Frequently Asked Questions

Question Answer
I’'m having problems connecting to The Dominion KX Il relies on your LAN/WAN
the Dominion KX Il over my IP network. Some possible problems include:

network. What could be the problem? «

Ethernet auto-negotiation. On some networks,
10/100 auto-negotiation does not work properly,
and the Dominion KX Il appliance must be set to
100 Mb/full duplex or the appropriate choice for
its network.

Duplicate IP address. If the IP address of the
Dominion KX Ill is the same as another
appliance, network connectivity may be
inconsistent.

Port 5000 conflicts. If another appliance is using
port 5000, the Dominion KX Il default port must
be changed (or the other appliance must be
changed).

When changing the IP address of a Dominion KX
I, or swapping in a new Dominion KX III,
sufficient time must be allowed for its IP and
Mac® addresses to be known throughout the
Layer 2 and Layer 3 networks.

Local Port Consolidation, Tiering and Cascading

Raritan.
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Question

How do | physically connect multiple
Dominion KX Il appliances together
into one solution?

Answer

To physically connect multiple KX Il appliances
together for consolidated local access, you can
connect the Tiering ports of multiple "tiered" (or
"cascaded") KX Il switches to a "base" KX Ill using
the Tiering port of the KX Ill. You can then access
the servers connected to your KX Il appliances
from a single point in the data center via a
consolidated port list.

The Tiering port must be used to connect the
tiered KX Il switch to the base switch.

Access via the consolidated port list is available in
the data center or even from a remote PC. All
servers connected to the tiered KX Ills can be
accessed via a hierarchical port list or via search
(with wildcards).

Two levels of tiering are supported; up to 1024
appliances can be accessed in a tiered
configuration. Remote power control is also
supported.

Virtual media, smart card and blade server access
via tiered access will be supported in a future
release. Of course these features are available
when accessed via a standard remote connection.

While remote IP server access via the consolidated
port list is available as a convenience, remote
accessing a tiered server from CommandCenter or
via the KX Ill the server is connected to, is
recommended for optimal performance.
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Question

Do | have to physically connect
Dominion KX lll appliances together?

Is CC-SG required?

Can | connect an existing analog KVM
switch to Dominion KX I1I?

Raritan.
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Answer

Multiple Dominion KX Il appliances do not need to
be physically connected together. Instead, each
Dominion KX Il appliance connects to the network,
and they automatically work together as a single
solution if deployed with Raritan’s
CommandCenter Secure Gateway (CC-SG)
management appliance.

CC-SG acts as a single access point for remote
access and management.

CC-SG offers a significant set of convenient tools,
such as consolidated configuration, consolidated
firmware update and a single authentication and
authorization database.

Customers using CC-SG for centralized remote
access can make good use of the KX IlI’s tiering
(cascading) feature to consolidate the local ports of
multiple KX Il switches and locally access up to
1024 servers from a single console when in the
data center.

For customers wanting stand-alone usage (without
a central management system), multiple Dominion
KX Il appliances still interoperate and scale
together via the IP network. Multiple Dominion KX
Il switches can be accessed from the KX 11
Web-based user interface.

Yes. Analog KVM switches can be connected to one
of Dominion KX llI’s server ports. Simply use a USB
computer interface module (CIM), and attach it to
the user ports of the existing analog KVM switch.

Analog KVM switches supporting hotkey-based
switching on their local ports can be tiered to a
Dominion KX Il switch and switched via a
consolidated port list, both remotely and in the
data center.

Please note that analog KVM switches vary in their
specifications and Raritan cannot guarantee the
interoperability of any particular third-party analog
KVM switch. Contact Raritan technical support for
further information.
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Computer Interface Modules (CIMs)

Question Answer

What type of video is supported by Our CIMs have traditionally supported analog VGA

your CIMs? video. Three new CIMs support digital video
formats, including DVI, HDMI and DisplayPort.
These are the D2CIM-DVUSB-DVI,
D2CIM-DVUSB-HDMI and D2CIM-DVUSB-DP.

Can | use computer interface modules Yes. Certain Paragon computer interface modules
(CIMs) from Paragon, Raritan’s analog (CIMs) may work with Dominion KX IIKX llIl. (Please
matrix KVM switch, with Dominion KX check the Raritan Dominion KX Il Release Notes on
" the website for the latest list of certified CIMs.)

However, because Paragon CIMs cost more than
Dominion KX Il CIMs (as they incorporate
technology for video transmission of up to 1,000
feet [304 m]), it is not generally advisable to
purchase Paragon CIMs for use with Dominion KX
. Also note that when connected to Dominion KX
I, Paragon CIMs transmit video at a distance of up
to 150 feet (46 m), the same as Dominion KX lII
CIMs — not at 1,000 feet (304 m), as they do when
connected to Paragon.

Does Dominion KX Il support Paragon Yes. The Dominion KX Il supports Paragon Il Dual

Dual CIMs? CIMs (P2CIM-APS2DUAL and P2CIM-AUSBDUAL),
which can connect servers in the data center to
two different Dominion KX Il switches.

If one KX Il switch is not available, the server can
be accessed through the second KX Il switch,
providing redundant access and doubling the level
of remote KVM access.

Please note these are Paragon CIMs, so they do not
support the KX lll advanced features such as virtual
media, absolute mouse, audio, etc.

Security
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Question

Is the Dominion KX Il FIPS 140-2
Certified?

What kind of encryption does
Dominion KX Il use?

Does Dominion KX Il support AES
encryption as recommended by the
U.S. government’s NIST and FIPS
standards?

Does Dominion KX Il allow encryption
of video data? Or does it only encrypt
keyboard and mouse data?

How does Dominion KX Il integrate
with external authentication servers
such as Active Directory, RADIUS or
LDAP?

How are usernames and passwords
stored?

Raritan.
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Answer

The Dominion KX Il uses an embedded FIPS 140-2
validated cryptographic module running on a Linux
platform per FIPS 140-2 implementation
guidelines. This cryptographic module is used for
encryption of KVM session traffic consisting of
video, keyboard, mouse, virtual media and smart
card data.

Dominion KX Il uses industry-standard (and
extremely secure) 256-bit AES, 128-bit AES or
128-bit encryption, both in its SSL communications
as well as its own data stream. Literally no data is
transmitted between remote clients and Dominion
KX 11l that is not completely secured by encryption.

Yes. The Dominion KX Ill utilizes the Advanced
Encryption Standard (AES) for added security.
256-bit and 128-bit AES is available.

AES is a U.S. government-approved cryptographic
algorithm that is recommended by the National
Institute of Standards and Technology (NIST) in the
FIPS Standard 197.

Unlike competing solutions, which only encrypt
keyboard and mouse data, Dominion KX Il does
not compromise security — it allows encryption of
keyboard, mouse, video and virtual media data.

Through a very simple configuration, Dominion KX
Il can be set to forward all authentication requests
to an external server such as LDAP, Active Directory
or RADIUS. For each authenticated user, Dominion
KX Ill receives from the authentication server the
user group to which that user belongs. Dominion
KX Il then determines the user’s access
permissions depending on the user group to which
he or she belongs.

Should Dominion KX IlI’s internal authentication
capabilities be used, all sensitive information, such
as usernames and passwords, is stored in an
encrypted format. Literally no one, including
Raritan technical support or product engineering
departments, can retrieve those usernames and
passwords.
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Question

Does Dominion KX Ill support strong
passwords?

Can | upload my own digital certificate
to the Dominion KX IIKX [111?

Does the KX Il support a configurable
security banner?

My security policy does not allow the
use of standard TCP port numbers.
Can | change them?

Answer

Yes. The Dominion KX Il has
administrator-configurable, strong password
checking to ensure that user-created passwords
meet corporate and/or government standards and
are resistant to brute force hacking.

Yes. Customers can upload self-signed or certificate
authority-provided digital certificates to the
Dominion KX Il for enhanced authentication and
secure communication.

Yes. For government, military and other
security-conscious customers requiring a security
message before user login, the KX lll can display a
user-configurable banner message and optionally
require acceptance.

Yes. For customers wishing to avoid the standard
TCP/IP port numbers to increase security, the
Dominion KX Il allows the administrator to
configure alternate port numbers.

Smart Cards and CAC Authentication

Question

Answer

Does Dominion KX Ill support smart card  Yes. Smart cards and DoD common access cards

and CAC authentication?

What is CAC?

Which KX Il models support smart
cards/CAC?

Do enterprise and SMB customers use
smart cards, too?

248

(CAC) authentication to target servers is
supported.

Mandated by Homeland Security Presidential
Directive 12 (HSPD-12), CAC is a type of smart
card created by the U.S. government and used
by U.S. military and government staff. The CAC
card is a multitechnology, multipurpose card;
the goal is to have a single identification card.
For more information, see the FIPS 201
standards.

All Dominion KX Ill models are supported. The
Dominion KX 111-101 models do not currently
support smart cards and CAC.

Yes. However, the most aggressive deployment
of smart cards is in the U.S. federal government.
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Question

Which CIMs support
smart card/CAC?

Appendix F: Frequently Asked Questions

Answer
The D2CIM-DVUSB, D2CIM-DVUSB-DVI,

D2CIM-DVUSB-HDMI and D2CIM-DVUSB-DP are

the required CIMs.

Which smart card readers are supported? The required reader standards are USB CCID

and PC/SC. Consult the user documentation for
a list of certified readers and more information.

Can smart card/CAC authentication work  Yes. Smart card/CAC authentication works on

on the local port and via
CommandCenter?

both the local port and via CommandCenter.
For the local port, connect a compatible smart

card reader to the USB port of the Dominion KX

Manageability

Question

Can Dominion KX Il be remotely
managed and configured via Web
browser?

Can | back up and restore Dominion
KX 1lI’s configuration?

What auditing or logging does
Dominion KX Il offer?

Raritan.
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Answer

Yes. Dominion KX Il can be completely configured
remotely via Web browser. Note that this does
require that the workstation have an appropriate
Java Runtime Environment (JRE) version installed.
Besides the initial setting of Dominion KX III’s IP
address, everything about the solution can be
completely set up over the network. (In fact, using
a crossover Ethernet cable and Dominion KX llI’s
default IP address, you can even configure the
initial settings via Web browser.)

Yes. Dominion KX IlI's appliance and user
configurations can be completely backed up for
later restoration in the event of a catastrophe.

Dominion KX lll's backup and restore functionality
can be used remotely over the network, or through
your Web browser.

For complete accountability, Dominion KX Il logs
all major user events with a date and time stamp.
For instance, reported events include (but are not
limited to): user login, user logout, user access of a
particular server, unsuccessful login, configuration
changes, etc.
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Question

Can Dominion KX Il integrate with
syslog?

Can Dominion KX Ill integrate with

SNMP?

Can an administrator log-off a user?

Can Dominion KX lII’s internal clock be
synchronized with a timeserver?

Answer

Yes. In addition to Dominion KX IlI's own internal
logging capabilities, Dominion KX Il can send all
logged events to a centralized syslog server.

Yes. In addition to Dominion KX llI’'s own internal
logging capabilities, Dominion KX Il can send SNMP
traps to SNMP management systems. SNMP v2 and
v3 are supported.

Yes, administrators can view which users are
logged into which ports and can log-off a user from
a specific port or from the appliance if required.

Yes. Dominion KX Il supports the industry-standard
NTP protocol for synchronization with either a
corporate timeserver, or with any public
timeserver (assuming that outbound NTP requests
are allowed through the corporate firewall).
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Documentation and Support

Question

Is online help available?

Where do | find documentation on
the Dominion KX III?

What documentation is available?

What CIM should | use for a particular
server?

Answer

Yes. Online help is available from the KX lll user
interface, and at raritan.com with the
documentation.

Online help includes KX Il administration and end
user information on using the Remote Console,
Virtual KVM Client (VKC) Active KVM Client (AKC)
and Local Console, as well KX lll specifications,
informational notes, using KX lll with Paragon II,
connecting KX Il to the Cat5 Reach DVI, connecting
KX 11l to the T1700-LED, and so on.

The documentation is available at raritan.com. The
documentation is listed by firmware release.

A Quick Setup Guide, online help, a PDF version of
the help in the form of an Administrators Guide
and a Users Guide, as well as Release Notes and
other information are available.

Consult the CIM Guide available with the KX IlI
documentation. Note that DVI, HDMI and
DisplayPort video standards are supported with the
digital video ClMs.
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Question

How long is the hardware warranty
for the KX I1I?

Appendix F: Frequently Asked Questions

Answer

The Dominion KX Ill comes with a standard
two-year warranty, which can be extended to 5
years of warranty coverage.

Miscellaneous

Question
What is Dominion KX llI’s default IP
address?

What is Dominion KX IlI's default
username and password?

| changed and subsequently forgot
Dominion KX llI’'s administrative
password; can you retrieve it for me?

How do | migrate from the Dominion
KX 1l to Dominion KX I1I?

Will my existing KX Il CIMs work with
Dominion KX Il switches?
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Answer
192.168.0.192

The Dominion KX IlI’'s default username and
password are admin/raritan. However, for the
highest level of security, the Dominion KX Ill forces
the administrator to change the Dominion KX llI
default administrative username and password
when the appliance is first booted up. Username is
not case sensitive.

Dominion KX lll contains a hardware reset button
that can be used to factory reset the appliance,
which will reset the administrative password on
the appliance to the default password.

In general, KX Il customers can continue to use
their existing switches for many years. As their data
centers expand, customers can purchase and use
the new KX Il models. Raritan’s centralized
management appliance, CommandCenter Secure
Gateway (CC-SG) Release 6.0 supports KX Il and KX
Il switches seamlessly.

Yes. Existing KX Il CIMs will work with the Dominion
KX Il switch. In addition, select Paragon CIMs will
work with the KX lII. This provides an easy
migration to KX Il for Paragon Il customers who
wish to switch to KVM over IP. However, you may
want to consider the D2CIM-VUSB and
D2CIM-DVUSB CIMs that support virtual media,
audio and Absolute Mouse Synchronization.
Additionally, digital video CIMs supporting DVI,
HDMI, and Display Port are also available.
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