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What's New in KX Ill Release 3.8.4
e All clients now support function keys F1-F24.
e New option on HKC client to construct Macro from Text: Text to Macro
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Introduction

The Dominion KX Il is an enterprise-class, secure, KVM-over-IP switch that
provides multiple users with remote BIOS-level control of 8 to 64 servers.

KX Il comes with standard features such as DVI/HDMI/DisplayPort digital and
analog video, audio, virtual media, smart card/CAC, blade server support, and
mobile access.

Deploy KX lll individually, or with Raritan’s CommandCenter Secure Gateway

(CC-S@G).

In This Chapter

PaCKage CONTENTS ...veiiiiiiiiieiee ettt ettt e be e 1
KX 1l Device Photos and FEATUIES .......cccuvvveeiiiiieiiireeeee ettt e 1
KX Il Remote/Local Console Interfaces and User Station ........ccoovveevveeeeeeereeiinns 5
KVM Client APPlICAtioNS ...cccccuiiieeciiee ettt e et e 5
KX T ONINE HEIP .ttt ettt 5

Package Contents

Each KX Il ships as a fully-configured stand-alone product in a standard 1U or
2U form with 19" rackmount chassis.

1- KX Il device

1 - Quick Setup Guide

1 - Rackmount kit

2 - AC power cords

1 - Set of 4 rubber feet (for desktop use)
1 - Application note

1 - Warranty card

KX 11l Device Photos and Features

Hardware

e Integrated KVM-over-IP remote access

e 1U or 2U rack-mountable (brackets included)

e Dual power supplies with failover; autoswitching power supply with power
failure warning

e Support for the following CIMs:

Raritan.
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=  For virtual media and Absolute Mouse Synchronization, use one of the
following ClMs:
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= D2CIM-VUSB

=  D2CIM-DVUSB

= D2CIM-DVUSB-DVI

= D2CIM-DVUSB-HDMI

=  D2CIM-DVUSB-DP

= D2CIM-VUSB-USBC
= Required for PS2 connection:

= DCIM-PS2
DVI monitor support from the DVI local port
= VGA support via a DVI to VGA converter
= DVIsupport via a standard DVI cable
Remote access and power management from an iPhone’ or iPad®

Support for tiering in which a base KX Il device is used to access multiple
other tiered devices

Multiple user capacity (1/2/4/8 remote users; 1 local user)
UTP (Cat5/5e/6) server cabling

Dual Ethernet ports (10/100/1000 LAN) with failover or isolation mode
support

Field upgradeable

Local USB User port for in-rack access

=  USB Keyboard/mouse ports, or connect to a cellular modem

= One front and three back panel USB ports for supported USB devices
=  Fully concurrent local and remote user access

= Local graphical user interface (GUI) for administration

Serial port to connect to an external telephone modem

Centralized access security

Integrated power control

LED indicators for dual power status, network activity, and remote user
status

Hardware Reset button

Software

Virtual media support in Windows*, Mac® and Linux® environments*
Absolute Mouse Synchronization*

*Note: Virtual media and Absolute Mouse Synchronization require use of a
D2CIM-VUSB, D2CIM-DVUSB, D2CIM-DVUSB-DVI, D2CIM-DVUSB-HDMI,
D2CIM-DVUSB-DP CIM or D2CIM-VUSB-USBC

Raritan.
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e Support for digital audio over USB

e Port scanning and thumbnail view of up to 32 targets within a configurable
scan set

e Web-based access and management
e Intuitive graphical user interface (GUI)
e Support for dual port video output

e  256-bit encryption of complete KVM signal, including video and virtual
media

e LDAP, Active Directory®, RADIUS, or internal authentication and
authorization

e  DHCP or fixed IP addressing

e Smart card/CAC authentication

e  SNMP, SNMPv3, SMTP, and Syslog management

e |Pv4 and IPv6 support

e Power control associated directly with servers to prevent mistakes

e Integration with Raritan's CommandCenter Secure Gateway (CC-SG)
management unit

e CCUnmanage feature to remove device from CC-SG control
e  Support of Raritan PDUs
e Support for remote IP access from the new Dominion KX Ill User Station

e Support for access to serial targets using the Dominion Serial Access
Module (DSAM)

Photos

Front View

Raritan. }
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Hardware models vary. Newer 2020 models have moved the DVI port to the
bottom position.

Diagram key

QPOVVWOOO

Dual Power AC 100V/240V

Dual 10/100/1000 Ethernet access

Local USB ports

DVI-D port

KVM ports for UTP Cabling (Cat5/5e/6)

Tier port for tiering devices

Modem port for external modems

Dominion Serial Access Module USB port
(optional)

Supported Number of Ports and Remote Users per Model

Model
KX3-864

KX3-832
KX3-808
KX3-464
KX3-432
KX3-416
KX3-232
KX3-216
KX3-132
KX3-116
KX3-108

Ports

64
32
8

64
32
16
32
16
32
16
8

Remote users

8
8
8
4
4
4

Raritan.
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KX 1l Remote/Local Console Interfaces and User Station

Use the Remote Console interface to configure and manage the KX Ill over a
network connection.

Use the Local Console interface to access the KX Il while at the rack.

See KX Ill Remote Console Interface (on page 15), KX Il Local Console - KX III
Administration Functions and KX Il Local Console Interface (on page 23),
respectively.

The Dominion User Station provides an alternative interface for IP access to the
KX llI's target servers. See Dominion User Station (on page 148).

KVM Client Applications

KX 11l works with -

e Active KVM Client (AKC) - Default client, Windows only. Microsoft .NET* 4.5
or above required to use KX Il with the Microsoft Windows -based Active
KVM Client (AKC). See Active KVM Client (AKC) Help (on page 73)

e Virtual KVM Client (VKC) -Java” 1.8 is required to use the Java-based Virtual
KVM Client (VKC). Java 1.8.0_40 or higher is required to use the VKCS. Also
available in a Standalone version for the Chrome browser. Java is required.
See Virtual KVM Client (VKC and VKCs) Help (on page 34)

e  HTML KVM Client (HKC) - Runs on Linux, Mac, and Windows without .NET,
in |IE, Edge, Firefox, Chrome and Safari. No Java. Basic KVM features are
supported. See HTML KVM Client (HKC) (on page 77).

KX 1l Online Help

Raritan.

Abrand of O legrand

KX 11l online help is considered your primary help resource.
KVM Client help is provided as part of KX Il online help.

Online help is accompanied by the KX Il Quick Setup Guide, which is included
with your KX Il and can be found on the Support page of Raritan's website
(https://www.raritan.com/support/product/dominion-kx-iii).

The Support page also contains a PDF version of the end user help sections of
online help, and a PDF containing the KX Ill administrator help sections.

See the KX Il Release Notes for important information on the current release
before you begin using the KX III.

To use online help, Active Content must be enabled in your browser.


https://www.raritan.com/support/product/dominion-kx-iii

Get Started Using KX IlI

This section walks you through high-level tasks to start using KX IlI.

In This Chapter

Install and Configure KX 1l .....uii et e 6
Default Login - Change the Password
AlIOW POP-UPS .eeeeeiiiieeeiiii ettt
Security Warnings and Validation Messages

INStalling @ CertifiCate ...uueiii i 8
Converting a Binary Certificate to a Base64-Encoded DER Certificate (Optional)12
LOGEING IN TO KX T e 14

Install and Configure KX IlI

If you have not already done so, install and configure KX III.

See the KX Il Quick Setup Guide that came with the KX Il device or download it
from the Raritan Support website https://www.raritan.com/support.

Default Login - Change the Password

The KX Ill device is shipped with the following default settings. You are forced
to change the password at first login to a strong password.

e Username = admin
e Password=raritan
e |Paddress=192.168.0.192

Important: For backup and business continuity purposes, it is strongly
recommended you create a backup administrator username and password,
and keep that information in a secure location.

Allow Pop-Ups

Regardless of the browser you are using, you must allow pop-ups in order to
launch the KX Ill Remote Console.

Security Warnings and Validation Messages

Raritan.
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When logging in to KX I, security warnings and application validation messages
may appear.

These include -
e Additional security warnings based on your browser and security settings

See Additional Security Warnings (on page 8)


https://www.raritan.com/support
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e If you choose to use the Virtual KVM Client (VKC/VKCS), you may see Java™
security warnings and requests to validate KX 1.

See Java Validation and Access Warning (on page 7) and Installing a
Certificate (on page 8).

Note! Use the HTML KVM Client (HKC) instead to avoid Java. The HKC is
Java-Free. See KVM Client Launching (on page 33).

Java Validation and Access Warning

When logging in to KX Il using the Java-based client, Java prompts you to
validate KX I, and to allow access to the application.

Installing an SSL certificate in each KX Il device is recommended to reduce Java
warnings, and enhance security.

See SSL Certificates

Do you want to run this application?

Name: Raritan Favorite Devices Applet

g
~ == Publisher: Raritan Americas, Inc.
=

Location: https:f/192.168.60. 137

This application will run with unrestricted access which may put your computer and personal
information at risk. Run this application only if you trust the location and publisher above.

@again for apps from the publisher@
6 More Information

Security Warning | & ]

Do you want to Continue?
The connection to this website is untrusted.

Website: https://192.168.50.137:443

Mote: The certificate is not valid and cannot be used to verify the identity of this website.

More Information
[ Continue ] Cancel

Raritan.
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Additional Security Warnings

Even after an SSL certificate is installed in the KX 1ll, depending on your browser
and security settings, additional security warnings may be displayed when you
log in to KX III.

It is necessary to accept these warnings to launch the KX Il Remote Console.

Reduce the number of warning messages during subsequent log ins by checking
the following options on the security and certificate warning messages:

e Inthe future, do not show this warning
e Always trust content from this publisher

Installing a Certificate

You may be prompted by the browser to accept and validate the KX IlI's SSL
certificate.

Depending on your browser and security settings, additional security warnings
may be displayed when you log in to KX IlI.

It is necessary to accept these warnings to launch the KX Ill Remote Console.
For more information, see Security Warnings and Validation Messages (on
page 6).

Two sample methods on how to install an SSL Certificate in the browser are
provided here. Specific methods and steps depend on your browser and
operating system. See your browser and operating system help for details.

Example 1: Import the Certificate into the Browser

In this example, you import the Certificate into the browser.

[More Information S
1

The certificate used to identfy the website is not trusted. The reasons
are bsted below.

—M‘ Proceed at your own risk. |

|
| Do youwantto inue? ‘ The certificate Authority that issued ths certficate is not trusted.
T

he connection to this websit is untrusted. "

The 2ppication is beng downloaded fiom a site other than the one:
' specfied by the seauity certificate.
2 'l - Domrioadng from "192.168.61.20"
Website:  httos://192.168.61.20:443 B Rariten KW

i futeinen e—"-wCubﬁ(rn:eDc:ds'
- s |

ore DormaNor MNote to the Publisher: Security features to prevent

unauthorized redistribution of your Java appication wil cause this
el appication to be blocked in the futire. See current Java

e Cooo 1) documentation about JAR Manifest entres for the dianges that

need to be made, |

Note to users:For any questions, please contact the Publsher
who provided you with ths appication,

Visit Java.com for more detads Cose.

1. Open a browser, then log in to KX III.
Click More Information on the first warning.

3. Click View Certificate Details on the More Information dialog. You are
prompted to install the certificate. Follow the wizard steps.

Raritan.
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Note: If you are not prompted by the browser, manually select the Settings or
Options for your browser, and import the certificate. The following example
shows the IE > Tools > Internet Options method.

Contificate lmpont Wiaard  —EE—— [=5C0)

Welcome to the Certificate Import
Wizard

o Tovs iz d elon you copy certAates, cervicate st

¢ o, and certhcats revoceson ket from your dak 19 &

Puas carticane store.

e Opices o sty it |
ety

o
. s e retac o o 5 et o At
Generai | prrmiip: Content. | Comection) oaciore:  arears e & B Yvoam s s
Coryicates are heot.

Content To contirue, ik Mest.

0 Ratings heb you contral the Internet cof
viewed on the computer.

Certficates

Use certificates for encrypted connectol

I vests | [ concel

AeComplete |

AutoComplete $I0res DreVious VS Lo Sattinns
| z zmwm’um Centiicate Irport Wizard. —
ou. > — ﬁ,
[
Fouds and Wb Shoes Completing the Certificate Import
Wizard

J°7] Feeds and Web Skces provide updated
) content om webates that can be
! read in Intermet Explorer and other The certAcate wl be imported after you ok Frsh.
programs, £
A (S5 fouhave weched e fohowng tettrgs:
Lr&ﬂmr’d’\l': Astomatcaly determred by t
Conters Corshcne
e Narw € omers perrerr ekt o
o Ll
= i L
Cersficate bmport Wizerd n

o The import was successhul

1. Click the Content tab.

2. Click Certificates.
The Certificate Import Wizard opens and walks you through each step.

=  File to Import - Browse to locate the Certificate

= Certificate Store - Select the location to store the Certificate
3. Click Finish on the last step of the Wizard.

The Certificate is imported. Close the success message.

4. Click OK on the Internet Options dialog to apply the changes, then close
and reopen the browser.

Raritan.
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Example 2: Add the KX Il to Trusted Sites and Import the Certificate

In this example, the KX IllI's URL is added as a Trusted Site, and the Self Signed
Certificate is added as part of the process.

L N O Uk W

e

Reopen Last Browsing Sessicn
InPrecate Fitering
InPrevate Filtering Settings.
Pop-up Blocker
SeartScreen Filter
Mansge Add-ons

patibiity View
Compatibiity View Settings
Satrscrbe to this Feed
Fred Discovery
Windows Update
Developer Tocks
Send to Bluetceth Device...
OneNote Linked Notes

Dagnose Connection Problem

i

o -

Select & 70re 5 veew Or hange seiity settngs.

L]

Trusted stes
S T sone contars webates
V' st s damage your
your fies
Tous have webstes ) P 2ove
Securty level for s zone

Custom
Custom pestngs.
~To change the sattngs, dick Custom level
ecomeerded

“Toume e setings, cick Oefadt kevet.

Custom evel. . Onfordt deves

Raset oh zones t defait et

Trusted sites (]

# You can 539 and remove webstes $rom B 20ne. Al webates 0
W/ P one il iae e 200t secunty settngs.

Add s websie 1o the 2one:
hitgs323.345.56 61 M|
|

Websttes:

o Cancel = ||
- @» Requre server verficaton (htion:) for of stes n s xore

Q-

Open an IE browser, then select Tools > Internet Options to open the

Internet Options dialog
Click the Security tab.
Click on Trusted Sites.

Disable Protected Mode, and accept any warnings.

Click Sites to open the Trusted Sites dialog.
Enter the KX IIl URL, then click Add.

Deselect server verification for the zone (if applicable).

Click Close.

Click OK on the Internet Options dialog to apply the changes, then close

and reopen the browser.
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Next, import the Certificate.

[i¥ioee Enformation X

[ The certificate used to identfy the website is not trusted. The reasons
are Isted below.
Proceed at your own risk. “

The certificate Authority that issued ths certificate is not trusted,

The applcation s bang downloaded from a site other than the one
specified by the security certificate.

- Downloading from "192.168.61.20°

- Expecting Raritan KVM™

Note: ? 1o verify of ths webste, ‘,—»’\:&‘;‘Bﬁ“_& D_C—E—I
AR fle manfest does not

This appication will be blocked In & futire Java security update
contain the Permissions attrbute. Please contact the Publsher More informaton Note to the Publisher: Securty features to prevent
unauthorized redistribution of your Java appication wil cause this

[—][—] appication to be bocked in the future, See current Java
Cogfine Caccal o about JAR Manfest entries for the changes that
need to be made. |

Note to users: For any questons, please contact the Publsher
who provided you with this appication,

Visit Java.com for more detads ‘(—Onse J

1. Open an IE browser, then log in to KX I1I.
Click More Information on the first Java™ security warning.

3. Click View Certificate Details on the More Information dialog. You are
prompted to install the certificate. Follow the wizard steps.

For details see, Example 1: Import the Certificate into the Browser (on
page 8).

Raritan. 1
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Converting a Binary Certificate to a Base64-Encoded DER Certificate (Optional)

KX Il requires an SSL certificate in either Base64-Encoded DER format or PEM
format.

If you are using an SSL certificate in binary format, you cannot install it.

However, you can convert your binary SSL certificate.

[ General | Detods Jeramez{ 2 )atn]

Show: |<.AI> vr
Field Vahe -
[Eversion v3 |
| |serial number Dce7eDes 17d3 46 fesfeS... |
=] signature algorithm shalRSA m
=] signature hash algorithm shat
(=Jtssuer DigiCert Assured ID Root CA, ...
|=]vakid from Thursday, November 09, 2006...
|=|vakd to Sunday, November 09, 2031 7...
s hiart Mini et A TN Bont 8 i

Edit Properties... | [ Copy toFie... |

Learn more about certificate detais

1. Locate the DEGHKVMOO0O1.cer binary file on your Windows machine.
Double-click on the DEGHKVMO0O0O1.cer file to open its Certificate dialog.
2. Click the Detail tab.

12 Raritan.
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3. Click "Copy to File...".

e Fxnart Wiran
Export Wizard
=

Welcome to the Certificate Export
Wizard

This wizard helps you copy certificates, certificate trust
lists and certificate revocation lists from a certificate
store to your disk.

A certificate, which is issued by a certification authority, is
a confirmation of your identity and contains information
used to protect data or to establish secure network
connections, A certificate store is the system area where
certificates are kept.

To continue, diick Next.

Export File Format
Certificates can be exported in a variety of file formats.

Select the format you want to use:
(*) DER encoded binary X.509 (.CER)

() Cryptographic Message Syntax Standard - PKCS 27 Certificates (.P78)
Indude all certificates in the certification path if possible
Personal Information Exchange - PKCS #12 (.PFX)
Indude all certificates in the certification path if possible
Delete the private key if the export is successful
Export all extended properties

Microsoft Serizlized Certificate Store (.SST)

Learn more about certificate file formats

[ <gak [ mext> | [ cancel ]

5. Select "Base-64 encoded X.509" in the second Wizard dialog.
6. Click Next to save the file as a Base-64 encoded X.509.

You can now install the certificate on your KX III.

Raritan. 13
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Logging In to KX Il

Log in to your KX Ill Remote Console from any workstation with network
connectivity. See the Release Notes for supported browser versions.
Logging in and using KX Il requires you to allow pop-ups.

For information on security warnings and validation messages, and steps to
reduce or eliminate them, see Security Warnings and Validation Messages (on
page 6).

» Tologin via Remote Console:

Launch a supported web browser, and enter the IP address assigned to the
KX 1.

2. Adefault client is launched based on your PC and browser settings. See
KVM Clients (on page 33). You can also choose a client by entering the URL
directly. See KVM Client Launching (on page 33).

Enter your username and password, then click Login.

Accept the user agreement (if applicable). If security warnings appear, click
to accept.

Raritan.
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KX Ill Interface and Navigation

The KX Il Remote Console and the KX Il Local Console are web-based graphical
user interfaces.

Use the Remote Console interface to configure and manage the KX Ill over a
network connection.

Use the Local Console interface to access the KX Il while at the rack.

Access targets from either the Remote or Local console from one of the
supported KVM clients.

If you have the Dominion User Station, you can also use it to access targets. See
Dominion User Station (on page 148).

In This Chapter
KX Il Remote Console INTEIfaCe ..uuuiiiiiiiiiieiiee et 15
KX 111 Local Console INterfaCe......ooiiviiiiiiiiiiiieeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeees 23

KX 1ll Remote Console Interface

Raritan.
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The KX Il Remote Console is a browser-based graphical user interface that
allows you to log in to targets connected to the KX Il and to remotely
administer the KX III.

The KX Il Remote Console provides a network connection to your connected
KVM target servers. When you log into a KVM target server using the KX 111
Remote Console, a KVM Client window opens.

There are many similarities among the KX Ill Local Console and the KX IlI
Remote Console graphical user interfaces, and where there are differences,
they are noted in the user manual. The following options are available in the KX
Il Remote Console but not the KX 11l Local Console:

e Virtual Media

e  Favorites

e Backup/Restore

e Firmware Upgrade

e  SSL Certificates

e Audio

15
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Port Access Page (Remote Console Display)

After a successful login, the Port Access page opens listing all ports along with
their status and availability.

Ports connected to KVM target servers (blades and standard servers) are
displayed in blue. Right-click on any of these ports to open the Port Action
menu. For more information, see Port Action Menu (on page 19).

If a KX Il port has no CIM connected or is connected to a CIM with no name, a
default port name of Dominion_Model Name_PortNumber is assigned to the
port. PortNumber is the number of the KX Ill physical port.

[EGRBEREE] Fove | Virtal Media | User Management | Device Settings | Securty | Maintenance | Diagnostcs| Help|
Home > Ports
Port Access
Click on the individual port name to see allowable operations.
0/ 2 Remote KVM channels currently in use.
B View By Seria | View By Group | View By Search| Set Scan|
Name Type Status Availability
1 Dominion_KX3_Port1 Dual-vMm up idle
2 VGA_OUT_4 Not Available down idle
3 Dominlon_KX3_Port3 M up idie
4 VGA_OUT_3 Not Available down idle
5 DVM-DP DVM-DP up connected
6 VGA_OUT_2 Not Available down idle
7 IBM-Power-720-primary DVM-DVI up idie
8 VGA_OUT_1 Not Available down idle
9 Dominion_KX3_Port9 Not Available down idle
10 Dominion_KX3_Port10 Not Available down idle
1" Dominion_KX3_Port11 Not Avallable down idie
12 Dominion_KX3_Port12 Not Available down idie
13 Dominion_KX3_Port13 Not Available down idle
14 Dominion_KX3_Port14 Not Available down idie
15 Dominion_KX3_Port15 Not Available down Idie
16 Dominion_KX3_Port16 Not Available down idie
Rows per Page [ Set |

Four tabs are provided on the page allowing you to view by port, view by group,
view by search and scan ports. A fifth tab, View by Serial, is available when an
optional DSAM is connected.

You can sort by Port Number, Port Name, Status (Up and Down), and
Availability (Idle, Connected, Busy, Unavailable, and Connecting) by clicking on
the column heading.

Use the Set Scan tab to scan for up to 32 targets that are connected to the KX
Ill. See Scanning Ports - Remote Console (on page 151)
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Tiered Devices - Port Access Page

If you are using a tiered configuration in which a base KX Il device is used to
access multiple other tiered devices, the tiered devices are viewed on the Port
Access page by clicking on the Expand Arrow icon ® to the left of the tier
device name.

Blade Chassis - Port Access Page

The blade chassis is displayed in an expandable, hierarchical list on the Port
Access page, with the blade chassis at the root of the hierarchy and the
individual blades labeled and displayed below the root. Use the Expand Arrow
icon ® next to the root chassis to display the individual blades.

Note: To view the blade chassis in a hierarchal order, blade-chassis subtypes
must be configured for the blade server chassis.

Dual Port Video Groups - Port Access Page

Dual video port groups appear on the Port Access page as Dual Port types.

The primary and secondary ports that are a part of the port group appear on
the Port Access page as Dual Port(P) and Dual Port(S), respectively.

When you access a dual port video group from the remote client, you connect
to the primary port, which opens a KVM connection window to both the
primary and secondary ports of the dual port group.

Note: The dual video primary port is defined when the port group is created.

Note: You cannot remotely connect to the dual video port group by clicking on a
primary port unless two KVM channels are available. If two channels are not
available, the Connect link is not displayed.

Note: The Action menu is not displayed when you click on a secondary port in a
dual video port group.

Note: You cannot connect to the primary port and secondary port at the same
time from the Local Port.

View by Group Tab

The View by Group tab displays blade chassis, 'standard' port groups, and dual
video port groups. Click the Expand Arrow icon ® next to a group to view the
ports assigned to the port group.

View by Search Tab

The View by Search tab allows you to search by port name. The search feature
supports the use of an asterisk (*) as a wildcard, and full and partial names.

17
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View by Serial Tab

The View By Serial tab is visible when a Dominion Serial Access Module (DSAM)
is connected by USB. Up to 4 serial targets can be connected to the DSAM by
USB.

| Power | Virtual Media | User Management | Device Settings | Security | Maintenance | Diag

Home = Ports

Port Access

Click on the individual port name to see allowable operations.
0/1 Remote KVM channels currently in use.

View By Port View By Group | View By Search m

Status Availability
4 L J DsAM4 Frant DsAM up
4.1 DSAM4 Port 1 DCE up idle
4.2 DSAM4 Port 2 AUTO down idle
4.3 DSAM4 Port 3 AUTO down idle
4.4 DSAM4 Port 4 AUTO down idle

3z Rows per Page

Set Scan Tab

The port scanning feature is accessed from the Set Scan tab on the Port Access
page. The feature allows you to define a set of KVM targets to be scanned.
Thumbnail views of the scanned targets are also available. Select a thumbnail
to open that target in its Virtual KVM Client window.

See Scanning Ports - Remote Console (on page 151) for more information.
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Port Action Menu

When you click a Port Name in the Port Access list, the Port Action menu
appears.

Choose the desired menu option for that port to execute it. Note that only
currently available options, depending on the port's status and availability, are
listed in the Port Action menu.

Home = Ports

Port Access

0 /4 Remote K\VM channels currently in use.

View By Group | View By Search | Set Scan

L
Click on the individual port name to see allowable operations. {

N

1 HOMI Target
3 4JPO20540016] h
Connect

e Connect - Creates a new connection to the target server
For the KX lll Remote Console, a new KVM Client page appears.

For the KX Il Local Console, the display switches to the target server, and
switches away from the local user interface.

On the local port, the KX Il Local Console interface must be visible in order
to perform the switch.

Hot key switching is also available from the local port.

Note: This option is not available from the KX Ill Remote Console for an
available port if all connections are busy.

Switch From

e  Switch From - Switches from an existing connection to the selected port
(KVM target server)

This menu item is available only for KVM targets, and only when a KVM
Client is opened.
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Note: This menu item is not available on the KX Il Local Console.

Home = Ports

Port Access

t W

(2]

Click on the individual port name to see allowable operations.
1/4 Remote KVM channels currently in use. }

4

Wiew By Part| View By Group | View By Search | Set Scan

(
}73 Low Cost DVM [PQ20540016] . -
e S Y ﬁ#’“*

Disconnect

Disconnect - Disconnects this port and closes the KVM Client page for this
target server

This menu item is available only when the port status is up and connected,
or up and busy.

Note: This menu item is not available on the KX Ill Local Console. The only
way to disconnect from the switched target in the Local Console is to use
the hot key.

Home = Ports

Port Access

1
o
Click on the individual port hame to see allowable operatfons.{
1/ 4 Remote K\VM channels currently in use. N

Whew By Part| View By Group | View By Search | Set Scan

2 2 Port? - ,

P T TR e pinet
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Power On

Power On - Powers on the target server through the associated outlet
This option is visible only when there are one or more power associations
to the target, and when the user has permission to operate this service.

Provided you have privileges to do so, you can manage power from the
Virtual KVM Client (VKC) and Active KVM Client (AKC) as well. See Power
Control Using VKC, VKCS, and AKC (on page 73)

Power Off

Power Off - Powers off the target server through the associated outlets

This option is visible only when there are one or more power associations
to the target, when the target power is on (port status is up), and when
user has permission to operate this service.

Provided you have privileges to do so, you can manage power from the
Virtual KVM Client (VKC) and Active KVM Client (AKC) as well. See Power
Control Using VKC, VKCS, and AKC (on page 73)

Power Cycle

Power Cycle - Power cycles the target server through the associated
outlets

This option is visible only when there are one or more power associations
to the target, and when the user has permission to operate this service.
Provided you have privileges to do so, you can manage power from the
Virtual KVM Client (VKC) and Active KVM Client (AKC) as well. See Power
Control Using VKC, VKCS, and AKC (on page 73)

DKX3-808 Fast Switching

DKX3-808 maintains the video connections to the servers, enabling faster
connections to servers and faster switching between channels.

Some Video Settings do not apply to DKX3-808 targets:

Automatic Color Calibration
Video Sensing: Best possible video mode/Quick sense video mode
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Left Panel
The left panel of the KX Ill interface contains the following information.

Note that some information is conditional - meaning it is displayed based on
your role, features being used and so on. Conditional information is noted here.

Information Description When displayed?

Time & Session The date and time the Always
current session started

User Username Always

State The current state of the Always
application, either idle or
active. If idle, the
application tracks and
displays the time the
session has been idle.

Your IP The IP address used to Always
access the KX Il

Last Login The last login date and time  Always

Under CC-SG The IP address of the CC-SG  When the KX Il is

Management device managing the KX Il  being managed by
CC-SG

Device Information Information specific to the  Always

KX 11l you are using

Device Name Name assigned to the Always
device

IP Address The IP address of the KX 1l Always

Firmware Current version of firmware Always

Device Model Model of the KX IlI Always

Serial number Serial number of the KX IlI Always

Network The name assigned to the Always

current network

Powerlinl Status of the power 1 outlet Always
connection. Either on or off,
or Auto-detect off

Raritan.
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Information

Powerln2

Configured As Base
or Configured As
Tiered

Port States

Connected Users

Online Help

Favorite Devices

FIPS Mode

Appendix A: KX Ill Interface and Navigation

Description

Status of the power 2 outlet
connection. Either on or off,
or Auto-detect off

If you are using a tiering
configuration, this indicates
if the KX Il you are
accessing is the base device
or a tiered device.

The statuses of the ports
being used by the KX 111

The users, identified by
their username and IP
address, who are currently
connected to the KX 111

Links to online help

See Managing Favorites
(on page 156)

FIPS Mode: EnabledSSL
Certificate: FIPS Mode
Compliant

When displayed?
Always

When the KX Ill is part
of a tiered
configuration

Always

Always

Always

When enabled

When FIPS is enabled

KX 11l Local Console Interface

Raritan.
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There are many similarities among the KX Il Local Console and the KX 1lI

Remote Console graphical user interfaces. Where there are differences, they

are noted in the help.

For details on using the Local Console see KX Il Local Console (on page 159).
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Overview
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All KX Il models support virtual media. Virtual media extends KVM capabilities
by enabling target servers to remotely access media from a client PC and
network file servers.

With this feature, media mounted on client PCs and network file servers are
essentially "mounted virtually" by the target server. The target server can then
read from and write to that media as if it were physically connected to the
target server itself.

Each KX Il comes equipped with virtual media to enable remote management
tasks using the widest variety of media/images.

Virtual media sessions are secured using the strongest encryption offered by
the browser, typically 256 bit AES. Older browsers may only support 128 bit
AES.

HKC does not support all virtual media features. See HTML KVM Client (HKC)
for details
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Prerequisites for Using Virtual Media

Raritan.
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KX 1l Virtual Media Prerequisites

For users requiring access to virtual media, the KX lll permissions must be
set to allow access to the relevant port, as well as virtual media access (VM
Access port permission) for the port. Port permissions are set at the
group-level.

If you want to use PC-Share, Security Settings must also be enabled in the
Security Settings page. Optional

A USB connection must exist between the device and the target server.

You must choose the correct USB connection settings for the KVM target
server you are connecting to.

Remote PC VM Prerequisites

Certain virtual media options require administrative privileges on the PC
(for example, drive redirection of complete drives).

Note: If you are using Windows, disable User Account Control or select Run
as Administrator when starting Internet Explorer. To do this, click the Start
Menu, locate IE, right-click and select Run as Administrator.

Target Server VM Prerequisites

KVM target servers must support USB connected drives.

CIMs Required for Virtual Media

You must use one of the following CIMs is to use virtual media:

D2CIM-VUSB
D2CIM-DVUSB
D2CIM-DVUSB-DVI
D2CIM-DVUSB-HDMI
D2CIM-DVUSB-DP
D2CIM-VUSB-USBC

The black USB connector on the DVUSB CIMs are used for the keyboard and
mouse. The gray connector is used for virtual media.

For CIMs with two USB plugs, keep both connected to the device.

The device may not operate properly if both plugs are not connected to the
target server.
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Mounting Local Drives

This option mounts an entire drive, which means the entire disk drive is
mounted virtually onto the target server.

Use this option for hard drives and external drives only. It does not include
network drives, CD-ROM, or DVD-ROM drives.

Note: Some browsers may restrict access to local drives, folders or files and may
not grant administrative permission.

Supported Tasks Via Virtual Media

Virtual media provides the ability to perform tasks remotely, such as:

e Transferring files

Running diagnostics

Installing or patching applications

Complete installation of the operating system

Important: Once you are connected to a virtual media drive, do not change
mouse modes in the KVM client if you are performing file transfers, upgrades,
installations or other similar actions. Doing so may cause errors on the virtual
media drive or cause the virtual media drive to fail.

Supported Virtual Media Types

The following virtual media types are supported for Windows®, Mac® and Linux™
clients when using AKC and VKC/VKCS.

e Internal and external hard drives

e Internal and USB-mounted CD and DVD drives
e  USB mass storage devices

e PCharddrives

e [SOimages (disk images)

e IMG files

e DMG files

e [SO9660 is the standard supported. However, other ISO standards can be
used.

Note: Due to browser limitations, HKC supports a different set of virtual media
types.
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Conditions when Read/Write is Not Available
Virtual media Read/Write is not available in the following situations:
e  For Linux® and Mac’ clients
e When the drive is write-protected
e  When the user does not have Read/Write permission:
= Port Permission Access is set to None or View

= Port Permission VM Access is set to Read-Only or Deny

Supported Virtual Media Operating Systems

The following client operating systems are supported:
e Windows ° 10

e openSUSE 15

e Fedora’ 28

e RHEL" 7.4

e (OSXSierra

The Active KVM Client (AKC) can be used to mount virtual media types but only
for Windows operating systems.

Number of Supported Virtual Media Drives

With the virtual media feature, you can mount up to two drives (of different
types) that are supported by the USB connection settings currently applied to
the target. These drives are accessible for the duration of the KVM session.

For example, you can mount a specific CD-ROM, use it, and then disconnect it
when you are done. The CD-ROM virtual media “channel” will remain open,
however, so that you can virtually mount another CD-ROM. These virtual media
“channels” remain open until the KVM session is closed as long as the USB
settings support it.

To use virtual media, connect/attach the media to the client or network file
server that you want to access from the target server.

This need not be the first step, but it must be done prior to attempting to
access this media.

Virtual Media
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Access a Virtual Media Drive on a Client Computer

Important: Once you are connected to a virtual media drive, do not change
mouse modes in the KVM client if you are performing file transfers, upgrades,
installations or other similar actions. Doing so may cause errors on the virtual
media drive or cause the virtual media drive to fail.
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2.

To access a virtual media drive on the client computer:

From the KVM client, choose Virtual Media > Connect Drive, or click the

Connect Drive... button D . The Map Virtual Media Drive dialog
appears.

Map Virtual Media Drive X

Select a local drive or image to mount onto the target server.

(®) Local Drive:
F: (Removable) v [ ] Read-Write

() Image File
Image Path

[ ok | cancel

Choose the drive from the Local Drive drop-down list.

If you want Read and Write capabilities, select the Read-Write checkbox.

This option is disabled for nonremovable drives. See the Conditions when
Read/Write is Not Available (on page 27) for more information.

When checked, you will be able to read or write to the connected USB disk.

WARNING: Enabling Read/Write access can be dangerous! Simultaneous
access to the same drive from more than one entity can result in data
corruption. If you do not require Write access, leave this option unselected.

Click OK. The media will be mounted on the target server virtually. You can
access the media just like any other drive.

Access a Virtual Media Image File

Use the "Image File" option to access a disk image of a removable disk.

>

Image file guidelines:

Image files created using dd on Linux (dd if=/dev/sdb of=disk.img) or
similar tools such as Win32Disklmager on Windows, or Mac Disk Utility are
supported.

Apple DMG files:
=  DMG image files of a FAT32 USB drive are recognized on all OSs.
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=  DMG images files of a folder on a Mac Drive are recognized only on
Mac OS targets.

= |mage should be created via Mac Disk Utility using the following
settings: Encryption: None; Image format: read/write.

= Not supported: Encrypted or compressed dmg images, MacOS install
images, DMG files downloaded from the Apple support site.

To access a virtual media image file:

From the KVM client, choose Virtual Media > Connect Drive, or click the
Connect Drive... button . The Map Virtual Media Drive dialog appears.

Select the Image File option, then click Browse to find and select the .img
or .dmg file.

Click OK. The media will be mounted on the target server virtually.

Mounting CD-ROM/DVD-ROM/ISO Images
This option mounts CD-ROM, DVD-ROM, and ISO images.

Note: ISO9660 format is the standard supported. However, other CD-ROM
extensions may also work.

>

To access a CD-ROM, DVD-ROM, or ISO image:
From the KVM client, choose Virtual Media > Connect CD-ROM/ISO Image,

]
or click the Connect CD ROM/ISO button . The Map Virtual Media
CD/I1SO Image dialog appears.

For internal and external CD-ROM or DVD-ROM drives:
a. Choose the Local CD/DVD Drive option.

b. Choose the drive from the Local CD/DVD Drive drop-down list. All
available internal and external CD and DVD drive names will be
populated in the drop-down list.

c. Click OK.
For ISO images:

a. Choose the ISO Image option. Use this option when you want to
access a disk image of a CD, DVD, or hard drive. ISO format is the only
format supported.

b. Click Browse.

c. Navigate to the path containing the disk image you want to use and
click Open. The path is populated in the Image Path field.

d. Click OK.
For remote ISO images on a file server:

a. Choose the Remote Server ISO Image option.
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b. Choose Hostname and Image from the drop-down list. The file servers
and image paths available are those that you configured using the
Virtual Media Shared Images page. Only items you configured using
the Virtual Media Shared Images page will be in the drop-down list.

c. File Server Username - User name required for access to the file server.
The name can include the domain name such as mydomain/username.

d. File Server Password - Password required for access to the file server
(field is masked as you type).

e. Click OK.

The media will be mounted on the target server virtually. You can access
the media just like any other drive.

Note: If you are working with files on a Linux® target, use the Linux Sync
command after the files are copied using virtual media in order to view the
copied files. Files may not appear until a sync is performed.

Note: If you are using the Windows 7° operating system*, Removable Disk is not
displayed by default in the Window's My Computer folder when you mount a
Local CD/DVD Drive or Local or Remote ISO Image. To view the Local CD/DVD
Drive or Local or Remote ISO Image in this folder, select Tools > Folder Options >
View and deselect "Hide empty drives in the Computer folder".

Disconnect from Virtual Media Drives

P  To disconnect the virtual media drives:
e  For local drives, choose Virtual Media > Disconnect Drive.

e For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media >
Disconnect CD-ROM/ISO Image.

Note: In addition to disconnecting the virtual media using the Disconnect
command, simply closing the KVM connection closes the virtual media as well.

Virtual Media in a Linux Environment

Active System Partitions
You cannot mount active system partitions from a Linux client.

Linux Ext3/4 drive partitions need to be unmounted via umount /dev/<device
label> prior to a making a virtual media connection.

Mapped Drives

Mapped drives from Linux clients are not locked when mounted onto
connected targets.
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Drive Partitions
The following drive partition limitations exist across operating systems:

e Windows® and Mac targets are not able to read Linux formatted partitions
e Windows and Linux cannot read Mac formatted partitions
e  Only Windows Fat partitions are supported by Linux

Root User Permission Requirement

Your virtual media connection can be closed if you mount a CD ROM from a
Linux client to a target and then unmount the CD ROM.

To avoid these issues, you must be a root user.

Connect Drive Permissions (Linux)

Linux users must have read-only permissions for the removable device they
wish to connect to the target. For /dev/sdb1 run the following as root user:

root@administrator-desktop:~# chmod 664 /dev/sdbl
root@administrator-desktop:~# 1s -1 /dev/sdbl
brw-rw-r-- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl

The drive is then available to connect to the target.

Virtual Media in a Mac Environment

Active System Partition

You cannot use virtual media to mount active system partitions for a Mac
client.

Drive Partitions

The following drive partition limitations exist across operating systems:

e Windows® and Mac targets are not able to read Linux formatted partitions
e  Windows cannot read Mac formatted partitions

e  Windows FAT and NTFS are supported by Mac

e Mac users must unmount any devices that are already mounted in order to
connect to a target server. Use >diskutil umount /dev/disk1s1 to unmount
the device and diskutil mount /dev/disk1s1 to remount it.
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Connect Drive Permissions (Mac)

For a device to be available to connect to a target from a Mac® client, you must
have read-only permissions to the removable device, and also unmount the
drive after doing so.

For /dev/sdb1, run the following commands as root user:

root@administrator-desktop:~# chmod 664 /dev/sdbl
root@administrator-desktop:~# 1ls -1 /dev/sdbl
brw-rw-r-- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl
root@admistrator-desktop:~# diskutil umount /dev/sdbl

Virtual Media File Server Setup (File Server ISO Images Only)

This feature is only required when using virtual media to access file server ISO
images. 1ISO9660 format is the standard supported. However, other CD-ROM
extensions may also work.

Note: SMB/CIFS support is required on the file server.

Use the Remote Console File Server Setup page to designate the files server(s)
and image paths that you want to access using virtual media. File server ISO
images specified here are available for selection in the Remote Server ISO
Image Hostname and Image drop-down lists in the Map Virtual Media CD/ISO
Image dialog. See Mounting CD-ROM/DVD-ROM/ISO Images (on page 29).

P> To designate file server ISO images for virtual media access:

Choose Virtual Media from the Remote Console. The File Server Setup
page opens.

2. Check the Selected checkbox for all media that you want accessible as
virtual media.

3. Enter information about the file server ISO images that you want to access:
= |P Address/Host Name - Host name or IP address of the file server.

= Image Path - Full path name of the location of the ISO image. For
example, /sharename0/path0/image0.iso,
\sharename1\path1\imagel.iso, and so on.

Note: The host name cannot exceed 232 characters in length.

4. Click Save. All media specified here are now available for selection in the
Map Virtual Media CD/ISO Image dialog.
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KVM Client
HTML KVM Client

Active KVM Client

Virtual KVM Client

KVM Clients

KX 11l can be accessed with a variety of KVM clients that support your individual
configuration.

e HKCis best for Linux and Mac users without Java.

e AKCis best for Windows Platforms, using Windows or Edge browsers.

e VKCis best for Linux and Mac users with Java.

Name Platforms Features
HKC = linux = Java-Free
= Mac = Supports most features
= Windows = See HTML KVM Client (HKC) (on
* HTML and Javascript page 77) for supported features
AKC = Windows = Full-featured KVM Client
= Requires Microsoft .NET = Java-Free
VKC = Linux = Full-featured KVM Client
= Mac = Requires Java

=  Windows

In This Chapter

KVM Client LAUNCRING .....vviiiiiiiie ettt et ta e st e e e an e e e 33
Virtual KVM Client (VKC and VKCs) HElp .ccvveeeeiiieeeeeeee e 34
Active KVM Client (AKC) HelP .oooeeeieecieee ettt st e 73
HTML KVM Client (HKC) .vvveeeiiiee ettt e vtee s s e e e ee e 77

KVM Client Launching

KVM Client Name | URL to Force Launch
HTML KVM Client - HKC <KX 11l IP Address>/hkc
Java-Free

Active KVM Client -
Requires .NET

AKC <KX 11l IP Address>/akc

Virtual KVM Client -

Requires Java

VKCs <KX Il IP Address>/vkcs
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Virtual KVM Client (VKC and VKCs) Help

Overview
There is one Virtual KVM Client for each target server connected.

Virtual KVM Client windows can be minimized, maximized, and moved around
your computer desktop.

IMPORTANT: Refreshing your browser closes the Virtual KVM Client
connection.

Recommended Minimum Virtual KVM Client (VKC) Requirements

It is recommended that the Virtual KVM Client (VKC) machines meet the
following minimum requirements.

e Client machine with either a -

= 'modern' dual-core CPU for a single connections, or

= 'modern' quad core CPU for two or more simultaneous connections
e 4GB of RAM

= VKCrequires 50MB of RAM per connection
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Virtual KVM Client Java Requirements

A supported Java version is required. Check the release notes for latest
supported version.

If Java is not installed, a prompt is displayed that the file cannot be opened,
with an option to search for the program.

Note: VKC cannot be launched from Safari, Edge, Chrome 45 or later, Firefox 42
or later. VKCS is recommended for these browsers.

P>  VKCS Launching:

For all browsers, the VKCS standalone application needs to be downloaded
everytime you use it.

e Chrome: The downloaded VKCS jnlp file must always be clicked at bottom
left corner of browser window to launch.

G NewTab

C | [7192.168.1.203/vk

2 Apps For quick sccess, place your bookmarks here on the bookmrks bar. Imgort bookmaris now.

-

& VkeStandaloneAppii N i # Show all downloads.. %

e Edge: You can allow and open the file from the browser downloads in the
top right corner.

- O
192.168.59.115/vke 6 v=| & O
Downloads B - 2
- \é’::s—ft;:dAloneApplication (Minlp —
See more
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Safari: Save the jnlp file locally. Hold down the Ctrl key when selecting to
open, then click Open in displayed prompt

Firefox: The current default setting in Firefox on Windows saves the file
and runs from the download. You can launch from the browser with this
setting: Tools>Options>Applications, then select "Jnlp File" in the Content
Type column, and change the Action from "Always ask" to "Use Java Web
Launcher".

Proxy Server Configuration

When the use of a Proxy Server is required, a SOCKS proxy must also be
provided and configured on the remote client PC.

Note: If the installed proxy server is only capable of the HTTP proxy protocol,
you cannot connect.

>

To configure the SOCKS proxy:
On the remote client PC, select Control Panel > Internet Options.

a. Onthe Connections tab, click 'LAN settings'. The Local Area Network
(LAN) Settings dialog opens.

b. Select 'Use a proxy server for your LAN'.
Click Advanced. The Proxy Settings dialog opens.
d. Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

e. Click OK at each dialog to apply the settings.
Next, configure the proxy settings for the Java™ applets:
a. Select Control Panel > Java.

b. Onthe General tab, click Network Settings. The Network Settings
dialog opens.

Select "Use Proxy Server".
d. Click Advanced. The Advanced Network Settings dialog opens.
e. Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).
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Connect to a Target from Virtual KVM Client (VKC), Standalone VKC (VKCs), or

Active KVM Client (AKC)

Once you have logged on to the KX Il Remote Console, access target servers via

the Virtual KVM Client (VKC), Standalone VKC (VKCs), or Active KVM Client
(AKC).

»  To connect to an available server:

On the Port Access page, click on the port name of the target server you
want to connect to. The Port Action menu opens.

2. Click Connect.

Home > Ports

Port Access

Click on the individual
0/ 4 Remote KVM char

See Port Action Menu (on page 19) for details on additional available menu
options.

Configuring Connection Properties

Connection properties manage streaming video performance over remote
connections to target servers.

The properties are applied only to your connection - they do not impact the
connection of other users accessing the same target servers.

If you make changes to connection properties, they are retained by the client.
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Access Connection Properties

P> To access connection properties:

@ Click Connection > Properties, or click the Connection... icon to open the

Connection Properties dialog.

Connection USB Profile Keyboard Video Mouse Tools View Virtual Media Audio SmartCard Help

SNEFEhEBRAILOR @E

Video Mode: Full Color 2

Default Connection Property Settings - Optimized for Best Performance

The KX Ill comes configured to provide optimal performance for the majority of
video streaming conditions.

>

38

KX3 default connection settings:

Optimized for: Text Readability - video modes are designed to maximize
text readability.

This setting is ideal for general IT and computer applications, such as
performing server administration.

Video Mode - defaults to Full Color 2.

Video frames transmit in high-quality, 24-bit color. This setting is suitable
where a high-speed LAN is used.

Noise Filter - defaults to 2.

The noise filter setting does not often need to be changed.
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Click Reset on the Connection Properties dialog at any time to return to the
default settings.

Tip: Use the Connection Information dialog to monitor the connection in
real-time. See Access and Copy Connection Information

ltem Description Data
Device Name DominionKX

=\

2 IP Address 192.168.53.214
3 Port 443

4 Data In/Second 608 bit/s

5 Data Out/Second 80 bit/s

6 DecodedFPS 1

7 Avg. FPS 9.88 (16 Sec.)
8 Connect Time 00:00:20

9 Resolution 1024 x 768

10 Refresh Rate 60 Hz
Protocol Version 01.31

-
N -k

Audio Playback Disconnected

13 Audio Capture  Disconnected

Copy to Clipboard Close

Optimize for: Selections
Text Readability

Text Readability is designed to provide video modes with lower color depth but
text remains readable. Greyscale modes are even available when applying
lower bandwidth settings.

This setting is ideal when working with computer GUIs, such as server
administration.

When working in full color video modes, a slight contrast boost is provided, and
text is sharper.

In lower quality video modes, bandwidth is decreased at the expense of
accuracy.
Color Accuracy

When Color Accuracy is selected, all video modes are rendered in full 24-bit
color with more compression artifacts.

This setting applies to viewing video streams such as movies or other broadcast
streams.

In lower quality video modes, sharpness of fine detail, such as text, is sacrificed.
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Video Mode

The Video Mode slider controls each video frame's encoding, affecting video
quality, frame rate and bandwidth.

Connection Properties [t S|
Optimize for: :Te)(t Readability
Video Mode: Full Color 2
Best Least |
Quality Noise Filter: 2 Bandwidth I
H
U I
|

]

In general, moving the slider to the left results in higher quality at the cost of
higher bandwidth and, in some cases, lower frame rate.

Moving the slider to the right enables stronger compression, reducing the
bandwidth per frame, but video quality is reduced.

In situations where system bandwidth is a limiting factor, moving the video
mode slider to the right can result in higher frame rates.

When Text Readability is selected as the Optimized setting, the four rightmost
modes provide reduced color resolution or no color at all.

These modes are appropriate for administration work where text and GUI
elements take priority, and bandwidth is at a premium.

Click Reset on the Connection Properties dialog at any time to return to the
default settings.
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Noise Filter

Unless there is a specific need to do so, do not change the noise filter
setting. The default setting is designed to work well in most situations.

The Noise Filter controls how much interframe noise is absorbed by the KX
1.

Optimize for: :TextReadabiIitg-I v:

Video Mode: Full Color 2

U

Least

Moise Filter: 2 Bandwidth

U

o) [conel ] [aem |

|

Moving the Noise Filter slider to the left lowers the filter threshold, resulting in
higher dynamic video quality. However, more noise is likely to come through,
resulting in higher bandwidth and lower frame rates.

Moving the slider to the right raises the threshold, allows less noise and less
bandwidth is used. Video artifacts may be increased.

Moving the noise filter to the right may be useful when accessing a computer
GUI over severely bandwidth-limited connections.

Click Reset on the Connection Properties dialog at any time to return to the
default settings.

Connection Information

Open the Connection Information dialog for real-time connection information
on your current connection, and copy the information from the dialog as
needed.

See Configuring Connection Properties (on page 37)

P> To open connection info:

1. Click Connection > Info.
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Note: Clicking Copy to Clipboard copies the information for pasting.

Connection Info X
ftem Description Data
2 IP Address 192.168.563.214
3 Port 443
4 DataIn/Second 640 bit/s
5 Data Out/Second 160 bit/s
6 DecodedFPS 1
7 Avg. FPS 0.53 (30 Sec)
8 Connect Time 00:03:07
9 Resolution 1024 x 768
10 RefreshRate 60 Hz
11 Protocol Version 01.31
12 Audio Playback Disconnected
13 Audio Capture Disconnected
Gese

P>  Current connection information:
e Name of the KX IlI
e [P address of the KX IlI

e  Port - The KVYM communication TCP/IP port used to access KX III.

e DataIn/Second - Data rate received from the KX III
e Data Out/Second - Data rate sent to the KX IlI.
e Connect Time - The duration of the current connection.

e FPS-Video frames per second transmitted received from the KX IlI.

e Average FPS - Average video frames per second.

e Resolution - The target server horizontal and vertical resolution.

e Refresh Rate - Refresh rate of the target server.
e Protocol Version - The version of the protocol.
e Audio Playback - The status of audio playback.
e Audio Capture - The status of audio recording.
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USB Profiles
Select a USB profile that best applies to the KVM target server.

For example, if the server is running Windows* operating system, it would be
best to use the Generic profile.

Or, to change settings in the BIOS menu or boot from a virtual media drive,
depending on the target server model, a BIOS profile may be more appropriate.

P To set a USB profile for a target server:

e Choose USB Profile, then choose Generic, or choose Other Profiles to
select from a menu.

Connection | USB Profile | Keyboard Video Mouse Tools View Virtual Media Audio Smart Power Cont Help
% % {o] Generic |@ o] %

Other Profiles * Linux

Mac OS-X (10.4.9 and later)

HP Proliant DL360/DL380 G4 (Windows 2003 Server Installation)
BIOS 1BM Thinkcentre Lenovo

RUBY Industrial Mainboard (AwardBIOS)

HP Proliant DL360/DL380 G4 (HP SmartStart CD)
BIOS Dell PowerEdge Keyboard and Mouse Only
Supermicro Mainboard (Phoenix AwardBIOS)
SuSE Linux 9.2

BIOS Mac

BIOS Lenovo ThinkPad T61 and X61

BIOS HP Compaq DC7100/DC7600

Use Full Speed for Virtual Media CIM

BIOS Generic

Troubleshooting 1

Troubleshooting 2

Troubleshooting 3

BIOS HP Proliant DL145

BIOS Dell PowerEdge 1950/2950/2970/6950/R200
BIOS Dell Optiplex Keyboard and Mouse Only
BIOS Asus P4C800 Motherboard

I1BM BladeCenter H with AMM

Use Full Speed for Keyboard and Mouse USB
BIOS HP Proliant DL385 G7

BIOS Dell Optiplex 790 Keyboard Only

BIOS Dell Optiplex 790

Target server may be powered off or in sleep mode SCR
vev———— Mac USB-C

Help on USB Profiles

P> To view details on USB profiles:
e Choose USB Profile > Help on USB Profiles.

Keyboard

Send Ctrl+Alt+Del Macro

Due to its frequent use, a Ctrl+Alt+Delete macro is preprogrammed.
Selecting Keyboard > Send Ctrl+Alt+Del, or clicking on the Ctrl+Alt+Delete
button EE in the toolbar sends this key sequence to the server or to the
KVM switch to which you are currently connected.

In contrast, if you were to physically press the Ctrl+Alt+Del keys, the command
would first be intercepted by your own PC due to the structure of the Windows
operating system, instead of sending the key sequence to the target server as
intended.

43



44

Appendix A: KVM Clients

Send LeftAlt+Tab (Switch Between Open Windows on a Target Server)

Select Keyboard > Send LeftAlt + Tab to switch between open windows on the
target server.

Setting CIM Keyboard/Mouse Options

P> To access the DCIM-USBG2 setup menu:

Put the mouse focus on a window such as Note Pad (Windows® operating
system) or an equivalent.

2. Select Set CIM Keyboard/Mouse options. This is the equivalent of sending
the Left-Control and Num Lock to the target. The CIM setup menu options
are then displayed.

Set the language and mouse settings.

4. Exit the menu to return to normal CIM functionality.

Send Text to Target

P> To use the Send Text to Target function for the macro:

Click the Keyboard > Send Text to Target. The Send Text to Target dialog
appears.

2. Enter the text you want sent to the target.

Note: Non-English characters are not supported by the Send Text to Target
function.

3. If the target uses a US/International keyboard layout, select the "Target
system is set to the US/International keyboard layout" checkbox.

4. Click OK.

Keyboard Macros

Keyboard macros ensure that keystroke combinations intended for the target
server are sent to and interpreted only by the target server. Otherwise, they
might be interpreted by your client PC.

Macros are stored on the client PC and are PC-specific. If you use another PC,
you cannot see your macros.

In addition, if another person uses your PC and logs in under a different name,
that user will see your macros since they are computer-wide.

Build a New Macro

P> To build a macro:
1. Click Keyboard > Keyboard Macros. The Keyboard Macros dialog appears.
2. Click Add. The Add Keyboard Macro dialog appears.
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Type a name for the macro in the Keyboard Macro Name field. This name
appears in the Keyboard menu after it is created.

From the Hot-Key Combination field, select a keyboard combination from
the drop-down list. This allows you to execute the macro with a predefined
keystroke. Optional

In the Keys to Press drop-down list, select each key you would like to use
to emulate the keystrokes that is used to perform the command. Select the
keys in the order by which they are to be pressed. After each selection,
select Add Key. As each key is selected, it appears in the Macro Sequence
field and a Release Key command is automatically added after each
selection.

For example, create a macro to close a window by selecting Left Ctrl + Esc.
This appears in the Macro Sequence box as follows:

Press Left Alt
Press F4

Press Esc
Release F4
Release Esc
Release Left Alt

Review the Macro Sequence field to be sure the macro sequence is defined
correctly.

a. Toremove a step in the sequence, select it and click Remove.

b. To change the order of steps in the sequence, click the step and then
click the up or down arrow buttons to reorder them as needed.

Click OK to save the macro. Click Clear to clear all fields and start over.
When you click OK, the Keyboard Macros dialog appears and lists the new
keyboard macro.

Click Close to close the Keyboard Macros dialog. The macro now appears
on the Keyboard menu in the application.

Select the new macro on the menu to run it or use the keystrokes you
assigned to the macro.

Importing and Exporting Macros

Macros created in VKC cannot be used in AKC or vice versa. Macros created on
HKC are only compatible with HKC, and cannot be used on AKC or VKC. Likewise,
macros created on VKC or AKC cannot be used on HKC.

Import Macros

>

To import macros:

Choose Keyboard > Import Keyboard Macros to open the Import Macros
dialog. Browse to the folder location of the macro file.

Click on the macro file and click Open to import the macro.
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a. Iftoo many macros are found in the file, an error message is displayed
and the import terminates once OK is selected.

b. If the import fails, an error dialog appears and a message regarding
why the import failed is displayed. Select OK to continue the import
without importing the macros that cannot be imported.

3. Select the macros to be imported by checking their corresponding
checkbox or using the Select All or Deselect All options.

4. Click OK to begin the import.

a. If aduplicate macro is found, the Import Macros dialog appears. Do
one of the following:

= Click Yes to replace the existing macro with the imported version.

= Click Yes to All to replace the currently selected and any other
duplicate macros that are found.

= Click No to keep the original macro and proceed to the next macro

= Click No to All keep the original macro and proceed to the next
macro. Any other duplicates that are found are skipped as well.

= Click Cancel to stop the import.

= Alternatively, click Rename to rename the macro and import it. If
Rename is selected, the Rename Macro dialog appears. Enter a
new name for the macro in the field and click OK. The dialog
closes and the process proceeds. If the name that is entered is a
duplicate of a macro, an alert appears and you are required to
enter another name for the macro.

b. If during the import process the number of allowed, imported macros
is exceeded, a dialog appears. Click OK to attempt to continue
importing macros or click Cancel to stop the import process.

The macros are then imported. If a macro is imported that contains a hot key
that already exists, the hot key for the imported macro is discarded.
Export Macros

1. Choose Tools > Export Macros to open the Select Keyboard Macros to
Export dialog.

Close Window
Deselect Al

2. Select the macros to be exported by checking their corresponding
checkbox or using the Select All or Deselect All options.

b
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3. Click OK. An "Export Keyboard Macros to" dialog is displayed. Locate and
select the macro file. By default, the macro exists on your desktop.

4. Select the folder to save the macro file to, enter a name for the file and
click Save. If the macro already exists, you receive an alert message.

5. Select Yes to overwrite the existing macro or No to close the alert without
overwriting the macro.

Video Properties

Refreshing the Screen

The Refresh Screen command forces a refresh of the video screen. Video
settings can be refreshed automatically in several ways:
e The Refresh Screen command forces a refresh of the video screen.

e The Auto-sense Video Settings command automatically detects the target
server's video settings.

e The Calibrate Color command calibrates the video to enhance the colors
being displayed.

In addition, you can manually adjust the settings using the Video Settings
command.

P> To refresh the video settings, do one of the following:
e
e Choose Video > Refresh Screen, or click the Refresh Screen button ==
in the toolbar.

Auto-Sense Video Settings

The Auto-sense Video Settings command forces a re-sensing of the video
settings (resolution, refresh rate) and redraws the video screen.

P> To automatically detect the video settings:
e Choose Video > Auto-sense Video Settings, or click the Auto-Sense Video

&

Settings button ==Y in the toolbar.

A message stating that the auto adjustment is in progress appears.
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Calibrating Color

Use the Calibrate Color command to optimize the color levels (hue, brightness,
saturation) of the transmitted video images.

The color settings are on a target server-basis.

Note: When color is successfully calibrated, the values are cached and reused
each time you switch to the target. Changes to the brightness and contrast in
Video Settings are not cached. Changing resolution resets the video to the
cached values again. You can clear the cached values in Video > Clear Video
Settings Cache. See Clear Video Settings Cache (on page 48).

P> To calibrate the color:

e Choose Video > Calibrate Color, or click the Calibrate Color button @
in the toolbar.

The target device screen updates its color calibration.

Clear Video Settings Cache

You can clear the video settings cache to delete old settings that do not apply
anymore, such as when a target server is replaced. When you clear the video
settings cache, the server automatically does a video auto-sense and color
calibration. The new values are cached and reused when the target is accessed
again.

P To clear the video settings cache:
e Choose Video > Clear Video Settings Cache in the toolbar.

Adjusting Video Settings

Use the Video Settings command to manually adjust the video settings.

P> To change the video settings:
Choose Video > Video Settings to open the Video Settings dialog.

2. Adjust the following settings as required. As you adjust the settings the
effects are immediately visible:

a. PLL Settings

Clock - Controls how quickly video pixels are displayed across the video
screen. Changes made to clock settings cause the video image to
stretch or shrink horizontally. Odd number settings are recommended.
Under most circumstances, this setting should not be changed because
the autodetect is usually quite accurate.

Phase - Phase values range from 0 to 31 and will wrap around. Stop at
the phase value that produces the best video image for the active
target server.
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Brightness: Use this setting to adjust the brightness of the target
server display.

Brightness Red - Controls the brightness of the target server display for
the red signal.

Brightness Green - Controls the brightness of the green signal.
Brightness Blue - Controls the brightness of the blue signal.
Contrast Red - Controls the red signal contrast.

Contrast Green - Controls the green signal.

Contrast Blue - Controls the blue signal.

If the video image looks extremely blurry or unfocused, the settings for
clock and phase can be adjusted until a better image appears on the
active target server.

Warning: Exercise caution when changing the Clock and Phase settings.
Doing so may result in lost or distorted video and you may not be able to
return to the previous state. Contact Technical Support before making any
changes.

d.

Horizontal Offset - Controls the horizontal positioning of the target
server display on your monitor.

Vertical Offset - Controls the vertical positioning of the target server
display on your monitor.

Select Automatic Color Calibration to enable this feature.

Select the video sensing mode.

Best possible video mode

The device will perform the full Auto Sense process when switching
targets or target resolutions. Selecting this option calibrates the video
for the best image quality.

Quick sense video mode

With this option, the device will use a quick video Auto Sense in order
to show the target's video sooner. This option is especially useful for
entering a target server's BIOS configuration right after a reboot.

Click OK to apply the settings and close the dialog. Click Apply to apply the
settings without closing the dialog.
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Note: Some Sun background screens, such as screens with very dark borders,
may not center precisely on certain Sun servers. Use a different background or

place a lighter colored icon in the upper left corner of the screen.

Contrast Blue: 80

Horizontal Offset: 265

Video Settings

PLL Settings
Clock: 1,312/ 1028 - { {1812
Phase: 1] o 1 31

Color Settings
Brightness Red: o o [} 127
Brightness Green: 0 o ” 127
Brightness Blue: 4= o {} 127
Contrast Red: ssl2| o i 127
Contrast Green: 87> 0 ” 127

Vertical Offset: 31

Automatic Color Calibration

Video Sensing

(@) Best possible video mode

() Quick sense video mode

Screenshot from Target Command (Target Screenshot)

Take a screenshot of a target server using the Screenshot from Target server
command. If needed, save this screenshot to a file location of your choosing as

a bitmap, JPEG or PNG file.

P> To take a screenshot of the target server:

Select Video > Screenshot from Target, or click the Target Screenshot

button ﬂ on the toolbar.

2. Inthe Save dialog, choose the location to save the file, name the file, and

select a file format from the 'Files of type' drop-down.

3. Click Save to save the screenshot.
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Mouse Options
You can operate in either single mouse mode or dual mouse mode.

When in a dual mouse mode, and provided the option is properly configured,
the mouse cursors align.

When controlling a target server, the Remote Console displays two mouse
cursors - one belonging to your KX IlI client workstation, and the other
belonging to the target server.

When there are two mouse cursors, the device offers several mouse modes:
e Absolute (Mouse Synchronization)

e Intelligent (Mouse Mode)

e Standard (Mouse Mode)

When the mouse pointer lies within the KVM Client target server window,
mouse movements and clicks are directly transmitted to the connected target
server.

While in motion, the client mouse pointer slightly leads the target mouse
pointer due to mouse acceleration settings.

Single mouse mode allows you to view only the target server's pointer. You can
use Single mouse mode when other modes don't work.

You can toggle between these two modes (single mouse and dual mouse).

Dual Mouse Modes
Absolute Mouse Synchronization

In this mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different acceleration
or speed. This mode is supported on servers with USB ports and is the default
mode for virtual media CIMs.

e Absolute Mouse Synchronization requires the use of a virtual media CIM -
D2CIM-VUSB, D2CIM-DVUSB, D2CIM-DVUSB-DVI, D2CIM-DVUSB-HDMI,
D2CIM-DVUSB-DP, D2CIM-VUSB-USBC

P> To enter Absolute Mouse Synchronization:
e Choose Mouse > Absolute from the KVM client.

The black USB connector on the DVUSB CIMs are used for the keyboard and
mouse. The gray connector is used for virtual media.

For CIMs with two USB plugs, keep both connected to the device.

The device may not operate properly if both plugs are not connected to the
target server.
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Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse settings and
synchronize the mouse cursors accordingly, allowing mouse acceleration on the
target. Intelligent mouse mode is the default for non-VM targets.

Enter Intelligent Mouse Mode

P> To enter intelligent mouse mode:
e Choose Mouse > Intelligent.
Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the Mouse
menu, automatically synchronizes mouse cursors during moments of inactivity.
For this to work properly, however, the following conditions must be met:

e The active desktop should be disabled on the target.

e No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of the
target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e The target advanced mouse properties such as “Enhanced pointer
precision" or “Snap mouse to default button in dialogs” should be disabled.

e The edges of the target video should be clearly visible (that is, a black
border should be visible between the target desktop and the remote KVM
console window when you scroll to an edge of the target video image).

e When using the intelligent mouse synchronization function, having a file
icon or folder icon located in the upper left corner of your desktop may
cause the function not to work properly. To be sure to avoid any problems
with this function, do not have file icons or folder icons in the upper left
corner of your desktop.

After autosensing the target video, manually initiate mouse synchronization by
clicking the Synchronize Mouse button on the toolbar. This also applies when
the resolution of the target changes if the mouse cursors start to desync from
each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.

Please note that mouse configurations will vary on different target operating
systems. Consult your OS guidelines for further details. Also note that
intelligent mouse synchronization does not work with UNIX targets.
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Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization algorithm. The
algorithm determines relative mouse positions on the client and target server.

In order for the client and target mouse cursors to stay in synch, mouse
acceleration must be disabled. Additionally, specific mouse parameters must
be set correctly.

P> To enter Standard Mouse mode:
e Choose Mouse > Standard.

Mouse Synchronization Tips
If you have an issue with mouse synchronization:

1. Verify that the selected video resolution and refresh rate are among those
supported by the device. The KVM Client Connection Info dialog displays
the actual values that the device is seeing.

2. Force an auto-sense by clicking the KVM Client auto-sense button.

3. If that does not improve the mouse synchronization (for Linux, UNIX, and
Solaris KVM target servers):

a. Open aterminal window.
b. Enter the following command: xset mouse 1 1

c. Close the terminal window.

4. Click the "KVM Client mouse synchronization" button ﬁ

Synchronize Your Mouse

In dual mouse mode, the Synchronize Mouse command forces realignment of
the target server mouse cursor with the client mouse cursor.

P> To synchronize the mouse cursors, do one of the following:

e Click the Synchronize Mouse button m in the KVM client toolbar, or
select Mouse > Synchronize Mouse from the menu bar.

Note: This option is available only in Standard and Intelligent mouse modes.

Cursor Shape

In dual mouse modes, you can select a custom cursor shape for your session.
To make the cursor selection permanent, see Client Launch Settings (on page
57).

P> To change the cursor shape:

e Choose Mouse > Cursor Shape, then select from the list.
= Default arrow
= Dot

= Crosshair
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=  Transparent

Mouse|T00|s View Virtual Media Audio Power (

Sync Mouse

Single Mouse Cursor

‘ Cursor Shape v ‘Ej Default

@ Absolute Dot
Intelligent Crosshair
Standard Transparent

Single Mouse Mode

Single Mouse mode uses only the target server mouse cursor; the client mouse
cursor no longer appears onscreen.

Note: Single mouse mode does not work on Windows or Linux targets when the
client is running on a Virtual Machine.

P> To enter single mouse mode, do one the following:
e Choose Mouse > Single Mouse Cursor.

e Click the Single/Double Mouse Cursor button h in the toolbar.

-
Single Cursor : ‘.

You are about to enter Single Cursor mode. While you are in this mode,
this software will have exclusive control over the mouse and keyboard.

To exit single cursor mode, you must press Ctrl+LeftAlt+0
[ Scale the video {no scroll bars)

| oK | ’ Cancel

P> To exit single mouse mode:

1. Press Ctrl+Alt+O on your keyboard to exit single mouse mode.

Tool Options

General Settings

1. Click Tools > Options. The Options dialog appears.

= Select the Enable Logging checkbox only if directed to by Technical
Support.

This option creates a log file in your home directory.
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Keyboard Type--not visible in AKC, because the keyboard type defaults
to the local client:

= US/International

= French (France)

= German (Germany)

= Japanese

= United Kingdom

= Korean (Korea)

= French (Belgium)

= Norwegian (Norway)
= Portuguese (Portugal)
= Danish (Denmark)

= Swedish (Sweden)

=  German (Switzerland)
= Hungarian (Hungary)
= Spanish (Spain)

= [talian (Italy)

= Slovenian

= Translation: French - US

= Translation: French - US International

e Select Adjust Full Screen Window Size to Target Resolution Instead of
Client Resolution if you prefer. Option not available for Linux clients. See
Adjust Full Screen Window Size to Target Resolution (on page 57) for
examples.

e Disable Menu in Full Screen: This option prevents the menu from popping
back up when cursor approaches while in Full Screen mode.

e  Configure hotkeys:

Raritan.
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Toggle Full Screen Mode - Hotkey.

When you enter Full Screen mode, the display of the target server
becomes full screen and acquires the same resolution as the target
server.

This is the hot key used for toggling in and out of this mode.
Toggle Single Cursor Mode - Hotkey.

When you enter single cursor mode, only the target server mouse
cursor is visible.

This is the hot key used to toggle in and out of single cursor mode,
removing and bringing back the client mouse cursor.

Toggle Scaling Mode - Hotkey.

When you enter scaling mode, the target server scales to fit your
display.

This is the hot key used to toggle in and out of scaling mode.
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= Disconnect from Target - Hotkey.

Enable this hotkey to allow users to quickly disconnect from the target.

For hotkey combinations, the application does not allow you to assign the

same hotkey combination to more than one function.

For example, if Q is already applied to the Disconnect from Target function,

it won't be available for the Toggle Full Screen Mode function.

Further, if a hotkey is added to the application due to an upgrade and the
default value for the key is already in use, the next available value is
applied to the function instead.

1. Click OK.

Keyboard Limitations

Turkish Keyboards

Turkish keyboards are only supported on Active KVM Client (AKC).

Slovenian Keyboards

The < key does not work on Slovenian keyboards due to a JRE limitation.

Language Configuration on Linux

Because the Sun JRE on Linux has problems generating the correct Key Events
for foreign-language keyboards configured using System Preferences, configure
foreign keyboards using the methods described in the following table.

Language
US Intl

French
German
Japanese
UK
Korean
Belgian
Norwegian
Danish
Swedish
Hungarian
Spanish
Italian

Slovenian

Configuration method
Default

Keyboard Indicator
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)
Keyboard Indicator
Keyboard Indicator
Keyboard Indicator
Keyboard Indicator
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)

System Settings (Control Center)
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Language Configuration method

Portuguese System Settings (Control Center)

Note: The Keyboard Indicator should be used on Linux systems using Gnome as
a desktop environment.

Adjust Full Screen Window Size to Target Resolution

When Adjust Full Screen Window Size to Target Resolution instead of Client
Resolution is enabled, the client starts in full-screen in a window equal to the
target's resolution, not the resolution of the client monitor. If you have a
multi-monitor client, a full-screen window may cover more than one monitor.
See General Settings for instructions on enabling the setting.

>  Example:

The client has a multi-head environment with 8 monitors, 1920 x 1080 each
with the following arrangement:

1 2 3 4
5 6 7 8

A KVM session is launched on monitor 6 with a the target resolution of 3840 x
1080. The client window opens on monitor 6 and 7 in native resolution and
covers both monitors by 100%.

Client Launch Settings

Configuring client launch settings allows you to define the screen settings for a
KVM session.

P> To configure client launch settings:

Click Tools > Options. The Options dialog appears.
2. Click on the Client Launch Settings tab.

= To configure the target window settings:

= Select 'Standard - sized to target Resolution' to open the window
using the target's current resolution. If the target resolution is
greater than the client resolution, the target window covers as
much screen area as possible and scroll bars are added (if
needed).

= Select 'Full Screen' to open the target window in full screen mode.

= To configure the monitor on which the target viewer is launched:
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= Select 'Monitor Client Was Launched From' if you want the target
viewer to be launched using the same display as the application
that is being used on the client (for example, a web browser or
applet).

= Use 'Select From Detected Monitors' to select from a list of
monitors that are currently detected by the application. If a
previously selected monitor is no longer detected, 'Currently
Selected Monitor Not Detected' is displayed.

= To configure cursor shape:

= Select Default arrow, Dot, Crosshair, or Transparent to set the
cursor shape for all sessions. Use the Mouse menu to change the
cursor shape during a session.

= To configure additional launch settings:
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= Select 'Enable Single Cursor Mode' to enable single mouse mode
as the default mouse mode when the server is accessed.

= Select 'Enable Scale Video' to automatically scale the display on
the target server when it is accessed.

= Select 'Pin Menu Toolbar' if you want the toolbar to remain visible
on the target when it is in Full Screen mode. By default, while the
target is in Full Screen mode, the menu is only visible when you
hover your mouse along the top of the screen.

= Always Show Tool Bar and Always Show Status Bar are per-user
settings that are stored in the computer you are accessing the
client from, so if you use a different computer, the setting may be
different. Select to keep tool bar and status bar visible as default,
deselect to keep tool bar and status bar hidden as default.

3. Click OK.

Options X
General Client Launch Settings
Window Mode
(®) Standard - sized to target resolution
() Full Screen
Monitor
(®) Monitor Client Was Launched From
() Select From Detected Monitors
Monitor A

Detected Monitors

Cursor Shape

(®) Default (O Dot

() Crosshair () Transparent
Other

[ ] Enable Single Mouse Cursor

[ ] Enable Scale Video

[ ] Pin Menu Toolbar

Always Show Tool Bar

Always Show Status Bar

Cancel
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Configuring Port Scan Settings in VKC/VKCS and AKC

Configuring port scan options in VKC/VKCS and AKC applies to scanning from
the Remote Console.

To configure port scan options for the Local Console, see Configure Local
Console Scan Settings (on page 164)

Use the port scanning feature to search for selected targets, and display them
in a slide show view, allowing you to monitor up to 32 targets at one time.

You can connect to targets or focus on a specific target as needed. Scans can
include standard targets, blade servers, tiered devices, and KVM switch ports.

Configure scan settings from either the VKC/VKCS or AKC.
See Scanning Ports - Remote Console (on page 151)
Use the Scan Settings tab to customize the scan interval and default display

options.

Configure Port Scan

To set scan settings:

>
1. Click Tools > Options. The Options dialog appears.
2. Select the Scan Settings tab.

3

In the "Display Interval" field, specify the number of seconds you want the
target that is in focus to display in the center of the Port Scan window.

4. Inthe "Interval Between Ports" field, specify the interval at which the
device should pause between ports.

5. Inthe Display section, change the default display options for the thumbnail
size and split orientation of the Port Scan window.

6. Click OK.

Collecting a Diagnostic Snapshot of the Target

Administrators are able to collect a "snapshot" of a target.
The "snapshot" function generate log files and image files from the target.

It then bundles these files in a zip file that can be sent to Technical Support to
help diagnose technical problems you may be encountering.

The following files are included in the zip file:
e screenshot_image.png

This is a screenshot of the target that captures a picture of the issue you
are experiencing. This feature operates like the "Screenshot from Target"
feature.

e raw_video_image.png:

A snapshot image created from raw video data. Please note that client's
postprocessing is applied, just as if it were a "regular" screen update.
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e raw_video_ycbcr420.bin:

Binary file of the raw snapshot.

e raw_video_ycbcr420.txt:

Text file containing data used to help diagnose issues.
e Log.txt file:
These are the client logs.

Note that the logs are included even if you have not enabled information
to be captured in them. VKC uses internal memory to capture the
information in this case.

Collect a Diagnostic Snapshot
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P> To capture a diagnostic snapshot:

L s N e W ) =)
Kome Sadwp Teok  Semagy  Wedw  Mep v
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‘0980
| Feiders » WinZp e ™
e [P d j g H’.. 5 \j j
[t video yebollibn | raw o ycholdint e ideo mugepeg  sovenictimageny  dagrosc e vy
eoifalips n Testhanda - 80
Steps
@ Access a target, and then click Tools > Collect a Diagnostic Snapshot.
Several messages are displayed as the information is collected.
@ You are prompted to save the zip file containing the diagnostic files.

@ The zip file containing the diagnostic files is saved.
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View Options

View Toolbar

You can use the Virtual KVM client with or without the toolbar display.

P> To toggle the display of the toolbar (on and off):
e Choose View > View Toolbar.

View Status Bar

By default, the status bar is displayed at the bottom of the target window.

P> To hide the status bar:
Click View > Status Bar to deselect it.

P> Torestore the status bar:
Click View > Status Bar to select it.

Scaling

Scaling your target window allows you to view the entire contents of the target
server window.

This feature increases or reduces the size of the target video to fit the Virtual
KVM Client window size, and maintains the aspect ratio so that you see the
entire target server desktop without using the scroll bar.

P> To toggle scaling (on and off):
e Choose View > Scaling.

63



Appendix A: KVM Clients

Full Screen Mode
When you enter Full Screen mode, the target's full screen is displayed and
acquires the same resolution as the target server.

The hot key used for exiting this mode is specified in the Options dialog, see
Tool Options (on page 54).

While in Full Screen mode, moving your mouse to the top of the screen
displays the Full Screen mode menu bar. The behavior of the menu in full
screen mode is affected by some options on the Tool Options menu. See Tool
Options > General Settings > Full Screen options

If you want the menu bar to remain visible while in Full Screen mode, enable
the Pin Menu Toolbar option from the Tool Options dialog. See Tool Options
(on page 54).

P> To enter full screen mode:
e Choose View > Full Screen, or click the Full Screen button IE'

P> To exit full screen mode:

e Press the hot key configured in the Tool's Options dialog. The default is
Ctrl+Alt+M.

If you want to access the target in full screen mode at all times, you can make
Full Screen mode the default.

P> To set Full Screen mode as the default mode:

Note: Not available in LX2.

1. Click Tools > Options to open the Options dialog.
2. Select Enable Launch in Full Screen Mode and click OK.

Connect to Virtual Media

See Virtual Media (on page 24)
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Smart Cards

Using the KX IIl, you are able to mount a smart card reader onto a target server
to support smart card authentication and related applications.

For a list of supported smart cards, smart card readers, and additional system
requirements, see Smart Card Minimum System Requirements, CIMs and
Supported/Unsupported Smart Card Readers (on page 65).

Note: The USB Smart Card token (eToken NG-OTP) is only supported from the
remote client.

Smart card reader mounting is also supported from the Local Console.

See Local Console Smart Card Access (on page 165).

Smart Card Minimum System Requirements, CIMs and Supported/Unsupported Smart
Card Readers

Before you begin using a smart card reader, review the following:

e  Smart Card Minimum System Requirements (on page 202)

e  Supported Computer Interface Module (CIMs) Specifications (on page
195)

e  Supported Smart Card Readers (on page 204, "Unsupported Smart Card
Readers" on page 205)

Authentication When Accessing a Smart Card Reader

When accessing a server remotely, you can select an attached smart card
reader and mount it onto the server.

Smart card authentication is used with the target server, it is not used to log
into the device. Therefore, changes to smart card PIN and credentials do not
require updates to device accounts.

PC Share Mode and Privacy Settings when Using Smart Cards

When PC-Share mode is enabled on the device, multiple users can share access
to a target server.

However, when a smart card reader is connected to a target, the device will
enforce privacy regardless of the PC-Share mode setting.

In addition, if you join a shared session on a target server, the smart card
reader mounting will be disabled until exclusive access to the target server
becomes available.
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Smart Card Reader Detected

After a KVM session is established with a target server, a Smart Card menu and
button are available in VKC and AKC.

Once the Smart Card button is selected or Smart Card is selected from the
menu, the smart card readers that are detected as attached to the remote
client are displayed in a dialog.

From this dialog, you can attach additional smart card readers, refresh the list
of smart card readers attached to the target, and detach smart card readers.

You are also able to remove or reinsert a smart card. This function can be used
to provide notification to a target server OS that requires a removal/reinsertion
in order to display the appropriate login dialog. Using this function allows the
notification to be sent to a single target without affecting other active KVM
sessions.

Mount a Smart Card Reader
When mounted onto the target server, the card reader and smart card will
cause the server to behave as if they had been directly attached.

Removal of the smart card or smart card reader will cause the user session to
be locked or you will be logged out depending on how the card removal policy
has been setup on the target server OS.

When the KVM session is terminated, either because it has been closed or
because you switch to a new target, the smart card reader will be automatically
unmounted from the target server.

> To mount a smart card reader from VKC or AKC:

Click the Smart Card menu and then select Smart Card Reader.

Alternatively, click the Smart Card button Q in the toolbar.
Select the smart card reader from the Select Smart Card Reader dialog.
Click Mount.

A progress dialog will open. Check the '"Mount selected card reader
automatically on connection to targets' checkbox to mount the smart card
reader automatically the next time you connect to a target. Click OK to
begin the mounting process.

Update a Smart Card Reader

P To update the smart card in the Select Smart Card Reader dialog:

e  C(lick Refresh List if a new smart card reader has been attached to the
client PC.
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Send Smart Card Remove and Reinsert Notifications

P>  To send smart card remove and reinsert notifications to the target:

e Select the smart card reader that is currently mounted and click the
Remove/Reinsert button.

Unmount (Remove) a Smart Card Reader

»  To unmount a smart card reader:

e Select the smart card reader to be unmounted and click the Unmount
button.

Digital Audio

The KX Ill supports end-to-end, bidirectional, digital audio connections for
digital audio playback and capture devices from a remote client to a target
server.

The audio devices are accessed over a USB connection.
e  Current device firmware is required.
e One of the following CIMs must be used:
= D2CIM-DVUSB
= D2CIM-DVUSB-DVI
= D2CIM-DVUSB-HDMI
e D2CIM-DVUSB-DP

Windows®, Linux® and Mac’ operating systems are supported. VKC, VKCS, and
AKC support connections to audio devices.

Note: Audio CDs are not supported by virtual media so they do not work with
the audio feature.

Before you begin using the audio feature, review the audio related information
documented in the next sections.

e Informational Notes, Audio (on page 227)

Supported Audio Device Formats

The KX Il supports one playback and capture device and one record device on a
target at a time. The following audio device formats are supported:

e Stereo, 16 bit, 44.1K

e Mono, 16 bit, 44.1K

e Stereo, 16 bit, 22.05K

e Mono, 16 bit, 22.05K

e Stereo, 16 bit, 11.025K

e Mono, 16 bit, 11.025K
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Digital Audio VKC and AKC Icons

Audio Icon name
icons
X Speaker
4 L]
vy Wil .
'ﬁ@-' Microphone

[ Ha-

Description

These icons are located in status bar at the bottom of
the client window.

Green, blinking waves indicate an audio playback
session is currently streaming.

A black speaker icon is displayed when the session is
muted.

The icon is grayed out when no audio is connected.
These icons are located in the status bar at the
bottom of the client window.

Red, blinking waves indicate an audio capture session
is currently underway.

The Speaker icon, indicating a playback session is
streaming, is also displayed when a session is
underway.

A black Microphone icon is displayed when the
session is muted.

When the Microphone icon is grayed out, no audio is
connected.

Audio Playback and Capture Recommendations and Requirements

Audio Level

e Setthe target audio level to a mid-range setting.

For example, on a Windows® client, set the audio to 50 or lower.

This setting must be configured through the playback or capture audio device,
not from the client audio device control.
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Recommendations for Audio Connections when PC Share Mode is Enabled

If you are using the audio feature while running PC Share mode, audio playback
and capture are interrupted if an additional audio device is connected to the
target.

For example, User A connects a playback device to Targetl and runs an audio
playback application then User B connects a capture device to the same target.
User A's playback session is interrupted and the audio application may need to
be restarted.

The interruption occurs because the USB device needs to be re-enumerated
with the new device configuration.

It may take some time for the target to install a driver for the new device.

Audio applications may stop playback completely, go to the next track, or just
continue playing.

The exact behavior is dependent on how the audio application is designed to
handle a disconnect/reconnect event.

Bandwidth Requirements

The table below details the audio playback and capture bandwidth
requirements to transport audio under each of the selected formats.

Audio format Network bandwidth requirement
44.1 KHz, 16bit stereo 176 KB/s

44.1 KHz, 16bit mono 88.2 KB/s

2.05 KHz, 16bit stereo 88.2 KB/s

22.05 KHz, 16bit mono 44.1 KB/s

11.025 KHz, 16bit stereo 44.1 KB/s

11.025 KHz, 16bit mono Audio 22.05 KB/s

In practice, the bandwidth used when an audio device connects to a target is
higher due to the keyboard and video data consumed when opening and using
an audio application on the target.

A general recommendation is to have at least a 1.5MB connection before
running audio/video.

e However, high video-content, full-color connections using high-target
screen resolutions consume much more bandwidth and impact the quality
of the audio considerably.

e Set Smoothing to High. This will improve the appearance of the target
video by reducing displayed video noise

e Under Video settings, set the Noise Filter to its highest setting of 7 (highest
value) so less bandwidth is used for target screen changes
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Saving Audio Settings

Audio device settings are applied on a per KX Ill device basis.

Once the audio devices settings are configured and saved on the KX Ill, the
same settings are applied to it.

See Connecting and Disconnecting from a Digital Audio Device (on page 71)
for information on connecting to and configuring an audio device, and
Adjusting Capture and Playback Buffer Size (Audio Settings) (on page 72) for
information on audio device buffer settings.

If you are using the audio feature while running PC Share mode and VM Share
mode so multiple users can access the same audio device on a target at once,
the audio device settings of the user who initiates the session are applied to all
users who join the session.

So, when a user joins an audio session, the target machine settings are used.

Connecting to Multiple Targets from a Single Remote Client

Connect to audio on up to four (4) target servers at the same time from a single,
remote client.

See Connecting and Disconnecting from a Digital Audio Device (on page 71)
for information on connecting to audio devices.

A Speaker icon 4 is displayed in the status bar at the bottom of the client
window. It is grayed out when no audio is being used. When the Speaker icon

il
. . 1 | . . . . .
and Microphone icon k"ﬁ' are displayed in the status bar, the session is being
captured as it is streamed.

Note: When audio over HDMlI is connected, the idle user timeout setting is
ignored.

Operating System Audio Playback Support

Review the table shown here to see which client works with audio
playback/capture for each operating system:

Operating system Audio playback and capture supported by:
Windows*® = Active KVM Client (AKC)
= Virtual KVM Client (VKC)
Linux® = Virtual KVM Client (VKC)
Mac® = Virtual KVM Client (VKC)
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Connecting and Disconnecting from a Digital Audio Device

Audio device settings are applied on a per KX Ill device basis.

Once the audio devices settings are configured and saved on the KX IlI, the
same settings are applied to it.

See Saving Audio Settings (on page 70) for more information.

Note: If you are using the audio feature while running PC Share mode and VM
Share mode, see Audio Playback and Capture Recommendations and
Requirements (on page 68) for important information. See also Connecting to
Multiple Targets from a Single Remote Client (on page 70).

Connect to a Digital Audio Device

>

10.

11.

To connect to an audio device:

Connect the audio device to the remote client PC prior to launching the
browser connection to the KX II.

Connect to the target from the Port Access page.

Once connected, click the Audio button Eﬂ'ﬂ in the toolbar.

The Connect Audio Device dialog appears. A list of available audio devices
connected to the remote client PC is displayed.

Note: If there are no available audio devices connected to the remote client
PC, the Audio icon is grayed out. .

Check Connect Playback Device if you are connecting to a playback device.
Select the device that you wish to connect from the drop-down list.

Select the audio format for the playback device from the Format:
drop-down.

Note: Select the format that you wish to use based on the available
network bandwidth. Formats with lower sampling rates consume less
bandwidth and may tolerate more network congestion.

Select the "Mount selected playback device automatically on connection to
target" checkbox to automatically connect an audio playback device when
you connect to an audio supporting target.

Check Connect Recording Device if you are connecting a recording device.

Note: The device names listed in the Connect Recording Device drop-down
are truncated to a maximum of 30 characters for Java clients.

Select the device that you wish to connect from the drop-down list.

Select the audio format for the recording device from the Format:
drop-down.

Click OK. If the audio connection is established, a confirmation message
appears. Click OK.
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If the connection was not established, an error message appears.

Once an audio connection is established, the Audio menu changes to
Disconnect Audio. The settings for the audio device are saved and applied
to subsequent connections to the audio device.

"
1

A Speaker icon 4’ is displayed in the status bar at the bottom of the

client window. It is grayed out when no audio is being used. When the
i

i
Speaker icon and Microphone icon '*'CQ?I are displayed in the status bar,
the session is being captured as it is streamed.

Disconnect from an Audio Device
»  To disconnect from the audio device:

o
e Click the Audio icon (If# in the toolbar and select OK when you are
prompted to confirm the disconnect. A confirmation message appears.
Click OK.

Adjusting Capture and Playback Buffer Size (Audio Settings)
Once an audio device is connected, the buffer size can be adjusted as needed.

This feature is useful for controlling the quality of the audio, which may be
impacted by bandwidth limitations or network spikes.

Increasing the buffer size improves the audio quality but may impact the
delivery speed.

The maximum available buffer size is 400 milliseconds since anything higher
than that greatly impacts audio quality.

The buffer size can be adjusted whenever needed, including during an audio
session.

Audio settings are configured in VKC or AKC.
Adjust Audio Settings

P> To adjust audio settings:

Select Audio Settings from the Audio menu. The Audio Settings dialog
opens.

2. Adjust the capture and/or playback buffer size as needed. Click OK.

Capture Buffer Size: miliseconds

Flayback Buffer Size: miliseconds
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Power Control Using VKC, VKCS, and AKC

You can power on, power off, and power cycle a target through the outlet it is
connected to.

Access the target, and then select a power control option from the Power
Control menu.

Connection USB Profile Keyboard Video Mouse Tools View Virtual Media Audie SmartCard [Power Control| Help

SANEEh@EQD DO R roven

Power Off

Power Cycle

The menu option is disabled if you do not have permission for power control,
and when outlets are not associated with the port.

Version Information - Virtual KVM Client

For version information about the client, in case you require assistance from
Raritan Technical Support.

e Choose Help > About Raritan Virtual KVM Client.

Active KVM Client (AKC) Help

Raritan.
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To launch AKC, enter https://<IP address>/akc in a browser.
The Active KVM Client (AKC) is based on Microsoft Windows .NET* technology.
This allows you to run the client in a Windows environments without Java..

For details on using the features, see Virtual KVM Client (VKC and VKCs) Help
(on page 34).

Recommended Minimum Active KVM Client (AKC) Requirements

It is recommended that the Active KVM Client (AKC) machines meet the
following minimum requirements.

e Client machine with either a -

=  'modern' dual-core CPU for a single connections, or

=  'modern' quad core CPU for two or more simultaneous connections
e 4GB of RAM
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AKC Supported Microsoft .NET Framework

The Active KVM Client (AKC) requires Windows .NET". See the Release Notes for
supported versions.

AKC Supported Operating Systems

When launched from Internet Explorer®, the Active KVM Client (AKC) allows you
to reach target servers via the KX III.

AKC is compatible with the following platforms:
e Windows 11 “ operating system (up to 64 bit)
See the Release Notes for the latest supported versions.

AKC Supported Browsers

See the Release Notes for supported browser versions.

Prerequisites for Using AKC

Allow Cookies

Ensure the cookies from the IP address of the device that is being accessed are
not currently being blocked.

Include KX Il IP Address in 'Trusted Sites Zone'

Add the IP address of the device being accessed to the browser's Trusted Sites
Zone.

Disable 'Protected Mode'

Make sure that Protected Mode is not on when accessing this device.

Enable AKC Download Server Certificate Validation

If the administrator has enabled the Enable AKC Download Server Certificate
Validation option:

e Administrators must upload a valid certificate to the device or generate a
self-signed certificate on the device. The certificate must have a valid host
designation.

e Each user must add the CA certificate (or a copy of self-signed certificate)
to the Trusted Root CA store in their browser.
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Proxy Server Configuration

When the use of a Proxy Server is required, a SOCKS proxy must also be
provided and configured on the remote client PC.

Note: If the installed proxy server is only capable of the HTTP proxy protocol,
you cannot connect.

>

To configure the SOCKS proxy:

On the remote client PC, select Control Panel > Internet Options.

a.

On the Connections tab, click 'LAN settings'. The Local Area Network
(LAN) Settings dialog opens.

Select 'Use a proxy server for your LAN'.
Click Advanced. The Proxy Settings dialog opens.
Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

e.

Click OK at each dialog to apply the settings.

Next, configure the proxy settings for the Java™ applets:

Select Control Panel > Java.

On the General tab, click Network Settings. The Network Settings
dialog opens.

Select "Use Proxy Server".
Click Advanced. The Advanced Network Settings dialog opens.
Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

Connect to a Target from Virtual KVM Client (VKC), Standalone VKC (VKCs), or
Active KVM Client (AKC)

Once you have logged on to the KX Il Remote Console, access target servers via
the Virtual KVM Client (VKC), Standalone VKC (VKCs), or Active KVM Client

(AKC).

»  To connect to an available server:

1.

On the Port Access page, click on the port name of the target server you
want to connect to. The Port Action menu opens.
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2. Click Connect.

Home > Ports

Port Access

Click on the individual
0/ 4 Remote KVM char

View By Grg

See Port Action Menu (on page 19) for details on additional available menu

options.
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HTML KVM Client (HKC)

Raritan.

Abrand of O legrand

The HTML KVM client (HKC) provides KVM over IP access that runs in the
browser without the need for applets or browser plugins. HKC uses Javascript,
NOT Java.

HKC runs on Linux and Mac clients, and on Windows clients in Internet Explorer
11, Edge, Firefox, Chrome and Safari browsers.

A mobile version of HKC also runs on iOS v10 and higher. See KVM Client
Launching (on page 33) for a full matrix of clients.

Many KVM features are supported. Future releases will provide more advanced
KVM features.

>

Supported Features:

Connection Properties

USB Profiles

Video Settings

Input Settings

Audio Playback

Virtual Media

Dual Video Targets

Keyboard Macros

Import and Export of Keyboard Macros
Send Text to Target

Keyboard and Mouse Settings

Single Mouse Mode - not available on IE browser
Power Control

Not supported:

Port Scanning

Smartcard

Limited Tools Menu options.

Limited keyboard support: US-English, UK-English, French, German,

Swiss-German, and Japanese are supported
Hotkeys for keyboard macros
Pre-populated keyboard macros for Sun targets

Can only create Macros from keys that exist on the client PC (US-English,
UK-English, French, German), no special function keys except for delay key.

Single Mouse mode - not available on IE
Virtual Media write not supported

Local file transfer not supported on IE11.
USB drive connects
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Favorites
Audio capture, No audio support on IE.

Tips and Known Issues:

Ensure that the device certificate is installed and trusted. The certificate
Common name should match the IP address/Hosthame used to connect to
the device. See SSL and TLS Certificates for information on creating and
installing certificates

When Single Mouse Mode in the Edge browser is selected for the first time,
the user is prompted to turn off the local mouse pointer. Select the bottom
part of the Yes button.

Target connections from Chrome 61 running on Fedora requires HardWare
Acceleration to be enabled.

If erratic mouse response is seen in Single Mouse mode on Fedora clients
using the default Gnome desktop, use the Gnome classic desktop.

To enable scrollbars on Mac Browser target connections: On the OS menu
bar, choose System Preferences > General > Show scroll bars: Always.

Internet Explorer and Edge support only 6 sessions at a time. The error
displayed when attempting to connect to a seventh target is "Error could
not connect to target." For IE11, you can increase the sessions allowed in
the Group policy editor. See
https://jwebsocket.org/documentation/reference-guide/internet-explorer-
tips.

For IE11 and Edge IPv6 device connections, either use device hostname or
literal IPv6 as UNC. See
https://en.wikipedia.org/wiki/IPv6_address#Literal_IPv6_addresses_in_UN
C_path_names

For Mac/Safari IPv6 device connections, use device hostname.

Client Keyboard input selection should be set for each device individually.
If encountering issues on browsers that have previously connected to an
older version, it may be necessary to clear the Cache Web Content from
the browser.

To launch HKC automatically in Safari browser: Use http://<IP
Address>/hkc, OR use http://<IP Address>/ if "Java content on browser" is
disabled in Java Control Panel, and "Java Plugin" is disabled in the browser.
From Chrome running on Linux, to get * * or A, the key needs to be hit three
times, or twice followed by a space.

On a default build of Redhat 7/Firefox ESR 24.5, there is no target video
displayed on HKC connections. Older versions of Firefox lack HTML5
functions needed to support HKC. Upgrade Firefox to the latest available
version.

If HKC does not load, but rather displays a white screen, your browser
memory may be full. Close all browser windows and try again.
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e In Chrome, disable the background throttling to prevent background tabs
from disconnecting after a certain amount of time. Go to chrome://flags,
then search for "throttle". Set "Throttle Javascript timers in backgound"
and "Calculate window occlusion on Windows" to "Disabled". Restart
chrome to apply settings.

Connection Properties

Connection properties manage streaming video performance over remote
connections to target servers.

The properties are applied only to your connection - they do not impact the
connection of other users accessing the same target servers.

If you make changes to connection properties, they are retained by the client.

P> To view connection properties:
e Choose File > Connection Properties.

Default Connection Properties

The KX Ill comes configured to provide optimal performance for the majority of
video streaming conditions.

P> KX3 default connection settings:

e Optimized for: Text Readability - video modes are designed to maximize
text readability.

This setting is ideal for general IT and computer applications, such as
performing server administration.

e Video Mode - defaults to Full Color 2.

Video frames transmit in high-quality, 24-bit color. This setting is suitable
where a high-speed LAN is used.

e Noise Filter - defaults to 2.
The noise filter setting does not often need to be changed.
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Click Reset to regain the default connection properties.

Connection Properties

Optimize for: Text Readability ~
Video Mode: Full Color 2

Best Lower
Noise Filter: 2
Quality oise mier Bandwidth

4

e (3 (D

Text Readability

Text Readability is designed to provide video modes with lower color depth but
text remains readable. Greyscale modes are even available when applying
lower bandwidth settings.

This setting is ideal when working with computer GUIs, such as server
administration.

When working in full color video modes, a slight contrast boost is provided, and
text is sharper.

In lower quality video modes, bandwidth is decreased at the expense of
accuracy.

Color Accuracy

When Color Accuracy is selected, all video modes are rendered in full 24-bit
color with more compression artifacts.

This setting applies to viewing video streams such as movies or other broadcast
streams.

In lower quality video modes, sharpness of fine detail, such as text, is sacrificed.
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Video Mode

The Video Mode slider controls each video frame's encoding, affecting video
quality, frame rate and bandwidth.

Connection Properties

Optimize for: Text Readability +
Video Mode: Full Color 2

Best Lower
Noise Filter: 2
Quality oise Fier Bandwidth

&

(I

In general, moving the slider to the left results in higher quality at the cost of
higher bandwidth and, in some cases, lower frame rate.

Moving the slider to the right enables stronger compression, reducing the
bandwidth per frame, but video quality is reduced.

In situations where system bandwidth is a limiting factor, moving the video
mode slider to the right can result in higher frame rates.

When Text Readability is selected as the Optimized setting, the four rightmost
modes provide reduced color resolution or no color at all.

These modes are appropriate for administration work where text and GUI
elements take priority, and bandwidth is at a premium.
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Noise Filter

Unless there is a specific need to do so, do not change the noise filter
setting. The default setting is designed to work well in most situations.

The Noise Filter controls how much interframe noise is absorbed by the KX 111.
Connection Properties

Optimize for: Text Readability ~

Video Mode: Full Color 2

Best Lower
Noise Filter: 2
Quality oise BI & Bandwidth

o o] ]

Moving the Noise Filter slider to the left lowers the filter threshold, resulting in
higher dynamic video quality. However, more noise is likely to come through,
resulting in higher bandwidth and lower frame rates.

Moving the slider to the right raises the threshold, allows less noise and less
bandwidth is used. Video artifacts may be increased.

Moving the noise filter to the right may be useful when accessing a computer
GUI over severely bandwidth-limited connections.
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Connection Info

Open the Connection Information dialog for real-time connection information
on your current connection, and copy the information from the dialog as
needed.

See Default Connection Properties (on page 79) for help configuring the
connection properties.

Raritan.

Abrand of Olegrand’

Name of the device

IP address of the device

Port - The KVM communication TCP/IP port used to access the device
Data In/Second - Data rate received from the device

Data Out/Second - Data rate sent to the device

FPS - Video frames per second from the device.

Average FPS - Average number of video frames per second.
Connect Time - The duration of the current connection.
Resolution - The target server's horizontal and vertical resolution.
Refresh Rate - Refresh rate of the target server.

Protocol Version - communications protocol version.
Subsampling - Adaptive color subsampling

Audio Playback Sample Rate - Audio playback sample rate seen if audio is
connected.

To view connection info:

Choose File > Connection Info.

Connection Info

Device Name: kx4-59-89
IP Address: 192.168.59.89
Port: 443

Data In: 3.00 Kbit/s
Data Out: 1.02 Kbit/s
FPS: 13

Avg. FPS: 12.50
Connect Time: 00:00:52
Horizontal Resolution: 1920
Vertical Resolution: 2160
Refresh Rate: 60 Hz
Protocol Version: 1.34
Subsampling: 4:2:2
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USB Profile
Select a USB profile that best applies to the KVM target server.

For example, if the server is running Windows* operating system, it would be
best to use the Generic profile.

Or, to change settings in the BIOS menu or boot from a virtual media drive,
depending on the target server model, a BIOS profile may be more appropriate.

P To set a USB profile for a target server:

e Choose USB Profile, then choose Generic, or choose Other Profiles to
select from a menu.

@ SmartCard 7.5 - HTML KVM Client - Google Chrome

A Not secure | hitps://192.168.61.140/jsclient/C

File « USB Profile « nput iew « ools - Virtual Med
Help ~ Generic v
% h Other f‘:‘gu:atﬂ—'?# II-"I:J‘IIIIEFHI'D,'LIJ—.:? =

BIOS Dell PowerEdge 1950/2950/2970/6950/R200
BIOS Dell Cptiplex Keyboard and Mouse Only
BIOS Asus P4C800 Motherboard

IBM BladeCenter H with AMM

Use Full Speed for Keyboard and Mouse USB
BIOS HP Proliant DL385 G7

BIOS Dell Optiplex 790 Keyboard Only

BIOS Dell Optiplex 790

Mac USB-C

Help on USB profiles

Note: When using the D2CIM-VUSB-USBC on Mac targets, you must select the
"Mac USB-C" profile.

P> To view details on USB profiles:

Choose USB Profile > Help on USB Profiles.

Input Menu
Keyboard Layout

P> To set your keyboard type.
e Choose Input > Keyboard Layout, then select your keyboard type.

= de-de
= de-ch
=  en-gb
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= en-us
= fr
[] ja

@ SmartCard 7.5 - HTML KVM Client - Google Chrome
A Notsecure | hitps://192.168.61.140/jsclient/Client.asp#
File « USB Profile « Input ~ Video ~ View « ools ~ Vir

Help ~ A Keyboard Layout de-de
3 28 Send Macro
de-ch
% R @ @ Q ﬂ # Macro Editor en-gb
= Send text to target en-us
%= Mouse Modes i
£ Mouse Sync

Send Macro

Due to frequent use, several keyboard macros are preprogrammed.

» Tosend a preprogrammed macro:
e Choose Input > Send Macro, then select the macro:

= Ctrl+Alt+Del: Sends the key sequence to the target without affecting
the client.

= Alt+F4: Closes a window on a target server.
= Alt+Tab: Switch between open windows on a target server.

= Print Screen: Take a screenshot of the target server.

Input ~ Video - View - Virtual Media ~
A Keyboard Layout + ) | gy £

&2 Send Macro Ctri+Alt+Del
# Macro Editor Alt+F4

= Send text to target Alt+Tab

“ Mouse Modes

Print Screen
2 Mouse Sync
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Macro Editor

Keyboard macros ensure that keystroke combinations intended for the target
server are sent to and interpreted only by the target server. Otherwise, they
might be interpreted by your client PC.

Macros are stored on the client PC and are PC-specific. If you use another PC,
you cannot see your macros.

In addition, if another person uses your PC and logs in under a different name,
that user will see your macros since they are computer-wide.

Macros created with HKC are only available with the current browser and KVM
device. If you use HKC in more than one browser, or more than one KX IlI, your
macros will only be available on the browser and KX Ill where they were
created. To reuse your macros in another KX Ill device, you can import and
export the macro files. See Import and Export Macros (on page 90).

P> To access the Macro Editor:
e Choose Inputs > Macro Editor.
e Select a macro from the Macros list to view the key combination.

Macro Editor

Name Ctri+Alt+Del
Macros Keys
Ctri+Alt+Del press: CTRL LEFT Add Key
Alt+F4 press: ALT LEFT
Alt+Tab press: DELETE Add Delay
Print Screen release: CTRL LEFT 2
Greetings release: ALT LEFT
release: DELETE 13

Delete

Add New Macro Delete Macro

Text to macro Use in Toolbar

Export Import m Cancel

Add New Macro

» To add a new macro:

1. Choose Input > Macro Editor.
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Click Add New Macro.

Name Option-Cmd-P-R
Macros Keys
Alt+F4 press: META
Alt+Tab press: P Add Delay
Print Screen press: R
delay: 500ms

Macro Editor

delav: 500ms

e

Text to macro Remove from Toolbar

Delete

Option-Cmd-P-R added to toolbar

o

Enter a Name for the new macro. The name will appear in the Send Macro
menu once the macro is saved.

Click Add Key, then press the key you want to add to the macro. The key
press and key release appear in the Keys list.

= To add more keys, click Add Key again, and press another key.
=  Toremove a key, select it in the Keys list and click Delete.

To put the keys in the correct sequence, click to select a key in the Keys list,
then click the up and down arrows.

To add a 500 ms delay to a key sequence, click Add Delay. A delay in the
middle of a press-and-release key sequence indicates holding down a key.
Add multiple delays to indicate a longer press-and-hold of a key. Click the
up and down arrows to move the delays into the correct sequence.
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7. Click OK to save. To use this macro from your toolbar, click Use in Toolbar.
See Add a Macro to the Toolbar (on page 89) for more details.

Macro Editor

Name Option-Cmd-P-R
Macros Keys
Alt+F4 press: META
Alt+Tab press: P Add Delay
Print Screen press: R
delay: 500ms

delav: 500ms

e

Text to macro Remove from Toolbar

Delete

Option-Cmd-P-R added to toolbar

o

This example shows a macro for a Mac bootup sequence that requires a
2-second delay.

Delete a Macro

To delete a macro:

»>

1. Choose Inputs > Macro Editor.

2. Select the macro, then click Delete Macro.
3

Click OK.
Macro Editor
Name Caps
Macros Keys
Ctri+Alt+Del - press: CAPS Add Key
ARsF4 release: CAPS
At+Tab Add Delay
Print Screen o
Greetings :
New Macro Z
Delete
Add New Macro Delete Macro
Text 1o macro Remove from Toolbar
Caps aocec

e | @Ea
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Add a Macro to the Toolbar

You can add a single macro to your HKC toolbar, so that you can use the macro
by clicking an icon.

>  To add a macro to the toolbar:
1. Choose Inputs > Macro Editor.
2. Select a macro from the Macros list.
3. Click Use in Toolbar.
Macro Editor
Name Ciri<Alt+Dei
Macros Keys
addKey
Alt+Fd press: ALT LEFT
Alt+Tab press: DELETE Add Delay
Print Screen release: CTRLLEFT
Greetings release: ALT LEFT

release: DELETE

Delete

Text to macro Use in Tooibar

o o (o] = ]

4. A message appears to confirm the macro is added to the toolbar.

=  To remove the macro from the toolbar, click Remove from Toolbar, or
select a different macro and click Use in Toolbar.

Macro Editor

Name Caps

Macros Keys
Cirt+Alt+Del - Add Key
All+Fa reiease: CAPS
At+Tab AcdiDelay
Print Screen )
Greetings
New Macro =

Delete

e
Text to macro Remoave from Toolbar
Caps added 1o tooar *—

Export Import Cancel
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5. Click OK and exit the Macro Editor. The macro icon is added to the toolbar
when one has been set.

BANEE REBEQ DO -a

Import and Export Macros

Macros created with HKC are only available with the current browser and KVM
device. If you use HKC in more than one browser, or more than one KX I, your
macros will only be available on the browser and KX Il where they were
created. To reuse your macros in another KX lll device, you can import and
export the macro files. Imported and exported macro files created on HKC are
only compatible with HKC, and cannot be used on AKC or VKC. Likewise, macro
files created on AKC or VKC cannot be imported for use on HKC.

Macros are exported to an xml file named "usermacros.xml". Files are saved in
your browser's default download location. Default macros are not exported.

Note: When exporting macros from Edge browser, a Down arrow is briefly
displayed at the bottom of the KVM window and a file named
"unconfirmed.crdownload" is saved to the default download directory. To use
this file as a macro input file, rename it with a .xml extension.

P> To export and import macros:

=

Choose Input > Macro Editor. The list of macros created for your browser
and KX Ill displays in the Macro Editor dialog.

To export the list, click the Export button, then save the file.
Log in to the KX Ill where you want to import the macros.

Choose Input > Macro Editor.

vk W

Click Import, then click Open to Import and select the usermacros.xml file,
and click OK.

6. The macros found in the file display in the list. Select the macros you want
to import, then click OK.
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= Macro names must be unique. If a macro with the same name already

exists, an error message appears. Click the Edit icon to rename the
macro, then click the checkmark to save the name.

Macro Import

Open to Import

Select macros to import:

Macro1 4

Select All Deselect All

Known Issues for Macros

e You cannot add the Command (Windows) key to a macro from Fedora
browsers. The key is consumed by the OS.
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Text to macro

Text to macros will enable you to work more efficiently by producing
frequently used phrases and paragraphs with a single command. Create a new
macro and then assign text to it.

>  To add text to a macro:

1. Choose Input > Macro Editor.

File « Input ~ Video ~ View ~

a h @ 2] h | A Keyboard Layout |

a8 Send Macro
-l M= # Macro Editor | €=
- = Send text to target
File Home Share Vi
< Mouse Modes
£ Mouse Sync

€ | *Untitled - Notepad
File Edit Format View Help
*# 4 ASDFGHIKL

(&= l
Select to add new macro and enter a macro name.

3. Click Text to macro.

Text to macro

Name Greetings
Ma(f:v‘l,vsAnwDe Beautiful Morning in the Garden Statef
AltrF4 press: B
Alt+Tab release; 8
i 0 release: Lt

release: €
press: A

I Add New Macro l

Text to macro

@

4. Enter text in the text box and then click OK to save.

5. Click OK again in the Macro Editor to save the macro.
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To use macros with text:
Connect to target you want to send macro to

Choose Input > Send Macro and then select the macro you created.

w N =Y

Macro will be sent to the target.

£ Mouse Modes
2 Mouse Sync
¥ Mouse Curso

r

Send Text to Target

Use the Send Text to Target function to send text directly to the target. If a text
editor or command prompt is open and selected on the target, the text is
pasted there.

>  To send text to target:

Choose Input > Send Text to Target. The Send Text to Target dialog
appears.

2. Enter the text you want sent to the target. Supported keyboard characters
only.

3. Click OK.
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Mouse Modes

You can operate in either single mouse mode or dual mouse mode.

When in a dual mouse mode, and provided the option is properly configured,
the mouse cursors align.

When controlling a target server, the Remote Console displays two mouse
cursors - one belonging to your KX llI client workstation, and the other
belonging to the target server.

When there are two mouse cursors, the device offers several mouse modes:

e  Absolute (Mouse Synchronization)
e Intelligent (Mouse Mode)
e Standard (Mouse Mode)

When the mouse pointer lies within the KVM Client target server window,
mouse movements and clicks are directly transmitted to the connected target
server.

While in motion, the client mouse pointer slightly leads the target mouse
pointer due to mouse acceleration settings.

Single mouse mode allows you to view only the target server's pointer. You can
use Single mouse mode when other modes don't work.

You can toggle between these two modes (single mouse and dual mouse).

Absolute Mouse Synchronization

In this mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different acceleration
or speed. This mode is supported on servers with USB ports and is the default
mode for virtual media CIMs.

e Absolute Mouse Synchronization requires the use of a virtual media CIM -
D2CIM-VUSB, D2CIM-DVUSB, D2CIM-DVUSB-DVI, D2CIM-DVUSB-HDMI,
D2CIM-DVUSB-DP, D2CIM-VUSB-USBC

P> To enter Absolute Mouse Synchronization Mode:
e Choose Input > Mouse Modes > Absolute.

Input ~ Video ~ View ~ Virtual Media ~

A Keyboard Layout ()] [DEL|
22 Send Macro ) —
# Macro Editor

= Send text to target
% Mouse Modes Absolute v
el

= Mouse Sync Intelligent

Standard
Single Mouse Mode
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Intelligent

In Intelligent Mouse mode, the device can detect the target mouse settings and
synchronize the mouse cursors accordingly, allowing mouse acceleration on the
target.

P> To enter Intelligent mouse mode:

e Choose Input > Mouse Mode > Intelligent. The mouse will synch. See
Intelligent Mouse Synchronization Conditions (on page 52).

Input ~ Video ~ View ~ Tools ~ Vil
A Keyboard Layout [DEE|

| faRey Y | 8@
as Send Macro

’ " Macro Editor
= Send text to target

Reasoning

’ 2 Mouse Modes Absolute

=2 Mouse Sync Intelligent v
| 4 Mouse Cursor Standard
_ Single Mouse Mode
Standard

Standard Mouse mode uses a standard mouse synchronization algorithm. The
algorithm determines relative mouse positions on the client and target server.

In order for the client and target mouse cursors to stay in synch, mouse
acceleration must be disabled. Additionally, specific mouse parameters must
be set correctly.

P To enter Standard mouse mode:
e Choose Input > Mouse Modes > Standard.
Input ~ Video ~ View ~ Tools ~ Vir

A Keyboard Layout DEL|
g 2 | go
as Send Macro

" Macro Editor “,‘

= Send text to target Ressoning

£+ Mouse Modes Absolute

r~

= Mouse Sync Intelligent
<* Mouse Cursor Standard v
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Single

Single Mouse mode uses only the target server mouse cursor; the client mouse
cursor no longer appears onscreen.

Note: Single mouse mode does not work on Windows or Linux targets when the
client is running on a Virtual Machine. Single mouse mode is not available on
Internet Explorer.

P> To enter Single mouse mode:
e Choose Inputs > Mouse Modes > Single.

Input ~ Video ~ View ~ Tools ~ Vir

A Keyboard Layout [DEY]
| Ebey d | B
a Send Macro
’ " Macro Editor
= Send text to target

’ g Mouse Modes Absolute
= Mouse Sync Intelligent
<» Mouse Cursor Standard v

e A message appears at the top of the client window: Press Esc to show your
cursor.

@ 192.168.61.16 has control of your pointer. Press Esc to take back control.

v

To exit Single mouse mode:
Press Esc.

e  Mouse mode changes back to dual mode.

Mouse Sync

In dual mouse mode, the Synchronize Mouse command forces realignment of
the target server mouse cursor with the client mouse cursor.

Note: This option is available only in Standard and Intelligent mouse modes.

P>  To synchronize the mouse cursors:
e Choose Inputs > Mouse Sync.
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Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the Mouse
menu, automatically synchronizes mouse cursors during moments of inactivity.
For this to work properly, however, the following conditions must be met:

e The active desktop should be disabled on the target.
e No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of the
target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e The target advanced mouse properties such as “Enhanced pointer
precision" or “Snap mouse to default button in dialogs” should be disabled.

e The edges of the target video should be clearly visible (that is, a black
border should be visible between the target desktop and the remote KVM
console window when you scroll to an edge of the target video image).

e  When using the intelligent mouse synchronization function, having a file
icon or folder icon located in the upper left corner of your desktop may
cause the function not to work properly. To be sure to avoid any problems
with this function, do not have file icons or folder icons in the upper left
corner of your desktop.

After autosensing the target video, manually initiate mouse synchronization by
clicking the Synchronize Mouse button on the toolbar. This also applies when
the resolution of the target changes if the mouse cursors start to desync from
each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.

Please note that mouse configurations will vary on different target operating
systems. Consult your OS guidelines for further details. Also note that
intelligent mouse synchronization does not work with UNIX targets.

97



98

Appendix A: KVM Clients

Video Menu

Refresh Screen

The Refresh Screen command forces a refresh of the video screen. Video
settings can be refreshed automatically in several ways:

e The Refresh Screen command forces a refresh of the video screen.

e The Auto-Sense command automatically detects the target server's video
settings.

e The Color Calibration command calibrates the video to enhance the colors
being displayed.

e In addition, you can manually adjust the settings using the Video Settings
command.

> To force a refresh of the video screen:
e Choose Video > Refresh Video.

File ~ JSB Profile ~ put ~ Video ~ ew ~ Tools ~ tual Media ~ Help ~
BhEHE R@@EE S

creenshot
@ Auto Sense
& Color Calibration
B Video Settings

< Clear Video Settings Cache

Screenshot

Take a screenshot of a target server using the Screenshot command.

P> To take a screenshot of the target server:
Choose Video > Screenshot.

2. The screenshot file appears as a download to view or save. Exact options
depend on your client browser.

Video «

BhEHE R@REC 2

esh Screen

50! s

<@ Clear Video Settings Cache
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Auto Sense

The Auto Sense command forces a re-sensing of the video settings, such as
resolution and refresh rate, and redraws the video screen.

P> To automatically re-sense the video settings:
e Choose Video > Auto Sense .
A message stating that the auto adjustment is in progress appears.

File v )SB Profile ~ put ~ Video ~ View - T - Virtual Media ~ 1eip ~
e Refresh Screen
ﬁ h @ m 0 m a c ESC:QQHSHOZ
@ Auto Sense

& Color Calibration

B Video Settings

< Clear Video Settings Cache

Auto adjustment in progress

Color Calibration

The Color Calibration command optimizes the color levels, such as hue,
brightness, and saturation, of the transmitted video images.

The color settings are on a target server-basis.

Note: When color is successfully calibrated, the values are cached and reused
each time you switch to the target. Changes to the brightness and contrast in
Video Settings are not cached. Changing resolution resets the video to the
cached values again. You can clear the cached values in Video > Clear Video
Settings Cache. See Clear Video Settings Cache (on page 48).

»  To calibrate color:
e Choose Video > Color Calibration.

A message stating that the color calibration is in progress appears.

File « USB Profile ~ Input ~ Video ~ View Tools Virtual Media S e -
Gr ra #  © Refresh Screen
% R @ m u - E c Ea Screenshot

E !! @ Auto Sense
& Color Calibration gg—
q 7]

B Video Settings

Google  Control Panel DougHartz MIB B

=7 o-end results
Chrome Q@ Clear Video Settings Cache

Video Settings

Use the Video Settings command to manually adjust the video settings.

P> To change the video settings:

1. Choose Video > Video Settings to open the Video Settings dialog.
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2. Adjust the following settings as required. As you adjust the settings the
effects are immediately visible:

a. PLL Settings

Clock - Controls how quickly video pixels are displayed across the video
screen. Changes made to clock settings cause the video image to
stretch or shrink horizontally. Odd number settings are recommended.
Under most circumstances, this setting should not be changed because
the autodetect is usually quite accurate.

Phase - Phase values range from 0 to 31 and will wrap around. Stop at
the phase value that produces the best video image for the active
target server.

b. Brightness: Use this setting to adjust the brightness of the target
server display.

Brightness Red - Controls the brightness of the target server display for
the red signal.

Brightness Green - Controls the brightness of the green signal.
Brightness Blue - Controls the brightness of the blue signal.
c. Contrast Red - Controls the red signal contrast.
Contrast Green - Controls the green signal.
Contrast Blue - Controls the blue signal.

If the video image looks extremely blurry or unfocused, the settings for
clock and phase can be adjusted until a better image appears on the
active target server.

Warning: Exercise caution when changing the Clock and Phase settings.
Doing so may result in lost or distorted video and you may not be able to
return to the previous state. Contact Technical Support before making any
changes.

d. Horizontal Offset - Controls the horizontal positioning of the target
server display on your monitor.
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e. Vertical Offset - Controls the vertical positioning of the target server
display on your monitor.

Video Settings

PLL Settings

Clock 1344 1026 | 1844
Phase 20 0 | 3

Color Settings
Brighiness Red 1] 4] | 127
Brighiness Green o (4] | 127
Erightness Blue o 1] J 127
Contrast Red B5 0 | 127
Contrast Grean 89 0 | 127
Contrast Blue 7a 0 | 127
Herizonial Offset 288 4] | 255
Verlical Offsat 35 [i] -TEB

¥ Automatic Color Calibration

Video Sensing

* Eest possible video mode

Quick senze video mode
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Clear Video Settings Cache

You can clear the video settings cache to delete old settings that do not apply
anymore, such as when a target server is replaced. When you clear the video
settings cache, the server automatically does a video auto-sense and color
calibration. The new values are cached and reused when the target is accessed
again.

P> To clear the video settings cache:
e Choose Video > Clear Video Settings Cache in the toolbar.

File « USB Profile « Input ~ Video ~ View « Tools « Virtual Media ~ Audio ~ Help «
R ra Refresh Screen
SRES KR@@RE JTrn

@ Auto Sense

& Color Calibration

Bk Video Settings

< Clear Video Settings Cache

View Menu
The View Menu contains options to customize your HKC display.

File ~ USB Profile ~ Input ~ Video ~ View ~ Tools ~ Virtual Media ~ Audio ~ Help ~

SREE REEQ L B

Bstatusbar

Scale Video

LFullscreen

P  Toolbar and Statusbar:

The toolbar contains icons for some commands. The Statusbar displays screen
resolution at the bottom of the client window.

P> Scale Video:

Scale Video scales your video to view the entire contents of the target server
window in your HKC window. The scaling maintains the aspect ratio so that you
see the entire target server desktop without using the scroll bar.

»  Fullscreen:

Fullscreen sets the target window to the size of your full screen, removing your
client from the view.

e  Press Esc to exit fullscreen.
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Tools Menu

The Tools menu contains options for HKC target connection settings.

P> Client Settings:

e Choose Tools > Client Settings to access the Disable Menu in Fullscreen
option.

e When selected, the menu bar will not be available in fullscreen mode. This
setting is specific to the client, so it must be set for each client device and
each browser used for access.

Client Settings

! Disable Menu in Fullscreen

m Cancel

P> Launch Settings:
e Choose Tools > Launch settings to access Client Launch Settings options.

e This menus allows selection of Enable Scale Video, Enable Toolbar, Enable
Statusbar and Mouse Cursor at target launch.

r — — a

Client Launch Settings

Enable Scale Video
Enable Toolbar
Enable Statusbar

Mouse Cursor default v

default

dot
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P> Touch Settings - enabled for iOS clients:

e Tap Tools > Touch Settings to access the Client Touch Settings. Customize
the Touch Input and Gesture Scrolling settings for your mobile device.

Client Touch Settings

Touch Input

Double Click Time (ms)
250 O 750

Mouse Click Hold Time (ms)
250 O 750

DUse Left Hand Mouse

Gesture Scrolling

(JEnable Inverted Scroll x-Axis

(JEnable Inverted Scroll y-Axis

Lo J oo

= Double Click Time: Time between two touch taps for the equivalent of
a mouse double click.

= Mouse Click Hold Time: Time to hold after touch down for the
equivalent of a mouse right click.

= Use Left Hand Mouse: Enable if the target OS's primary mouse button
is set to Right.

= Enable Inverted Scroll x-Axis: If selected, two-finger movement to the
right moves the screen to the left instead of the default right.

= Enable Inverted Scroll y-Axis: If selected, two-finger movement up
moves the screen down instead of the default up.

Virtual Media Menu

Due to browser limitations, HKC supports a different set of virtual media
functions than the other KVM Clients.

Due to browser resources, virtual media file transfer is slower on HKC than the
other KVM clients.
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Connect Files and Folders

The Connect Files and Folders command provides an area to drag and drop files
or folders that you want to connect by means of virtual media.

Supported browsers: Chrome, Firefox, Safari, Edge.

File size limit: 4GB per file

P»  To connect files and folders:

1. Choose Virtual Media > Connect Files and Folders. Or, click the matching
icon in toolbar.

Virtual Media ~ Audio ~ Help ~

ﬁ % @ @ Q @ @ I’J \}_‘,‘, % B Connect Files and Folders <

@ Connect 1ISO

2. Drag files or folders onto the Map Virtual Media Files and Folders dialog.
Click OK.

Map Virtual Media Files And Folders

Cancel

3. A message appears to show virtual media is connected. After a short time,
a VM drive containing the selected files or folders will be mapped to the
target server.

SBRAEE CEEQ 00 mE
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P>  To disconnect files and folders:

e Choose Virtual Media > Disconnect Files and Folders. Or, click the matching
icon in the toolbar.

USB Profile ~ Input ~ T

HE REEQ

Virtual Media ~ Help «

() DET A Disconnect Files and Folders
© @ <+

2. @ Connect ISO

% B

Connect ISO

The Connect ISO command maps a virtual media image file to the target. You
can connect ISO, DMG or IMG files from your client PC or ISO files from a
remote server.

Note: If connection to your SAMBA server is lost while transferring files from
your image file to the target, keyboard and mouse control will be lost for
several minutes, but will recover.

> To map virtual media image files:
1. Choose Virtual Media > Connect ISO. Or, click the matching icon in the
toolbar.

File ~ USB Profile « Input ~ Video ~ View ~ Tools « Virtual Media ~ Audio ~ Helf

M . ) > DET B Connect Files and Folders
‘%kﬁ hﬁ@ 4)’ @ n @Connectlso‘_

2. Select the option for your file's location:

Map Virtual Media ISO Image

@ I1SO Image ¢#——
Browse... | No file selected.

(©) Remote Server ISO Image €¢——

= Select ISO Image if the image file is directly accessible on your client.
Click Browse, select the ISO, DMG or IMG file, and click OK. The
filename appears next to the Browse button.

@ IS0 Image

Browse... | Raritan.iso
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= Select Remote Server ISO Image for ISO files on a remote server.
Remote ISO files must be pre-configured by an administrator for the
mapping to appear here. See Virtual Media File Server Setup (File
Server ISO Images Only) (on page 32). Select the Hostname, then
select the image file from the Image list. Enter the file server's
username and password.

3. Click OK to map the selected file to the target. A message appears to show
virtual media is connected.

BREE REEQ V00 =

»  To disconnect ISO:

e Choose Virtual Media > Disconnect ISO. Or, click the matching icon in the
toolbar.

Virtual Media ~ \ v i

Files and Folders

@ Disconnect I1ISO

ShEE REEQ :

Audio Menu
The Audio menu contains audio connection and settings.

Audio quality deteriorates if multiple target connections are open. To preserve
quality, limit to four target connections open on HKC when an audio session is
running.

Note: IE does not support audio. The menu will appear grayed out.
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Connect Audio

The Connect Audio command connects your playback device, selects audio
format and gives an option to mount the selected playback device
automatically when you connect to the target.

HKC connects the client PC's default audio playback device. To use a different
device, it must be set as default in the client OS.

Supported audio sample rates differ depending on your connecting device and
browser:

e On Windows Edge - 11,025, 22,050 and 44,100 Hz

e On Mac/Windows and Linux Chrome - 11,025, 22,050 and 44,100 Hz

e On Mac/Windows and Linux Firefox only 44.1 kHz available

e  On Mac Safari - only 44.1 kHz available

e OnIOS devices - only 44.1 kHz available

Note: For best quality, limit the number of audio sessions to a maximum of four
KVM sessions.

»  To connect audio:

1. Choose Audio > Connect Audio, or click the matching icon in the toolbar.

File USB Profile ~ Input ~ Video ~ View ~ Tools ~ Virtual Media ~ T T
= h @ =R lad @ =Dy Q)) = =) Connect Audio ="

/ Audio Settings

2. Inthe Connect Audio Device dialog, select the Connect Playback Device
checkbox.

Connect Audio Device

Connect Playback Device

Format:

[ Mount selected playback device automatically on connection to target

& =T
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3. Select the Format.

stereo, 16hit, 44.100 Hz
mono, 16bit, 44.100 Hz
stereo, 16bit, 22.050 Hz
mono, 16bit, 22.050 Hz
stereo, 16hit, 11.025 Hz
mono, 16bit, 11.025 Hz

4. Select the "Mount selected playback device automatically on connection to
target" checkbox to enable the option. This setting will connect audio
automatically the next time you connect to the target.

5. Click OK. A success message appears.

Audio connection
established

>  To disconnect audio:

1. Choose Audio > Disconnect Audio, or click the matching icon in the toolbar.

Audio Settings

The Audio Settings option is enabled when audio is connected. Use the Audio
Settings to set the buffer and volume.

Increasing the buffer size improves the audio quality but may impact the
delivery speed.

The maximum available buffer size is 400 milliseconds since anything higher
than that greatly impacts audio quality.

P> To configure audio settings:

1. Choose Audio > Audio Settings while Audio is connected.
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2. Set the Buffer and Volume using the arrows or sliders.

Audio Device Settings

Buffer Sizes (ms)

Playback 120 40 ol 400
Advanced
Volume 100 0 100

E B3

3. Click OK.

Power Control Menu

You can power on, power off, and power cycle a target through the outlet it is
connected to.

Access the target, and then select a power control option from the Power
Control menu.

The menu option is disabled if you do not have permission for power control,
and when outlets are not associated with the port.

Using HKC on Apple iOS Devices

KX 11l supports remote access to targets from Apple mobile devices with iOS
10.0 or higher, using a mobile version of HKC. Due to Apple iOS limitations, you
may notice some differences in operation. See Limitations on Apple iOS
Devices (on page 119).
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Install Certificate on Apple iOS Device

You must install a CA-signed certificate on your Apple iOS device before you
can connect to KX lll. Access is prevented if only the default certificate is
present. Depending on your browser, you may see an error such as "This
Connection is Not Private".

When creating certificates, the certificate Common name should match the IP
address/Hostname used to connect to the device.

Install both the KX Il certificate and the CA certificate used to sign the KX III
certificate.

Note: If you have issues launching connections from 10S devices, check that the
certificate meets Apple requirements:
https://support.apple.com/en-us/HT210176

P> Toinstall the certificate on an 10S device:

1. Email the certificate file to an email account that can be opened on the iOS
device. Open the email and tap the attachment.

247 Wi TEW )
{0 2 Messages N
User Name m

To:

See More

2. The certificate downloads as a "profile" that you have to install. You can
have only one profile ready to install at a time. For example, if you
download a profile and don't install it, and then download a second profile,
only the second profile is available to be installed. If a profile is not
installed within 8 minutes of downloading it, it is automatically deleted.

To install the profile, go to Settings, then tap Profile Downloaded.

4. Tap install, then follow prompts as presented to verify and Install.
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2:47

wl LTE®
- Mail

Cancel Install Profile Install

ﬁ ystomtest

Signed by systemtest
Not Verified

Contains Certificate

More Details

Install

Cancel

2:48 wiTEm
- Mail
Cancel Warning Install

UNMANAGED ROOT CERTIFICATE

Installing the certificate “systemtest” will add
it to the list of trusted certificates on your
iPhone. This certificate will not be trusted for
websites until you enable it in Certificate Trust
Settings.

UNVERIFIED PROFILE

The authenticity of “systemtest” cannot
be verified.

5. When complete the certificate is marked Verified. Tap Done.
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2:48

A Mail

a LTER

Profile Installed Done

@ systemtest

signed by systemtest
ied v

“ontains  Certificate

More Details

6. To enable the certificate, go to Settings > General > About, then scroll all
the way down. Tap Certificate Trust Settings.
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2:50

£ General
Available
Version
Carrier

Model

Serial Number
Wi-Fi Address
Bluetooth

IMEI

ICCID

Modem Firmware

SEID

Legal

Certificate Trust Settings

TR

About

31.88 GB

11.4.1 (16G77)

AT&T 32.01

QAK2ZLL/A

N5JDJC

6470 B:81:9D
64:78:33:3B:01:9E
486209 890050 2
14104270885178490

1.84.80

—R

2:51 wil = 0
{ About  Certificate Trust Settings
Trust Store Version 2018040200

Some certificate settings are enforced by
“Management Profile

ENABLE FULL TRUST FOR ROQT CERTIFICATES

Microsoft Intune Root Certification A.
Microsoft Intune Root Certification A...
systemtest

SC Online_Issuing /

SC_Online_lssuing L/

Learn more about trusted certificates

7. Tap the certificate that was installed earlier to enable. A warning appears.
Tap Continue to enable. The certificate slider displays green for enabled.
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2:51 il T W
{ About Certificate Trust Settings
Trust Store Version 2018040200

Some certificate settings are enforced by
“Management Profile”

ENABLE FULL TRUST FOR ROOT CERTIFICATES

Microsaoft Intune Root Certification A...

Microsoft Intune Root Certification A...

Root Certificate

systemtest

Warning: enabling this certificate for SC Online |SSUH’1_(]

websites will allow third parties to view

any private data sent to websites.

Cancel Continue

Touch Mouse Functions

SC_Online_lssuing

LS
©

Learn more about trusted certificates

Use the touchscreen equivalent for each mouse function. Some touch settings
are configurable. See Tools Menu (on page 103).

Single Finger Touch

touch down - move - release

short tap

double short tap

short tap - touch down - hold for 250ms

short tap - touch down - move - release

Two Finger Touch

touch down - move - release

Mouse Equivalent

move mouse pointer

left click

left double-click

mouse equivalent of Right Click"

hold down left mouse button and
move, as in drag and drop or select

Mouse Equivalent

move screen
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Keyboard Access on Mobile

Keyboard access to the target is through a virtual keyboard, available on the
toolbar. For all other actions requiring keyboard input, the 10S popup keyboard
displays automatically.

Manage HKC iOS Client Keyboard Macros

The HKCiOS client includes a list of default macros. You can create additional
macros using the HKC Macro Editor or import macros from a file. See Macro
Editor (on page 86) and Import and Export Macros (on page 90).

Note: To import macros when using an Apple iOS device, first export the file
from HKC using a PC client. Add the file to a Cloud location to access from the
10S device for import.

Tools Menu

The Tools menu contains options for HKC target connection settings.

P Client Settings:

e Choose Tools > Client Settings to access the Disable Menu in Fullscreen
option.

e When selected, the menu bar will not be available in fullscreen mode. This
setting is specific to the client, so it must be set for each client device and
each browser used for access.

Client Settings

Disable Menu in Fullscreen

.
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P> Launch Settings:
e Choose Tools > Launch settings to access Client Launch Settings options.

e This menus allows selection of Enable Scale Video, Enable Toolbar, Enable
Statusbar and Mouse Cursor at target launch.

r = — a

Client Launch Settings

Enable Scale Video
Enable Toolbar
Enable Statusbar

Mouse Cursor default

default

dot

TR, _

P> Touch Settings - enabled for iOS clients:

e Tap Tools > Touch Settings to access the Client Touch Settings. Customize
the Touch Input and Gesture Scrolling settings for your mobile device.

Client Touch Settings

Touch Input

Double Click Time (ms)
250 O 750

Mouse Click Hold Time (ms)
250 O 750

DUse Left Hand Mouse
Gesture Scrolling
(JEnable Inverted Scroll x-Axis

(JEnable Inverted Scroll y-Axis
¥

= Double Click Time: Time between two touch taps for the equivalent of
a mouse double click.

=  Mouse Click Hold Time: Time to hold after touch down for the
equivalent of a mouse right click.
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= Use Left Hand Mouse: Enable if the target OS's primary mouse button
is set to Right.

= Enable Inverted Scroll x-Axis: If selected, two-finger movement to the
right moves the screen to the left instead of the default right.

= Enable Inverted Scroll y-Axis: If selected, two-finger movement up
moves the screen down instead of the default up.
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Limitations on Apple iOS Devices

Mobile access with iOS devices is supported for several Raritan products. Not
all limitations apply to all products. Differences are noted.

e Target connections are closed after about one minute if the browser is in
background, or if your iOS device enters Auto Lock mode

e Unable to create Macros for some special characters: F1-F24, ESC, Control,
Alt, OS Meta keys and others. A selection of commonly used keys are
available in the default Macro list. These keys can be edited. Additional
keys such as F1-24 and arrows can be added using a Macro Import.

e In Safari on iOS, must refresh the connection to device after a KVM or
Serial target launch in order to access menu options or serial targets. Not
needed in Chrome on iOS.

e iOS does not support auto connect audio device to targets.

e  On Ubuntu 14.04 target, no response to mouse click and hold on target
items to simulate right clicking.

e Dual Target connection issues: Both target windows have to be closed
separately. Only 1 port of a Dual target opened from Safari on iOS 11.x
devices. (Dual targets not supported on KX4-101).

e  Options "FullScreen" and "Resize window to fit screen" are not
enabled/available on iOS.

e KB locale from the Client Virtual Keyboard must match input locale of
device and OS locale of the target.

e iOS client target window does not have scrollbars. Unscaled video can be
scrolled horizontally/vertically by sliding two fingers left/right or up/down.
See Touch Mouse Functions (on page 115).

e  On Safari, users are prompted to save passwords when switching from a
target with a server VM connection to another target. These prompts can
be turned off by unchecking the box "Usernames and passwords" in
Safari > Preferences > AutoFill.

e  On Safari, the onscreen keyboard includes word forecast. Selecting a
forecast word adds a space at the end. For example, at login screen,
selecting "admin" enters "admin ". Similar behavior occurs for VM File
server Username and other areas.

e Cannot move menu option panels such as Connection Info.
e i0OS On-Screen keyboard is displayed from all mouse clicks on the HTML

admin page if keyboard "Go" is tapped to save setting changes instead of
tapping the Save button.

e For DSAM targets opened from iOS clients, every time a menu item is
selected and closed the on-screen keyboard is displayed.

e VKC login occurs when refreshing login page after a reboot. This causes
target connections to fail. To restore mobile HKC login, logout and enter
the KX III IP or hostname again. Issue is applicable to both iOS and PC
Clients.
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e The VM Files and Folders Option from the Virtual Media menu is disabled
as not possible to drag and drop files to panel.

e Not all Accented letters are processed from iOS client.

e  Macro files exported from iOS devices using Safari are automatically given
the name "unknown" and need to be renamed with an xml extension to be
imported to another client.

e  Macro file export from Chrome on iOS devices is not possible due to issues
with downloading data.

e  Only characters supported by target will be processed. There is no
response from iOS characters such as ¥, § and ... that are found on iPad
keyboards.

e With the onscreen keyboard, selecting ' character or "Return" key, brings
keyboard display back to first in list.

e On default 10S client settings, characters ' and " are not processed from
macro or send text to target options. The work around is to turn smart
punctuation off
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Serial Access With Dominion Serial Access
Module

uejey m————
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Connecting a KX Ill and a Dominion Serial Access Module (DSAM) provides
access to devices such as LAN switches and routers that have a RS-232 serial
port.

The DSAM is a 2- or 4 port serial module that derives power from the KX IlI.

Connect a maximum of 2 DSAM modules to the KX 11l using USB cables. DSAM
can be mounted in a OU configuration.

In This Chapter

CONNECE DSAM ...t 121
View DSAM Serial POMES .....oiiuiiiiiieiiiieiieese ettt 125
Configure DSAM Serial POITS ..ocvviveiiiiee ettt 125
Serial POrt KEYWOIrd LiST.....uueeeeciiieiiiiee ettt e e e e 128
Upgrade DSAM FIrMWAIrE ....cccuviiiieeeeeeciitieee e e eecire e e e e e e aarae e e e e e e e saaraneeeeeeena 129
Supported CLI COMMANAS ....vviiieiiiiiiiiiiieee et ee s e e e e s eirrr e e e e e e s enannees 130
Browser Tips FOr HSC ...ouvuiiieiieie ettt et 135
Connect to DSAM Serial Targets in Port Access Page......ccccoeeuvvvveeeeieiccivnenennnn. 135
Connect to DSAM Serial Target with URL Direct Port ACCess .......c.ceceevvveernnenn. 136
Connect to DSAM Serial Target via SSH ......oooviiiiiiiiiee e 137
HTML Serial Console (HSC) Help ..uuiiiiiieeecee et 137

Connect DSAM

Raritan.

Abrand of Olegrand’

1. Connect the DSAM unit's USB cable to the TOP USB port on the rear of KX
lll device. Additional DSAM units can be added at any other USB port.
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2. Connect the serial devices to the serial ports on the DSAM unit.

Serial Devices Serial Devices
Cats
Connections
1 e |
DSAM-4
USB
Connections
LAN g
At-the-Rack

Serial over IP

DSAM LED Operation
The DSAM unit has one LED for status, and 2 LEDs on each port.

Raritan DSAM-4

)

@  status 1 2 3 & ()

g—"ﬁ’@‘f’”ﬁ‘ﬁ“ﬁ‘
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P> Status LED:

The Status LED is labeled on the unit front. Light is on back. The Status LED
gives information at bootup and upgrade.

e Green LED - Slow blink: DSAM booting up but not controlled by KX III.
e  Blue LED - Slow blink: DSAM controlled by KX III.
e  Blue LED - Fast blink: Firmware upgrade in progress.

> USB Port LEDs:
Each USB port has a left Green LED and a right Yellow LED.

e Green LED: Port is set as DCE
e Yellow LED: Port is set as DTE
e  LEDs off: Port is set as AUTO
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Supported USB Device Combinations

Each USB device draws from a fixed pool of USB resources. There are limits on
the number of USB devices that can be connected to the KX Il at the same
time.

The following device combinations are supported for all KX Il hardware
versions.

If you have the latest 2020-released KX Il hardware, which have a hardware
revision number beginning with A or higher, the USB-combination in the last
column is supported. Older hardware revision numbers begin with 0-9. To
check your hardware version: Go to Maintenance > Device Information >
Hardware Revision number.

4-Port DSAM X X X
4-Port DSAM X X X X
2-Port DSAM X X X

2-Port DSAM

Keyboard and X X X X
Mouse

SmartCard X X X
Wireless Modem X X X X
DSAM Ports 8 6 6 4 2 8
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View DSAM Serial Ports

When a DSAM unit is connected to the KX Ill, a new tab is available in the Ports
page. The View by Serial tab shows all connected serial ports.

|

41
42
43
44

v DSAM4
DSAM4 Port 1
DSAM4 Port 2
DSAM4 Port 3
DSA.Mai Port4

Back Top

DSAM
DCE

AUTO
AUTO
AUTO

Status Availability
up

up idle

down idle

down idle

down idle

?

>  To view DSAM serial ports:

In the Port Access page, click the View By Serial tab.

32 Rows per Page

e Ports are listed by physical USB position on the DSAM unit.
e USB Port column indicates which KX Il USB port DSAM is plugged into.

e Type column indicates port's DTE/DCE setting.

Configure DSAM Serial Ports

Raritan.
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The serial port configuration options are available when a DSAM unit is

connected.

P> To configure DSAM serial ports:

1. Choose Device Settings > Serial Port Configuration.

2. Click the Port Name for the port you want to configure.

| Home = Device Seftings = Serial Port Configuration I

41
42
43
44

Serial Port Configuration

DSANM4 Port 1 —pet

DSAM4 Port 2 AUTO
DSAM4 Port 3 AUTO
DSAM4 Port 4 AUTO

3. The Port Type is set to Serial only.

4. Enter a meaningful name for the serial target or leave the default name.

Type:
Serial

Name:
DSAM4 Port 1
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Power Association

If an outlet is connected to the same server that the port is connected to, a
power association can be made with the target device.

A port can have up to four associated outlets, and you can associate a different
rack PDU (power strip) with each. From this page, you can define those

associations so that you can power on, power off, and power cycle the server
from the Port Access page.

To use this feature, you need Raritan remote rack PDU(s).

1. Select the Power Strip Name and associate a name with each of the power
strip's outlets by selecting from the Outlet Name drop-down.

2. Click OK. A confirmation message is displayed.

Power Strip Name

Powerstrip -

Powerstrip

Powerstrip

Powerstrip

Serial Port Settings

~
~
e

Qutlet Name

MNew outlet 1 .

Curtiet 2

s

Qurtlet 3

Qutiet 4

~
N

Configure the remaining port settings.

1. Select the terminal emulation type from the drop-down menu in the
Emulation field. This is the terminal emulation mode used to match the
serial targets connected to the ports.

VT100
VT220
VT320
ANSI

2. Set Encoding if you want to always use a specific character encoding for
this port. Encoding overrides the global setting for the port to whatever

value you set.
DEFAULT
US-ASCII
ISO8859-1
ISO8859-15

UTF-8
Shift-JIS
EUC-JP
EUC-CN
EUC-KR
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In the Equipment Type field, indicate whether you want the KX Il to
automatically detect a physical connection to the target. The default is
Auto Detection.

Force DTE causes KX Il to act as a piece of data terminal detection
equipment to detect targets connected to it.

Force DCE causes KX Ill to act as a piece of data communications
equipment to detect equipment connected to it.

Note: If the target has the ability to autodetect either DTE or DCE, you must
select either Force DTE or Force DCE for the port. KX Ill does not support
autodetection of both DCE and DTE on the same port.

Select the value of Bits Per Second (BPS) from the BPS drop-down menu.

= BPS options: 1200, 1800, 2400, 4800, 9600, 19200, 38400, 57600,
115200, 230400

Select the Parity/Bits from the Parity Bits drop-down menu.
Select the Flow Control from the Flow Control drop-down menu.
Select the Stop Bits from the Stop Bits drop-down menu.

If you need to configure the delay between when individual characters are
sent via the port, enter the time in milliseconds in the Char Delay field.

To configure the delay between when lines of text are sent via the port,
enter it in the Line Delay field.

Configure the sendbreak duration by entering the send break time in the
Send Break Duration field. The send break is configurable from Oms -
1000ms.

Select an option to allow single or multiple writers on a port at one time in
the Multiple Writers field.

Select Always Active if you want to log activities coming into a port even if
no user is connected.

The default option is to not maintain port access without a connected user,
which means ignore data coming into a port when no user is connected.

This option is for port data logs.

Note: When no users are logged into a port session, port traffic, by default,
is discarded .

If you do not want messages displayed to users connecting to KX Ill via
Direct Port Access, select the Suppress Message checkbox.

Select the Escape Mode.

The escape sequence affects only the CLI. When entering the escape mode,
the user is given a menu of commands that can be performed (for example,
gethistory, power commands, and so on), a command to return to the port
session, and a command to exit the port connection.

The default is None.

Change as follows:
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= Select control from the drop-down menu in the Escape Mode field.
15. Type the character in the Escape Character field. The default for the KX 1l
is ] (closed bracket).

Raritan recommends that you do not use [ or Ctrl-[. Either of these may
cause unintended commands, such as invoking the Escape Command
unintentionally. This key sequence is also triggered by the arrow keys on
the keyboard.

16. Type a command in the Exit Command field, such as 1ogout.

This is the command that is sent to your system when a user with write
permission disconnects from the port.

The main function of this command is to ensure that the user's session on
the target machine is closed; however, it is not imperative to have an Exit
command configured on a port.

17. Click OK.

Apply Settings to Other Ports
Once finished, you can apply the same port settings to other ports.

1. Select the ports from the Apply Serial Port Settings To Other Ports section
of the page.
2. Click OK to apply the port configuration settings.

Serial Port Keyword List

128

Port keywords work as a filter. If a keyword is detected, a notification is sent to
the following:

e Audit Log

e Syslog Server (if configured)

e  SNMP (if configured)

e  SMTP (if configured)

This feature is useful for notifying administrators if a particular event occurs on
a port.

For keywords to trigger when no users are connected to a port, "Always Active'
must be selected on the port's Port Configuration page.

A list of existing port keywords is displayed on the Port Configuration page as
well.

»  To configure serial port keywords:
Choose Device Settings > Serial Port Keyword List. The Serial Port Keyword
List page opens.
Click Add at the bottom of list on the page. The Keyword page opens.
Type a keyword in the Keyword field.
Select the Port(s) you want to associate with that keyword.
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5. Click Add to add them to the Selected box.

Click OK.

Upgrade DSAM Firmware

DSAM firmware is upgraded automatically during KX Il device firmware
upgrades if a new DSAM version is detected in the device firmware. You can
also upgrade your DSAM firmware manually.

P> To upgrade the DSAM firmware manually:
Choose Maintenance > DSAM Firmware Upgrade.

2. Select the checkboxes for the DSAM units you want to upgrade to the
Upgrade DSAM Version listed.

Click Upgrade, then click OK to confirm. A progress message appears.

When firmware upgrade completes, a success message appears.
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Supported CLI Commands

Port Connect Commands

Connect to a serial port using port number or port name. Use double quotes
around port names that contain space symbols. For example: "DSAM Port 1".

admin > connect <port number>

admin > connect <port name>

»  Port number example:

admin > connect 1.1

P> Port name example:

admin > connect "DSAM Port 1"

Port Sub-Menu Commands

The port sub-menu can be reached using the escape key sequence.

Clear history buffer for this port.

admin > [portname] > clearhistory

Close this target connection. When a target is disconnected, the appropriate
disconnect message appears.

admin > [portname] > close, quit, g

Display the history buffer for this port.

admin > [portname] > gethistory

Get write access for the port.

admin > [portname] > getwrite

Return to the target session.

admin > [portname] > return

Send a break to the connected target.

admin > [portname] > sendbreak

Lock write access to this port.

admin > [portname] > writelock

Unlock write access to this port.

admin > [portname] > writeunlock

Query Power status of this port.
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admin > [portname] > powerstatus

Toggle Power On/Off of this port.

admin > [portname] > powertoggle

Power on the target.

admin > [portname] > poweron

Power off the target.

admin > [portname] > poweroff

Power cycle the target.

admin > [portname] > powercycle

Configure Ports Commands

Enter admin > to access the menu.

Description Parameters

List accessible ports NA

Enter admin > config > port to accessthe menu.

Description Parameters

= port <number | range | *> - Single port or
range of ports (1-n or 1,3,4 or * for all ports)
® name <port name> - Port name

= bps <1200 | 1800 | 2400 | 4800 | 9600 | 19200
| 38400 | 57600 | 115200 | 230400> - Port
speed in bits-per-second

= parity <none|even|odd> - Port parity type

= flowcontrol <none|hw|sw> - Port flowcontrol
type hw = hardware flow control sw =X on/X
off)

= eqtype <auto|dte|dce> - Equipment type
(auto=>AUTO Detection, dte=>Force DTE,
dce=>Force DCE)

= Note: If the target has the ability to autodetect
either DTE or DCE, you must select either Force
DTE or Force DCE for the port. KX Ill does not
support autodetection of both DCE and DTE on
the same port.

= escapemode <none|control> - Use Ctrl-key
(escapemode=control) or single key
(escapemode=none) as escape sequence; for

131




Appendix A: Serial Access With Dominion Serial Access Module

Command Description Parameters
example, Ctrl- =>escapemode=control,
escapechar= escapechar char-Escape
character

= Raritan recommends that you do not use or
Ctrl- as the Escape command. Either of these
may cause unintended commands, such as
opening a menu, instead of invoking the Escape
Command.

= emulation <vt100 | vt220 | vt320 | ansi> -
Target Emulation type

= sendbreak <duration>- Duration of the
sendbreak signal in milliseconds.

= exitstring <cmd #delay; > - Execute exit string
when port session closes, for example, config
port 1 exitstring logout (execute logout on exit)
config port 1 exitstring #0 (disable exit string for
the port). The delay is the amount of time to
wait after writing the command to the target.
Number in seconds up to 60.

= alwaysactive <true | false> - Determine
whether data coming into a port is logged, for
example, config port 1 alwaysactive true
(always log activities coming into a port even if
no user is connected) config port 1 alwaysactive
false (ignore data coming into a port when no
user is connected)

= suppress - Determine whether none or all
messages should be displayed during a DPA
connection, such as "Authentication successful"

= encoding - Target Encoding type
(DEFAULT | US-ASCII|1SO-8859-1|1SO-8859-15| U
TF-8|Shift-JIS|EUC-JP| EUC-CN | EUC-KR)

= multiwrite - Port set in Multiple Writer Mode.

= chardelay delay - Delay inserted between
writing characters (0-9999ms)

= |inedelay delay - Delay inserted between
writing lines (0-9999ms)

= stopbits - Number of bits used to signal the end
of a character (usually 1) (1/2)

= stopbits <1/2> -Number of bits used to signal
the end of a character

= chardelay - Delay inserted between characters
(0-9999) in ms
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Command Description Parameters

= Jinedelay - Delay inserted between lines
(0-9999) in ms

= escapechar - Escape character

= encoding -
<DEFAULT/US-ASCII/ISO-8859-1/1SO-8859-15/U
TF-8/Shift-JIS/EUC-JP/EUC-CN/EUC-KR> - Target
encoding type

=  multiwrite <true/false> - Port set in multiple
writer mode

= suppress <true/false> - Suppress SX messages
when connecting to this target(true/false)

= sendbreak - Duration of sendbreak signal in ms

Command Line Interface Shortcuts

Press the Up arrow key to display the last entry.
Press Backspace to delete the last character typed.

Press Ctrl + C to terminate a command or cancel a command if you typed
the wrong parameters.

Press Enter on your keyboard to execute the command.

Press Tab on your keyboard to complete a command. Tab also completes
parameters and values (if the value is part of an enumerated set).

Command Line Interface High-Level Commands

The CLI is menu based. Some commands move to a menu with a different
command set.

The following common commands can be used at all levels of the command
line interface (CLI):
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top - Return to the top level of the CLI hierarchy, or the username
prompt.

history - Displays the last 200 commands the user entered into the KX
111 CLI.

logout - Logs the user out of the current session.
quit - Moves the user back one level in the CLI hierarchy.

help - Displays an overview of the CLI syntax.
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Supported Escape Key Characters
The default escape key is CTRL ]

The following characters are supported for customized escape keys.

o A7
e a3z
. ]
o {}
o \
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Browser Tips for HSC

Some browsers have limitations that affect HSC.

In Chrome, disable the background throttling to prevent background tabs
from disconnecting after a certain amount of time. Go to chrome://flags,
then search for "throttle". Set "Throttle Javascript timers in backgound"
and "Calculate window occlusion on Windows" to "Disabled". Restart
chrome to apply settings.

Browser option to select certificate for authentication displayed on Edge
and Chrome after session is idle for about 5 minutes, due to internal
browser SSL caching and timeouts. If certificate is selected promptly,
reconnection is successful. With longer idle times, authentication is not
successful, and the browser should be restarted to reconnect. Issue is not
observed in Firefox or IE 11.

Internet Explorer has an internal limitation on the number of websockets
that are allowed to be created to a single server (6). This can be changed
by modifying a registry variable as shown here :
https://msdn.microsoft.com/en-us/library/ee330736(v=vs.85).aspx#webso
cket_maxconn.

Internet Explorer 11,and Safari have a limitation when connecting to IPv6
devices. Using the numerical URL will not work when it attempts to
establish a websocket connection. In these browsers, use the device
hostname or literal IPv6 as UNC to connect to the SX II. See
https://en.wikipedia.org/wiki/IPv6_address#Literal_IPv6_addresses_in_UN
C_path_names

When using HSC in 10S Safari, the keyboard may not appear in some pages
if the "request desktop website" setting is enabled. To change the setting,
go to Settings > Safari >Request Desktop Website, then make sure All
Websites is not selected, and the device address is not selected. You can
also set this per address by clicking the "aA" in Safari's URL pane when
connected to the HSC port, then select "Website Settings" and make sure
that "Request Desktop Website" is not selected.

Connect to DSAM Serial Targets in Port Access Page
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P> To connect to DSAM serial targets:

1.

In the Port Access page, click the View By Serial tab to view the serial
targets.
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2. Click the port name you want to connect to. Click Connect.

Availability

4 v Front DSAM up
4.1 DCE up idle
42 DSAM4 Po AUTO down idle
43 D3AM4 Port 3 AUTD down idle
4.4 DSAM4 Port 4 AUTO down idle
32 Rows per Page | set

3. The HTML Serial Console (HSC) window opens. See HTML Serial Console
(HSC) Help (on page 137)

Raritan HTML Serial Console : DSAM3 ... = O X

A | https://192.168.59.100/hsc_js/hsc_js.html?port=3018&Ses

EMULATOR EDIT TOOLS POWER HELP

Successfully Connected!

4. To exit the serial port, hit the hot-key. Default hot key is
Scrolllock-Scrollock.

Connect to DSAM Serial Target with URL Direct Port Access
1. Choose Security > KVM Security, then select the Enable Direct Port Access
via URL checkbox.
2. To connect with direct port access, type the URL:

"https://<IP Address>/dpa.asp?port=<serial port
number>&username=<user name>&password=<password>"

Example:

https://192.168.51.101/dpa.asp?port=1.4&username=admin&password=r
aritan0

136
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3. HTML Serial Client (HSC) launches and connects to the serial target.

Connect to DSAM Serial Target via SSH
1. Choose Device Settings > Device Services, then select the Enable SSH
checkbox.
2. Launch SSH client in client PC to connect to KX IIl.
After login, user will enter CLI interface.

4. Type command "connect <serial port number>", or type command
"connect <name of serial port>".

Example-1: connect 4.1

Example-2: connect "DSAM4 Port1"

If successful, serial target is accessed.

6. To exit serial target, type escape-key-sequence, default is Ctrl-], then enter
port sub-menu CLI interface.

7. Type "quit", then enter main CLI interface.

HTML Serial Console (HSC) Help

You can connect to serial targets using HSC. HSC is supported with several
Raritan products that offer serial connections. Not all products support all HSC
features. Differences are noted.

Raritan HTML Serial Console : DSAM3 ... = O K

A https://192.168.59.100/hsc_js/hsc_js.html?port=301&Ses

EMULATOR EDIT TOOLS POWER HELP

Successfully Connected!
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HSC Functions

Emulator

IMPORTANT: HSC sessions are affected by the KX lll Idle Timeout.

If you have not changed the KX Il Idle Timeout setting from the default, your
session could be closed automatically if it exceeds the Idle Timeout period.

Change the default Idle Timeout setting and then launch the HSC. See Login
Limitations for details on changing the Idle Timeout setting.

Access Emulator Options

1. Select the Emulator drop-down menu to display a list of options.

EMULATOR EDIT TOOLS POWER HELP
Settings b !
Get History

Clear History

Get Write Lock
Write Unlock
Send Break
Reset Port

Connected Users...

Settings
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Note:

KX3 administrators can set Terminal emulation settings in Setup > Serial Port
Configuration.

KX4-101 administrators can set terminal emulation settings in DSAM Serial
Ports > Settings.

SX2 administrators can set terminal emulation settings in Device Settings > Port
Configuration.

1. Choose Emulator > Settings. The Terminal Properties dialog displays the
default settings.

Terminal Properties

Columns: |80 Rows: 25 |
Foreground: |j' Background: - v
Font size: [11 Scrollback: 'W\
Encoding: [ut-8  v|Language: [English v

Backspace Sends: |Delete v |

OK Cancel Reset

2. Set the terminal size by selecting the number of Columns and Rows.
Default is 80 by 25.

Set the Foreground and Background colors. Default is white on black.
Set the Font size. Default is 11.

Set the Scrollback number to indicate the number of lines available for
scrolling.

6. Choose one of the following from the Encoding drop-down menu:
=  UTF-8

= 8-bit ascii
= |SO-8859-1
= |SO-8859-15
= Shift-JIS
= EUC-JP
=  EUC-KR
7. Choose one of the following from the Language drop-down menu:
= English
= Japanese
= Korean
= Chinese

= Bulgarian
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8. The Backspace Sends default is ASCII DEL, or you can choose Control-H
from the Backspace Sends drop-down menu.

9. Click OK to save. If you changed the Language setting, the HSC changes to
that language when the Display Settings window is closed.

The emulator settings are saved on a per port basis in the browser used for
HSC, so make sure your browser is not set to delete history on exit.

Get History

History information can be useful when debugging, troubleshooting, or
administering a target device. The Get History feature:

e Allows you to view the recent history of console sessions by displaying the
console messages to and from the target device.

e Displays up to 512KB of recent console message history. This allows a user
to see target device events over time.

When the size limit is reached, the text wraps, overwriting the oldest data with
the newest.

Notes: History data is displayed only to the user who requested the history.

To view the Session History, choose Emulator > Get History.

Clear History

= To clear the history, choose Emulator > Clear History.

Get Write Access

Only users with permissions to the port get Write Access. The user with Write
Access can send commands to the target device. Write Access can be
transferred among users working in the HSC via the Get Write Access
command.

To enable Write Access, choose Emulator > Click Get Write Access.
e  You now have Write Access to the target device.
e  When another user assumes Write Access from you:
= The HSC displays a red block icon before Write Access in the status bar.

= A message appears to the user who currently has Write Access,
alerting that user that another user has taken over access to the
console.

Get Write Lock

Write lock prevents other users from taking the write access while you are
using it.

1. To get write lock, choose Emulator > Get Write Lock.

2. If Get Write Lock is not available, a request rejected message appears.

Write Unlock
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To get Write Unlock, choose Emulator > Write Unlock.

Send Break

Some target systems such as Sun Solaris servers require the transmission of a
null character (Break) to generate the OK prompt. This is equivalent to issuing a
STOP-A from the Sun keyboard.

Only users with Write Access privileges can send a break.
To send an intentional “break” to a Sun Solaris server:

1. Verify that you have Write Access. If not, follow the instructions in the
previous section to obtain write access.

2. Choose Emulator > Send Break. A Send Break Ack (Acknowledgement)
message appears.

3. Click OK.

Reset Port

Reset Port resets the physical serial port on the SX2 and re-initializes it to the
configured values regarding bps/bits, and so on.

Connected Users

The Connected Users command allows you to view a list of other users who are
currently connected on the same port.

1. Choose Emulator > Connected Users.

User List

* admin

System: Auto Naming

oK

2. Astar appears in the Write column for the User who has Write Access to
the console.

Exit

1. Choose Emulator > Exit to close the HSC.
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Copy and Paste and Copy All

Data on the current visible page can be selected for copying. Copy and Paste
are accessible in the HSC by right click in the terminal window. Select Copy or
Paste in the context menu that appears.

To copy all text, use the Copy All option in the Edit menu.

If you need to paste a large amount of data, it is better to save the data in a file
and use the Send a Text File function. Pasting a large amount of data in a
browser windows can cause the browser to hang as it processes the data. See
Send Text File (on page 142).

When pasting data to a port, the end of a line is sent as a carriage return.
The Cut option on the right-click menu is disabled.

Do not use the Delete option that appears in the right-click menu of IE and
some versions of Firefox. This Delete option will remove display lines entirely
from the emulator window.

>  Browser-specific behaviors

When copying from IE or Edge browsers, there are no end of line characters in
the copied data. The pasted data appears to be all in one line and contains
many spaces. When pasting back into a HSC window, the data may appear to
be misaligned, but the data is complete.

Send Text File

1. Select Edit> Send Text File.
2. Inthe Send Text File dialog, click Browse to find the text file.
3. Click OK.
= When you click OK, the selected file sends directly to the port.
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If there is currently no target connected, nothing is visible on the
screen.

A Not secure | htps//192.168,59.182/hsc_js/hsc_jshtmiZport=1

EMULATOR EDIT TOOLS POWER HELP

Send Text File

| Choose File | No file chosen

OK Cancel

E Open X
« v A > ThisPC » Downloads » SendText v
Organize v New folder + T 9
[ This PC > Name Date modified
) 30 Objects SendTexttxt 8/18/2022 &d1 AM Text Documen
I Desktop
% Documents
& Downloads A 5
File name: 5‘"‘”5“& v Al Files (*.) v
Coc
P> Note, if you are using a Mac® and/or Safari’, do the following in order to
use this feature:
1. In Safari, select Preferences.
2. Under the Security tab, select "Manage Website Settings"
3. Click on the KX Il website.
4. Select "Run in unsafe mode" from the drop-down box.
5. Restart Safari.

Tools: Start and Stop Logging

The Tools menu contains options for creating a data history file and
downloading it.

1. Choose Tools > Start Logging to start the storage of serial port data in
memory.
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2. Click Stop Logging to save the log file. A pop up message appears with a
download link. Click to download the memory buffer into a text file.

EMULATOR EDIT TOOLS POWER HELP

Successfully Connected!

Save Log File

Click Here to Download

OK

Write Access Encoding: utf-8  Term Size: 80 x 25

Power Status

Power Status in HSC shows the status of the outlet the target is plugged into.
1. Choose Power > Power Status.

2. The Notification dialog shows the status of the outlet as ON or OFF.
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Status may also show no associated outlet, or no power permission to the
port.

Notification

192.168.61.142(1) Power
Status : Off

OK

E' Notification P

Port has no associated
outlets, or user does not
have power permission on
this port.

Power on a Target

Use this option to power on a target from HSC.

This option is visible only when there are one or more power associations to
the target, and when you have permission to manage the target's power.

1. Select Power> Power On.

145

Raritan.

Abrand of O legrand



Appendix A: Serial Access With Dominion Serial Access Module

2. Click OK in the success message.

Notification

Power operation succeeded.

ok

Power Off a Target

Use this option to power off a target from HSC.

This option is visible only when there are one or more power associations to
the target, and when you have permission to manage the target's power.

1. Select Power> Power Off.

2. Click OK in the success message.

Notification

Power operation succeeded.

oK

Power Cycle a Target

Power cycling allows you to turn a target off and then back on through the
outlet it is plugged into.
This option is visible only when -
e there are one or more power associations to the target
e thetargetis already powered on (the port status us Up)
e you have permission to manage the target's power
Choose Power> Power Cycle.

2. Click OKin the success message.
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Browser Tips for HSC

Some browsers have limitations that affect HSC.

In Chrome, disable the background throttling to prevent background tabs
from disconnecting after a certain amount of time. Go to chrome://flags,
then search for "throttle". Set "Throttle Javascript timers in backgound"
and "Calculate window occlusion on Windows" to "Disabled". Restart
chrome to apply settings.

Browser option to select certificate for authentication displayed on Edge
and Chrome after session is idle for about 5 minutes, due to internal
browser SSL caching and timeouts. If certificate is selected promptly,
reconnection is successful. With longer idle times, authentication is not
successful, and the browser should be restarted to reconnect. Issue is not
observed in Firefox or IE 11.

Internet Explorer has an internal limitation on the number of websockets
that are allowed to be created to a single server (6). This can be changed
by modifying a registry variable as shown here :
https://msdn.microsoft.com/en-us/library/ee330736(v=vs.85).aspx#webso
cket_maxconn.

Internet Explorer 11,and Safari have a limitation when connecting to IPv6
devices. Using the numerical URL will not work when it attempts to
establish a websocket connection. In these browsers, use the device
hostname or literal IPv6 as UNC to connect to the SX II. See
https://en.wikipedia.org/wiki/IPv6_address#Literal_IPv6_addresses_in_UN
C_path_names

When using HSC in 10S Safari, the keyboard may not appear in some pages
if the "request desktop website" setting is enabled. To change the setting,
go to Settings > Safari >Request Desktop Website, then make sure All
Websites is not selected, and the device address is not selected. You can
also set this per address by clicking the "aA" in Safari's URL pane when
connected to the HSC port, then select "Website Settings" and make sure
that "Request Desktop Website" is not selected.
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Dominion User Station

To use a standalone appliance for remote access to KX Il target servers instead
of using the VKC or AKC clients on a PC or laptop, purchase Dominion User
Stations from Raritan. The User Station is perfect for environments like labs,
studios and control rooms where a PC or laptop is not wanted.

This chapter provides a brief introduction to the User Station. For detailed
information, refer to the user documentation from the User Station's section
on the Raritan website's Support page (www.raritan.com/support).

In This Chapter
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Overview

The Dominion User Station (DKX3-UST) is designed to access servers and
computer devices connected to KX llI's from your LAN/WAN networks. ALL KX
Il models are supported. KX Il Release 3.2 and above is required.

One User Station can access the servers connected to multiple KX IlI's so that
you can easily access a large number of servers with a single click.

Note that the User Station does NOT support the access to a target server
which is from a tiered KX Ill or a blade server. Use VKC or AKC clients to access
such targets instead.

SSH, RDP, VNC
/=

el CITID =0

Vi =0
=0

KX Il KVM
coeseee-EERES ]

KX Il KVM

)=

KX IV-101 KVM
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Appendix A: Dominion User Station

A USB Keyboard, USB mouse, and one or two HDMI- or

A DisplayPort-interfaced monitors

B Analog or digital audio appliances

c Optional smart card reader for remote IT device authentication
D External drives as virtual media, such as CD-ROM

E USB drives for virtual media or User Station software update

F Optional integration with CC-SG

User Station Photo and Features

e Supports single, dual monitors or three monitors

e Three 1080p streaming video sessions at 30 FPS
e  Supports VGA, DVI, HDMI and DisplayPort video
e  Favorites and hot-key switching

e Access hundreds of servers

e Ultra-fast connections and sub-second switching with the non-blocking
DKX3-808 model

e Dual Gigabit Ethernet ports
e Self-contained, low maintenance appliance

e Desktop, rack and VESA mountable

Operating the User Station

1. Have the required equipment properly connected to the User Station.
a. Power OFF all devices.

b. Connect a USB keyboard, mouse and one or two monitors to the User
Station.

c. Connect the User Station to the LAN/WAN network.

2. Power on and log in to the User Station.
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Appendix A: Dominion User Station

= Forinitial login, use Raritan's default username and password: admin
and raritan.

3. Add KX IllI's data. See Logging In to KX lll (on page 14).
4. The added KX Ill's are displayed in the Port Navigator window.

-

Favorite Ports

5. Click a KX Il to show a list of its servers.

6. Click a target server, and a KVM Client opens, showing the target video.
Now you can control the target with the attached keyboard and mouse.

For detailed information, refer to the user documentation from the User
Station's section on the Raritan website's Support page
(www.raritan.com/support).
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KX Ill Remote Console

In This Chapter
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Managing Favorites

Overview
When you log in to the KX Ill using a network connection, you access the
Remote Console. The first page accessed is the Port Access page.

See Logging In to KX Il (on page 14) and Port Access Page (Remote Console
Display) (on page 16)

Use the Remote Console to access and scan target servers, manage favorites,
and change your password.

For more in the Remote Console interface elements, see KX Ill Remote Console
Interface (on page 15).

Scanning Ports - Remote Console
Use the port scanning feature to search for selected targets and display them in
individual thumbnails as part of a slide show.

This feature allows you to monitor up to 32 targets at one time since you can
view each target server individually as it is displayed during the slide show.

Connect to targets or focus on a specific target as needed.

For dual video port groups, the primary port is included in a port scan, but the
secondary port is not included when connecting from a remote client. Both
ports can be included in the scan from the Local Port.

Note: The scan port feature is available from the Remote Console and Local
Console, but the feature varies slightly.
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Scanning Ports Slide Show - Remote Console
When you start a scan, the Port Scan window opens.
As each target is found, it is displayed as a thumbnail in a slide show.

The slide show scrolls through the target thumbnails based on the default
interval of 10 seconds or according to the interval you specify.

As the scan scrolls through the targets, the target that is the focus of the slide
show displays in the center of the page.

The name of the target is displayed above its thumbnail.

If a target is busy, a blank screen is displayed instead of the target server access
page.

|2 Port Scan - Virtual KVM Client i . . b S S, o RCTiey

Scan Options

» Control Panel » All Control Panel ltems » Display » Screen Resolution

Change the appearance of your display

Display: ‘@I
Resclution: ‘}“‘jﬁ'foﬁtl

Oxientation: llmds(ape

D 2-xx3 L0l Port

B +-T1oRE4sHKCT00.

B 5 - Dorinicn 002 _Forts

I , J L -Damnion-£X2_Ports

Configure scan settings for the Remote Console in the KVM client.

Note: Scan port settings for the Local Console are configured on the Local Port
Settings page. See Scanning Ports - Local Console (on page 162)
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Target Status Indicators During Port Scanning - Remote Console

The status of each target is indicated by green, yellow and red lights that are
displayed below the target thumbnail.

As the target is the focus of the rotation, the indicator is in the task bar also
shows the status.

Lights for each target are gray until they are the focus of the slide show.
The status lights indicate the following:

e Green - the target is up/idle or up/connected

e Yellow - the target is down but connected

e Red - the target is down/idle, busy, or otherwise not accessible

|44 Port Scan - Virtual KVM Client i i .
Scan Options

» Control Panel » Al Control Pane! iems » Display » Screen Resalution

Change the appearance of your display

Display: [2. Rantan cov ~ |

Resclution: | 1420 x 900 -|

Crienation: [Landscape

va

2 -KX3 Local Port

B + - T10-4164KET00. .

B 5 - Doriricn012_Ports

B L -Dominion+X3 Ports [
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Using Scan Port Options
Following are options available to you while scanning targets.

With the exception of the Expand/Collapse icon, all of these options are
selected from the Options menu in the upper left of the Port Scan viewer.

The options will return to their defaults when you close the window.

Note: Configure scan settings such as the display interval from the KVM Client.

P> Hide or View Thumbnails
4
e Use the Expand/Collapse icon P at the upper left of the window to hide
or view thumbnails. Expanded is the default view.

»  Pause the Thumbnail Slide Show

e Pause thumbnails from rotating between one target and the next by
selecting Options > Pause. Rotating thumbnails is the default setting.

P> Resume the Thumbnail Slide Show
e  Resume the thumbnail rotation by selecting Options > Resume.

P Size the Thumbnails in the Port Scan Viewer
e Enlarge the size of the thumbnails by selecting Options > Size > 360x240.

e  Minimize the size of the thumbnails by selection Options > Size > 160x120.
This is the default thumbnail size.

P> Change the Orientation of the Port Scan Viewer

e View thumbnails along the bottom of the Port Scan viewer by selecting
Options > Split Orientation > Horizontal.

e View thumbnails along the right of the Port Scan viewer by selecting

Options > Split Orientation > Vertical. This is the default view.

| ) Port Scan - Virtual KVM Ciient Y - -— gy
[Scan Optious}}‘

Pause

Resume
Thumbnail Size ¥
Spht Orientation »

» Control Panel » Al Control Panel ltems » Display » Screen Resolution

Change the appearance of your display

Display. [2 Raritan cM | B 2 -«x3Lomlport

Resclutiont ‘ 1440 = 900 ']
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Scan for Targets

P> To scan for targets:

Click the Set Scan tab on the Port Access page.

2. Select the targets you want to include in the scan by selecting the
checkbox to the left of each target, or select the checkbox at the top of the
target column to select all targets.

3. Leave the Up Only checkbox selected if you only want targets that are up
to be included in the scan. Deselect this checkbox if you want to include all
targets, whether up or down.

4. Click Scan to begin the scan.

As each target is scanned, it is displayed in slide show view on the page.

5. Click Options > Pause to pause the slide show and stop it from moving
between targets, click Options > Resume to resume the slide show.
Click on a target thumbnail to scan it next.

Connect to a target by double clicking on its thumbnail.
Changing a Password

»  To change your KX Il password:
Choose User Management > Change Password. The Change Password page
opens.
Type your current password in the Old Password field.

3. Type a new password in the New Password field. Retype the new password

Raritan.
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in the Confirm New Password field. Passwords can be up to 64 characters
in length and can consist of English alphanumeric characters and special
characters.

Click OK.

You will receive confirmation that the password was successfully changed.
Click OK.
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Note: If strong passwords are in use, this page displays information about the
format required for the passwords. For more information about passwords and
strong passwords, see Strong Passwords.

Home = Uzer Management * Change Pasamord

Change Password

Old Password

Hew Password

Confirm Hew Password

OK | Cancel

Managing Favorites

A Favorites feature is provided so you can organize and quickly access the
devices you use frequently.

The Favorite Devices section is located in the lower left sidebar of the Port
Access page and provides the ability to:

e Create and manage a list of favorite devices

e Quickly access frequently-used devices

e List your favorites either by Device Name, IP Address, or DNS hostname
e Discover KX Il devices on its subnet

e Retrieve discovered KX Il devices from the connected Dominion device

Note: Due to browser limitations, HKC does not support Favorites.

Enable Favorites

e Click Enable in the Favorite Devices section of the left panel of the KX 111
interface, below Online Help.
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Access and Display Favorites

P> To access a favorite KX Il devices:

e Click on a KX Il listed beneath Favorite Devices in the left of the Remote
Console.

P> To display favorites by Name, IP Address or Host Name:
e Click Display by Name, Display by IP, or Display by Host Name.

Favorite Devices:
Somerset

Tokyo
Raleigh

| Manage | | Display By Name |

[ Display By Host Name | [ Display By IP |

Discovering Devices on the Local Subnet

This option discovers KX Il devices on your local subnet. This is the subnet
where the KX Ill Remote Console is running.

These devices can be accessed directly from this page or you can add them to
your list of favorites.

P> To discover devices on the local subnet:

Choose Manage > Discover Devices - Local Subnet. The Discover Devices -
Local Subnet page appears.

2. Choose the appropriate discovery port:

= To use the default discovery port, select the Use Default Port 5000
checkbox.

= To use a different discovery port:

a. Deselect the Use Default Port 5000 checkbox.

b. Type the port number in the Discover on Port field.
c. Click Save.

3. Click Refresh. The list of devices on the local subnet is refreshed.

P>  To add devices to your Favorites List:

Select the checkbox next to the device name/IP address.
2. Click Add.
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P> To access a discovered device:

e  Click the device name or IP address for that device. A new browser opens
to that device.

Discovering Devices on the KX Il Subnet
This feature is only available in the Java client , RSC.

This option discovers KX Il devices on the device subnet. This is the subnet of
the KX 11l device's IP address.

You can access these devices directly from the Subnet page or add them to
your list of favorites.

This feature allows multiple KX 11l devices to interoperate and scale
automatically.

The KX Il Remote Console automatically discovers the KX 11l devices, and any
other Raritan device, in the subnet of the KX IlI.

P>  To discover devices on the device subnet:

1. Choose Manage > Discover Devices - KX Ill Subnet.

Fawvorite Devices:

Somerset
Tokyo
Raleigh

| Manage | | Display By Name |

[ Display By Host Name | | Display By IP |

The Discover Devices - KX Il Subnet page appears.

2. Click Refresh. The list of devices on the local subnet is refreshed.

P>  To add devices to your Favorites List:
Select the checkbox next to the device name/IP address.
2. Click Add.

P> To access a discovered device:

e  Click the device name or IP address for that device. A new browser opens
to that device.
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KX lll Local Console

The Local Console interface provides access to the KX Il while at the rack.

This section contains help on tasks performed by end users at the Local
Console.

In This Chapter

ACCESSING @ TArget SEIVEN c..eviiiiiii e e
Local Console Video Resolution Behavior
SIMUILANEOUS USEIS .eeiiieeiiiie ettt ettt ettt e e et e st e e s e e e e ateeesnseeas
Local Port Hot Keys and CoNNECt KEYS .....ccccuveeeeiiiieieiiee e
Scanning Ports - LOCal CONSOIE ......cocuvieeeiiiccciee et e
Local Console SMart Card ACCESS ....uiviuvierieeriieeeiiiesieeeieesieesteesieesaeesseessees
Local Console USB Profile OptioNnS.......ccuueeeiiiieeeiiiec et
KX 11l Local Console Factory RESEt .......ceeeueeriiieiiieniieeiee e
Resetting the KX 11l Using the Reset Button

Accessing a Target Server

P> To access a target server:

Click the Port Name of the target you want to access. The Port Action
Menu is displayed.

2. Choose Connect from the Port Action menu. The video display switches to
the target server interface.

Local Console Video Resolution Behavior

Raritan.
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By default, monitors are typically set to the highest resolution they support.

Once a monitor is connected to the KX Il Local Console, KX IIl detects the
monitor's native resolution. As long as the native resolution is supported by the
Local Console, KX Il uses that resolution.

If the native resolution is not supported by the Local Console, and no other
resolution is supported by the monitor and Local Console, KX Il uses the
resolution of the last monitor that was connected to the Local Console.

For example, you connect a monitor set to a resolution of 1600x1200@60Hz to
the KX Il Local Console. KX Il uses that resolution since it is supported by the
Local Console.

If the next monitor you connect to the Local Console is not set to a supported
resolution, KX Il uses the resolution of 1024x768@60.

For a list of supported Local Console video resolutions, see KX Ill Supported
Local Port DVI Resolutions (on page 194).
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Simultaneous Users

The KX Il Local Console provides an independent access path to the connected
KVM target servers.

Using the Local Console does not prevent other users from simultaneously
connecting over the network. And even when remote users are connected to
the KX 11I, you can still simultaneously access your servers from the rack via the
Local Console.

Local Port Hot Keys and Connect Keys

Because the KX Il Local Console interface is completely replaced by the
interface for the target device you are accessing, a hot key is used to
disconnect from a target and return to the local port GUI.

A connect key is used to connect to a target or switch between targets.

The Local Port hot key allows you to rapidly access the KX Il Local Console user
interface when a target device is currently being viewed.

See Select the Local Port Hotkey and Select the Local Port Connect Key for
more information.

Return to the Local Console from a Target Device - Default Hot Key
e Press the Scroll Lock hot key twice rapidly

The video display switches from the target device interface to the KX llI
Local Console interface.

Local Port Auto-Sense (Video Refresh) - Default Hot Key

P> To perform an auto-sense (video refresh) on the KX Ill local port via hot
key:

e Press and hold the Shift key, and quickly press the Scroll Lock key twice,
and then release.

Connect Key Examples

Standard servers

Connect key action Key sequence example

Access a port from the local ® Press Left ALT > Press and Release 5 > Release Left ALT

port

Switch between ports = Press Left ALT > Press and Release 1 > Press and Release 1 >

Release Left ALT

Disconnect from a targetand ® Double-click Scroll Lock
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Standard servers

Connect key action Key sequence example
return to the local port

Blade chassis

Connect key action Key sequence example
Access a port from the local ~ Access port 5, slot 2:

port GUI = Press Left ALT > Press and Release 5 > Press and Release - >

Press and Release 2 > Release Left ALT
Switch between ports Switch from target port 5, slot 2 to port 5, slot 11:
= Press Left ALT > Press and Release 5 > Press and Release - >
Press and Release 1 > Press and Release 1 > Release Left ALT
Disconnect from a target and Disconnect from target port 5, slot 11 and return to the local
return to the local port GUI port GUI (the page from which you connected to target):
=  Double Click Scroll Lock

Special Sun Key Combinations

The following key combinations for Sun™ Microsystems server’s special keys
operate on the Local Console port. These special keys are available from the
Keyboard menu when you connect to a Sun target device:

Sun key Local port key combination
Again Ctrl+ Alt +F2
Props Ctrl + Alt +F3
Undo Ctrl + Alt +F4
Stop A Break a

Front Ctrl + Alt + F5
Copy Ctrl + Alt + F6
Open Ctrl + Alt + F7
Find Ctrl + Alt + F9
Cut Ctrl + Alt + F10
Paste Ctrl + Alt + F8
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Sun key Local port key combination
Mute Ctrl + Alt + F12

Compose Ctrl+ Alt + KPAD *

Vol + Ctrl + Alt + KPAD +

Vol - Ctrl + Alt + KPAD -

Stop No key combination

Power No key combination

Scanning Ports - Local Console

The scan port feature is available from the Remote Console and Local Console,
but the feature varies slightly. See Scanning Ports - Remote Console (on page
151)

Click the thumbnail of any target server to exit scan mode and connect to the
target, or use the Local Port ConnectKey sequence.

To exit scan mode, click the Stop Scan button in the thumbnail view, or use the
Local Port Hotkey sequence hot key.
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Scanning Port Slide Show - Local Console
When you start a scan, the Port Scan window opens.
As each target is found, it is displayed as a thumbnail in a slide show.

The slide show scrolls through the target thumbnails based on the default
interval of 10 seconds or according to the interval you specify.

As the scan scrolls through the targets, the target that is the focus of the slide
show displays in the center of the page.

The name of the target is displayed above its thumbnail.

If a target is busy, a blank screen is displayed instead of the target server access
page.

Configure the time between the slide show thumbnail rotation and the
thumbnail focus interval on the Local Port Settings page.

See Configure Local Console Scan Settings (on page 164)

Note: Configure scan settings for the Remote Console from VKC, VKCS, or AKC.
See Configuring Port Scan Settings in VKC/VKCS and AKC (on page 60)

Connmcten VS Pofle Gnpboed Video Mome Took View Virtus! Mo
BhHELEEA 0O @i

8:25

Thursday; November 17
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Connection USB Profile Keyboerd Video Mouse Tools View Virtual Media Audio SmartCard Help

SGREERBEQDIE R mE

Welcome

Target Status Indicators During Port Scanning - Local Console

When scanning on the Local Console, the status of each target is indicated
below the thumbnail.

The scanning status of each target is displayed as:
e notscanned

e connecting

e scanned

e skipped

Configure Local Console Scan Settings

Do the following to configure Local Console scan port options.

To configure the Local Console scan port settings:
On the Local Console, select Device Settings.

In the Local Port Settings section, select Local Port Scan Mode.

w N =Y

Change the display interval as needed:
= Display Interval - changes the scan display interval.

= Interval Between Ports - change interval between switching different
port during scan.
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Scan for Targets - Local Console

P> To scan for targets:
Click the Set Scan tab on the Port Access page.

2. Select the targets you want to include in the scan by selecting the
checkbox to the left of each target, or select the checkbox at the top of the
target column to select all targets.

3. Leave the Up Only checkbox selected if you only want targets that are up
to be included in the scan. Deselect this checkbox if you want to include all
targets, whether up or down.

4. Click Scan to begin the scan.

As each target is scanned, it is displayed in slide show view on the page.

Local Console Smart Card Access

Raritan.
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To use a smart card to access a server at the Local Console, plug a USB smart
card reader into the KX Il using one of the USB ports located on the KX IlI.

Once a smart card reader is plugged in or unplugged from the KX 11, the KX IlI
autodetects it.

For a list of supported smart cards and additional system requirements, see
Supported Smart Card Readers (on page 204), Unsupported Smart Card
Readers (on page 205) and Smart Card Minimum System Requirements (on
page 202).

When mounted onto the target server, the card reader and smart card will
cause the server to behave as if they had been directly attached.

Removal of the smart card or smart card reader will cause the user session to
be locked or you will be logged out depending on how the card removal policy
has been setup on the target server OS.

When the KVM session is terminated, either because it has been closed or
because you switch to a new target, the smart card reader will be automatically
unmounted from the target server.

P> To mount a smart card reader onto a target via the KX Ill Local console:

Plug a USB smart card reader into the KX Il using one of the USB ports
located on the device. Once attached, the smart card reader will be
detected by the KX IIl.

From the Local Console, click Tools.

3. Select the smart card reader from the Card Readers Detected list. Select
None from the list if you do not want a smart card reader mounted.

4. Click OK. Once the smart card reader is added, a message will appear on
the page indicating you have completed the operation successfully. A
status of either Selected or Not Selected will appear in the left panel of the
page under Card Reader.
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To update the Card Readers Detected list:

Click Refresh if a new smart card has been mounted. The Card Readers

Detected list will be refreshed to reflect the newly added smart card
reader.

Select Card Reader

Card Readers Detected

USE SmantCard Reader (Gemplus)

QK Refresh | Cancel |

Note: If a smart card reader is selected for local port login in Security>Local

Smart Card Authentication, then that card reader cannot be selected for target
connections; it will be listed, but cannot be chosen.

166
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Using a Smart Card at the Local Port

When Local Smart Card Authentication is enabled, you can be authenticated by
using your smart card at the card reader connected to a KX 11l USB port.

If Local Smart Card Authentication is enabled but not required, the Login tab
remains accessible to allow for username/password login.

P> To use a smart card at the local port.

1. When the card reader is detected, the Login page shows a PIN tab.

m Local Console Port

Rarit

Dominion® KX 111

Smart Card reader detected.

Insert Smart Card.

Login to DominionKX

Username: || T

Password: |

2. Insert a card. The PIN tab opens automatically.
3. Enter the PIN and click Login.

Local Console Port

Raritan.

& i o Dlggand

Login - DominiankX

Dominion® KX Il Smart Card reader detected.

Smart Card inserted.

Login to Dominionkx

PIN: ]

Login

4. After successful entry of the card’s PIN, access is granted if the card
contains an authentication certificate approved by Client Certificate
Authentication. See Client Certificate Authentication Settings.

If login fails, check the Audit log for failure information.
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Local Console USB Profile Options

From the USB Profile Options section of the Tools page, you can choose from
the available USB profiles.

The ports that can be assigned profiles are displayed in the Port Name field and
the profiles that are available for a port appear in the Select Profile To Use field
after the port is selected. The profiles selected for use with a port appear in the
Profile In Use field.

>  To apply a USB profile to a local console port:

In the Port Name field, select the port you want to apply the USB profile
to.

2. Inthe Select Profile To Use field, select the profile to use from among
those available for the port.

3. Click OK. The USB profile will be applied to the local port and will appear in
the Profile In Use field.

168

KX 1l Local Console Factory Reset

Note: It is recommended that you save the audit log prior to performing a
factory reset.

The audit log is deleted when a factory reset is performed and the reset event is
not logged in the audit log. For more information about saving the audit log,
see Audit Log.

»  To perform a factory reset:

Choose Maintenance > Factory Reset. The Factory Reset page opens.
2. Choose the appropriate reset option from the following options:

=  Full Factory Reset

Removes the entire configuration and resets the appliance completely
to the factory defaults.

Because of the complete nature of this reset, you will be prompted to
confirm the factory reset.

= Network Parameter Reset

Resets the network parameters of the appliance back to the default
values (click Device Settings > Network Settings to access this
information).

3. Click Reset to continue. You will be prompted to confirm the factory reset
because all network settings will be permanently lost.

4. Click OK proceed. Upon completion of full factory reset, the KX Ill device is
automatically restarted.
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Resetting the KX Ill Using the Reset Button

On the back panel of the device, there is a Reset button. It is recessed to
prevent accidental resets (you need a pointed object to press this button).

The actions that are performed when the Reset button is pressed are defined
on the Encryption & Share page. See Encryption & Share.

Note: It is recommended that you save the audit log prior to performing a
factory reset.

The audit log is deleted when a factory reset is performed and the reset event is
not logged in the audit log. For more information about saving the audit log,

see Audit Log.

P> To reset the device:

1. Power off the KX II.

2. Use a pointed object to press and hold the Reset button.

3. While continuing to hold the Reset button, power the KX Il device back on.
4. Continue holding the Reset button for 10 seconds.

LOCAL ’

USER
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Appendix A Connecting a KX lll and Cat5 Reach DVI -
Provide Extended Local Port Functionality

An extended local port extends the reach of the local port beyond the rack the
KX 1l is located, for example to another KVM switch.

This can be achieved by configuring a KX Il to work with a Raritan Cat5 Reach
DVI transmitter and receiver, which are then connected to a remote console or
other device.

Once connected to the Cat5 Reach DVI, the KX Ill can be accessed up 500 feet
(152 m) away.

Connecting the KX 11l to the Cat5 Reach DVI by daisy chaining Ethernet switches
extends can extend the KX IlI's reach up to 3000 feet (914 m).

In This Chapter
About the Cat5 RE@aCh DVI ...cccooviiiiiiiiiieeeeeeeeeeeeeeeeeeeeeeeeeee 170
Connect Cat5 Reach DVI and Cat5 Reach DVl........uvevvvvvevevererererererereenrnrerennnenens 170

About the Cat5 Reach DVI

For details on the Cat5 Reach DVI, see the Cat5 Reach DVI online help available
on the Raritan Support page http://www.raritan.com/support.

Contact Raritan (http://www.raritan.com/contact-us/) for additional
information on the Cat5 Reach DVI, or for information on purchasing.

Connect Cat5 Reach DVI and Cat5 Reach DVI

Note: The images used in the diagrams are not specific to Cat5 Reach DVI but
the connections are accurate.

This section introduces three scenarios involving KVM switches.
e  Connect the Cat5 Reach DVI between any KVM switch and its local console.
e Connect the Cat5 Reach DVI between two KVM switches.

e Connect the Cat5 Reach DVI between a computer/server and a KVM
switch.

Turn off all devices before making the connections.

For detailed information on setting up the local and remote consoles, see
Connecting a Keyboard/Mouse/Video Source in Cat5 Reach DVI Help for more
information.

»  To connect Cat5 Reach DVI and Cat5 Reach DVI:

1. If you have not already done so, set up the local and remote consoles with
the Cat5 Reach DVI transmitter and receiver, respectively.
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Appendix A: Connecting a KX Ill and Cat5 Reach DVI - Provide Extended Local Port Functionality

See Basic Installation in Cat5 Reach DVI Help for more information.
2. Use a Cat5e/6 cable to connect the transmitter and receiver.

Connect the transmitter and receiver to an appropriate power source
respectively.

4. Connect the local console ports of the KVM switch to the transmitter.

a. Plugone end of the Raritan-provided DVI cable into the DVI-I IN port
on the transmitter, and the other end into the KVM switch's video
port.

b. Plug the USB-B connector of the Raritan-provided USB cable into the
USB-B port on the transmitter, and the other end into the KVM
switch's local USB-A port.

5. Turn on the KVM switch.

io
io

b .

=

Tip: The local or remote console can be equipped with a KVM drawer instead of
a set of keyboard, mouse and monitor. See the illustration below.

P Toincrease the distance between two tiered KVM switches:

1. Set up a remote console by connecting the receiver to a KVM switch.
a. Connect a USB CIM to the receiver.

b. Connect this USB CIM to any channel port on the KVM switch via a
Cat5 cable.
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Appendix A: Connecting a KX Il and Cat5 Reach DVI - Provide Extended Local Port Functionality

Use a Cat5e/6 cable to connect the transmitter and receiver.

Connect the transmitter and receiver to an appropriate power source

respectively.
Connect the KVM switch to the transmitter.
Turn on both KVM switches.

N

v L

PO NPEY

To increase the distance between any computer and a KVM switch:

Set up an optional local console with the transmitter.

Set up a remote console by connecting the receiver to a KVM switch.

Use a Cat5e/6 cable to connect the transmitter and receiver.

Connect the transmitter and receiver to an appropriate power source

respectively.
Connect the computer to the transmitter.

Turn on the computer.

0 W n o u 1
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Appendix B Updating the LDAP Schema

In This Chapter

Returning User Group INformation.........ccceccvveeeeciiic e
Setting the Registry to Permit Write Operations to the Schema
Creating @ New Attribute.....cooiviiiie e
Adding Attributes to the Class
Updating the Schema Cache........cooiiiiiiiiiiic e
Editing rciusergroup Attributes for User Members ........ccoceeeveiriieeniecnieeniennn

Returning User Group Information

Use the information in this section to return User Group information (and assist
with authorization) once authentication is successful.

From LDAP/LDAPS

When an LDAP/LDAPS authentication is successful, the KX Il determines the
permissions for a given user based on the permissions of the user's group. Your
remote LDAP server can provide these user group names by returning an
attribute named as follows:

rciusergroup attribute type: string

This may require a schema extension on your LDAP/LDAPS server. Consult your
authentication server administrator to enable this attribute.

In addition, for Microsoft” Active Directory’, the standard LDAP memberOf is
used.

From Microsoft Active Directory

Note: This should be attempted only by an experienced Active Directory®
administrator.

Returning user group information from Microsoft's® Active Directory for
Windows 2000° operating system server requires updating the LDAP/LDAPS
schema. See your Microsoft documentation for details.

1. Install the schema plug-in for Active Directory. See Microsoft Active
Directory documentation for instructions.

2.  Run Active Directory Console and select Active Directory Schema.

Raritan. 173

Abrand of Olegrand’



Appendix B: Updating the LDAP Schema

Setting the Registry to Permit Write Operations to the Schema

To allow a domain controller to write to the schema, you must set a registry
entry that permits schema updates.

P> To permit write operations to the schema:

Right-click the Active Directory® Schema root node in the left pane of the

window and then click Operations Master. The Change Schema Master
dialog appears.

Change Schema Master ed |

The zchema master manages modifications to the schema. Only one
zerver in the enterprize performs this role.

Current zchema maszter [online]:

rei-gofdi2nzmzt. mypc. mydamain. com

To transfer the schema master role to the targeted
darnain contraller below, click Change.

rei-gofdi2nzmet. mypc. mydamain. com

Cloze

2. Select the "Schema can be modified on this Domain Controller" checkbox.
Optional

3. Click OK.

Creating a New Attribute

P> To create new attributes for the rciusergroup class:

Click the + symbol before Active Directory® Schema in the left pane of the
window.

2. Right-click Attributes in the left pane.
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Appendix B: Updating the LDAP Schema

3. Click New and then choose Attribute. When the warning message appears,
click Continue and the Create New Attribute dialog appears.

Create New Attribute 21x|

‘ Create a New Attribute Dbject

r~ Identification

Common Name: Irciusergroup

LDAP Display Name: ~ |rciusergroup

Unique X500 Object ID: |1.3.6.1.4.1.13742.50

Description: | LDAF attribute
 Syntax and Range
Syntax: |Ease Inzensitive String j
Mirirnirn: |1
b aimum: |24|

™ Multivalued ok | Cancel |

4. Type rciusergroup in the Common Name field.

5. Type rciusergroup in the LDAP Display Name field.

6. Type 1.3.6.1.4.1.13742.50 in the Unique x5000 Object ID field.
7. Type a meaningful description in the Description field.

8

Click the Syntax drop-down arrow and choose Case Insensitive String from
the list.

9. Type 1inthe Minimum field.
10. Type 24 in the Maximum field.
11. Click OK to create the new attribute.

Adding Attributes to the Class

P To add attributes to the class:

1. Click Classes in the left pane of the window.
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2. Scroll to the user class in the right pane and right-click it.

"% Consolel - [Console Root} Active Directory Schema [rai-gefd) (=] B3]
'ﬁ Fie Acton Uiew Favorites ‘Widow  Help 18| x|
- | B @B &
[ Corscle Roct Narre | Type [ Status | Cescial
E1-Wg Active Directory Schema | B3 serviceConnecbonPoint  Structural Active Servi
B Classes B3 servicelnstarce Structural Active Servi
~{1) Atrbutes B2 cirrplzSacunityObject Auxliary Active The <
B3 site Structural Active Site
B3 siteLink Structural Active Site-L
W3 citeLinlBridge Structural Active Site-1
B3 sitesCentainer Structural Bctive Sites-
W sterage Struztural Active Stere
B3 subnct Structural Active Zubn
B2 cubnetContainer Structural Active Subn
B3 subSchema Structural Active “ubS
B3 top Abstract Active Top
3 bustecDomain Structural Active Trust
B3 bepelibrary Steuctural Active Type:
= New Wirdow From Here
B2 volume Active Volun v
4| e Refrach | b
Properties |
Help

3. Choose Properties from the menu. The user Properties dialog appears.
4. Click the Attributes tab to open it.
5
6

Click Add.

Choose rciusergroup from the Select Schema Object list.

Select Sehema Dbject '

Select 5 poherma obypscl

peoduct’ode

prolie sth

prosaedDibpectt ame
ey

=l

7. Click OK in the Select Schema Object dialog.

8. Click OKin the User Properties dialog.

Raritan.

A brand of [llegrand’



Appendix B: Updating the LDAP Schema

Updating the Schema Cache

P>  To update the schema cache:

Right-click Active Directory” Schema in the left pane of the window and
select Reload the Schema.

2.  Minimize the Active Directory Schema MMC (Microsoft® Management
Console) console.

Editing rciusergroup Attributes for User Members

Raritan.

Abrand of Olegrand’

To run the Active Directory® script on a Windows 2003" server, use the script
provided by Microsoft® (available on the Windows 2003 server installation CD).
These scripts are loaded onto your system with a Microsoft” Windows 2003
installation. ADSI (Active Directory Service Interface) acts as a low-level editor
for Active Directory, allowing you to perform common administrative tasks
such as adding, deleting, and moving objects with a directory service.

To edit the individual user attributes within the group rciusergroup:

Double-click SUPTOOLS.MSI to install the support tools.

Go to the directory where the support tools were installed. Run
adsiedit.msc. The ADSI Edit window opens.

>
1. From the installation CD, choose Support > Tools.
2
3

< Pl Acwn Was Whdox  Hep l;lﬂ_"_l

: [ Qs i sy Nane
&5 Doman [r Ty I mype... domanDAS

#r i Cofiaration [rcrgeféromet.mn | 0§ Corfigrabon [rcrgeiéiame... - cenfigurebon

chemns [ro- TYREM' | | Schema [romp:! g dRD

< aostEck

i | sl i |

4. Open the Domain.
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Appendix B: Updating the LDAP Schema

5. Inthe left pane of the window, select the CN=Users folder.

G B Ackn Vew Wndon beb [SETE

o |BEXEER(2 |
< anstecr Hane {0m: [ Detruphed Nzoe

£ Doman o ek mypc i, | LA C user CH=teminiskr skor, (N=Users, 0 C=mypc, 0C=nydoman,C

2 CC=mype LC=mdoman b | ZICH=Cert Pubishers rop CH=Cert Publishiers, C=Users,CC=nypc,CC=mrdoman

d-Ld N-fukn ZACH=Crehdnrs rap CH=Cradmrs, Qu=Users, CC=nypc CC=mpdoman 0C:

e il LACH=Crelpdaebrony arep CH=Crelpddmbrony, CH=Users D C=myps, CC=nydane

$-4d cu=Domain Contabes ) 5 h-pomein Adnirs g CH=Demein Admirs, C=Users, OC=nype,CC=mpdomen

fb‘ P raiy s tyP L) B CH=omen Conputers g CH=Comein Computers, CN=Users, D C=myps, OC=mydor

b Lch=Demen Cortrabers e I=Comen Controlers, (N=Users, 0 C=mys, D C=mydor

-3 Oh=Program Data den=Comen Guests s omen Guests, CH=Ussrs, DC=mrpe, DX=mydomsn

$-03 Q=Fysten ch=comenuzers e ek Uzers, CH=Ussrs, DC=myge Do=mydaman |

R Sdch-ervemves Admrs Srep JEnvze e tzn AdMing, imlisers, CCmmype, DS =frrpcom

&8 Coniguralion [rcr-rgraet m | =S CN=Gro.m Pelcy Dreatar Cwv, greup I~roup Pelcy Creator Caer s, CheUsae s, Dmtinnc, L

& 3 Schems [ra-aFAEnzms:. mypem: | —CH=GLest user CHELesE, Chla sy s, I mfit e, Dt e, Do monr

dCHHebServrestioun areup CHet-ieker iesGroup, CNmlisers, D Camne, D Camydar

Cdcnaketegt usar CHakebigt, Chimdlsers, CCmmypc CC =mpdaman, [C =cen

CHcNRAS and 145 Servars qreup CH=RAS and 145 Servers, (Nwlsers, D Camyps, DCanyC !

CcHasehams admine areup CHaGehem Ak, Chel 5o 5, DO iy pe, D =fiycomar

'_'d(u-uw:m'msan user CN-’;.FFERV'WSBD,(M&iE(-m{,D:-m‘M

CAcHaTaneCerts qreup CHaTanSClerts, Clie s, DCmtiyne, DCamydemain,C

< i )

| 0|
T i

6. Locate the user name whose properties you want to adjust in the right

pane. Right-click the user name and select Properties.

7. Click the Attribute Editor tab if it is not already open. Choose rciusergroup
from the Attributes list.

CN=Administrator Properties 1

Attribute Editor | Secuiity |

21x

IV Show mandatory attributes
[V Show gptional attributes
[~ Show only attributes that have values

Attributes:
Attribute [ Syntax ] Value :_l
proxydddresses Unicode Sting ~ <Not Set>
pwdLastSet Large Integer/...  128299285248088608
queryPolicyBL Distinguished <Not Set>
[CIUSEIgroup 1S <h et
registeredéddress Octet String <Not Set>
replPropertyMetaData  Octet Sting 0x01 0x00 0200 0x00 0x0
replUpToDateVector  Octet Sting <Nat Set>
repsFrom Octet String <Not Set>
repsTo Octet String <Not Set> el
revision Integer <Nat Set>
rid Integer <Not Set>
roomMNumber Unicode String ~ <Not Set>
s.fllMAccounlN ame Unicode S!r'ru Administrator __lﬂ
4 »

oK I Cancel I Apply I

8. Click Edit. The String Attribute Editor dialog appears.
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Appendix B: Updating the LDAP Schema

9. Type the user group (created in the KX IIl) in the Edit Attribute field. Click
OK.

String Attribute Editor i x|

Attribute: rciusergroup

Value:
IAdmirI

Clear | 0K I Cancel
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Appendix C

Cisco ISE for RADIUS Users

Authorization is performed by means of user’s membership to local User
Groups. When using remote authentication, since there is no user account

locally, there needs to be way of returning user group information from remote

authentication server that the product will then match and perform

appropriate authorization. To achieve this objective, appropriate local group on
the product must be created and remote authentication server configured to

return appropriate matching group (case sensitive).

In This Chapter

Settings to Configure on Raritan Product........ccccceecveeevcieeeenieee s,
Settings to Configure on CisCO ISE .......ovivviieeiiiiiiiiee e,

Settings to Configure on Raritan Product

Raritan.
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1. Login to Raritan product with administrative account.
2. Access User Management>Authentication>RADIUS
3. Add the Cisco ISE 2.1.x Radius server.

| Home = User Management > Authentication Settings

Authentication Settings

() Local Authentication
©) LDAP

.;'E.:';. RADIUS
» LDAP

Primary RADIUS Server
[192.168.56.6

Shared Secret

Authentication Port
1812

T

Accounting Port
1813

;

Timeout (in seconds)

:

Retries

1
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Appendix C: Cisco ISE for RADIUS Users

4. Create user group with appropriate permission and port permission by
accessing User Management>User Group List.

Group Name *
[kviv_Admin

-
e
1]
3
n
n,
=]
3
n

Device Access While Under CC-SG Management
Device Settings

Diagnostics

Maintenance

Modem Access

PC-Share

Security

User Management

RNENEEEEE

¥ Port Permissions

Port Access Power Control
1: DPX2-Console Control | ¥ | Access | ¥ |
2: DPX3-Console Control | ¥ | Access | ¥ |
3: Serial Port 3 Control | » | Access | ¥ |
4: DPX3-5041-Console-86 Control | ¥ | Access | ¥ |
5: DPX3-5041-Console2-83 Control | ¥ | Access |7 |
6: DPX3-5041-Console3-85 Control | * | Access | 7 |
7: Cisco Cat3560x Control | > | Access | ¥ |
8 Serial Port 8 Control | ¥ | Access | ¥ |
9: Serial Port @ Control : Access :
. -1 P |

Settings to Configure on Cisco ISE

Step 1: Add Raritan Network Devices

1. Access Cisco ISE Web URL https://x.x.x.x/admin (see https://x.x.x.x/admin
- https://x.x.x.x/admin) and login with administrative credentials.

N

Access Work Centers>Network Resources under Network Access section to

<L Add

load Network Device menu and click

» Overview  » ldentities

Network Devices
Default Device

External RADIUS Servers

Identity Services Engine Home » Context Visibility » Operations » Policy » Administration ~ Work Centers
- Network Access » Guest Access » TrustSec » BYOD » Profiler » Posture  » Device Administration Network Access
Id Groups  Extld Sources  ~ Network Resources  Device Groups  » Policy Elements A Over?-'llew
! Identities
o Id Groups
Network Devices AU SULTLE
Network Resources
Device Groups
ﬁ-? Edit cl‘]:Add E‘Z uplicate | @uImport @ Export ate PAC | 3 Policy Elements
1 Authentication Polic)
Mal - | |P/Mask Profile Name Loc entication Folicy

RADIUS Server Sequences
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Appendix C: Cisco ISE for RADIUS Users

3. Configure Name, Description and IP Address/Range, and enable Radius
Authentication Settings option. Set Shared secret then click Submit to save
changes. If appropriate and applicable, assign Device Type and Location.

MNetwork Devices List > New Network Device
Network Devices

* Name 192.168.56.32

*IP Address: [192.16856.32] x| /|32 |

* Device Profile | usk Cisco| | &

Software Version l:l

* Network Device Group

Device Type |AIIDevice Types Q | [ Set To Default ]

Location )l Locations © | [ SetToDefault |

+ RADIUS Authentication Settings

Enable Authentication Settings
Protocol

* Shared Secret

Enable KeyWrap

* Key Encryption Key

* Message Authenticator Code Key

RADIUS

| [ show |

[

%3]
=}
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Appendix C: Cisco ISE for RADIUS Users

Step 2: Create/Edit User

In production environments with user accounts or configured external identity
source (AD/LDAP), kip this step.

e Add

1. Access Work Centers>Device Administration>ldentities> and click
to add a user

Home » Context Visibility » Operations i ~ \Work Centers
» TrustSec  » BYOD  » Profiler  » Posture |~ Device Administration Network Access TrustSec Profiler
ntity Groups ~ Extld Sources  » Network Resources  Network Device Groups  » P OVEMEW Ovenview Overview
| Identities Components ExtId Sources
] Id Groups TrustSec Policy Network Devices
Network Access Users Ext Id Sources Authentication Policy Endpoint Classification
MNetwork Resources Authorization Policy Node Config
+Add @eimoot oo | Device Groups SXP Feeds
Policy Elements Troubleshoot Manual Scans
a | Description Firg Authentication Policy Reports Policy Elements
Authorization Policy Settings Profiling Policies
Troubleshoot BYOD Authorization Policy
Reports Troubleshoot
Cverview
S.etl.\ngs ) Identities Rep.ons
Dictionaries |dentity Groups St_atl_mgs
Guest Access Network devices Dictionaries
Overview Ext Id Sources Posture
Identities Client Provisioning Overview
Identity Groups Configure Network devices
Ext Id Sources Policy Elements Client Provisioning
Administration Authentication Policy Policy Elements
Network Devices Authorization Policy Posture Policy
Configure Reports Authentication Policy
Manage Accounts Settings Authorization Policy
Policy Elements Troubleshoot
Authentication Policy Reports
Authorization Policy + -
Reports Device Administration
Settings .
Overview
>
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2. Configure required fields and click Submit to add user

Metwork Access Users List > New Network Access User

¥ Network Access User

* Name | iseraduser

Status Enabled ~

Email |

¥ Passwords

Password Type: Internal Users -

Password Re-Enter Password
*Login Password | sesseses | [eseeesee | [ Generate Password |
Enable Password | | | | [ Generate Password |

¥ User Information

FirstName [ Cisco ISE |

LastName | Radius Ussd x |

¥ Account Options

Description |

Change password on next login O

¥ Account Disable Policy

O Disable account if date exceeds | 2017-05-00 {yyyy-mm-dd)
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Appendix C: Cisco ISE for RADIUS Users

Step 3: Configure Allowed Authentication Protocol Service
(PAP/CHAP/MS-CHAP)

1. Access Policy>Results under Policy Elements section. Select Allowed
Protocols under Authentication Dropdown from left pane. Click to Edit
Default Network Access and select CHAP. Xerus supports both PAP and
CHAP authentication types. In case CHAP authentication type is desired,
verify Global Authentication Type setting on Xerus RADIUS configuration is
set to CHAP as well as this step is completed on Cisco ISE 2.1.x server.

alaili  |dentity Services Engine

cisco Home » Context Visibility » Operations » Administration » Work Centers
Authentication  Authorization  Profiling  Posture  Client Provisioning | ~ Policy Elen  aythentication Authorization
Dictionaries » Conditions  + Results Profiling Posture
[ ] Client Provisioning Policy Elements
. Dictionaries
_— Allowed Protocols Services
~ Authentication For Policy Export go to Administration = System = Conditions.

Allowed Protocols
Edit opAdd [f3Duplicate Delete

» Authorization - -
[ | Semvice Name | Description

+ Profiling [0 Default Network Access Default Allowed Protocol Service

» Posture 0

Allowed Protocols Services List » Default Network Access
» Client Provisioning Allowed Protocols

Name Default Network Access

Description Default Allowed Protocol Service

w Allowed Protocols
Authentication Bypass
O Pprocess Hast Lookup 7
Authentication Protocols

Allow PAPIASCII
Allow CHAP
Allow MS-CHAPY1

0O
O Allow MS-CHAP2

Step 4: Create Authorization Profile

1. Access Policy>Results under Policy Elements, and from Authorization on
left pane, choose Authorization Profiles and click Add
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2. Under General Tab configure Policy Friendly Name.

- Identity Services Engine Home » Context Visibility » Operations + Administration » Work Centers
Authentication ~ Authorization  Profiing  Posture  Client Provisioning | ~ Policy Elen  Authentication Authorization
Dictionaries » Conditions  ~ Resulis Profiling Posture
[<] Client Provisioning Policy Elements
Dictionaries
» Authentication Standard Authorization Profiles Conditions
For Policy Export go to Administration = Syster
~ Authorization
| # Edit Add JLf5Duplicate | 3 Delete
Authorization Profiles f Eq’:‘
[]| Name Profile .l
Downloadable ACLs - )
[0 Blackhole_Wireless_Access il Cisco &3 |
» Profiling [ cisco_IP_Phones iis Cisco & |
isco W e T
> e [ cisco_webauth iy Cisco & |

3. Specify appropriate Profile name. Scroll down to Advanced Attributes
Settings section and click on drop down next to Select and Item text field.
Select Radius and from Submenu select Filter-ID--[11] option.

Authorization Profiles > New Authorization Profile
Authorization Profile

* Name |Raritan Dominion KXII_SXII Profi

Description
"Access Type  [ACCESS_ACCEPT -
) Dictionaries Radius
Network Device Profile & Cisco
R D) L)
A v —1 - -
Service Template [ ] U T
u AlcatetLucent ’ DNS-Server-1Pv6-Address-—-[169]
"] -Server-IPv6-Address--|
Track Movement [ ] i W Aba » ~ 797 ~
& EAP-Message--[79
w Brocade >
Passive Identity Tracking [] i ) u  Egress-VLAN-Name—[58]
u Cdsco »
W Egress-VLANID--[56]
w Csco-585M »
Error-Cause--[101
W Cisco-VPN3000 >
| H3C » d
» Common Tasks — R w Framed-AppleTalk-Link--[37]
@ Framed-AppleTalk-Network--[38)
W Juniper >
@ Framed-AppleTalk-Zone--[39]
W Microsoft »
& Framed-Compression--[13]
. . W Motorola-Symbol >
v Advanced Attributes Settings o Framed-Interface-1d--[96]
u Radius ¢ v
- o Framed-1P-Address—[8]

% [select an item =l 9|
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4. Verify in the text box that it correctly displays attribute name
Radius:Filter-ID. In the next test field, type attribute value
Raritan:G{KVM_Admin} and click anywhere on the page to set it. Confirm
Attribute Details display as shown below.

¥ Advanced Attributes Settings

i [Radius:Filter-ID )] = [Raritan:G{KVM_admin} Q|

v Attributes Details
Access Type = ACCESS ACCEPT

Filter-ID = Raritan:G{KVM_Admin}
5. Click Submit to create new Authorization profile and return to profile list

™
. . L . .
summary page. Verify profile name and mouse over “* icon for preview
of summary.

et |dentity Services Engine

Home » Context Visibility » Operations » Administration » Work Centers
Authentication  Authorization  Profiling  Posture  Client Provisioning = ~ Policy Elements
Dictionaries  » Conditions  + Results

» Authentication standard Authorization Profiles
For Policy Export go to Administration = System = Backup & Restore = Policy Export Page

~ Authorization

J# Edit Add Duplicate 3¢ Delete
Authorization Profiles - % EE‘

[ Name Profile a | Descripti
Downloadable ACLs . )
[ Blacknole_Wireless_Access dits Cisco &3 Default p
+ Profiling [ cisco_IP_Phones Wk Cisco & Default p
O cisco_WebAuth ]
» Posture - Standard Authorization Profile Details D4
[0 NSP_onboard
. o Name Raritan Dominion KXIII_SXII Profile
» Client Provisioning 0 Mon_Cisco_IP_Phones o
- - Description
Raritan Dominion KXII_SXII Profile &
) o Attributes Details
[ Raritan Dominion PX Profile LR
Access Type ACCESS_ACCEPT
[0 DenyAccess ~ _ ) )
- Radius:Filter-ID Raritan:G{KVM_Admin}
[ PemmitAccess

Step 5: Configure/Create Authorization Policy

1. Access Policy>Authorization to see policy listing

hatl |dentity Services Engine

Home » Context Visibility » Operations » Administration » Work Centers
Authentication = Authorization | Profiling  Pesture  Client Provisioning  » Policy Eler  Authentication
Profiling Posture

Authorization Policy

Client Provisioning Policy Elements
Define the Authorization Policy by configuring rules based on identity groups and/or other conditi Dictionaries
For Policy Export go to Administration = System = Backup & Restore = Policy Export Page Conditions
| First Matched Rule Applies - Results
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2.

Above.

Authorization Policy

Define the Authorization Policy by configuring rules based on identity groups andior other conditions. Drag and drop rules to change the order.
For Policy Export go o Adminisiration » System » Backup & Restore > Policy Export Page

First Matched Rule Applies ~

» Exceptions (0)

Conditions (identity groups and other conditions)

Blacklist - Wireless_Access T
Cisco-P-Phone then
Non_Cisco_Profiled_Phones then

Network Access Authentication Passed A0 Comoliant Devices then

Permissions

Cisco_IP_Phones
Non_Cisco_IP_Phenes

PermitAccess

New first row is added.

Standard
Status  Rule Name
Wireless Black List Default
Profiled Cisco [P Phones
Profiled Non Cisco IP Phones
L] Comoliant Devices Access
Status  Rule Name

Conditions (identity groups and other conditions)

& « || standard Rule 1

Blackhole_Wireless_Access

Next, click Edit dropdown in the first row and select Insert New Rule

Insert New Rule Above

Duplicate Above
Duplicate Below
Delete

Permissions

| f | Any & | | Condition(s)

S ]

3. Specify appropriate Policy name and Click on add ('_.U:) in Permission text
box. Select Standard and from Submenu should appear with list of
available profiles. Select Raritan Dominion KXIII_SXII Profile and click
Done..

Authorization Policy

Define the Authorization Policy by configuring rules based on identity groups and/or other conditions. Drag and drop rules to change the order.
For Policy Export go to Administration = System > Backup & Restore = Policy Export Page

‘ First Matched Rule Applies -

» Exceptions (0)
Standard

Status

#» v | Dominion KXIII_SXII Policy

Rule Name

Dominion PX Palicy

Wireless Black List Default
Profiled Cisco IP Phones
Profiled Non Cisco IP Phones

@ Compliant_Devices_Access

@ Employee_EAP-TLS

@ Employee_Onboarding

@ Wi-Fi_Guest_Access

@ Wi-Fi_Redirect_to_Guest_Login

Basic_Authenticated_Access
Status  Rule Name

then | AuthZ Pr... P

Conditions (identity groups and other conditions) Permissions
’ |Any < [and | Condition(s) o ‘ Gen [ Authz Pr.. = |
Any
Blacklist A1l Wireless_Access gy  [electan tem O =4

Profile Standard
Cisco-IP-Phone Ci

( p) (
Non_Cisco_Profiled_Phones N g {é}_ E=R
Network_Access_Authenfication_Passed A0 Compliant_Devices PermitAccess (5 Sety e * @

[ standard » Cisco_IP_Phones

Wireless_802.1X AND BYCD_is_Registered AND EAP-TLS AND
MAC_in_SAN

Wireless_802.1X AND EAP-MSCHAPv2

Guest_Flow AND Wireless_MAB

Wireless_MAB

Network_Access_Authenfication_Passed

Conditions (identity groups and other conditions)

~ | Dominion KXill SXII Policy

PermitAccess AND BYOD
NSP_Onboard AND BYOD
PermitAccess AND Guests
Cisco_WebAuth

PermitAccess

Permissions

e

and | Condition(s)

Dominion PX Policy

c(}>| then

Any

4. Click Save to create policy.

then Rantan Dominion PX
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(G Gisco_webauth
DenyAccess

@ NsP_Onboard

(&) Non_Cisco_IP_Phanes

() Raritan Dominion KXIIL

Permission Det:
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Appendix C: Cisco ISE for RADIUS Users

Troubleshooting Tips
1. Verify from Live Logs under Operations> RADIUS that correct Authorization

Policy is being applied. Click Details icon 9 to see more information

License Warning

'Eln'n'"'r':' Identity Services Engine Home + Context Visibility ~ Operations » Policy + Administration » Work Centers
*RADIUS | TC-NACLivelogs » TACACS Reporis » Troublesl RaApIUS TC-NAC Live Logs
Live Logs  Live Sessions e g - Reports
— 4 Ive Sessions
Adaptive Network Control
TACACS 5 N N
Policy List ] Client Stopped Responding €& Repeat Counter @

Misconfigured Supplicants € .
Live Logs Endpoint Assignment

O Troubleshoot 0 0
Diagnostic Tools

Download Logs
Refresh | Every 1 minute Show  Latest 20 records

= Refresh © Reset Repeat Counis

Time Status Details Repeat. Identity End.. End.. Authenticat.. Authorization Policy Authorization Profiles 1P Addr
x

Mar 10, 2017 01:53:55.700 PM ﬂ a Default == D__ I Default == Dominion KXIII_SXII Policy I |F€an’tan Dominion KXIII_SXII Profile

Mar 10, 2017 01:53:27.043 PM [-] a admin Default == D...

2. User authorization may fail if incorrect policy is applied. Check the
following:
= Moving policy higher up in the order (in case of multiple policy sets)

= More appropriate conditions in policy coupled with device type and
location when adding KXI11/SXII as a network device in Cisco ISE
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Appendix D Specifications
In This Chapter
[ e 1V T <SPPSR 190
Yo ] 1V YRR 211
BSIMI Certification .......uuveeeie e 214
Hardware
Dimensions and Physical Specifications
Dominion KX lll Description  Power & Dimensions  Weight Operating Humidity
model heat (WxDxH) temp
dissipation
DKX3-108 = 8server Dual Power 17.3" x 8.60lbs 02-45°C 0-85 % RH
ports 110Vv/240V, 13.15" x
= 1remote 50-60Hz 1.73"
user 1.8A60W 52 4394334x44  3.9kg 32¢-1132F
= 1local KCAL mm
port for
use at the
rack
DKX3-116 = 16server Dual Power 17.3"x 8.60lbs 02-45°C 0-85 % RH
ports 110V/240V, 13.15" x
= 1remote 50-60Hz 1.73"
user 1.8A60W 52 4394334544  3.9kg 329-113°F
= 1local KCAL mm
port for
use at the
rack
DKX3-132 = 32server Dual Power 17.3"x 8.60lbs 02-45°C 0-85 % RH
ports 110Vv/240V, 13.15" x
= 1remote 50-60Hz 1.73"
user 1.8A60WS2  4394334x44  3.9kg 320-113¢F
= 1local KCAL mm
port for
use at the
rack
DKX3-216 = 16server Dual Power 17.3" x 9.08lbs 02-45°C 0-85 % RH
ports 110Vv/240V, 13.15" x
= 2remote 50-60Hz 1.73"
Raritan 150
(U]
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Dominion KX IlI

model

DKX3-232

DKX3-416

DKX3-432

DKX3-464

DKX3-808

Raritan.
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Description

users

= 1local
port for
use at the
rack

= 32 server
ports

= 2 remote
users

= 1 local
port for
use at the
rack

= 16 server
ports

= 4 remote
users

= 1local
port for
use at the
rack

= 32 server
ports

= 4 remote
users

= 1local
port for
use at the
rack

= 64 server
ports

= 4 remote
users

= 1local
port for
use at the
rack

=  8server
ports

= 8 remote

Power &
heat
dissipation
1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110v/240V,
50-60Hz

Dimensions
(WxDxH)

439x334x44
mm

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3"x
13.15" x
1.73"

439x334x44
mm

17.3"x13.3"
x 3.5"

439x338x89
mm

17.3" x
13.15" x
1.73"

Weight

4.12kg

9.08lbs

4.12kg

9.08lbs

4.12kg

9.08lbs

4.12kg

12.391bs

5.62kg

9.96lbs

Appendix D: Specifications

Operating Humidity
temp

322-1139F

02-45¢C 0-85 % RH
329-1139F

02-45°C 0-85 % RH
329-113°F

02-45°C 0-85 % RH
322-113°F

02-45°C 0-85 % RH
329-113°F

09-45°C 0-85 % RH
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Dominion KX IlI
model

DKX3-832 -

DKX3-864 "

Description

users

1 local
port for
use at the
rack

32 server
ports
8 remote
users

1 local
port for
use at the
rack

64 server
ports
8 remote
users

1 local
port for
use at the
rack

Power &
heat
dissipation
1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110Vv/240V,
50-60Hz

1.8A 60W 52
KCAL

Dimensions
(WxDxH)

439x334x44
mm

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3"x13.3"
x 3.5"

439x338x89
mm

Weight

4.52kg

9.96lbs

4.52kg

12.391bs

5.62kg

Operating Humidity

temp

329-113¢9F

02-45°C 0-85 % RH

329-113¢9F

02-452C 0-85 % RH

322-113°F
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Appendix D: Specifications

Supported Target Server Video Resolutions

When using digital CIMs, you set the target's video resolution to match your
monitor's native display resolution. The native display resolution is set when
configuring ports for digital CIMs (see Configure the CIM Target Settings).

Following is a complete list of supported video resolutions when accessing a
target from the Remote Console.

e 640x350@70Hz
e 640x350@85Hz
e 640x400@56Hz
e 640x400@84Hz
e 640x400@85Hz
e 640x480@60Hz
e 640x480@66.6Hz
e 640x480@72Hz
e 640x480@75Hz
e 640x480@85Hz
e 720x400@70Hz
e 720x400@84Hz
e 720x400@85Hz
e 800x600@56Hz
e 300x600@60Hz
e 800x600@70Hz
e 800x600@72Hz
e 800x600@75Hz
e 800x600@85Hz
e 800x600@90Hz
e 800x600@100Hz
o 832x624@75.1Hz
e 1024x768@60Hz
e 1024x768@70Hz
e 1024x768@72Hz
e 1024x768@85Hz
e 1024x768@75Hz
e 1024x768@90Hz
e 1024x768@100Hz
e 1152x864@60Hz
e 1152x864@70Hz
e 1152x864@75Hz
e 1152x864@85Hz
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1152x870@75.1Hz
1280x720@60Hz
1280x800@60Hz
1280x960@60Hz
1280x960@85Hz
1280x1024 @60Hz
1280x1024@75Hz
1280x1024@85Hz
1360x768@60Hz
1366x768@60Hz
1368x768@60Hz
1400x1050@60Hz
1440x900@60Hz
1600x900 @60Hz
1600x1200@60Hz
1680x1050@60Hz
1920x1080@50Hz
1920x1080@60Hz

1920x1200@60Hz (Requires Reduced Blanking Time)

For 1920x1200@60Hz, you must use a digital CIM and set the CIM’s

preferred resolution to 1920x1200@60Hz.

KX 11l Supported Local Port DVI Resolutions

Following are the resolutions supported when connecting to a DVI monitor
from the Local port.

1920x1080@60Hz
1280x720@60Hz

1024x768@60Hz (default)

1024x768@75Hz
1280x1024 @60Hz
1280x1024@75Hz
1600x1200@60Hz
800x480@60Hz
1280x768@60Hz
1366x768@60Hz
1360x768@60Hz
1680x1050@60Hz
1440x900@60Hz
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Target Server Video Resolution - Supported Connection Distances and Refresh
Rates

The maximum supported distance is a function of many factors including the
type/quality of the Cat5 cable, server type and manufacturer, video driver and
monitor, environmental conditions, and user expectations.

The following table summarizes the maximum target server distance for
various video resolutions and refresh rates:

Target server video resolution Maximum distance
1024x768@60Hz (and below) 150' (45 m)
1280x1024@60Hz 100' (30 m)
1280x720@60Hz 75' (22 m)
1600x1200@60Hz 50' (15 m)
1920x1080@60Hz 50' (15 m)

See Supported Target Server Video Resolutions (on page 193) for the video
resolutions supported by the KX II.

Note: Due to the multiplicity of server manufacturers and types, OS versions,
video drivers, and so on, as well as the subjective nature of video quality,
performance cannot be guaranteed across all distances in all environments.

Supported Computer Interface Module (CIMs) Specifications

Digital CIMs support Display Data Channels (DDC) and Enhanced Extended Display
Identification Data (E-EDID). However, they do not support HDCP (high bandwidth
digital copy protection) or embedded audio.

Note: Both plugs must be plugged in for the HDMI and DVI CIMs.

CIM model Description Dimensions (WxDxH) Weight
D2CIM-DVUSB Dual USB CIM for: = 1.7"x3.5"x0.8" = (0.25lb
= 0OSvirtual media = 43x90x19mm = 0.11kg
=  Smartcard/CAC
= Audio

= Absolute Mouse Synchronization
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CIM model Description Dimensions (WxDxH) Weight
D2CIM-VUSB USB CIM for: = 1.3"x3.0"x0.6" = 0.20lb
= OSvirtual media = 33x76x15mm = 0.09g

= Absolute Mouse Synchronization

D2CIM-VUSB-USBC USB CIM for: = 1.7"x3.5"x0.8" = 0.25lb
= USB-C ports on Macs and PCs ® 43x90x19mm * 0.11kg
= USB keyboard, mouse, and virtual

media

= DisplayPort video

= No Audio or Smartcard

D2CIM-DVUSB-DP Digital CIM that provides = 1.7"x3.5"x0.8" = 0.25lb
digital-to-analog conversion and = 43x90x19mm = 0.11kg
support for:

= (OSvirtual media

=  Smartcard/CAC

= Audio

= Absolute and Relative Mouse
Synchronization

TR |
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CIM model
D2CIM-DVUSB-HDMI

D2CIM-DVUSB-DVI

DCIM-PS2

Raritan.

Abrand of Olegrand’

Appendix D: Specifications

Description Dimensions (WxDxH) Weight
Digital CIM that provides = 1.7"x3.5"x0.8" = 0.25b
digital-to-analog conversion and = 43x90x19mm = 0.11kg

support for:

= OS virtual media

= Smartcard/CAC

= Audio

= Absolute and Relative Mouse
Synchronization

Digital CIM that provides = 1.7"x3.5"x0.8" = 0.25b
digital-to-analog conversion and = 43%x90x 19mm » 0.11kg
support for:

= OSvirtual media

=  Smartcard/CAC

= Audio

= Absolute and Relative Mouse
Synchronization

CIM for PS2 = 1.3"x3.0"x0.6" = 0.20lb
= 33x76x15mm = 0.09kg
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CIM model Description Dimensions (WxDxH) Weight

DCIM-USBG2 CIM for USB and Sun USB = 1.3"x3.0"x0.6" = 0.20lb
= 33x76x15mm = 0.09g

Supported Digital Video CIMs for Mac

Use a digital video CIM to connect to the following Mac® ports:

Mac port CiMm

USB-C D2CIM-VUSB-USBC
DVI D2CIM-DVUSB-DVI
HDMI D2CIM-DVUSB-HDMI

DisplayPort or Thunderbolt D2CIM-DVUSB-DP

If the Mac’s HDMI or DisplayPort video has a mini connector, a passive adapter
cable may be required to connect to the full sized HDMI and DisplayPort plugs
on the digital CIMs.

Alternatively, use the Mac VGA adapter with the D2CIM-VUSB or
D2CIM-DVUSB. Note that this may be less reliable and the video quality may
suffer.

For information on established modes supported by the KX 111 2.5.0 (and later)
for Mac, see Digital CIM Established and Standard Modes (on page 199).
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Digital CIM Timing Modes
Following are the default timing modes that are used when the KX 111
communicates with a video source via a digital CIM.

The timing mode that is used is dependent on the native resolution of the
video source.

o 1024x768@60Hz

e 1024x768@70Hz

o 1152x864@60Hz

e 1280x720@60Hz

e 1280x800@60HZ

e 1280x960@60Hz

e 1280x1024@60Hz (default resolution applied to digital CIMs)
e 1360x768@60Hz

e 1400x1050@60Hz

e 1440x900@60Hz

e 1600x900@60Hz

e 1600x1200@60Hz

e 1680x1050@60Hz

e 1920x1080@50Hz

e 1920x1080@60Hz

e 1920x1200@60Hz

See Configuring CIM Ports for more information.

Digital CIM Established and Standard Modes

The following additional established and standard resolutions and timing
modes are supported by the KX 111 3.0.0 (and later).
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Digital CIM Established Modes

e 720x400@70Hz IBM, VGA

e 640x480@60Hz IBM, VGA

e 640x480@67Hz Apple Mac’ Il
e 640x480@72Hz VESA

e 640x480@75Hz VESA

e 800x600@56Hz VESA

e 800x600@60Hz VESA

e 800x600@72Hz VESA

e 800x600@75Hz VESA

e 832x624@75Hz Apple Mac Il
e 1024x768@60Hz VESA

e 1024x768@70Hz VESA

e 1024x768@75Hz VESA

e 1280x1024@75Hz VESA

e 1152x870@75Hz Apple Mac Il

Digital CIM Standard Modes

e 1152x864@75Hz VESA
e 1280x960@60Hz VESA
e 1280x1024@60Hz VESA
e 1360x768@60Hz VESA
e 1400x1050@60Hz VESA
e 1440x900@60Hz VESA
e 1600x1200 @60Hz VESA
e 1680x1050@60Hz VESA
e 1920x1080@60Hz VESA

DVI Compatibility Mode

DVI Compatibility Mode may be required if you are using an HDMI CIM to
connect to a Dell Optiplex target with an Intel video card, or a Mac® Mini with
an HDMI video port.

Selecting this mode ensures a good video quality from the targets.

See Configuring CIM Ports  in online help.
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Supported Remote Connections

Remote connection

Network

Protocols

Details

10BASE-T, 100BASE-T, and 1000BASE-T (Gigabit)

Ethernet

TCP/IP, UDP, SNTP, HTTP, HTTPS, RADIUS, LDAP/LDAPS

Network Speed Settings

KX 11l network speed setting

Network
switch port
setting

Raritan.
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Auto
Auto
1000/Full
100/Full

100/Half
100/Half
10/Full

10/Half
10/Half

Legend:

1000/Full

100/Half

No
Communicati
on

100/Full

No
Communicati
on

No
Communicati
on

100/Half
100/Half

No
Communicati
on

No
Communicati
on

10/Full

No
Communicati
on

10/Half
10/Half

No
Communicati
on

No
Communicati
on

No
Communicati
on

No
Communicati
on

No
Communicati
on

No
Communicati
on

Does not function as expected

No
Communicati
on

No
Communicati
on
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Supported

Functions; not recommended

NOT supported by Ethernet specification; product will
communicate, but collisions will occur

Per Ethernet specification, these should be “no
communication,” however, note that the KX Ill behavior
deviates from expected behavior

Note: For reliable network communication, configure the KX Ill and the LAN
switch to the same LAN Interface Speed and Duplex. For example, configure the
KX Ill and LAN Switch to Autodetect (recommended), or set both to a fixed
speed/duplex such as 100MB/s/Full.

Dell Chassis Cable Lengths and Video Resolutions

In order to maintain video quality, it is recommended to use the following cable
lengths and video resolutions when you are connecting to Dell® blade chassis

from the KX 111

Video resolution Cable length
1024x768 @60Hz 50' (15.24 m)
1280x1024@60Hz 50' (15.24 m)
1600x1200@60Hz 30'(9.14 m)

Smart Card Minimum System Requirements

Local Port Requirements

The basic interoperability requirement for local port attachment to the KX Ill is:

e All devices (smart card reader or token) that are locally attached must be
USB CCID-compliant.
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Target Server Requirements

When using smart card readers, the basic requirements for interoperability at
the target server are:

e The IFD (smart card reader) Handler must be a standard USB CCID device
driver (comparable to the generic Microsoft” USB CCID driver).

e Adigital CIM or D2CIM-DVUSB (Dual-VM CIM) is required and must be
using firmware version 3A6E or later.

e Blade chassis server connections, where a CIM per blade is used, are
supported.

e Blade chassis server connections, where a CIM per chassis is used, is only
supported for IBM* BladeCenter® models H and E with auto-discovery
enabled.

Remote Client Requirements
The basic requirements for interoperability at the remote client are:

e The IFD (smart card reader) Handler must be a PC/SC compliant device
driver.

e The ICC (smart card) Resource Manager must be available and be PC/SC
compliant.

e The JRE" Java” 1.8 with smart card APl must be available for use by the
client application.

Remote Linux Client Requirements

If you are using a Linux® client, the following requirements must be met to use
smart card readers with the KX 11l device.

Note: User login to client, on smart card insertion, may take longer when 1 or
more KVM sessions are actively in place to targets. As the login process to
these targets is also under way.

e PC/SC Requirements

Operating system Required PC/SC

RHEL 5 pcsc-lite-1.4.4-0.1.el5

SuSE 11 pcsc-lite-1.4.102-1.24
Fedora® Core 10 pcsc-lite-1.4.102.3.fc10.i386
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Type
USB

usB

usB

USB

USB Keyboard/Card
reader combo

USB Keyboard/Card
reader combo

USB reader for
SIM-sized cards

Integrated (Dell
Latitude D620)

PCMCIA
PCMCIA

e Create alJava’ Library Link

A soft link must be created to the libpcsclite.so after upgrading RHEL 4,
RHEL 5 and FC 10. For example, In —s /usr/lib/libpcsclite.so.1
/usr/lib/libpcsclite.so, assuming installing the package places the libraries
in /usr/lib or /user/local/lib

e PC/SC Daemon

When the pcsc daemon (resource manager in framework) is restarted,

restart the browser

Supported Smart Card Readers

Vendor

SCM Microsystems

Activldentity®

Activldentity

Gemalto®

Dell®

Cherry GmbH

Omnikey

02Micro

Activildentity

SCM Microsystems

Model
SCR331

Activldentity USB Reader v2.0

Activldentity USB Reader v3.0

GemPC USB-SW

USB Smart Card Reader Keyboard

G83-6744 SmartBoard

6121

07776

Activldentity PCMCIA Reader
SCR243

Verified

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Remote only

Remote only

Remote only

Note: SCM Microsystems SCR331 smart card readers must be using SCM
Microsystems firmware v5.25.
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Unsupported Smart Card Readers
The following card readers are not supported.

If a smart card reader does not appear in the supported smart card readers
table or in the unsupported smart card readers table, it's function cannot be
guaranteed.

Type Vendor Model Notes
USB Keyboard/Card HP® ED707A No interrupt endpoint
reader Combo => not compatible with

Microsoft® driver

USB Keyboard/Card SCM SCR338 Proprietary card reader
reader Combo Microsystems implementation (not
CCID-compliant)

USB Token Aladdin® eToken Proprietary
PRO™ implementation

Audio Playback and Capture Recommendations and Requirements

Audio Level

e Set the target audio level to a mid-range setting.
For example, on a Windows’ client, set the audio to 50 or lower.

This setting must be configured through the playback or capture audio device,
not from the client audio device control.

Recommendations for Audio Connections when PC Share Mode is Enabled

If you are using the audio feature while running PC Share mode, audio playback
and capture are interrupted if an additional audio device is connected to the
target.

For example, User A connects a playback device to Targetl and runs an audio
playback application then User B connects a capture device to the same target.
User A's playback session is interrupted and the audio application may need to
be restarted.

The interruption occurs because the USB device needs to be re-enumerated
with the new device configuration.

It may take some time for the target to install a driver for the new device.

Audio applications may stop playback completely, go to the next track, or just
continue playing.

The exact behavior is dependent on how the audio application is designed to
handle a disconnect/reconnect event.
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Bandwidth Requirements

The table below details the audio playback and capture bandwidth
requirements to transport audio under each of the selected formats.

Audio format Network bandwidth requirement
44.1 KHz, 16bit stereo 176 KB/s

44.1 KHz, 16bit mono 88.2 KB/s

2.05 KHz, 16bit stereo 88.2 KB/s

22.05 KHz, 16bit mono 44.1 KB/s

11.025 KHz, 16bit stereo 44.1 KB/s

11.025 KHz, 16bit mono Audio 22.05 KB/s

In practice, the bandwidth used when an audio device connects to a target is
higher due to the keyboard and video data consumed when opening and using
an audio application on the target.

A general recommendation is to have at least a 1.5MB connection before

running audio/video.

e However, high video-content, full-color connections using high-target
screen resolutions consume much more bandwidth and impact the quality
of the audio considerably.

e Set Smoothing to High. This will improve the appearance of the target
video by reducing displayed video noise

e Under Video settings, set the Noise Filter to its highest setting of 7 (highest
value) so less bandwidth is used for target screen changes

Audio in a Mac Environment
Following are known issues in a Mac® environment.

e  On Mac clients, only one playback device is listed on the Connect Audio
panel. The device listed is the default and is displayed on the Connect
Audio panel as Java Sound Audio Engine.

e Using audio on a Mac target through Skype® may cause the audio to be
corrupted.
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Number of Supported Audio/Virtual Media and Smartcard Connections

Following are the number of simultaneous Audio/Virtual Media and Smartcard
connections that can be made from a client to a target:

e 2 Virtual Media devices

e 1 Virtual Media + 1 smart card reader

e 1 Virtual Media + 1 audio device (w. playback and capture interfaces)

e 1smartcard reader + 1 audio device (w. playback and capture interfaces)

Certified Modems

e USRobotics® 56K 5686E

e ZOOM°v90

e ZOOM V92

e USRobotics Sportster® 56K
e  USRobotics Courier” 56K

KX 11l Supported Keyboard Languages

The KX Ill provides keyboard support for the languages listed in the following
table.

Note: You can use the keyboard for Chinese, Japanese, and Korean for display
only; local language input is not supported at this time for the KX Il Local
Console functions. For more information about non-US keyboards, see
Informational Notes (on page 215).

Note: It is strongly recommended that you use system-config-keyboard to
change languages if you are working in a Linux environment.

Language Regions Keyboard layout

US English United States of America and most  US Keyboard layout
of English-speaking countries: for
example, Canada, Australia, and
New Zealand.

US English United States of America and most  US Keyboard layout
International  of English-speaking countries: for
example, Netherlands

UK English United Kingdom UK layout keyboard
Chinese Hong Kong S. A. R., Republic of Chinese Traditional
Traditional China (Taiwan)

Chinese Mainland of the People’s Republic  Chinese Simplified
Simplified of China
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Keystroke

Press C during
startup

Press D during
startup

Press Option-

208

Language Regions

Korean South Korea

Japanese Japan

French France

German Germany and Austria

French Belgium

Norwegian Norway

Danish Denmark

Swedish Sweden

Hungarian Hungary

Slovenian Slovenia

Italian Italy

Spanish Spain and most Spanish speaking
countries

Portuguese Portugal

Keyboard layout
Dubeolsik Hangul

JIS Keyboard

French (AZERTY) layout
keyboard.

German keyboard
(QWERTZ layout)

Belgian
Norwegian
Danish
Swedish
Hungarian
Slovenian
Italian

Spanish

Portuguese

Mac Mini BIOS Keystroke Commands

The following BIOS commands have been tested on Intel-based Mac® Mini
target servers and Mac Lion® servers running Mac Snow Leopard®. The servers
were attached to a KX Il with D2CIM-DVUSB and D2CIM-VUSB CIMs. See below
for the supported keys and any notes.

Description

Start up from a bootable
CD or DVD, such as the
Mac OS X Install disc

Start up in Apple
Hardware Test (AHT)

Reset NVRAM

Virtual Media CIM

Yes

Yes

May need BIOS Mac
profile for the
mouse to work

Dual Virtual Media Mac Lion Server

cim

Yes

Yes

May need BIOS
Mac profile for
mouse to work

Yes

HDMI CIM

Yes

Yes

May need BIOS
Mac profile for the
mouse to work

Yes
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Keystroke

Command-P-R until
you hear startup

sound a second time.

Press Option during
startup

Press Eject, F12, or
hold the mouse
button

Press N during
startup

Press T during
startup

Press Shift during
startup

Press Command-V
during startup

Press Command-S
during startup

Press Option-N
during startup

Press Command-R
during startup

Raritan.
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Description

Start up in Startup

Manager, where you can
select a Mac OS X volume

to start from

Ejects any removable

media, such as an optical

disc

Start up from a
compatible network
server (NetBoot)

Start up in Target Disk
mode

Start up in Safe Boot
mode and temporarily
disable login items

Start up in Verbose
mode.admin

Start up in Single-User
mode

Start from a NetBoot
server using the default
boot image

Virtual Media CIM

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Start from Lion Recoveryl N/A

Appendix D: Specifications

Dual Virtual Media Mac Lion Server

M

Yes

Yes

Yes

Yes

Yes

Yes

Yes

N/A

HDMI CIM

Yes

Yes

Yes

Known issue with
LION to boot to
safe mode. "Safe
Mode" in red does
not appear for Lion

Yes

Yes

Yes

Yes

Using a Windows Keyboard to Access Mac Targets

A Windows® keyboard can be used to access a Mac® connected to a KX IlI.
Windows keys are then used to emulate the special Mac keys. This is the same

as connecting a Windows keyboard directly to the Mac.
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TCP and UDP Ports Used

P Listening TCP Ports:

* 80: http access (configurable)

* 443: https access (configurable)

* 5000: CC-SG and KXUS access (configurable)
* 22: SSH access (if enabled, configurable)

* 68: DHCP access (if DHCP is enabled)

P> Listening UDP Ports:
*162: SNMP access (if SNMP Agent is enabled)
* 5001: CC_SG event notification (if under CC-SG management)

P> TCP Ports Outgoing:

* 389: LDAP authentication (if LDAP is enabled, configurable)

* 636: LDAPS/StartTLS (if LDAPS/StartTLS is enabled, configurable)
* 25: SMTP (email) (if enabled)

* 445: SMB (Windows File System) access (Remote ISO image access).

>  UDP Ports Outgoing:

* 514: Syslog (if enabled, configurable)

* 5001: CC_SG event notification (if under CC-SG management, configurable)
* 1812: RADIUS authentication (if enabled, configurable)

* 1813: RADIUS authentication (if enabled, configurable)
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Software

Supported Operating Systems, Browsers and Java Versions

> Java:

Oracle Java™ Runtime Environment (JRE) version 8 is supported up to
1.8.0_351 at the time of this release.

Future Java versions should work correctly assuming no incompatible changes
are made by the Java developers. For any issues, please contact Technical
Support.

e  For best results, we recommend that Java Plug-in Caching is not enabled.

e  For greater security and fewer Java and browser warning messages,
Raritan recommends customers upload a SSL certificate to each KX IlI
switch.

e Customers need to affirmatively click through all security warnings for the
Raritan Java applets to load. See www.raritan.com/java for more
information.

> Browsers:
Supported browsers, see the Release Notes for latest supported versions:
e  Microsoft Edge
e  Firefox
e Chrome
e Safari
For more details on compatible browsers for your OS, see the table below.

The Active KVM Client (AKC), the native Windows Client, requires Internet
Explorer or Edge and Microsoft .NET Framework versions 4.5 and above, and is
supported on Windows 7/8/10 desktops.

Note: These support statements do not apply to the KX Ill when used with CC-SG.
Check the CC-SG Release Notes and Compatibility Matrix.

Operating Systems Browsers Java

Windows 10 Windows Edge Java 1.8 or later for
Windows 8" 64-bit Internet Explorer VKC

Windows 7° Home Premium SP1 64-bit Chrome Java 1.8.0_151 or
Windows 7 Ultimate SP1 64-bit Firefox later for VKCs
Windows 7 Ultimate 32-bit

openSUSE’ 15 Firefox

Fedora® 32 Firefox
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Operating Systems
Red Hat 7.5

Mac 10.14, 10.15

Solaris® 10 64-bit

212

Browsers Java

Firefox

Safari
Chrome

Firefox

Firefox

JRE Requirements and Browser Considerations for Mac

Java Runtime Environment Requirements for Mac

Install Java Runtime Environment 8 (JRE)® on PCs and Macs® when using the
Virtual KVM Client (VKC) to access target devices via KX Il

This ensures in order to provide high performance, KVM-over-IP video
processing when remotely accessing target devices/PCs/Macs.

The latest version of JRE for Mac can be downloaded from the Oracle Support
website.

Browser Considerations for Mac

Java may be disabled by default in certain browsers. Enable Java and accept all
security warnings in order to use KX I11.

Certain versions of Safari® block Java for security reasons. Use Firefox® instead
in this case.

Additionally, you may be required to navigate through a number of messages.
Select 'Do Not Block' if these messages are displayed.

Multi-Language Keyboard JRE Requirement

In order for multi-language keyboards to work in the KX 1ll and Virtual KVM
Client (VKC), install the multi-language version of JRE™.
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Events Captured in the Audit Log and Syslog

Following is a list and description of the events that are captured by the KX 111
audit log and syslog:

Access Login - A user has logged in to the KX 11l

Access Logout - A user has logged out of the KX III

Active USB Profile - The USB profile is active

CIM Connected - A CIM was connected

CIM Disconnected - A CIM was disconnected

Connection Lost - The connection to the target was lost
Disconnected User - A user was disconnected from a port
Duplicate CIM Serial - A CIM has same serial number with other CIM.
End CC Control - CC-SG management ended

Login Failed - User login failed

Password Changed - Password change occurred

Port Connect - Port was connected

Port Disconnect - Port was disconnected

Port Status Change - Change in the port status

Scan Started - A target scan was started

Scan Stopped - A target scan was stopped

Session Timeout - A session timeout occurred

USB Profile Set Modify Failed - Failed to change USB Profile Set.
USB Profile Set Modified - USB Profile Set was modified.
USB Net Present - A broadband modem is plugged in.
USB Net Absent - A broadband modem is unplugged.

VM Image Connected - A VM image was connected

VM Image Disconnected - A VM image was disconnected

802.1X Authentication Failed, CA Certificate uploaded for 802.1X
authentication, Client Certificate uploaded for 802.1X authentication,
Client Key uploaded for 802.1X authentication

213



Appendix D: Specifications

BSMI Certification

Equipment name

Type designation (Type)

WAL KVM-over-IP ST EHE2E A (AR DKX32F (AFIERERRE)

RAMEREIZFHE
Restricted substances and its chemical symbols

g 7 Uni R | BRME | SR M
P70 Unit A Lead FKMercury | $%Cadmium | Hexavalent Polybrominated | Polybrominated

(Pb) (He) {Cd) chromium biphenyls diphenyl ethers

6 (FPEE) (PBIE)

T - O O O O ©
TARASE | — O O O O O
s O O O O O O
i O 0 O O O O
At O O O O O O

{ﬁ B

reference percentage value of presence condition.
#AL O GERARAWETZE SRS I ABEESRETARME -

Note 2 1 “o7 indicates that the percentage content of the restricted substance does not exceed the percentage of reference value of presence.

HEL =" AR A Y AHREE -

Note 3 : The “—” indicates that the restricted substance corresponds to the exemption.

HAL "RE0Iwt %" A TRE0N R GERANTZE SRS ERLFE SRS EEAR

Note 1 ! “Exceeding 0.1 wt %7 and “exceeding 0.01 wt %7 indicate that the percentage content of the restricted substance exceeds the

Ry AR

DKX3-108 DKX3-116 DKX3-132
DKX3-216 DKX3-232 DKX3-416
DKX3-432 DKX3-464 DKX3-808
DKX3-832 DKX3-864
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Overview

This section includes important notes on KX Ill usage. Future updates will be
documented and available online through the Help link in the KX 1ll Remote
Console interface.

Note: Some topics in this section reference other multiple Raritan appliances
because various appliances are impacted by the information.

Java Runtime Environment (JRE) Notes

Raritan.
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Disable Java Caching and Clear the Java Cache

It is highly recommended that you disable Java caching in Microsoft Windows®,
and clear the Java” cache.

P> To disable Java caching and clear the cache:
From the Windows Start menu, click Control Panel.

2. Double-click on the Java icon to launch it. The Java Control Panel dialog
appears.

3. Todisable Java caching:

a. From the General tab, click the Settings button. The Temporary Files
Settings dialog appears.

b. Click the View Applets button. The Java Applet Cache Viewer opens.

c. Deselect the Enable Caching checkbox if it is already checked.
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d. Click OK.
4. To clear the Java cache:

a. From the Temporary Files Settings dialog, click the Delete Files button.
The Delete Temporary Files dialog appears.

b. Select the temporary files that you want to delete.
c. Click OK.

Java Not Loading Properly on Mac

If you are using a Mac® and see the following message when connecting to a
device from the KX Il Port Access Table, Java™ is not loaded properly:

"Error while getting the list of open targets, please try again in a few seconds".

If this occurs, check your Java installation from this website:
http://www.java.com/en/download/testjava.jsp
http://www.java.com/en/download/testjava.jsp

If your Java applet is inactive, it can be enabled from this page. If it is not
installed correctly, a message lets you know and you can then reinstall Java.

AKC Download Server Certification Validation IPv6 Support Notes

If you are connecting to a KX Il standalone device and support for AKC
download server certificate validation is enabled, the valid IPv6 format to
generate the certificate is either:

e CN =[fd07:02fa:6cff:2500:020d:5dff:£fe00:01c0] when
there is a leading 0
or

e CN =[fd07:02fa:6cff:2500:020d:5dff:0000:01c0] when
there is no zero compression

Dual Stack Login Performance Issues

If you are using the KX lll in a dual stack configuration, it is important you
configured the domain system (DNS) correctly in the KX IIl in order to avoid
delays when logging in.

See Tips for Adding a Web Browser Interface for information on configuring
your DNS in KX III.
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CIM Notes

Windows 3-Button Mouse on Linux Targets

When using a 3-button mouse on a Windows® client connecting to a Linux®
target, the left mouse button may get mapped to the center button of the
Windows client 3-button mouse.
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Target Video Picture Not Centered (Mouse Out of Synch)
At certain resolutions when using an HDMI or DVI CIM with the KX IlI:

e The video display may not be centered properly - black rectangles can be
seen at the edges of the screen

e The mouse on the target may appear to be slightly out of synch

If either or both of these occur, you may be able to correct this by adjusting the

display scaling options from the target computer’s video controller software.

For example, if your target computer uses the Catalyst Control Center video
controller, adjust the Underscan/Overscan setting as needed.

Powerstrip is not detected

When the PowerCIM-PDU is disconnected physically from the KX3, the PDU is
still listed in the PowerStrip Device drop-down list with a "Powerstrip is not
detected, please check!" message that does not disappear.

» To solve:

In the port configuration page for the port, click Reset To Default.

Virtual Media Notes
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Cannot Connect to Drives from Linux Clients

If you cannot connect to a virtual media drive on a target server when you
connect from a client running Linux® Fedora™ 18 with Java™ 1.8 (update 45 and
later), disable SELinux in Fedora 18 on the client to resolve the problem.

Cannot Write To/From a File from a Mac Client

If you are connecting to the KX Il from a Mac® 10.8.5 client running Safari with
Java™ 1.8 and cannot write to/from a file on a KX2 or KX3 target server or access
virtual media, do the following to correct this:

1. In Safari, select Preferences.

2. Under the Security tab, select Manage Website Settings.
3. Click on "Website for KX2 or KX3".
4

Select "Run in unsafe mode" from the drop-down.

Note: In Safari 10.0, "Run in safe mode" is now hidden as an option for
Plugin-Settings. Hold the Mac Option/Alt key while clicking on the site to
list the option.

If running MacOS Sierra 10.12, Java version must be 1.8.0.121 or higher.

5. Restart Safari.
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Virtual Media via VKC and AKC in a Windows Environment

When Virtual Media is enabled, access to fixed drives and fixed drive partitions
will not be accessible with a Standard Windows user. To access those drives, a
Windows Administrator user must be used. This is because Windows User
Access Control (UAC) provides the lowest level of rights and privileges a user
needs for an application.

Both features affect the types of virtual media that can be accessed in VKC,
VKCS, and AKC. See your Microsoft® help for additional information on these
features and how to use them.

Following is a list virtual media types users can access via VKC and AKC when
running in a Windows environment.

Client Administrator Standard User
AKC and Access to: Access to:
VKC = Fixed drives and fixed drive = Removable drives
partitions = CD/DVD drives
= Removable drives * SO images
= CD/DVD drives = Remote ISO images

= |SO images
=  Remote ISO images

Virtual Media Not Refreshed After Files Added

After a virtual media drive has been mounted, if you add a file(s) to that drive,
those files may not be immediately visible on the target server. Disconnect and
then reconnect the virtual media connection.

Virtual Media Linux Drive Listed Twice

For KX Ill, users who are logged in to Linux” clients as root users, the drives are
listed twice in the Local Drive drop-down.

For example, you will see eg /dev/sdc and eg /dev/sdcl where the first drive is
the boot sector and the second drive is the first partition on the disk.
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Disconnecting Mac and Linux Virtual Media USB Drives

In a Linux® or Mac® environment:

e  For Linux users, if there is /dev/sdb and /dev/sdb1, the client only uses
/dev/sdb1l and advertise it as removable disk

e /dev/sdb is not available for the user.

e  For Linux users, if there is /dev/sdb but no /dev/sdb1, /dev/sdb is used as a
removable device

e For Mac users, /dev/diskl and /dev/disk1s1 is used

Target BIOS Boot Time with Virtual Media

The BIOS for certain targets may take longer to boot if media is mounted
virtually at the target.

P> To shorten the boot time:
1. Close the Virtual KVM Client to completely release the virtual media drives.
2. Restart the target.

Virtual Media Connection Failures Using High Speed for Virtual Media
Connections

Under certain circumstances it may be necessary to select the "Use Full Speed
for Virtual Media CIM" when a target has problems with "High Speed USB"
connections or when the target is experiencing USB protocol errors caused by
signal degradation due to additional connectors and cables (for example, a
connection to a blade server via a dongle).

USB Port and Profile Notes
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VM-CIMs and DL360 USB Ports

HP° DL360 servers have one USB port on the back of the device and another on
the front of the device. With the DL360, both ports cannot be used at the same
time. Therefore, a dual VM-CIM cannot be used on DL360 servers.

However, as a workaround, a USB2 hub can be attached to the USB port on the
back of the device and a dual VM-CIM can be attached to the hub.
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Help Choosing USB Profiles

When you are connected to a KVM target server via the Virtual KVM Client
(VKC), you can view information about USB profiles via the Help on USB Profiles
command on the USB Profile menu.

v HP Froliant DL3G0/DL380 G4 (HF SmartStarnt COY

Generic

Troubleshooting 1
Troubleshooting 2
Trouhleshooting 3

Add Other Profiles r

Help on LISE Profiles

USB profile help appears in the USB Profile Help window. For detailed
information about specific USB profiles, see Available USB Profiles.

A standard selection of USB configuration profiles are provided for a wide
range of operating system and BIOS level server implementations. These are
intended to provide an optimal match between remote USB device and target
server configurations.

The ‘Generic’ profile meets the needs of most commonly deployed target
server configurations.

Additional profiles are made available to meet the specific needs of other
commonly deployed server configurations (for example, Linux®, Mac OS X°).

There are also a number of profiles (designated by platform name and BIOS
revision) that have been tailored to enhance the virtual media function
compatibility with the target server, for example, when operating at the BIOS
level.

‘Add Other Profiles’ provides access to other profiles available on the system.
Profiles selected from this list will be added to the USB Profile Menu. This
includes a set of ‘trouble-shooting’ profiles intended to help identify
configuration limitations.

The USB Profile Menu selections are configurable via the Console Device
Settings > Port Configuration page.

Should none of the standard USB profiles provided meet your target server
requirements, Technical Support can work with you to arrive at a solution
tailored for that target.

1. Check the most recent release notes to see if a solution is already available
for your configuration.

2. If not, please provide the following information when contacting Technical
Support:
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a. Target server information, manufacturer, model, BIOS, manufacturer,
and version.

b. The intended use (e.g. redirecting an image to reload a server’s
operating system from CD).

Changing a USB Profile when Using a Smart Card Reader

There may be certain circumstances under which you will need to change the
USB profile for a target server. For example, you may need to change the
connection speed to "Use Full Speed for Virtual Media CIM" when the target
has problems with the "High Speed USB" connection speed.

When a profile is changed, you may receive a New Hardware Detected
message and be required to log in to the target with administrative privileges
to reinstall the USB driver. This is only likely to occur the first few times the
target sees the new settings for the USB device. Afterward, the target will
select the driver correctly.

Video Mode and Resolution Notes

Video Image Appears Dark when Using a Mac

If you are using a Mac® with an HDMI video port and the video seems too dark,
enable DVI Compatibility Mode on the CIM to help resolve the issue.

See Configuring CIM Ports

Video Shrinks after Adjusting Target Clock

On HP* Proliant” DL380p G8 target servers, certain resolutions cause the target
video to shrink. This is caused when the server's clock attempts to auto-adjust
and detects the wrong active line length.

Depending on the resolution the target is set to, this occurs when connecting
to the HP target from the KX Ill Remote Console or Local Port, or both the
Remote Console and Local Port. This issue was detected at the following

resolutions:

Target resolution Issue seen on Local Issue seen from Remote
Port Console

1440x900@60Hz Yes Yes

1400x1050@60Hz No Yes

1152x864@60Hz No Yes

Raritan. 21
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Black Stripe/Bar(s) Displayed on the Local Port

Certain servers and video resolutions may display on the local port with small
black bars at the edge of the screen.

If this occurs:

1. Try adifferent resolution, or

2. If using a digital CIM, then change the Display Native Resolution on the
Port Configuration page to another resolution, or

3. If using the HDMI CIM, use the DVI Compatibility Mode.

Contact Raritan Technical Support for additional assistance.

Sun Composite Synch Video

Sun” composite synch video is not supported.

SUSE/VESA Video Modes

The SuSE X.org configuration tool SaX2 generates video modes using modeline
entries in the X.org configuration file. These video modes do not correspond
exactly with VESA video mode timing (even when a VESA monitor is selected).
The KX Ill, on the other hand, relies on exact VESA mode timing for proper
synchronization. This disparity can result in black borders, missing sections of
the picture, and noise.

P> To configure the SUSE video display:

The generated configuration file /etc/X11/xorg.conf includes a Monitor
section with an option named UseModes. For example,
UseModes "Modes[0]"

2. Either comment out this line (using #) or delete it completely.
3. Restart the X server.

With this change, the internal video mode timing from the X server is used and
corresponds exactly with the VESA video mode timing, resulting in the proper
video display on the KX III.
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Keyboard Notes
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French Keyboard

Caret Symbol (Linux Clients Only)

The Virtual KVM Client (VKC) do not process the key combination of Alt Gr + 9
as the caret symbol (*) when using French keyboards with Linux® clients.

P> To obtain the caret symbol:

From a French keyboard, press the ” key (to the right of the P key), then
immediately press the space bar.

Alternatively, create a macro consisting of the following commands:
1. Press Right Alt

2. Press9.

3. Release 9.

4. Release Right Alt.

Note: These procedures do not apply to the circumflex accent (above vowels). In
all cases, the * key (to the right of the P key) works on French keyboards to
create the circumflex accent when used in combination with another character.

Numeric Keypad

From the Virtual KVM Client (VKC), the numeric keypad symbols display as
follows when using a French keyboard:

Numeric Displays as
keypad symbol
/ ;
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Tilde Symbol

From the Virtual KVM Client (VKC), the key combination of Alt Gr + 2 does not
produce the tilde (~) symbol when using a French keyboard.

P> To obtain the tilde symbol:

Create a macro consisting of the following commands:
e  Press right Alt

e Press2

e Release 2

e Release right Alt

Keyboard Language Preference (Fedora Linux Clients)

Because the Sun™ JRE” on Linux® has problems generating the correct KeyEvents
for foreign-language keyboards configured using System Preferences, it is
recommended that you configure foreign keyboards using the methods
described in the following table.

Language Configuration method

UsS Intl Default

UK System Settings (Control Center)
French Keyboard Indicator

German Keyboard Indicator

Hungarian System Settings (Control Center)
Spanish System Settings (Control Center)
Swiss-German System Settings (Control Center)
Norwegian Keyboard Indicator

Swedish Keyboard Indicator

Danish Keyboard Indicator

Japanese System Settings (Control Center)
Korean System Settings (Control Center)
Slovenian System Settings (Control Center)
Italian System Settings (Control Center)
Portuguese System Settings (Control Center)

Raritan.

A brand of Olegrand



Appendix E: Informational Notes

Note: The Keyboard Indicator should be used on Linux systems using Gnome as
a desktop environment.

When using a Hungarian keyboard from a Linux client, the Latin letter U with
Double Acute and the Latin letter O with Double Acute work only with JRE 1.6
(and later).

There are several methods that can be used to set the keyboard language
preference on Fedora® Linux clients. The following method must be used in
order for the keys to be mapped correctly from the Virtual KVM Client (VKC).

P> To set the keyboard language using System Settings:

1. From the toolbar, choose System > Preferences > Keyboard.
2. Open the Layouts tab.

3. Add or select the appropriate language.

4. Click Close.

P> To set the keyboard language using the Keyboard Indicator:

Right-click the Task Bar and choose Add to Panel.

2. Inthe Add to Panel dialog, right-click the Keyboard Indicator and from the
menu choose Open Keyboard Preferences.

In the Keyboard Preferences dialog, click the Layouts tab.

4. Add and remove languages as necessary.

Macros Not Saving on Linux Targets

If you receive the following error message when you create and then save a
macro on a target server running Linux® Fedora™ 18 with Java™ 1.7.0 (update 45
and later), disable SELinux in Fedora 18 on the target server to resolve the
problem.

"An error occurred attempting to write the new keyboard
macros. Macro was not added"
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Mac Keyboard Keys Not Supported for Remote Access

When a Mac’ is used as the client, the following keys on the Mac" keyboard are
not captured by the Java” Runtime Environment (JRE™):

e F9

e F10
e Fl11
e Fl14
e F15

e Volume Up

e Volume Down
e Mute

e Eject

As a result, the Virtual KVM Client (VKC) are unable to process these keys from
a Mac client's keyboard.

Mouse Notes

Mouse Pointer Synchronization (Fedora)

When connected in dual mouse mode to a target device running Fedora® 7, if
the target and local mouse pointers lose synchronization, changing the mouse
mode from or to Intelligent or Standard may improve synchronization.

Single mouse mode may also provide for better control.

P> To resynchronize the mouse cursors:
e Use the Synchronize Mouse option from the Virtual KVM Client (VKC).

Single Mouse Mode when Connecting to a Target Under CC-SG Control

When using Firefox® to connect to a KX Il target under CC-SG control using
DCIM-PS2 or DCIM-USBG?2, if you change to Single Mouse Mode in the Virtual
KVM Client (VKC), the VKC window will no longer be the focus window and the
mouse will not respond.

If this occurs, left click on the mouse or press Alt+Tab to return the focus to the
VKC window.

Mouse Sync Issues in Mac OS 10

In Mac OS 10, if mouse sync is an issue at some resolutions, use USB profile
"General" and Absolute mouse mode.
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Audio
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Audio Playback and Capture Issues
Features that May Interrupt an Audio Connection

If you use any of the following features while connected to an audio device,
your audio connection may be interrupted. These features are not
recommended if you are connected to an audio device:

e Video Auto-Sense

e Extensive use of the local port

e Adding users

Issues when Using a Capture Device and Playback Device Simultaneously on a
Target

On some targets, the simultaneous connection of capture devices and playback
devices may not work due to the USB hub controller and how it manages the
USB ports. Consider selecting an audio format that requires less bandwidth.

If this does not resolve the issue, connect the D2CIM-DVUSB CIM's keyboard
and mouse connector to a different port on the target. If this does not solve the
problem, connect the device to a USB hub and connect the hub to the target.

Audio in a Linux Environment

The following are known issues when using the audio feature in a Linux®
environment.

e Linux® users, use the default audio device for playback. Sound may not
come through if a non-default sound card is selected.

e  SuSE 11 clients require Javas_1_6_0-sun-alsa (ALSA support for

java-1_6_0-sun) to be installed via YAST.

e For Logitech® headsets with a built in a mic, only the Mono Capture option
is available.

e Inorder to display the device, if you are running SUSE 11 and an ALSA
driver, log out of KX IlI, then log back in.

Additionally, if you connect and disconnect the audio device a number of
times, the device may be listed several times vs. just once as it should.

e Using the audio feature with a Fedora Core® 13 target set to mono 16 bit,
44k may cause considerable interference during playback.

Audio in a Windows Environment

On Windows* 64-bit clients, only one playback device is listed on the Connect
Audio panel when accessing the device through the Virtual KVM Client (VKC).

The audio device is the default device, and is listed on the Connect Audio panel
as Java Sound Audio Engine.
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Smart Card Notes

Virtual KVM Client (VKC) Smart Card Connections to Fedora Servers

If you are using a smart card to connect to a Linux® Fedora® server via Virtual
KVM Client (VKC) upgrade the pcsc-lite library to 1.4.102-3 or above.

CC-SG Notes

Virtual KVM Client Version Not Known from CC-SG Proxy Mode

When the Virtual KVM Client (VKC) is launched from CommandCenter Secure
Gateway (CC-SG) in proxy mode, the VKC version is unknown.

In the About Raritan Virtual KVM Client dialog, the version is displayed as
“Version Unknown”.

Moving Between Ports on a Device

If you move a between ports on the same Raritan device and resume
management within one minute, CC-SG may display an error message.

If you resume management, the display will be updated.

Browser Notes

Resolving Issues with Firefox Freezing when Using Fedora

If you are accessing Firefox® and are using a Fedora® server, Firefox may freeze
when it is opening.

To resolve this issue, install the libnpjp2.so Java™ plug-in on the server.
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Frequently Asked Questions
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Question

What is Dominion KX I1I?

How is KX 1l

different from KX Il ?

Answer

Dominion KX Il is a third-generation digital KVM
(keyboard, video, mouse) switch that enables one,
two, four or eight IT administrators to access and
control 8, 16, 32 or 64 servers over the network
with BIOS-level functionality. Dominion KX Ill is
completely hardware- and OS-independent; users
can troubleshoot and reconfigure servers even
when servers are down.

At the rack, Dominion KX Il provides the same
functionality, convenience, and space and cost
savings as traditional analog KVM switches.
However, Dominion KX Ill also integrates the
industry’s highest performing KVM-over-IP
technology, allowing multiple administrators to
access server KVM consoles from any networked
workstation as well as from the iPhone® and iPad".

The KX Ill is the next generation version of the KX II.
Featuring a modern hardware design with
increased computing power and storage, the KX Il
provides KVM-over-IP access for IT
administration, as well as high performance IP
access for broadcast applications. KX Il includes
virtually all KX Il features with the following
advancements:

The KX Ill's new video processing engine supports a
broad range of applications from traditional
computer applications to the most dynamic
broadcast applications requiring 30
frames-per-second 1920x1080 video, 24 bit color,
digital audio, dual monitors and DVI, HDMI,
DisplayPort and VGA video.

With the industry’s first DVI-based local port, the
KX 1lI's common user interface provides new levels
of productivity and performance for at-the-rack
administration and server access.

All KX 11l models feature a tiering port to connect
multiple Dominion KX Il switches together and
access the attached servers. Up to 1024 servers can
be accessed via a consolidated port list.

KX 11l supports all Dominion and Paragon Il CIMs
supported by KX II.
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Question

How does Dominion KX Il differ from
remote control software?

Can the Dominion KX Il be rack
mounted?

How large is the Dominion KX III?

Appendix F: Frequently Asked Questions

Answer

When using Dominion KX Il remotely, the
interface, at first glance, may seem similar to
remote control software such as pcAnywhere™,
Windows’ Terminal Services/Remote Desktop,
VNC, etc. However, because Dominion KX Il is not
a software but a hardware solution, it’s much more
powerful:

Hardware- and OS-independent — Dominion KX IlI
can be used to manage servers running many
popular OSs, including Intel®, Sun®, PowerPC
running Windows, Linux®, Solaris™, etc.

State-independent/Agentless — Dominion KX IIKX
Il does not require the managed server OS to be
up and running, nor does it require any special
software to be installed on the managed server.

Out-of-band — Even if the managed server’s own
network connection is unavailable, it can still be
managed through Dominion KX III.

BlOS-level access — Even if the server is hung at
boot up, requires booting to safe mode, or requires
system BIOS parameters to be altered, Dominion
KX 11 still works flawlessly to enable these
configurations to be made.

Yes. The Dominion KX IlI ships standard with 19"
rack mount brackets. It can also be reverse rack
mounted so the server ports face forward.

Dominion KX Il 'is only 1U high (except the KX3-864
and KX3-464, which are 2U), fits in a standard 19"
rack mount and is only 11.4" (29 cm) deep. The
Dominion KX3-832 and KX3-864 are 13.8" (36 cm)
deep.

Remote Access
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Question

How many users can remotely access
servers on each Dominion KX III?

Can | remotely access servers from
my iPhone or iPad?

Can two people look at the same
server at the same time?

Can two people access the same
server, one remotely and one from
the local port?

In order to access Dominion KX I
from a client, what hardware,
software or network configuration is
required?

Answer

Dominion KX Il models offer remote connections
for up to eight users per user channel to
simultaneously access and control a unique target
server. For one-channel appliances like the
DKX3-116, up to eight remote users can access and
control a single target server. For two-channel
appliances, like the DKX3-216, up to eight users can
access and control the server on channel one and
up to another eight users on channel two. For
four-channel appliances, up to eight users per
channel, for a total of 32 (8 x 4) users, can access
and control four servers. Likewise, for the
eight-channel appliances, up to eight users can
access a single server, up to an overall maximum of
32 users across the eight channels.

Yes. Users can access servers connected to the KX
Il using their iPhone or iPad.

Mobile access is provided through Mobile Access
Client, which requires the use of CommandCenter
Secure Gateway (CC-SG).

Yes. Actually, up to eight people can access and
control any single server at the same time.

Yes. The local port is completely independent of
the remote "ports." The local port can access the
same server using the PC-Share feature.

Because Dominion KX Il is completely
Web-accessible, it doesn’t require customers to
install proprietary software on clients used for
access.

Dominion KX Il can be accessed through major
Web browsers, including: Internet Explorer® and
Firefox". Dominion KX Il can be accessed on
Windows®, Linux® and Mac® desktops, via Raritan’s
Windows Client, and the Java™based Virtual KVM
Client™.

Dominion KX Il administrators can also perform
remote management (set passwords and security,
rename servers, change IP address, etc.) using a
convenient browser-based interface.
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Question Answer

What is the file size of the applet The Virtual KVM Client (VKC) applet used to access
that’s used to access Dominion KX [[I? Dominion KX Ill is approximately 500KB in size. The
How long does it take to retrieve? following chart describes the time required to

retrieve Dominion KX IIl's applet at different
network speeds:

100Mbps Theoretical 100Mbit .05 seconds
network speed

60Mbps Likely practical .08 seconds
100Mbit network
speed

10Mbps Theoretical 10Mbit .4 seconds
network speed

6Mbps Likely practical .8 seconds
10Mbit network
speed

512Kbps Cable modem 8 seconds
download speed

(typical)

Do you have a Windows KVM Client?  Yes. We have a native .NET Windows Client called
the Raritan Active KVM Client (AKC). See Active
KVM Client (AKC) Help (on page 73)

Do you have a non-Windows KVM Yes. The Virtual KVM Client (VKC) allows

Client? non-Windows users to connect to target servers in
the data center. See Virtual KVM Client (VKC and
VKCs) Help (on page 34)

Do your KVM Clients have Yes. The Dominion KX IlI’'s remote HTML User

multi-language support? Interface and the KVM Clients support the
Japanese, Simplified Chinese and Traditional
Chinese languages. This is available stand-alone as
well as through CC-SG.

Do your KVM Clients support dual LCD Yes. For customers wishing to enhance their

monitors? productivity by using multiple LCD monitors on
their desktops, the Dominion KX Il can launch KVM
sessions to multiple monitors, either in full screen
or standard modes.
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Question

Do you support servers with dual
video cards?

How do | access servers connected to
Dominion KX Il if the network ever
becomes unavailable?

Answer

Yes, dual video cards are supported with an
extended desktop configuration available to the
remote user.

You can access servers at the rack or via modem.

Dominion KX Il offers a dedicated modem port for
attaching an external modem.

Universal Virtual Media

Question

Which Dominion KX Ill models
support virtual media?

Which types of virtual media does the
Dominion KX lll support?

Answer

All Dominion KX IIl models support virtual media. It
is available stand-alone and through
CommandCenter® Secure Gateway, Raritan’s
centralized management appliance.

Dominion KX Il supports the following types of
media: internal and USB-connected CD/DVD drives,
USB mass storage devices, PC hard drives and ISO
images.
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Question Answer

What is required for virtual media? A Dominion KX IlI virtual media CIM is required.
There are two VGA-based CIMs: a D2CIM-VUSB or
D2CIM-DVUSB.

The D2CIM-VUSB has a single USB connector and is
for customers who will use virtual media at the OS
level.

The D2CIM-DVUSB has dual USB connectors and
should be purchased by customers who wish to
utilize virtual media at the BIOS level. The
D2CIM-DVUSB is also required for smart card
authentication, tiering/cascading and digital audio.

Both support virtual media sessions to target servers
supporting the USB 2.0 interface. Available in
economical 32 and 64 quantity CIM packages, these
CIMs support Absolute Mouse Synchronization™ as
well as remote firmware updates.

Our CIMs have traditionally supported analog VGA
video. Three new dual virtual media CIMs support
digital video formats, including DVI, HDMI and
DisplayPort. These are the D2CIM-DVUSB-DVI,
D2CIM-DVUSB-HDMI and

D2CIM-DVUSB-DP.

Is virtual media secure? Yes. Virtual media sessions are secured using 256-bit
AES or 128-bit AES encryption.

Does virtual media really support Yes. Audio playback and recording to a server

audio? connected to the Dominion KX Il is supported. You
can listen to sounds and audio playing on a remote
server in the data center using the speakers
connected to your desktop PC or laptop. You can
also record on the remote server using a
microphone connected to your PC or laptop. A
digital CIM or D2CIM-DVUSB dual virtual media CIM
is required.

What is a USB profile? Certain servers require a specifically configured USB
interface for USB-based services such as virtual
media. The USB profile tailors the KX IlI's USB
interface to the server to accommodate these
server-specific characteristics.
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Question Answer

Why would | use a USB profile? USB profiles are most often required at the BIOS
level where there may not be full support for the
USB specification when accessing virtual media
drives. However, profiles are sometimes used at the
OS level, for example, for mouse synchronization for
Mac and Linux servers.

How is a USB profile used? Individual ports or groups of ports can be configured
by the administrator to use a specific USB profile in
the KX 1lI’s port configuration page. A USB profile
can also be selected in the KX Ill Client when
required. See the user guide for more information.

Do | always need to set a USB profile  No. In many cases, the default USB profile is

when | use virtual media? sufficient when using virtual media at the OS level or
operating at the BIOS level without accessing virtual
media.

What profiles are available? Where Consult the user guide for the available profiles and
can | find more information? for more information.
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Question

How is bandwidth used in
KVM-over-IP systems?

How does bandwidth affect
KVM-over-IP performance?
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Answer

Dominion KX IIl offers totally new video processing
that provides flexible, high performance video,
efficient use of bandwidth and anytime/anywhere
access via LAN, WAN or Internet.

The Dominion KX Il digitizes, compresses and
encrypts the keyboard, video and mouse signals
from the target server and transmits IP packets
over the IP network to the remote client to create
the remote session to the user. The KX lll provides
an at-the-rack experience based on its
industry-leading video processing algorithms.

Screen changes, i.e., video accounts for the
majority of the bandwidth used —and keyboard
and mouse activity are significantly less.

It is important to note that bandwidth is only used
when the user is active. The amount of bandwidth
used is based on the amount of change to the
server’s video display screen.

If there are no changes to the video — the user is
not interacting with the server —there is generally
little to no bandwidth used. If the user moves the
mouse or types a character, then there is a small
amount of bandwidth used. If the display is running
a complex screen saver or playing a video, then
there can be a larger amount of bandwidth used.

In general, there is a trade-off between bandwidth
and performance. The more bandwidth available,
the better performance can be. In limited
bandwidth environments, performance can
degrade. The Dominion KX Ill has been optimized
to provide strong performance in a wide variety of
environments.
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Question
What factors affect bandwidth?

How much bandwidth does KX Il use
for common tasks?

How do | optimize performance and
bandwidth?

Answer

There are many factors that determine how much
bandwidth will be used. The primary factor, noted
above, is the amount of change in the target
server’s video display. This is dependent on the
user’s task and actions.

Other factors include the server’s video resolution,
networking speed and characteristics, the KVM
Client Connection Properties, client PC resources
and video card noise.

Bandwidth primarily depends on the user’s task
and actions. The more the server’s video screen
changes, the more bandwidth is utilized.

KX 1ll provides a variety of settings in our remote
clients for the user to optimize bandwidth and
performance. The default settings will provide an
at-the-rack level of performance in standard
LAN/WAN environments with economical use of
bandwidth.

Optimize For. Use this setting to configure the
video engine for standard IT/computer applications
or for video/broadcast applications.

Compression. Move the slider to the left for the
highest possible video quality and to the right for
the least amount of bandwidth.

Noise Filter. In most cases, the default setting
will work best, however you can move to the left
for more responsive video and to the right for
lower bandwidth.

Other tips to decrease bandwidth include:

= Use a solid desktop background instead of a
complex image

= Disable screensavers

= Use a lower video resolution on the target
server

= Uncheck the "Show window contents while
dragging" option in Windows

= Use simple images, themes and desktops (e.g.,
Windows Classic)
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Question

| want to connect over the Internet.
What type of performance should |
expect?

I have a high bandwidth environment.
How can | optimize performance?

What is the maximum remote (over
IP) video resolution supported?

How much bandwidth is used for
audio?

What about servers with DVI ports?

Appendix F: Frequently Asked Questions

Answer

It depends on the bandwidth and latency of the
Internet connection between your remote client
and the KX lll. With a cable modem or high speed
DSL connection, your performance can be very
similar to a LAN/WAN connection. For lower speed
links, use the suggestions above to improve
performance.

The default settings will work well.  You can move
the Connection Properties settings to the left for
increased video performance.

The Dominion KX Il is the first and only
KVM-over-IP switch to support full high definition
(HD) remote video resolution — 1920x1080 at
frame rates up to 30 frames per second with digital
audio.

In addition, popular widescreen formats are
supported, including 1600x1200, 1680x1050 and
1440x900, so remote users can work with today’s
higher resolution monitors.

It depends on the type of audio format used, but to
listen to CD quality audio, approximately 1.5 Mbps
is used.

Servers with DVI ports that support DVI-A (analog)
and DVI-I (integrated analog and digital) can use
Raritan’s ADVI-VGA inexpensive, passive adapter to
convert the server’s DVI port to a VGA plug that
can be connected to a KX Il CIM’s VGA plug.

Servers with DVI ports that support DVI-I or DVI-D
(digital) can use the new D2CIM-DVUSB-DVI CIM.

IPv6 Networking
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Question
What is IPv6?

Why does KX Il support IPv6
networking?

What is "dual stack" and why is
it required?

How do | enable IPv6 on the KX
"

What if | have an external
server with an IPv6 address that
| want to use with my KX 111?

What if my network doesn’t
support IPv6?

Where can | get more
information on IPv6?

Answer

IPv6 is the acronym for Internet Protocol Version 6. IPv6 is
the "next generation" IP protocol which will replace the
current IP Version 4 (IPv4) protocol.

IPv6 addresses a number of problems in IPv4, such as the
limited number of IPv4 addresses. It also improves IPv4 in
areas such as routing and network auto-configuration.
IPv6 is expected to gradually replace IPv4, with the two
coexisting for a number of years.

IPv6 treats one of the largest headaches of an IP network
from the administrator’s point of view — configuring and
maintaining an IP network.

U.S. government agencies and the Department of Defense
are now mandated to purchase IPv6-compatible products.
In addition, many enterprises and foreign countries, such
as China, will be transitioning to IPv6 over the next several
years.

Dual stack is the ability to simultaneously support IPv4 and
IPv6 protocols. Given the gradual transition from IPv4 to
IPv6, dual stack is a fundamental requirement for IPv6
support.

Use the "Network Settings" page, available from the
"Device Settings" tab. Enable IPv6 addressing and choose
manual or auto-configuration. Consult the user guide for
more information.

The KX Il can access external servers via their IPv6
addresses, for example, an SNMP manager, syslog server
or LDAP server.

Using the KX IlI’s dual-stack architecture, these external
servers can be accessed via: (1) an IPv4 address, (2) IPv6
address or (3) hostname. So, the KX Ill supports the mixed
IPv4/IPv6 environment many customers will have.

The KX III's default networking is set at the factory for IPv4
only. When you are ready to use IPv6, then follow the
above instructions to enable IPv4/IPv6 dual-stack
operation.

See www.ipv6.org for general information on IPv6. The KX
Il user guide describes the KX llI's support for IPv6.
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Servers

Question

Does Dominion KX Il depend on a
Windows server to operate?

What should | do to prepare a server
for connection to Dominion KX I1I?

What about mouse synchronization?

What comes in the Dominion KX llI
box?

Answer

Absolutely not. Because users depend on the KVM
infrastructure to always be available in any
scenario whatsoever (as they will likely need to use
the KVM infrastructure to fix problems), Dominion
KX 11l is designed to be completely independent
from any external server.

Set the mouse parameter options to provide users
with the best mouse synchronization and turn off
screensavers and any power management features
that affect screen display.

In the past, KVM-over-IP mouse synchronization
was a frustrating experience. The Dominion KX IlI’s
Absolute Mouse Synchronization provides for a
tightly synchronized mouse without requiring
server mouse setting changes on Windows and
Apple® Mac servers. For other servers, the
Intelligent Mouse mode or the speedy, single
mouse mode can be used to avoid changing the
server mouse settings.

The following is included: (1) Dominion KX IlI
appliance, (2) Quick Setup Guide, (3) standard 19"
rack mount brackets, (4) user manual CD-ROM, (6)
localized AC line cord and (7) warranty certificate
and other documentation.

Blade Servers

Question

Can | connect blade servers to the
Dominion KX 111?

Which blade servers are supported?

Raritan.
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Answer

Yes. Dominion KX Il supports popular blade server
models from the leading blade server
manufacturers: HP°, IBM", Dell* and Cisco".

The following models are supported: Dell
PowerEdge® 1855, 1955 and M1000e; HP
BladeSystem ¢3000 and c7000; IBM BladeCenter®
H, E and S; and Cisco UCS B-Series.
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Question Answer

Which CIM should | use? It depends on the type of KVM ports on the specific
make and model of the blade server you are using.
The following CIMs are supported: DCIM-PS2,
DCIM-USBG2, D2CIM-VUSB and D2CIM-DVUSB.

Which types of access and control are  The Dominion KX Il provides automated and
available? secure KVM access: (1) at the rack, (2) remotely
over IP, (3) via CommandCenter and (4) by modem.

Do | have to use hotkeys to switch Some blade servers require you to use hotkeys to

between blades? switch between blades. With the Dominion KX IIl,
you don’t have to use these hotkeys. Just click on
the name of the blade server, and the Dominion KX
Il will automatically switch to that blade without
the explicit use of the hotkey.

Can | access the blade server’s Yes. You can define the URL of the management

management module? module and access it from the Dominion KX Ill or
from our CommandCenter Secure Gateway. If
configured, one-click access is available.

How many blade servers can | For performance and reliability reasons, you can

connect to a Dominion KX [1I? connect up to eight blade chassis to a Dominion KX
I1l, regardless of model. Raritan recommends
connecting up to two times the number of remote
connections supported by the device. For example,
with a KX3-216 with two remote channels, we
recommend connecting up to four blade server
chassis. You can, of course, connect individual
servers to the remaining server ports.

I’'m an enterprise customer using Yes. Once blade servers are configured on the
CommandCenter Secure Gateway. Dominion KX Ill, the CommandCenter Secure
Can | access blade servers via Gateway user can access them via KVM
CommandCenter Secure Gateway? connections. In addition, the blade servers are

organized by chassis as well as CommandCenter
Secure Gateway custom views.

What if | also want in-band or In-band and embedded access to blade servers can
embedded KVM access? be configured within CommandCenter Secure
Gateway.

I’'m running VMware® on some of my  Yes. With CommandCenter Secure Gateway, you
blade servers. Is this supported? can display and access virtual machines running on
blade servers.
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Question

Is virtual media supported?

Is Absolute Mouse Synchronization
supported?

Is blade access secure?

Does the Dominion KSX Il or the KX

Appendix F: Frequently Asked Questions

Answer

This depends on the blade server. HP blades can
support virtual media. The IBM BladeCenter
(except for BladeCenter T) supports virtual media if
configured appropriately. A virtual media CIM —
D2CIM-VUSB or D2CIM-DVUSB — must be used.

Servers with internal KVM switches inside the
blade chassis typically do not support absolute
mouse technology. For HP blade and some Dell
blade servers, a CIM can be connected to each
blade, so Absolute Mouse Synchronization is
supported.

Yes. Blade access uses all of the standard Dominion
KX 11l security features such as 128-bit or 256-bit
encryption. In addition, there are blade-specific
security features such as per blade access
permissions and hotkey-blocking that eliminates
unauthorized access.

At this time, these products do not support blade

I11-101 support blade servers? servers.
Installation
Question Answer

Besides the appliance itself, what do |
need to order to install Dominion KX
1113

Which kind of Cat5 cabling should be
used in my installation?

Which types of servers and PCs can be
connected to Dominion KX III?

Raritan.
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Each server that connects to Dominion KX llI
requires a Dominion or Paragon computer
interface module (CIM), an adapter that connects
directly to the keyboard, video and mouse ports of
the server.

Dominion KX Ill can use any standard UTP
(unshielded twisted pair) cabling, whether Cat5,
Cat5e or Cat6. Often in our manuals and marketing
literature, Raritan will simply say "Cat5" cabling for
short. In actuality, any brand UTP cable will suffice
for Dominion KX III.

Dominion KX Il is completely vendor independent.
Any server with standards-compliant keyboard,
video and mouse ports can be connected. In
addition, servers with serial ports can be controlled
using the DSAM.
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Question Answer

How do | connect servers to Dominion Servers that connect to the Dominion KX Ill require

KX 117? a Dominion or Paragon CIM, which connects
directly to the keyboard, video and mouse ports of
the server. Then, connect each CIM to Dominion KX
Il using standard UTP (unshielded twisted pair)
cable such as Cat5, Cat5e or Cat6.

How far can my servers be from In general, servers can be up to 150 feet (45 m)

Dominion KX 111? away from Dominion KX Ill, depending on the type
of server. (See Target Server Video Resolution -
Supported Connection Distances and Refresh
Rates (on page 195)) For the D2CIM-VUSB CIMs
that supports virtual media and Absolute Mouse
Synchronization, a 100-foot (30 m) range is
recommended.

Some operating systems lock up when Each Dominion computer interface module (DCIM)

| disconnect a keyboard or mouse dongle acts as a virtual keyboard and mouse to the
during operation. What prevents server to which it is connected. This technology is

servers connected to Dominion KX Il called KME (keyboard/mouse emulation). Raritan’s
from locking up when | switch away KME technology is data center grade, battle-tested
from them? and far more reliable than that found in lower-end

KVM switches: it incorporates more than 15 years
of experience and has been deployed to millions of
servers worldwide.

Are there any agents Servers connected to Dominion KX Ill do not
that must be installed on servers require any software agents to be installed because
connected to Dominion KX III? Dominion KX Il connects directly via hardware to

the servers’ keyboard, video and mouse ports.

How many servers can be connected  Dominion KX Il models range from 8, 16 or 32

to each Dominion KX Il appliance? server ports in a 1U chassis, to 64 server ports in a
2U chassis. This is the industry’s highest digital
KVM switch port density.

What happens if | disconnect a server Dominion KX Il will automatically update the

from Dominion KX Il and reconnect it server port names when servers are moved from

to another Dominion KX Il appliance, port to port. Furthermore, this automatic update

or connect it to a different port on the does not just affect the local access port, but

same Dominion KX Il appliance? propagates to all remote clients and the optional
CommandCenter Secure Gateway management
appliance.
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Question

How do | connect a serially controlled
(RS-232) device, such as a Cisco
router/switch or a headless Sun
server, to Dominion

KX 117?

Appendix F: Frequently Asked Questions

Answer

Connecting a KX lll and a Dominion Serial Access
Module (DSAM) provides serial access for the KX 111

The DSAM is a 2- or 4 port serial module that
derives power from the KX III.

Local Port - KX 11l

Question

Can | access my servers directly from
the rack?

Can | consolidate the local ports of
multiple KX IlIs?

When | am using the local port, do |
prevent other users from accessing
servers remotely?

Can | use a USB keyboard or mouse at
the local port?

Is there an onscreen display (OSD) for
local, at-the-rack access?

Raritan.
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Answer

Yes. At the rack, Dominion KX Il functions just like a
traditional KVM switch — allowing control of up to 64
servers using a single keyboard, monitor and mouse.
You can switch between servers by the browser-
based user interface or via a hotkey.

Yes. You can connect the local ports of multiple KX
Il switches to another KX Il using the "tiering"
feature of the KX Ill. You can then access the servers
connected to your KX Ill appliances from a single
point in the data center via a consolidated port list.

No. The Dominion KX Il local port has a completely
independent access path to the servers. This means
a user can access servers locally at the rack —
without compromising the number of users that
access the rack remotely at the same time.

Yes. The Dominion KX Il has USB keyboard and
mouse ports on the local port. Dominion KX IlI
switches do not have PS/2 local ports. Customers
with PS/2 keyboards and mice should utilize a PS/2
to USB adapter.

Yes, but Dominion KX III’s at-the-rack access goes
way beyond conventional OSDs. Featuring the
industry’s first browser-based interface for
at-the-rack access, Dominion KX IlI’s local port uses
the same interface for local and remote access.
Moreover, most administrative functions are
available at the rack.
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Question

How do | select between servers
while using the local port?

How do | ensure that only authorized
users can access servers from the
local port?

Answer

The local port displays the connected servers using

the same user interface as the remote client. Users

connect to a server with a simple click of the mouse
or via a hotkey.

Users attempting to use the local port must pass the
same level of authentication as those accessing
remotely. This means that:

If the Dominion KX Il is configured to interact with
an external RADIUS, LDAP or Active Directory’
server, users attempting to access the local port will
authenticate against the same server.

If the external authentication servers are
unavailable, Dominion KX Il fails over to its own
internal authentication database.

Dominion KX lll has its own stand-alone
authentication, enabling instant, out-of-the-box
installation.

Extended Local Port

Question

What is the extended local port?

Answer

The Dominion KX2-808, KX2-832 and KX2-864
featured an extended local port. The corresponding
Dominion KX Il models do not have an extended
local port. Instead all KX 1l models have a tiering
port.

To extend the KX lll's digital local port, you can use
the Raritan Cat5 Reach DVI product for local and
remote access up to 500 meters.

See Connecting a KX Ill and Cat5 Reach DVI -
Provide Extended Local Port Functionality (on
page 170)

Dual Power Supplies
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Question

Does Dominion KX Il have a dual
power option?

Does the power supply used by
Dominion KX Il automatically detect
voltage settings?

If a power supply or input fails, will |
be notified?

Appendix F: Frequently Asked Questions

Answer

Yes. All Dominion KX Il models come equipped with
dual AC inputs and power supplies with automatic
failover. Should one of the power inputs or power
supplies fail, then the KX Il will automatically switch
to the other.

Yes. Dominion KX llI’'s power supply can be used in
AC voltage ranges from 100-240 volts, at 50—60 Hz.

The Dominion KX Ill front panel LED will notify the
user of a power failure. An entry will also be sent to
the audit log and displayed on the KX remote client
user interface. If configured by the administrator,
then SNMP or syslog events will be generated.

Intelligent Power Distribution Unit (PDU) Control

Question

What type of remote power control
capabilities does Dominion KX IlI
offer?

What type of power strips does
Dominion KX Ill support?

How many PDUs can be connected to
a Dominion KX III?

How do | connect the PDU to the
Dominion KX 111?

Raritan.
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Answer

Raritan’s intelligent PDUs can be connected to the
Dominion KX Ill to provide power control of target
servers and other equipment. For servers, after a
simple one-time configuration step, just click on
the server name to power on, off or to recycle a
hung server.

Raritan’s Dominion PX" and Remote Power Control
(RPC) power strips.

These come in many outlet, connector and amp
variations. Note that you should not connect the
PM series of power strips to the Dominion KX III as
these power strips do not provide outlet-level
switching.

Up to eight PDUs can be connected to a Dominion
KX Il appliance.

The D2CIM-PWR is used to connect the power strip
to the Dominion KX Ill. The D2CIM-PWR must be
purchased separately; it does not come with the
PDU.
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Question

Does Dominion KX Ill support servers
with multiple power supplies?

Does the Dominion KX Il display
statistics and measurements from the
PDU?

Does remote power control require
any special configuration of attached
servers?

What happens when | recycle power
to a server?

Answer

Yes. Dominion KX Ill can be easily configured to
support servers with multiple power supplies
connected to multiple power strips. Four power
supplies can be connected per target server.

Yes. PDU-level power statistics, including power,
current and voltage, are retrieved from the PDU
and displayed to the user.

Some servers ship with default BIOS settings such
that the server does not automatically restart after
losing and regaining power. For these servers, see
the server’s documentation to change this setting.

Note that this is the physical equivalent of
unplugging the server from the AC power line, and
reinserting the plug.
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Ethernet and IP Networking

Question

What is the speed of Dominion KX llI’s
Ethernet interfaces?

Can | access Dominion
KX 11l over a wireless connection?

Does the Dominion KX Il offer dual
gigabit Ethernet ports to provide
redundant failover or load balancing?

Answer

Dominion KX Ill supports gigabit as well as 10/100
Ethernet. KX lll supports two 10/100/1000 speed
Ethernet interfaces, with configurable speed and
duplex settings (either auto detected or manually
set).

Yes. Dominion KX Il not only uses standard
Ethernet, but also very conservative bandwidth with
very high quality video. Thus, if a wireless client has
network connectivity to a Dominion KX Ill, servers
can be configured and managed at the BIOS level
wirelessly.

Yes. Dominion KX Ill features dual gigabit Ethernet
ports to provide redundant failover capabilities.
Should the primary Ethernet port (or the
switch/router to which it is connected) fail,
Dominion KX Il will failover to the secondary
network port with the same IP address — ensuring
that server operations are not disrupted. Note that
automatic failover must be enabled by the
administrator.
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Question
Can | use Dominion KX Il with a VPN?

Can | use KX Il with a proxy server?

How many TCP ports must be open on
my firewall in order to enable
network access to Dominion KX 111?

Are these ports configurable?

Can Dominion KX Il be used with
Citrix*?

Can the Dominion KX Ill use DHCP?

Raritan.
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Answer

Yes. Dominion KX Il uses standard Internet Protocol
(IP) technologies from Layer 1 through Layer 4.
Traffic can be easily tunneled through standard
VPNs.

Yes. KX Il can be used with a SOCKS proxy server,
assuming the remote client PC is configured
appropriately. Contact the user documentation or
online help for more information.

Two ports are required: TCP port 5000 to discover
other Dominion appliances and for communication
between Raritan appliances and CC-SG; and, of
course, port 443 for HTTPS communication.

Yes. Dominion KX IlI’'s TCP ports are configurable by
the administrator.

Dominion KX Il may work with remote access
products like Citrix if configured appropriately, but
Raritan cannot guarantee it will work with
acceptable performance. Customers should realize
that products like Citrix utilize video redirection
technologies similar in concept to digital KVM
switches so that two KVM-over-IP technologies are
being used simultaneously.

DHCP addressing can be used; however, Raritan
recommends fixed addressing since the Dominion
KX 1l is an infrastructure appliance and can be
accessed and administered more effectively with a
fixed IP address.
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Question Answer
I’'m having problems connecting to The Dominion KX IIl relies on your LAN/WAN
the Dominion KX Il over my IP network. Some possible problems include:

network. What could be the problem? .

Ethernet auto-negotiation. On some networks,
10/100 auto-negotiation does not work properly,
and the Dominion KX Il appliance must be set to
100 Mb/full duplex or the appropriate choice for
its network.

Duplicate IP address. If the IP address of the
Dominion KX IIl is the same as another
appliance, network connectivity may be
inconsistent.

Port 5000 conflicts. If another appliance is using
port 5000, the Dominion KX Il default port must
be changed (or the other appliance must be
changed).

When changing the IP address of a Dominion KX
I, or swapping in a new Dominion KX III,
sufficient time must be allowed for its IP and
Mac® addresses to be known throughout the
Layer 2 and Layer 3 networks.

Local Port Consolidation, Tiering and Cascading
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Question

How do | physically connect multiple
Dominion KX Ill appliances together
into one solution?
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Answer

To physically connect multiple KX Il appliances
together for consolidated local access, you can
connect the Tiering ports of multiple "tiered" (or
"cascaded") KX Il switches to a "base" KX Il using
the Tiering port of the KX Ill. You can then access
the servers connected to your KX Ill appliances
from a single point in the data center via a
consolidated port list.

The Tiering port must be used to connect the
tiered KX Il switch to the base switch.

Access via the consolidated port list is available in
the data center or even from a remote PC. All
servers connected to the tiered KX llls can be
accessed via a hierarchical port list or via search
(with wildcards).

Two levels of tiering are supported; up to 1024
appliances can be accessed in a tiered
configuration. Remote power control is also
supported.

Virtual media, smart card and blade server access
via tiered access will be supported in a future
release. Of course these features are available
when accessed via a standard remote connection.

While remote IP server access via the consolidated
port list is available as a convenience, remote
accessing a tiered server from CommandCenter or
via the KX IIl the server is connected to, is
recommended for optimal performance.

251



Appendix F: Frequently Asked Questions

Question Answer

Do | have to physically connect Multiple Dominion KX 11l appliances do not need to

Dominion KX Ill appliances together? be physically connected together. Instead, each
Dominion KX Il appliance connects to the network,
and they automatically work together as a single
solution if deployed with Raritan’s
CommandCenter Secure Gateway (CC-SG)
management appliance.

CC-SG acts as a single access point for remote
access and management.

CC-SG offers a significant set of convenient tools,
such as consolidated configuration, consolidated
firmware update and a single authentication and
authorization database.

Customers using CC-SG for centralized remote
access can make good use of the KX III’s tiering
(cascading) feature to consolidate the local ports of
multiple KX Il switches and locally access up to
1024 servers from a single console when in the
data center.

Is CC-SG required? For customers wanting stand-alone usage (without
a central management system), multiple Dominion
KX Il appliances still interoperate and scale
together via the IP network. Multiple Dominion KX
Il switches can be accessed from the KX I1I
Web-based user interface.

Can | connect an existing analog KVM  Yes. Analog KVM switches can be connected to one

switch to Dominion KX [11? of Dominion KX llI’s server ports. Simply use a USB
computer interface module (CIM), and attach it to
the user ports of the existing analog KVM switch.

Analog KVM switches supporting hotkey-based
switching on their local ports can be tiered to a
Dominion KX Il switch and switched via a
consolidated port list, both remotely and in the
data center.

Please note that analog KVM switches vary in their
specifications and Raritan cannot guarantee the
interoperability of any particular third-party analog
KVM switch. Contact Raritan technical support for
further information.
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Computer Interface Modules (CIMs)

Question

What type of video is supported by
your CIMs?

Can | use computer interface modules
(CIMs) from Paragon, Raritan’s analog
matrix KVM switch, with Dominion KX
"

Does Dominion KX Il support Paragon
Dual CIMs?

Answer

Our CIMs have traditionally supported analog VGA
video. Three new CIMs support digital video
formats, including DVI, HDMI and DisplayPort.
These are the D2CIM-DVUSB-DVI,
D2CIM-DVUSB-HDMI and D2CIM-DVUSB-DP.

Yes. Certain Paragon computer interface modules
(CIMs) may work with Dominion KX IIKX 1. (Please
check the Raritan Dominion KX Il Release Notes on
the website for the latest list of certified CIMs.)

However, because Paragon CIMs cost more than
Dominion KX Il CIMs (as they incorporate
technology for video transmission of up to 1,000
feet [304 m]), it is not generally advisable to
purchase Paragon CIMs for use with Dominion KX
Ill. Also note that when connected to Dominion KX
I, Paragon CIMs transmit video at a distance of up
to 150 feet (46 m), the same as Dominion KX IlI
CIMs — not at 1,000 feet (304 m), as they do when
connected to Paragon.

Yes. The Dominion KX Il supports Paragon Il Dual
CIMs (P2CIM-APS2DUAL and P2CIM-AUSBDUAL),
which can connect servers in the data center to
two different Dominion KX Il switches.

If one KX Il switch is not available, the server can
be accessed through the second KX IlI switch,
providing redundant access and doubling the level
of remote KVM access.

Please note these are Paragon CIMs, so they do not
support the KX Il advanced features such as virtual
media, absolute mouse, audio, etc.

Security
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Question

Is the Dominion KX Il FIPS 140-2
Certified?

What kind of encryption does
Dominion KX Ill use?

Does Dominion KX IIl support AES
encryption as recommended by the
U.S. government’s NIST and FIPS
standards?

Does Dominion KX Il allow encryption
of video data? Or does it only encrypt
keyboard and mouse data?

How does Dominion KX Il integrate

with external authentication servers
such as Active Directory, RADIUS or

LDAP?

How are usernames and passwords
stored?

Answer

The Dominion KX Il uses an embedded FIPS 140-2
validated cryptographic module running on a Linux
platform per FIPS 140-2 implementation
guidelines. This cryptographic module is used for
encryption of KVM session traffic consisting of
video, keyboard, mouse, virtual media and smart
card data.

Dominion KX 1l uses industry-standard (and
extremely secure) 256-bit AES, 128-bit AES or
128-bit encryption, both in its SSL communications
as well as its own data stream. Literally no data is
transmitted between remote clients and Dominion
KX 11l that is not completely secured by encryption.

Yes. The Dominion KX Il utilizes the Advanced
Encryption Standard (AES) for added security.
256-bit and 128-bit AES is available.

AES is a U.S. government-approved cryptographic
algorithm that is recommended by the National
Institute of Standards and Technology (NIST) in the
FIPS Standard 197.

Unlike competing solutions, which only encrypt
keyboard and mouse data, Dominion KX Il does
not compromise security — it allows encryption of
keyboard, mouse, video and virtual media data.

Through a very simple configuration, Dominion KX
Il can be set to forward all authentication requests
to an external server such as LDAP, Active Directory
or RADIUS. For each authenticated user, Dominion
KX 11l receives from the authentication server the
user group to which that user belongs. Dominion
KX Il then determines the user’s access
permissions depending on the user group to which
he or she belongs.

Should Dominion KX III's internal authentication
capabilities be used, all sensitive information, such
as usernames and passwords, is stored in an
encrypted format. Literally no one, including
Raritan technical support or product engineering
departments, can retrieve those usernames and
passwords.
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Question Answer

Does Dominion KX Il support strong  Yes. The Dominion KX Il has

passwords? administrator-configurable, strong password
checking to ensure that user-created passwords
meet corporate and/or government standards and
are resistant to brute force hacking.

Can | upload my own digital certificate Yes. Customers can upload self-signed or certificate

to the Dominion KX IIKX 1II? authority-provided digital certificates to the
Dominion KX Il for enhanced authentication and
secure communication.

Does the KX Ill support a configurable Yes. For government, military and other

security banner? security-conscious customers requiring a security
message before user login, the KX Ill can display a
user-configurable banner message and optionally
require acceptance.

My security policy does not allow the  Yes. For customers wishing to avoid the standard

use of standard TCP port numbers. TCP/IP port numbers to increase security, the

Can | change them? Dominion KX IIl allows the administrator to
configure alternate port numbers.

Smart Cards and CAC Authentication

Question Answer

Does Dominion KX Ill support smart card  Yes. Smart cards and DoD common access cards

and CAC authentication? (CAC) authentication to target servers is
supported.

What is CAC? Mandated by Homeland Security Presidential

Directive 12 (HSPD-12), CAC is a type of smart
card created by the U.S. government and used
by U.S. military and government staff. The CAC
card is a multitechnology, multipurpose card;
the goal is to have a single identification card.
For more information, see the FIPS 201

standards.
Which KX Il models support smart All Dominion KX Il models are supported. The
cards/CAC? Dominion KX 11I-101 models do not currently

support smart cards and CAC.

Do enterprise and SMB customers use Yes. However, the most aggressive deployment
smart cards, too? of smart cards is in the U.S. federal government.
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Question

Which CIMs support
smart card/CAC?

Answer

The D2CIM-DVUSB, D2CIM-DVUSB-DVI,
D2CIM-DVUSB-HDMI and D2CIM-DVUSB-DP are
the required CIMs.

Which smart card readers are supported? The required reader standards are USB CCID

and PC/SC. Consult the user documentation for
a list of certified readers and more information.

Can smart card/CAC authentication work  Yes. Smart card/CAC authentication works on

on the local port and via
CommandCenter?

both the local port and via CommandCenter.
For the local port, connect a compatible smart
card reader to the USB port of the Dominion KX
1.

Manageability

Question

Can Dominion KX Il be remotely
managed and configured via Web
browser?

Can | back up and restore Dominion
KX 1lI’s configuration?

What auditing or logging does
Dominion KX IIl offer?

256

Answer

Yes. Dominion KX Ill can be completely configured
remotely via Web browser. Note that this does
require that the workstation have an appropriate
Java Runtime Environment (JRE) version installed.
Besides the initial setting of Dominion KX III’s IP
address, everything about the solution can be
completely set up over the network. (In fact, using
a crossover Ethernet cable and Dominion KX III’s
default IP address, you can even configure the
initial settings via Web browser.)

Yes. Dominion KX IlI's appliance and user
configurations can be completely backed up for
later restoration in the event of a catastrophe.

Dominion KX llI’'s backup and restore functionality
can be used remotely over the network, or through
your Web browser.

For complete accountability, Dominion KX IIl logs
all major user events with a date and time stamp.
For instance, reported events include (but are not
limited to): user login, user logout, user access of a
particular server, unsuccessful login, configuration
changes, etc.
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Question

Can Dominion KX Il integrate with
syslog?

Can Dominion KX Il integrate with

SNMP?

Can an administrator log-off a user?

Can Dominion KX llI’s internal clock be
synchronized with a timeserver?

Appendix F: Frequently Asked Questions

Answer

Yes. In addition to Dominion KX IlI’s own internal
logging capabilities, Dominion KX Il can send all
logged events to a centralized syslog server.

Yes. In addition to Dominion KX Ill’'s own internal
logging capabilities, Dominion KX Il can send SNMP
traps to SNMP management systems. SNMP v2 and
v3 are supported.

Yes, administrators can view which users are
logged into which ports and can log-off a user from
a specific port or from the appliance if required.

Yes. Dominion KX Il supports the industry-standard
NTP protocol for synchronization with either a
corporate timeserver, or with any public
timeserver (assuming that outbound NTP requests
are allowed through the corporate firewall).

Documentation and Support

Question

Is online help available?

Where do | find documentation on
the Dominion KX [1I?

What documentation is available?

What CIM should | use for a particular
server?

Raritan.
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Answer

Yes. Online help is available from the KX IIl user
interface, and at raritan.com with the
documentation.

Online help includes KX lll administration and end
user information on using the Remote Console,
Virtual KVM Client (VKC) Active KVM Client (AKC)
and Local Console, as well KX Il specifications,
informational notes, using KX Il with Paragon I,
connecting KX lll to the Cat5 Reach DVI, connecting
KX 11l to the T1700-LED, and so on.

The documentation is available at raritan.com. The
documentation is listed by firmware release.

A Quick Setup Guide, online help, a PDF version of
the help in the form of an Administrators Guide
and a Users Guide, as well as Release Notes and
other information are available.

Consult the CIM Guide available with the KX 111
documentation. Note that DVI, HDMI and
DisplayPort video standards are supported with the
digital video CIMs.
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Question

How long is the hardware warranty
for the KX I1I?

Answer

The Dominion KX Ill comes with a standard
two-year warranty, which can be extended to 5
years of warranty coverage.

Miscellaneous

Question

What is Dominion KX IlI’s default IP
address?

What is Dominion KX IlI's default
username and password?

| changed and subsequently forgot
Dominion KX llI’'s administrative
password; can you retrieve it for me?

How do | migrate from the Dominion
KX 1l to Dominion KX III?

Will my existing KX Il CIMs work with
Dominion KX lll switches?

Answer
192.168.0.192

The Dominion KX IlI’'s default username and
password are admin/raritan. However, for the
highest level of security, the Dominion KX IIl forces
the administrator to change the Dominion KX IlI
default administrative username and password
when the appliance is first booted up. Username is
not case sensitive.

Dominion KX Ill contains a hardware reset button
that can be used to factory reset the appliance,
which will reset the administrative password on
the appliance to the default password.

In general, KX Il customers can continue to use
their existing switches for many years. As their data
centers expand, customers can purchase and use
the new KX IIl models. Raritan’s centralized
management appliance, CommandCenter Secure
Gateway (CC-SG) Release 6.0 supports KX Il and KX
Il switches seamlessly.

Yes. Existing KX II CIMs will work with the Dominion
KX 11l switch. In addition, select Paragon CIMs will
work with the KX lIl. This provides an easy
migration to KX 1l for Paragon Il customers who
wish to switch to KVM over IP. However, you may
want to consider the D2CIM-VUSB and
D2CIM-DVUSB CIMs that support virtual media,
audio and Absolute Mouse Synchronization.
Additionally, digital video CIMs supporting DVI,
HDMI, and Display Port are also available.
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