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What's New in KX IV-101 Release 4.1.2

Release 4.1.2:
Auto scan ports and save an image: Auto Scan (on page 125)
Support for updates via SCP: Update Firmware Using SCP (on page 169)

New group permission for changing your own password: Users and Groups
(on page 114)

Security Updates: Strong passwords and user blocking for failed login
attempts are enabled by default.

= Login Settings (on page 155)

=  Password Policy (on page 156)

More supported video resolutions: Supported Preferred Video Resolutions
(on page 11)

Integration with Dominion User Station: Dominion User Station Access to
Dual KX4-101 Setups (on page 104)

List of events for easier reference: Dominion KX IV-101 Events (on page
136)

Release 4.1.0

Support for DVI and HDMI custom EDIDs, and local port monitor EDID, and
new audio settings:

= Port Configuration: KVM Port Settings - General, Video, Audio (on
page 9)

=  Port Configuration: Custom EDIDs (on page 17)

= Port Configuration: Local Port Monitor EDID (on page 18)

Support for DSAM: Serial Access With Dominion Serial Access Module (on
page 21)

New option to access virtual media image files: Access a Virtual Media
Image File (on page 63)

New Pulse option for Terminal Block Control: Terminal Block Control (on
page 146)

Encryption option for device discovery: Discovery Port (on page 141)

New option to disable HTTP: HTTP/HTTPS Ports (on page 141)

TLS 1.3 support: TLS Certificate (on page 158)

Updated documentation for using HKC on iOS: Using HKC on Apple iOS
Devices (on page 96)

Tips for Accessing Dominion KX IV-101 With Dual Monitor Setups (on
page 104)

Please see the Release Notes for a more detailed explanation of the changes
applied to this version of the Dominion KX IV-101.
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Chapter 1

Installation and Initial Configuration

In This Chapter
SUPPOTTEA BIrOWSES ...vvvieeiiiieeeitieeeiiteeesiieeeestseeeeseaeessasaaeasssseseessseesssseseeansseseanes 1
Minimum Client and System Recommendations ........ccceccveeevciieeeecieeeecieee e 1
Package Contents

Front View
Rear VIeW ........ccoviiiiiiiiiiieeieeeeieeee e,
Connecting the Equipment
INitial CoNfiGUratioN ....cccueiie e e et aae e e s aaeee s

Option 1: Connect @ PCt0 the LAN POrt......cccciiieeciiieeciiee et 4

Option 2: Connect an i0S device at the Local POrt........ccceeeeciveeeeciiee e 5

Option 3: Serial configuration........ccccveeiiiiie e e 5

N XL ST PSS i 6

KVIM CliIeNt OPLIONS ..evvvieiiieeeeeiiiee ettt e et e e e e e et e e e e e e e e saraareeeeeeenannns 6
Supported Browsers

e Chrome

e Edge

e Firefox

e Safari

See the Release Notes for more details on versions and compatibility.

Minimum Client and System Recommendations

Raritan.
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Minimum client requirements vary somewhat depending on what client you
want to use, and what kind of video you plan to stream.

> Network Speed Recommendation:
= A fast network like Gigabit Ethernet or WiFi 802.11ac

> Standalone Virtual KVM Client (VKCS) and Active KVM Client (AKC)
= CPU:

= For FullHD video: a modern and fast dual core CPU, such as Intel
Core i3 4xxx or newer, or a quad core CPU. If you plan to run more
than one KVM session, a quad core CPU is recommended.

= For 4K video: a modern and fast quad core CPU, such as Intel Core
i5 4xxx or newer. If you plan to run more than one 4K stream, a
CPU with 6 or more cores is recommended, such as Intel Core
i5/i7 8xxx.

= 8GBRAM
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= Graphics Card: a modern OpenGL capable graphics card, such as

GeForce or Radeon. At least 1GB.

B HTML KVM Client (HKC):
4K video not recommended on HKC.

=  CPU:a modern and fast dual core CPU
= 8GB RAM
=  OpenGL capable graphic card

Package Contents

= 1 Dominion KX V=101

= 1 power cord

= 1 HDMI cable

= 1 USB-B to USB-A cable
= 1 mounting bracket kit

Front View

5,

Q00000 Demnllon 4101
8 8 8 8 8 E e CONTREL

o oy i
00CO00 [3a- 5 e @®
866500 L] 2,
000000

Local Port HDMI Out to local port monitor

Local Port USB K/M:

= Use for local port keyboard/mouse, OR connect 1
or 2 DSAM units

(1)

(2]

0 Input/Output
0 Reset

(5]

Power Status LED:
= Green ON: Power on
= Green BLINKING: Remote target connection
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Chapter 1: Installation and Initial Configuration

Rear View

DKX4-101

00, 2000

303 ogo

08 a3 o
.-oo ae D

w00 00

=i

To sEmVER

umn

00 © 006

o Power 5V/4A from power adapter

e RJ-45 LAN Network Port with 2 LEDs for network
' speed and activity:

Amber OFF/Green OFF: Link Inactive

Amber ON/Green OFF: 1000 MBps Link/No
Activity

Amber BLINKING/Green OFF: 1000 MBps
Link/Activity(RX, TX)

Amber OFF/Green ON: 100 MBps Link/No Activity
Amber OFF/Green BLINKING: 100 MBps
Link/Activity(RX, TX)

Amber ON/Green ON: 10 MBps Link/No Activity

Amber BLINKING/Green BLINKING: 10 MBps
Link/Activity(RX, TX)

0 Serial Admin Port

0 USB In from target server

6 HDMI In from target server

Connecting the Equipment

|
of
|

Reriln  pkxa101 OO

(s]s]els]sle]
QDaCOC

OBOQOO

Geeseql

® E el
POYER LAN USEYH ) HOM N
,
it F—\
e =0
y LAN ™ PIiie=0

> Connect the Dominion KX IV-101 to the network:

= Connect the Dominion KX IV=101 to the network using the LAN port.
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Chapter 1: Installation and Initial Configuration

> Connect your target server:

= Connect the target server with an HDMI cable to the Dominion KX
IV=101 HDMI IN port. If the target server video is not HDMI, purchase
a Raritan cable- or video-adapter.

= Connect the target server to the Dominion KX IV-=101 USB IN port using
the included USB cable.

> Connect the power adapter:

= Newer models include a power adapter with a 4-pin connector. Push
the adapter in to lock.

= Some of the original models include twist-to-lock adapters, as shown in
the image below. These are marked with an arrow. Connect with the
arrow facing up. Push in firmly and twist clockwise to lock. Check to
ensure it is locked.

Power on all devices.

Initial Configuration

Default login: admin/raritan

Option 1: Connect a PC to the LAN Port

Re-connect the Dominion KX IV-101 to the LAN after initial configuration.
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Chapter 1: Installation and Initial Configuration

e Disable the wireless interface of the PC, and make sure the PC is set to
DHCP.

e Connect a network cable between the PC and Dominion KX [V=101 LAN
port.

e Open a browser. Enter the URL "https://kvm.local". The login page
appears.

e Follow the prompts to change the default password.

Option 2: Connect an iOS device at the Local Port

Required App: Raritan KVM by Raritan:
https://itunes.apple.com/us/app/raritan-kvm/id1455817539?mt=8

Rertan 000000 Dominlen KX4-101
| 888880 c:wm‘;l o
JE—— o pioy
@® CC0000 [CHaggas] = @
000000 s — ™=
e P e S OO D © O

e Launch the Raritan KVM app on an iOS device.

e Connect the iOS device with the Raritan KVM app to the Dominion KX
IV=101 USB port.

e  Wait until the app detects the connected Dominion KX IV-101.
e Follow the prompts to change the default password.

Option 3: Serial configuration

. = p— —
Rarfen  owxa101 O 9060800053 iy
— §%09sees03 8
[ s otgeiBl o -
coFiE=="ace ‘
= = 22 S=H 285 =

e Connect a DB9 serial cable or USB-Serial adapter between the PC and the
Dominion KX IV-101 serial Admin port.

e Serial console configuration: (default) 115200bps/None/8bits/1stop

e To find the default DHCP IP address, use the "show" command to "show
network".

e  For help with all commands, see CLI Commands (on page 179).

Raritan. 5
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Chapter 1: Installation and Initial Configuration

Next Steps

e Configure network settings: See Network (on page 138)

e Configure time settings: See Date and Time (on page 126)
e Install certificates: See TLS Certificate (on page 158)

e Configure users: See User Management (on page 105)

e Configure port settings: Port Configuration: KVM Port Settings - General,
Video, Audio (on page 9)

KVM Client Options

Dominion KX IV-101 offers a selection of KVM clients. Upon launching the
Dominion KX IV-101 IP address in a supported browser, the login page appears.
The HTML KVM Client (HKC) is loaded by default.

e Click the Learn more link in the login page to view other KVM client
options.

Raritan.
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Other KVM clients offer better video and virtual media
performance. Learn more.

e The Learn more link launches a client options dialog. Click the provided
links to launch a different client.

= https://<IP address> launches HKC
= https://<IP address>/akc launches AKC

Raritan.
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Chapter 1: Installation and Initial Configuration

= https://<IP address>/vkcs launches VKC
KX4-101 Client Options

Three different dients are available to launch KVM sessions®r administer your device, each with its own benefits. Note that you must log into
each client separately.

Client Name How to Launch Notes

HTML KVM Client On anv‘browser including mobile, go to ;I'his_ is Wgat ‘1"'_3:'@ rul:lfni_ng "0.W- Q(;lic_kt'ﬁt Ia"‘;E_BSiESI to

(HKO) https://192.168.56.27 log into, but video performance and virtual media
functionality are limited.

On Windows, using Microsoft Edge™ Internet Explorer™

Active KVM Client 11, or another browser with ClickOnce plug-in, go to Recommended high-performance client for Windows. AKC

(AKC) https://192.168.56.27 /akc will load and launch automatically when the link is clicked.

Recommended high-performance client for Mac and Linux.
Virtual KVM Client On any system with Java 1.8, go to After clicking link, VKCS will download. If browser does
Standalone (VKCS) https://192.168.56.27vkes not do it automatically, click the downloaded .jnlp file (or
ctrl-click on Mac) to launch.

When a different client is selected, Dominion KX IV-101 automatically checks
your system to make sure it meets the requirements of the client. If your
system is ready, the selected client loads. If your system needs to meet
additional requirements, another message displays with details.

Note: For AKC and VKCS, your browser may display a "This site is not secure"
warning message until you have installed valid certificates. Click to accept the
warnings and go to the site. See TLS Certificate (on page 158) for help installing
certificates that prevent these warnings.

For more details and instructions for using all clients, see KVM Clients (on page
40).

Raritan. 7
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Port Access and Configuration

In This Chapter

POt ACCESS. .ttt et e e e s e e e e e e e e e e nnnees 8
Port Configuration: KVM Port Settings - General, Video, Audio..........cccvveeuneee. 9
Port Configuration: CUSTOM EDIDS......cccueivuieiiiieiiiiesiee e eieesveesveesveesereesvee e 17
Port Configuration: Local Port Monitor EDID ........cccvevieeriieesiiiesieesieecvee e 18
Port Configuration: USB Connection SEttings........ccceveereeneenenieieeneesieeieene 19

Port Access

Raritan.
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Click Port Access to view the port preview and connect to the target.

*  Port Preview:
e The preview image refreshes every 5 seconds.

e Your ability to see the preview depends on your privileges. If you do not
have sufficient privileges, a message displays with details.

Connect J

»  Connect to the target:

Click the Connect button to open a connection to the target server.
For help with using the KVM clients, see KVM Clients (on page 40).
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Port Configuration: KVM Port Settings - General, Video, Audio

Raritan.
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The Port Configuration page contains all port settings for the KVM port name
and video resolution, as well as USB port and audio settings.

> To access all port configuration:
e  Click Port Configuration.

% Model: DKX4-101 « Firmware: 4.0.0.5.45611

Port Access

KVM Port 1 Settings

&o} General

Port Name Dominion_KX4_Port1
Configuration

Current State Active, Tdle

> KVM Port Settings:

General Settings:
e Torename the KVM port: enter a new name and click Save.
e View the Current Port Status:
= Active, Idle
= Active, Busy: Connected, but PC Share is disabled. See KVM Security
(on page 153).
= Active, Connected: Connected, and PC Share is enabled.

Video Settings:

e Select Enable VGA Mode if the video input originates with a VGA or other
analog source, through an HDMI adapter. In VGA mode, resolution is
controlled on the video source device only.

e Select the Preferred Video Resolution: Important! The KX IV uses an
“EDID” data structure to tell the target server what video resolution is
wanted. To change the video resolution on the target server, change the
Preferred Video Resolution to the new resolution. This should change the
resolution when you connect to the target; if not, you can then also change
the resolution on the target server.

= See Supported Preferred Video Resolutions (on page 11) for a list of all
supported resolutions.

= |f you have a specific EDID to load, see Port Configuration: Custom
EDIDs (on page 17).
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e Set the Video Interface to HDMI or DVI (no audio).

e Setalonger Cycle Time if your target video is not responding properly to
changes in preferred video resolution. Default is 200ms. A longer Cycle
Time may allow your target to respond accurately to a new preferred video
resolution.

e Select Enable Video Throttle to cap the client frame rate at half the frame
rate of the incoming video. This can be useful to reduce network
bandwidth and CPU load on the client.

@Enable VGA Mode when the video input originates with a VGA
or other analog source, through an HDMI adapter. In VGA mode,
resolution is controlled on the video source device only.

Enable VGA Mode L]

OUse these settings if necessary to help force digital video
sources to desired screen resolution. Try a longer cycle time
value if target does not respond properly.

Video Interface HDMI =
Preferred Video Resolution 1920x1080 @ 60Hz v
Cycle Time 200 ms =

©Enable Video Throttle to cap the client frame rate at 1/2 that of
the incoming video. This can be useful to reduce network
bandwidth and/or CPU load on the client.

Enable Video Throttle [

Audio Settings

e If there is no audio, select Audio Compensation to enable it. You must
reboot the Dominion KX IV=101 after disabling this function to allow a new
audio connection to another target computer.

© If there is no audio, please enable Audio Compensation.
Please reboot this KX4-101 switch if you disable this setting to connect the KX4-101 to another target computer.

Audic Compensation )

e Click Save to apply all settings.

Raritan.
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Supported Preferred Video Resolutions

Each supported EDID is listed with the preferred video resolutions it can offer.
The server will generally choose the largest resolution and refresh rate that it
can support.

>

1024x768@60Hz

640x480@60Hz, @72Hz, @75Hz
720x400@70Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz
1024x768@60Hz, @70Hz, @75Hz

1152x864@60Hz

640x480@60Hz, @72Hz, @75Hz, @85Hz
720x400@70Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz, @85Hz
1024x768@60Hz, @70Hz, @75Hz, @85Hz
1152x864@60Hz

1280x720@60Hz

640x480@60Hz, @72Hz, @75Hz, @85Hz
720x400@70Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz, @85Hz
1024x768@60Hz, @70Hz, @75Hz, @85Hz
1152x864@60Hz, @75Hz

1280x720@60Hz

1280x960@60Hz

640x480@60Hz, @72Hz, @75Hz, @85Hz
720x400@70Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz, @85Hz
1024x768@60Hz, @70Hz, @75Hz, @85Hz
1152x864@60Hz, @75Hz

1280x960@60Hz

1280x1024@60Hz

640x480@60Hz, @72Hz, @75Hz, @85Hz
720x400@70Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz, @85Hz
1024x768@60Hz, @70Hz, @75Hz, @85Hz
1152x864@60Hz, @75Hz

1280x1024@60Hz, @75Hz

11
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1360x768@60Hz

640x480@60Hz, @72Hz, @75Hz
720x400@70Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz
1024x768@60Hz, @70Hz, @75Hz
1152x864@60Hz, @75Hz
1280x960@60Hz

1280x1024@60Hz

1360x768@60Hz

1440x900@60Hz

640x480@60Hz, @72Hz, @75Hz
720x400@70Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz
1024x768@60Hz, @70Hz, @75Hz
1152x864@75Hz

1280x960@60Hz

1280x1024@60Hz

1440x900@60Hz

1400x1050@60Hz

640x480@60Hz, @72Hz, @75Hz
720x400@70Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz
1024x768@60Hz, @70Hz, @75Hz
1152x864@60Hz, @75Hz
1280x960@60Hz

1280x1024@60Hz, @75Hz
1400x1050@60Hz

1600x900@60Hz

640x480@60Hz, @72Hz, @75Hz, @85Hz
720x400@70Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz, @85Hz
1024x768@60Hz, @70Hz, @75Hz, @85Hz
1152x864@60Hz, @75Hz, @85Hz
1600x900@60Hz

1600x1200@60Hz
640x480@60Hz, @72Hz, @75Hz, @85Hz

Raritan.
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e 720x400@70Hz

e 800x600@56Hz, @60Hz, @72Hz, @75Hz, @85Hz
e 1024x768@60Hz, @70Hz, @75Hz, @85Hz

e 1152x864@60Hz, @75Hz, @85Hz

o 1280x1024@75Hz

e 1600x1200@60Hz

>  1680x1050@60Hz

o 640x480@60Hz, @72Hz, @75Hz

e 720x400@70Hz

e 800x600@56Hz, @60Hz, @72Hz, @75Hz
e 1024x768@60Hz, @70Hz, @75Hz

e 1152x864@60Hz, @75Hz

e 1280x960@60Hz

e 1280x1024@60Hz, @75Hz

e 1440x900@60Hz

e 1680x1050@60Hz

> 1920x1080@60Hz (148.5MHz clock)
e 640x480@60Hz, @72Hz, @75Hz

e 720x400@70Hz

e 800x600@56Hz, @60Hz, @72Hz, @75Hz
e 1024x768@60Hz, @70Hz, @75Hz

e 1152x864@75Hz

e 1280x720@60Hz

e 1280x960@60Hz

e 1280x1024@60Hz, @75Hz

e 1440x900@60Hz

e 1600x1200@60Hz

e 1680x1050@60Hz

e 1920x1080@60Hz

> 1920x1200@60Hz (Reduced Blanking 154MHz clock)
e 640x480@60Hz, @72Hz, @75Hz

e 720x400@70Hz

e 800x600@56Hz, @60Hz, @72Hz, @75Hz

e 1024x768@60Hz, @70Hz, @75Hz

e 1152x864@75Hz

e 1280x720@60Hz

o 1280x960@60Hz

e 1280x1024@60Hz, @75Hz

Raritan. 13
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e 1440x900@60Hz

e 1600x1200@60Hz
e 1680x1050@60Hz
e 1920x1080@60Hz
e 1920x1200@60Hz

> 1920x2160@60Hz

e 640x480@60Hz, @72Hz, @75Hz
e 720x400@70Hz

e 800x600@56Hz, @60Hz, @72Hz, @75Hz
e 1024x768@60Hz, @70Hz, @75Hz
e 1152x864@75Hz

e 1280x720@60Hz

e 1280x960@60Hz

e 1280x1024@60Hz, @75Hz

e 1440x900@60Hz

e 1600x1200@60Hz

e 1680x1050@60Hz

e 1920x1080@60Hz

e 1920x2160@60Hz

*  2560x1440@60H:z

o 640x480@60Hz, @72Hz, @75Hz

e 720x400@70Hz

e 720x480@60Hz

e 720x576@50Hz

e 800x600@56Hz, @60Hz, @72Hz, @75Hz
e 1024x768@60Hz, @70Hz, @75Hz
e 1152x864@75Hz

e 1280x720@50Hz, @60Hz

e 1280x800@60Hz

e 1280x1024@60Hz, @75Hz

e 1440x900@60Hz

e 1600x900@60Hz

e 1680x720@60Hz

e 1680x1050@60Hz

e 1920x1080@24Hz, @30Hz, @60Hz
e 1920x1200@60Hz

e 2560x1080@30Hz

e 2560x1440@60Hz

Raritan.
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2560x1600@60Hz
640x480@60Hz, @72Hz, @75Hz
720x400@70Hz

720x480@60Hz

720x576@50Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz
1024x768@60Hz, @70Hz, @75Hz
1152x864@75Hz
1280x720@50Hz, @60Hz
1280x800@60Hz
1280x1024@60Hz, @75Hz
1440x900@60Hz

1600x900@60Hz

1680x720@60Hz
1680x1050@60Hz
1920x1080@24Hz, @30Hz, @60Hz
1920x1200@60Hz
2560x1080@30Hz
2560x1600@60Hz

3840x1080@60Hz
640x480@60Hz, @72Hz, @75Hz
720x400@70Hz

720x480@60Hz

720x576@50Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz
1024x768@60Hz, @70Hz, @75Hz
1152x864@75Hz
1280x720@50Hz, @60Hz
1280x800@60Hz
1280x1024@60Hz, @75Hz
1440x900@60Hz

1600x900@60Hz

1680x720@60Hz
1680x1050@60Hz
1920x1080@24Hz, @30Hz, @60Hz
1920x1200@60Hz
2560x1080@30Hz, @60Hz
2560x1440@60Hz

Chapter 2: Port Access and Configuration
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2560x1600@60Hz
3840x1080@60Hz

3840x1200@60Hz
640x480@60Hz, @72Hz, @75Hz
720x400@70Hz

720x480@60Hz

720x576@50Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz
1024x768@60Hz, @70Hz, @75Hz
1152x864@75Hz
1280x720@50Hz, @60Hz
1280x800@60Hz
1280x1024@60Hz, @75Hz
1440x900@60Hz

1600x900@60Hz

1680x720@60Hz
1680x1050@60Hz
1920x1080@24Hz, @30Hz, @60Hz
1920x1200@60Hz
2560x1080@30Hz, @60Hz
2560x1440@60Hz
3840x1200@60Hz

3840x1600@30Hz
640x480@60Hz, @72Hz, @75Hz
720x400@70Hz

720x480@60Hz

720x576@50Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz
1024x768@60Hz, @70Hz, @75Hz
1152x864@75Hz
1280x720@60Hz
1280x800@60Hz
1280x1024@60Hz, @75Hz
1440x900@60Hz
1600x900@60Hz
1680x1050@60Hz
1920x1080@60Hz
1920x1200@60Hz
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2560x1080@60Hz
2560x1440@60Hz
3840x1600@30Hz

3840x2160@30Hz
640x480@60Hz, @72Hz, @75Hz
720x400@70Hz

720x480@60Hz

720x576@50Hz

800x600@56Hz, @60Hz, @72Hz, @75Hz
1024x768@60Hz, @70Hz, @75Hz
1152x864@75Hz
1280x720@50Hz, @60Hz
1280x800@60Hz
1280x1024@60Hz, @75Hz
1440x900@60Hz

1600x900@60Hz

1680x720@60Hz
1680x1050@60Hz
1920x1080@24Hz, @30Hz, @60Hz
1920x1200@60Hz
2560x1080@60Hz
2560x1440@60Hz
2560x1600@60Hz
3440x1440@50Hz
3840x2160@24Hz, @25Hz, @30Hz
4096x2160@30Hz

Port Configuration: Custom EDIDs

Raritan.
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A custom EDID can be loaded to allow the Dominion KX IV-101 to support a
new or different video resolution, or to specify a custom version of standard
supported resolution. Only one custom EDID per resolution can be added. The
files have a ".rfp" extension and are provided by the vendor on request.

You can upload up to 20 custom EDIDs with a maximum of 10 custom HDMI
EDIDs and 10 custom DVI EDIDs. Custom EDIDs are not included in backups.

w N =T

To upload a custom EDID:

Click Port Configuration, then scroll down to Custom EDIDs.
Click Browse to find and select the .rfp EDID file.

Click Upload. Repeat these steps to add more files.

17
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4. Once EDIDs are uploaded, they display in a list sorted by resolution.
= Click Show Description to view the details.

= (Click the Delete icon to remove a file.
Custom EDIDs A

© Custom EDIDs extend the capabilities of the KX4 to support new or different video resolutions. The
files have a ".rfp" extension and are provided by vendor on request.

Resolution 4

800x600 @ 60Hz Show Description (]

1024x768 @ 70Hz Show Description ]

Port Configuration: Local Port Monitor EDID

If a Local Port Monitor is attached to Dominion KX IV=101, a Local Port Monitor
EDID section appears on the Port Configuration page and the monitor's EDID is
included in the Preferred Video Resolution. You can use the Local Port
Monitor's EDID by selecting it as the Preferred Video Resolution.

If the Local Port Monitor is removed while it's EDID was in use as the preferred
video resolution, the preferred video resolution will revert back to the default
1920x1080@60Hz standard EDID.

If a new monitor is attached, it will overwrite the old Local Port Monitor EDID.

*  To view Local Port Monitor EDID:
1. Click Port Configuration, then scroll down to Local Port Monitor EDID.
2. The EDID of the currently attached local port monitor is listed.

= Click Show Description to view the details.
Local Port Monitor EDID A

©Local Port Monitor EDID extends the capabilities of the KX4 to
allow users to use their Local Port Monitor's EDID.

Resolution

1920x1080 @ 60Hz Show Description

18 Raritan.
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Port Configuration: USB Connection Settings

USB Connection Settings are disabled when the port is connected. All users
must be disconnected from the KVM target to change the USB port settings.

> To define USB connections for the target server:

e Click Port Configuration, then scroll down to USB Connection Settings.
e Select the USB connection settings you will be using:

Enable Absolute Mouse - Disable if the target does not support
absolute mouse mode

Use Full Speed - Useful for BIOS that cannot accommodate High Speed
USB devices. Clear the checkbox to allow negotiation to the target's
highest USB speed capability.

Enumerate virtual media first before keyboard and mouse: Useful to
resolve issues when a target cannot detect USB mass storage at the
BIOS.

e C(Click Save.

USB Connection Settings

Basic

Enable Absolute Mouse v
Use Full Speed - Useful for BIOS that

cannot handle High Speed USB devices

Enumerate virtual media first before
keyboard and mouse

e Set Advanced Options as needed:

Virtual Media Interface Types: Both interfaces cannot be set to CDROM
or Removable Disk.

= Disabled
= CDROM

=  Removable Disk

Auto - can function as either COROM or Removable Drive but not
both at the same time

Remove Unused VM Interface From Device Configuration: Select this

option to remove the drive when VM is disconnected. Clear this option
to allow empty drives.

Raritan. 19
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e  (Click Save.

Virtual Media Interface #1 Type

Remove Unused VM Interface #1 From
Device Configuration

Virtual Media Interface #2 Type

Remove Unused VM Interface #2 From
Device Configuration

| CD-ROM . |
O
| Removable Disk s |
O

Raritan.
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Serial Access With Dominion Serial Access
Module

uejey Mm—————

[:[ .
[:[ .

T-HYS0

Connecting a Dominion KX IV=101 and a Dominion Serial Access Module (DSAM)
provides access to devices such as LAN switches and routers that have a RS-232
serial port.

The DSAM is a 2- or 4 port serial module that derives power from the Dominion
KX IV=101.

Connect a maximum of 2 DSAM modules to the Dominion KX IV=101 using USB
cables. DSAM can be mounted in a OU configuration.

In This Chapter

CONNECT DSAM ...ttt e e e e s bt e e e e e e e anreeeeas 22
VieW DSAM Serial POIS ...ciieeiieiiiiee ettt e et 23
Configure DSAM Serial POS ....ccoieiiiiiiiee et e 24
Configure Serial Port Keyword LiSt ........ccccveeiiiiieeiiiie e 26
UpPdate DSAM FirMWAIE ....cccvieieeiiieeeciiieeeeieeeeeiteeestveeeesaaeeesaaaeestreeesssaeesennnes 28
Supported CLI COMMANGS ....eeeiiiieeeciiie e e ctee e e e eae e e e e e stae e e eaaeeeeaneeeas 28
Connect to DSAM Serial Targets in the Web Interface........ccccceeeecieeevcieeeccinennn. 30
Connect to DSAM Serial Target with URL Direct Port Access.......ccccvveeeeeennnnen.. 31
Connect to DSAM Serial Targets via SSH ......ccviiiiiiiiiieee e, 31
HTML Serial Console (HSC) Help c...ueii it 32
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Connect DSAM

» To connect DSAM to Dominion KX IV-101:

e Connect the DSAM unit's USB cable to either of the USB K/M ports on the
front of the Dominion KX IV-101.

e Connect the serial devices to the serial ports on the DSAM unit.

e When 2 DSAM units are connected, a local keyboard and mouse cannot be
connected.

e  When only 1 DSAM unit is connected, a combined keyboard/mouse can be
connected to the remaining open USB K/M.

Serial Devices Serial Devices

Cats
Connections

241 ] L r— ;z' i
USB
DSAM-4 . DSAM-4
Connections

Local
Port

Monitor Serial over IP

DSAM LED Operation
The DSAM unit has one LED for status, and 2 LEDs on each port.

Raritan DSAM-4

©  status 1 2 3 4 fi

g—'ﬁ’@f‘ﬁ‘ﬁ“ﬁ‘
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Status LED:

The Status LED is labeled on the unit front. Light is on back. The Status LED
gives information at bootup and upgrade.

>

Green LED - Slow blink: DSAM booting up but not controlled by Dominion
KX IV-101.

Blue LED - Slow blink: DSAM controlled by Dominion KX IV-101.
Blue LED - Fast blink: Firmware upgrade in progress.

USB Port LEDs:

Each USB port has a left Green LED and a right Yellow LED.

Green LED: Port is set as DCE
Yellow LED: Port is set as DTE
LEDs off: Port is set as AUTO

View DSAM Serial Ports

Raritan.
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When a DSAM unit is connected to the Dominion KX IV=101, a DSAM Serial
Ports page is available.

Serial Port Access and Configuration
;i@ # A Name Type Status Availibility Settings
11 DSAM1 Port 1 DTE Active Idle -2
Port
Configuration 1.2 DSAM1 Port 2 DTE Active Idle o
13 DSAM1 Port 3 DCE Active Idle o
@ 1.4 DSAM1 Port 4 DCE Active Idle -3

Device
Information

e

Ports

> To view DSAM serial ports:

Click DSAM Serial Ports. You can access and configure serial ports from this

page.

e Ports are listed by physical USB position on the DSAM unit.

e # column indicates which Dominion KX V=101 USB port DSAM is plugged
into.

e Type column indicates port's DTE/DCE setting.

e Status and Availability columns show current activity.

e C(Click the Settings icon to open configuration for the port.
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Configure DSAM Serial Ports

You can rename serial ports and configure their settings.

*  To configure DSAM serial ports:

1. Click DSAM Serial Ports, then click the gear icon for the port you want to

configure to open the settings.

Serial Port Access and Configuration

#A Name Type Status Availibility
1.1 DSAM1 Port 1 DTE Active Idle

12 DSAM1 Port 2 DTE Active Idle

13 DSAM1 Port 3 DCE Active Idle

1.4 DSAM1 Port 4 DCE Active Idle

2. Inthe General section:
DSAM Serial Port 1.1 Settings
General
Name DSAM1 Port 1

Current State Active, Idle

= Enter a Name for the port.

Settings

o —
&

i

-

= Check the Current State of the port. Status and Availablity are listed.

Serial Settings
Emulation VT100 B Escape Mode Control
Encoding Default é Escape Character 1
Equipment Type Auto Detection B Char Delay (ms) 0
BPS 9600 B Line Delay (ms) 0
’ A Send Break
Parity/Bits Node/8 v Duration (ms) 300
Flow Control None 4 Suppress
Messages
Stop Bits 1 B Always Active

Exit Command

Multiple Writers Single writer allowed oQ

Port Keywords

Emulation: Select the terminal emulation
targets connected to the ports.

= VT100
= VT220
= V1320
= ANSI

In the Serial Settings section, check or change the following settings:

mode used to match the serial
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Encoding: Select a specific character encoding for this port if needed.
Encoding overrides the global setting for the port to whatever value you
set.

= DEFAULT

= US-ASCII

= 8-BIT ASCII

= |SO-8859-1
= |SO-8859-15
= UTF-8

= Shift-JIS

= EUCJP

= EUC-CN

= EUC-KR

Equipment Type: Indicate whether you want the Dominion KX IV-101 to
automatically detect a physical connection to the target.

= Default is Auto Detection.

= Force DTE causes Dominion KX IV=101 to act as a piece of data
terminal detection equipment to detect targets connected to it.

= Force DCE causes Dominion KX IV-101 to act as a piece of data
communications equipment to detect equipment connected to it.

Note: If the target has the ability to autodetect either DTE or DCE, you must
select either Force DTE or Force DCE for the port. Dominion KX IV-101 does
not support autodetection of both DCE and DTE on the same port.

Bits Per Second (BPS): Select a value.

= BPS options: 1200, 1800, 2400, 4800, 9600, 19200, 38400, 57600,
115200, 230400

Parity/Bits: Select a value.
Flow Control: Select a value.
Stop Bits: Select a value.

Multiple Writers: Select an option to allow single or multiple writers on a
port at one time.

Port Keywords: When configured, port keywords appear here. Go to
Device Settings > Serial Port Keyword List to add port keywords.

Escape Mode: The escape sequence affects only the CLI. When entering
escape mode, the user is given a menu of commands that can be
performed (for example, gethistory, view commands, and so on), a
command to return to the port session, and a command to exit the port
connection. Default is Control.

= None

= Control

25



Chapter 3: Serial Access With Dominion Serial Access Module

14. Escape Character: The default for the Dominion KX IV-101 is ] (closed
bracket).

Raritan recommends that you do not use [ or Ctrl-[. Either of these may
cause unintended commands, such as invoking the Escape Command
unintentionally. This key sequence is also triggered by the arrow keys on
the keyboard.

15. Char Delay: To specify the delay between when individual characters are
sent via the port, enter the time in milliseconds.

16. Line Delay: To specify the delay between when lines of text are sent via the
port, enter it in the field.

17. Send Break Duration: Entering the send break time in milliseconds. Range
is from Oms - 1000ms.

18. Always Active: Select the checkbox if you want to log activities coming into
a port even if no user is connected.

The default option is to not maintain port access without a connected user,
which means ignore data coming into a port when no user is connected.

This option is for port data logs.

Note: When no users are logged into a port session, port traffic, by default,
is discarded .

19. Exit Command: Type a command, such as 1ogout, to be sentto your
system when a user with write permission disconnects from the port.

This ensures that the user's session on the target machine is closed, but it
is not imperative to have an Exit command configured on a port.

20. Click Save.

Configure Serial Port Keyword List

Port keywords work as a filter. If a keyword is detected, message are sent to:

e Eventlog

e SNMP
e SMTP
e Syslog

This feature is useful for notifying administrators if a particular event occurs on
a port. For keywords to trigger when no users are connected to a port, "Always
Active" must be selected in the port settings. (See Configure DSAM Serial Ports
(on page 24).) You can also view the list of existing port keywords on the serial
port settings page.

> To configure serial port keywords:

1. Click Device Settings > Serial Port Keywords. The Serial Port Keyword List
page opens.
2. Click New. The New Keyword Settings page opens.
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Enter a keyword in the Keyword field, then select the ports you want to
associate with that keyword. For all ports, select the top checkbox.

New Keyword Setting

Event
Management
Keyword Example
Keycode List
Select Ports
Network Name 4
v DSAM1 Port 1
Network )
Services DSAM1 Port 2
DSAM1 Port 3
Serial Port
DSAM1 Port 4

Serial Port
Keyword List

Cancel Add Keyword

Click Add Keyword. The Serial Port Keyword List appears.

Serial Port Keyword List

No. Keyword

ol Example

New  Edit Delete

= To edit or delete a keyword, select it to highlight blue, then click Edit or
Delete.
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Update DSAM Firmware

DSAM firmware is upgraded automatically during Dominion KX IV=101 device
firmware upgrades if a new DSAM version is detected in the device firmware.
You can also upgrade your DSAM firmware manually.

Update DSAM Firmware

Update
Firmware
Name Serial Current DSAM Update DSAM
v A Model Number Version Version
Update DSAM DSAM-
Eirmware | DSAM1 4 RKK6B00009 1.0 1.0

« Update Firmware

»  To update the DSAM firmware manually:
1. Choose Maintenance > Update DSAM Firmware.

2. Select the checkboxes for the DSAM units you want to upgrade to the
Upgrade DSAM Version listed.

3. Click Update Firmware, then click OK to confirm. A progress message
appears.

The firmware update is being prepared.

This may take up to 3 minute. On successful completion
the firmware update will be started.

4. When firmware upgrade completes, a success message appears.

Supported CLI Commands

e show
"= show device

If DSAMs is attached in KX4-101, show device will include DSAM device
information

" show keyword

Shows all configured keywords
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" show port
Shows DSAM serial port parameters
connect:
Connect to a DSAM serial port
= connect <port index> (1.1/1.2../2.4)

During connecting to target, using the escape key sequence, the following
target port CLI command can be reached:

= clearhistory
Clear history buffer for this port
= clientlist
Display all users on the port
= close
Close this target connection
= gethistory
Display the history buffer for this port
" getwrite
Get write access for the port
" resetport
Reset port
" return
Return to the target session
" sendbreak
Send a break to the connected target
= writelock
Lock write access to this port
"= writeunlock
Unlock write access to this port
config
keyword
= keyword add [key <key>] [port <port>]
Add a keyword
= keyword delete [key <key>]
Delete a keyword
= keyword modify [key <key>] [port <port>
Edit a keyword
port
Configure DSAM serial port settings
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= port [index <index>] [name <name>] [emulation
<emulation>] [encoding <encoding>] [egtype
<egtype>] [bps <bps>] [parity <parity>]
[flowcontrol <flowcontrol>] [stopbits
<stopbits>] [multiwrite <multiwrite>]
[escapemode <escapemode>] [escapechar
<escapechar>] [chardelay <chardelay>]
[linedelay<linedelay>] [sendbreak <sendbreak>]
[suppress <suppress>] [alwaysactive
<alwaysactive>] [exitcommand <exitcommand>]

Supported Escape Key Characters
The default escape key is CTRL ]

The following characters are supported for customized escape keys.

o AZ
e 3z
o I
o {1
o |\

Connect to DSAM Serial Targets in the Web Interface

% Serial Port Access and Configuration
Ports # A Name Type Status Availibility Settings
1.1 | [Dsami port 1 DTE Active Idle o
1.2 Connect h DTE Active Idle Ee
User 1.3 DCE Active Idle o
Management
1.4 DSAM1 Port 4 DCE Active Idle o

>  To connect to DSAM serial targets in the web interface:
Click DSAM Serial Targets to view the list of ports.

2. Click the port you want to connect to, then click the pop-up Connect
button.

HSC launches in a new window.
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Connect to DSAM Serial Target with URL Direct Port Access

1.

Choose Device Settings > Device Services, then select the Enable Direct
Port Access via URL checkbox.

To connect with direct port access, type the URL:

"https://<IP Address>/dpa.asp?port=<serial port
number>&username=<user name>&password=<password>"

Example:
https://192.168.51.101/dpa.asp?port=1.4&username=admin&password=r
aritan0

HTML Serial Client (HSC) launches and connects to the serial target.

Connect to DSAM Serial Targets via SSH

Raritan.

A brand of Klegrand’

See Supported CLI Commands (on page 28).

»>

To connect to DSAM serial targets via SSH:

Make sure that SSH Access is enabled in Device Settings > Network
Services > SSH.

Launch SSH client in client PC to connect to Dominion KX IV-101.
After login, user will enter CLI interface.

Type command "connect <serial port number>".

Example: connect 1.4

If successful, serial target is accessed.

To exit serial target, type escape-key-sequence, default is Ctrl-], then enter
port sub-menu CLl interface.

Type "close", then enter main CLI interface.
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HTML Serial Console (HSC) Help

You can connect to serial targets using HSC. HSC is supported with several
Raritan products that offer serial connections. Not all products support all HSC
features. Differences are noted.

Raritan HTML Serial Console : DSAM3 ... = O X

A | https://192.168.59.100/hsc_js/hsc_js.htmI?port=301&Ses

EMULATOR EDIT TOOLS POWER HELP

Successfully Connected!

HSC Functions

Emulator

IMPORTANT: HSC sessions are affected by the Dominion KX IV-101 Idle
Timeout.

If you have not changed the Dominion KX IV-101 Idle Timeout setting from
the default, your session could be closed automatically if it exceeds the Idle
Timeout period.

Change the default Idle Timeout setting and then launch the HSC. See Login
Limitations for details on changing the Idle Timeout setting.

Access Emulator Options
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Select the Emulator drop-down menu to display a list of options.

EMULATOR EDIT TOOLS POWER HELP
Settings
Get History

Clear History

Get Write Lock
Write Unlock
Send Break
Reset Port

Connected Users...

Settings

Note:

KX3 administrators can set Terminal emulation settings in Setup > Port
Configuration.

KX4-101 administrators can set terminal emulation settings in DSAM Serial
Ports > Settings.

1.

Choose Emulator > Settings. The Terminal Properties dialog displays the
default settings.

Terminal Properties

Columns: Rows: 25 =
Foreground: - Background:lil
Font size: 11 Scrollback: 1000 v
Encoding:  utf-8 v Language: English ~

Backspace Sends: Ctrl-H -

OK Cancel

Set the terminal size by selecting the number of Columns and Rows.
Default is 80 by 25.

Set the Foreground and Background colors. Default is white on black.
Set the Font size. Default is 11.
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5. Set the Scrollback number to indicate the number of lines available for
scrolling.

6. Choose one of the following from the Encoding drop-down menu:
= UTF-8

= 8-bit ascii
= |SO-8859-1
= |SO-8859-15
= Shift-JIS
= EUC-JP
=  EUC-KR
7. Choose one of the following from the Language drop-down menu:
=  English
= Japanese
= Korean
= Chinese

= Bulgarian

8. The Backspace Sends default is ASCII DEL, or you can choose Control-H
from the Backspace Sends drop-down menu.

9. Click OK to save. If you changed the Language setting, the HSC changes to
that language when the Display Settings window is closed.

Get History

History information can be useful when debugging, troubleshooting, or
administering a target device. The Get History feature:

e Allows you to view the recent history of console sessions by displaying the
console messages to and from the target device.

e Displays up to 512KB of recent console message history. This allows a user
to see target device events over time.

When the size limit is reached, the text wraps, overwriting the oldest data with
the newest.

Notes: History data is displayed only to the user who requested the history.

To view the Session History, choose Emulator > Get History.

Clear History

= To clear the history, choose Emulator > Clear History.

Get Write Access
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Only users with permissions to the port get Write Access. The user with Write
Access can send commands to the target device. Write Access can be
transferred among users working in the HSC via the Get Write Access
command.

To enable Write Access, choose Emulator > Click Get Write Access.
e You now have Write Access to the target device.
e  When another user assumes Write Access from you:
=  The HSC displays a red block icon before Write Access in the status bar.

= A message appears to the user who currently has Write Access,
alerting that user that another user has taken over access to the
console.

Get Write Lock

Write lock prevents other users from taking the write access while you are
using it.

1. To get write lock, choose Emulator > Get Write Lock.

2. If Get Write Lock is not available, a request rejected message appears.

Write Unlock

To get Write Unlock, choose Emulator > Write Unlock.

Send Break

Some target systems such as Sun Solaris servers require the transmission of a
null character (Break) to generate the OK prompt. This is equivalent to issuing a
STOP-A from the Sun keyboard.

Only users with Write Access privileges can send a break.
To send an intentional “break” to a Sun Solaris server:

1. Verify that you have Write Access. If not, follow the instructions in the
previous section to obtain write access.

2. Choose Emulator > Send Break. A Send Break Ack (Acknowledgement)
message appears.

3. Click OK.

Reset Port

Reset Port resets the physical serial port on the SX2 and re-initializes it to the
configured values regarding bps/bits, and so on.

Connected Users
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The Connected Users command allows you to view a list of other users who are
currently connected on the same port.

1. Choose Emulator > Connected Users.

User List

* admin

System: Auto Naming

oK

2. Astar appears in the Write column for the User who has Write Access to
the console.

Exit

1. Choose Emulator > Exit to close the HSC.

Copy and Paste and Copy All

Data on the current visible page can be selected for copying. Copy and Paste
are accessible in the HSC by right click in the terminal window. Select Copy or
Paste in the context menu that appears.

To copy all text, use the Copy All option in the Edit menu.

If you need to paste a large amount of data, it is better to save the data in a file
and use the Send a Text File function. Pasting a large amount of data in a
browser windows can cause the browser to hang as it processes the data. See
Send Text File (on page 37).

When pasting data to a port, the end of a line is sent as a carriage return.
The Cut option on the right-click menu is disabled.

Do not use the Delete option that appears in the right-click menu of IE and
some versions of Firefox. This Delete option will remove display lines entirely
from the emulator window.

> Browser-specific behaviors

When copying from IE or Edge browsers, there are no end of line characters in
the copied data. The pasted data appears to be all in one line and contains
many spaces. When pasting back into a HSC window, the data may appear to
be misaligned, but the data is complete.
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Send Text File

1. Select Edit> Send Text File.

2. Inthe Send Text File dialog, click Browse to find the text file.
3. Click OK.

= When you click OK, the selected file sends directly to the port.

= |fthereis currently no target connected, nothing is visible on the

screen.
Send Text File
No file selected.
OK Cancel
| File Upload &

Kol | * X2 TextFile o[

Organize ~ MNew folder = N | e‘

Search 5X2 Text File jo

- Favorites [l Name Date modified Type

B Deskiop | SX2.ixt 6/13/2016 5:03 PM  Text Doc

4 Downloads

% Dropbox

m

[ «» Recent Places

) Libraries

*. Documents

4. Music
= Pictures
%, Videos
v 4 10 | 3
File name: SX2.txt v | A Files v|

[ Open H[ Cancel ]

» Note, if you are using a Mac® and/or Safari’, do the following in order to
use this feature:

In Safari, select Preferences.

2. Under the Security tab, select "Manage Website Settings"
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3. Click on the Dominion KX IV-101 website.
4. Select "Run in unsafe mode" from the drop-down box.
5. Restart Safari.

Tools: Start and Stop Logging

The Tools menu contains options for creating a data history file and
downloading it.

1. Choose Tools > Start Logging to start the storage of serial port data in
memory.

2. Click Stop Logging to save the log file. A pop up message appears with a
download link. Click to download the memory buffer into a text file.

EMULATOR EDIT TOOLS POWER HELP

Successfully Connected!

Save Log File

Click Here to Download

OK

Write Access Encoding: utf-8 Term Size: 80 x 25
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Browser Tips for HSC

Some browsers have limitations that affect HSC.

In Chrome, disabling the background throttling to prevent background tabs
from disconnecting after a certain amount of time. Go to chrome://flags,
then search for "throttle". Set "Throttle Javascript timers in backgound"
and "Calculate window occlusion on Windows" to "Disabled". Restart
chrome to apply settings.

Browser option to select certificate for authentication displayed on Edge
and Chrome after session is idle for about 5 minutes, due to internal
browser SSL caching and timeouts. If certificate is selected promptly,
reconnection is successful. With longer idle times, authentication is not
successful, and the browser should be restarted to reconnect. Issue is not
observed in Firefox or IE 11.

Internet Explorer has an internal limitation on the number of websockets
that are allowed to be created to a single server (6). This can be changed
by modifying a registry variable as shown here :
https://msdn.microsoft.com/en-us/library/ee330736(v=vs.85).aspx#webso
cket_maxconn.

Internet Explorer 11, Safari, and Edge have a limitation when connecting to
IPv6 devices. Using the numerical URL will not work when it attempts to
establish a websocket connection. In these browsers, use the device
hostname or literal IPv6 as UNC to connect to the SXII. See
https://en.wikipedia.org/wiki/IPv6_address#Literal_IPv6_addresses_in_UN
C_path_names

When using HSC in 10S Safari, the keyboard may not appear in some pages
if the "request desktop website" setting is enabled. To change the setting,
go to Settings > Safari >Request Desktop Website, then make sure All
Websites is not selected, and the device address is not selected. You can
also set this per address by clicking the "aA" in Safari's URL pane when
connected to the HSC port, then select "Website Settings" and make sure
that "Request Desktop Website" is not selected.
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KVM Client
HTML KVM Client

Active KVM Client

Virtual KVM Client

KVM Clients

Dominion KX IV-101 can be accessed with a variety of KVM clients that support
your individual configuration.

e HKCis best for Linux and Mac users without Java.

e AKCis best for Windows Platforms, using Windows or Edge browsers.

e VKCis best for Linux and Mac users with Java.

Name Platforms
HKC = linux
= Mac
= Windows
= HTML and Javascript
AKC =  Windows
= Requires Microsoft .NET
VKC = linux
= Mac
=  Windows
In This Chapter

Virtual KVM Client (VKCS) Help
Active KVM Client (AKC) Help
HTML KVM Client (HKC)
Tips for Accessing Dominion KX V=101 With Dual Monitor Setups
Dominion User Station Access to Dual KX4-101 Setups

Features

Java-Free
Supports most features

See HTML KVM Client (HKC) for

supported features
Full-featured KVM Client
Java-Free

Full-featured KVM Client
Requires Java

Virtual KVM Client (VKCS) Help
To launch VKCS, enter https://<KX4-101 IP address>/vkcs in a browser.
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Java Requirements

e Asupported Java version is required. Check the release notes for latest
supported version.

e If Javais not installed, a prompt is displayed that the file cannot be opened,
with an option to search for the program.

> VKCS Launching:

For all browsers, the VKCS standalone application needs to be downloaded
everytime you use it.

e Chrome: The downloaded VKCS jnlp file must always be clicked at bottom
left corner of browser window to launch.

= a X
G New Tab %\ New Tab X
C | [1192.168.1.203/vkes =
£ Apps  For quick access, place your bookmarks here on the bookmarks bar. Import bookmarks now..
g: K
y
4] WicStandaloneappi..{olp b ¥ Show all downloads.. %
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e Edge: You can allow and open the file from the browser downloads in the
top right corner.

<

192.168.59.115/vkc 8 o=
Downloads £ Q -

i VkecStandAloneApplication (1).jnlp 4

Open file

See more

e Safari: Save the jnlp file locally. Hold down the Ctrl key when selecting to
open, then click Open in displayed prompt
=  Firefox: The current default setting in Firefox on Windows saves the
file and runs from the download. You can launch from the browser
with this setting: Tools>Options>Applications, then select "Jnlp File" in
the Content Type column, and change the Action from "Always ask" to
"Use Java Web Launcher".

Proxy Server Configuration

When the use of a Proxy Server is required, a SOCKS proxy must also be
provided and configured on the remote client PC.

Note: If the installed proxy server is only capable of the HTTP proxy protocol,
you cannot connect.

®  To configure the SOCKS proxy:
1. Ontheremote client PC, select Control Panel > Internet Options.

a. Onthe Connections tab, click 'LAN settings'. The Local Area Network
(LAN) Settings dialog opens.

b. Select 'Use a proxy server for your LAN'.
Click Advanced. The Proxy Settings dialog opens.
d. Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

e. Click OK at each dialog to apply the settings.

2. Next, configure the proxy settings for the Java™ applets:
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a. Select Control Panel > Java.

b. Onthe General tab, click Network Settings. The Network Settings
dialog opens.
Select "Use Proxy Server".

d. Click Advanced. The Advanced Network Settings dialog opens.

e. Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

Connection Properties

The Connection Properties dialog allows you to configure the video stream
parameters to match your system capabilities with your performance needs.

i Connection Properties @
Video Encoding

> Usage: [Genera\ Purpose Video v] —
T 3
8 [eadla]ieiele]ia]ie]) &
§' Full Color Modes ]

a
.§_' Color Subsampling §
b} [¥] Automatic F
m

i

Current Status
Source: 19201080 @ 60 Hz
Performance: 60 FPS. 14.8 Kbit/s incoming
Encryption: On

-

> Video Encoding

This section selects the video encoding algorithm and quality setting.

Usage: specify your general application area. This selection optimizes the

available choices elsewhere in this dialog.

=  General Purpose Video: video content where smooth color
reproduction is most important, such as movies, video games, and
animations.

= Computer and IT Applications: video content where text sharpness and
clarity are important, such as computer graphical interfaces.
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Encoder Mode: Choose the encoder mode from the row of eight buttons.
Options will vary depending on the Usage selection. In general, modes
towards the left of the button bar offer higher image quality but consume
higher bandwidth, and might cause frame rate to drop depending on
network speed and/or client performance. Modes towards the right
consume lower bandwidth at the cost of reduced image quality. In
network- or client-constrained situations, modes towards the right may
achieve better frame rates.

The default video mode is always "Full Color 2", which is a high-quality mode
and works well for most uses in LAN environments. If needed, experiment with
modes further towards the right to find the right balance of image quality and
frame rate.

>

Color Subsampling

Color subsampling reduces the color information in the encoded video stream.

»>

Automatic: Recommended. The optimal color subsampling mode will be
enabled based on the selections in the video encoding section.

4:4:4: Highest quality at significant bandwidth cost. Usually not necessary
except for some situations in graphical user interfaces. Not supported for
resolutions above 1920x1200, so for those resolutions color subsampling
will automatically drop down to 4:2:2.

4:2:2: Good blend of image quality and bandwidth.

4:2:0: Maximum savings of network bandwidth and client load. Works fine
for most general-purpose applications that don't emphasize
high-resolution lines or text.

Current Status

Current status includes real-time video performance statistics. As you change
settings in the dialog, you can immediately see the effects on performance.

44

Source: resolution and frame rate of the incoming video source.

Performance: frames per second (FPS) being rendered in the client, and
the data rate of the incoming video stream. These values are where you
will see the effects of your video settings.

Encryption: whether the video stream is encrypted or not. Encrypted
streams usually have lower frame rates and lower bandwidth. Encryption is
a global setting in security - KVM Security = "Apply Encryption Mode to
KVM and Virtual Media".

Raritan.

A brand of Olegrand’



Raritan.

A brand of Klegrand’

Chapter 4: KVM Clients

Connection Info

Open the Connection Information dialog for real-time connection information
on your current connection, and copy the information from the dialog as
needed. To edit the connection properties, see Connection Properties (on page
43).

e Toview the Connection Info, choose Connection > Info...

rConnection Info M1

ltern Description Data

1 Device Name kod-101

2 IP Address 192.168.56.27

3 Port 443

4 Data In/Second 11.3 Kbitfs

5 Data Out/Second 352 Kbitjs
|6 Decoded FPS 45

7 Avg. FPS 54.27 (30 Sec.)

k] Connect Time 00:30:43

9 Resolution 1920x 1080

10 RefreshRate 60Hz

mn Color Subsampling Mode 4:2:2

12 Protocol Version 0133

Copy to Clipboard | | Close ] 'J

Keyboard

Send Ctrl+Alt+Del Macro

Due to its frequent use, a Ctrl+Alt+Delete macro is preprogrammed.
Selecting Keyboard > Send Ctrl+Alt+Del, or clicking on the Ctrl+Alt+Delete
button EE in the toolbar sends this key sequence to the server or to the
KVM switch to which you are currently connected.

In contrast, if you were to physically press the Ctrl+Alt+Del keys, the command
would first be intercepted by your own PC due to the structure of the Windows
operating system, instead of sending the key sequence to the target server as
intended.

Send LeftAlt+Tab (Switch Between Open Windows on a Target Server)

Select Keyboard > Send LeftAlt + Tab to switch between open windows on the
target server.

Send Text to Target

> To use the Send Text to Target function for the macro:

1. Click the Keyboard > Send Text to Target. The Send Text to Target dialog
appears.
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2. Enter the text you want sent to the target.

Note: Non-English characters are not supported by the Send Text to Target
function.

3. Ifthe target uses a US/International keyboard layout, select the "Target
system is set to the US/International keyboard layout" checkbox.

4. Click OK.

Keyboard Macros

Keyboard macros ensure that keystroke combinations intended for the target
server are sent to and interpreted only by the target server. Otherwise, they
might be interpreted by your client PC.

Macros are stored on the client PC and are PC-specific. If you use another PC,
you cannot see your macros.

In addition, if another person uses your PC and logs in under a different name,
that user will see your macros since they are computer-wide.

Build a New Macro

»  To build a macro:
1. Click Keyboard > Keyboard Macros. The Keyboard Macros dialog appears.
2. Click Add. The Add Keyboard Macro dialog appears.

3. Type a name for the macro in the Keyboard Macro Name field. This name
appears in the Keyboard menu after it is created.

4. From the Hot-Key Combination field, select a keyboard combination from
the drop-down list. This allows you to execute the macro with a predefined
keystroke. Optional

5. Inthe Keys to Press drop-down list, select each key you would like to use
to emulate the keystrokes that is used to perform the command. Select the
keys in the order by which they are to be pressed. After each selection,
select Add Key. As each key is selected, it appears in the Macro Sequence
field and a Release Key command is automatically added after each
selection.

For example, create a macro to close a window by selecting Left Ctrl + Esc.
This appears in the Macro Sequence box as follows:

Press Left Alt
Press F4

Esc

Release F4

Esc

Release Left Alt

6. Review the Macro Sequence field to be sure the macro sequence is defined
correctly.
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a. Toremove a step in the sequence, select it and click Remove.

b. To change the order of steps in the sequence, click the step and then
click the up or down arrow buttons to reorder them as needed.

Click OK to save the macro. Click Clear to clear all field and start over.

When you click OK, the Keyboard Macros dialog appears and lists the new

keyboard macro.

Click Close to close the Keyboard Macros dialog. The macro now appears
on the Keyboard menu in the application.

Select the new macro on the menu to run it or use the keystrokes you
assigned to the macro.

Importing and Exporting Macros

Macros created in VKC cannot be used in AKC or vice versa. Macros created on
HKC are only compatible with HKC, and cannot be used on AKC or VKC. Likewise,
macros created on VKC or AKC cannot be used on HKC.

Import Macros

> To import macros:

1. Choose Keyboard > Import Keyboard Macros to open the Import Macros
dialog. Browse to the folder location of the macro file.

2. Click on the macro file and click Open to import the macro.

a. Iftoo many macros are found in the file, an error message is displayed
and the import terminates once OK is selected.

b. If the import fails, an error dialog appears and a message regarding
why the import failed is displayed. Select OK to continue the import
without importing the macros that cannot be imported.

3. Select the macros to be imported by checking their corresponding
checkbox or using the Select All or Deselect All options.
4. Click OK to begin the import.

a. Ifaduplicate macro is found, the Import Macros dialog appears. Do
one of the following:
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= Click Yes to replace the existing macro with the imported version.

= (Click Yes to All to replace the currently selected and any other
duplicate macros that are found.

= (Click No to keep the original macro and proceed to the next macro

= Click No to All keep the original macro and proceed to the next
macro. Any other duplicates that are found are skipped as well.

= (Click Cancel to stop the import.

= Alternatively, click Rename to rename the macro and import it. If
Rename is selected, the Rename Macro dialog appears. Enter a
new name for the macro in the field and click OK. The dialog
closes and the process proceeds. If the name that is entered is a
duplicate of a macro, an alert appears and you are required to
enter another name for the macro.

b. If during the import process the number of allowed, imported macros
is exceeded, a dialog appears. Click OK to attempt to continue
importing macros or click Cancel to stop the import process.

The macros are then imported. If a macro is imported that contains a hot key
that already exists, the hot key for the imported macro is discarded.

Export Macros

1. Choose Tools > Export Macros to open the Select Keyboard Macros to
Export dialog.

Close Window Select All
Deselect Al

2. Select the macros to be exported by checking their corresponding
checkbox or using the Select All or Deselect All options.

3. Click OK. An "Export Keyboard Macros to" dialog is displayed. Locate and
select the macro file. By default, the macro exists on your desktop.

4. Select the folder to save the macro file to, enter a name for the file and
click Save. If the macro already exists, you receive an alert message.

5. Select Yes to overwrite the existing macro or No to close the alert without
overwriting the macro.
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Video

Refreshing the Screen

The Refresh Screen command forces a refresh of the video screen

[e* |
e Choose Video > Refresh Screen, or click the Refresh Screen button |—|
in the toolbar.

Screenshot from Target Command (Target Screenshot)

Take a screenshot of a target server using the Screenshot from Target server
command. If needed, save this screenshot to a file location of your choosing as
a bitmap, JPEG or PNG file.

> To take a screenshot of the target server:

1. Select Video > Screenshot from Target, or click the Target Screenshot

button ﬂ on the toolbar.

2. Inthe Save dialog, choose the location to save the file, name the file, and
select a file format from the 'Files of type' drop-down.

3. Click Save to save the screenshot.

Mouse Options
You can operate in either single mouse mode or dual mouse mode.

When in a dual mouse mode, and provided the option is properly configured,
the mouse cursors align.

When controlling a target server, the Remote Console displays two mouse
cursors - one belonging to your Dominion KX IV-101 client workstation, and the
other belonging to the target server.

When there are two mouse cursors, the device offers several mouse modes:
e Absolute (Mouse Synchronization)

e Intelligent (Mouse Mode)

e Standard (Mouse Mode)

When the mouse pointer lies within the KVM Client target server window,
mouse movements and clicks are directly transmitted to the connected target
server.

While in motion, the client mouse pointer slightly leads the target mouse
pointer due to mouse acceleration settings.

Single mouse mode allows you to view only the target server's pointer. You can
use Single mouse mode when other modes don't work.

You can toggle between these two modes (single mouse and dual mouse).
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Dual Mouse Modes
Absolute Mouse Synchronization

In this mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different acceleration
or speed.

This is the default mouse mode.

> To enter Absolute Mouse Synchronization:
e Choose Mouse > Absolute from the KVM client.

Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse settings and
synchronize the mouse cursors accordingly, allowing mouse acceleration on the
target. Use intelligent mouse mode if absolute mouse mode is not supported
on the target.

Enter Intelligent Mouse Mode

»  To enter intelligent mouse mode:
e Choose Mouse > Intelligent.
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Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the Mouse
menu, automatically synchronizes mouse cursors during moments of inactivity.
For this to work properly, however, the following conditions must be met:

e The active desktop should be disabled on the target.

e No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of the
target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e The target advanced mouse properties such as “Enhanced pointer
precision" or “Snap mouse to default button in dialogs” should be disabled.

e The edges of the target video should be clearly visible (that is, a black
border should be visible between the target desktop and the remote KVM
console window when you scroll to an edge of the target video image).

e When using the intelligent mouse synchronization function, having a file
icon or folder icon located in the upper left corner of your desktop may
cause the function not to work properly. To be sure to avoid any problems
with this function, do not have file icons or folder icons in the upper left
corner of your desktop.

After autosensing the target video, manually initiate mouse synchronization by
clicking the Synchronize Mouse button on the toolbar. This also applies when
the resolution of the target changes if the mouse cursors start to desync from
each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.

Please note that mouse configurations will vary on different target operating
systems. Consult your OS guidelines for further details. Also note that
intelligent mouse synchronization does not work with UNIX targets.
Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization algorithm. The
algorithm determines relative mouse positions on the client and target server.

In order for the client and target mouse cursors to stay in synch, mouse
acceleration must be disabled. Additionally, specific mouse parameters must
be set correctly.

»  To enter Standard Mouse mode:
e Choose Mouse > Standard.
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Mouse Synchronization Tips
If you have an issue with mouse synchronization:

1. Verify that the selected video resolution and refresh rate are among those
supported by the device. The KVM Client Connection Info dialog displays
the actual values that the device is seeing.

2. If that does not improve the mouse synchronization (for Linux, UNIX, and
Solaris KVM target servers):

Open a terminal window.

3
4. Enter the following command: xset mouse 1 1
5. Close the terminal window.

6

Click the "KVM Client mouse synchronization" button.

Synchronize Your Mouse

In dual mouse mode, the Synchronize Mouse command forces realignment of
the target server mouse cursor with the client mouse cursor.

*  To synchronize the mouse cursors, do one of the following:

e  Click the Synchronize Mouse button m in the KVM client toolbar, or
select Mouse > Synchronize Mouse from the menu bar.

Note: This option is available only in Standard and Intelligent mouse modes.

Cursor Shape

In dual mouse modes, you can select a custom cursor shape for your session.
To make the cursor selection permanent, see Client Launch Settings (on page
57).

> To change the cursor shape:

e Choose Mouse > Cursor Shape, then select from the list.
= Default arrow
= Dot
= Crosshair

=  Transparent

Mouse|T00|s View Virtual Media Audio Power (

Sync Mouse

Single Mouse Cursor

‘ Cursor Shape b ‘fj Default

@ Absolute Dot
Intelligent Crosshair

Standard Transparent
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Single Mouse Mode

Single Mouse mode uses only the target server mouse cursor; the client mouse
cursor no longer appears onscreen.

Note: Single mouse mode does not work on Windows or Linux targets when the
client is running on a Virtual Machine.

> To enter single mouse mode, do one the following:
e Choose Mouse > Single Mouse Cursor.

e Click the Single/Double Mouse Cursor button h in the toolbar.

Single Cursor

—

You are about to enter Single Cursor moede. While you are in this mode,
W this software will have exclusive control over the mouse and keyboard,

To exit single cursor mode, you must press Ctrl+ Leftalt+ 0
[] Scale the video {no scroll bars)

Lok || cancel

> To exit single mouse mode:

1. Press Ctrl+Alt+0 on your keyboard to exit single mouse mode.

Tool Options
General Settings

»  To set the tools options:
1. Click Tools > Options. The Options dialog appears.

2. OpenGL rendering of scaled KVM images is enabled by default. If there are
performance issues, select the Disable Hardware Accelerated Rendering
checkbox to disable. Only available in AKC.

3. Select the Enable Logging checkbox only if directed to by Technical
Support.

This option creates a log file in your home directory.
4. Choose the Keyboard Type from the drop-down list (if necessary).
The options include:
= US/International
=  French (France)

=  German (Germany)
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= Japanese

=  United Kingdom

= Korean (Korea)

=  French (Belgium)

= Norwegian (Norway)
= Portuguese (Portugal)
= Danish (Denmark)

= Swedish (Sweden)

= German (Switzerland)
= Hungarian (Hungary)
= Spanish (Spain)

= ltalian (Italy)

= Slovenian

= Translation: French - US

=  Translation: French - US International

In AKC, the keyboard type defaults to the local client, so this option does
not apply.

Select Adjust Full Screen Window Size to Target Resolution Instead of
Client Resolution if you prefer. Option not available for Linux clients. See
Adjust Full Screen Window Size to Target Resolution (on page 56) for
details and examples.

In Mac 0OS/VKCs launches only, Let Full Screen Window Cover the Main
Menu Bar and the Dock is enabled by default. Use this setting to prevent
the Java menubar from hiding the VKCs menubar when running VKCs in
full-screen mode on Mac.

Configure hotkeys:
=  Toggle Full Screen Mode - Hotkey.

When you enter Full Screen mode, the display of the target server
becomes full screen and acquires the same resolution as the target
server.

This is the hot key used for toggling in and out of this mode.
=  Toggle Single Cursor Mode - Hotkey.

When you enter single cursor mode, only the target server mouse
cursor is visible.

This is the hot key used to toggle in and out of single cursor mode,
removing and bringing back the client mouse cursor.

= Toggle Scaling Mode - Hotkey.
When you enter scaling mode, the target server scales to fit your
display.

This is the hot key used to toggle in and out of scaling mode.
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= Disconnect from Target - Hotkey.
Enable this hotkey to allow users to quickly disconnect from the target.

For hotkey combinations, the application does not allow you to assign the
same hotkey combination to more than one function.

For example, if Q is already applied to the Disconnect from Target function,
it won't be available for the Toggle Full Screen Mode function.

Further, if a hotkey is added to the application due to an upgrade and the
default value for the key is already in use, the next available value is
applied to the function instead.

8. Click OK.

Options >
General Client Launch Settings
[] Disable Hardware Accelerated Rendering

[ Enable Logging

] Adjust Full Screen Window Size to Target
J Resolution instead of Client Resolution

Toggle Full Screen Mode - HotKey: Chri+LeftAlt+M  ~

Toggle Single Cursor Mouse Mode - Hotkey:  Clri+LeftAlt+O  ~

Toggle Scaling Mode - Hotkey: Cir+LeftAlt+S  ~
Disconnect From Target - HotkKey: Chri+LeftAlt+Q
[0k ] canc
Keyboard Limitations

Turkish Keyboards

Turkish keyboards are only supported on Active KVM Client (AKC).
Slovenian Keyboards

The < key does not work on Slovenian keyboards due to a JRE limitation.
Language Configuration on Linux

Because the Sun JRE on Linux has problems generating the correct Key Events
for foreign-language keyboards configured using System Preferences, configure
foreign keyboards using the methods described in the following table.

Language Configuration method
US Intl Default
French Keyboard Indicator
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Language Configuration method

German System Settings (Control Center)
Japanese System Settings (Control Center)
UK System Settings (Control Center)
Korean System Settings (Control Center)
Belgian Keyboard Indicator

Norwegian Keyboard Indicator

Danish Keyboard Indicator

Swedish Keyboard Indicator

Hungarian System Settings (Control Center)
Spanish System Settings (Control Center)
Italian System Settings (Control Center)
Slovenian System Settings (Control Center)
Portuguese System Settings (Control Center)

Note: The Keyboard Indicator should be used on Linux systems using Gnome as
a desktop environment.

Adjust Full Screen Window Size to Target Resolution

When Adjust Full Screen Window Size to Target Resolution Instead of Client
Resolution is enabled, the client starts in full-screen in a window equal to the
target's resolution, not the resolution of the client monitor. If you have a
multi-monitor client, a full-screen window may cover more than one monitor.
See General Settings (on page 53) for instructions on enabling the setting.

> Example:

The client has a multi-head environment with 8 monitors, 1920 x 1080 each
with the following arrangement:

1 2 3 4
5 6 7 8

A KVM session is launched on monitor 6 with a the target resolution of 3840 x
1080. The client window opens on monitor 6 and 7 in native resolution and
covers both monitors by 100%.
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Client Launch Settings

Configuring client launch settings allows you to define the screen settings for a
KVM session.

> To configure client launch settings:
1. Click Tools > Options. The Options dialog appears.
2. Click on the Client Launch Settings tab.
= To configure the target window settings:
= Select 'Standard - sized to target Resolution' to open the window
using the target's current resolution. If the target resolution is
greater than the client resolution, the target window covers as

much screen area as possible and scroll bars are added (if
needed).

= Select 'Full Screen' to open the target window in full screen mode.
= To configure the monitor on which the target viewer is launched:

= Select 'Monitor Client Was Launched From' if you want the target
viewer to be launched using the same display as the application
that is being used on the client (for example, a web browser or
applet).

= Use 'Select From Detected Monitors' to select from a list of
monitors that are currently detected by the application. If a
previously selected monitor is no longer detected, 'Currently
Selected Monitor Not Detected' is displayed.

= To configure cursor shape:

= Select Default arrow, Dot, Crosshair, or Transparent to set the
cursor shape for all sessions. Use the Mouse menu to change the
cursor shape during a session.

= To configure additional launch settings:
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= Select 'Enable Single Cursor Mode' to enable single mouse mode
as the default mouse mode when the server is accessed.

= Select 'Enable Scale Video' to automatically scale the display on
the target server when it is accessed.

= Select 'Pin Menu Toolbar' if you want the toolbar to remain visible
on the target when it is in Full Screen mode. By default, while the
target is in Full Screen mode, the menu is only visible when you
hover your mouse along the top of the screen.

= Always Show Tool Bar and Always Show Status Bar are per-user
settings that are stored in the computer you are accessing the
client from, so if you use a different computer, the setting may be
different. Select to keep tool bar and status bar visible as default,
deselect to keep tool bar and status bar hidden as default.

3. Click OK.

Options X
General Client Launch Settings
Window Mode
(®) Standard - sized to target resolution
() Full Screen

Monitor
(®) Monitor Client Was Launched From

() Select From Detected Monitors
Monitor A

Detected Monitors

Cursor Shape

(®) Default () Dot

() Crosshair () Transparent
Other

[ ] Enable Single Mouse Cursor
[ ] Enable Scale Video

[ ] Pin Menu Toolbar

Always Show Tool Bar
Always Show Status Bar

Cancel
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Collecting a Diagnostic Snapshot of the Target

Administrators are able to collect a "snapshot" of a target.
The "snapshot" function generate log files and image files from the target.

It then bundles these files in a zip file that can be sent to Technical Support to
help diagnose technical problems you may be encountering.

The following files are included in the zip file:
e screenshot_image.png

This is a screenshot of the target that captures a picture of the issue you
are experiencing. This feature operates like the "Screenshot from Target"
feature.

e raw_video_image.png:

A snapshot image created from raw video data. Please note that client's
postprocessing is applied, just as if it were a "regular" screen update.

e raw_video_ycbcr420.bin:

Binary file of the raw snapshot.
e raw_video_ycbcr420.txt:

Text file containing data used to help diagnose issues.
e Log.txt file:

These are the client logs.

Note that the logs are included even if you have not enabled information
to be captured in them. VKC uses internal memory to capture the
information in this case.

Collect a Diagnostic Snapshot
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»  To capture a diagnostic snapshot:

[Took) view Virtal Megia Audio SmartCard Couer ool Help
Options...
Cellert Dingaentics Snapahe,.,

.'l'
Nebwork  Faesoftyoe:  [Z1p archive fles

File name:

(T - v - 80
Steps
@ Access a target, and then click Tools > Collect a Diagnostic Snapshot.
Several messages are displayed as the information is collected.
@ You are prompted to save the zip file containing the diagnostic files.

@ The zip file containing the diagnostic files is saved.
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View Options

View Toolbar

You can use the Virtual KVM client with or without the toolbar display.

> To toggle the display of the toolbar (on and off):
e Choose View > View Toolbar.

View Status Bar

By default, the status bar is displayed at the bottom of the target window.

»  To hide the status bar:
Click View > Status Bar to deselect it.

> Torestore the status bar:
Click View > Status Bar to select it.

Scaling

Scaling your target window allows you to view the entire contents of the target
server window.

This feature increases or reduces the size of the target video to fit the Virtual
KVM Client window size, and maintains the aspect ratio so that you see the
entire target server desktop without using the scroll bar.

> To toggle scaling (on and off):
e Choose View > Scaling.
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Full Screen Mode

When you enter Full Screen mode, the target's full screen is displayed and
acquires the same resolution as the target server.

The hot key used for exiting this mode is specified in the Options dialog, see
Tool Options (on page 53).

While in Full Screen mode, moving your mouse to the top of the screen
displays the Full Screen mode menu bar. The behavior of the menu in full
screen mode is affected by some options on the Tool Options menu. See Tool
Options > General Settings > Full Screen options

If you want the menu bar to remain visible while in Full Screen mode, enable
the Pin Menu Toolbar option from the Tool Options dialog. See Tool Options
(on page 53).

> To enter full screen mode:
e Choose View > Full Screen, or click the Full Screen button @

> To exit full screen mode:

e Press the hot key configured in the Tool's Options dialog. The default is
Ctrl+Alt+M.

If you want to access the target in full screen mode at all times, you can make
Full Screen mode the default.

> To set Full Screen mode as the default mode:

Note: Not available in LX2.

1. Click Tools > Options to open the Options dialog.

2. Select Enable Launch in Full Screen Mode and click OK.

Virtual Media

Access a Virtual Media Drive on a Client Computer

Important: Once you are connected to a virtual media drive, do not change
mouse modes in the KVM client if you are performing file transfers, upgrades,
installations or other similar actions. Doing so may cause errors on the virtual
media drive or cause the virtual media drive to fail.
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To access a virtual media drive on the client computer:

From the KVM client, choose Virtual Media > Connect Drive, or click the

Connect Drive... button D . The Map Virtual Media Drive dialog
appears.

Map Virtual Media Drive X

Select a local drive or image to mount onto the target server.

(®) Local Drive:
F: (Removable) v [ ] Read-Write

() Image File
Image Path:

El Cancel

Choose the drive from the Local Drive drop-down list.

If you want Read and Write capabilities, select the Read-Write checkbox.

This option is disabled for nonremovable drives. See the Conditions when
Read/Write is Not Available (on page 173) for more information.

When checked, you will be able to read or write to the connected USB disk.

WARNING: Enabling Read/Write access can be dangerous! Simultaneous
access to the same drive from more than one entity can result in data
corruption. If you do not require Write access, leave this option unselected.

Click OK. The media will be mounted on the target server virtually. You can
access the media just like any other drive.

Access a Virtual Media Image File

Use the "Image File" option to access a disk image of a removable disk.

>

Image file guidelines:

Image files created using dd on Linux (dd if=/dev/sdb of=disk.img) or
similar tools such as Win32Diskimager on Windows, or Mac Disk Utility are
supported.

Apple DMG files:
= DMG image files of a FAT32 USB drive are recognized on all OSs.

= DMG images files of a folder on a Mac Drive are recognized only on
Mac OS targets.
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= |mage should be created via Mac Disk Utility using the following
settings: Encryption: None; Image format: read/write.

= Not supported: Encrypted or compressed dmg images, MacOS install
images, DMG files downloaded from the Apple support site.

> To access a virtual media image file:

1. From the KVM client, choose Virtual Media > Connect Drive, or click the
Connect Drive... button . The Map Virtual Media Drive dialog appears.

2. Select the Image File option, then click Browse to find and select the .img
or .dmg file.

3. Click OK. The media will be mounted on the target server virtually.

Mounting CD-ROM/DVD-ROM/ISO Images
This option mounts CD-ROM, DVD-ROM, and ISO images.

Note: ISO9660 format is the standard supported. However, other CD-ROM
extensions may also work.

* To access a CD-ROM, DVD-ROM, or ISO image:
1. From the KVM client, choose Virtual Media > Connect CD-ROM/ISO Image,

i
or click the Connect CD ROM/ISO button . The Map Virtual Media
CD/I1SO Image dialog appears.

2. Forinternal and external CD-ROM or DVD-ROM drives:
a. Choose the Local CD/DVD Drive option.

b. Choose the drive from the Local CD/DVD Drive drop-down list. All
available internal and external CD and DVD drive names will be
populated in the drop-down list.

c. Click OK.
3. ForISO images:

a. Choose the ISO Image option. Use this option when you want to
access a disk image of a CD, DVD, or hard drive. ISO format is the only
format supported.

b. Click Browse.

c. Navigate to the path containing the disk image you want to use and
click Open. The path is populated in the Image Path field.

d. Click OK.
4. For remote ISO images on a file server:
a. Choose the Remote Server ISO Image option.

b. Choose Hostname and Image from the drop-down list. The file servers
and image paths available are those that you configured using the
Virtual Media Shared Images page. Only items you configured using
the Virtual Media Shared Images page will be in the drop-down list.
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c. File Server Username - User name required for access to the file server.
The name can include the domain name such as mydomain/username.

d. File Server Password - Password required for access to the file server
(field is masked as you type).

e. Click OK.

The media will be mounted on the target server virtually. You can access
the media just like any other drive.

Note: If you are working with files on a Linux® target, use the Linux Sync
command after the files are copied using virtual media in order to view the
copied files. Files may not appear until a sync is performed.

Note: If you are using the Windows 7° operating system*, Removable Disk is not
displayed by default in the Window's My Computer folder when you mount a
Local CD/DVD Drive or Local or Remote ISO Image. To view the Local CD/DVD
Drive or Local or Remote ISO Image in this folder, select Tools > Folder Options >
View and deselect "Hide empty drives in the Computer folder".

Disconnect from Virtual Media Drives

»  To disconnect the virtual media drives:
e  For local drives, choose Virtual Media > Disconnect Drive.

e For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media >
Disconnect CD-ROM/ISO Image.

Note: In addition to disconnecting the virtual media using the Disconnect
command, simply closing the KVM connection closes the virtual media as well.

Digital Audio
The Dominion KX IV-101 supports audio playback over HDMI.

Supported Audio Device Formats

The following playback formats are supported:

e Stereo, 16bit, 44.1K
e Stereo, 16bit, 32K
e Stereo, 16bit, 48K
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Digital Audio VKC and AKC Icons

Audio Icon name
icons

)|
o
.

Speaker

.:L Microphone

Description

These icons are located in status bar at the bottom of
the client window.

Green, blinking waves indicate an audio playback
session is currently streaming.

A black speaker icon is displayed when the session is
muted.

The icon is grayed out when no audio is connected.

Playback is not supported. Microphone icon appears
grayed out.

Audio Playback Recommendations and Requirements

> Audio level:

e Set the target audio level

to a mid-range setting.

e For example, on a Windows’ client, set the audio to 50 or lower.

e This setting must be configured through the playback device, not from the
client audio device control.

Bandwidth Requirements

The table below details the audio playback bandwidth requirements to
transport audio under each of the selected formats.

Audio format
44.1 KHz, 16bit stereo

32 KHz, 16bit stereo,
48 KHz, 16bit stereo
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Network bandwidth requirement
176 KB/s

128KB/s
192KB/s
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In practice, the bandwidth used when an audio device connects to a target is
higher due to the keyboard and video data consumed when opening and using
an audio application on the target.

A general recommendation is to have at least a 1.5MB connection before
running audio/video.

However, high video-content, full-color connections using high-target screen
resolutions consume much more bandwidth and impact the quality of the
audio considerably.

To help mitigate quality degeneration, there are a number of recommended

client settings that reduce the impact of video on audio quality at lower
bandwidths:

e Connect audio playback at the lower quality formats. The impact of video
consuming bandwidth is much less notable at 11k connections than at 44k

e Set the connection speed under Connection Properties to a value that best
matches the client to server connection

Under Connection Properties, set the color depth to as low a value as possible.
Reducing the color depth to 8 bit color considerably reduces the bandwidth
consumed

Saving Audio Settings

Audio device settings are applied on a per Dominion KX IV-101 device basis.

Once the audio devices settings are configured and saved on the Dominion KX
IV=101, the same settings are applied to it.

See Connecting and Disconnecting from a Digital Audio Device for information
on connecting to and configuring an audio device, and Adjusting Buffer Size
(Audio Settings) for information on audio device buffer settings.

If you are using the audio feature while running PC Share mode and VM Share
mode so multiple users can access the same audio device on a target at once,
the audio device settings of the user who initiates the session are applied to all
users who join the session.

So, when a user joins an audio session, the target machine settings are used.

Connecting and Disconnecting a Digital Audio Device

Audio device settings are applied on a per Dominion KX IV-101 device basis.

Once the audio devices settings are configured and saved on the Dominion KX
IV=101, the same settings are applied to it.

See Saving Audio Settings (on page 67) for more information.
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Connect to a Digital Audio Device

»  To connect to an audio device:

1. Connect the audio device to the remote client PC prior to launching the
browser connection to the Dominion KX IV=101.

2. Connect to the target from the Port Access page.

i
3. Once connected, click the Audio button Eﬂ :I] in the toolbar.

The Connect Audio Device dialog appears. A list of available audio devices
connected to the remote client PC is displayed.

Note: If there are no available audio devices connected to the remote client
PC, the Audio icon is grayed out. .

Check Connect Playback Device if you are connecting to a playback device.
Select the device that you wish to connect from the drop-down list.

Select the "Mount selected playback device automatically on connection to
target" checkbox to automatically connect an audio playback device when
you connect to an audio supporting target.

7. Click OK. If the audio connection is established, a confirmation message
appears. Click OK.

If the connection was not established, an error message appears.

Once an audio connection is established, the Audio menu changes to
Disconnect Audio. The settings for the audio device are saved and applied
to subsequent connections to the audio device.

A Speaker icon _is displayed in the status bar at the bottom of the client
window. It is grayed out when no audio is being used.

Disconnect from an Audio Device
»  To disconnect from the audio device:

P
e C(Click the Audio icon ‘@ in the toolbar and select OK when you are
prompted to confirm the disconnect. A confirmation message appears.
Click OK.
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Adjusting Playback Buffer Size
Capture buffer size is not adjustable on Dominion KX IV-101. Playback buffer
can be adjusted as needed once an audio device is connected.

This feature is useful for controlling the quality of the audio, which may be
impacted by bandwidth limitations or network spikes. Increasing the buffer size
improves the audio quality but may impact the delivery speed. The maximum
available buffer size is 400 milliseconds since anything higher than that greatly
impacts audio quality.

The buffer size can be adjusted whenever needed, including during an audio
session.

Audio settings are configured in VKC or AKC.

> To adjust audio settings:

1. Select Audio Settings from the Audio menu. The Audio Settings dialog
opens.

2. Adjust the capture and/or playback buffer size as needed. Click OK.

Capture Buffer Size: miliseconds

Flayback Buffer Size: miliseconds

External Device

The External Device menu allows you to control the device connected at the
terminal block of the Dominion KX IV-101.

External Device Settings:
Choose External Device > Settings to view the dialog.

The device state is listed.

w N =T

Enabled devices can be controlled using the Actions options.

= Turn External Device On/Off: Click On or Off to control terminal output
relay.

69



Chapter 4: KVM Clients

= Blink External Device: Enter the half-second interval to control blinking
of the external device.

External Device Settings ﬂ

Actual External Device State: Disabled

Actions

1 Interval (Half-Seconds)

[0k Gonel |

4. Click OK or Apply to save.

Version Information - Virtual KVM Client

For version information about the client, in case you require assistance from
Raritan Technical Support.

e Choose Help > About Raritan Virtual KVM Client.

Active KVM Client (AKC) Help

To launch AKC, enter https://<IP address>/akc in a browser.

The Active KVM Client (AKC) is based on Microsoft Windows .NET* technology.
This allows you to run the client in a Windows environments without Java..
AKC provides the same features as VKC with the exception of the following:

e Keyboard macros created in AKC cannot be used in any other client.
e Direct port access configuration

e AKC server certification validation configuration (see Prerequisites for
Using AKC (on page 71))

For details on using the features, see Virtual KVM Client (VKC) Help.
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Overview

The Active KVM Client (AKC) is based on Microsoft Windows .NET* technology.
This allows you to run the client in a Windows environments without Java..
AKC provides the same features as VKC with the exception of the following:

e Keyboard macros created in AKC cannot be used in any other client.

e Direct port access configuration

e AKC server certification validation configuration (see Prerequisites for
Using AKC (on page 71))

For details on using the features, see Virtual KVM Client (VKC) Help.

AKC Supported Microsoft .NET Framework

The Active KVM Client (AKC) requires Windows .NET". See the Release Notes for
supported versions.

AKC Supported Browsers

See the Release Notes for supported browser versions.

AKC Supported Operating Systems

When launched from Internet Explorer®, the Active KVM Client (AKC) allows you
to reach target servers via the Dominion KX IV-101.

AKC is compatible with the following platforms:
e Windows 10 ° operating system (up to 64 bit)

See the Release Notes for the latest supported versions.

Prerequisites for Using AKC

Allow Cookies

Ensure the cookies from the IP address of the device that is being accessed are
not currently being blocked.

Include Dominion KX IV-101 IP Address in 'Trusted Sites Zone'

Add the IP address of the device being accessed to the browser's Trusted Sites
Zone.

Disable 'Protected Mode'

Make sure that Protected Mode is not on when accessing this device.
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Edge Chromium versions

The Edge Chromium browser has experimental ClickOnce support which must
be enabled for AKC. The browser will not detect support for ClickOnce, so you
will still need to download AKC manually.

To enable ClickOnce in Edge: Type edge://flags in the browser, search for
ClickOnce support, set to enabled and restart the browser.

To download AKC manually: Go to the Dominion KX IV-=101 URL, for

example https://(KX-IP-Hostname)/akc then select "Please click here" on
the message showing that ClickOnce support has not been detected.

Proxy Server Configuration

When the use of a Proxy Server is required, a SOCKS proxy must also be
provided and configured on the remote client PC.

Note: If the installed proxy server is only capable of the HTTP proxy protocol,
you cannot connect.

>

1.

To configure the SOCKS proxy:
On the remote client PC, select Control Panel > Internet Options.

a. Onthe Connections tab, click 'LAN settings'. The Local Area Network
(LAN) Settings dialog opens.

b. Select 'Use a proxy server for your LAN'.
Click Advanced. The Proxy Settings dialog opens.
d. Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).

e. Click OK at each dialog to apply the settings.
Next, configure the proxy settings for the Java” applets:
a. Select Control Panel > Java.

b. On the General tab, click Network Settings. The Network Settings
dialog opens.

Select "Use Proxy Server".
d. Click Advanced. The Advanced Network Settings dialog opens.
e. Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols'.

Note: The default port for a SOCKS proxy (1080) is different from HTTP
proxy (3128).
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HTML KVM Client (HKC)

Raritan.

A brand of Klegrand’

The HTML KVM client (HKC) provides KVM over IP access that runs in the
browser without the need for applets or browser plugins. HKC uses Javascript,
NOT Java.

HKC runs on Linux and Mac clients, and on Windows clients in Internet Explorer
11 (not supported in IE 10 or lower), Edge, Firefox, Chrome and Safari
browsers.

Many KVM features are supported. Future releases will provide more advanced
KVM features.

>  Supported Features:

e Connection Properties

e Input Settings

e Audio Playback

e Virtual Media

e Keyboard Macros

e Import and Export of Keyboard Macros
e Send Text to Target

e Keyboard and Mouse Settings

e Single Mouse Mode - not available on IE browser
e  External Device

>  Not supported:
e Video Settings

e Tools Menu for setting client launch settings, setting disconnect from
target hotkey, or configuring toolbar display.

e Limited keyboard support: US-English, UK-English, French, and German are
supported

e Hotkeys for keyboard macros
e Pre-populated keyboard macros for Sun targets

e Can only create Macros from keys that exist on the client PC (US-English,
UK-English, French, or German), no special function keys

e Single Mouse mode - not available on IE

e  Virtual Media write not supported

e Local file transfer supported by Chrome and Firefox browsers only
e  USB drive connects

e  Audio capture

»  Known Issues:

e If HKC does not load, but rather displays a white screen, your browser
memory may be full. Close all browser windows and try again.
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Connection Properties

Connection properties manage streaming video performance over remote
connections to target servers.

The properties are applied only to your connection - they do not impact the
connection of other users accessing the same target servers.

If you make changes to connection properties, they are retained by the client.

* To view connection properties:

e Choose File > Connection Properties.

Connection Properties

Video Encoding

Usage General Purpose Video
=
5 1 2 3 4 5 6 7 8 o
3 o
(€] ot
e Full Color B
(1] 3
E g
E Color Subsampling %
Automatic
4:4:4 (if available) 4:2:2 4.2:0

Source 0x0 @ 60 Hz

Performance 0.00 FPS, 0.00 bit/s incoming

Encryption On

> Video Encoding

This section selects the video encoding algorithm and quality setting.

Usage: specify your general application area. This selection optimizes the
available choices elsewhere in this dialog.

=  General Purpose Video: video content where smooth color

reproduction is most important, such as movies, video games, and
animations.

Computer and IT Applications: video content where text sharpness and
clarity are important, such as computer graphical interfaces.

Raritan.
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Encoder Mode: Choose the encoder mode from the row of eight buttons.
Options will vary depending on the Usage selection. In general, modes
towards the left of the button bar offer higher image quality but consume
higher bandwidth, and might cause frame rate to drop depending on
network speed and/or client performance. Modes towards the right
consume lower bandwidth at the cost of reduced image quality. In
network- or client-constrained situations, modes towards the right may
achieve better frame rates.

The default video mode is always "Full Color 2", which is a high-quality mode
and works well for most uses in LAN environments. If needed, experiment with
modes further towards the right to find the right balance of image quality and
frame rate.

>

Color Subsampling

Color subsampling reduces the color information in the encoded video stream.

»>

Automatic: Recommended. The optimal color subsampling mode will be
enabled based on the selections in the video encoding section.

4:4:4: Highest quality at significant bandwidth cost. Usually not necessary
except for some situations in graphical user interfaces. Not supported for
resolutions above 1920x1200, so for those resolutions color subsampling
will automatically drop down to 4:2:2.

4:2:2: Good blend of image quality and bandwidth.

4:2:0: Maximum savings of network bandwidth and client load. Works fine
for most general-purpose applications that don't emphasize
high-resolution lines or text.

Current Status

Current status includes real-time video performance statistics. As you change
settings in the dialog, you can immediately see the effects on performance.

Raritan.
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Source: resolution and frame rate of the incoming video source.

Performance: frames per second (FPS) being rendered in the client, and
the data rate of the incoming video stream. These values are where you
will see the effects of your video settings.

Encryption: whether the video stream is encrypted or not. Encrypted
streams usually have lower frame rates and lower bandwidth. Encryption is
a global setting in security - KVM Security = "Apply Encryption Mode to
KVM and Virtual Media".
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Connection Info

Open the Connection Information dialog for real-time connection information
on your current connection, and copy the information from the dialog as

needed.

See Default Connection Properties for help configuring the connection

properties.

e Name of the device
e |P address of the device

e  Port-The KVM communication TCP/IP port used to access the device

e Data In/Second - Data rate received from the device

e Data Out/Second - Data rate sent to the device

e FPS-Video frames per second from the device.

e Average FPS - Average number of video frames per second.

e Connect Time - The duration of the current connection.

e  Resolution - The target server's horizontal and vertical resolution.

o Refresh Rate - Refresh rate of the target server.

e  Protocol Version - communications protocol version.

> To view connection info:

e Choose File > Connection Info.

Device Name:

IF Address:

Port:

Data In/Second:
Data Out/Second:
FPS:

Avg. FPS:

Connect Time:
Horizontal Resolution:
‘Vertical Resolution:
Refresh Rate:
Protoceol Version:

Connection Info

kx3-61-16
192.168.61.16
443

121 kBis
234 Bis
17

21.80
00:00:25
1024

768

60 Hz
1.31

oK
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Input Menu

Keyboard Layout

>  To set your keyboard type.

e Choose Input > Keyboard Layout, then select your keyboard type.

de-de
de-ch
en-gb
en-us
fr

Send Macro

Due to frequent use, several keyboard macros are preprogrammed.

* To send a preprogrammed macro:

e Choose Input > Send Macro, then select the macro:

Ctrl+Alt+Del: Sends the key sequence to the target without affecting
the client.

Alt+F4: Closes a window on a target server.
Alt+Tab: Switch between open windows on a target server.

Print Screen: Take a screenshot of the target server.

Input ~ Video - View - Virtual Media ~
A Keyboard Layout ' ) | gy I8

&2 Send Macro Ctri+Alt+Del
# Macro Editor Alt+F4

= Send text to target Alt+Tab

4 Mouse Modes

> Mouse Sync

Print Screen
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Macro Editor

Keyboard macros ensure that keystroke combinations intended for the target
server are sent to and interpreted only by the target server. Otherwise, they
might be interpreted by your client PC.

Macros are stored on the client PC and are PC-specific. If you use another PC,
you cannot see your macros.

In addition, if another person uses your PC and logs in under a different name,
that user will see your macros since they are computer-wide.

Macros created with HKC are only available with the current browser and KVM
device. If you use HKC in more than one browser, or more than one Dominion
KX IV=101, your macros will only be available on the browser and Dominion KX
IV-101 where they were created. To reuse your macros in another Dominion
KX IV=101 device, you can import and export the macro files. See Import and
Export Macros (on page 82).

»  To access the Macro Editor:
e Choose Inputs > Macro Editor.

e Select a macro from the Macros list to view the key combination.

Macro Editor

Name Ctrl+Alt+Del
Macros Keys
Ctri+Alt+Del o press: CTRL LEFT o Add Key
Alt+F4 press: ALT LEFT
Alt+Tab press: DELETE Add Delay
Print Screen release: CTRLLEFT
release: ALT LEFT i
release: DELETE
- -
Delete

Delete Macro Use in Toolbar

Add New Macro

Export Import

m Cancel

Add New Macro

» To add a new macro:

1. Choose Inputs > Macro Editor.
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Click Add New Macro.

Macro Editor

Name New Macro
Macros Keys
Ctri+Alt+Del - - Add Key
Alt+F4
Alt+Tab Add Delay
Print Screen
New Macro i
- -
w

Delete

Add New Macro Delete Macro Use in Toolbar

Enter a Name for the new macro. The name will appear in the Send Macro
menu once the macro is saved.

Click Add Key, then press the key you want to add to the macro. The key
press and key release appear in the Keys list.

= To add more keys, click Add Key again, and press another key.
= Toremove a key, select it in the Keys list and click Delete Key

To put the keys in the correct sequence, click to select a key in the Keys list,
then click the up and down arrows.

To add a 500 ms delay to a key sequence, click Add Delay. A delay in the
middle of a press-and-release key sequence indicates holding down a key.
Add multiple delays to indicate a longer press-and-hold of a key. Click the
up and down arrows to move the delays into the correct sequence.
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7. Click OK to save. To use this macro from your toolbar, click Use in Toolbar.
See Add a Macro to the Toolbar (on page 80) for more details.

Export Import

Add New Macro Delete Macro

Option-Command-P-R added to toolbar

Macro Editor

Name Option-Command-P-R
Macros Keys

Ctri+Alt+Del I -

Alt+F4 press: META
Alt+Tab press: P =|

Print Screen press: R

delay- 500ms 4

delay: 500ms

delay: 500ms
i delay: 500ms 2

Add Key

Add Delay

This example shows a macro for a Mac bootup sequence that requires a

2-second delay.

Add a Macro to the Toolbar

You can add a single macro to your HKC toolbar, so that you can use the macro

by clicking an icon.

» To add a macro to the toolbar:

1. Choose Inputs > Macro Editor.

2. Select a macro from the Macros list.

80
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3. Click Use in Toolbar.

Macro Editor

Name New Macro
Macros Keys
Cirl+Alt+Del - press: ENTER Add Key
Alt+E4 delay. 500ms
Alt+Tab Add Delay
Print Screen
New Macro
i Delete
Add New Macro Delete Macro Use in Toolbar

(o [ o

4. A message appears to confirm the macro is added to the toolbar.

=  To remove the macro from the toolbar, click Remove from Toolbar, or
select a different macro and click Use in Toolbar.

Delete Macro Remove from Toolbar

New Macro added to toolbar m—

5. Click OK and exit the Macro Editor. The macro icon is added to the toolbar
when one has been set.

S hEHE CEE@ 0@ agg| v

Delete a Macro

» To delete a macro:
1. Choose Inputs > Macro Editor.

2. Select the macro, then click Delete Macro.

Raritan. 81
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3. Click OK.

Macro Editor

Name New Macro

Macros Keys

Ctri+Alt+Del - - Add Key
Alt+F4

Alt+Tab Add Delay
Print Screen

New Macro i3

1|

Delete

Add New Macro Delete Macro Use in Toolbar

Import and Export Macros

Macros created with HKC are only available with the current browser and KVM
device. If you use HKC in more than one browser, or more than one Dominion
KX 1V=101, your macros will only be available on the browser and Dominion KX
IV=101 where they were created. To reuse your macros in another Dominion
KX IV-101 device, you can import and export the macro files. Imported and
exported macro files created on HKC are only compatible with HKC, and cannot
be used on AKC or VKC. Likewise, macro files created on AKC or VKC cannot be
imported for use on HKC.

Macros are exported to an xml file named "usermacros.xml". Files are saved in
your browser's default download location. Default macros are not exported.

* To export and import macros:

Choose Input > Macro Editor. The list of macros created for your browser
and Dominion KX IV-101 displays in the Macro Editor dialog.

To export the list, click the Export button, then save the file.
Log in to the Dominion KX IV=101 where you want to import the macros.

Choose Input > Macro Editor.

vk W

Click Import, then click Open to Import and select the usermacros.xml file,
and click OK.
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6. The macros found in the file display in the list. Select the macros you want
to import, then click OK.

= Macro names must be unique. If a macro with the same name already
exists, an error message appears. Click the Edit icon to rename the
macro, then click the checkmark to save the name.

Macro Import

Open to Import

Select macros to import:

Macro1 4

Select All Deselect All

Send Text to Target

Use the Send Text to Target function to send text directly to the target. If a text
editor or command prompt is open and selected on the target, the text is
pasted there.

* To send text to target:

1. Choose Input > Send Text to Target. The Send Text to Target dialog
appears.

2. Enter the text you want sent to the target. Supported keyboard characters
only.

3. Click OK.
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Mouse Modes

You can operate in either single mouse mode or dual mouse mode.

When in a dual mouse mode, and provided the option is properly configured,
the mouse cursors align.

When controlling a target server, the Remote Console displays two mouse
cursors - one belonging to your Dominion KX IV-101 client workstation, and the
other belonging to the target server.

When there are two mouse cursors, the device offers several mouse modes:
e Absolute (Mouse Synchronization)

e Intelligent (Mouse Mode)

e Standard (Mouse Mode)

When the mouse pointer lies within the KVM Client target server window,
mouse movements and clicks are directly transmitted to the connected target
server.

While in motion, the client mouse pointer slightly leads the target mouse
pointer due to mouse acceleration settings.

Single mouse mode allows you to view only the target server's pointer. You can
use Single mouse mode when other modes don't work.

You can toggle between these two modes (single mouse and dual mouse).

Absolute

e Inthis mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different
acceleration or speed.

»  To enter Absolute Mouse Synchronization Mode:
e Choose Input > Mouse Modes > Absolute.

Input ~ Video ~ View ~ Virtual Media ~

A Keyboard Layout Gl [ DEL]
8 Send Macro ) ——

# Macro Editor

£ Send text to target

4 Mouse Modes Absolute v
el

=2 Mouse Sync Intelligent

Standard
Single Mouse Mode
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Intelligent

In Intelligent Mouse mode, the device can detect the target mouse settings and
synchronize the mouse cursors accordingly, allowing mouse acceleration on the
target.

> To enter Intelligent mouse mode:
e Choose Input > Mouse Mode > Intelligent. The mouse will synch. See
Intelligent Mouse Synchronization Conditions (on page 51).
Input ~ Video ~ View ~ Virtual Media ~

A Keyboard Layout 51 [DEL]
22 Send Macro ) —

# Macro Editor 3
£ Send text to target

2 Mouse Modes Absolute
= Mouse Sync Intelligent v
Standard
Single Mouse Mode
Standard

Standard Mouse mode uses a standard mouse synchronization algorithm. The
algorithm determines relative mouse positions on the client and target server.

In order for the client and target mouse cursors to stay in synch, mouse
acceleration must be disabled. Additionally, specific mouse parameters must
be set correctly.

>  To enter Standard mouse mode:
e Choose Input > Mouse Modes > Standard.

Input ~ Video ~ View ~ Virtual Media ~

' A Keyboard Layout [DEL|

i Seﬁd Macro ’ ) @ oo

# Macro Editor

£ Send text to target

4 Mouse Modes Absolute

% Mouse Sync

Intelligent
Standard +
Single Mouse Mode
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Single

Single Mouse mode uses only the target server mouse cursor; the client mouse
cursor no longer appears onscreen.

Note: Single mouse mode does not work on Windows or Linux targets when the
client is running on a Virtual Machine. Single mouse mode is not available on
Internet Explorer.

»*  To enter Single mouse mode:
e Choose Inputs > Mouse Modes > Single.

Input ~ Video ~ View - Virtual Media ~

A Keyboard Layout (O] [DEL]
22 Send Macro ) ——

# Macro Editor L3
= Send text to target

< Mouse Modes Absolute

el

= Mouse Sync Intelligent «*

Standard
| Single Mouse Mode |

e A message appears at the top of the client window: Press Esc to show your
cursor.

@ 192.168.61.16 has control of your pointer. Press Esc to take back control.

v

To exit Single mouse mode:
Press Esc.

e  Mouse mode changes back to dual mode.

Mouse Sync

In dual mouse mode, the Synchronize Mouse command forces realignment of
the target server mouse cursor with the client mouse cursor.

Note: This option is available only in Standard and Intelligent mouse modes.

»  To synchronize the mouse cursors:
e Choose Inputs > Mouse Sync.
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Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the Mouse
menu, automatically synchronizes mouse cursors during moments of inactivity.
For this to work properly, however, the following conditions must be met:

e The active desktop should be disabled on the target.
e No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of the
target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e The target advanced mouse properties such as “Enhanced pointer
precision" or “Snap mouse to default button in dialogs” should be disabled.

e The edges of the target video should be clearly visible (that is, a black
border should be visible between the target desktop and the remote KVM
console window when you scroll to an edge of the target video image).

e When using the intelligent mouse synchronization function, having a file
icon or folder icon located in the upper left corner of your desktop may
cause the function not to work properly. To be sure to avoid any problems
with this function, do not have file icons or folder icons in the upper left
corner of your desktop.

After autosensing the target video, manually initiate mouse synchronization by
clicking the Synchronize Mouse button on the toolbar. This also applies when
the resolution of the target changes if the mouse cursors start to desync from
each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.

Please note that mouse configurations will vary on different target operating
systems. Consult your OS guidelines for further details. Also note that
intelligent mouse synchronization does not work with UNIX targets.
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Video Menu

Refresh Screen

The Refresh Screen command forces a refresh of the video screen.

> To force a refresh of the video screen:
e Choose Video > Refresh Video.

File ~ USB Profile ~ Input ~ Video ~ View =

ﬁ h @@ u@@ © Refresh Screen €—

Ea Screenshot

Screenshot

Take a screenshot of a target server using the Screenshot command.

> To take a screenshot of the target server:
1. Choose Video > Screenshot.
2. The screenshot file appears as a download to view or save. Exact options
depend on your client browser.
File ~ USB Profile ~ Input ~ Video ~ View ~
Help ~ © Refresh Screen

ﬁ h@@ .}E@ el Screenshot €——

d
n&.
Security

Configuration
‘Wizard

ALl

CyberLink
PowerDVD

»
Desktop Size is 1024x768 wx 23 FNUMY CAPS SCRL

L screenshot_14785..png  * —— Show all x
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View Menu

The View Menu contains options to customize your HKC display.

File ~ USB Profile ~ Input ~ Video ~ View ~
3 7 ) |
= EEE @ Toolbar
B hEE REEQ @E -
¥ Statusbar
¥ Scale Video
) Fullscreen

» Toolbar and Statusbar:

The toolbar contains icons for some commands. The Statusbar displays screen

resolution at the bottom of the client window.

> Scale Video:

Scale Video scales your video to view the entire contents of the target server
window in your HKC window. The scaling maintains the aspect ratio so that you

see the entire target server desktop without using the scroll bar.

> Fullscreen:

Fullscreen sets the target window to the size of your full screen, removing your

client from the view.

e  Press Esc to exit fullscreen.

Tools Menu

The Tools menu contains options for HKC target connection settings.

> Client Settings:

e Choose Tools > Client Settings to access the Disable Menu in Fullscreen

option.

e When selected, the menu bar will not be available in fullscreen mode. This
setting is specific to the client, so it must be set for each client device and

each browser used for access.

Client Settings

|/ Disable Menu in Fullscreen
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»  Launch Settings:

e Tap Tools > Launch Settings to access the Enable Scale Video option. When
enabled, target video scales to the current KVM window size.

Client Launch Settings

() Enable Scale Video

> Touch Settings - enabled for iOS clients:

e Tap Tools > Touch Settings to access the Client Touch Settings. Customize
the Touch Input and Gesture Scrolling settings for your mobile device.

Client Touch Settings

Touch Input

Double Click Time (ms)
250 O 750

Mouse Click Hold Time (ms)
250 O 750

(Duse Left Hand Mouse

Gesture Scrolling

[JEnable Inverted Scroll x-Axis

(DEnable Inverted Scroll y-Axis

Coc Jomes

= Double Click Time: Time between two touch taps for the equivalent of
a mouse double click.

= Mouse Click Hold Time: Time to hold after touch down for the
equivalent of a mouse right click.

= Use Left Hand Mouse: Enable if the target OS's primary mouse button
is set to Right.

= Enable Inverted Scroll x-Axis: If selected, two-finger movement to the
right moves the screen to the left instead of the default right.

= Enable Inverted Scroll y-Axis: If selected, two-finger movement up
moves the screen down instead of the default up.
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Virtual Media Menu

Due to browser limitations, HKC supports a different set of virtual media
functions than the other KVM Clients.

Due to browser resources, virtual media file transfer is slower on HKC than the
other KVM clients.

Connect Files and Folders

The Connect Files and Folders command provides an area to drag and drop files
or folders that you want to connect to on virtual media.
Supported browsers: Chrome, Firefox, Safari

File size limit: 4GB per file

»  To connect files and folders:

1. Choose Virtual Media > Connect Files and Folders. Or, click the matching
icon in toolbar.

2. Drag files or folders onto the Map Virtual Media Files and Folders dialog.
Click OK.

Map Virtual Media Files And Folders

o ED
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3. A message appears to show virtual media is connected. After a short time,
a VM drive containing the selected files or folders will be mapped to the
target server.

File ~ USB Profile ~ Input ~ Video ~ View ~ Virtual Media ~

ShEHE REEQ DO @b

Vm connection
established

»  To disconnect files and folders:

e Choose Virtual Media > Disconnect Files and Folders. Or, click the matching
icon in the toolbar.

Connect ISO

The Connect ISO command maps a virtual media image file to the target. You
can connect to ISO, DMG or IMG files from your client PC or to ISO files from a
remote server.

Note: If connection to your SAMBA server is lost while transferring files from
your image file to the target, keyboard and mouse control will be lost for
several minutes, but will recover.

*  To map virtual media image files:

Choose Virtual Media > Connect ISO. Or, click the matching icon in the
toolbar.

File - SB P

N - Virtual Media - Audio -

ﬁ B Disconnect Files and Folders
wt @ Connect ISO e

ShEE REEQ <

2. Select the option for your file's location:

Map Virtual Media ISO Image

© IS0 Image ¢——
Browse... | No file selected.

Remote Server ISO Image <4——

Raritan.
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= Select ISO Image if the image file is directly accessible on your client.
Click Browse, select the ISO, DMG or IMG file, and click OK. The
filename appears next to the Browse button.

@ I1SO Image

Browse... | Raritan.iso

= Select Remote Server ISO Image for ISO files on a remote server.
Remote ISO files must be pre-configured by an administrator for the
mapping to appear here. See Virtual Media File Server Setup (File
Server ISO Images Only). Select the Hostname, then select the image
file from the Image list. Enter the file server's username and password.

3. Click OK to map the selected file to the target. A message appears to show
virtual media is connected.

File = USB Profile ~ Input - Video ~ View ~ Virtual Media ~

ShEHE CBEQ DO

Vm connection
established

> To disconnect ISO:

e Choose Virtual Media > Disconnect ISO. Or, click the matching icon in the
toolbar.

File ~ USB Profile ~ Input ~ Video ~ View ~ Virtual Media ~ Audio ~

lﬁ h @ & Q @ q D' ] B connect Files and Folders
4

Q Disconnect 1ISO €——
]

Audio Menu
The Audio menu contains audio connection and settings.

Audio quality deteriorates if multiple target connections are open. To preserve
quality, limit to four target connections open on HKC when an audio session is
running.

Note: IE does not support audio. The menu will appear grayed out.
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Connect Audio

The Connect Audio command connects your playback device, selects audio
format and gives an option to mount the selected playback device
automatically when you connect to the target.

HKC connects the client PC's default audio playback device. To use a different
device, it must be set as default in the client OS.

Note: For best quality, limit the number of audio sessions to a maximum of four
KVM sessions.

»  To connect audio:

1. Choose Audio > Connect Audio, or click the matching icon in the toolbar.

File ~ USB Profile ~ Input ~ Video - View v Virtual Media ~ Audio ~

ﬁ h @ 57 h @ D ._ (o) =) Connect Audio €——

/ Audio Settings
J

2. Inthe Connect Audio Device dialog, select the Connect Playback Device
checkbox.

Connect Audio Device

Connect Playback Device

Format:
stereo, 16bit, 44.100 Hz +

] Mount selected playback device automatically on connection to target

3. Select the "Mount selected playback device automatically on connection to
target" checkbox to enable the option. This setting will connect audio
automatically the next time you connect to targets.

4. Click OK. A success message appears.

Audio connection
established

> To disconnect audio:

1. Choose Audio > Disconnect Audio, or click the matching icon in the toolbar.

Raritan.
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Audio Settings

The Audio Settings option is enabled when audio is connected. Use the Audio
Settings to set the buffer and volume.

Increasing the buffer size improves the audio quality but may impact the
delivery speed.

The maximum available buffer size is 400 milliseconds since anything higher
than that greatly impacts audio quality.

»  To configure audio settings:
1. Choose Audio > Audio Settings while Audio is connected.

2. Set the Buffer and Volume using the arrows or sliders.

Audio Device Settings

Buffer Sizes (ms)

Playback 280 |2 40 O 400
Advanced
Volume 100 k£ 0 ) | 100

3. Click OK.

Auto Play in Safari

For HKC connections in the Safari browser that have auto mounted audio
devices, make sure that the "Auto Play" setting is "Allow all Auto Play".

https://support.apple.com/guide/safari/customize-settings-per-website-ibrw7f
78f7fe/mac

External Device Menu

The External Device menu allows you to control the device connected at the
terminal block of the Dominion KX IV-101.

> External Device Settings:

1. Choose External Device > Settings to view the dialog.

N

The device state is listed.
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3. Enabled devices can be controlled using the Actions options.

= Turn External Device On/Off: Click On or Off to control terminal output
relay.

= Blink External Device: Enter the half-second interval to control blinking
of the external device.

External Device Settings

External Device State: Disabled

Action

@ Turn External Device On/Off
On  Off

Blink External Device
1 ., Interval (Half-Seconds)

4. Click OK or Apply to complete the action.

Using HKC on Apple iOS Devices

Dominion KX IV-101 supports remote access to targets from Apple mobile
devices with iOS 10.0 or higher, using a mobile version of HKC. Due to Apple
iOS limitations, you may notice some differences in operation. See Limitations
on Apple iOS Devices (on page 103).

Raritan.
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Install Certificate on Apple iOS Device

You must install a CA-signed certificate on your Apple iOS device before you
can connect to Dominion KX IV-101. Access is prevented if only the default
certificate is present. Depending on your browser, you may see an error such
as "This Connection is Not Private".

When creating certificates, the certificate Common name should match the IP
address/Hostname used to connect to the device.

Install both the Dominion KX IV=101 certificate and the CA certificate used to
sign the Dominion KX IV-101 certificate.

Note: If you have issues launching connections from I0S devices, check that the
certificate meets Apple requirements:
https://support.apple.com/en-us/HT210176

»  Toinstall the certificate on an 10S device:

1. Email the certificate file to an email account that can be opened on the iOS
device. Open the email and tap the attachment.

2:47 o UEE
{@ 2 Messages v
User Name @

To: ¢

2. The certificate downloads as a "profile" that you have to install. You can
have only one profile ready to install at a time. For example, if you
download a profile and don't install it, and then download a second profile,
only the second profile is available to be installed. If a profile is not
installed within 8 minutes of downloading it, it is automatically deleted.

3. Toinstall the profile, go to Settings, then tap Profile Downloaded.

4. Tapinstall, then follow prompts as presented to verify and Install.
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247 WIUEED
« Mail
Cancel Install Profile Install

ﬁ systemtest

Signed by systemtest
Not Verified

Contains Certificate

More Details

248 WIUEED
- Mail
Cancel Warning Install

UNMANAGED ROOT CERTIFICATE

Installing the certificate "systemtest” will add
it to the list of trusted certificates on your
iPhone. This certificate will not be trusted for
websites until you enable it in Certificate Trust
Settings.

UNVERIFIED PROFILE

The authenticity of “systemtest” cannot
be verified.

Install

A

Cancel

5. When complete the certificate is marked Verified. Tap Done.

2:48

; w LTEm )
« Mail

Profile Installed Done

ﬁ systemtest

Signed by systemtest
Verified o

Contains Certificate

More Details

98

Raritan.

Abrand of Kllegrand’



2:50

£ General
Available
Version
Carrier

Model

Serial Number
Wi-Fi Address
Bluetooth

IMEI

ICCID

6.

a =8

About

64:79:33:3B:01:9E

486209 890050 2

14104270885178490

Modem Firmware 1.94.80
SEID
Legal
Certificate Trust Settings e
—
7.

Raritan.
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To enable the certificate, go to Settings > General > About, then scroll all
the way down. Tap Certificate Trust Settings.

2:51 w o Tm

{ About Certificate Trust Settings
Trust Store Version 2018040200

Some certificate settings are enforced by
“Management Profile

ENABLE FULL TRUST FOR ROOT CERTIFICATES

Microsoft Intune Root Certification A
Microsoft Intune Root Certification A...
systemtest

SC_Online_lssuing /

SC_Online_lssuing

Learn more about trusted certificates

Tap the certificate that was installed earlier to enable. A warning appears.

Tap Continue to enable. The certificate slider displays green for enabled.
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2:51 i
{ About Certificate Trust Settings

Trust Store Version 2018040200

Some certificate settings are enforced by
“Management Profile”

ENABLE FULL TRUST FOR ROOT CERTIFICATES

Microsoft Intune Root Certification A...

Microsoft Intune Root Certification A...

systemtest o |

Root Certificate
Warning: enabling this certificate for
websites will allow third parties to view
any private data sent 1o websites.

SC_Online_Issuing

SC_Online_lssuing o

Cancel Continue

Learn more about trusted certificates

Touch Mouse Functions

Use the touchscreen equivalent for each mouse function. Some touch settings
are configurable. See Tools Menu (on page 89).

Single Finger Touch

touch down - move - release

short tap

double short tap

short tap - touch down - hold for 250ms

short tap - touch down - move - release

Two Finger Touch

touch down - move - release

Mouse Equivalent

move mouse pointer

left click

left double-click

mouse equivalent of Right Click"

hold down left mouse button and
move, as in drag and drop or select

Mouse Equivalent

move screen

Raritan.
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Keyboard Access on Mobile

Keyboard access to the target is through a virtual keyboard, available on the
toolbar. For all other actions requiring keyboard input, the 10S popup keyboard
displays automatically.

Manage HKC iOS Client Keyboard Macros

The HKC iOS client includes a list of default macros. You can create additional
macros using the HKC Macro Editor or import macros from a file. See Macro
Editor (on page 78) and Import and Export Macros (on page 82).

Note: To import macros when using an Apple iOS device, first export the file
from HKC using a PC client. Add the file to a Cloud location to access from the
10S device for import.

Tools Menu

The Tools menu contains options for HKC target connection settings.

»  Client Settings:

e Choose Tools > Client Settings to access the Disable Menu in Fullscreen
option.

e When selected, the menu bar will not be available in fullscreen mode. This
setting is specific to the client, so it must be set for each client device and
each browser used for access.

Client Settings

Disable Menu in Fullscreen

»  Launch Settings:

e Tap Tools > Launch Settings to access the Enable Scale Video option. When
enabled, target video scales to the current KVM window size.

Client Launch Settings

() Enable Scale Video

Raritan. 101
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*  Touch Settings - enabled for iOS clients:

e Tap Tools > Touch Settings to access the Client Touch Settings. Customize
the Touch Input and Gesture Scrolling settings for your mobile device.

Client Touch Settings

Touch Input

Double Click Time (ms)
250 O 750

Mouse Click Hold Time (ms)
250 O 750

DUse Left Hand Mouse

Gesture Scrolling

(DEnable Inverted Scroll x-Axis

(DEnable Inverted Scroll y-Axis

n Cancel

= Double Click Time: Time between two touch taps for the equivalent of
a mouse double click.

= Mouse Click Hold Time: Time to hold after touch down for the
equivalent of a mouse right click.

= Use Left Hand Mouse: Enable if the target OS's primary mouse button
is set to Right.

= Enable Inverted Scroll x-Axis: If selected, two-finger movement to the
right moves the screen to the left instead of the default right.

= Enable Inverted Scroll y-Axis: If selected, two-finger movement up
moves the screen down instead of the default up.

102 Raritan.
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Limitations on Apple iOS Devices

Mobile access with iOS devices is supported for several Raritan products. Not
all limitations apply to all products. Differences are noted.

e Target connections are closed after about one minute if the browser is in
background, or if your iOS device enters Auto Lock mode

e Unable to create Macros for some special characters: F1-F12, ESC, Control,
Alt, OS Meta keys and others. A selection of commonly used keys are
available in the default Macro list. These keys can be edited. Additional
keys such as F1-12 and arrows can be added using a Macro Import.

e |n Safari on iOS, must refresh the connection to device after a KVM or
Serial target launch in order to access menu options or serial targets. Not
needed in Chrome on iOS.

e iOS does not support auto connect audio device to targets.

e  On Ubuntu 14.04 target, no response to mouse click and hold on target
items to simulate right clicking.

e Dual Target connection issues: Both target windows have to be closed
separately. Only 1 port of a Dual target opened from Safari on iOS 11.x
devices. (Dual targets not supported on KX4-101).

e  Options "FullScreen" and "Resize window to fit screen" are not
enabled/available on iOS.

e KB locale from the Client Virtual Keyboard must match input locale of
device and OS locale of the target.

e iOS client target window does not have scrollbars. Unscaled video can be
scrolled horizontally/vertically by sliding two fingers left/right or up/down.
See Touch Mouse Functions (on page 100).

e  On Safari, users are prompted to save passwords when switching from a
target with a server VM connection to another target. These prompts can
be turned off by unchecking the box "Usernames and passwords" in
Safari > Preferences > AutoFill.

e  On Safari, the onscreen keyboard includes word forecast. Selecting a
forecast word adds a space at the end. For example, at login screen,
selecting "admin" enters "admin ". Similar behavior occurs for VM File
server Username and other areas.

e Cannot move menu option panels such as Connection Info.

e iOS On-Screen keyboard is displayed from all mouse clicks on the HTML
admin page if keyboard "Go" is tapped to save setting changes instead of
tapping the Save button.

e For DSAM targets opened from iOS clients, every time a menu item is
selected and closed the on-screen keyboard is displayed.

e VKC login occurs when refreshing login page after a reboot. This causes
target connections to fail. To restore mobile HKC login, logout and enter
the Dominion KX IV-101 IP or hostname again. Issue is applicable to both
iOS and PC Clients.
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e The VM Files and Folders Option from the Virtual Media menu is disabled
as not possible to drag and drop files to panel.

e Not all Accented letters are processed from iOS client.

e  Macro files exported from iOS devices using Safari are automatically given

the name "unknown" and need to be renamed with an xml extension to be
imported to another client.

e Macro file export from Chrome on iOS devices is not possible due to issues
with downloading data.

e Only characters support by target will be processed. There is no response
from iOS characters such as ¥, § and ... that are found on iPad keyboards.

e With the onscreen keyboard, selecting ' character or "Return" key, brings
keyboard display back to first in list.

Tips for Accessing Dominion KX IV-101 With Dual Monitor Setups

When remotely accessing a Dominion KX IV=101 in a dual monitor setup, make
sure the monitor out to Dominion KX IV-101 is set as the Primary Display. Align
the two monitors horizontally with the monitor out to KX4-101 in the left
position. To ensure good mouse alignment in this scenario, use Intelligent
Mouse Mode.

Note: For Windows 10 targets, you must disable all acceleration when using
Intelligent Mouse Mode.

Dominion User Station Access to Dual KX4-101 Setups

Two Dominion KX4-101 devices can be accessed as a dual-KVM channel using
Dominion User Station.

The access must be configured in Dominion User Station:
https://help.raritan.com/kxus/v4.3.0/en/#100568.htm
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User Management

Dominion KX IV-101 can be configured for local or remote authentication. To
prepare for configuring external authentication, see Gathering LDAP/Radius
Information (on page 106).

Dominion KX IV-101 is shipped with one built-in administrator account: admin,
which is ideal for initial login and system administration. You cannot delete
'admin' or change its permissions, but you can change the username and
password. For other security settings related to user management, see Security
(on page 150).

Click User Management to view the submenu options.

aa

Port Access

B>

Port
Configuration

®

Device
Information

In This Chapter
Gathering LDAP/Radius INfOrmation .........cccueeeveeeeveeeieecre et 106
Configuring Authentication ..........cccoviieii e 106

Disabling External Authentication

Change Your Password 113

Connected Users............. 113

USEIS @NA GrOUPS .uvvvieeieiiieeeireeeeiteeeesueeeessreeeesssaeessssseeassseeessssseessseseessssseeanns 114
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Gathering LDAP/Radius Information

You must have the following information about your AA server settings to
configure external authentication. If you are not familiar with these settings,
consult your AA server administrator for help.

> LDAP authentication:

e The IP address or hostname of the LDAP server

e The type of the LDAP server, usually one of the following options:
= QOpenlLDAP

= |f using an OpenlLDAP server, consult the LDAP administrator for
the Bind Distinguished Name (DN) and password.

= Microsoft Active Directory® (AD)

= |f using a Microsoft Active Directory server, consult your AD
administrator for the name of the Active Directory Domain.

e The required type of LDAP Security (None, TLS, SmartTLS).

= |f Secure LDAP is in use, consult your LDAP administrator for the CA
certificate file.

e The network port used by the LDAP server

e  Bind Distinguished Name (DN) and password (if anonymous bind is NOT
used)

e The Base DN of the server (used for searching for users)
e The login name attribute (or AuthorizationString)

e The user entry object class

e The user search subfilter (or BaseSearch)

»  Radius authentication:

e The IP address or host name of the Radius server

e The type of Radius Authentication used by the Radius server (PAP or CHAP)
e Shared secret for a secure communication

e UDP authentication port and accounting port used by the Radius server

Configuring Authentication

Important: Raritan uses TLS instead of SSL 3.0 due to published security
vulnerabilities in SSL 3.0. Make sure your network infrastructure, such as
LDAP and mail services, uses TLS rather than SSL 3.0.
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The Dominion KX IV-101 supports :

e Local user database on the Dominion KX V=101
e LDAP
e Radius

By default, the Dominion KX IV=101 is configured for local authentication. If
you use this method, you only need to create user accounts. See Creating
Users.

If you prefer external authentication, you must provide the Dominion KX
IV-101 with information about the external Authentication and Authorization
(AA) server.

If you would like local authentication to be available as a backup method when
external authentication is not available, create user accounts on the Dominion
KX 1V=101 in addition to providing the external AA server data. Note that local
and external authentication cannot be used simultaneously. When configured
for external authentication, all Dominion KX IV=101 users must have an
account on the external AA server. Local-authentication-only users will have no
access when external authentication is enabled, except for the admin, who can
always access the Dominion KX IV-101.

> To select authentication type:
1. Click User Management > Authentication.

2. Select Authentication Type:

= Local
= |DAP
=  Radius

3. Select the "Use Local authentication when Remote Authentication is not
available" checkbox to allow local authentication as a backup method
when external authentication is not available, such as when the server is
down.

4. Click Save. The authentication type is enabled.

For help with adding your external servers, see LDAP Authentication (on
page 108) and Radius Authentication (on page 111). For help with adding
users, see Users and Groups (on page 114).

Authentication

@ Local authentication is used if nothing is enabled.

ar

Authentication Type LDAP

»| Use Local Authentication if Remote Authentication is not

available

+ Save
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LDAP Authentication

Gather the information you need to add your LDAP servers to Dominion KX
IV=101. For help, see Gathering LDAP/Radius Information (on page 106).

> To add LDAP servers:

1. Click User Management > Authentication.
2. Inthe LDAP section, click New. Enter your LDAP details.

Field/setting
IP Address / Hostname

Copy settings from
existing LDAP server

Type of LDAP Server

Security

Port (None/StartTLS)
Port (TLS)

Enable verification of
LDAP Server
Certificate

108

Description
The IP address or hostname of your LDAP/LDAPS server.

= Without encryption enabled, you can type either the
domain name or IP address in this field, but you must type
the fully qualified domain name if encryption is enabled.

This checkbox appears only when there are existing AA server
settings on the Dominion KX IV-101. To duplicate any existing
AA server's settings, refer to the duplicating procedure below.

Choose one of the following options:

=  OpenlLDAP

= Microsoft Active Directory. .

Determine whether you would like to use TLS encryption,

which allows the Dominion KX IV=101 to communicate
securely with the LDAPS server.

Three options are available:

= StartTLS
= TLS
= None

= The default Port is 389, or specify another port.
Configurable only when "TLS" is selected in the Security
field.

The default port is 636, or specify another port.

Select this checkbox if it is required to validate the LDAP

server's certificate by the Dominion KX IV-101 prior to the
connection.

If the certificate validation fails, the connection is refused.

Raritan.
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Field/setting Description

CA Certificate Consult your AA server administrator to get the CA certificate
file for the LDAPS server.
Click Browse to select and install the certificate file.
= Click Show to view the installed certificate's content.

= Click Remove to delete the installed certificate if it is
inappropriate.

Note: If the required certificate file is a chain of
certificates, and you are not sure about the requirements
of a certificate chain, see TLS Certificate Chain.

Allow expired and not | ® Select this checkbox to make the authentication succeed
yet valid certificates regardless of the certificate's validity period.

= After deselecting this checkbox, the authentication fails
whenever any certificate in the selected certificate chain
is outdated or not valid yet.
Anonymous Bind Use this checkbox to enable or disable anonymous bind.
= To use anonymous bind, select this checkbox.
= When a Bind DN and password are required to bind to the
external LDAP/LDAPS server, deselect this checkbox.
Bind DN Required after deselecting the Anonymous Bind checkbox.

Distinguished Name (DN) of the user who is permitted to
search the LDAP directory in the defined search base.

Bind Password, Required after deselecting the Anonymous Bind checkbox.
Confirm Bind Enter the Bind password.
Password

Base DN for Search Distinguished Name (DN) of the search base, which is the
starting point of the LDAP search.

= Example: ou=dev, dc=example, dc=com

Login Name Attribute | The attribute of the LDAP user class which denotes the login
name.

= Usuallyitistheuid.

User Entry Object The object class for user entries.

Class = Usuallyitis inetOrgPerson.
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Field/setting Description

User Search Subfilter | Search criteria for finding LDAP user objects within the
directory tree.

Active Directory The name of the Active Directory Domain.

Domain = Example: testldap.com

3. Click Test Connection to check if Dominion KX V=101 can connect with the
server.

4. Click Add Server. The new LDAP server is listed on the Authentication page.
To add more servers, repeat the same steps. If you have multiple servers,
use the arrow buttons to set their order, then click Save Order.

5. To start using these settings, make sure LDAP is selected and saved in the
Authentication Type field. See Configuring Authentication (on page 106).

Returning User Group Information from Active Directory Server

The Dominion KX IV-101 supports user authentication to Active Directory® (AD)
without requiring that users be defined locally on the Dominion KX IV-101. This
allows Active Directory user accounts and passwords to be maintained
exclusively on the AD server. Authorization and AD user privileges are
controlled and administered through the standard Dominion KX IV-101 policies
and user group privileges that are applied locally to AD user groups.

IMPORTANT: If you are an existing user, and have already configured the
Active Directory server by changing the AD schema, the Dominion KX IV-101
still supports this configuration and you do not need to perform the following
operations. See Updating the LDAP Schema for information about updating
the AD LDAP/LDAPS schema.

* To enable your AD server on the Dominion KX IV-101:

1. Using the Dominion KX IV-101, create special groups and assign proper
permissions and privileges to these groups. For example, create groups
such as KVM_Admin and KVM_Operator.

2. Onyour Active Directory server, create new groups with the same group
names as in the previous step.

3. Onyour AD server, assign the Dominion KX IV-101 users to the groups
created in step 2.

4. From the Dominion KX IV=101, enable and configure your AD server
properly. See Implementing LDAP/LDAPS Remote Authentication.
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Important Notes

e Group Name is case sensitive.

e The Dominion KX IV=101 provides the following default groups that cannot
be changed or deleted: Admin and <Unknown>. Verify that your Active
Directory server does not use the same group names.

e |f the group information returned from the Active Directory server does
not match the Dominion KX IV-101 group configuration, the Dominion KX
IV-101 automatically assigns the group of <Unknown> to users who
authenticate successfully.

e |f you use a dialback number, you must enter the following case-sensitive
string: msRADIUSCallbackNumber.

e Based on recommendations from Microsoft, Global Groups with user
accounts should be used, not Domain Local Groups.

Radius Authentication

Gather the information you need to add your Radius servers to Dominion KX
IV=101. For help, see Gathering LDAP/Radius Information (on page 106).

»  To add Radius servers:
1. Click User Management > Authentication.

2. Inthe Radius section, click New. Enter your Radius details.

Field/setting Description

IP Address / Hostname | The IP address or hostname of your Radius server.

Type of RADIUS Select an authentication protocol.
Authentication = PAP (Password Authentication Protocol)
= CHAP (Challenge Handshake Authentication Protocol)

CHAP is generally considered more secure because the user
name and password are encrypted, while in PAP they are
transmitted in the clear.

Authentication Port, The defaults are standard ports -- 1812 and 1813.

Accounting Port To use non-standard ports, type a new port number.

Timeout This sets the maximum amount of time to establish contact
with the Radius server before timing out.

Type the timeout period in seconds.
Retries Type the number of retries.

Shared Secret, The shared secret is necessary to protect communication with

Confirm Shared Secret  the Radius server.

3. Click Test Connection to check if Dominion KX V=101 can connect with the
server.
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4. Click Add Server. The new Radius server is listed on the Authentication
page. To add more servers, repeat the same steps. If you have multiple
servers, use the arrow buttons to set their order, then click Save Order.

5. To start using these settings, make sure Radius is selected and saved in the
Authentication Type field. See Configuring Authentication (on page 106).

Returning User Group Information via RADIUS

When a RADIUS authentication attempt succeeds, the Dominion KX IV-101
determines the permissions for a given user based on the permissions of the
user's group.

Your remote RADIUS server can provide these user group names by returning
an attribute, implemented as a RADIUS FILTER-ID. The FILTER-ID should be
formatted as follows: Raritan:G{GROUP_NAME} where GROUP_NAME is a
string denoting the name of the group to which the user belongs.

Raritan:G{GROUP_ NAME }

where GROUP_NAME is a string denoting the name of the group to which the
user belongs.

RADIUS Using RSA SecurlD Hardware Tokens

Dominion KX IV-101 supports RSA SecurlD Hardware Tokens used with a
RADIUS server for two factor authentication

Users will specify their RADIUS password followed by the token ID without a
delimiter between.

> For example:

e password = apple

e token=1234

e User enters: apple1234

Or, configure the RADIUS server to use only hardware token and no passwords.
Users will specify the token ID only.

Disabling External Authentication

»  To disable external authentication:

1. Click User Management > Authentication.
2. Inthe Authentication Type, select Local.
3. Click Save.
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Change Your Password

*  To change your password:
1. Click User Management > Change Password.
2. Enter your old password, then enter your new password twice. Click Save.

Connected Users

You can check which users have logged in to the Dominion KX V=101 and their
status. If you have administrator privileges, you can terminate any user's
connection to the Dominion KX IV-101.

> To view and manage connected users:

1. Click User Management > Connected Users. A list of logged-in users

displays.

Column Description

User name The login name of each connected user.

IP Address The IP address of each user's host.
For the login via a local connection (USB), <local> is
displayed instead of an IP address.

Client Type Web GUI: Refers to the web interface.
CLI: Serial (local, such as USB connection) or SSH
RDM: CC-SG or User Station

Idle Time The length of time for which a user remains idle.

a. Todisconnect any user, click Disconnect.

b. Click Disconnect on the confirmation message. The user is forced to
log out.
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Users and Groups

All users must have a user account, containing the login name and password.
Multiple users can log in simultaneously using the same login name. The admin
user is created by default, and cannot be deleted, but you can change the
username.

Privileges are assigned at the Group level, so you must also add groups, and
assign your users to Groups. An admin group is created by default and has
exclusive privileges. See Admin Group Special Privileges (on page 121).

When a user is assigned to multiple groups with different privilege levels, the
highest-level of access specified is allowed to the user.

User group privilege changes take effect for the users in the group at the next
login.

> To add groups:

1. Click User Management > Groups, then click the add group icon 1 +

Groups E 14+
Group Name A Description
Admin Sy.stem defined administrator group including all
privileges.

2. Complete the New Group information:

Field/setting Description

Group Name = 1to 32 characters
= (Case sensitive
= Spaces are permitted.

Description = Enter a description of the group's role.
= Up to 64 characters.

New Group
Settings
Group Name Maintenance
Description Maintenance privileges

3. Select the Privileges assigned to this group. All tasks noted here as
exclusions are available exclusively to the admin group. See Admin Group
Special Privileges (on page 121).

= Change Own Password: Allows users to change their own password.
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= Device Access While Under CC-SG Management: Allows users to
directly access the Dominion KX IV-101 using an IP address when Local
Access is enabled for the device in CC-SG. When a device is accessed
directly while it is under CC-SG management, access and connection
activity is logged on the Dominion KX IV=101. User authentication is
performed based on Dominion KX IV-101 authentication settings.

= Device Settings: All functions in the Device Settings menu except
Enable and Configure SNMPv3

= Maintenance: All functions in the Maintenance menu except
Backup/Restore and Reset to Factory Defaults

= PC Share: Simultaneous access to the same target by multiple users
= Security: All functions in the Security menu

= Terminal Block: All settings in Device Settings > Terminal Block, and
access to the externally connected device using the KVM client

= User Management: All functions in the User Management menu except
Disconnect Users

[ ] change Own Password

| | Device Access While Under CC-SG Management

| | Device Settings

[ ] PCShare

[ ] security
[ | Terminal Block

| | User Management

4. Select the Access and VM privileges for the KVM Port.

KVM Port Access VM Access

Port 1 View # Deny % v

= Access: Deny, View, Control
= VM Access: Deny, Read-only, Read-write
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Some privileges require certain access permission. If you do not set the
needed permissions, an error will display.

® Error

There is an error in port privilege section!
s To perform VM operations the user must have the
Control privilege on the specific port.

Ok

5. When a DSAM unit is connected, the Serial Port section is available to
select the Access privileges for the Serial Ports.

= Access: Deny, View, Control

DSAM Serial Port Access

1.1:DSAM1 Port 1 View 5
1.2:DSAM1 Port 2 Control s
1.3:DSAM1 Port 3 Deny 3
1.4:DSAM1 Port 4 ~ Deny .

6. The Restrictions section has options for restricting client views and
blocking keys.

= Select Hide Client Toolbar and Menu Bar to remove these components
from view for this group. Scaling and hotkeys for Single Mouse and
Full-Screen will be available.

= |nthe Block Key Stroke field, select a keycode list to restrict the users
in this group from using the keys in the list. See Keycode List (on page
137).

{ X Cancel l  Save J

7. Click Save. To assign these privileges and restrictions to users, select the
group when you add or edit the user.
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1. Click User Management > Users, then click the add user icon 1 +

Users A+
Enabled 4 User Name Full Name Roles
v admin Administrator Admin

2. Complete the User information:

Field/setting

Username

Full Name

Password

Confirm Password

Telephone Number

eMail Address

Enable

Force password
change on next login

Raritan.

A brand of Klegrand’

Description

The name the user enters to log in to the Dominion KX
IV-101.

= 4 to 32 characters

= (Case sensitive

=  Spaces are NOT permitted.
The user's first and last names.
= Up to 64 characters

= 4to 64 characters

= (Case sensitive

= Spaces are permitted.

The user's telephone number

The user's email address

= Up to 128 characters
= (Case sensitive

When selected, the user can log in to the Dominion KX
IV-101.

When selected, a password change request
automatically appears the next time the user logs in.
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Username user
Full Name User One
Password ssssss
Confirm password ssssse
Telephone Number 555-555-5555
eMail Address user@legrand.com
Enable
Force password change on next login: D
3. SSH: The SSH public key is required when public key authentication for SSH
is enabled. See SSH Settings (on page 144).
Open the SSH public key with a text editor.
5. Copy and paste all content in the text editor into the SSH Public Key field.

$ cat ~/.sshfid_rsa.pub

ssh-rsa AAAALKBzaClyc? FAAAABIWAAAQEAKIOUpkDHIFHY1

GPl+nafzIHDTYW7hdI4yZ5ew 18IH4IW9ibhUFrviQzM7xIELE!

P997fO&J/ LKIBIWXFCR+HA03FXRitBaxiX1nKhXpHAZsMciLag

£3Fao0loAsncM109x5+3VOWwES/eldksKUdFrEIKpriX88Xyph
SSH Public Key mZ+AWA40ZPnTPI89ZPmVMLuayrD2cEB6Z/il8b+gw3r3+1nt

NrRFi9wif+M7Q== user@legrand.local

+ I A

o

SNMPv3: The SNMPv3 access permission is disabled by default. This
section appears when the permission is enabled in the SNMP settings, or
when a user is part of the admin group.

Field/setting Description

Enable SNMPv3 Select this checkbox when intending to permit the
SNMPv3 access by this user.
Note: The SNMPv3 protocol must be enabled for
SNMPv3 access. See Configuring SNMP Settings.

Security Level Click the field to select a preferred security level from
the list:

= None: No authentication and no privacy. This is the
default.
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Description
= Authentication: Authentication and no privacy.

= Authentication & Privacy: Authentication and
privacy.

Authentication Password: This section is configurable only when
'Authentication' or 'Authentication & Privacy' is selected.

Field/setting

Same as User
Password

Password,

Confirm Password

Description

Select this checkbox if the authentication password is
identical to the user's password.

To specify a different authentication password, disable
the checkbox.

Type the authentication password if the 'Same as User
Password' checkbox is deselected.

The password must consist of 8 to 32 ASCII printable
characters.

Privacy Password: This section is configurable only when 'Authentication &

Privacy' is selected.

Field/setting

Same as
Authentication
Password

Password,

Confirm Password

Description

Select this checkbox if the privacy password is
identical to the authentication password.

To specify a different privacy password, disable the
checkbox.

Type the privacy password if the 'Same as
Authentication Password' checkbox is deselected.

The password must consist of 8 to 32 ASCII printable
characters.

Protocol: This section is configurable only when 'Authentication’ or
'Authentication & Privacy' is selected.

Field/setting

Authentication

Privacy

Description

Click this field to select the desired authentication
protocol. Two protocols are available:

= MD5

= SHA-1 (default)

Click this field to select the desired privacy protocol.
Two protocols are available:

= DES (default)

= AES-128
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Enable SNMPv3

Security Level

Authentication Password Authentication
Authentication & Privacy

Same as User Password [:]

Password

Confirm Password

Privacy Password
Same as Authentication Password [:]

Password

Confirm Password

Protocol
Authentication SHA-1 =
Privacy DES s

1. Groups: Select the groups this user belongs to. Users have the privileges
assigned to their groups.

2. Click Save.

»  To edit a user; change the admin username:

1. Click User Management > Users, then click to select the user you want to

edit.
Enabled 4 Username Full Name Groups
4 admin Administrator Admin Unblock
L Userl User One Admin Unblock

2. Change the user information as needed, then click Save.
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Admin Group Special Privileges

The following special privileges are exclusively available to the admin group.

Backup/Restore

Disconnect Connected users

Reset to Factory Defaults

Diagnostics

Enable SNMPv3 in the SNMP agent (SNMP gets and sets)
Configure SNMPMv3 user parameters

Security Level
Authentication Protocol
Authentication Password
Privacy Password

Privacy Protocol
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Click Device Information to view name, system, and network details about your
Dominion KX IV-101. In this page you can also rename your device, and view
open source license information.

> To edit your device name:
e Click Device Information, then click Edit to enter a new name. Click Save.

DKX4-101

-_-_-_) Edit

Name DKX4-101

*® Cancel
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*  To view system details and status:

e  System Details: View the product name, model, firmware version,
hardware ID, and serial number.

e  System Status: View the internal temperatures status, and local monitor
status.
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»  To view network details:

e View the network details as currently configured: IPv4 address, MAC
address, Link state, DNS servers, DNS suffixes, DNS resolver preference,

and IPv4/IPv6 routes.

Ethernet

IPv4 Address
MAC Address

Link State

Common

192.168.56.27/24 b
00:0d:5d:00:02:da

1 GBit/s, ful duplex, ink OK, autonegotiation o

DNS Servers
DNS Suffixes

DNS Resolver Preference

IPv4 Routes

IPv6 Routes

>  To view DSAM details:

none
none
IPv6 Address

192.168.56.0/24 dev ETHERNET
default via 192.168.56.126 (ETHERNET)

none

e When a DSAM unit is attached, view the hardware details: name, port
number, USB port location, model, firmware version, hardware ID, serial

number.

DSAM1

Name

Port Number

USB Port

Model

Firmware Version

Hardware ID

Serial Number

DSAM1

Back Bottom
DSAM-4

1.0

0x0

RKK6B00009
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Auto Scan

The Auto Scan feature uses one of the Dominion KX IV=101 video channels to
automatically scan and capture a screenshot of your target video at a specified
time interval. Images are scaled and saved to a directory on your Network File
Server. Image files are named after the port name, and saved as .JPG files. The
image file is overwritten as each new capture is saved.

PC Share Mode should be enabled when using Auto Scan to ensure images can
be captured and sent to the NFS server. When PC Share Mode is disabled, Auto
Scan cannot capture a port image when the port is already occupied by another
user. Go to Security > KVM Security to enable PC Share Mode.

While Auto Scan is enabled, the function will perform similarly to a connected
user. In the User Management > Connected Users list, details are listed as
shown here. The connection occupied by Auto Scan can be "disconnected" by
disabling Auto Scan.

Connected Users

Username A IP Adress Client Type Idle Time

Autoscan-Occupied AutoScan

admin 192.168.62.29 Web GUI 0 min Disconnect

To configure auto scan settings:
Choose Device Settings > Auto Scan.

Enable Auto Scan: Click the checkbox to enable the setting.

w N =T

Scan Scale %: Saved images will be resized according to the scale
percentage. 1%-100%.

4. Scan Interval (seconds): Enter the number of seconds between image
captures. 10 seconds - 86400 seconds.

5. NFS Server IP Address/Host Name: Enter the network file server IPv4/IPv6
IP address or host name.

6. NFS Server Directory: Enter the directory on the network file server that
will store the image file. For example, /nfs/autoscan

7. Click Save to apply the settings.
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8. When Auto Scan is enabled, view the status in the Device Info page. Go to
Device Info, then check Auto Scan NFS in the System section.

System
Detail
Product KxX4
Model DKX4-101
Firmware Version 4.1.2.2.0
Hardware ID 1
Serial Number 1178500025
Status
Internal Temperature Current Value 46.2°C [/ 115.1°F
Internal Temperature Maximum Value 49.8°C / 121.5°F
Local Monitor Not Detected
Auto Scan NFS On

> Auto Scan NFS Status:

When Auto Scan is disabled, it does not appear in Device Info > Status. When
enabled, possible status are:

e On
e Suspended
e Failed

e Connecting

Date and Time

Set the internal clock on the Dominion KX IV-101 manually, or link to a
Network Time Protocol (NTP) server.

The Dominion KX IV-101 system date and time appears in the upper right
corner of the web interface.

03/13/2019 10:53:04 @

A Administrator ~
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To set the date and time:
Click Device Settings > Date/Time.

Select your Time Zone.

wn =T

If your area participates in daylight saving time, verify the Automatic
Daylight Saving Time Adjustment checkbox is selected.

Select the Time Setup Method:

= User Specified Time: Set the time manually.

&

= Synchronize with NTP Server

= (Click the calendar icon to select the Date.

=  Enter the time in Hours, Minutes and Seconds. Specify AM or PM. Click AM/PM to toggle the
setting.

= (Click Save.

Date (YYYY-MM-DD) ‘ 2019-03-13 =
-~ ~ N
Il
Time (hh:mm:ss) ‘ 04 ‘I 50 || 20 ‘ PM

« Save
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Synchronize with NTP server

=  To use the DHCP-assigned NTP servers: leave the First and Second time server fields blank.

DHCP-assigned NTP servers are available when either IPv4 or IPv6 DHCP is enabled. See
Network (on page 138).

NTP Settings

First Time Server

Second Time Server

To specify NTP servers manually, enter the primary NTP server in the First Time Server field.
A secondary NTP server is optional. Click Check NTP Servers to verify. Click Save.

NTP Settings
First Time Server 192.168.22.124

Second Time Server

:

+ Save

Event Management

All supported events are logged in the system log by default. You can also
create additional actions for any event, including sending an email, sending an
SNMP notification, and forwarding a syslog message.

»  Configuring events and actions:

1. Click Device Settings > Event Management.
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= The Event Management page shows events by Category. Click a
category to view individual events. In this example, an action named
"User events - email" has been added and assigned to all User Activity
and User Administration events.

Event Management =4 New Action
Ir i
User events - |System Event
Category Event email Log Action
| > All Events e -C] ]
> Device | () |
| > KVM Port -C] |
| > Serial Port ) |
v
;l'«cti\aflijt;s;e " |
| | User. accepted the Restricted |
Service Agreement
| Authentication failure - ]
| User logon state |
| Session timeout - ]
| User blocked |
>
Adm::'ﬁ::ration - |

+'Save

2. Select the event checkboxes to assign an action to an event. Click Save.

» To add an action:
1. Click New Action.

Event Management =+ New Action

2. Assign a name to this action.
Select the desired action and configure it.
= Email Actions: See Send Email (on page 130)
=  SNMP Actions: See SNMP Notifications (on page 130)
= Syslog Actions: See Syslog Messages (on page 134)
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Click Create.

Send Email

Use this action to send an email according to your preconfigured SMTP settings,
or create actions with one or more customized SMTP settings.

See Event Management (on page 128) for help assigning this action to an
event.

»  To create the send email action:

New Action
Action Name Email Admins
Action Send email N +
Recipient Email Addresses nina@raritan.com, steve@raritan.com
@ Use default settings

Server Name: rartan.com

Sender Email Address: user@raritan.com
SMTP Server

Settings can be changed in SMTP Server
settings.

Use custom settings

X Cancel + Create

Select Send Email from the Action list.

In the Recipient Email Addresses field, enter the email addresses of the

recipients. Use a comma to separate multiple email addresses.

By default, the SMTP server settings will be used to complete this action.

To view or change those settings, click the SMTP Server hyperlink.

=  To use a different SMTP server, click the "Use custom settings" radio
button. The fields for customized SMTP settings appear. See SMTP
Server Settings (on page 142).

Click Create.

SNMP Notifications
Use this action to send an SNMP notification to one or more SNMP servers.

See Event Management (on page 128) for help assigning this action to an
event.

»  To create the SNMP notification action:

Select Send SNMP Notification from the Action list.
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2. Select the type of SNMP notification. Follow the procedure below based on
your selection.

>  SNMP v2c notifications:

New Action

Action Name SNMP messages
Action Send SNMP notification .
Notification Type SNMPv2c Trap :

# Host Port Community

1 192.168.22.57 162 users

2 162

3 162

® Cancel + Create

1. Inthe Notification Type field, select SNMPv2c Trap.

2. Inthe Host fields, enter the IP address of the device(s) you want to access.
This is the address to which notifications are sent by the SNMP system
agent.

In the Port fields, enter the port number used to access the device(s).

4. Inthe Community fields, enter the SNMP community string to access the
device(s). The community is the group representing the Dominion KX
IV=101 and all SNMP management stations.

5. Click Create.
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Tip: An SNMP v2c notification action permits a maximum of three SNMP
destinations. If you need to assign more than 3 SNMP destinations to an event,
you can create and assign multiple actions comprising all the destinations.

>  SNMP v3 notifications:

Note: Duplicated SNMP Trap v3 secName (User ID) is not supported when
multiple SNMP Trap destinations are configured.

New Action

Action Name

Action

Notification Type

Engine ID

Host

Port

User ID

Security Level

Syslog messages

Send SNMP notification

4»

SNMPv3 Trap 2

0x800035ae8000b33777b6039fc0984c22b1bdb3017
3383275011bae2170354383

192.168.22.57
162

user

ar

noAuthNoPriv

X Cancel + Create

1. Inthe Notification Type field, select SNMPv3 Trap. The engine ID is

prepopulated.

2. Enter the following as needed and then click OK to apply the settings:

a. Host: Enter the IP address of the device(s) you want to access. This is
the address to which notifications are sent by the SNMP system agent.

b. Port number

c. User ID for accessing the host -- make sure the User ID has SNMPv3

permission.

d. Select the host security level:

Security level
"noAuthNoPriv"

Description

Select this if no authorization or privacy protocols are
needed.
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3.

Security level

"authNoPriv"

"authPriv"

Click Create.
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Description

Select this if authorization is required but no privacy
protocols are required.

Select the authentication protocol - MD5 or SHA
Enter the authentication passphrase and then confirm
the authentication passphrase

Select this if authentication and privacy protocols are
required.

Select the authentication protocol - MD5 or SHA

Enter the authentication passphrase and confirm the
authentication passphrase

Select the Privacy Protocol - DES or AES

Enter the privacy passphrase and then confirm the
privacy passphrase
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Syslog Messages

Use this action to automatically forward event messages to the specified syslog
server. Determine the syslog transmission mechanism you prefer when setting
it up.

Dominion KX IV-101 may or may not detect syslog message transmission
failure. Detected syslog failures and reasons are saved in the event log.

See Event Management (on page 128) for help assigning this action to an
event.

»  To create the syslog message action:

New Action
Action Name Syslog Example
Action Syslog message :
Syslog Server 192.168.1.1
Transport Protocol uDP A
Legacy BSD Syslog Protocol v
UDP Port 514

*® Cancel + Create

1. Select Syslog Message from the Action list.

2. Inthe Syslog Server field, specify the IP address to which the syslog is
forwarded.

3. Inthe Transport Protocol field, select one of the syslog protocols: UDP, TCP,
or TCP+TLS. The default is UDP.

Transport Next steps
protocols
UDP = |nthe UDP Port field, type an appropriate port number. Default is 514.
= Select the "Legacy BSD Syslog Protocol" checkbox if applicable.
TCP NO TLS certificate is required. Type an appropriate port number in the TCP Port field.
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A TLS certificate is required.
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= Type an appropriate port number in the "TCP Port" field. Default is 6514.

= |n the CA Certificate field, click

Browse. ..

to select a TLS certificate. After importing the

certificate, click Show to view its contents, or click Remove to delete.

= To allow event messages even if any TLS certificate in the selected certificate chain is outdated
or not valid yet, select the "Allow expired and not yet valid certificates" checkbox.
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4. Click Create.
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Dominion KX IV-101 Events

Event log cleared - Event log was cleared

CC Management Started - CC-SG management started

CC Management Stopped - CC-SG management stopped

Device settings restored - Device settings were restored

Device settings saved - Device settings were backed up

DSAM Connected - A DSAM connected to KX4-101

DSAM Disconnected - A DSAM disconnected from KX4-101

DSAM Controller Recovery - DSAM controller was recovered

DSAM Controller Reset - DSAM Controller was reset

DSAM Firmware update completed - DSAM firmware update completed
DSAM Firmware update started - DSAM firmware update started
Firmware update completed - KX4-101 firmware update completed
Firmware update failed - KX4-101 firmware update failed

Firmware update started - KX4-101 firmware update started
Firmware validation failed - KX4-101 firmware validation failed

A LDAP error occurred - A LDAP error was occurred

Local Port Out Disabled - Local port output disabled

Local Port Out Enabled - Local port output enabled

Network interface link state is up - Network interface link state is up

NFS Mount - NFS mount status
(started/suspended/resumed/succeeded/failed)

A Radius error occurred - A Radius error was occurred

Sending SMTP message failed - Sending SMTP message failed
Sending Syslog message failed - Sending Syslog message failed
System reset - System reset

System started - System started

Terminal block settings changed - Terminal block settings changed
Terminal block status changed - Terminal block status changed
KVM Port Connected - KVM Port was connected

KVM Port Disconnected - KVM Port was disconnected

KVM Port settings Changed - KVM Port settings changed

Video Scan Started - Target scan was startedVideo Scan Stopped- Target
scan was stopped

VM Image Connected - A VM image was connected

VM Image Disconnected - A VM image was disconnected
Serial Port Alert String - A keyword was detected

Serial Port Connected — Serial port was connected

Serial Port Disconnected - Serial port was connected
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Serial Port settings Changed - Serial port settings changed

User accepted the Restricted Service Agreement - User accepted/declined
the restricted service agreement

Authentication failure - Authentication was failed

User logon state - User logged in/out

Session timeout - Session was timed out

User blocked - User was blocked

Password changed - Password was changed.

Password settings changed - Password settings were changed

Restricted Service Agreement changed - Restricted Service Agreement was
changed

Group added - Group was added
Group deleted - Group was deleted
Group modified - Group was modified
User added - User was added

User deleted - User was deleted

User modified - User was modified

Keycode List
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Use the Keycode List feature to create lists of keys you want to block from
being used. Assign the list to a user group to block the group from using those
keys. Keycode lists are created by keyboard language type. You are provided
with a list of keys that can be blocked for each keyboard type.

When users are assigned more than one blocked keycode list, a given key will
be available if it is not included on every keycode list. For example, a user is in
groups with both List1 and List2 assigned. If List1 restricts F1, but List2 does not
restrict F1, the user would be able to use F1

w N T

To add a new keycode list:

Click Device Settings > Keycode List.

Click New.

Enter a Keyset Name to identify this list of keys to be blocked.

The keyset name is used when you assign the list to a user group. See Users
and Groups (on page 114).

Select the Keyboard Type by language.
Select each Key you want to block from the Keys list, then click Add Key.

The added keys appear in the Keys Selected list. Click the Remove button
to delete a key from the list.

When complete, click Add Keyset.
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To edit a keycode list:
Click Device Settings > Keycode List.

Click a keycode list by name to select it. The selected list is highlighted
blue.

Click Edit to make changes to the list, and click Modify Keyset to save.

To delete a keycode list:
Click Device Settings > Keycode List.

Click a keycode list by name to select it. The selected list is highlighted
blue.

Click Delete to remove the list.

To block a user group from a keyset:

Select the keyset in the User Management > Group settings. See Users and
Groups (on page 114).

Network

The default network setting is DHCP-enabled for IPv4. You can find your
automatically assigned IP address in the Device Information page. See Device
Information (on page 122).

Note: Network settings cannot be changed when the device is under CC-SG
management.

>

IPv4 settings:

Field/setting Description
Enable IPv4 Enable or disable the IPv4 protocol.

IP auto configuration Select the method to configure IPv4 settings.

= DHCP: Auto-configure IPv4 settings via DHCP
servers.

= Static: Manually configure the IPv4 settings.

DHCP settings: Optionally specify the preferred hostname, which must
meet the following requirements:

=  Consists of alphanumeric characters and/or hyphens

= Cannot begin or end with a hyphen

= Cannot begin with a number

= Cannot contain punctuation marks, spaces, and other symbols
= Maximum 253 characters

Raritan.
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Static settings: Assign a static IPv4 address, which follows this syntax "IP
address/prefix length".

Example: 192.168.84.99/24

IPv6 settings:

Field/setting Description
Enable IPv6 Enable or disable the IPv6 protocol.

IP auto configuration Select the method to configure IPv6 settings.

= Automatic: Auto-configure IPv6 settings via
DHCPv6.

= Static: Manually configure the IPv6 settings.
Automatic settings: Optionally specify the preferred hostname, which
must meet the above requirements.
Static settings: Assign a static IPv6 address, which follows this syntax "IP
address/prefix length".
Example: fd07:2fa:6¢ff:1111::0/128

Interface Settings:

Field Description

Speed = Select a LAN speed.

= Auto: System determines the optimum LAN speed
through auto-negotiation.

= 10 MBit/s: Speed is always 10 Mbps.
= 100 MBit/s: Speed is always 100 Mbps.
= 1 GBit/s: Speed is always 1 Gbps (1000 Mbps).

Duplex = Select a duplex mode.

= Auto: The Dominion KX IV=101 selects the
optimum transmission mode through
auto-negotiation.

= Full: Data is transmitted in both directions
simultaneously.

= Half: Data is transmitted in one direction (to or
from the Dominion KX IV=101) at a time.

Current state Show the LAN's current status, including the current
speed and duplex mode.
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Note: Auto-negotiation is disabled after setting both the speed and duplex
settings of the Dominion KX IV-101 to NON-Auto values, which may result in a
duplex mismatch.

» Common Network Settings:

Common Network Settings are OPTIONAL. If there are no specific local
networking requirements, leave the default settings.

Field Description
DNS resolver Determine which IP address is used when the DNS
peference resolver returns both IPv4 and IPv6 addresses.

= |Pv4 Address: Use the IPv4 addresses.
= |Pv6 Address: Use the IPv6 addresses.

DNS suffixes Specify a DNS suffix name if needed.
(optional)

First/Second DNS Manually specify static DNS server(s).

server = |f any static DNS server is specified in these fields,
it will override the DHCP-assigned DNS server.
= If DHCP (or Automatic) is selected for IPv4/IPv6
settings, and there are NO static DNS servers
specified, the Dominion KX IV=101 will use
DHCP-assigned DNS servers.

Network Services

The Dominion KX IV-101 supports the following network communication
services:

e Discovery

e HTTP/HTTPS
e  SMTP Server
e SNMP

e SSH
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Discovery Port

Dominion KX IV-101 uses the default Discovery Port 5000 for communication

with other Raritan products, such as User Station and CC-SG. You can change

the port number if needed, but it cannot be changed while the device is under

CC-SG management.

The device will transmit information about itself (make,model,firmware
version,encryption) in clear text unless the encryption option is selected.

To change the default discovery port:
Click Device Settings > Network Services > Discovery Port.

Enter the port number.

w N =T

Select the Encrypted checkbox to encrypt the transmission of device
information.

4. Click Save.
€ Network Services | Discovery
Discovery Port 5000
v Encrypted

X Cancel + Save

HTTP/HTTPS Ports

Dominion KX IV=101 uses the default HTTP/HTTPS ports 80/443. You can
change the default if needed.

HTTP access will be redirected to HTTPS.

>  To change the default HTTP/HTTPS ports:
1. Click Device Settings > Network Settings > HTTP/HTTPS Ports.
2. Select the HTTP Access checkbox if you need HTTP enabled.

Note: When HTTP is disabled, AKC is downloaded via HTTPS. Microsoft .NET

will check if the device TLS certificate is valid. Device certificate must be
added into the "Trusted Root Certification Authorities" zone, and the
common name of the certificate should match the device IP address or
hostname.
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3. Enter the port numbers then click Save.

€ Network Services | HTTP/HTTPS

HTTP
HTTP Access ¥| Enable
Port 30
HTTPS
Port 443

X Cancel

4. The connection to the device will refresh with new HTTP/HTTPS port
numbers. You must login again.

SMTP Server Settings

To send event emails, you must configure the SMTP settings and enter an IP
address for your SMTP server and a sender's email address. See Event
Management (on page 128).

If any email messages fail to be sent successfully, the failure event and reason
are available in the event log. See Event Log (on page 164).

>  To set SMTP server settings:
Click Device Settings > Network Services > SMTP Server.

2. Enter the information needed.

Field Description

IP address/host Type the name or IP address of the mail server.
name

Port Type the port number.

= Defaultis 25
Sender email address Type an email address for the sender.

Number of sending Type the number of email retries.

retries = Default is 2 retries
Time between Type the interval between email retries in minutes.
sending retries = Default is 2 minutes.
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Field Description
Server requires Select this checkbox if your SMTP server requires
authentication password authentication, then enter the username

and password.

User name = 4 to 64 characters allowed. Case sensitive.
Password = No spaces allowed in user name.
= Spaces are allowed in password.

Enable SMTP over Select this checkbox if your SMTP server supports TLS.
TLS (StartTLS)

= Settings for the CA Certificate:

Field/setting Description

= (Click Browse to import a certificate file. Then you
Browse. _. can:

= (Click Show to view the certificate's content.
= Click Remove to delete the installed certificate.

Allow expired and = Select this checkbox to make the authentication
not yet valid succeed regardless of the certificate's validity
certificates period.

3. To test the settings:

a. Enter a Recipient Email Address. Separate multiple email addresses
with a comma.

b. Click Send Test Email and verify emails are received.
4. Click Save.

Note: The Dominion KX IV-101 device's TLS-based protocols support AES 128
and 256-bit ciphers. The exact cipher to use is negotiated between the device
and the client web browser. To force a specific cipher, check your client
documentation for configuring AES settings.

SNMP Settings

You can enable or disable SNMP communication between an SNMP manager
and the Dominion KX IV=101.

*  To configure SNMP communication:
Click Device Settings > Network Services > SNMP.

2. Enable or disable SNMP v1 / v2c and/or SNMP v3 by clicking the
corresponding checkbox.

a. The SNMP v1/v2c read-only access is enabled by default. The default
'Read community string' is "public".
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b. To enable read-write access, type the 'Write community string.'
Usually the string is "private".

Enter the MIB-Il system group information, if applicable.

a. sysContact - the contact person in charge of the system
b. sysName - the name assigned to the system

c. syslocation - the location of the system

Click the download link to get the SNMP MIB to use with your SNMP
manager.

Click Save.

Enable SNMP v1 / v2c
Read Community String public
Write Community String private
Enable SNMP v3 O

sysContact

sysName

sysLocation

RADM-MIB download

+ Save

SSH Settings

Enable or disable SSH access to the CLI, change the TCP port, or set a password
or public key for login over SSH.

P nNMERY

SSH settings:

Click Device Settings > Network Services > SSH.

To enable or disable SSH access, select or deselect the checkbox.

To change the default port 22, type a port number.

Select one of the authentication methods.

= Password authentication only: Enables password-based login only.
=  Public key authentication only: Enables public key-based login only.
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= Password and public key authentication: Enables both password and
public key-based login, which allows either login authentication
method to be used. This is the default setting.

If public key authentication is selected, you must enter a valid SSH public
key for each user profile to log in over the SSH connection. See Users and
Groups (on page 114)

5. Click Save.

Serial Port

The Serial Port setting controls the baud rate of the Dominion KX IV-101 serial
port. Dominion KX IV=101's serial port supports CLI serial console use only.

TO SERVER

. ==
Raritan  pkxa-101 8?0@@@0@@08

O
0O d ol
7 [T 24 ‘B
® (5 0§ o @
Psuv‘?f: LAN O C D USBIN HOMIIN
> To configure the serial port:
1. Click Device Settings > Serial Port.
2. Enter the Baud Rate and click Save.
Serial Port
Baud Rate 115200 %+  bit/s
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Terminal Block Control

The Terminal Block Control feature allows you to configure an external device
that is connected to the terminal block of the Dominion KX IV-101.

The Dominion KX IV-101 has one input terminal and one output terminal.

>

»>

Input Terminal:

Two pins

Supports an external push button or switch input
Binary switches only

Use case: turning off remote access when maintenance is being performed
on the target

Output Terminal:
Three pins

Two relays. One Normally Open (NO), and Normally Closed (NC). Both
relays share the same common, so it is preferred to use only one. When
using both at the same time, the common must be wired correctly.

Use cases: performing remote power control of a server via its power
button, turning on a light when a remote user is connected, or turning on a
door lock or camera.

Supported output devices: LED, Buzzer, PC Power Button. Output devices
must provide their own power.

Permissions:

There are several types of permissions involved in configuring and using
terminal block control.

To configure the terminal block settings, you must have the Terminal Block
privilege. See Users and Groups (on page 114). With this privilege, you can
access the Device Settings > Terminal Block Control page, which allows you
to enable or disable input and output, and set permissions to allow input
control for remote and local users, and configure the action of the output
control. See procedure below.

In addition to setting the permissions in the Terminal Block page, you must
give all remote and local users Port Access permissions. The KVM Client's
External Device menu will be accessible to users with the correct combined
permissions. See Users and Groups (on page 114).

You must enable local port output. The setting Security > KVM Security >
Disable Local Port Output will override all other permissions. See KM
Security (on page 153).

Terminal Block Control Settings: Input

Click Device Settings > Terminal Block Control.
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Enable External Input | Enable or disable the input switch.
Switch

Current External Input | The current state is displayed: Open or Closed.
Switch State When switch state is open, the device functions normally.

Give Remote Console | Select the access permission for remote console users.
User = Full Access: Default setting.
= Video Only

= No Access: No video, keyboard, and mouse activity
allowed, VM session terminated, KVM session terminated,
Connection to target disallowed.

Give Local Console Select the access permission for local console users.
User = Full Access
= Video Only

= No Access

2. Click Save.

Enable External Input Switch

Current External Input Switch State QOpen

Full Access N
Video Only
. No Access

Give Remote Console User

e

Full Access
Video Only
No Access

Give Local Console User

e

» Terminal Block Control Output Settings and Actions:
1. Click Device Settings > Terminal Block Control.
2. Scroll down for the Output settings and actions.

Enable External Device | Enable or disable the external device.

Raritan. 147

A brand of [legrand’



Chapter 6: Device Settings and Information

Output Configuration
External Device State | The external device state is displayed:
= On
= Off
= Blinking
= Disabled
Action Select the radio button for the output action you want to

perform on the external device:
= Turn External Device On/Off: Click On or Off.

= Pulse External Device: Sends a pulse to the device, either
off to on, or on to off. Initial state of pulse can be changed
by clicking button "On" and "Off".

= Blink External Device: Make sure the blink interval is set as
desired.

Blink/Pulse Interval Set interval between blinks or pulses in half-seconds. Default
is 1.
= Blink range: 1-100 half-seconds
= Pulse range: 1 - 100 half-seconds

Output
Enable External Device v

External Device State Disabled

@ Turn External Device On/Off

Blink External Device
Action
on Off Pulse

Blink/Pulse Interval 1 half-seconds

3. Click Save.

Connecting the Terminal Block to a Motherboard

Dominion KX IV-101 can control one external switch, either power SW or reset
SW, by connecting the terminal block to the pins on a motherboard of the
external device.

There are power SW and reset SW headers on most motherboards. They are
normally connected to the push buttons on the front panel of the case.

e Connect the two pin header to NO(normally open) of the terminal block on
the Dominion KX IV-101.
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Virtual Media Shared Images

Configure Virtual Media Shared Images when using virtual media to access file
server ISO images. 1IS09660 format is the standard supported. However, other

CD-ROM extensions may also work.

Virtual Media Shared Images

Raritan.
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IP Address / Hostname Share Name Image Path
. 192.168.1.211 . is0s . [fedora28.iso
. windows2012.systemtestest?.local . isos . windows2016.iso
. windows2012.systemtestest?. local . is0s . JOSFilesfubuntui8.iso
. fedora.systemiestest2 local . sambagusst . JOSFilesfopenSUSE.iso
. 192.168.1.12 . isoshare . JFedora?9.iso
MNew

Enable SAMBA v1.0

no

no

no
no

yes

Note: SMB/CIFS support is required on the file server.

Click New to add a shared image.

w N =T

To designate file server ISO images for virtual media access:

Click Device Settings > Virtual Media Shared Images.

Enter information about the file server ISO images that you want to access:

= |P Address/Host Name: Host name or IP address of the file server. Up

to 248 characters.

= Share Name: Share name portion of the ISO image.

= |mage Path: Full path name of the location of the ISO image. For
example, /path0/image0.iso, \path1\imagel.iso, and so on.

=  Select the Enable Samba 1.0 checkbox to allow Dominion KX IV-101 to
use an older Samba version. When unchecked, Samba 3.0 is used.

Click Test Connection to verify.
Click Add Shared Image.
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Group Based Access Control
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Group based access control rules are similar to IP access control rules, except
that they are applied to members of a user group. This enables you to grant
system permissions to groups, based on their IP addresses.

The order of role-based access control rules is important, since the rules are
executed in numerical order.

> To create IPv4 or IPv6 group based access control rules:
Choose Security > Group Based Access Control.

2. Select the Enable Group Based Access Control for IPv4 or scroll down to
select the checkbox for IPv6.

Enable Group Based Access Control for IPv4
Default Policy Accept
# Start IP End IP Group Policy

192.168.22.57 192.168.22.59

Append | Insert Above

« Save

3. Determine the default policy.
= Accept: Accepts traffic when no matching rules are present.
= Deny: Rejects any user's login attempt when no matching rules are
present.
4. Create rules and put them in priority order.
= Enter Start IP and End IP, Group the rule applies to, and Policy.
150
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= Click Append to add another rule. To add a rule above another, select a
rule and click Insert Above.

= To rearrange rules in order, click the arrow buttons on each rule.
=  To delete a rule, click the trashcan icon.

Click Save. Note that IPv4 and IPv6 rules are saved separately.

IP Access Control
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IP access control rules (firewall rules) determine whether to accept or discard
traffic to/from the Dominion KX IV=101, based on the IP address of the host
sending or receiving the traffic. When creating rules, keep these principles in
mind:

Rule order is important.

When traffic reaches or is sent from the Dominion KX IV-=101, the rules are
executed in numerical order. Only the first rule that matches the IP address
determines whether the traffic is accepted or discarded. Any subsequent
rules matching the IP address are ignored.

Prefix length is required.

When typing the IP address, you must specify it in the CIDR notation. That
is, BOTH the address and the prefix length are included. For example, to
specify a single address with the 24-bit prefix length, use this format:

XX.X.X/24
/24 = the prefix length.

To create IPv4 or IPv6 IP access control rules:
Choose Security > IP Access Control.

Select the Enable IP Access Control for IPv4 or scroll down to select the
checkbox for IPv6.

Select the Default Policy:
= Accept: Accepts traffic from all addresses.

= Drop: Discards traffic from all addresses, without sending any failure
notification to the source host.

= Reject: Discards traffic from all addresses, and an ICMP message is sent
to the source host for failure notification.

Go to the Inbound Rules section or the Outbound Rules section according
to your needs.

= Inbound rules control the data sent to the Dominion KX IV-101.

= Qutbound rules control the data sent from the Dominion KX IV=101.
Create rules and put them in priority order.

= Enter IP address and mask and select the Policy.

= (Click Append to add another rule. To add a rule above another, select a
rule and click Insert Above.
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= Torearrange rules in order, click the arrow buttons on each rule. The

selected rule displays in blue.

= To delete a rule, click the trashcan icon.

Enable IPv4 Access Control
Inbound Rules

Default Policy | Accept # ‘
# IP/Mask Policy

192.168.22.57/24

| Append | Insert Above ‘

Outbound Rules

Default Policy | Accept B
# IP/Mask Policy
no rules defined

| Append | [nsert

6. Click Save. Note that IPv4 and IPv6 rules are saved separately.
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KVM Security
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> To configure KVM Security settings:

Click Security > KVM Security.

KVM Security

Apply Encryption Mode to KVM and
Virtual Media

PC Share
PC Share Idle Timeout 5

Virtual Media Share

Disable Local Port Output

Local Device Reset Mode Enable Local Factory Reset

Enable Direct Port Access via URL

Select options as needed.

Field/setting Description

Apply Encryption
Mode to KVM and well as KVM.
Virtual Media

The KVM Security settings page includes options for encryption mode, virtual
media, local ports, and other functions that affect the device locally.

seconds

4»

Select this checkbox to use encryption for virtual media as

PC Share Select PC Share to allow concurrent remote KVM access,
enabling up to eight remote users to simultaneously log into
one Dominion KX IV-101 and concurrently view and control
the same target server through the device.

Note: PC Share mode cannot be disabled when Auto Scan is
enabled. See Auto Scan (on page 125).

PC Share Idle Timeout | Set an idle time limit for users in PC Share mode. If a user has
not moved the mouse or entered keyboard input and the
timeout period expires, the user relinquishes control, and
another user can access keyboard and mouse control of the

target.

Virtual Media Share This option is available only when PC-Share mode is enabled.
When selected, Virtual Media Share permits the sharing of
virtual media and audio among multiple users, that is, several
users can access the same virtual media or audio session. The

default is disabled.
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Field/setting Description
Disable Local Port If you will be using the Terminal Block Control feature, make
Output sure this checkbox is cleared. When Disable Local Port Output

is selected, this setting will override all other permissions for
terminal block control. See Terminal Block Control (on page

146).
Local Device Reset This option specifies which actions are taken when the
Mode hardware Reset button on the device is depressed. Choose

one of the following options:

= Enable Local Factory Reset (default): Returns the
Dominion KX IV-101 device to the factory defaults.

= Enable Local Admin Password Reset: Resets the local
administrator password only. The password is reset to
"raritan".

= Disable All Local Resets: No reset action is taken.

Enable Direct Port When selected, users can access the target directly by

Access via URL entering login credentials for the Dominion KX IV-101 in a
URL. See Direct Port Access URL (on page 154).

Direct Port Access URL

When Direct Port Access is enabled, you can access a target directly with a
special URL that you can bookmark. This allows you to bypass logging into the
Dominion KX IV-101 to connect to the target.

e Username and password are optional. If username and password are not
provided, a login dialog will be displayed and, after being authenticated,
the user will be directly connected to the target.

e The port may be a port number or port name. If you are using a port name,
the name must be unique or an error is reported. Port number is "1".

e Ifthe port is omitted altogether, an error is reported.

e Any special characters in the username, password, or port name must be
passed in encoded URL codes.

> Direct Port Access with VKCS:

If you are using VKCS and direct port access, use one of the following syntaxes
for standard ports.
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= https://IPaddress/dpa.asp?username=username&password=password&port=1&client=vkcs

= https://IPaddress/dpa.asp?username=username&password=password&portname=port
name&client=vkcs

>  Direct Port Access with AKC:

If you are using AKC and direct port access, use one of the following syntaxes
for standard ports.

= https://IPaddress/dpa.asp?username=username&password=password&port=1&client=akc

name&client=akc

= https://IPaddress/dpa.asp?username=username&password=password&portname=port

>

Direct Port Access with HKC:

If you are using HKC and direct port access, use one of the following syntaxes
for standard ports.

= https://IPaddress/dpa.asp?username=username&password=password&port=1&client=hkc

name&client=hkc

= https://IPaddress/dpa.asp?username=username&password=password&portname=port

Login Settings
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The Login Settings page contains options for user blocking and login limitations.

The default Login Setting is:

Block user on login failure: Enabled
Block timeout: 5 minutes
Maximum number of failed logins: 3

To configure login settings:
Click Security > Login Settings.

To block users for failed logins, select the Block user on login failure
checkbox, then configure the parameters.

= Block timeout: Select the time period that users with failed logins will
be blocked from logging in.

=  Maximum number of failed logins: Enter the number of failed login
attempts that users can make before they are blocked.
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3. To automatically logout users after an idle period, select a time in the Idle
timeout period field. To allow idle users to remain logged in, select
"infinite."

4. Select "Prevent concurrent login with same username" to prevent logins by
more than one user with the same username. This setting does not apply
to the default admin user.

Login Settings
User Blocking
Block user on login failure v
Block timeout 10 min +
Maximum number of failed logins 3

Login Limitations

4r

Idle timeout period 10 min

Prevent concurrent login with same
username

5. Click Save.

Password Policy
The Password Policy page contains settings for password aging and strong
passwords.
The default Password Policy is:
e Password Aging: Disabled
e Strong Passwords: Enabled

>  To configure a password policy:
Click Security > Password Policy.

2. To enable Password Aging, which forces users to change their passwords at
selected intervals:

= Select the Enabled checkbox for Password Aging Interval.
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= Select a Password Aging Interval, from 7 days to 365 days.

Password Aging Interval D Enabled

Password Aging Interval 60d

3. To enable strong passwords and set their parameters:
= Select the Enabled checkbox for Strong Passwords.

= Set a Minimum and Maximum Password Length. Minimum is 8.
Maximum is 64.

= Select options to enforce at least one lower case, upper case, numeric,
and/or special character.

= Specify the Password History Size, which controls how frequently
passwords can be reused. Maximum is 12.

Strong Passwords D Enabled
Minimum Password Length 8
Maximum Password Length 32
cE:;:;:;t least one lower case
E:::;:;t least one upper case
cE:;:::;t least one numeric
E:;t:;c;;t least one special
Password History Size 5

+ Save

4. Click Save.
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TLS Certificate

Dominion KX IV-101 uses TLS 1.3 for any encrypted network traffic between
itself and a connected client. When establishing a connection, Dominion KX
IV-101 has to identify itself to a client using a cryptographic certificate. The
Dominion KX IV—-101 contains a default certificate that you should replace with
your own.

Dominion KX IV=101 can generate a Certificate Signing Request (CSR) or a
self-signed certificate using SHA-2.

The CA verifies the identity of the originator of the CSR. The CA then returns a
certificate containing its signature to the originator. The certificate, bearing the
signature of the well-known CA, is used to vouch for the identity of the
presenter of the certificate.

Important: Make sure your Dominion KX IV-101 date/time is set correctly.

When a self-signed certificate is created, the Dominion KX IV-101 date and time
are used to calculate the validity period. If the Dominion KX IV-101 date and
time are not accurate, the certificate's valid date range may be incorrect,
causing certificate validation to fail. See Date and Time (on page 126).

Note: The CSR must be generated on the Dominion KX IV-101.

Note: When upgrading firmware, the active certificate and CSR are not
replaced.

» To view and download the active certificate and key:

1. Click Security > TLS Certificate. The active certificate details display.

Active TLS Certificate

Subject Issuer
Country us Country us
State or province NJ State or province NJ
Locality Somerset Locality Somerset
Organization Raritan Americas, Inc. Organization Raritan Americas, Inc.
Organizational unit Engineering Organizational unit Engineering
Common name Raritan KVM Common name Raritan CA
Email address not set Email address not set

Miscellaneous
Not valid before Feb 13 21:35:57 2015 GMT
Not valid after Feb 9 21:35:57 2030 GMT
Serial number 03
Key length 2048 bits

Download Certificate

2. Click Download Key and Download Certificate to get the active certificate
files.
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To create and install a new SSL certificate:

Click Security > TLS Certificate. Scroll down to the New TLS Certificate
section.

Complete the Subject fields:

= Country (ISO code) - The country where the organization is located.
This is the two-letter ISO code, e.g. DE for Germany, or US for the U.S.

= State/Province - The state or province where the organization is
located.

= Locality/City - The city where the organization is located.

= QOrganization - The name of the organization to which the Dominion KX
IV-=101 belongs.

= QOrganizational unit - This field is used for specifying to which
department within an organization the Dominion KX IV=101 belongs.

= Common name - The network name of the Dominion KX IV-101 once it
is installed on your network (usually the fully qualified domain name).
The common name is identical to the name used to access the
Dominion KX IV-101 with a web browser, but without the prefix
“http://”. In case the name given here and the actual network name
differ, the browser displays a security warning when the Dominion KX
IV-101 is accessed using HTTPS.

=  Email address - The email address of a contact person that is
responsible for the Dominion KX IV-101 and its security.

Add up to 10 Subject Alternative Names (SAN) by clicking the Add Name
button, then enter the hostname or IP in the field. SANs are the hostnames
or IP addresses the certificate will be valid for.

To generate, do one of the following:

= To generate self-signed certificate, do the following:

a. Inthe Key Creation Parameters, select the Self-Sign checkbox . When
you select this option, the Dominion KX IV-101 generates the
certificate based on your entries, and acts as the signing certificate

authority. The CSR does not need to be exported and used to generate
a signed certificate.

b. Set the Validity in Days, which controls how many days until this
certificate expires. Ensure the Dominion KX IV-101 date and time are
correct. If the date and time are not correct, the certificate's valid date
range may not be calculated correctly.

Click Create New TLS Key.

d. When the page refreshes, new buttons appear in the New TLS
Certificate section, to allow you to install, download or delete the
newly generated self-signed certificate and key.

e. To start using the new certificate, click Install Key and Certificate.

f.  The page may refresh as the certificate loads.
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= To generate a CSR to send to the CA for certification:

a. Inthe Key Creation Parameters, enter a password in the Challenge and
Confirm Challenge fields.

b. Click Create New TLS Key.

c.  When the page refreshes, new buttons appear in the New TLS
Certificate section, to allow you to download the CSR, download the
key, or delete the CSR.

d. Click the Download the Certificate Signing Request button to
download the CSR. Click the Download Key button to download the
file containing the private key.

e. Send the CSR to a CA for certification. You will get the new certificate
from the CA.

Note: The CSR and the private key file are a matched set and should be
treated accordingly. If the signed certificate is not matched with the private
key used to generate the original CSR, the certificate will not be useful. This
applies to uploading and downloading the CSR and private key files.

= Once you get the certificate from the CA, return to this page to
upload it to the Dominion KX IV-101. After uploading, click Install
to start using the new certificate. The page may refresh as the
certificate loads.

New TLS Certificate
Subject Key Parameters
Country us Key Length 2048
State or Province NI Upload Certificate
Locality Somerset Yy - active_cert.pem
QOrganization not set
Upload
Qrganizational Unit not set
Common Name raritan
Email Address not set

Download Certificate Signing Request Download Key Delete Certificate Signing Request

> To upload a key and certificate:

1. To activate the upload fields, click Security > TLS Certificate, then scroll
down to the New TLS Certificate section.

2. Select the Upload Key and Certificate checkbox. The Browse and upload
controls appear.

[CA3ICMll Please choose a file to upload ‘
(0= CRiIWM  Please choose a file to upload ‘

¥/ Upload key and certificate
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Service Agreement
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The Service Agreement page allows you to enable an agreement that appears
on the login page of the Dominion KX IV=101. Users must select a checkbox on
the agreement before logging in.

> To configure the service agreement:

1. Click Security > Service Agreement.
Service Agreement

Enforce Service Agreement b

Unauthorized access prohibited; all access and activities not explicitly authorized by
management are unauthorized. All activities are monitored and logged. There is no privacy
on this system. Unauthorized access and activities or any criminal activity will be reported
to appropriate authorities.

9703 characters remaining.

+ Save

Select the Enforce Service Agreement checkbox.

3. Enter the agreement text in the field and click Save. The login page will

present the service agreement. Users must select the checkbox before
logging in.

Raritan
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DKX4-101

Unauthorized access prohibited; all access and activities
not explicitly authonzed by management are
unauthorized. All activities are monitored and logged.
There is no privacy on this system. Unauthorized access
and activities or any criminal activity will be reported to
appropriate authorities.

1 understand and accept the Restricted Service
Agreement

Other KVM clients offer better video and virtual media
performance. for more information.
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Backup and Restore
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You must be a member of the admin group to download a backup file, and to
restore a Dominion KX IV-101 with a backup file.

Backups can be encrypted by adding password protection. The password must
be entered when the file is used to perform a restore.

> To download the Device Settings backup file:
Click Maintenance > Backup/Restore.

2. To password protect the backup file, enter a password in the Password
Protection Used For Backup/Restore (Optional) field.
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3. Click Download Device Settings to automatically download the
backup_settings.rfp file.

Download Device Settings

Browse...

'@ Protected _ Full Jpload & Restore Device Settings

Last restore: 12/11/2020, 16:17:21 UTC+0000, status: OK

»  To restore the Dominion KX IV-101 using a backup file:

1. Click Maintenance > Backup/Restore.

Browse. ..

Click
Select Protected or Full.

to select the backup file.

=  Protected: Restores all settings except for device specific settings:
network information, names, preferred resolution.

= Full: Restores everything.

4. |If the file is password protected, enter the password in the Password
Protection Used For Backup/Restore (Optional) field.

Click Upload & Restore Device Settings to upload the file.

Wait until the Dominion KX IV-101 resets and the Login page re-appears,
indicating that the restore is complete. Note: In a full restore, the IP
address may have been changed. You must start a new browser session to
login to the new IP address.
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Event Log
The Dominion KX IV-101 captures certain system events and saves them in a
local event log.

You can view over 2000 historical events that occurred on the Dominion KX
IV=101 in the local event log. When the log size exceeds 384KB, each new entry
overwrites the oldest one.

»  Event Classes:

e Device

e KVM Port

e  User Activity

e  User Administration
e  Serial Port

Event Log o <
Filter Event Class: Any 4
First = Previous 2 3 4 5 .. Next Last

1D

A Timestamp EventClass Event

01/17/2019

1 17:02:19 Device System started.
2 ?;/;?5319 User Activity  Authentication failed for user ‘admin’ from host "<usb>".
3 ?;/;?5?19 User Activity  User 'admin’ from host '<usb>' logged in.

> To display the event log:

e Choose Maintenance > Event Log.
Each event entry consists of:
= |D number of the event

= Timestamp of the event: The timestamp in the event log is
automatically converted to your computer's time zone. To avoid time
confusion, apply the Dominion KX IV-101 time zone settings to your
computer or mobile device.

= Event class

= Adescription of the event
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e
e Refresh the event log by clicking the refresh icon =~ in the top-right

corner.

* To view by event category:
e Select an option in the Filter Event Class field.

>  To clear the local event log:

pr—
Click the trash icon m on the top-right corner.

2. Click Clear Log on the confirmation message.

Firmware History

The firmware upgrade history is retained even after device reboot or firmware
upgrade. The history is cleared in the event of a factory default reset.

>  To view the firmware update history:
e Choose Maintenance > Firmware History.
Each firmware update event consists of:
= Update date and time
= Previous firmware version
= Update firmware version
= Update result

Firmware Update History

Timestamp ¥ Previous Version Update Version Status
03/18/2019 10:05:06 4.0.0.1.45554 4.0.0.5.45611 SUCCESSFUL
03/01/2019 11:17:40 4.0.0.1.45375 4.0.0.1.45554 SUCCESSFUL

Unit Reset

The Unit Reset section has options to remotely reboot or reset to factory
defaults.

e Reboot Unit: Restarts the Dominion KX IV=101.

e Reset to Factory Defaults: Removes all customized settings and returns the
Dominion KX IV-101 to the factory default settings. Requires admin
privilege.

Unit Reset

Reboot Unit Reset to Factory Defaults
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To reboot the device:
Choose Maintenance > Unit Reset.
Click Reboot Unit.

A confirmation message appears. Click Reboot to proceed.

w N =T

A countdown timer appears.

Unit Reboot

The device will reboot in a few seconds.

You can reconnect to the device and login after 2-3
minutes.

4. When the restart is complete, the login page opens.

»  To reset to factory defaults:
Click Maintenance > Unit Reset.

2. Click Reset to Factory Defaults. Click to confirm reset in the confirmation
message.

A countdown timer appears. It takes about two minutes to complete.

When the reset is complete, proceed with initial configuration. See Initial
Configuration (on page 4).

> Other factory reset options:

e Use the reset button on the Dominion KX IV-=101 device. Press the reset
button for 5 seconds. Device will reset and reboot.

e  Perform the CLI command. See CLI: reset (on page 197)

Update Firmware

Firmware files are available on Raritan's Support page:
www.raritan.com/support.

You must have the Maintenance privilege to update the Dominion KX IV-101
firmware.

*  To update the firmware:

1. Click Maintenance > Update Firmware.
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2. Click Browse to select an appropriate firmware file, then click Upload. A
progress bar appears to indicate the upload process.

Upload

The firmware update is being prepared.

This may take up to a minute. On successful completion
the firmware update will be started.

4

3. Once complete, information of both installed and uploaded firmware
versions as well as compatibility and signature-checking results are
displayed.

A new firmware has been uploaded to your device.

Version

Installed Version 4.0.0.5.45611
New Version 4.0.0.5.45611
Compatibility

+ The uploaded firmware file is compatible with this
device.

Signature

+ The signature of the uploaded firmware file is valid.

View Certificate

R Discard Upload H + Update Firmware

= To cancel, click Discard Upload.
=  To proceed with the update, click Update Firmware.
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4. When the update begins, another progress bar appears. Warning: Do NOT
power off the Dominion KX IV-101during the update. The LAN port LED on
the device fast-blinks green during update.

The firmware update is in progress

This may take some minutes. Please do not power off the
device while the update is in progress! After a successful
update, the device will reboot automatically.

Note: No users can successfully log in during the update. Logged in users
are forced to suspend operations.

5. When the update is complete, the Dominion KX IV-101reboots, and the
Login page re-appears. The update and reboot process should take around
5 minutes. If your device displays a "Loading" screen after update and
reboot for longer, you can safely restart your browser and login to the
Dominion KX IV-101 again to check the update results.

After Updating: The Dominion KX IV-101 MIB may have changed. If you are
using an SNMP manager, you may need to re-download the MIB and make
update. See SNMP Settings (on page 143).

> The firmware update completed with warnings:

The message, "The firmware update completed with warnings" may appear
before reboot if you completed your update while an iOS device was connected
to the USB port on the Dominion KX IV=101. This warning does not indicate any
problems or that the update failed.

The firmware update completed with
warnings

The device will now reboot. Please wait for five minutes,
then follow this link to the login page to log in. If the device
does not work correctly after the update, please contact
Raritan support.
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Update Firmware Using SCP
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While updating firmware using SCP, all user management operations are
suspended and all login attempts fail.

Warning: Do NOT perform the firmware upgrade over a wireless network
connection.

To update the firmware via SCP:
Type the following SCP command and press Enter.
scp <firmware file> <user name>@<device ip>:/fwupdate

= <firmware file> is the Dominion KX IV-101 firmware's filename. If the
firmware file is not in the current directory, you must include the path
in the filename.

= <user name> is the "admin" or any user profile with the Firmware
Update permission.

= <device ip> is the IP address or hostname of the Dominion KX 1V-101
where you want to upload the specified file.

Type the password when prompted, and press Enter.

The system transmits the specified firmware file to the Dominion KX
IV-101, and shows the transmission speed and percentage.

When the transmission is complete, it exits without a message. Dominion
KX IV-101 will start to update its firmware after transmission is done
successfully.

Check the Dominion KX IV-101 web interface for update progress and
success message when update is complete.

SCP example
scp kx-kx4-040100-47253.rfp
admin@192.168.87.50:/fwupdate

Windows PSCP command:

PSCP in Windows works in a similar way to the SCP.

" pscp <firmware file> <user name>@<device
ip>:/fwupdate
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Overview
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All Dominion KX IV=101 models support virtual media. Virtual media extends
KVM capabilities by enabling target servers to remotely access media from a
client PC and network file servers.

With this feature, media mounted on client PCs and network file servers are
essentially "mounted virtually" by the target server. The target server can then
read from and write to that media as if it were physically connected to the
target server itself.

Each Dominion KX IV-101 comes equipped with virtual media to enable remote
management tasks using the widest variety of media/images.

Virtual media sessions are secured using the strongest encryption offered by
the browser, typically 256 bit AES. Older browsers may only support 128 bit
AES.

HKC does not support all virtual media features. See HTML KVM Client (HKC)
for details
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Virtual Media Performance Recommendations

Additional studies of virtual media performance show that KX4-101 virtual
media performance can range up to 175 mbps. This is significantly faster than
the KX3 switches (8-10 mbps).

*  For maximum performance:

e Turn off encryption. Encryption has a large effect on performance.
e Utilize a high-speed laptop/PC with AKC or VKC KVM Clients.

e  Utilize the KX IV User Station (DKX4-UST).

e  Writing to a virtual media drive connected to the KVM Client may be
slower than reading from the drive.

e There may be performance variations across different USB drives.
e Network performance is also a factor.

Prerequisites for Using Virtual Media
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Dominion KX IV-101 Virtual Media Prerequisites

e  For users requiring access to virtual media, the Dominion KX 1V-101
permissions must be set to allow access to the relevant port, as well as
virtual media access (VM Access port permission) for the port. Port
permissions are set at the group-level.

e If you want to use PC-Share, Security Settings must also be enabled in
the Security Settings page. Optional

e A USB connection must exist between the device and the target server.

e  You must choose the correct USB connection settings for the KVM target
server you are connecting to.

Client PC VM Prerequisites

e Certain virtual media options require administrative privileges on the PC
(for example, drive redirection of complete drives).

Note: If you are using Windows, disable User Account Control or select Run as
Administrator when starting Internet Explorer. To do this, click the Start Menu,
locate IE, right-click and select Run as Administrator.

Target Server VM Prerequisites
e KVM target servers must support USB connected drives.
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Mounting Local Drives

This option mounts an entire drive, which means the entire disk drive is
mounted virtually onto the target server.

Use this option for hard drives and external drives only. It does not include
network drives, CD-ROM, or DVD-ROM drives.

Supported Tasks Via Virtual Media

Virtual media provides the ability to perform tasks remotely, such as:
e Transferring files

e Running diagnostics

e Installing or patching applications

e Complete installation of the operating system

Important: Once you are connected to a virtual media drive, do not change
mouse modes in the KVM client if you are performing file transfers, upgrades,
installations or other similar actions. Doing so may cause errors on the virtual
media drive or cause the virtual media drive to fail.

Supported Virtual Media Types

The following virtual media types are supported for Windows*, Mac® and Linux”
clients when using AKC and VKC/VKCS.

e Internal and external hard drives

e Internal and USB-mounted CD and DVD drives
e USB mass storage devices

e PCharddrives

e |SOimages (disk images)

e IMG files

e DMG files

e |S09660 is the standard supported. However, other ISO standards can be
used.

Note: Due to browser limitations, HKC supports a different set of virtual media
types.
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Conditions when Read/Write is Not Available
Virtual media Read/Write is not available in the following situations:
e  For Linux"and Mac’ clients
e When the drive is write-protected
e  When the user does not have Read/Write permission:
= Port Permission Access is set to None or View

= Port Permission VM Access is set to Read-Only or Deny

Number of Supported Virtual Media Drives

With the virtual media feature, you can mount up to two drives (of different
types) that are supported by the USB connection settings currently applied to
the target. These drives are accessible for the duration of the KVM session.

For example, you can mount a specific CD-ROM, use it, and then disconnect it
when you are done. The CD-ROM virtual media “channel” will remain open,
however, so that you can virtually mount another CD-ROM. These virtual media
“channels” remain open until the KVM session is closed as long as the USB
settings support it.

To use virtual media, connect/attach the media to the client or network file
server that you want to access from the target server.

This need not be the first step, but it must be done prior to attempting to
access this media.

Virtual Media in a Linux Environment
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Active System Partitions
You cannot mount active system partitions from a Linux client.

Linux Ext3/4 drive partitions need to be unmounted via umount /dev/<device
label> prior to a making a virtual media connection.

Mapped Drives

Mapped drives from Linux clients are not locked when mounted onto
connected targets.

Drive Partitions
The following drive partition limitations exist across operating systems:

e Windows® and Mac targets are not able to read Linux formatted partitions
e Windows and Linux cannot read Mac formatted partitions
e  Only Windows Fat partitions are supported by Linux
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Root User Permission Requirement

Your virtual media connection can be closed if you mount a CD ROM from a
Linux client to a target and then unmount the CD ROM.

To avoid these issues, you must be a root user.

Connect Drive Permissions (Linux)

Linux users must have read-only permissions for the removable device they
wish to connect to the target. For /dev/sdb1 run the following as root user:

root@administrator-desktop:~# chmod 664 /dev/sdbl
root@administrator-desktop:~# 1ls -1 /dev/sdbl
brw-rw-r-- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl

The drive is then available to connect to the target.

Virtual Media in a Mac Environment

Active System Partition

You cannot use virtual media to mount active system partitions for a Mac
client.

Drive Partitions

The following drive partition limitations exist across operating systems:

e Windows® and Mac targets are not able to read Linux formatted partitions
e Windows cannot read Mac formatted partitions

e Windows FAT and NTFS are supported by Mac

e  Mac users must unmount any devices that are already mounted in order to
connect to a target server. Use >diskutil umount /dev/disk1s1 to unmount
the device and diskutil mount /dev/disk1s1 to remount it.
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Connect Drive Permissions (Mac)

For a device to be available to connect to a target from a Mac’ client, you must
have read-only permissions to the removable device, and also unmount the
drive after doing so.

For /dev/sdb1, run the following commands as root user:

root@administrator-desktop:~# chmod 664 /dev/sdbl
root@administrator-desktop:~# 1ls -1 /dev/sdbl
brw-rw-r-- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl
root@admistrator-desktop:~# diskutil umount /dev/sdbl

Virtual Media File Server Setup (File Server ISO Images Only)

This feature is only required when using virtual media to access file server ISO
images. 1ISO9660 format is the standard supported. However, other CD-ROM
extensions may also work.

Note: SMB/CIFS support is required on the file server.

Use the Virtual Media Shared Images setup page to designate the files server(s)
and image paths that you want to access using virtual media. File server 1ISO
images specified here are available for selection in the Remote Server ISO
Image Hostname and Image drop-down lists in the Map Virtual Media CD/ISO
Image dialog. See Mounting CD-ROM/DVD-ROM/ISO Images (on page 64).

> To designate file server ISO images for virtual media access:

1. Choose Device Settings/Virtual Media Shared Images from the remote
console. The Virtual Media Shared Images setup page opens.

2. Click New to open the Add Shared Image page.
Enter information about the file server ISO images that you want to access.
= |P Address/Hostname
= Share Name
= |mage Path
= Select Enable SAMBA v1.0 as applicable.
4. Click Add Shared Image.

All media specified here are now available for selection in the Map Virtual
Media CD/ISO Image dialog
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Download Diagnostic

Important: This function is for use by Raritan Field Engineers or when you are
directed by Raritan Technical Support.

You can download a diagnostic file from the Dominion KX IV-101 to a client
machine. The file is compressed into a .zip file and should be sent to Raritan
Technical Support.

You must be a member of the admin group.

* To download a diagnostic file:
Download Diagnostic

Download Diagnostic

1. Click Diagnostics> Download Diagnostic.
2. Click Download Diagnostic, then save the file.
3. Send this file as instructed by Raritan Technical Support.
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Network Diagnostics
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Dominion KX IV-101 provides the following tools diagnosing potential

networking issues.

e Ping

e Trace Route: Find out the route over the network between two hosts or
systems.

e List TCP Connections: Display a list of TCP connections.

Choose Diagnostics > Network Diagnostics, and then perform any function
below.

>  Ping:

Enter the IP or hostname in the Network Host field, then set the of requests to
send. Maximum is 20. This determines how many packets are sent for pinging
the host. Click Run Ping to ping the host. The Ping results are then displayed.

Ping Results

PING 192.168.56.27 (192.168.56.27): 56 data bytes

64 bytes from 192.168.56.27: seq=0 ttl=64 time=0.219
ms

64 bytes from 192.168.56.27: seq=1 ttl=64 time=0.183
ms

64 bytes from 192.168.56.27: seq=2 ttl=64 time=0.179
ms

64 bytes from 192.168.56.27: seq=3 ttl=64 time=0.196
ms

64 bytes from 192.168.56.27: seq=4 ttl=64 time=0.171
ms

--- 192.168.56.27 ping statistics —-

5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 0.171/0.189/0.219 ms

Close

> Trace Route:

1. Type values in the following fields.

Field/setting Description

Hostname The IP address or name of the host whose route you
want to check.

Timeout(s) A timeout value in seconds to end the trace route
operation. Maximum 900 seconds.

Use ICMP packets To use the Internet Control Message Protocol (ICMP)
packets to perform the trace route command, select
this checkbox.

2. Click Run. The Trace Route results are displayed.
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>  List TCP Connections:

1. Click the List TCP Connections title bar to show the list of active
connections.

Active Internet connections (w/o servers)

Recv- Send-
# Proto Q Q Local Address Foreign Address State
::fFﬁ’:l@Z.lﬁS.Sﬁ.Z?: ::ffff:192.168.55.78:62
1 tp 0 [1] o . TIME_WAIT
-ffff:192.168.56.27:  ::ffff:192.168.55.78:62
2 tcp 1] 1] 243 G4z TIME_WAIT
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The Dominion KX IV-101 supports the following categories of commands in the

CLI:

check Check services

clear Clear logs

config Enter configuration view

connect Connect to a target

diag Enter diagnostics view
exit Exit CLI session
reset Reset device
show Shows various device information
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CLI: check
check
# check ntp
CLI: clear
clear

# clear eventlog

Do you really want to clear the event log? [y/n]
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CLI: config

config

# config

config:#

>

Available commands:

apply
authentication
cancel

check

device

group
keyword
network
password
port

security

serial
terminalblock
time

user

Save changed settings and leave config mode
Configure authentication settings

Discard changed settings and leave config mode
Check services

Configure Device

Configure user groups

Configure keyword for DSAM serial ports
Configure network settings

Change password of currently logged in user
Configure DSAM serial port settings
Configure security settings

Configure serial port settings

Configure terminal block settings

Configure date/time settings

Configure users
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CLI: config authentication

authentication

config # authentication

Available commands:

e Idap Configure LDAP server settings

e radius Configure Radius server settings
e type Configure authentication type (local/ldap/radius)

> LDAP:

add Add a new LDAP server

addClone Add a new LDAP server, cloning another server
delete Delete LDAP server

modify Modify an existing LDAP server

e config # authentication Idap add

authentication Idap add <host> <port> < type> <security> <bindtype> <basedn>
<loginnameattr> <userentryclass> [userSearchSubfilter <usersearchfilter>]
[adDomain <addomain>] [verifyServerCertificate <certverify>]
[allowExpiredCertificate <allowexpiredcert>] [bindDN <binddn>]

Add a new LDAP server

host IP address/host name

port Port number (0..4294967295)

type LDAP server type (openldap/activeDirectory)
security Security type (none/startTls/tls)

bindtype Bind type (anonymousBind/authenticatedBind)
basedn Base DN for search

loginnameattr Login name attribute

userentryclass User entry object class

userSearchSubfilter User search subfilter

adDomain Active directory domain

verifyServerCertificate ~ Enable validation of LDAP server certificate
(true/false)

allowExpiredCertificate  Allow expired and not yet valid server certificates
(true/false)

bindDN Bind DN
e config # authentication Idap addClone
authentication Idap addClone <index> <host>

Add a new LDAP server, cloning another server
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index  Source server index
host IP address/host name
e config # authentication Idap delete
authentication Idap delete <index>
Delete LDAP server
index  Server index
e config # authentication Idap modify

authentication Idap modify <index> [host <host>] [port <port>] [serverType
<Server type>] [securityType <security>] [bindType <bindtype>] [searchBaseDN
<basedn>] [loginNameAttribute <loginnameattr>] [userEntryObjectClass
<userentryclass>] [userSearchSubfilter <usersearchfilter>] [adDomain
<addomain>] [verifyServerCertificate <certverify>] [certificate]
[allowExpiredCertificate <allowexpiredcert>] [bindDN <binddn>] [bindPassword]
[sortPosition <position>]

Modify an existing LDAP server

index Index

host IP address/host name

port Port number (0..4294967295)

serverType LDAP server type (openldap/activeDirectory)
securityType Security type (none/startTls/tls)

bindType Bind type

(anonymousBind/authenticatedBind)

searchBaseDN Base DN for search
loginNameAttribute Login name attribute
userEntryObjectClass User entry object class
userSearchSubfilter User search subfilter
adDomain Active directory domain

verifyServerCertificate ~ Enable validation of LDAP server certificate

(true/false)
certificate Certificate CA chain

allowExpiredCertificate ~ Allow expired and not yet valid server certificates

(true/false)
bindDN Bind DN
bindPassword Bind password

sortPosition New position in server list

> RADIUS:
e config # authentication radius

Available commands:
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e add
Add a new Radius server
authentication radius add <host> <type > <authport> <acctport> <timeout>

<retries>
host IP address/host name
type Authentication type (pap/chap/msChapV2)

authport  Authentication port number (0..4294967295)
acctport  Accounting port number (0..4294967295)
timeout Timeout (1..60)
retries Number of retries (0..5)
e delete
Delete Radius server
index  Server index
e  modify
Modify an existing Radius server
config:# authentication radius modify

authentication radius modify <index> [host <host>] [authType ] [authPort
<authport>] [accountPort <acctport>] [timeout <timeout>] [retries
<retries>] [secret] [sortPosition <position>]

index Index

host IP address/host name

authType Authentication type (pap/chap/msChapV2)
authPort Authentication port number (0..4294967295)
accountPort Accounting port number (0..4294967295)
timeout Timeout (1..60)

retries Number of retries (0..5)

secret Shared secret

sortPosition New position in server list

> TYPE:

e config # authentication type

authentication type [uselocallfRemoteUnavailable <localfallback>]
Configure authentication type
type Authentication type (local/ldap/radius)

uselocallfRemoteUnavailable Use local authentication if remote
authentication is unavailable (true/false)
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CLI: config device

device

config:# device name

device [name <name>]
Configure Device
name Device name

For example, to name device "KX4newname", at config menu type "device
name KX4newname", then type "apply" to save.
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CLI: config group

group

config:# group create

group create [name <name>] [privileges <privs>]
Create a new group
name Group name

privileges  Group privileges (one or more (separated by '/') of
changeTerminalBlockSettings/deviceAccessUnderCcsg/deviceSettings/mainten
ance/pcShare/portControl:1/portViewOnly:1/portVmROnly:1/portVmRW:1/sec
uritySettings/userManagement)

config:# group delete [name <name>]

Delete group

name  Group name (Admin)

config:# group modify [name <name>] [description <desc>] [addPrivileges
<addprivs>] [removePrivileges <removeprivs>]

Edit a group

name Group name (Admin)

description Group description

addPrivileges Add group privileges (one or more (separated by '/') of

changeTerminalBlockSettings/deviceAccessUnderCcsg/deviceSettings/mainten
ance/pcShare/portControl:1/portViewOnly:1/portVmROnly:1/portVmRW:1/sec
uritySettings/userManagement)

removePrivileges  Remove group privileges (one or more (separated by '/')
of
changeTerminalBlockSettings/deviceAccessUnderCcsg/deviceSettings/mainten
ance/pcShare/portControl:1/portViewOnly:1/portVmROnly:1/portVmRW:1/sec
uritySettings/userManagement)
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CLI: config keyword

keyword

config:# keyword add

keyword add [key <key>] [port <port>]
Add a keyword.

keyword delete [key <key>]

Delete a keyword

keyword modify [key <key>] [port <port>
Edit a keyword
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CLI: config network
network

config:## network dns [firstServer <server1>] [secondServer <server2>]
[searchSuffixes <searchSuffixes>] [resolverPreference <resolverPreference>]

Configure DNS settings

firstServer First DNS server
secondServer Second DNS server
searchSuffixes Search suffixes

resolverPreference  DNS resolver preference (preferV4/preferVe)

config:# network ethernet [speed <speed>] [duplexMode <duplexMode>]
Configure ethernet interface
speed Speed (1000Mbps/100Mbps/10Mbps/auto)
duplexMode  Duplex mode (half/full/auto)

config:# network ipv4 gateway

network ipv4 gateway <gateway>
Configure default IPv4 gateway
gateway  Default IPv4 gateway

config:# network ipv4 interface [enabled <enabled>] [configMethod
<configMethod>] [preferredHostName <prefHostname>] [address <addrCidr>]

Configure interface IPv4 settings

enabled Enable/disable IPv4 protocol (true/false)
configMethod IPv4 Configuration method (dhcp/static)
preferredHostName  Preferred host name

address IPv4 address/prefix-len

config:# network ipv6 gateway

network ipv6 gateway <gateway>
Configure default IPv6 gateway
gateway  Default IPv6 gateway

config:# network ipv6 interface [enabled <enabled>] [configMethod
<configMethod>] [preferredHostName <prefHostname>] [address <addrCidr>]

Configure interface IPv6 settings
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enabled Enable/disable IPv6 protocol (true/false)
configMethod IPv6 Configuration method (automatic/static)
preferredHostName  Preferred host name

address IPv6 address/prefix-len

config:# network services discovery
network services discovery [port <port>]
Configure Discovery Port
port  RDM discovery port (1..65535)

config:# network services http [enabled <enabled>] [port <port>] [enforceHttps
<enforcehttps>]

Configure HTTP access
enabled Enable/disable HTTP access (true/false)
port HTTP access TCP port (1..65535)

enforceHttps  Enable HTTPS enforcement for web access (true/false)

config:# network services https [enabled <enabled>] [port <port>]
Configure HTTPS access
enabled  Enable/disable HTTPS access (true/false)
port HTTPS access TCP port (1..65535)

config:# network services snmp [v1/v2c <v12enabled>] [v3 <v3enabled>]
[readCommunity <readcommunity>] [writeCommunity <writecommunity>]
[sysContact <syscontact>] [sysName <sysname>] [sysLocation <syslocation>]

Configure SNMP settings

vl/v2c Enable SNMP v1/v2c access (enable/disable)
v3 Enable SNMP v3 access (enable/disable)
readCommunity SNMP read community string

writeCommunity ~ SNMP write community string

sysContact MIB-II sysContact
sysName MIB-II sysName
sysLocation MIB-II sysLocation

config:# network services ssh [enabled <enabled>] [port <port>]
[authentication <authmode>]

Configure SSH access
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enabled Enable/disable SSH access (true/false)
port SSH access TCP port (1..65535)

authentication  Authentication type
(passwordOnly/publickeyOnly/passwordOrPublicKey)

CLI: config password
config:# password

Then press Enter key. System will prompt for current password, new password,
and confirm new password.

config:# apply

The password is changed if confirm password is correct.

CLI: config port
port: Configure DSAM serial port settings

port [index <index>] [name <name>] [emulation <emulation>] [encoding
<encoding>] [eqtype <eqtype>] [bps <bps>] [parity <parity>] [flowcontrol
<flowcontrol>] [stopbits <stopbits>] [multiwrite <multiwrite>] [escapemode
<escapemode>] [escapechar <escapechar>] [chardelay <chardelay>] [linedelay
<linedelay>] [sendbreak <sendbreak>] [suppress <suppress>] [alwaysactive
<alwaysactive>] [exitcommand <exitcommand>]
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CLI: config security
config:# security groupBasedAccessControl ipv4

security groupBasedAccessControl ipv4 [enabled <enable>] [defaultPolicy
<defpolicy>]

Configure group based access control settings for IPv4
enabled Enable group based access control (true/false)

defaultPolicy  Default policy (allow/deny)

config:# security groupBasedAccessControl ipv6 [enabled <enable>]
[defaultPolicy <defpolicy>]

Configure group based access control settings for IPv6
enabled Enable group based access control (true/false)

defaultPolicy  Default policy (allow/deny)

config:# security ipAccessControl ipv4

security ipAccessControl ipv4 [enabled <enable>] [defaultPolicyln <defpolicyin>]
[defaultPolicyOut <defpolicyout>]

Configure IPv4 access control settings

enabled Enable IP access control (true/false)

defaultPolicyln Default policy for inbound traffic (accept/drop/reject)
defaultPolicyOut  Default policy for outbound traffic (accept/drop/reject)

config:# security ipAccessControl ipv6 [enabled <enable>] [defaultPolicyln
<defpolicyin>] [defaultPolicyOut <defpolicyout>]

Configure IPv6 access control settings

enabled Enable IP access control (true/false)

defaultPolicyln Default policy for inbound traffic (accept/drop/reject)
defaultPolicyOut  Default policy for outbound traffic (accept/drop/reject)

config:# security loginLimits [singleLogin <singlelogin>] [passwordAging
<pwaging>] [passwordAginglinterval <pwaginginterval>] [idleTimeout
<idletimeout>]

Configure login limitations
singleLogin Prevent concurrent user login (enable/disable)
passwordAging Enable password aging (enable/disable)

passwordAginginterval  Set password aging interval (in days) (7..365)
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idleTimeout Set user idle timeout (in minutes) (1..1440 or
infinite)

config:# security restrictedServiceAgreement [enabled <enabled>]
[bannerContent]

Configure the Restricted Service Agreement banner

enabled Enable Restricted Service Agreement enforcement
(true/false)

bannerContent  The Restricted Service Agreement banner

config:## security strongPasswords [enabled <enable>] [minimumLength
<minlength>] [maximumLength <maxlength>]
[enforceAtLeastOneLowerCaseCharacter <forcelower>]
[enforceAtLeastOneUpperCaseCharacter <forceupper>]
[enforceAtLeastOneNumericCharacter <forcenumeric>]
[enforceAtLeastOneSpecialCharacter <forcespecial>] [passwordHistoryDepth
<historydepth>]

Configure strong password requirements

enabled Enable strong passwords
(true/false)

minimumLength Minimum password length
(8.32)

maximumLength Maximum password length
(16..64)

enforceAtLeastOneLowerCaseCharacter  Enforce at least one lower case
character (enable/disable)

enforceAtLeastOneUpperCaseCharacter  Enforce at least one upper case
character (enable/disable)

enforceAtLeastOneNumericCharacter Enforce at least one numeric
character (enable/disable)

enforceAtLeastOneSpecialCharacter Enforce at least one special
character (enable/disable)

passwordHistoryDepth Password history depth (1..12)

config:# security userBlocking [maximumNumberOfFailedLogins <maxfails>]
[blockTime <blocktime>]

Configure user blocking

maximumNumberOfFailedLogins ~ Set maximum number of failed logins
before blocking a user (3..10 or unlimited)

blockTime Set user block time (in minutes) (1..1440
or infinite)
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CLI: config serial

config:# serial [consoleBaudRate <consolebps>] [modemBaudRate
<modembps>] [deviceDetectionType <detecttype>]

Configure serial port settings

consoleBaudRate Serial console baud rate
(1200/2400/4800/9600/19200/38400/57600/115200)
modemBaudRate Modem baud rate

(1200/2400/4800/9600/19200/38400/57600/115200)

deviceDetectionType  Device detection mode
(automatic/forceConsole/forceAnalogModem/forceGsmModem)

CLI: config terminalblock

config:# terminalblock [inputEnable <inputEnable>] [inputRemote
<inputRemote>] [inputLocal <inputLocal>] [outputEnable <outputEnable>]
[outputAction <outputAction>] [blinkinterval <blinkinterval>]

Configure terminal block settings
inputEnable Enable/Disable input switch (enable/disable)

inputRemote Setup input remote console
(fullAccess/videoOnly/noAccess)

inputLocal Setup input local console (fullAccess/videoOnly/noAccess)
outputEnable Enable/Disable output device (enable/disable)
outputAction Setup output action (deviceOff/deviceOn/blinkDevice)

blinkinterval  Setup device blink interval(in half-seconds) (1..10)

CLI: config time

config:# time [method <method>] [zone] [autoDST <autodst>]
Configure date/time settings
method Time setup method (manual/ntp)
zone Select time zone

autoDST  Automatic daylight saving time adjustment (enable/disable)
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CLI: config user

config:# user create

user create [name <name>] [enabled <enabled>] [groups <groups>]
Create a new user
name User name
enabled  User enabled state (true/false)

groups Groups (comma separated list of group names) (Admin)

e [f user wants to create a new user "cccc" into groups "aaa" and "bbb bbb",
you must use quotes around the group names, because spaces in the
group names cannot be accepted. Example command:

= user create name cccc enabled true groups "aaa/bbb bbb"
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config:# user delete [name <name>]
Delete user

name  User name (admin)

config:# user modify [name <name>] [newName <newname>] [password]
[password] [fullName <fullname>] [telephoneNumber <telephone>]
[eMailAddress Info@Acme.com] [enabled <enabled>]
[forcePasswordChangeOnNextLogin <forcepwchange>] [snmpV3Access
<snmpv3>] [securityLevel <seclevel>]
[userPasswordAsAuthenticationPassphrase <pwasauthpass>]
[authenticationPassPhrase] [useAuthenticationPassPhraseAsPrivacyPassPhrase
<authpassasprivpass>] [privacyPassPhrase] [authenticationProtocol
<authproto>] [privacyProtocol <privproto>] [groups <groups>] [sshPublicKey]

Create or edit user

name User name
(admin)

newName New name

password Account password

fullName Full name

telephoneNumber Telephone
number

eMailAddress E-mail address

enabled User enabled

state (true/false)

forcePasswordChangeOnNextLogin Select whether the
user needs to change his password on next login (true/false)

snmpV3Access Enable/disable
SNMPv3 access (enable/disable)

securityLevel SNMPv3 security
level (noAuthNoPriv/authNoPriv/authPriv)

userPasswordAsAuthenticationPassphrase Use password as
SNMPv3 authentication passphrase (true/false)

authenticationPassPhrase Authentication pass
phrase

useAuthenticationPassPhraseAsPrivacyPassPhrase  Use authentication pass
phrase as privacy pass phrase (true/false)

privacyPassPhrase Privacy pass phrase

authenticationProtocol Authentication
protocol (MD5/SHA-1)

Raritan.

A brand of Olegrand’



Chapter 11: CLI Commands

privacyProtocol Privacy protocol
(DES/AES-128)

groups Groups (Comma
separated list of group names) (Admin)

sshPublicKey Set SSH public key

CLI: connect
connect <port index> (1.1/1.2../2.4)
See Supported CLI Commands (on page 28).
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CLI: diag
diag

diag:# netstat
netstat <mode>
Netstat
mode  Specify the netstat mode (ports/connections)
diag:# nslookup <host>
Name server query

host  Host name or IP address to query DNS information for

diag:# ping <dest> [count <num_echos>] [size <packet_size>] [timeout

<timeout>]
Ping
dest Target host name or IP address
count Specify the number of echo requests to be sent (1..100) [5]
size Specify number of bytes in one request packet (1..65468) [56]

timeout  Specify the maximum amount of time (in s) to wait for responses
(1..600)

diag:# traceroute <dest> [uselCMP]

Trace route

dest Target host name or IP address

uselCMP  Use ICMP packets instead of UDP packets
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CLI: reset

reset
# reset
reset <command> [arguments...]

> Available commands:

factorydefaults  Reset device to factory defaults

unit Reset and reboot device

# reset factorydefaults
reset factorydefaults /y ...
Reset device to factory defaults

/y ... Assume 'yes' as answer to questions

# reset unit /y ...

Reset and reboot device

/y ... Assume 'yes' as answer to questions
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CLI: show

show

# show <command> [arguments...]

> Available commands:

authentication
connectedusers
device
eventlog
groups

history
keyword
network

port

security

serial
terminalblock
time

user

198

Shows info about authentication settings
Shows connected user information
Shows Device info. Shows DSAM info if connected
Shows event log

Shows group information

Shows session command history

Shows configured serial port keywords
Shows all network information

Shows DSAM serial port parameters
Shows security settings

Shows serial port parameters

Shows terminal block settings

Shows date/time information

Shows user information
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# show authentication

Authentication type: Local

Configured LDAP servers:

# IPaddress Server type

No servers are currently configured.

Configured Radius servers:

# IP address Authentication type Ports (auth./acc.)

No servers are currently configured.
#

# show connectedusers

User Name IP Address Client Type Idle Time
admin 192.168.55.11 CLI (SSH) Oom
#

# show device
Device 'SteveKX4-101'

Product: KX4
Model: DKX4-101
Firmware Version: 4.0.0.1.45557
Hardware ID: 1

Serial Number: 11T8400006
Internal Temperature Current Value: 38.7 C/ 101.6 F
Internal Temperature Maximum Value: 39.6 C/ 103.3 F

# show eventlLog

Event Time Event Class Event Message
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2019-03-01 09:17:34 EST User Activity User 'admin' from host
'192.168.32.187"' logged out.

2019-03-01 09:17:34 EST User Activity  Session of user 'admin' from host
'192.168.32.187' timed out.

2019-03-01 09:44:54 EST User Activity User 'admin' from host
'192.168.32.206' logged in.

2019-03-01 09:55:00 EST User Activity User 'admin' from host
'192.168.32.206' logged out.

2019-03-01 09:55:00 EST User Activity  Session of user 'admin’' from host
'192.168.32.206' timed out.

2019-03-01 16:03:52 EST User Activity  Authentication failed for user
‘admin' from host '192.168.32.187".

2019-03-01 16:03:56 EST User Activity User 'admin' from host
'192.168.32.187' logged in.

2019-03-01 16:15:00 EST User Activity User 'admin' from host
'192.168.32.187' logged out.

2019-03-01 16:15:00 EST User Activity  Session of user 'admin’ from host
'192.168.32.187' timed out.

2019-03-04 06:32:19 EST User Activity User 'admin' from host
'192.168.32.184" logged in.

2019-03-04 06:33:17 EST Device Firmware upgrade started from
version '4.0.0.1.45553' to version '4.0.0.1.45557" by user 'admin' from host
'192.168.32.184".

2019-03-04 06:35:52 EST Device The ETHERNET network
interface link is now up.
2019-03-04 06:35:54 EST Device Firmware upgraded successfully

from version '4.0.0.1.45553" to version '4.0.0.1.45557" by user 'admin' from
host '192.168.32.184".

2019-03-04 06:35:54 EST Device System started.

2019-03-04 06:36:34 EST User Activity Authentication failed for user
‘admin’' from host '192.168.32.184'.

2019-03-04 06:36:39 EST User Activity User 'admin' from host
'192.168.32.184' logged in.

2019-03-04 06:45:00 EST User Activity User 'admin’ from host
'192.168.32.184' logged out.

2019-03-04 06:45:00 EST User Activity Session of user 'admin’ from host
'192.168.32.184' timed out.

2019-03-06 07:43:24 EST User Activity User 'admin’ from host
'192.168.55.11" logged in.
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'192.168.55.11' logged out.

User Activity
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User 'admin' from host

2019-03-06 07:55:10 EST User Activity Session of user 'admin' from host
'192.168.55.11' timed out.
2019-03-07 09:39:44 EST User Activity User 'admin' from host

'192.168.55.11' logged in.

2019-03-07 09:53:22 EST User Activity User 'admin' from host
'192.168.55.11' logged out.
2019-03-07 09:53:22 EST User Activity Session of user 'admin’ from host

'192.168.55.11"' timed out.

2019-03-11 13:14:34 EDT User Activity User 'admin’ from host
'192.168.55.11' logged in.

2019-03-11 13:16:39 EDT User Activity User 'admin' from host
'192.168.55.11" logged in.

2019-03-11 13:24:46 EDT User Activity User 'admin’ from host
'192.168.55.11' logged out.

2019-03-11 13:24:46 EDT User Activity Session of user 'admin' from host

'192.168.55.11' timed out.

2019-03-11 13:29:13 EDT User Activity User 'admin' from host
'192.168.55.11" logged out.
2019-03-11 13:30:32 EDT User Activity User 'admin' from host

'192.168.55.11' logged in.

# show groups

Group 'Admin':

Description: System defined administrator group including all privileges.

Privileges: adminPrivilege

# show keyword

Keyword: Example

Port: 1.1

# show network

DNS resolver

Servers: 192.168.50.115
192.168.50.116

Search suffix: raritan.com.
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Resolver preference: Prefer IPv6 addresses

Routing
IPv4
Default gateway: 192.168.50.126

Static routes: None
IPv6

Default gateway: None

Static routes: None

Interface 'ETHERNET'
Link
Configured speed:  Automatic

Configured duplex: Automatic

Link state: Autonegotiation On, 1 Gbit/s, Full Duplex, Link OK
MAC address: 00:0d:5d:00:02:d5
IPv4
Config method: DHCP
Address: 192.168.50.35/24
Preferred hostname: Not configured
DHCP server: 192.168.50.115
IPv6
Disabled

# show security

IPv4 access control: Disabled
IPv6 access control: Disabled
Group based access control for IPv4: Disabled
Group based access control for IPv6: Disabled

Password aging: Disabled
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Prevent concurrent user login: No

Strong passwords: Disabled

Restricted Service Agreement: disabled

# show serial

Configured console baud rate: 115200 bit/s
Configured modem baud rate: 115200 bit/s

Device detection type: Force console

Detected device: Console

# show terminalblock
External input switch: Disabled

Current external switch state: Open

Give remote console user: Full Access

Give local console user: Full Access

External output device: Disabled

External device state: Disabled

Output action: Turn Device Off
Device blink interval: 1 (half-seconds)

# show time

Device Time: 2019-03-11 13:50:26 EDT

Time Zone: (UTC-05:00) Eastern Time (US & Canada)

Setup Method:  NTP synchronized

# show user

User 'admin":
Enabled: Yes
Groups:  Admin

SNMP v3 Access: Disabled
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CLI: exit
exit

# exit
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Appendix A Specifications

Case Dimension:

140mm (W) x 144mm (D)x 30mm (H), 5.51” (W) x 5.67
“(D) x “1.18(H)

Weight (excluding power
adapter):

0.65kg (1.42Ib)

Operating Temperature:

0°C--55°C (32 °F--131°F)

Storage Temperature: -

20 °C -- 80 °C (-4 °F --176 °F)

Operating Humidity:

20%-80% RH

Storage Humidity:

10%-90% RH

Maximum Power Consumption:

12.5W under 4K@30 video stream and without local USB
device. DKX4-101 can support two USB devices with up to
500mA for each.

Power adapter:

ATS024T-WO050V with different plugs:

Input: Universal 100VAC-240VAC 50/60Hz

Output: 5VDC/4A

C14 Socket

Safety certification: UL / CUL / PSE / BSMI / RCM / GS

EMI: FCC/ CE Class B Conduction and Radiation Met.

Additional power adapter:

ATS24T-P050 with C14 socket input.

Input: Universal 100VAC-240VAC 50/60Hz

Output: 5VDC/4A

Plug: US, EU, AU, UK, CN, Korea

Safety certification: UL / CUL / PSE / BSMI / RCM / GS

EMI: FCC/ CE Class B Conduction and Radiation Met.

Terminal block output:

Dry contact output supports load with up to 2A/30VDC,
or 0.5A/60VDC, or 0.3A/125VAC.

Terminal block input:

Dry contact input only. Does not support any power
input.

Cables for additional interface
support:

D4CBL-DP-HDMI
D4CBL-MDP-HDMI
DACBL-DVI-HDMI
DACBL-USBC-HDMI
D4CBL-VGA-HDMI

Mounting bracket:

Includes Bracket "L" KX101 (part number
250-62-3011-00 )
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Appendix A: Specifications

= Metal Hook DSAM-4

Optional mounting hardware: = 1U bracket RACK-KIT-DKX4-101-3 for mounting three
DKX4-101 units

=  Universal HDMI Cable Lock P/N: 254-01-0055-00

In This Chapter
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TCP and UDP Ports Used

P Listening TCP Ports:

* 80: http access (configurable)

* 443: https access (configurable)

* 5000: CC-SG and KXUS access (configurable)
* 22: SSH access (if enabled, configurable)

* 68: DHCP access (if DHCP is enabled)

> Listening UDP Ports:
* 162: SNMP access (if SNMP Agent is enabled)
* 5001: CC_SG event notification (if under CC-SG management)

®  TCP Ports Outgoing:

* 389: LDAP authentication (if LDAP is enabled, configurable)

* 636: LDAPS/StartTLS (if LDAPS/StartTLS is enabled, configurable)
* 25: SMTP (email) (if enabled)

* 445: SMB (Windows File System) access (Remote I1SO image access).

»  UDP Ports Outgoing:

* 514: Syslog (if enabled, configurable)

* 5001: CC_SG event notification (if under CC-SG management, configurable)
* 1812: RADIUS authentication (if enabled, configurable)

* 1813: RADIUS authentication (if enabled, configurable)
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Absolute ¢ 84
Absolute Mouse Synchronization ¢ 50

Access a Virtual Media Drive on a Client Computer

° 62

Access a Virtual Media Image File e iii, 63

Active KVM Client (AKC) Help ¢ 70

Active System Partition e 174

Active System Partitions ¢ 173

Add a Macro to the Toolbar ¢ 80

Add New Macro ¢ 78

Adjust Full Screen Window Size to Target
Resolution e 54, 56

Adjusting Playback Buffer Size ¢ 69

Admin Group Special Privileges ¢ 114, 121

AKC Supported Browsers » 71

AKC Supported Microsoft .NET Framework ¢ 71

AKC Supported Operating Systems ¢ 71

Allow Cookies ¢ 71

Audio Menu ¢ 93

Audio Playback Recommendations and
Requirements ¢ 66

Audio Settings ¢ 95

Auto Play in Safari ® 95

Auto Scan e iii, 125, 153

B

Backup and Restore ¢ 162
Bandwidth Requirements ¢ 66
Browser Tips for HSC ¢ 39
Build a New Macro ¢ 46

C

Change Your Password ¢ 113
CLI
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check » 179
clear e 179
config ¢ 180
config authentication ¢ 181
config device ¢ 184
config group ¢ 185
config keyword ¢ 186
config network ¢ 187
config password ¢ 189
config port » 189
config security ¢ 190
config serial ® 192
config terminalblock ¢ 192
config time ¢ 192
config user ¢ 193
connect ¢ 195
diag 196
exit e« 204
reset e 166, 197
show ¢ 198
CLI Commands e 5, 179
Client Launch Settings ¢ 52, 57
Client PC VM Prerequisites 171
Collect a Diagnostic Snapshot ¢ 59

Collecting a Diagnostic Snapshot of the Target

59

Conditions when Read/Write is Not Available ¢ 63,

173

Configure DSAM Serial Ports ¢ 24, 26

Configure Serial Port Keyword List ® 26

Configuring Authentication ¢ 106, 110, 112

Connect Audio ¢ 94

Connect Drive Permissions (Linux) e 174

Connect Drive Permissions (Mac) ¢ 175

Connect DSAM e 22

Connect Files and Folders ¢ 91

Connect ISO » 92

Connect to a Digital Audio Device 68

Connect to DSAM Serial Target with URL Direct
Port Access ¢ 31

Connect to DSAM Serial Targets in the Web
Interface ¢ 30

Connect to DSAM Serial Targets via SSH ¢ 31

Connected Users ¢ 113

Connecting and Disconnecting a Digital Audio
Device ¢ 67

Connecting the Equipment ¢ 3
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Connecting the Terminal Block to a Motherboard e
148

Connection Info ¢ 45, 76

Connection Properties ® 43,45, 74

Copy and Paste and Copy All * 36

Cursor Shape ¢ 52

D

Date and Time ¢ 6, 126, 158

Delete a Macro ¢ 81

Device Information ¢ 122, 138

Device Settings and Information e 122

Diagnostics 176

Digital Audio ¢ 65

Digital Audio VKC and AKC Icons ¢ 66

Direct Port Access URL ¢ 154

Disable 'Protected Mode' ¢ 71

Disabling External Authentication ¢ 112

Disconnect from an Audio Device ¢ 68

Disconnect from Virtual Media Drives ® 65

Discovery Port e iii, 141

Dominion KX V=101 Events e iii, 136

Dominion KX IV-101 Virtual Media Prerequisites e
171

Dominion User Station Access to Dual KX4-101
Setups e iii, 104

Download Diagnostic ® 176

Drive Partitions ¢ 173, 174

DSAM LED Operation e 22

Dual Mouse Modes ¢ 50

E

Edge Chromium versions ¢ 72

Emulator ¢ 32

Enter Intelligent Mouse Mode e 50
Event Log ¢ 142, 164

Event Management ¢ 128, 130, 134, 142
Export Macros ¢ 48

External Device ¢ 69

External Device Menu ¢ 95

F

Firmware History ¢ 165
Front View e 2
Full Screen Mode ¢ 62
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G

Gathering LDAP/Radius Information e 105, 106,
108, 111

General Settings ¢ 53, 56

Group Based Access Control e 150

H

HSC Functions e 32

HTML KVM Client (HKC) » 73

HTML Serial Console (HSC) Help » 32
HTTP/HTTPS Ports e iii, 141

Import and Export Macros ¢ 78, 82, 101

Import Macros ¢ 47

Importing and Exporting Macros e 47

Include Dominion KX V=101 IP Address in 'Trusted
Sites Zone' ¢ 71

Initial Configuration ¢ 4, 166

Input Menu e 77

Install Certificate on Apple iOS Device ¢ 97

Installation and Initial Configuration e 1

Intelligent « 85

Intelligent Mouse Mode ¢ 50

Intelligent Mouse Synchronization Conditions e 51,
85, 87

IP Access Control e 151

J
Java Requirements ¢ 41

K

Keyboard ¢ 45

Keyboard Access on Mobile ¢ 101
Keyboard Layout ® 77

Keyboard Limitations ® 55
Keyboard Macros ¢ 46

Keycode List » 116, 137

KVM Client Options ¢ 6

KVM Clients » 7, 8, 40

KVM Security ¢ 9, 146, 153

L

LDAP Authentication ¢ 107, 108
Limitations on Apple iOS Devices ¢ 96, 103
Login Settings e iii, 155
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Macro Editor e 78, 101

Maintenance ¢ 162

Manage HKC iOS Client Keyboard Macros ¢ 101

Mapped Drives ¢ 173

Minimum Client and System Recommendations e
1

Mounting CD-ROM/DVD-ROM/ISO Images ¢ 64,
175

Mounting Local Drives ¢ 172

Mouse Modes ¢ 84

Mouse Options ¢ 49

Mouse Sync ¢ 86

Mouse Synchronization Tips ¢ 52

N

Network ¢ 6, 128, 138

Network Diagnostics e 177

Network Services ¢ 140

Next Steps ¢ 6

Number of Supported Virtual Media Drives ¢ 173

(o)

Option 1
Connect a PC to the LAN Port ¢ 4
Option 2
Connect an iOS device at the Local Port ¢ 5
Option 3
Serial configuration ¢ 5
Overview ¢ 71, 170

P

Package Contents e 2
Password Policy e iii, 156
Port Access ¢ 8
Port Access and Configuration ¢ 8
Port Configuration

Custom EDIDs ¢ iii, 9, 17

KVM Port Settings - General, Video, Audio e iii,

6,9

Local Port Monitor EDID e iii, 18

USB Connection Settings ¢ 19
Prerequisites for Using AKC ¢ 70, 71
Prerequisites for Using Virtual Media ¢ 171
Proxy Server Configuration e 42, 72
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Radius Authentication e 107, 111

RADIUS Using RSA SecurlD Hardware Tokens e 112

Rear View ¢ 3

Refresh Screen ¢ 88

Refreshing the Screen ¢ 49

Returning User Group Information from Active
Directory Server e 110

Returning User Group Information via RADIUS e
112

Root User Permission Requirement e 174

S

Saving Audio Settings ¢ 67

Scaling ¢ 61

Screenshot ¢ 88

Screenshot from Target Command (Target
Screenshot) ¢ 49

Security ¢ 105, 150

Send Ctrl+Alt+Del Macro e 45

Send Email » 129, 130

Send LeftAlt+Tab (Switch Between Open Windows
on a Target Server) o 45

Send Macro ¢ 77

Send Text File « 36, 37

Send Text to Target ¢ 45, 83

Serial Access With Dominion Serial Access Module
e iii, 21

Serial Port ¢ 145

Service Agreement ¢ 161

Single ¢ 86

Single Mouse Mode ¢ 53

SMTP Server Settings ¢ 130, 142

SNMP Notifications e 129, 130

SNMP Settings ¢ 143, 168

Specifications ¢ 205

SSH Settings ¢ 118, 144

Standard ¢ 85

Standard Mouse Mode ¢ 51

Supported Audio Device Formats e 65

Supported Browsers ¢ 1

Supported CLI Commands e 28, 31, 195

Supported Escape Key Characters ¢ 30

Supported Preferred Video Resolutions e iii, 9, 11

Supported Tasks Via Virtual Media ¢ 172

Supported Virtual Media Types ¢ 172

Synchronize Your Mouse © 52
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Syslog Messages ¢ 129, 134
T

Target Server VM Prerequisites e 171
TCP and UDP Ports Used » 206
Terminal Block Control e iii, 146, 154
Tips for Accessing Dominion KX IV=101 With Dual
Monitor Setups e iii, 104
TLS Certificate e iii, 6, 7, 158
Tool Options ¢ 53, 62
Tools
Start and Stop Logging ¢ 38
Tools Menu ¢ 89, 100, 101
Touch Mouse Functions ¢ 100, 103

U

Unit Reset ¢ 165

Update DSAM Firmware ¢ 28

Update Firmware * 166

Update Firmware Using SCP e iii, 169

User Management ¢ 6, 105

Users and Groups e iii, 107, 114, 137, 138, 145,
146

Using HKC on Apple iOS Devices e iii, 96

Vv

Version Information - Virtual KVM Client ¢ 70

Video ¢ 49

Video Menu ¢ 88

View DSAM Serial Ports ¢ 23

View Menu e 89

View Options ¢ 61

View Status Bar ¢ 61

View Toolbar ¢ 61

Virtual KVM Client (VKCS) Help ¢ 40

Virtual Media ¢ 62, 170

Virtual Media File Server Setup (File Server I1SO
Images Only) e 175

Virtual Media in a Linux Environment ¢ 173

Virtual Media in a Mac Environment ¢ 174

Virtual Media Menu ¢ 91

Virtual Media Performance Recommendations e
171

Virtual Media Shared Images ¢ 149

W

What's New in KX IV-101 Release 4.1.2 e iii
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